User Tools

Site Tools


Render Album

image_medium.jpg

Product: Render Album
Product Code: ds_ap026
DAZ Original: Yes
Released: October 22, 2007

Product Information

  • Required Products: DAZ Studio 1.8.0.10
  • For the Users Documentation for this plugin, see User Guide below.

Product Notes

  • Render Album images are saved in Memory. The size and quantity of images you can use in the Render Album is determined by the amount of RAM your system has. If your system has limited amounts of memory, it is recomended you use lower settings.
  • When the maximum number or renders is reached the oldest image in the Render Album will be dropped.
  • Some icons on buttons and in the interface may not display correctly in all styles. This will be fixed in a later version of DAZ Studio.
  • Changing the icon size can cause the bottom of the render Album dialog to move below the screen, closing and reopening the Render Album will correct this. Remember to save your edited image before you close the render album as it will be lost otherwise.
  • Use the “Reset Current Tab” button to clear Filters applied to an image.

Support

Visit our site for further technical support questions or concerns: http://www.daz3d.com/i.x/support

Thank you and enjoy your new products!

DAZ Productions Technical Support
12637 South 265 West #300
Draper, UT 84020
Phone:(801) 495-1777
FAX:(801) 495-1787
TOLL-FREE 1-800-267-5170

User Guide

What is the DAZ Studio Render Album?

DAZ Studio Render Album provides a means of storing recent image renders in an album format which can then be loaded into the Render Editor to perform various editing functions on the image. The editor provides options for blending two images, color adjustment, image comparison, and applying filters without having to open a separate paint program.

Installation

Macintosh®

1. Make sure DAZ Studio is closed before installing the plug-in.
2. Double-click on the DAZ Studio Render Album installer icon to start the installation.
3. When the splash screen appears, click Continue.
4. Read the Software License Agreement and click on the Accept button to accept the terms of the agreement and continue.
5. If a previous version of the plug-in is already installed, you will be prompted to remove the current version to prevent possible conflicts. Select Uninstall and click on the Uninstall button.
6. Select Easy Install and click on the Install button.
7. Once the plug-in has been installed, the readme will be displayed for viewing.

Windows®

1. Make sure DAZ Studio is closed before installing the plug-in.
2. Double-click on the DAZ Studio Render Album installer icon to start the installation.
3. If a previous version of the plug-in is already installed, you will be prompted to remove the current version to prevent possible conflicts. Click on OK to continue.
4. When the splash screen appears, click Next.
5. Read the Welcome screen and click on Next.
6. Read the Software License Agreement and click on the Yes button to accept the terms of the agreement and continue.
7. Read the Ready to Install text and click on Next.
8. Once the plug-in has been installed, click on Next to close the installer and view the readme.

The Render Album Tab

The Render Album tab is accessible through the View > Tabs menu and once it is active, can be docked to one of the tab panels.

  • Number of Renders - At the top of the tab, under the tab itself, is a status field showing how many renders are currently stored in the album and how many total renders can be stored, i.e., Renders: 0 of 10; Renders: 5 of 30. Once the maximum number of renders has been reached, the first images will be removed in order to make room for new renders.
  • Capture Renders - Enables or disables capturing of renders into the album. The size in parentheses indicates the maximum render size set in the preferences (see below).
  • Close - Available from the small arrow at the top right or by clicking on the X

button when the album is not docked.

  • Preferences - The album itself is blank by default, but right-clicking in the blank album brings up the Preferences menu where the thumbnail size, number of renders, and maximum render size can be set.
    • Icon Size - sets the size of the icon thumbnail.
    • Number of Renders - sets the maximum number of renders that can be placed in the album.
    • Maximum Render Size - sets the maximum size allowed for renders maintained in the album. Studio uses an OS-independent graphics system which maintains images in full 32-bit format. The larger an image is, the more memory it will consume.
  • Once a render has been added to the album, additional options become available by right-clicking on the thumbnail:
    • Save As - saves the selected render to the computer.
    • Copy to Clipboard - copies the selected render to the clipboard where it can then be pasted into another program.
    • Remove Image - removes the selected render from the album and from memory.
  • Double-clicking on a thumbnail opens the Render Editor and sets the selected image as the primary image source.

Using the Render Album

The Render Album provides a way to hold renders ready for saving or modifying in the Render Editor without having to save each render before moving on to the next render. The Album has basic copy and remove features along with preferences for setting the icon size, number of renders to hold, and render size.

1. Click on the Render tab in Studio then select View > Tabs > Render Album from the menu to activate the Render Album.
2. Dock the Render Album tab to one of the tab panels.
3. Make sure that the checkbox next to Capture Renders is checked so the render will be captured by the album. Unchecking this option will prevent the album from capturing renders, such as when you are checking composition and are not ready to have the renders captured.
4. Load or create a new scene and render the scene. As soon as the render is complete, the thumbnail for the render will show up in the Render Album. The status text will also update to show that there is now one image in the album.
5. Right-click on the thumbnail or in the blank area of the album and choose Preferences > Icon Size from the menu.
6. The default thumbnail size of 91 will be in the field. Change the size to a larger or smaller size as needed by entering a number in the field or dragging the slider.
Thumbnail size can be set from 50 to 400 pixels. Click on Accept. The thumbnail will be resized to match the size you entered.
7. Right-click on the thumbnail or in the blank area of the album and choose Preferences > Number of Renders from the menu. This option sets how many renders can be held in the album. For example, if the maximum renders is set to 20 and you render 21 images, the first image will be removed so the last image can be added.
8. Change the current number to any number from 1 to 30 and click on Accept. The number of total renders allowed will be updated to reflect the new number.
9. Right-click on the thumbnail or in the blank area of the album and choose Preferences > Maximum Render Size from the menu. This option sets the maximum render size of the images with the default being set to 2048.
10. Change the number to any number between 0 and 10000 and click on Accept. The render size on the status bar will be updated to reflect the new size. Note: When setting maximum image size, remember that the images are stored in memory, so if your images are all very large, you may run out of memory before the album can be filled.
11. Make a change to the scene such as adjusting light intensity or color and rerender. The second thumbnail will be added to the album.
12. Save image to disk - Right-click on the third thumbnail and choose Save As from the menu. The standard save dialog will come up allowing you to save the image to your desktop in the following formats: JPEG, PNG, DSI (Studio layered image file for use in the Multi-Layered Image Editor), TIFF and PNG.
13. Copy image to Clipboard - Right-click on the thumbnail again and choose Copy to Clipboard from the menu. Open a paint program and paste the image in the program.
14. Remove image - Right-click on the thumbnail again and choose Remove Image. The image will be removed from the album and from the computer's memory.
15. Select which render you want to be your main image and double-click on it to open the Render Editor.

The Render Editor Panel

The Render Editor panel is accessible by either double-clicking on a thumbnail in the Render Album, selecting it from the Render menu, or by adding it to tool bar through the Customize menu.

  • Image Source - allows choosing of the primary and secondary image sources, blending options, and image alignment.
  • Adjustment - provides access to various adjustment options such as color, brightness, filters, levels, and image orientation.
  • Results tab - provides view of image along with any adjustments and image blending, allows user to save the image or load new images from the clipboard or the computer, and provides zooming options.
  • Compare tab - provides options for comparing the primary and secondary images.
  • Render Album Icon View - provides quick access to the images available in the Render Album.
  • Help - provides access to tool tips and descriptions of the different options and fields. Either click on the Question Mark icon then left-click on any field, or rightclick on any field and choose What's This from the menu.
  • Close - closes the Render Editor. Any changes made will be lost unless the image has been saved to disk.

Using the Render Editor

The Render Editor provides basic image editing capabilities on images that have been saved to the Render Album. While not complicated to use, it has several options for adjusting, blending, and comparing images.

Accessing the Render Editor

There are three ways to access the Render Editor:

1. Double-click on any thumbnail in the Render Album tab. This will open up the editor and set the selected image as the primary image.
2. Choose Render > Render Editor from the menu.
3. Add the Render Editor action to the toolbar and click on the icon to open the editor.

Adding the Render Editor to the Toolbar

To add the Render Editor icon to the toolbar, do the following:

1. Choose Edit > Customize from the menu. The Customize DAZ Studio dialog will come up.
2. In the left-hand panel, locate the Miscellaneous item and click on the plus sign (+) to expand the listing.
3. Scroll down until you find the listing for the Render Editor.
4. In the right-hand panel, click on the plus sign next to Render, then on the plus sign next to Actions.
5. Scroll down until you find the listing for Spot Render and Render.
6. Left-click on the Render Editor listing in the left-hand panel and drag it on top of the Render listing in the right-hand panel. This will place the Render Editor listing under the Render listing.
7. Click on Accept and click on the Render tab. The Render Editor icon should be in the toolbar next to the Render icon.

Image Source

At the top left of the Render Editor is the Image Source area which allows you to select the images you wish to work with. Two images can be active at a time, the Primary image, which is the main image you will be working with, and the Secondary image, which can be blended with the Primary image.

Image adjustments, such as color or orientation will be applied to the current active image, indicated by selecting the radio button for the primary or secondary image. Each source image maintains its own adjustment settings so, for example, you can adjust the color settings differently for each image. When you change which image is currently active, the interface elements will change to reflect the current values/settings for that image.

Selecting Image Sources

There are five ways to select an image source, plus a swap option:

1. Double-clicking on a thumbnail in the Render Album will automatically open the Render Editor and set the selected image as the Primary image source.
2. Activating an image source then double-clicking on a thumbnail will set the image as the image source for the current active image.

  • Click on the radio button next to either Primary or Secondary.
  • Double-click on the thumbnail in the Render Album that you want as the selected image source.

3. Selecting the image from the menus below each image source thumbnail.
4. Left-clicking on a thumbnail in the Render Album listing and dragging it onto the thumbnail for the image source.
5. Right-clicking on a thumbnail in the Render Album Listing and selecting to either set as primary or secondary image from the menu.
6. Once an image is loaded into both image source thumbnails, clicking on the Swap button will swap the primary and secondary images.

Image Blending Options

The options for blending the primary and secondary images are located between the image source thumbnails. Selecting the type of blend from the drop menu displays options and sliders depending on the selected blend type.

1. Select a primary and secondary image source.
2. Left-click on the Blend Options Type field and select a blend type from the menu.

  • None - no blending takes place
  • Horizontal - when selected, the secondary image is blended horizontally over the primary image
    • Strength - determines the overall strength of the blending
    • Start & End - determines the blend area - before Start, the primary image is used and after end, the secondary image is used with the area between the two settings a blend between the two images
    • Examples:
      • Start & End set to 50% - the primary image is used from 0 to 50% of the result with the secondary image used from 50 to 100% with no blending between the two areas
      • Start set to 40%, End set to 60% - the primary image is used from 0 to 40% of the result with the secondary image used from 60 to 100% with blending between the two areas
    • Vertical - when selected, the secondary image is blended vertically over the primary image
      • Strength - determines the overall strength of the blending
      • Start & End - determines the blend area - before Start, the primary image is used and after end, the secondary image is used with the area between the two settings a blend between the two images. This works the same as the horizontal blend type.
    • Multiply - when selected, multiplies the colors of the Secondary image with that of the Primary image. Adjust the Strength slider to vary the amount of blending.
    • Add - when selected, adds the colors of the Secondary image to that of the Primary image. Adjust the Strength slider to vary the amount of blending.
    • Subtract - when selected, subtracts the colors of the Secondary image from that of the Primary image. Adjust the Strength slider to vary the amount of blending.
    • Alpha - when selected, uses the alpha channel in the Secondary image to blend it over the Primary image. Adjust the Strength slider to vary the amount of blending.
    • Overlay - when selected, places the Secondary image over the Primary image without using the alpha channel of the secondary image. Adjust the Strength slider to vary the amount of blending.

Blending Alignment Options

Alignment is only relevant if the Primary and Secondary images are of different sizes. For example, you could add a logo as a secondary image and then align it at the bottom right corner.

  • Align Vertical - when selected, aligns the secondary image along the vertical axis or stretches the image to fit vertically in the image.
  • Align Horizontal - when selected, aligns the secondary image along the horizontal axis or stretches the image to fit horizontally in the image.
  • Used together, the two options align the image both horizontally and vertically. For example, the image below shows the DAZ logo centered vertically and aligned right horizontally.

Adjustment Options

Under the image source section are several tabs for making adjustments to the images. You can use just one option, or combine two or more to produce the final result.

1. Click in the radio button next to Primary or Secondary to select which image to adjust. If adjusting the secondary image, set the blend option to Alpha or Overlay so the image will be brought to the front.
2. Click on the adjustment tab for the option you want to use and modify the settings for each option. See listing of adjustment options available below.
3. To reset the current tab, click on Reset Current Tab and all changes made on that tab for the current image will be reset to the default settings.
4. To reset all tabs, click on Reset All Tabs and all changes made on all tabs for the current image will be reset to the default settings.
5. To switch between images, click in the radio button next to the image not currently selected. All adjustment options will change to reflect the current settings for the selected image.

Types of adjustments available:

  • Color - provides options to adjust color by either RGB or HSV value. Click in the radio button next to the option you wish to use.
  • Brightness - provides options to adjust the contrast, brightness, and gamma of the current image.
  • Filters - provides filters for adjusting the current image. The options shown below are available for the Blur, Soften, Sharpen, Edge Detect, and Emboss filters. The Convert to Gray filter provides options for selecting what to convert to gray in the current image. The Invert Colors filter has no options and applies immediately.
  • Levels - provides options for adjusting the various levels shown by the histogram. Click on the Type menu to select the different types of levels that can be adjusted.
  • Orientation - provides options for changing the orientation of the current image by flipping and/or rotating the image.

Results View

The Results tab allows you to view the changes being made to your images, and provides options for zooming, adding new images, and saving images.

  • Viewing Pane - this is where the results of the image adjustments is shown, if the image is too large to fit in the pane, scroll bars show up along the right side and bottom edge.
  • Result Image Size - shows the size of the image in the viewing pane.
  • Save current image to disk (Cmd/Ctrl+S) - saves the currently selected image to your computer.
  • Open an image - allows selection of an image from the computer and places it in the Render Album. The number of renders will update to reflect the addition of the image to the album.
  • Copy the current image into the Album - places the current image into the Render Album, usually needed after pasting an image from the clipboard. The number of renders will update to reflect the addition of the image to the album.
  • Copy the image to the clipboard (Cmd/Ctrl+C) - copies the current image to the clipboard so it can be pasted into another program.
  • Paste the clipboard image (Cmd/Ctrl+V) - pastes the current image on the clipboard into the viewing pane.
  • Zoom Level status - shows the current zoom level and pixel dimensions.
  • Zooming - the zoom tools step in 25% increments except as noted below:
    • Zoom Out - has a minimum zoom level of 10% or the smallest size that will fit within the viewing pane, whichever is larger; when at the minimum size, a single click on the Zoom In button should change the zoom level to the next increment of 25%.
    • Zoom In - has a maximum zoom level of 600%, except for images larger than 3000×3000 although exact size may vary by RAM and/or OS.
    • Zoom to Fit - zooms the image in or out to fit in the viewing pane.

Comparison View

The Compare tab allows you to compare two renders in various ways. It also allows access to the zoom controls but the zoom levels are set separately from those on the Results tab.

  • Drop Menus - select which images are to be compared by selecting them from the left and right drop menus, select one image for the right side and one for the left side.
  • Comparison Type - select what type of comparison to make by selecting from the center drop menu.
  • Horizontal Wipe - overlays the images so that the left side shows the first image and the right side shows the second image (as shown in the image above). Adjust the slider to move the split position as needed.
  • Vertical Wipe - overlays the images so that the top half shows the first image and the bottom half shows the second image. Adjust the slider to move the split position as needed.
  • Toggle - toggles between viewing the image on the left and the image on the right. Click on the button below the drop menu to toggle between the images.
  • Opacity - adjusts the opacity of the second image so the first image can be viewed through it.

Render Album Listing

The Render Album Listing at the bottom of the editor provides quick access to the images in the Render Album. It provides the same options as the Render Album with the addition of options to set a selected image as the primary or secondary image.

Notes

  • There is no list of installed files for this product.
  • The User Guide comes in PDF format and includes screenshots illustrating each point.