Chapter 9: Vertex Modeling

The Vertex modeler lets you sculpt 3D objects by directly manipulating their surfaces but also create morph targets for performing advanced animation, fine tune bones weights or set UV coordinates for texture mapping.

You can start with a predefined object, such as a sphere or cube, or you can use the Vertex modeling tools to generate complex shapes. Once you've created an object, you can reshape and refine it by editing the points that define its surface, edit morph targets, UVs and weights.

Enhancements in Carrara 6 allow you to edit imported content, and create new morph targets and full body morphs for DAZ or Poser content. You'll also notice improved performance with larger meshes when you move, scale, or rotate points.

Vertex Modeling Concepts

A vertex object is any object created in the Vertex modeler, or created with another modeler and opened in the Vertex modeler.

The power of vertex modeling lies in the ability to change an object by directly positioning its vertices and edges.

Vertices, Edges, Polylines, and Polygons

Three-dimensional objects can be described as sets of vertices, edges, and polygons:

- A vertex defines a position in 3D space.
- An edge is the line that connects two vertices. For example, eight vertices and twelve edges describe a cube. Each face of the cube is a polygon.

A vertex object’s surface is defined by its vertices.

- A polyline is a set of connected edges.
- A polyline that forms a closed loop is a closed polyline. A closed polyline is not equivalent to a polygon—but if you fill a closed polyline, it becomes a polygon.
- A collection of vertices, edges, and the polygons that they form is called a polymesh. A polymesh can form a closed volume, such as a cube, or an open object such as an oval.

In the Vertex modeler, all vertices are connected by straight lines. Vertex modeling is the process of creating 3D objects by directly manipulating vertices, edges, and polygons. Instead of modeling all objects as extrusions, you can “sculpt” objects by changing the number and location of their vertices,
edges, and polygons.

Although it is possible to sculpt a complex shape in the vertex modeler from scratch by adding and editing polygons and vertices, the vertex modeler provides you with a very rich set of advanced modeling tools such as extrusion, sweep, loft, lathe, chamfer, boolean operations, thickness, offset surface, Coons surface (Pro version only), Gordon surface (Pro version only) or double sweep (Pro version only).

When an object is modeled using a small number of polygons, its silhouette is often very rough and it is difficult to create smooth surfaces. Subdivision surface helps to create smooth objects without adding too many polygons. You will see in real time your the mesh as you edit a few control points.

The Vertex Modeling Window

The Vertex modeler is where you create vertex objects.

The Vertex Modeling window.

When you edit a vertex object, new menu commands are available, different tool sets appear, and the Properties tray describes your object. Your view switches to a close-up view of the object. The preview Scene window opens at the lower right of the Modeling window. This shows how your object will look in the Assemble room.

Like the Assemble window, the Vertex modeling window provides up to four different views of your object. For information on using the view controls, refer to Changing Views.

The Vertex Modeler's 3D View

The Vertex modeler's 3D view shows a working box that contains the features for creating shapes and paths. Three colored lines indicate the intersections of the planes of the working box.

The Vertex modeler's working box.

By default, the working box is centered on the origin of the coordinate system. The bottom of the working box sits on the ground plane of the universe, so the working box's vertical center is slightly elevated from the universe's ground plane. Each side of the box measures 20 inches, with a grid line every inch. For information on changing these dimensions, refer to Setting Preferences for the Vertex Modeler.

You can move and rotate the working box and its planes independently of the object you are modeling. Any adjustments you make to the orientation and location of the working box take place in relation to the universe. Thus, if you move the entire working box 10 inches up along the Z axis, you are effectively moving it up by 10 inches in your scene. The object itself, however, remains in place both in the 3D view and in the scene.
The Drawing Plane

The Drawing plane is the plane you're currently working on, whether you are drawing a shape, adjusting a sweep path, or viewing your object. By default, the Drawing plane lies on the X and Y axes of the working box. It is highlighted as a brighter border.

For information on changing and moving the Drawing plane, refer to Changing Your Point of View.

The default Drawing plane lies on the Working box's X and Y axes.

Setting Preferences for the Vertex Modeler

In the Vertex Modeler Preferences dialog, you can set preferences for the default welding tolerance.

To set preferences for the Vertex Modeling window:

1. Choose *File menu* > *Preferences*.
2. Click the menu and choose Vertex Modeler.
3. Set the options you want

   - **Edge Propagation Angle**: Use this option to specify the angle determining whether a second edge will be selected when you double-click on the first one edge.
   - **Rotation Constrain Angle**: Sets the angle increment used during a constrained rotation (to constrain a rotation, hold down the Shift key while dragging).
   - **Maximum Saved Selections**: Sets the limit of the number of selections than can be saved using the menu *Selection* > *Add To Saved Selections*. When the number of saved selections bypasses this limit, the oldest one is lost
   - **Handle Size**: sets the size of the vertices in the 3D view.

1. Click OK.

To set the Grid Settings preferences:

1. Choose *View* > *Grid*...
2. Set the option you want.

   - **Working Box Size**: Specifies the dimension of the working box.
   - **Spacing**: Sets the increment value used when Snap To Grid is turned on.
   - **Draw Line Every**: Sets the distance between 2 consecutively drawn lines.
   - **Snap To Grid**: Check this option if you want the dragged object to snap to the grid. The Snap To Grid option also influences the way object are inserted in the scene, scaled, and extruded. Another and faster way to turn on or off this option is available in View > Snap To Grid.

1. Click OK.

Opening the Vertex Modeling Window

You open the Vertex Modeling window by doing one of the following:
Double-click the object in the Hierarchy or the scene window.
Select a vertex object, then click the Model button.

The Model button.

When you're finished modeling, you can save your changes and enter a different room by clicking the appropriate room's button.

Note: To avoid the memory-consuming accumulation of windows, always close the modeling window when you are finished modeling.

To create a new vertex object:

1. Open or create a document in the Assemble room. (For more information, refer to Creating an Empty Scene.)
2. Depending on the desired location of the vertex object, do one of the following:
   - To insert a vertex object of default size at the center of the universe, choose Insert menu> Vertex Object or drag the Vertex Object tool into the Hierarchy section of the Sequencer.
   - To insert a vertex object in any other location, drag the Vertex Object tool into the scene window to any location.

The Vertex Object tool.

To convert a spline or metaball object:

1. Select the object in its native modeler and choose Edit menu> Convert to Another Modeler. The Convert to Another Modeler dialog appears.
2. Choose the Vertex Modeler from the Available Modelers list.
3. Specify the fidelity for the conversion using the Fidelity slider.

The default, 100%, divides the object's surface into the recommended number of polygons. A higher percentage generates more polygons, providing more points of control.

Regardless of the fidelity of the conversion, some data may be lost and the model altered.

1. Click OK.

Note: If you edit a spline or metaball object in the Vertex modeler, its conversion is permanent; you cannot reopen it in the native modeler.

Working with the Modeling Window

Like the Assemble room, the Vertex modeler can simultaneously display up to four separate panes. Each pane gives you a different view of your object.

For information on changing the display of panes, refer to Changing Views.
You can work in any view you want. For instance, you may find it convenient to work in a 2D view when drawing a sweep or extrusion path, then switch to the 3D view when you want to work in 3D. To work in a different view, simply click in the pane.

**Note** You cannot view objects through user-created cameras in the modeling room.

To make your work flow easier, you can change different features of the Vertex modeler:

- Change the display and behavior of the grid. For more information, refer to Setting Preferences for the Vertex Modeler.
- Change the active plane.
- Change the Drawing plane.
- Move the working box.
- Show and hide the working box's bounding planes.

### Showing and Hiding Planes

By default, the planes that define the boundaries of the working box are visible. You can show them using the Grid Controls.

**The Grid Controls**

For information on using the Grid Controls, refer to Displaying Grid Planes.

### Changing the Active Plane

The active plane is the reference plane that Carrara 6 uses when creating points or objects in all tools.

There are three different ways to change the active plane depending on your preferred modeling technique:

- **User defined plane**: the active plane can be changed by clicking the plane icon in the Active Plane Tool.

Click one of the planes in the Active Plane tool to change the active plane in the modeler.

- Automatic plane mode: the active plane is automatically defined depending on the view orientation. The plane which appears to be the most perpendicular to the view direction is selected automatically.
- All planes mode: the active plane is the closest plane the cursor is in.

### Changing the Drawing Plane

To make your work easier, you can change the Drawing plane to different axes and move it to a selection or a specific set of coordinates. You can also drag it to any position you like.
The easiest and quickest way to move the drawing plane and the working box to a specific position is to Command/Ctrl+click the vertex, edge or polygon where to move it.

To move the Drawing plane to a selection:

1. Select the vertex, polygon, or group of vertices with which you want to align the Drawing plane.
2. Be sure the Selection tool is chosen.
3. **Command/Ctrl+click** your mouse.

If the selection is a single vertex, Carrara centers the Drawing plane on that vertex without changing the plane's orientation.

If the selection is a group of vertices or a polygon, Carrara moves the Drawing plane to the plane shared by those vertices. If the vertices lie in different planes, the Drawing plane is moved so that all the selected points are as near the Drawing plane as possible.

To reset the working box position to its original position, **Command/Ctrl+click** an empty area of the 3D View or choose **View> Reset Working Box**.

To send the Drawing plane to specific coordinates:

1. Choose **View menu> Send Drawing Plane to**. The Send Plane dialog appears
2. Specify the universe's X, Y, and Z coordinates to which you want to move the Drawing plane.
3. Enable a plane option:
   - **Drawing plane** Moves the Drawing plane on the axis perpendicular to itself by the amount you specify. For instance, you could move a Drawing plane lying on the X and Y axes by the specified amount on the Z axis only.
   - **Drawing plane centered** Moves the Drawing plane on the axis perpendicular to itself by the amount you specify, centering it on the remaining coordinates. For instance, you could move a Drawing plane lying on the X and Y axes by a specified amount on the Z axis, centering it on the X and Y axes.
   - **All planes** Moves the origin of the working box to the specified coordinates, centering all planes. Note that this option moves the working box itself.
4. Click OK.

**Moving the Working Box and its Planes**

You'll find it particularly useful to move the working box when you want to model or view a specific part of a vertex object. You can also drag the planes of the working box separately. If you drag a plane far enough, you will drag the working box along with it, re-centering the working box in the universe.

To move the working box to specific coordinates:

1. Choose **View menu> Send Working Box to**. The Send Working Box dialog appears.
2. Enter the coordinates where you want to position the center of the working box.
3. Click OK.

To move the working box manually:
• **Command+Option/Ctrl+Alt click** the working box and drag it to wherever you like.
• Hold the Command/Ctrl key to move the working box perpendicular to the Drawing plane.
• Release the Command/Ctrl key to move the working box in the Drawing plane.
• Hold the Shift key to drag the working box in the Drawing plane by its interior planes.

To drag a plane:

• **Command/Ctrl+Shift+Alt click** the plane and drag it to wherever you like.

You can drag in any pane or view you like, whether 2D or 3D.

**Changing Your Point of View**

Without changing your point of view to examine an object from all sides, it can be difficult to determine its position relative to other objects in the model. When you perform a Boolean operation such as subtraction, this is particularly important— you must be sure that the objects are actually overlapping for it to work.

You can dolly, zoom, bank, and track the Director's Camera using the camera controls, and you can pan and zoom the view in 2D using the pan and zoom controls.

Use the camera controls to dolly, pan, bank and track the view through the Director's Camera.

For information on using these controls, refer to Camera Navigation.

Use the pan and zoom controls to perform 2D panning and zooming.

For information on using these controls, refer to 2D View Tools.

You can also use the camera list in the upper left corner of the Vertex modeling window to switch among the Director's Camera (3D view) and isometric views of the working box's sides.

Use the camera list to switch between the Director's Camera and isometric views of the working box sides.

For information on using these controls, refer to Camera Navigation.

After you have changed your view, the working box may appear off-center in its pane. By sending your view to the working box, you can restore the view to the origin of the coordinate system.

**Previewing Objects**

You can preview objects in the Vertex Modeling window at different levels of quality.

For more information on the Preview modes, refer to Previewing Objects.
In a scene, the vertex model can have several instances with each instance having a different shader. When the preview quality is set to Textured in the Vertex Modeler, you can choose the instance to be used for the shader.

The list of instances of the object is displayed in the Global tab of the Properties tray in the Shader For Object panel.

The shader list

This shader is also used when a Test Render is done in the vertex modeler.

**Vertex Modeling Tools and Techniques**

This section describes how to use the Vertex modeling tools.

**Inserting Vertex Primitives**

The Vertex Primitive tools let you create 9 basic 2D or polymesh shapes: Sphere, Cube, Grid, Rectangle, Cylinder, Cone, Oval, Polyhedron and Polygon.

Vertex Primitive basic objects are inserted the same way primitives are inserted in the assemble room. For more information about how to insert an object, Primitive tools

When inserted from the menu **Construct> Insert>**, each primitive has its own properties dialog. The dialog lets you define the primitives attributes before it is inserted in the modeler.

When inserted from the tool bar, the dimensions of the object are set during the insertion by dragging, other attributes are then set with the + or - keys and validated by clicking **Enter** or **Return**.

To insert a Primitive from the tool bar:

1. Choose a vertex primitive from the pop up.

The vertex primitives

1. In the Modeling window, drag one corner of the bounding box to the opposite corner. Release the mouse button when the object is the desired size.
2. Use + or - to set the mesh density of the primitive.
3. Press **Enter** to validate the inserted primitive.

To insert a Primitive from the Construct Menu:

1. Choose a vertex primitive from the list in **Construct> Insert>**.
2. A dialog appears which allows you to further define the primitive.
Drawing Polylines and Curves

A polyline is a set of vertices and edges that are joined but do not branch. An open polyline includes one or more edges that do not meet, while a closed polyline begins and ends at the same vertex. Examples are the outline of a square or a triangle. Use the Polyline Tool to create polylines.

A Curve is a smooth representation of a polyline. It is created like a polyline but each point acts like a magnet for the curve. There are two type of curves: Interpolated Curves that pass through control points and Curves that does not pass through control points. The Interpolate Curve tool and Curve tool can be used to create curves.

You can draw open and closed polylines, which can be used as cross-sections, paths, and lathe profiles.

To draw a polyline, a curve or an interpolated curve:

1. Click the Polyline, curve or interpolated curve tool.

1. Click in the modeling window to create each vertex in the curve. Vertices are added to the current drawing plane except if you click on an existing point not lying in this plane. In this case, the subsequent points are created in a plane parallel to the active plane and passing through the existing point. This is very convenient for starting curves attached to existing points of curves or polygons.

   - Edges are automatically drawn to connect the vertices.
   - By default, when a vertex is added on an already existing vertex, the two vertices are merged in one. If you don't want the vertices to be merged, uncheck the **Weld with Snapped Point** option in the tool option panel in the Properties tray.

1. Close the curve by clicking on the first point or by selecting the close option in the Properties tray.
2. Enter to end the tool.

Drawing Circles

Three methods are available to create a circle:

1. Click the circle tool
2. Select the From Center Build Mode
3. Click to define the center point
4. Set the radius by moving the mouse
5. Click to fix the radius
6. Set the number of points on the circle (+/- keys)
Circle from diameter:

1. Click the circle tool
2. Select the From Diameter Build Mode
3. Click to define the first point
4. Click to define the second point
5. Set the number of points on the circle (+/- keys)

Circle from three points:

1. Click the circle tool
2. Select the From Three Points Build Mode
3. Click to define the first point
4. Click to define the second point
5. Click to define the third point
6. Set the number of points on the circle (+/- keys)

Creating a Curve by Extracting a Selection of Edges

The Extract Curve tool located in the Model menu allows you to create a curve by transforming a selection of edge into a curve.

Closing a Curve

The Close Curve tool located in the Model menu can be used to close an open curve in a single click.

Drawing Polygons

A polygon can be created using the polygon tool. The polygon tool works like the polyline tool but creates a polygon instead of a polyline.

The polygon tool can also be used to add a new polygon to an existing polymesh if the point selected for the new polygon belongs to the polymesh and if it is not connected to more than three polygons.

A polygon can also be created by filling a closed polyline.

To draw a polygon:

1. Click the Polygon tool.

The polygon tool.

1. Click in the modeling window to add each vertex in the polygon.
2. Hit return to end the tool.
Using an image as a model

It is often useful to place an image in the backdrop to reference to when drawing a polyline. Any image stored as an external file can be placed in the backdrop of the vertex modeler.

An image in the Vertex Modeler backdrop.

This image is just a tool to help you in the construction of a vertex object and will not be visible in the rendering.

To place an image in the backdrop:

1. Select the Global tab in the Properties tray.
2. In the Backdrop panel, click the choose an image file button and select a file in the file browser.

The Backdrop Panel

1. Check the Enable option to display it in the interactive view.

The image is not displayed in the Director's Camera view, but is visible in all other views.

Note that the image uses the working box dimensions to set the size on the screen. You can therefore zoom in and out or pan using the Zoom and Pan tool.

Making Selections

By default, selected vertices, edges and polygons are highlighted in red.

There are 4 different modes of selection in the Vertex Modeler. Clicking on their icons at the top of the properties tray switch the selection mode from one to another.

In the default mode, called the Regular Selector, vertices, edges and polygons can be selected. Furthermore, this mode automatically `complete' the selection when possible: if 2 vertices linked by an edge are selected, the edge will be selected too, and if all the edge around a polygon are selected, the polygon will be selected too.

The 3 other modes, called Vertex Edge and Polygon Selector, force the selection on this objects.

To select a vertex or edge:

1. Click the Selection tool.
2. Click the vertex point or the line between points.

An object with selected vertices.
To select a polygon:

1. Click the Selection tool.
2. Click the middle of the polygon you want to select.

An object with selected polygons.

To select an edge and all connected edges in the same direction:

1. Click the Selection tool.
2. Double-click an edge of the polygon.

An adjoining edge is considered to lie in the same direction if the angle formed between the selected edge and the adjoining edge is equal to or less than Properties tray: Tool Options: Angle of Selection Propagation. If the adjoining edge lies in the same direction, it is selected and the angles formed between it and any adjoining edges are evaluated. In this way, the selection propagates until there are no more adjoining edges that meet the selection criteria.

An object with all of the edges in a particular direction selected.

To add an item to the current selection

To extend the selection, hold down the Shift key before selecting additional vertices.

To select an entire object:

1. Click the Selection tool.
2. Double-click in the middle of any polygon.

To select all objects:

- Choose Edit menu> Select All or click Ctrl+A.

To deselect all selections:

1. Click the Selection tool.
2. Click in an empty area of the modeling window.

Marquee selection modes

Marquee selection can be done using three different modes:

- **Rectangle Mode**: drag until the marquee surrounds the objects, edges and vertices you want to select.
- **Lasso Mode**: drag to define a polygonal area surrounding the objects, edges and vertices you want to select.
- **Paint Mode**: click and drag cursor over elements to paint them.
The selection tools

**Saving and Restoring Selections**

When you're working with complex objects, it's often convenient to save selections of objects so that you can easily reselect them.

You can have as many saved selection as you want. To set the maximum number of saved selection, use the Vertex Modeler preference dialog (see To set preferences for the Vertex Modeling window:).

To save the current selection:

- Choose *Selection menu > Add To Saved Selections*.

To restore the saved selection:

- Choose *Selection menu > Restore Selection*: the previous saved selection is restored. To get a previous selection, select again *Selection menu > Restore Selection*.

**Inverting the Current Selection**

Inverting the selection deselects the current selection and selects all other items.

To invert the current selection:

- Choose *Selection menu > Invert Selection*.

**Selection Loop**

The Loop tool lets you expand a selection along a surface by continuing it as far as possible in the direction you started. The Loop tool works with polygons and edges, but not with points. For polygons, you must have at least two polygons selected to indicate the direction to expand the selection.

To select a loop:

1. Select an edge or two faces to start.
2. Click on the Loop icon, in the property panel.

**Selection Ring**

The Ring tool lets you expand a selection along a surface by continuing it as far as possible in the direction you started, as with the Loop tool, but in parallel, like the rungs on a ladder. The Ring tool works only with edges.

To select a ring:
Select an edge.
2. Click on the Ring icon, in the property palette.

Select Between

The Between tool lets you connect a selection on a surface after defining its start and finish. The tool only works on simple cases, like a direct path. Since this tool is based on Loop and Ring, it will stop at the same types of problems which would stop those other tools.

To select between:
1. Select an edge or face as start element.
2. Select an edge or face as end element.
3. Click on the Btw icon, in the property panel.

Grow selection

The Grow selection tools allows you to add to the selection faces, edges or points close to the currently selected items.

To grow the selection:
1. Select an item start.
2. Click on the + icon, in the property panel.

Shrink selection

The Shrink selection tools allows you to reduce the selection by unselecting the items located on the outer limit of the currently selected items.

To shrink the selection:
1. Select an item start.
2. Click on the - icon, in the property panel.

Hiding Selections

When you're editing a complex object, you might want to hide parts of the object to make it easier to view and select the vertices and edges you want to work with.

Selected vertices hidden using the Hide Selection command.

To hide a selection:
1. Select the vertices and edges you want to hide.
2. Choose View menu> Hide Selection.

To reveal hidden vertices in an object:

1. Select the object.
2. Choose View menu> Reveal Hidden Vertices.

**Naming Selections**

You can assign names to polymeshes, polygons, edges and vertices. Once named you can reselect the object by name. As well, names are used by some exporters.

Even though you can select large parts of your vertex object, using the Select by Name feature, a selection only directly applies to vertices. For example, when you select an edge both its vertices are selected. In some cases, this means that you may actually select edges unintentionally. Suppose you tried to select two edges of a triangular polygon, because all three vertices are selected, the third edge is also selected.

To name a selection:

1. Choose Selection menu> Name> Polymeshes, Edges, Vertices or Polymesh.
2. Type a name for the selection in the dialog that appears and click OK.

To select named objects:

1. Choose Selection menu> Select by> Name.

To deselect, choose Deselect by Name.

1. Then choose the type of object (vertex, polygon, edge or polymesh) and the name you want to select and click OK.

**Working with Vertices**

The power of Vertex modeling lies in the ability to directly position vertices and edges. By joining separate objects and moving vertices, edges, and polygons, you can model just about anything you can imagine.

**Adding Vertices**

You can edit existing polylines or edges by adding vertices on them. Adding vertices is useful when you need more control over the object than is provided with the existing vertices.

To add a vertex:

1. Click the Add Vertex tool.
2. Click an edge where you want to add the vertex.
   - By default, the new vertex is added at 1/4, 1/3 or 1/2 of the edge.
To add a vertex at any position on the edge, select **Free Position** in the tool options of the Properties tray. The new vertex is highlighted in red.

You can also drag with the **Add Vertex tool** to add and immediately move a new vertex.

**Additional tool options:**

By default, the position of a vertex on an edge is constrained to the nearest specific position (1/4, 1/3 or 1/2). To add a vertex at the exact clicked position, select **Free Position** in the tool options of the Properties tray.

When 2 vertices are added consecutively to the same polygon, they are automatically linked with an edge. This behavior can be switch off by unchecking the **Auto-link** option.

**Deleting**

1. To delete a vertex:
   2. Click the **Delete** tool.

   1. Click the vertex you want to remove.

Removing a vertex also removes the edges that connected the vertex to other vertices, unless the edges connected to this vertex are 2. In that case, a new edge is created to replace the 2 previous ones.

You can also delete a vertex by selecting it and using the Dissolve tool from the Edit menu or by hitting the Backspace key.

To delete an edge:

1. Click the **Delete** tool.
   2. Click the edge you want to remove.

Removing an edge does not remove the vertices that it connected.

You can also delete an edge by selecting it and using the Dissolve tool from the Edit menu or by hitting the Backspace key.

To delete a polygon:

1. Click the **Delete** tool.
   2. Click the polygon you want to remove.

   • Removing a polygon does not remove the edges around it.
   • Deleting a polygon is the same as emptying it (with the **Model menu > Empty polygons**).  
   • You can also delete a polygon by selecting it and using the Dissolve tool from the Edit menu or by hitting the Backspace key.
Linking and Unlinking Vertices

Linking vertices creates an edge between them. Unlinking vertices removes the edge that connects them, but does not affect the vertices themselves.

Linking can be used for breaking a polygon in two between two of its vertices, or for closing or extending a polyline.

It is not possible to create an edge on a polymesh if the two vertices do not belong to the same polygon. For instance, linking two vertices on the border of a hole is not possible.

To link vertices:

1. Click the Link tool.

The Link tool

1. Select the first vertex. This vertex will turn yellow.
2. Select the second vertex. An edge is created to connect the vertices. If the two vertices are part of the same polygon, the polygon is divided into two smaller polygons.

To unlink vertices:

1. Select the vertices you want to unlink.
2. Choose Model menu > Unlink.

The edge connecting the two vertices is removed.

You can also unlink two vertices by clicking the edge with the Delete tool or by selecting the edge and using the Dissolve tool or hitting the Backspace key.

Welding Vertices

You can join separate objects by welding selected vertices. Normally, if two vertices are within a specified distance from each other, they are welded when you use the Weld command. However, if welding the vertices would cause a single edge to be shared by more than two polygons, the vertices are not joined.

To weld vertices:

1. Select the vertices to be welded.
3. Set weld options:
   - Align but do not weld aligns the vertices but does not make two or more objects one, as the Weld command does. The vertices move to the average position of all the vertices that lie
within the threshold.

- **Use default tolerance** welds the vertices if the distance between them is within the default tolerance specified in the Vertex Modeler preferences.
- **Weld all selected vertices** welds the selected vertices no matter how far apart they are.
- **Use custom tolerance** specifies the maximum distance vertices can be from each other and still be welded.
- **Custom tolerance** determines how close the vertices must be to be welded. Enter a value.

1. Click OK.

The welded vertices are joined into a single vertex.

Two vertices can also be welded together using the Weld tool or the Target Weld tool. The Weld tool welds points and moves the result at mid distance of the two selected points, whereas the Target Weld tool welds vertices and moves the first selected vertex to the position of the second vertex.

To Weld vertices:

1. Click the weld tool.

The Weld Tool

1. Click on the 2 vertices to be welded together.

**Moving Vertices**

In addition to simply dragging with the Selection tool, you can move vertices in other ways:

- Attract groups of vertices along a specified curve shape.
- Position vertices by a specific amount.
- Move a vertex, edge, or polygon to specific global coordinates.

**Attracting Groups of Vertices**

You can selectively move vertices in an object with the Sphere of Attraction tool. This tool behaves like a magnet, attracting the vertices within its sphere of influence.

Using the Sphere of Attraction tool.

You can set the following properties for the Sphere of Attraction tool:

- The shape of the attraction curve.
- The radius of the sphere of attraction.
- Whether nearby edges and vertices are attracted or only the selected vertices and edges are attracted.
The effects of the Sphere of Attraction tool are most noticeable when you use it on a highly defined object.

To attract a group of vertices:

1. Select the vertices you want to move or attract.
2. Click the Sphere of Attraction tool.

1. Drag the Sphere of Attraction tool in the direction in which you want to move the vertices.

To constrain the move operation to the direction perpendicular to the Drawing plane, hold down the Command/Ctrl key.

Sphere of Attraction tool properties:

- **Cubic, Linear, Spiky**, or **Bumpy** determine the shape of the attraction curve.
- **Move selection**, attract other vertices moves selected vertices as they would be with the Selection tool, while other vertices within the sphere of attraction are moved towards the selected vertices.
- **Attract only selected vertices** moves selected vertices only.
- **Radius of attraction** sets the area around the tool that will be affected.

Repositioning Vertices Numerically

In the Vertex modeler, you can precisely reposition vertices in two ways:

- Offset a selection from its current location with the Move command.
- Change the coordinates of a vertex, edge, or polygon using the Properties tray. For information on using the Properties tray, refer to Checking and Specifying Object Properties.

To offset a selection by a specific amount:

1. Select the object or portion of the object you want to move.
2. In the Move tool options of the Properties tray, specify the amounts you want to move the selection on the X, Y and Z axis

Displacement Painting

Carrara 6 includes a new displacement modeling feature in the Vertex Modeler. This feature allows you to increase the detail in your model without increasing the geometry. The typical workflow is to take a model and paint your displacement using the Displacement Painting Tool. After the displacement painting is done, you save the displacement map, which you later apply to the original model to restore the detail.

When you use displacement painting on a subdivided mesh, you can increase the number of subdivisions to increase the detail of the displacement painting. Checking the Symmetry option when available also applies the displacement symmetrically along the axis that you select.
The steps are as follows:

1. Select a model and open it in the Vertex Modeler.
2. Click the Displacement Painting Tool in the toolbar.

Displacement Painting Tool.

1. Choose a mode for painting:
   - Choose **Displace** to paint raised or lowered areas onto the mesh. Paint normally to raise areas, and press the Shift key while painting to lower areas.
   - Choose **Smooth** to soften the areas between the raised and lowered areas, to blend them together.

1. Set parameters for the brush as follows:
   - Increase or decrease the **Size** to displace wider or finer areas of the mesh.
   - Adjust the **Strength** of the brush to increase or decrease the amount of displacement you can achieve in a single stroke.
   - Increase or decrease the **Hardness** of the brush to create a brush that has less or more falloff around the edge of the brush.
   - Click the **Alpha Mask** button to select an alpha mask image that will be used to texture the brush.

1. To save the displacement map for use in other 3D software, choose **Selection menu > Export Displacement Map**. The Export Displacement Map dialog allows you to select a subdivision level, texture map size, and shading domain, and file location. After you select your options, click OK to export the map.

Using the Bridge Tool

The Bridge Tool allows you to connect selected polygons between two objects in the Vertex Modeler.

Bridge tool.

To use the tool, begin by selecting the polygons, edges, or vertices that you want to connect. Then select the Bridge Tool. The following options appear in the tray:

Bridge Tool options.

- In the Options section, choose any of the following options:
  - **Twist** specifies how many times the bridge should twist before it connects to the other side.
  - **Segments** defines the number of segments in the bridge. The default setting is 0, which adds no additional segments to the bridge.
  - Check the **Invert** option to reverse the direction of the twist.
  - Click the **Commit** button to complete the bridging operation.
Working with Edges (Pro version only)

The Vertex modeler provides several advanced tools to manipulate edges quickly. These tools can be used to improve the topology of polygonal objects.

Extract Along (Pro version only)

The Extract Along tool lets you extract a selected edge along the edges next to it. This tool is useful for fine-tuning a model, for example adding a loop of edges around an existing edge.

To extract edges along:

1. Select one or several edges on a surface or volume.
2. Select the Extract Along tool.

   1. Click and drag on the selected edge and move it to define the placement of the newly created edges.

Extract Around (Pro version only)

The Extract Around tool lets you create two edges parallel and around the original edge, or edges, depending on the selection made before. The original edge stays selected after the operation is finished.

To extract edges along:

1. Select one or several edges of a surface or volume.
2. Select the Extract Around tool.

   1. Click and drag on the selected edge, and move it to define the offset of the newly created edges.
2. With the original edge still selected, it is now easy to manipulate it, for example, creating a raised button, or a pushed in zone.

Move Along (Pro version only)

The Move Along tool lets you move an edge along its adjacent face. It is a very useful tool for fine-tuning, for example, moving an “edge loop” on an existing surface, like around an eye.

To move edges along:

1. Select one or several edges on a surface or a volume.
2. Select the Move along tool.
1. Click-drag on the selection of edges, and move them to their new position.

**Quick Fillet (Pro version only)**

The Quick Fillet tool lets you extract a selected edge along the edges next to it. The result is similar to using the Chamfer tool set to range 0.

To use the Quick Fillet tool:

1. Select one or several edges on a surface or a volume.
2. Select the Quick Fillet tool.
3. Click-drag on the selection of edges, and move them to their new position.

**Target Weld of Vertices or Edges**

The Target Weld tool allows you to weld two vertices so that the first selected vertex is moved to the second selected one and merged with it.

The Target weld tool can also be used to weld edges.

To weld a vertex or edge to another vertex or edge using the Target Weld:

1. Click the Target Weld tool.
2. Click on the vertex to weld to another vertex.
3. Click on the target vertex. The first vertex is moved to the second vertex position and the two vertices are welded.

**Chamfering Edges or Vertices**

The Chamfer tool lets you create smooth angles and corners, by rounding chosen edges or vertices of a polymesh.

The tool needs input of the Radius, which is the circular section that makes the edge or vertex rounded, and the Range, which is the quality of the rounded edge, or how many facets/points will be created to describe this curved edge.

Example of use:

Most real objects seldom have truly sharp edges. To get this effect, use the Chamfer tool to round off the angles.

An example is right in front of you: look at your computer screen, whose shell probably has rounded edges, whether for safety or design or both.

To use the Chamfer tool on already selected edges:

1. Select one or several edges on a surface or a volume.
2. Select the Chamfer tool.
3. Set the radius and the range parameters
4. Hit Return.

To use the Chamfer tool without selecting edges first:

1. Select the Chamfer tool.
2. Click on the edge to chamfer. The chamfer is computed.
3. To select several adjacent edges, hold the Shift key while selecting new edges then release the Shift key and click on the selection to compute the chamfer.
4. Set the radius and the range parameters
5. Hit Return.

To Chamfer vertices to create round corners:

1. Select the Chamfer tool.
2. Click on each vertex.
3. Set the radius and the range parameters.
4. Hit Return.

**Working with Objects**

The Vertex modeler provides a number of ways to manipulate an object without directly editing individual vertices and edges. This section describes how you can:

- Duplicate existing vertex objects.
- Adjust the position of vertices, edges, and polygons to align two objects.
- Add depth to an object's surface to give it a visible shell.
- Create and fill holes in an object.
- Smooth or sharpen an object's surface.
- Increase the number of polygons that describe an object's surface, giving you more control over its shape and appearance.

**Duplicating Objects**

You can duplicate an object with the Duplicate and Duplicate with Symmetry commands.

When you choose Duplicate, a second copy of the object is created at the same location as the original.

When you choose Duplicate with Symmetry, the copy mirrors the original object. The Drawing plane behaves differently from usual in that neither the object nor its duplicate is placed on the Drawing plane, but on either other side of it.

Objects can be duplicated with symmetry.

To duplicate an object:

1. Select the object you want to duplicate.
2. Choose *Edit menu* > *Duplicate* or press Command/Ctrl+D.
To duplicate an object with symmetry:

1. Move the Drawing plane so that when used as a mirror, it will reflect the original object.
2. Select the object you want to mirror.
3. Do one of the following:
   - Choose **Edit menu > Duplicate with Symmetry**
   - Press Command+Option+D/Ctrl+Alt+D.

**Duplicating Objects: Tutorial**

This section provides a quick step-by-step lesson to help you see the practical applications of duplicating with symmetry.

To create an airplane:

1. Create the airplane's fuselage and one wing.

   1. Select the wing.
   2. Move the Drawing plane to the center of the airplane.

The Drawing plane will behave like a mirror between the original object and its duplicate.

1. Choose **Edit menu > Duplicate with Symmetry**.

The plane now has two wings of the exact size and shape.

You can repeat the same procedure to complete the tail.

**Replicating an Object**

When an object is made of a repeated pattern, a model of the pattern can be created and then be replicated as many times as needed.

To replicate an object:

1. Select the object (or part of the object) to be replicated.
2. Choose the **Edit menu > Replicate**. The Replicate menu appears.
3. Choose a replication along a line, an array or a circle and adjust the settings of the chosen mode.
4. Click OK.
Aligning Objects

You can adjust the alignment of two objects by attaching them at selected vertices, edges, or polygons.

To align one object with another:

1. Select the vertices, edges, or polygons on two objects you want to align. You must make the same type of selection on each object: a vertex, an edge, or a polygon. Ctrl+Alt+Click a vertex on the object you want to be the reference for the alignment. The vertex will turn yellow.
2. Choose **Edit menu > Align**.

Adding Thickness to an Object

The Add Thickness command lets you extrude vertices at right angles to the plane of the surrounding polygons.

Object with added thickness.

Note: You can also extrude a single polygon or edge with the Extrude command. Refer to Extruding and Sweeping Cross-Sections.

To add thickness to an object:

1. Select the part of the object you want to extrude.

In this case the entire object was selected.

1. Choose Model > **Add Thickness**. The Add Thickness dialog appears.
2. Specify how thick you want the surface to be and click OK. Enter a positive value to add thickness to the outside of the object, or a negative value to add thickness on the inside.

Two inches of thickness were added to the entire object.

To Offset the surface of an object:

1. Select the polygons that you want to offset from the object.
2. Choose Model menu > **Offset Surface**. The Offset dialog appears.
3. Specify the amount you want to move the selected polygons.
4. Click OK.

The surface is expanded like a balloon. All selected vertices are moved outward at right angles to the average plane of the surrounding polygons.

To flatten selections to the plane that lies closest to the selected vertices:
1. Select the objects you want to flatten.
2. Choose Model menu *Flatten*.

To move a selection to the Drawing plane:

1. Select the vertices, edges, polygons, or objects you want to move to the Drawing plane.
2. Choose Model menu > *Move to Drawing Plane*.

Selected vertices sent to the Drawing plane.

**Creating and Filling Holes in an Object**

Vertex objects do not have to be completely solid. You can cut holes in an object by emptying polygons on the object's surface, or you can detach polygons to create an effect such as a can with a half-open lid.

You can also cut away parts of an object by using the Boolean operation. For more information refer to Using Boolean Operations and Cut Tool.

Emptying a polygon to create a hole in an object.

To create a hole in an object:

1. Select the polygons you want to remove to create the hole.
2. Choose Model menu > *Empty Polygon*.

You can also empty polygons with the Delete tool.

Filled and emptied polygons appear the same in the Wireframe views. To view the hole, switch to one of the shaded modes.

To fill a hole in an object:

1. Select the closed polyline that you want to fill.
2. Choose Model menu > *Fill Polygon*.

To detach a polygon:

1. Select the polygon you want to detach from the main object.
2. Choose Model menu > *Detach Polygons*.
3. Drag the polygon to any position you like.

The main object has a hole where you detached the polygon.
Smoothing and Creasing Edges

When an object such as a sphere is rendered, the individual polygons are shaded to appear smooth. In some cases, you do not want smooth shading–you might want an edge to represent a crease in the object's surface, such as an edge on an auto body. A crease separates regions that are flat or appear smoothly curved.

Creased and smoothed edges of an object.

The Vertex modeler provides two different ways to smooth or crease edges on an object's surface:

- Smoothing or creasing selected parts of an object with the Smooth and Crease commands.
- Creasing an edge with the Crease tool so that it remains creased, regardless of how you redefine the object through subdivision.

Creasing an edge will prevent it from being rendered as smooth or curved. In this example, the Crease tool was used to create the sharp ridges on the head and mouth of the gargoyle.

To smooth or crease selected edges:

1. Select the edges you want to be rendered as smooth or creased. Creased edges are highlighted in yellow when selected.

2. Choose **Model menu > Smooth Edges or Crease Edges**. The Smooth selected edges dialog or the Crease selected edges dialog appears.

3. Enter a value in degrees for the crease angle.

- For smoothing, any edges that meet at an angle greater than the crease angle will be rendered as smooth; any edges that meet at a lesser angle will be rendered as creased.
- For creasing, any edges that meet at an angle less than the crease angle will be rendered as sharp; any edges that meet at a larger angle will be rendered as smooth.

4. Click OK.

To crease an edge:

1. Click the Crease tool.

2. Select all edges you want to be rendered as straight.

Creased edges will be highlighted in yellow when selected, in blue when deselected.

To uncrease an edge:

1. Click the Crease tool.
2. Command/Ctrl +click all creased edges that you want to uncrease.
Changing an Object’s Definition

The Vertex modeler provides four commands that allow you to change the number of vertices and edges used to describe an object: Decimate, Triangulate, Subdivide, and tesselate. You can triangulate, subdivide, or decimate an entire object or just selected portions of the object.

An object with a selection subdivided.

Decimating an Object

Decimating an object removes information, such as a percentage or number of vertices. Decimating is an easy way to simplify imported models that contain more detail than you need.

To get the best results when you’re decimating an object, you might want to alternate decimating and triangulating the object.

To decimate an object:

1. Select the object or portion of an object that you want to decimate.
2. Choose Model menu > Decimate. The Decimate dialog appears.

The Decimate dialog.

1. Adjust the percentage to specify the percentage of vertices to be removed.

The higher the number, the more vertices will be removed.

1. Choose the decimate technique you want.
   - **Vertex count** removes the percentage of vertices specified in the Decimation percentage.
   - **Fidelity** removes the vertices that meet the decimation criterion, up to the threshold percentage.

1. Choose the decimation criterion you want.
   - **Distance** causes vertices to be removed based on their distance from the planes shared by their neighbors.
   - **Angle** causes vertices to be removed based on the angles formed by the polygons connecting the vertices to their neighbors.

1. Click OK.

Triangulating an Object

The Triangulate command divides selected polygons with more than three sides into several triangular polygons, without affecting the number of vertices.
Triangulate can also be used in conjunction with the Decimate command to produce more satisfactory results.

Triangulating a three-sided polygon has no effect, but you can subdivide a triangle.

An odd-shaped polygon triangulated.

To triangulate selected polygons:

1. Select the polygons you want to triangulate.
2. Choose **Model menu > Triangulate Polygon**.

**Subdividing an Object**

Subdividing an object adds vertices and edges to give you finer-grain control over an object's surface.

To subdivide selected polygons:

1. Select the polygons you want to subdivide.
2. Choose **Model menu > Subdivide**.

**Tesselating objects**

3 types of tesselation are available:

The 3 tesselation types

- **Vertex To Center** Links the center of the polygon to its vertices.
- **Mid-Edge To Center** Creates new vertices in the middle of the edges of the polygon and links them to the center of the polygon.
- **Mid-Edge To Mid-Edge** Creates vertices in the middle of the edges and links them consecutively one to the other.

To switch from one mode to the other, click their respective icons in the tool options of the Properties tray.

To tesselate a polygon:

1. Click on the tesselate tool.

The Tesselate tool

1. Choose the type of tesselation wanted in the tool options of the Properties tray.
2. Click on the polygons to be tesselated.
Cleaning topology

In some cases, after a long modeling process, complex objects may contain incorrect topologies that can create bad display when rendering. A set of tools can be used to fix these type of problems. These tools are located in the Model menu and work on the current selection.

Triangulate non planar faces:

The Triangulate non planer faces tool lets you transform into triangles the polygons of a selected object the points of which are not in the same plane.

Triangulate n-gons:

The Triangulate n-gons tool lets you divide any polygon made up of more than four points into triangles.

Remove duplicate points:

The Remove duplicate points tool lets you delete any points that might be overlapping, or are one on top of another.

Merge coplanar faces:

The Merge coplanar faces tool lets you combine any facets that share an edge and are in the same plane.

Checking and Specifying Object Properties

The Modeling tab in the Properties tray displays the properties of the selected vertex, edge, or polygon.

You can use the Modeling tab to check statistics on the contents of the working box, to name a selected polymesh, and to move selected vertices and objects to particular X, Y, and Z coordinates.

The Properties tray statistics show:

- The total number of polymeshes, polygons, edges, and vertices in the working box.
- The total number of each that are currently selected.

You can also use the Modeling tab to specify an object's shading domain. For more information, refer to Setting a predefined mapping.

The information shown in the Modeling tab depends on the current selection. To use the Modeling tab to reposition vertices, you must select either a vertex, an edge, or a polygon of no more than four sides.

- When a vertex is selected, the Properties tray displays the coordinates of the vertex.
- When an edge is selected, the Properties tray displays the coordinates of the edge's vertices.
- When a polygon of no more than four sides is selected, the Properties tray displays coordinates of each vertex.
Properties tray with an edge selected.

To specify object properties in the Properties tray:

1. Select the object whose properties you want to change. You can change the name or the coordinates of the current selection.
2. Directly edit the displayed values.

**Transforming Objects and Selections**

The Vertex modeler provides a number of ways to move, scale, and rotate vertex objects or selections. The most convenient way consists of using one of the 3D manipulators. But it can be necessary to use one of the other methods, such as entering values numerically to define a scale factor, for instance.

**The 3D Manipulator**

The 3D manipulator is displayed in the graphic view at the center of the selection. Depending on the selected mode (move, rotate, scale or universal) it shows several colored handles that can be used to transform the selection.

You can choose which manipulator to display by selecting its icon in the left tool palette or by using keyboard shortcuts.

**The Move Manipulator:**

Shortcut: T

This manipulator moves (translates) the selected elements. The manipulator is symbolized by arrow points (2D and 3D).

If you click on an axis, the movement of the selected item is restricted to that axis.

If you click on a triangle on the same plane as the two axis, the movement is restricted to that plane.

If you click drag on the selected element, the object is moved in the active plane.

**The Scale Manipulator:**

Shortcut: S

This manipulator scales the selected elements. It is symbolized by cubes. If you click on a cube on the end of an axis, the scaling of the selected element is limited to that axis.

If you click on one of the grey cubes on the same plane as the two axes, the scaling is restricted to
that plane.

This manipulator also shows a global interactive box which surrounds the object. Click on a face of this box to scale the object as if you were pulling on the face. Click on an edge of this box to pull on both faces that touch that edge. Click on a corner of the box to scale the box proportionally away from the opposite corner.

**The Rotate manipulator:**

*Shortcut: R*

This manipulator rotates the selected elements. It is symbolized by circles. If you click on a circle corresponding to an axis, the rotation of the selected element is limited to that axis.

**The Universal Manipulator:**

*Shortcut: U.*

This manipulator is a combination of the three fundamental manipulators. It lets you perform moves, rotations and scalings without changing the tool.

Using this manipulator is practical to move the objects globally. However, for precise manipulations of 3D entities like vertices or edges, the number of clickable modifiers on each axis may become a problem.

**3D Manipulator Orientation**

Three modes are available from the property panel

- **World (default mode):** the 3D manipulator transforms the selection relatively to the world axes.
- **Camera:** the manipulator transform takes place in the camera plane. Changing the camera orientation changes the transform plane. This mode is useful for tweaking selections.
- **Selection:** the manipulator is oriented in the main plane of the selection. For instance, if a polygon is selected, the XY plane of the manipulator will be the plane of the polygon. This mode is convenient for modeling precisely while keeping the orientation of the selection.

**Hiding the 3D Manipulator**

It is sometimes necessary to hide the manipulator for being able to select or view small details that can be hidden by the numerous controls of the 3D manipulator. A click on the hide button of the property panel to hide the manipulator.

Note that you can still move, rotate or scale selected items even if the manipulator is not visible but only in the active plan.
Soft selection

Complementing the selection modes, there is a specific option that smoothly increases the influence of a manipulation around the active selection: the “Soft Selection”.

Soft selection parameters.

For example, on a face, select a polygon corresponding to a part of the cheek. With no Soft Selection, if you move the selected polygon it will be the only element moving. Activate the Smooth Selection and an influence area will appear around the selected element, represented by red polygons (maximum influence) whose color becomes grey (minimum influence). Move it now and you will see that a part of the nose is modified as well, smoothly following your manipulation.

Two parameters, in the Properties Panel, will allow you to fine-tune the Soft Selection:

- **Radius**: defines the size of the influenced area around the selection.
- **Softness**: the influence ratio in the soft selection area. The higher the value, the less flexible the modified surface.

Flipping objects

An object can easily be flipped using the menu **Edit > Flip**. The selection is then flipped using the active drawing plane as a reference.

Applying modifiers

The modifiers accessible in the assemble room can also be applied to a selection or an object. To learn more about modifiers, see Applying Modifiers.

To apply a modifier on a selection:

1. Select the polygons to be affected.
2. Choose the menu **Selection > Deform**. The Deform Selection dialog appear.
3. Choose a modifier and adjust their settings.
4. Click OK.

Modifying the Polygon Normals

Some situations require the polygons to be oriented in a certain way. This is the case with models that are exported to some other software that use this information for display purposes. It is also the case with the Non-Photorealistic Renderer. The polygons oriented toward the camera are rendered whereas the others are not.

In the vertex modeler, switching the orientation of one polygon will also switch all the adjacent polygons so that the mesh stays consistent.
To switch the normals orientation on a mesh:

1. Select one or more polygons on the mesh.
2. Use the menu **Model menu>Reverse Polygon Normals**.

## Working With Subdivision Surfaces

### Subdividing a Polymesh

When an object is modeled using a small number of polygons, its silhouette is often very rough and it is difficult to create smooth surfaces. However, if you use more polygons, it becomes difficult to make any changes to your model because of the high number of vertices.

Subdivision surfaces help you create smooth surfaces without increasing the number of control points of your model. With subdivision surfaces you can see, in real time, your final mesh as you edit its control points.

An object with a subdivision surfaces.

To use subdivision surfaces:

1. Select the polymesh you want to smooth (you can do that by double-clicking on one of its facets.)
2. In the Properties tray, make sure the Polymesh section is open.
3. To turn on surface subdivision, select smooth.
4. To select the precision of the surface, select the subdivision level.

Subdivision smooth settings.

1. Another subdivision level can be set for rendering allowing you to keep a low level of subdivision for modeling and a high level for the final render.

**Tip**

A high subdivision level can slow down modeling operations, so you should keep the level low while modeling and only turn it up once your object is finished.

### Edge Creasing

In the process of subdividing a polymesh, the smoothing of the edges has a primary importance. Creased edges will still display a sharp angle after the subdivision is applied.

For more information about Creasing or Smoothing edges, see Smoothing and Creasing Edges.

Following is an example of a Subdivision applied to a cube with none, some or all of its edges smoothed. The resulting meshes are radically different and underline the importance of this parameter in the Subdivision Surfaces.
Cubes with Subdivision Surfaces

Open Surfaces

The Subdivision Surfaces can be applied to either a closed or an open polymesh. On an open polymesh, the resulting surface is smoothed along its edge and no distortions are created in respect to the rest of the surface.

Open Surface with Subdivision Surfaces

Symmetrical Modeling

When working with polymeshes in the Vertex Modeler, a new Symmetry section in the Model tab allows you to make symmetrical modeling changes to your meshes.

Symmetry options in the Model tab: Symmetry pane.

To use symmetrical modeling:

- Check or uncheck the Symmetry option when you want to enable or disable Symmetrical modeling.
- Select the axis of symmetry (X, Y, or Z).
- When Symmetrical modeling is enabled, any changes you make on one side of the axis will be repeated on the other side.

Using Standard Modeling Techniques

You can use standard modeling techniques introduced with the Spline modeler to create complex objects in the Vertex modeler. The Vertex modeler supports:

- Extrusions
- Sweeps
- Lathed objects
- Lofted objects
- Coons surface (Pro version only)
- Gordon surfaces (Pro version only)
- Double sweep surfaces (Pro version only)
- Ruled surface (Pro version only)

If the object you are modeling is easier to describe using Bézier curves, you can create the object in the Spline or Metaball modeler and then edit it in the Vertex modeler.
Extruding and Sweeping Cross-Sections

Extruding or sweeping a polygon creates an object similar to that created with the Spline modeler. You can use an open or closed polyline to define the cross-section of an extrusion or sweep. Using an open polyline as a cross-section creates a shell with the shape of the polyline.

The cross-section can be a separate polyline object, or a set of selected edges in a larger object.

There are 2 ways of extruding a cross-section:

- Dynamically by clicking and dragging the cross-section.
- Along a path by selecting another polyline as a path for the sweeping.

Dynamic Extrusion

The Dynamic Extrusion tool is a very easy and fast tool to create the rough shape of a model starting from a simple primitive or to add details to a particular part of a model after its creation.

To start a Dynamic Extrusion:

1. Click the Dynamic Extrusion tool.

The Dynamic Extrusion Tool

1. Click and drag the polygons or polylines to be extruded.

The extrusion method can be chosen among the four available in the tool options of the Properties tray:

The 4 extrusion methods

- **Normal Extrusion** Creates an extrusion perpendicular to the original cross-section but with a different size.
- Holding the **Shift** key down during the extrusion will constrain the extrusion to the plane of the original cross-section.
- Holding the **Command/Ctrl** key down during the extrusion will constrain the size of the extrusion to the size of the original cross-section.
- **Parallel Extrusion** Creates an extruded cross-section parallel to the original one, but with a rotation of its center. By default the size of the extruded cross-section is the same as the original one but can be modify by holding the Shift key down during the extrusion.
- The rotation of the center is done in the active drawing plane. Holding the **Command/Ctrl** key down during the extrusion will constrain the rotation in a plane perpendicular to the drawing plane.
- **Irregular Extrusion** Rotates the new cross-section from the original one. By default, the extruded cross-section and the original cross-section have the same size.
- Therefore, depending on the angle between the two cross-sections, the extrusion will appear to...
shrink.

- To set the size of the new cross-section, hold the **Shift** key while extruding.
- The rotation of the cross-section is done in the active drawing plane. Holding the **Command/Ctrl** key down during the extrusion will constrain the rotation in a plane perpendicular to the drawing plane.
- **Regular Extrusion** This mode is similar to Irregular Extrusion with the difference here that the new cross-section is scaled so that the extrusion will appear to have a constant section, whatever the angle between the two cross-sections is.

When several polygons or polylines are selected, they are all independently extruded following the extrusion of the last selected one. Very complex models can so be created with a simple click and drag action.

To keep the adjacent polygons linked together as one entity during the extrusion, check the **Link Polygons** option in the tool options of the Properties tray.

Check the **Edge Extrude** option to enable Edge Extrusion mode, which allows you to extrude edges into corners.

Note that the **Snap To Grid** preference option (see To set the Grid Settings preferences:) influences the way the extrusion is made.

If you want to manually enter an offset value for the extrusion, enter it in the Manual Offset field in the tool options of the Properties tray. All the selected polylines will then be offset at this distance.

**Path Sweep**

The Path sweep tool uses the same principles as Dynamic Extrusion, but instead of manually clicking and dragging the polylines and polygons to extrude, the extrusion is done along a predefined path.

The sweep path is defined by a polyline. It is not necessary for the vertices of the path to lie on the same plane, which allows you to easily define complex 3D paths.

Like cross-sections, the sweep path can be defined by a separate polyline object or a set of selected edges of a larger object.

There are 4 ways of sweeping a cross-section along a path:

- **Irregular Sweep** The cross-section remains perpendicular to the sweep path and its size remains constant.
- **Regular Sweep** The cross-section remains perpendicular to the sweep path and its size is modified so that the section of the created volume is constant.
- **Parallel Sweep** The cross-section remains parallel to the original one.
- **Envelop** The cross-section remains parallel to the original one and is scaled to follow the path.

In this mode, the position of the path relative to the original is very important since the distance between the path vertices and the cross-section determines the scaling value.
To sweep a cross-section:

1. Create one or several cross-sections. For this, you can use the Polyline tool, select an existing polygon or closed polyline, or create a 2D primitive.

2. Draw the sweep path with the Polyline tool, or select an existing polyline to use as the path.

You may find it convenient to switch to a 2D view to create an extrusion path perpendicular to the cross-section.

1. Select the cross-sections and the path.
2. Click the Path Sweep tool and choose the sweep mode in the tool options of the Properties tray.

The Path Sweep tool

1. Click on the path. If the path is an open polyline, the sweep can use one or the other end as its starting point. To determine which point should be used, click as close to the chosen extremity as possible when selecting the path. If the path is not previously selected when clicked, it will be automatically selected.

If you want to use a group of polygons as a single cross-section, check the **Link Polygons** option in the tool options of the Properties tray.

**Lofting with Polyline Cross-Sections**

Lofting enables you to stretch a surface over a series of cross-sections. In the Vertex modeler, these cross-sections can be defined by open or closed polylines.

Like the cross-sections used for extrusions and sweeps, these cross-sections can be separate polyline objects or selected edges in a larger object.

You can define as many cross-sections as you need, but all of the cross-sections for a single lofted object must be either open polylines or closed polylines; you cannot mix them. To be lofted, the cross-sections must lie on different planes.

In certain situations, not all of the cross-sections you define are used. This might happen if two of the cross-sections lie very close to the same plane—one of them is used and the other ignored.

Two polylines and the object that results when they're lofted.

Lofting can also be done using the Ruled surface tool (Pro version only)

To loft an object:

1. Create the cross-sections with the Polyline tool or choose existing polylines to use as cross-sections.
You can combine any number of polyline cross-sections to create a shape.

1. Select the cross-sections.
2. Choose **Construct menu> Loft**.

The resulting shape after lofting.

**Lathing with Polygon and Polyline Profiles**

When you lathe objects in the Vertex modeler, you control both the lathe profile and the lathe axis. The lathed object is created by revolving the profile around the specified axis. The lathe profile is always rotated a full 360 degrees around the axis.

Both polylines and polygons can be used as lathe profiles. The lathe axis can be defined by any edge.

A polyline lathe profile and the resulting object.

To lathe an object:

1. Create the lathe profile with the Polyline tool, or select a set of connected edges to use as the lathe profile.
2. Select the profile(s) to be lathed.
3. Click the Lathe tool. If the profiles are open polylines, new edges will appear in red. These new edges can also be used as an axis for the lathing.

1. Select an edge to use as the axis.
2. Set the number of sections in the new model using the + or - keys or manually enter the number in the tool options of the Properties tray.
3. Validate with **Enter** or **Return**.

Use the Polyline tool to draw a lathe profile.

The resulting shape after lathing.

**Coons Surface (Pro version only)**

The Coons surface tool lets you create a surface between a closed curve, or several open curves connected together.

This tool is very useful for the creation of complex shells, for example when two profiles and two
sections are necessary like in the case of a car hood. Here we can see that it could be difficult to create such a complex form quickly.

Using the Coons surface tool, you can define a curve for the lateral part, one for the center, and one for the front, and finally another for the back.

To create a Coons surface:

1. Create the curves to be used by the Coons surface tool making sure each curve is connected on both ends so that the curves define a closed loop.
2. Select the Coons surface tool in the Surface modeling tab.

1. Click on the curves. The selecting order is not important.
2. Once all the connected curves are selected, the surface is automatically created.

**Gordon Surface (Pro version only)**

The Gordon surfaces tool lets you create a surface defined by a series of latitudinal cross sections and longitudinal profiles. These must be created before the use of this tool.

This tool is used for the creations of complex surfaces often based on very precise curves, like a custom bottle for example.

The bottle could be made using a Sweep or Double sweep tool, but they may be too limited for a complex project.

Generally, this tool is used in product design.

To create a Gordon surface:

1. Create all the sections to be used.
2. Create the profile curves making sure that each point passes through a point of the section curves, to construct a mesh that is connected.
3. Select the Gordon Surfaces tool.
4. First click on all the sections and Validate by pressing the Enter key.
5. Click on all the profiles and validate again.

Two things can happen:

1. The curves were correctly connected and the surface is automatically generated.
2. The curves were incorrectly connected, and the surface is generated as best as possible, but due to the missing points, the results may not be satisfactory. You should cancel, verify the connections and start again.

Remarks:

1. All sections and profiles must be connected.
2. All ends of profiles must be connected to the first and last cross sections.
3. Unlike the Double sweep tool, it is impossible to have a profile go past a section.
4. The tool does not have a “close” option.

**Double Sweep Surface (Pro version only)**

The Double sweep tool lets you create a surface or volume from a section and two profiles connected to it.

To create a Double Sweep surface:

1. Create the curves to be used.
2. Select the curve that will be the section.
3. Select the Double sweep tool.
4. Click on the two curves to become the profile. The selecting order is not important.
5. The surface is created.

**Gordon Surface (Pro version only)**

The Gordon surfaces tool lets you create a surface defined by a series of latitudinal cross sections and longitudinal profiles. These must be created before the use of this tool.

This tool is used for the creations of complex surfaces often based on very precise curves, like a custom bottle for example.

The bottle could be made using a Sweep or Double sweep tool, but they may be too limited for a complex project.

Generally, this tool is used in product design.

To create a Gordon surface:

1. Create all the sections to be used.
2. Create the profile curves making sure that each point passes through a point of the section curves, to construct a mesh that is connected.
3. Select the Gordon Surfaces tool.
4. First click on all the sections and Validate by pressing the Enter key.
5. Click on all the profiles and validate again.

Two things can happen:

1. The curves were correctly connected and the surface is automatically generated.
2. The curves were incorrectly connected, and the surface is generated as best as possible, but due to the missing points, the results may not be satisfactory. You should cancel, verify the connections and start again.

Remarks:

1. All sections and profiles must be connected.
2. All ends of profiles must be connected to the first and last cross sections.
3. Unlike the Double sweep tool, it is impossible to have a profile go past a section.
4. The tool does not have a “close” option.
Ruled Surface (Pro version only)

The Ruled surface tool is another way to create Lofted surface. It's ergonomics allows you to select each section curve so that you can choose which curve is connected to the current curve by hand.

Sections curves must be all closed or all open. Polygon edges cannot be selected as section curves without being extracted first.

To create a Ruled surface:

1. Create the curves to be used.
2. Select the Ruled Surface tool.
3. Click on each curve. The surface appears between each selected curve.
4. Type Return to stop.

Creating Organic Models

Complex models can be created very simply by using flat polygons and applying Organic functions to them.

To create organic models:

1. Create a closed polyline using the polyline tool and select it.
2. In the Construct menu, choose the Organic item.

Using Boolean Operations and Cut Tool

The Boolean operations–Union, Intersection, and Subtraction–are used to produce a complex object from two or more simpler objects. Boolean operations are performed on two overlapping volumes. Both volumes should be closed–holes in the surface of a volume can prevent Boolean operations from producing the desired results.

The Cut tool is very similar to the Boolean tool in that it allows you to punch a volume with a polyline or a curve.

The union of two objects is an object whose surface encompasses the visible surfaces of both objects. For example, if you spray-paint two overlapping spheres, the painted surface represents the union of the two spheres.

The intersection of two objects is the volume shared by both objects. For example, if you take the intersection of two overlapping spheres, the resulting object resembles a flying saucer.
Result of two objects joined using Boolean Intersection.

Boolean subtraction is similar to the concept of compounding shapes in the Spline modeler. However, compounding shapes only enables you to create holes through extruded objects. Boolean subtraction enables you to work directly with 3D objects and remove overlapping volumes.

Result of two objects joined using Boolean Subtraction.

| Note | When you perform a Boolean operation, you lose the UV coordinates of the original objects, and surface shading can become more complex. |

Using Boolean operations enables you to quickly produce certain types of complex models. For example, suppose that you want to create a cylindrical hole through a sphere that originates on the top of the sphere and exits to the sphere's left side.

Using normal modeling techniques, this would be nearly impossible, but with Boolean subtraction it's easy. It's just a matter of aligning a bent pipe and a sphere and then subtracting the two.

An example of the types of effects you can create with Subtraction.

**Boolean operators**

The Boolean tool can perform the three most commonly used operations (Union, Intersection and Subtraction), and it can also create all the possible operations such as the closed intersections, open intersections, intersection lines, and so on.

The Boolean tool.

There are 12 possible combinations, accessible in the property panel, either by clicking on the chosen icon, or by using the +/- keys to cycle through the choices.

**Available operators:**

1. Remove A from B
2. Union of A and B
3. Intersection (shared part) of A and B
4. Remove B from A
5. Intersection of the surface of A from B
6. Intersection of the surface of B from A
7. Surface of A removed by B
8. Surface of B removed by A
9. Contour of the intersection (creates a 3D line)
10. All surface parts of the cut
11. All surface parts of B sliced by A
12. All surface parts of A sliced by B

To perform a boolean operation on objects:

1. Select the objects that must be the first operand of the Boolean operation. If more than one object is selected, a first Boolean operation between them is made automatically to merge them in a single shape.
2. Take the Boolean tool.
3. Click on the second object that must be the second operand.
4. The Boolean operation is performed and a first result is displayed.
5. Click on the operator icon in the property tray or use the +/- keys to select the operation required.
6. Hit Return to stop.

Cut Tool

The Cut tool can be used to punch a volume with a polyline or a curve.

To cut an object with a line:

1. Draw the line that must cut the object. If the line has more than three points defining a plane, the cut will take this plane as the reference plane for cutting. The curve will be projected perpendicularly to that plane. Otherwise, the current active plane is used.

1. Select the object to cut.
2. Take the Cut tool.
3. Click on the line.
4. The Boolean operation is performed and a first result is displayed.
5. Click on the operator icon in the property tray or use the +/- keys to select the operation required.
6. Hit Return to stop.

Using Morph Targets

Morph targets are a powerful animation tool that allow you to define deformations to a Vertex Primitive and then animate the morph between the original object and the deformed version. For example, on a model of a face, you might define a morph target for the eyes blinking, another for the jaw opening, and another for the tongue moving. Then, when animating speech, it is easy to add all of these deformations in turn to provide realistic facial motion, without having to move the vertices by hand each time.

An example of a morph target.
Defining a Morph Area

The set of vertices on which Morph targets are defined is known as the Morph Area. You can create any number of Morph Areas, each with its own collection of Morph targets.

To create a Morph Area:

1. Click on the Morph tab in the Properties Tray
2. Select the vertices of the object to be included in the Morph Area
3. Click the Create button.

Morph areas.

To add or remove vertices from the Morph Area:

- Select the vertices to be added or removed and choose Model menu > Add to Morph Area or Remove from Morph Area.

Creating and Editing Morph Targets

These are the steps to create and edit a Morph target.

To create a Morph target:

1. With a Morph Area selected, press the button and choose Create Target from the pop-up menu.
2. Pick a name for the target and click OK.

Creating a morph target.

The new Morph target, with slider bar and Edit button, appears in the list. You can create multiple Morph targets on the Morph Area.

To edit a Morph target:

1. Click the Edit button next to the Morph target's slider. The edges in the target being edited turn green while you are editing a Morph target.
2. Move the vertices to their new positions. Note that you cannot edit vertices outside the current Morph Area while editing the Morph target.
3. Click the Valid button in the properties tray. This defines the Morph target deformation.

To finish editing a morph target.
Animating Morph Targets

Morph targets can be animated from either the Modeling room or the Assembly room. In both cases, the Morph target sliders appear in the Properties pane and can be moved from 0 to 1 to control the degree to which the Morph target is applied. A value of 0 results in no change from the original mesh, while a value of 1 results in the Morph target being fully applied to the mesh. Changing a slider value inserts a keyframe with the new value at the current time on the Timeline. See Animation Techniques for a full discussion of animation in Carrara.

The Modeling room has two modes:

Modeling and animation/skinning buttons.

- In Modeling Mode, Morph targets can be edited, but when you’re not editing a Morph target, the mesh is displayed without any deformations applied. This mode lets you define multiple Morph targets, starting with a non-deformed mesh each time.
- In Animation Mode, you can see the effects of Skinning and Morph targets on your mesh, allowing you to animate them conveniently.

To animate Morph targets in the Modeling room:

1. Switch to Animation Mode by clicking the Animation button at the top of the Properties tray.
2. Click on the Morph tab in the Properties Tray.
3. Select the Morph Area whose target you want to adjust from the list appearing under the Morph tab.
4. Move the Morph target slider to the desired value.

To animate Morph targets in the Assembly room:

1. Click on the Vertex object to be animated.
2. Select the Morph Area whose target you want to adjust from the list appearing in the Vertex object section of the Properties Tray.
3. Move the Morph target slider to the desired value.

Note: It's generally most effective to animate Morph targets from the Assembly room, where you can see the changes to the Morph Area in context with the rest of your scene.

Shading Vertex Objects

Since vertex objects can have a large number of sides and complex geometry, it can be difficult to
apply shaders to vertex objects. Using standard mapping you may get unexpected results. In some cases, you may need to specify the mapping mode for a specific model to get the results you want.

The Shader room provides a number of controls for adjusting mapping on objects in a scene. The Vertex modeler provides additional control by allowing you to specify how shaders are mapped to individual objects in a model.

**Creating Shading Domains on a Vertex Object**

In many cases, it can be useful to apply different shaders to different parts of a vertex object. On a model of a face for example, we might want to separate the texture of the skin from the one of the eyes, the teeth, or other specific parts. This is in order to have a shading tree easier to create and a UV mapping simpler to edit.

The part of the object where different shaders are applied is called Shading Domains. For more information, see Shading Domains.

Note that to be able to apply different shaders on the shading domains, the shader should be in the Layer List of the Parametric Mapping shaders.

By default, all the polygons of a vertex object are part of the default Shading Domain called 'Texture 0'.

You can then create a new Shading Domain for each polygon of the model and give them different names. These names are important since they are the names that will then be displayed in the shaders of the shading room.

To create a new Shading Domain:

1. Select the polygons on which you want to create a new Shading Domain. Their current shading domain is displayed in selection panel of the Modeling tab.
2. If several polygons are selected, they may have several different Shading Domains. In that case, “Multiple Domains” is visible in the pop-up menu.

To change a Shading Domain to an existing one:

1. Select the polygons for which you want to change the Shading Domain. Their current shading domain is displayed in the selection panel of the Modeling tab.
2. If several polygons are selected, they may have several Shading Domains. In that case, “Multiple Domains” is visible in the popup menu.
3. Select in the Shading Domain pop-up menu the shading domain you want to set the selected polygons to.
The Shading Domains in a vertex model can also be managed from the Shading Domain Management panel.

To open the Shading Domain Management panel:

1. Open the Properties tray.
2. Select the Global tab.

The Shading Domain Management panel gives you the option to add, delete or modify the names of the Shading Domains.

The Shading Domain Management panel

To modify the name of a Shading Domain:

1. Select it in the Shading Domain list. Its name appears in the Name text field.
2. Enter a new name in the text field.
3. Validate with Enter.

Specifying an Object's Mapping Mode

In addition to the three projection mapping modes supported at the scene level, the Vertex modeler supports a custom mode that allows you to specify UV coordinates for particular vertices. For more information about mapping modes, refer to Mapping Shaders.

If you specify mapping modes for individual objects in the Vertex modeler, and then specify a projection mapping mode for the entire model at the scene level, the modes you specified in the Vertex modeler are overridden. To use the settings specified in the Vertex modeler, use the Parametric Mapping mode at the scene level.

To change an object's mapping mode:

1. Select the object in the Vertex Modeler.
2. Display the Properties tray.
3. Make sure the UV Mapping mode section is open.
4. Click the menu and choose a mapping mode: Custom, Box Face, Cylindrical, or Spherical.
5. Set your options (described below).
6. Apply your settings.

Setting a predefined mapping

To set Box Face options:

1. Display the Properties tray.
2. Make sure the UV Mapping mode section is open.
3. Click the menu and choose Box Face.
4. Enable the mode you want to use:
• Full wraps the 2D image onto the box much like you'd wrap a package.
• The single face modes (Top, Bottom, Left, Right, Front, and Back) project the image on one side of the object. The project continues onto the side of the object.

Examples of Box Face mapping.

By default the image is aligned with the object's bounding box axes (i.e. Align with Global Axis is enabled). If you need to, you can change the orientation of the image on the object.

1. Enable Custom to change the orientation.
2. Enter values in the X, Y and Z rotation fields to change the orientation of the image.

To set Cylindrical or Spherical options:

1. Display the Properties tray.
2. Make sure the UV Mapping mode section is open.
3. Click the menu either Cylindrical or Spherical.

An example of Spherical mapping.

An example of Cylindrical mapping.

1. Enable an alignment option—Align with X, Align with Y, or Align with Z.

You can also design your own orientation:

• Enable the Custom option.
• Enter values in the X, Y and Z rotation fields to change the orientation of the image.

**Setting a custom mapping**

When you choose the Custom mapping mode in the **Properties tray: UV Mapping section** you can specify how UV coordinates from the shader should be applied to the selected vertex or group of vertices.

When the mode is set to Custom, the UV values determined by the previous mode are assigned on the vertices. So, if you want to create a custom UV mapping that is similar to a spherical, cylindrical or box mapping, set the mapping to one of these before setting the it to Custom.

When you enable Wrap, the shader is wrapped around the object from the specified U or V coordinate.

To view the UV coordinates that are set for a particular vertex:

1. Select the vertex.
2. Display the Properties tray.
3. Choose the Projection Mapping tab.
4. Make sure the UV Mapping mode section is open.
5. Make sure the UV Mapping Mode is set to Custom.

The Custom controls on the UV Mapping section of the Properties tray.

- The current U and V values are displayed in the number fields.
- The UV mapping on an object might not be continuous. This means that one single vertex can have different UV values used by polygons sharing this vertex. When a vertex is selected, all its existing UV values are displayed.
- An example of non-continuous mapping is the box mapping when applied to all the faces of a cube. In this case, the vertices at the corners will have 3 UV values each.
- The mapping on a polymesh can also wrapped in U and/or V values. Wrapping a texture map avoids going through all the texture maps when a vertex has a U or V value near 1 and is linked to a vertex with a value near 0.
- A vertex can also be in Interpolated mode. In that case, its UV values are determined by the UV values of its surrounding vertices.

**Editing Custom UV Values**

To edit the UV mapping on a polymesh:

1. Select the polymesh or part of it.
2. Choose the Projection Mapping tab in the Properties tray.
3. Click the UV Editor Button. The UV Editor dialog appears.

The UV Editor dialog

1. Edit the UV values and click OK.

The UV Editor contains a 3D view of the polymesh, a 2D display of the UV values on the polymesh vertices, and a set of tools to manipulate them.

If there is no texture on the object, the 2D view will only display the mesh of the vertices in their UV values. If the shader has a 2D texture map, it appears in the background of the mesh.

**The 3D View**

A 3D View displays the edited polymesh and can be used to check the modifications made to the UV values.

The 3D View

Three Camera tools are available to move around the object and the Pan and Zoom tools can also be used to display some particular area of the object. For more information on the Camera tools, see
Camera Tools. For more information about the Zoom and Pan tool, see Navigating Your Scene.

To render the object or a part of it, use the Area Render tool. For more information about the Area Render tool, see To use the Test Render tool:

The 3D View is also very useful as a tool to select points in the 2D View.

To select points in the 2D View using the 3D View:

1. Click on the Move, Rotate or Scale tool.
2. Select the vertices in the 3D View. Their corresponding UV values also appear to be selected in the 2D View.

The 2D View

The 2D View display a flatten mesh of the model using the UV values of the vertices to determine their position. Modifying the point's position in the 2D view will therefore modify the mapping on the object but at all not affect the geometry of the polymesh.

The 2D View

The Zoom tool and the Pan tool can be used in the 2D View to display more specific areas of the texture.

To select one or several points in the 2D View:

1. Click on the Move, Rotate or Scale tool.
2. Then either click on them, click in an empty area and drag to use a Marquee Selection, or click on them in the 3D View. To complete a selection hold Shift while selecting new vertices.

If there is more than one Shading Domain on the polymesh, selecting in the Shading Domain List the one you want to edit will select all the points of this domain.

The Shading Domains list

When a shading domain is selected, its associated texture is displayed in the 2D view. For more information about Shading Domains, see Creating Shading Domains on a Vertex Object

You can then, depending on the tool currently selected, move, rotate or scale the selected vertices.

You can also move them by directly entering their U and V values in the Edition panel.

The Edit Panel

The Edit panel gives you several ways to edit or select the UV mesh.
The Edit Panel

In the Edit panel, you can:

- Set the wrapping in U or V.
- Set the U and V values of the current selection. If one point in the 2D view is selected, the value are its actual values, but if the selection contains more than one point, the value displayed is the average UV value of the selection.
- Choose a shading domain from the list of shading domains set on the polymesh. Each shading domain can be selected by clicking on its name. By default, only the current shading domain is displayed in the 2D view. To display them all at once, check the Show All option.
- A tool which splits a set of vertices from the mesh is also available here.

To split a set of vertices:

1. Select the set of vertices to be split (using either the 2D view, the 3D view or the shading domain list).
2. Click the Detach Polygons button.

You can see now, by using for example the Move, Scale or Rotate tool on the selection, that the vertices around the selection were all split to `free' the selected polygons.

A group of polygons detached from the mesh

The Projection Panel

The projection panel offers a list of projection methods that can be applied to the current selection.

To apply a projection:

1. Select the vertices to apply the projection to.
2. Choose among these 4 available projection methods: Box, Cylindrical, Spherical and Planar.
3. Adjust the settings on the chosen projection.
4. Click the Apply button.

The following options can be adjusted for the different projection methods:

The Box projection options:

The box projection modes

The box projection mode can be chosen among three. The Cover All mode will project all the faces of the box one over the other. The Cover Front/Back mode will project the faces 2 by 2, creating 3
distinct areas: the front and back sides together, then the left and right sides, and finally the top and bottom sides. The No Cover option will project the 6 faces of the box separately so none of them will overlap another.

The Cylindrical and Spherical projection share the same options:

The Spherical projection options

The axis of projection and an offset for the center of projection can be set here.

The Planar projection panel contains options that let you split the mesh by orientation or by the offset position from the center. You can also display the projected mesh horizontally or vertically.

The Planar projection options

The Display Panel

Some parameters relative to the display of the UV values can be tweaked here:

The Display Panel

- As a background of the mesh, a color (white by default) or a low- or high-resolution texture can be displayed.
- The background color and the size of the points can be modified.
- The mesh color can be modified in order to see it no matter what the texture underneath might be.
- The mesh can be exported in an image file. Note that only the mesh and the background color will be exported. The texture map, the grid or the points won't be exported.
- If there are different instances of the vertex object in the scene, each instance could have a different shader on it. You can choose the shader you want to work with by selecting it in the Instance List.

Since a UV mapping can be discontinued (see Editing Custom UV Values), the UV Editor provides a way to create or remove the discontinuities on a vertex.

To create a discontinuity on a specific vertex:

1. Check the Show Split Handles option in the Selection panel. The points are now surrounded by other small handles, each handle corresponding to one of the polygons attached to the vertex.
2. Click on the Move tool.
3. Click on one of the handles to split the UV value. The same vertex on the polymesh will now have different UV values depending on which polygon it is.

You can also merge different UV values when they are shared by a single vertex on the polymesh.

To merge several UV values on a single vertex:
1. Check the **Show Merge Candidates** option in the Selection panel.
2. Click on the move tool.
3. Select the point you want to merge. If the UV mapping has a discontinuity on this point (several UV values for one vertex), the other UV values shared by this vertex will be highlighted in the 2D View.
4. Drag the point over another highlighted point to merge them together.