User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Chapter 14: Setting Lights

How objects appear in a Carrara scene is influenced greatly by the light in which they are viewed. Lighting contributes to effects such as shadows and colors. Lighting also influences the shaders applied to your objects. Sometimes you can adjust the lighting instead of editing a shader to create a specific result.

This chapter covers how to create and use lights. It includes descriptions of the different types of lighting and how you set the options for each.

Lighting in Carrara

Carrara supports two categories of lighting–ambient and specific. There is one ambient light setting, and three types of specific lights: bulb, distant, and spot.

You may add as many lights as you like, but as the number increases, so does the rendering time. Most scenes can be lit with one, two, or at most three well-placed lights.

Tip Carrara also lets you create visible light spheres and cones as rendering effects. The visible light cone effect is like a searchlight cutting through the fog. For more information, refer to Rendering Effects.

Ambient Light

Ambient light is uniform throughout the scene. It radiates in every direction, having no specific origin and casting no shadows.

Ambient light is useful for scene building, but you will want to turn it down or even off for rendering, since it tends to reduce the feeling of depth by washing out shadows and contrast. Instead, concentrated light sources (from specific lights) bring out shadows and highlights and emphasize your subject's form and surface features.

Note A properly placed distant light is actually more effective than ambient light for simulating a daylight scene.

Specific Lights

Specific lights give you the greatest amount of control over your lighting, especially when you set properties such as color, brightness, and shadow strength.

Use Carrara's specific lights to light your scene for mood and composition, and to give your rendering a “sense of place.” The types of specific lights differ in how much and in what direction they radiate.

  • A bulb lightemanates from a single point and casts light evenly in all directions, like a naked bulb in a lamp.

Bulb light.

  • A spot light emanates from a single point and casts light in a specific direction. It works the same way as a stage spotlight by making what appears in the light the center of attention.

Spot light.

  • A distant light source's position is conceptually outside of the scene's universe, although you may choose to place the shape representing its direction inside the working box. The rays are parallel as they enter your scene and they affect all objects. An example of distant light is the way the sun lights the earth..

Distant light.

Viewing Lighting Effects

You can quickly view your lighting effects using the Test Render tool to preview lighting and shading effects.

Use the Test Render tool to check lighting effects.

To view the entire image,, use the Render room. For details, refer to Rendering

Lighting Concepts

This section explains basic lighting concepts. If you are already familiar with the subject, you may skip this section. If you want more detailed information, the techniques given in most standard reference books on lighting and photography can be applied in Carrara.

A good set of lighting conditions is an important step toward creating high-quality artwork. The same scene rendered under varying light can provide strikingly different results. For example, rendering with all lighting at zero brightness is like taking a photograph–without a flash–in the bottom of a coal mine. Conversely, too much lighting washes out subtle effects.

Three-Point Lighting

Three-point lighting is the classic way to place lights. It provides illumination while preserving shadows and the illusion of depth.

Place two lights at 45° angles to the front of your scene. Make one of these a key light. This is the main source of illumination and strong shadows. Make the other a fill light, which softens the shadows and supplies the mid-tones.

Three-point lighting.

It is also a good idea to color one of these lights warm and the other cool–which one you color warm and which cool depends on the mood and effect you want to achieve. To simulate outdoor light, choose a cool color for the key light; to simulate indoor light, choose a warm color for the key light.

Set a backlight behind your subject to separate it from the background, adding a feeling of depth. If you want to create the effect of light creeping over the subject's features, elevate the light slightly.

The results of three-point lighting.

Other Lighting Arrangements

Here are some of the effects of different light placements.

Frontlighting is placing a light source in front of your subject. This allows clear rendering of details and colors, but reduces shadows and depth.

Frontlighting.

Sidelighting creates dramatic light-and-shadow effects. If you don't want some objects to be completely obscured by shadows, you can place a softer fill light in the scene on the opposite side of the subject from the sidelight.

Sidelighting.

Backlighting is placing a light source behind your subject. This creates silhouettes. You can combine backlighting with spots set at the side or front of the subject to cast shadows from behind while brightly illuminating a small area, such as a face.

Backlighting.

Bottomlightingis placing a light source below your subject. Like backlighting, this also creates silhouettes. It can be very effective if you are lighting a transparent subject. However, if you want to show more detail, add a fill light above your subject.

Bottomlighting.

Creating a New Light Source

A new light appears in the scene as a colored object that points toward the center of the universe.

A new light in a scene.

Lights are objects with projections, just like cameras and modeled objects. You can move the light as you would any other object. You'll learn about special features for moving and orienting cameras later in Positioning and Aiming Lights.

In the Hierarchy, lights are listed as numbered light objects. You can rename a light just as you can any object. If you set up several lights, you can name them according to their position and type to make it easier to select the light you want. For information on naming objects, refer to Using the SequencerTray.

You create specific lights in the Assemble or Storyboard room. All the light tools appear off a single pop-up menu.

To create a new light source:

  1. Choose the type of light you want from the Create Light tool pop-up menu.

Click and hold the Light tool to view the light options.

  1. Click in the scene window where you want to place the light.

You can also choose Insert menu> (Type of) Lightto add a light at the center of the universe and then drag it to any position you like.

If you want to create a light with the same settings as an existing light, select the existing light, then choose Edit menu> Copy and Paste, or Edit menu> Duplicate.

After creating a light, you can change its properties.

Tip To make a light easier to see (or see around), you can change its scale using the Scale control in Properties tray: Motion tab: Transform panel as you would any other object. This does not affect the brightness of a light or any other light characteristics.

Setting Light Properties

Once you have created a new light, you can specify its type–distant, bulb, or spot–and then set its options in the Properties tray. You can use the light controls at any time to adjust the settings of a selected light.

Note You can also use these controls to adjust the default distant light.

To set a light's properties:

  1. Select the light.
  2. Display the Properties tray: General tab: Lightpanel.
  3. Choose the type of light you want. When you change the light type, the panel displays the parameters appropriate to that type.

Setting Common Light Characteristics

The characteristics of color, brightness, and shadow control are common to distant, bulb, and spot lights.

To set common light characteristics:

  1. Display the Properties tray: General tab: Lightpanel.

Common light characteristics.

  1. Adjust the controls as appropriate:
  • Brightness sets the light's brightness. The color chip launches the Carrara color picker, which you can use to set a color for the light.
  • Casts Shadows makes the light cast shadows.
  • Shadow Intensity sets the intensity of shadows. A lower setting creates weaker shadows. By default, all lights except ambient light cast shadows. Shadows appear only in renderings. Use the Test Render tool or render the image to view the changes.

For more control over shadows, refer to Shadow Options.

Setting Distant Light Direction

No matter where you position a distant light in your scene, it behaves as if the source is a distant object, sending parallel rays into your scene. To change the direction of a distant light, change the orientation of the light.

To set the direction of a distant light:

  1. Select the distant light arrow.

The Distant Light is represented as an arrow in the scene window.

  1. Use the Rotate tool to point the arrow in the direction in which you want the rays to shine.

The Rotate tool.

Tip As with ambient light, you can use a distant light to soften the shadows cast by other light sources. Position a distant light above your scene, then experiment with light settings to diffuse the shadows from the other lights.

Setting Bulb Light Characteristics

You can move bulb lights anywhere in the workspace with any of the positioning features, including the Selection tool, Rotate tool, and The positioning controls in the Properties tray: Motion tab: Transform panel. Because bulb lights shine equally in all directions, you do not need to aim them.

Bulb light controls appear in the Properties tray: General tab: Light panel.

To set bulb light characteristics:

  1. Display the Properties tray: General tab: Light panel.
  2. Enter a value in the Range field. The units of measure are those currently set in file preferences.
  • Range is the distance from the light itself to the point where the light disappears.

The bulb light range is the distance from the light to the point where the light disappears.

  1. Drag the Range Falloff slider to set a percentage.
  • Range Falloff determines how the brightness of the light diminishes toward the edge of its range. A falloff of 10% means that the light has full intensity from the source through 90% of its range, then decreases linearly to the end of the range.

All these parameters interact with each other. For example, using a soft-colored light with a low brightness setting may generate a result similar to a darker-colored light with a higher brightness setting. However, animating the individual parameters produces different results.

Note You may also use the Direct Manipulation controls to set these features. Refer to Controlling a Bulb Light Directly.

Setting Spot Light Characteristics

Spot lights appear in the scene window. You can move them anywhere in the 3D workspace and change their direction with any of the positioning and orientation features, including the Selection tool, the Rotate tool, and the Properties tray: Motion tab: Transform panel controls.

To set spot light characteristics:

  1. Display the Properties tray: General tab: Light panel.
  2. Drag the Half Angle slider to set a percentage.
  • Half-angle is the angle of the radius of the cone. A narrow angle creates a beam like that of a spot light. A wide angle creates a beam like that of a floodlight.

The spot light half-angle changes the diameter of the light cone.

  1. Drag the Brightness slider to set the brightness of the light.
  2. Click the color chip to select the color of the light from the color picker.
  3. Drag the Angular Falloff slider to set a percentage.
  • Angular Falloff is how the brightness of the light diminishes toward the edge of the light cone. A falloff of 10% means that the light has full intensity from the center to 90% of the radius of the light cone, then decreases linearly to the edge of the cone.

As you increase the Angular Falloff, you decrease the area that is 100% bright.

  1. Enter a Range value. The units of measure are those currently set in File menu> Preferences> Units.
  • Range is the distance from the light itself to the point where the light has no effect.

The range of the spot light is distance between the light's point of origin and the point where the light has no effect.

  1. Drag the Range Falloff slider to set a percentage.
  • Range Falloff determines how the brightness of the light diminishes toward the edge of its range. A falloff of 10% means that the light has full intensity from the source through 90% of its range, then decreases linearly to the end of the range.
Note You may also use the Direct Manipulation controls to set these features. Refer to Controlling Lights Directly.

Setting Ambient Light Characteristics

Ambient light characteristics are scene settings. Choose color and brightness to achieve the effect you want. Remember, a strong ambient light level washes out the effects of your specific lights.

Tip Use a warm color to simulate indoor light and a cool color to simulate outdoor light.

To set ambient light:

  1. Choose the scene in the Properties tray: Findlist.
  2. Display the Properties tray: Effects tab: Ambient panel.
  3. Click the color chip and select a color from the color picker.

Use the Effects tab to set the ambient light controls.

  1. Enter a percentage for the brightness.
  2. To view your changes, use the Test Render tool.

Setting Tube Light Characteristics

To set tube lights:

  1. Set Brightness to control the intensity of the light.
  2. Use the Color chip to control the color of the light when the Color option is set to Light Color.
  3. Use Range to control how far away the light illuminates. While, Range Falloff controls how the brightness decreases at the end of its range, Fall Off Rate controls how the light goes from full brightness to zero.
  4. Use Cast Shadows to turn shadows on and off, and Shadow Intensity to set how dark the shadows are.
  5. Use Length to set the length of the tube light.

Setting Shape Light Characteristics

Setting shape lights:

  1. Set Brightness to control the intensity of the light.
  2. Use the Color chip to control the color of the light when the Color option is set to Light Color.
  3. Set the following controls: Range controls how far away the light illuminates. While Range Falloff controls how the brightness decreases at the end of its range, Fall Off Rate controls how it goes from full brightness to zero.
  4. Use Cast Shadows to turn shadows on and off, and Shadow Intensity to set how dark the shadows are.
  5. Use Width and Height to set the size of the light.
  6. Use Shape to specify the shape of the light.

Making Anything Glow

Anything Glows is a light that allows you to use any object as a source of light. Anything Glows helps you create glowing objects that really cast light, realistic lighting effects, and it allows you to control many lights at the same time using Master Lights.

To make any object glow:

  1. Set Brightness to control the intensity of the light.
  2. The Color chip controls the color of the light when the Color option is set to Light Color.
  3. Set Range to control how far away the light illuminates. While Range Falloff controls how the brightness decreases at the end of its range, Fall Off Rate controls how it goes from full brightness to zero.
  4. Use Cast Shadows to turn shadows on and off, and Shadow Intensity to set how dark the shadows are.
  5. Set Color to determine what drives the light's color.
  6. Set Item to the name of the object to use for the light source. If the name of the object is not unique in the scene, you may not get the results you expect. If Anything Glows can't match the name, it won't emit any light.
  7. Use Origin to control the starting point of the light rays.
  8. Set the following mesh controls:
  • Fidelity controls how detailed a mesh Anything Glows will use when Origin is set on Vertex or Facet. The higher the Fidelity, the more detailed the mesh.
  • Standoff specifies how far away from the mesh the light ray starts. This keeps the Anything Glows light ray from intersecting the rendered mesh and causing unwanted shadows.
  • Minimum Distance controls how far away from the mesh a point must be to be illuminated. This keeps Anything Glows from illuminating its own mesh.
  • Resynch Position or Mesh tells Anything Glows you have moved the object or changed the geometry. If you render, make a change, and then want to render again, press this button to tell Anything Glows to synch up with your object.
Tips and Tricks
  • Anything Glows 2 doesn't require that the Cast Shadows option be turned off for Anything Glows Items, but some scenes look better with it that way.
  • If you are far away from the object Anything Glows is using, turn Origin to Bounding Box or Vertex. Turn it back to Facet when you get close enough to see the details.
  • If you are far from the object Anything Glows uses, set the Color to Light Color instead of Object Color or Object Glow.
  • On rough surfaces (heavy bump) or surfaces with lots of color changes, you often won't be able to tell the difference between an Origin of Facet or Vertex. If your light only illuminates those kinds of surfaces, use Vertex, it's much faster.
  • Gels are a great way to control Anything Glows output without changing the shader's color or glow. Putting a slightly blurred version of the objects glow map in Anything Glows' gel is a great way to simulate monitors or TV screens.
  • Set the Fidelity to the lowest setting that give the results you need. The lower the Fidelity, the faster Anything Glows renders.
  • Use Light Smart Sampling on your render settings. Anything Glows is about three times faster with Light Smart Sampling on and most of the time you won't be able to tell the difference in the resulting image.

Setting up Environmental Lighting

To activate Environment Lighting, select an object in the 3DView and click Edit menu> Environment Lighting.

Setting environmental lighting options:

  1. Mesh Fidelity controls how detailed a mesh Anything Glows will use when Origin is set on Vertex or Facet. The higher the Mesh Fidelity, the more detailed the mesh.
  2. Quality specifies how many lights will be used. At 1 Anything Glows will use 1 light for every 10 facets, at 6 Anything Glows will use 1 light for each facet.
  3. Color determines what drives the light's color.

Environment Lighting works by breaking up the mesh into little chunks and assigning an Anything Glows light to each chunk. The plane primitive, which only has two facets regardless of the Fidelity, makes a poor emitter. To create a flat emitter, build a grid in the Vertex Modeler.

Setting Master Lights Characteristics

To set Master Lighting options:

  1. Apply To controls which types of lights will be changed, while Apply specifies which settings will be changed.
  2. Brightness controls the intensity of the light. As Percentage of Current Value will multiply the light's current value times the Brightness setting to get the light's new value.
  3. The Color chip controls the color of the light when the Color option is set to Light Color.
  4. Range controls how far away the light illuminates. Range Falloff controls how the brightness decreases at the end of its range.
  5. Use Cast Shadows to turn shadows on and off, and Shadow Intensity to set how dark the shadows are.
  6. Default will restore the Master Light options to the default values.
  7. Last Run will restore the Master Light's settings to the settings from the last time you clicked OK.

Positioning and Aiming Lights

You can position lights as you would any object in your scene–by dragging a light or its projection, or numerically by using the controls in Properties tray: Motion tab: Transform panel.

Note You can also use the Direct Manipulation controls to move and aim lights. Refer to Controlling Lights Directly.

For information on positioning and orienting lights numerically, refer to Arranging Objects.

Positioning Lights by Dragging

You can drag lights as you would any other object in your scene.

To move a light:

  1. Select the light.
  2. Select the Selection tool.
  3. Drag the light to where you want it.

The light moves parallel to the active plane.

To move the light perpendicular to the active plane, hold the Option/Alt key while you drag.

You can also drag one of the light's projections to position the light on that plane.

Drag a light's projection to position it on the plane where the projection lies.

Pointing a Light at an Object

Carrara provides other methods of aiming lights, including the Point At command, the Point At modifier, and the Direct Manipulation controls.

Tip To direct a light to a particular area in your scene, create a temporary object for the light to point at, then delete the object. Remember that the light points at the hot point of the selected object.

The Point At Command

The Point At command lets you point a light directly at an object.

To point a light at an object:

  1. Hold down the Shift key and select both the light and the object you want to point it at.

You may select multiple lights, but only one object.

  1. Choose Edit menu> Point At.

Carrara reorients the light to point at the hot point of the selected object.

The Point At command does not link the light to the object. That is, if you move either element, the light no longer points at the object. If you want to maintain the distance between a light and the object it points at, group them. For more information, refer to Grouping Objects. If you want the light to follow the object, apply the Point At modifier, described in the next section.

The Point At Modifier

The Point At modifier aims a light at an object. If the object moves, the light automatically reorients itself to point at the object in its new position.

To have a light follow an object:

  1. Select the light you want to use.
  2. On the Properties tray: Modifierstab, click the + sign to expand the list and choose Point At.

The Point At controls appear.

Use the Point At controls to set the Point At modifier.

  1. Adjust the Point At controls as appropriate:
  • Towards Enter the name of the target object–the one you want the light to follow. Enter the name exactly as it appears in the Hierarchy area of the Sequencer. (The text field is case-sensitive.)
  • Axis Leave this option as is. The axis option sets which axis of the object should point at the target. For a light, you only want to use the axis that emits the light.
  • Enabled Check this box to turn on the Point At modifier.

When you move the target object, the light reorients to point at it.

Controlling Lights Directly

The Direct Manipulation controls provide an on-screen description of a light's aim and properties. You can drag a light's control handles to change light properties.

To display the Direct Manipulation controls on a light:

  1. Select a light.
  2. Display the Properties tray: General tab: Light panel.
  3. Click the Direct Manipulation button to display the control handles on the selected light.

Use the Direct Manipulation button to display the selected light's Direct Manipulation controls.

The controls appear as a set of wires with handles at certain points. Each handle represents a control you can drag to set properties.

The Direct Manipulation controls for a spot light are shown below. The appearance and number of these controls depend on the type of light you have selected.

The control handles for a spot light. You can drag these handles to move and aim a spot light and to set its properties.

Directly Controlling Spot Lights

You can use the Direct Manipulation controls to change all the characteristics of a spot light except color.

To aim the spot light:

  • Drag the control handle in front of the light cone.
  • The handle moves parallel to the active plane.
  • Hold down the Option/Alt key to drag the handle perpendicular to the active plane. You can drag the handle out, extending it all the way to the point you want to aim at. The wire shows the direction of the light beam.
  • You can also drag the target handle on one of the light's projections to aim the light on that plane.
  • The light rotates to aim where you place the handle.

c14-31.jpg

Drag the spot light's Aim control to set the point the light aims at.

To move the position of the spot light:

  • Drag the handle behind the light cone.

c14-32.jpg

Drag the spot light's Position control to move the light along a given plane.

You can also drag the handle on one of the light's projections to position the light on that plane.

The light moves to the new position and orients itself to point at the target.

To check the light cone diameter at a given point:

Drag the handle on the direction wire, centered in the ring.

Drag the Light Cone Cross-Section control to help you visualize the diameter of the light cone in the scene window.

The ring around the direction wire describes the cone diameter at that point. Notice that as you drag the handle closer to the target, the ring expands.

Note The Cross-Section control is intended to help you visualize the diameter of the light cone at different ranges. It does not change any of the light's properties.

To change the spot light's half angle:

Drag the handle on the ring perimeter.

Drag the Half Angle control to adjust the spot light's half angle.

Tip If you have the Properties tray: General tab: Light panel displayed, you can see the effect of your changes in the preview and settings.

To change the Angular falloff:

Hold down the Cmd/Ctrl key while dragging in toward the center of the ring.

Drag the Angular Falloff control to set the spot light's angular falloff.

Tip If you have the Properties tray: General tab: Light panel displayed, you can see the effect of your changes in the preview and settings.

To change the brightness:

Drag the handle on the wire that extends from the light perpendicular to the direction wire.

Drag the Brightness control to set the spot light's brightness.

Drag away from the light to increase the brightness, or towards the light to decrease brightness.

Controlling a Bulb Light Directly

On a bulb light, brightness is the only control available with Direct Manipulation.

The bulb light's brightness control.

To change a bulb light's brightness:

Drag the handle on the wire that extends sideways from the bulb light.

Tip If you have the Properties tray: General tab: Light panel displayed, you can see the effect of your changes in the preview and settings.

Shadow Options

Objects block light and, therefore, cast shadows on other surfaces. For each light, you can choose between two methods to calculate shadows: Raytraced shadows and Shadow buffer shadows. Each of those methods allows you to create two types of shadows:

Hard shadows have sharp edges. The transition from complete shadow to full light is immediate.

Hard shadows.

Soft shadows create an obscurity at the shadow edge. The shadow has a soft transition between complete shadow and full light.

Soft shadows.

To set shadow options for a light:

  1. Select the light you want to set.
  2. On the Properties tray: Effects tab: Shadow panel, choose the method you want to calculate your shadows.

Raytraced //shadows//

The Raytraced shadow is the default. It is the most accurate method for calculating shadows. It will create very nice soft shadows but tends to be slow with this type of shadow.

You can adjust the following settings:

  • Enable Soft Shadows will create soft shadows instead of the simple hard shadows (Note that soft shadows take a quite a bit more time to render).
  • Light Radius only affects soft shadows. It determines how big the light source is and thus how soft the shadows will be. Note that you need to take into account the distance of the light to the scene. A light that is far away will only create soft shadows if the radius is very big (this is especially true for distant lights that are always far from the scene).
  • Quality only affects soft shadows. It determines how many rays are used to evaluate the shadows. It recommended to use the lowest quality setting that works with your scene and to only increase it if there is a visible artifact.

Shadow Buffers

Shadow buffers should be mostly used to create soft shadows. They are usually much faster than raytraced soft shadows, especially for complex scenes. However they are not as accurate as Raytraced Soft Shadows and do not let light go through objects (even when the Light through transparency option of the renderer is checked).

To set the Shadow buffers options:

  1. Select a light.
  2. On the Properties tray: Effects tab: Shadow panel, choose Shadow Buffer.
  3. Set shadow buffers controls.
  • Resolution determines the quality of the shadow effect. A higher resolution uses more memory.
  • Blur Size increases the area of softness. You need a higher setting here if you have set a high Resolution.
  • Bias controls the placement of the shadow. Increase this setting if your objects are self-shadowed. Decrease this setting if shadows appear too far away from the objects themselves.

Using Gels

You can place an image as a mask or transparency in front of a light to project complex patterns and images on your scene. The image you place in front of the light is called a gel. Gels are typically used on spot lights.

If the gel is a 1-bit image, it becomes a mask. White regions of the mask transmit the light, and black regions block it. Bitmap gels can create intricate effects, such as the shadow of a chain-link fence, or the dappled shade under a tree.

A 1-bit gel used with a spot light.

Grayscale or color images create transparencies when used as gels. Their image is projected into your scene, just as a slide projector sends an image across the room. With a color image, you can achieve many effects, such as sunlight filtering through a stained glass window.

A grayscale gel.

Blinds, Gradient, and Formula are built-in gels. You may also load a texture map or movie to use as a gel. An 8-bit gel will probably provide all the color you need.

As you adjust the settings for these gels, a preview displays at the right. Specific blend controls are described later in this chapter.

Note Gels have no effect on distant lights.

To place a gel on a light:

  1. Select a light. Gels are generally used on spot or bulb lights. Your choice depends on the effect you want.
  2. On the Properties tray: Effectstab: Gel panel, choose a type of gel:
  • None is the default. The light has no gel.

The other options are discussed in the following sections.

Blinds Options

The Blinds option creates horizontal or vertical stripes such as venetian blinds or prison bars.

Select Blinds to create a gel that projects stripes onto an object.

To set blinds options:

  1. On the Properties tray: Effects tab: Gel panel, choose Blinds.

The Blinds controls.

  1. Set the Blinds controls:
  • Horizontal Count sets the number of horizontal slats.
  • Vertical Count sets the number of vertical slats.
  • Horizontal Size sets the width of the vertical slats. The width is expressed as a percentage of the gel frame.
  • Vertical Size sets the height of the vertical slats. The height is expressed as a percentage of the gel frame.

Formula Options

The Formula option uses a mathematical formula to create colors and patterns in the gel. You can devise your own formula to create a new pattern.

Select Formula to create a gel that projects a pattern onto an object.

To select a formula for the gel:

  1. On the Properties tray: Effects tab: Gel panel, choose Formula.

The Formula controls.

  1. If the current formula uses Parameter values, you can adjust them to change the formula result.
  2. If you want to edit the formula or create your own, click More. The formula editor appears.

Carrara uses the Formula Editor in several places. Use of the editor is common, but the type of formula you're creating determines the valid input and output variables. Refer to Using Formulas in Carrara for details on using the Formula Editor.

Gradient Options

The Gradient option uses a blend of two colors as a gel. A gradient gel can be vertical or circular.

Select Gradient to create a gel that projects a pattern containing color transitions onto an object.

To set gradient options:

  1. On the Properties tray: Effects tab: Gel panel, choose Gradient.

The Gradient controls.

  1. Set the Gradient controls: Horizontal, Vertical, or Circular sets the gradient pattern. Click the top color chip to select a start color, and the bottom color chip to select an end color.
  • For a Horizontal gradient pattern, the start color appears on the top and the end color on the bottom.
  • For a Vertical gradient pattern, the start color appears on the left and the end color on the right.
  • For a Circular gradient pattern, the start color appears on the inside and the end color on the outside.

Map Options

The Map optionuses a bit-mapped image file as the gel. This is the best choice when you want specific images in the gel.

Select Map to create a gel that projects an image onto an object.

You can use any 2D graphics program to create an image for the gel. You might scan a photograph and use filters to accentuate or nominalize some aspects of the image. The gel does not need to be high-resolution. If you intend to use this gel on a bulb light, create the image at an aspect ratio of 2:1. If you are going to use this gel on a spot or distant light, use an aspect ratio of 1:1.

Save the image file in a format that Carrara supports and in a convenient folder.

For a list of the image file types that Carrara supports, refer to Importing 3D Objects.

To load a map image as a gel:

  1. On the Properties tray: Effects tab: Gel panel, choose Map.

The Map controls.

  1. Click the Folder icon to display the Open dialog.
  2. Use the Open dialog to locate and open the map image you saved.

A preview appears on the Gel panel with the image's dimensions given in pixels.

To set map controls:

  1. Click the directional buttons next to the Folder icon to change the image's orientation.
  2. Choose among the following options:
  • Tile makes the image repeat. Use the Horizontally and Vertically sliders to set the number of tiles in each direction.
  • Seamlessly smoothes the transitions between tiles
  • Invert Color inverts the image's colors.
  • Interpolate smoothes out textures for zooming. This option works best with low resolution textures, and may slow the rendering.
  • Brightness sets the image's brightness.
Note You can use Map options to place movies. To do this, load movie images as a gel, just as you would load map images.

Light Effects

You can add effects to your scene that simulate the results obtained from photographic cameras and special lighting. You apply light effects on a light-by-light basis.

Note Light effects are post-render filters. Although they simulate adjustments to your lights and cameras, they do not actually change any of your light or camera settings.

Using the preview

All the light effects dialogs have a rendered preview that helps you to adjust the settings of a specific effect.

You can use the zoom and pan tools at the bottom of the preview to get a better view of the details of the image.

Clicking on the Render button after zooming in will increase the quality of that part of the image you are viewing. To display the full image again, click on the Reset View button.

When you check the Auto Update box, the preview is re-rendered each time you adjust a control, otherwise you will need to click the Render button after changing one or more controls.

CrossScreen

The CrossScreen effect adds a glow and star-like rays to every visible light source.

Use the CrossScreen effect to make a star-like effect.

The light source must be visible from the camera to produce an effect. It must be within the production frame and not hidden behind or inside an object.

To set CrossScreen options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Effects panel, check the Enable CrossScreen box, then click Edit. The CrossScreen dialog appears.

The CrossScreen controls.

  1. Set the CrossScreen options:
  • Glow Size sets the diameter of the glow.
  • Star Size sets the star radius.
  • Angle rotates the stars around the light source center.
  • Branches sets the number of rays.
  • Intensity sets the effect intensity.

Glow

Glow simulates a photographic filter by adding a glow around every visible light source. The effect of the glow depends on the light's position, color, and intensity.

Glow created a visible glow around light sources.

The light source must be visible from the camera to produce a glow. It must be within the production frame and not hidden behind or inside an object.

To set Glow options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Glow box, then click Edit. The Glow dialog appears.

The Glow controls.

  1. Set the Glow options:
  • Glow Size sets the diameter of the glow.
  • Intensity sets the strength of the glow.

Nebula

The Nebula effect adds multicolored streaks around every visible light source.

Use the Nebula effect to simulate the light streaks produced by a bright light pointed at the camera.

The light source must be visible from the camera to produce a nebula effect. It must be within the production frame and not hidden behind or inside an object.

Note Render on a dark background to see the Nebula effect.

To set Nebula options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Nebula box, then click Edit. The Nebula dialog appears.

The Nebula controls.

  1. Set the Nebula options:
  • Radius 1 sets the streaks' starting radius.
  • Radius 2 sets the streaks' ending radius.
  • Angle rotates the streaks around the light source center.
  • Branches sets the number of streaks.
  • Thick makes the streaks thicker.
  • Intensity sets the streak intensity.

Pulsator

Pulsator adds dotted streaks around every visible light source.

Use the Pulsator effect to simulate the dotted streaks of light produced by a flashing light.

The light source must be visible from the camera to produce a pulsator effect. It must be within the production frame and not hidden behind or inside an object.

To set Pulsator options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Pulsator box, then click Edit. The Pulsator dialog appears.

The Pulsator controls.

  1. Set the Pulsator options:
  • Size sets the streak radius.
  • Thickness sets the streaks' thickness.
  • Angle rotates the streaks around the light source center.
  • Intensity sets the streak intensity.

Stars

Stars adds a star around every visible light source.

Use the star effect to add starry streaks around objects.

The light source must be visible from the camera to produce a star effect. It must be within the production frame and not hidden behind or inside an object.

To set Stars options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Stars box, then click Edit. The Stars dialog appears.

The Stars controls.

  1. Set the Stars options:
  • Size sets the stars' radius.
  • Thickness sets the stars' thickness.
  • Angle rotates the stars around the light source center.
  • Branches sets the number of rays.
  • Diffraction splits the stars into rainbow colors.
  • Intensity sets the stars' intensity.

VarioCross

The VarioCross effect adds two streaks around every visible light source.

Use the VarioCross effect to simulate the light streaks produced by distant bright lights.

The light source must be visible from the camera to produce a VarioCross effect. It must be within the production frame and not hidden behind or inside an object.

Note Render on a dark background to see the VarioCross effect.

To set VarioCross options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Effects panel, check the Enable VarioCross box, then click Edit. The VarioCross dialog appears.

The VarioCross controls.

  1. Set the VarioCross options:
  • Size sets the streak radius.
  • Thickness sets the streaks' thickness.
  • Angle 1 rotates the first streak around the light source center.
  • Angle 2 rotates the second streak around the light source center.
  • Diffraction splits the streaks into rainbow colors.
  • Intensity sets the streaks' intensity.

Light Cone

In the real world, light rays are visible when the atmosphere contains small particles of dust or vapor that diffuse light. The Light Cone effect simulates the interaction between light from a spot light and smoke, fog, and dust.

Use the Light Cone effect to produce visible cones of light in your scene.

The Light Cone effect post-processes the rendered picture by adding visible light beams from spot lights. The visible light beams accurately describe the half angle of each spot light in the scene.

To set Light Cone options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Cone panel, check the Enable box, then click Edit. The Light Cone dialog appears.

The Light Cone controls.

  1. Set the Fog options:
  • Use Gel allows you to use any gel on the lights in the light cone effect. Enable this option only if you've applied gels to your spot lights.
  • Gel Buffer Size sets the quality of the gel effect in the light cone. Drag to the right to increase quality of the gel in the light cone.
Note To render textured light rays, the filter pre-processes and stores buffers for each spot light in your scene. High buffer values produce better results, but are costly in rendering time and memory requirements. Don't use values higher than 200 unless you have a powerful computer and are working on high-resolution pictures. Always start with a small value.
  1. Set the Turbulence options:
  • Enable produces swirls in the fog medium.
  • Animate makes the fog medium change over time. This option slows down the rendering. Enable it only when creating animations.
  • Turbulence Scale sets the mean size, in inches, of the wreath of smoke. This slider ranges from 0.01 inches to 489 inches.
  • Lumpiness sets the contrast level in the wreath of smoke.
  1. Set the 3D Shadows options:
  • Enable makes objects in the light cone cast shadows in the fog.
Note 3D Shadows is a powerful but costly effect. The filter must pre-process and store buffers for each spot light in your scene. High values are costly in rendering time and memory requirements. Do not use values higher than 200 unless you have a powerful computer and you are working on high-resolution pictures. Always start with a small value.
  • Shadow Buffer Size sets the quality of the 3D shadow effect in the light cone.
  1. To change the color of the fog, click on the color chip. Carrara opens the system color picker so you can choose a color.

The color of the visible light cone results from the interaction of the light's color and the fog color. Yellow light in a white fog produces a yellowish light cone. In a blue fog, yellow light produces a green cone.

  • Intensity sets the strength of the light cone effect.

Light Sphere

The Light Sphere simulates the interaction between light from a bulb light and smoke, fog, and dust.

Use the Light Sphere effect to add a ball of light in your scene.

The Light Sphere effect post-processes the rendered picture by adding a light sphere around each bulb light.

To set Light Sphere options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Light Sphere panel, check the Enable box, then click Edit. The Light Sphere dialog appears.
  3. Set the Light Sphere options:
  • Enable produces swirls in the fog medium.
  • Animate makes the fog medium change over time. This option slows down the rendering. Enable it only when doing animations.
  • Turbulence scale sets the mean size, in inches, of the wreath of fog.
  • Lumpiness sets the contrast level in the wreath of fog.
  • Intensity changes the strength of the light sphere effect.

The Light Sphere controls.

Lens Flare

Lens flares are reflections of a strong light source on the various components of the lens. Flare color and size depend on the kind of glass and shape of each lens component.

Lens Flare simulates the reflections produced by a very strong light source.

The Lens Flare effect adds lens flares to one or more light sources in your final rendered image, according to their positions, colors, and intensities.

To get a lens flare effect, a light source must be visible to the rendering camera. The light source must be within the production frame and not hidden behind or inside another object–even if it is a transparent object. A spot light must be aiming toward the rendering camera to produce a lens flare. The camera must be within the light cone.

The Lens Flare effect uses three parameters to render the effect: Light source color, Light source intensity, and Lens Flare intensity.

To get brighter lens flares, use brighter light sources. It also helps to lower the ambient light and use darker backdrops.

Note If you are rendering with a white background, you won't see the result of the lens flare effect. Select a dark color for the background.

To set Lens Flare options:

  1. Select the light to which you want to apply an effect.
  2. In the Properties tray: Effects tab: Lens Flare panel, click Edit. The Lens Flare dialog appears.

The Lens Flare controls.

  1. Set the General controls:
  • Settings sets the type of lens flare. Choose a Carrara preset and edit it as needed. If you choose None, there is no lens flare.
  • Brightness controls the overall intensity of the entire flare.
  • Colored renders the lens flare in color. When disabled, the lens flare is rendered in grayscale.
  1. SetThe Light Glow controls. Enable the option you want to apply, then click the color chip to choose a color:
  • Color enables and sets the color of the light itself.
  • Glow enables and sets the color of the glow immediately surrounding the light.
  • Inner enables and sets the color of the inner glow gradation.
  • Outer enables and sets the color of the outer glow gradation.
  • Intensity sets the strength of the light glow effect.
  • Scale sets the size of the light glow.
  1. Adjust the Streaks controls. This section sets the appearance of the streaks you see when looking at a light (such as a car headlight or street lamp). You can animate all the attributes of a halo, but you cannot change the type of streaks over time in an animation.
  • Type sets the streak type. Choose a Carrara preset or choose None.
  • Intensity sets the strength of the streak effect.
  • Scale sets the size of the streaks.
  • Rotation rotates the streaks for animated effects such as a photon torpedo, which spins as it moves.
  • Color sets the color of the streaks.
  1. Set the Halo controls. This section sets the appearance of the ring you see when looking directly at a light source. You can animate all the attributes of a halo, but you cannot change the type of halo over time in an animation.
  • Type Choose Filled for a solid color ring, or Lenticular for a ring in the full spectrum of the rainbow that gradually fades in intensity. Choose a color for a Filled halo, or a starting color for a Lenticular halo.
  • Intensity sets the strength of the halo effect.
  • Scale sets the size of the halo.
  1. Set the Reflection controls. This section sets the appearance of the set of circles that emanates from the light on a line toward the camera lens. You can animate all the attributes of a halo, but you cannot change the type of reflections over time in an animation.
  • Type sets the reflection type. Choose a Carrara preset or choose None.
  • Grayscale turns off color for the reflections.
  • Intensity sets the strength of the reflection effect.
  • Scale sets the size of the reflection.
  1. Click OK when you are done.