User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

DAZ Studio 3

Product: DAZ Studio
Build: 3.0.1
Version Released: Beta June 1, 2009

Product Information

  • For the User's Documentation for this product, click here.

New Features

Note: Not all features are available in all versions of DAZ Studio. Please check the version you have installed if you are not seeing a particular plug-in or feature available.

  • Figure Mixer -The Figure Mixer allows you to load similar generation figures and create new blended figures. This is accomplished by adjusting sliders to blend the figures as a percentage of each figure loaded. Once the figures are blended, the final figure can be frozen, then exported as a CR2 file or saved as a Studio scene file.
  • Map Transfer - The Map Transfer tool is used to transfer maps from one figure to another, if the figures have the same number of vertices, etc., for example, Victoria 4 and Michael 4. This allows you to convert a V4 texture to one that either M4 can use or V4 with the M4 UV Set applied.
  • Morph Follower - The Morph Follower is used to move active morphs from a base figure to any other item that has been fit to the base figure. This allows a conformed item, such as clothing or hair, to approximate the effects of the morph on the base figure in its own geometry. While the process is not perfect, it can solve many poke through issues and in many cases leave minor, or no, poke through to be corrected.
  • Render Album - While this is not a new feature, it is now included as an integral part of DAZ Studio and no longer available as a stand-alone product. The Render Album provides a means of storing recent image renders in an album format which can then be loaded into the Render Editor to perform various editing functions on the image. The editor provides options for blending two images, color adjustment, image comparison, and applying filters without having to open a separate paint program.
  • Shader Baker - The Shader Baker makes it possible to bake many of the properties of a shader down to a texture map. While the results will not always look exactly like the original shader, this feature will allow you to roughly see what the content will look like in its final render. If the baked textures are good enough, they can also be exported for use in other applications, such as for games, with no visible loss in quality.
  • Shader Builder - The Shader Builder is a plug-in for DAZ Studio 3.x that provides a data flow diagram (aka shader graph) type of visual development environment for generating RenderMan® Shading Language (RSL) shaders. The intended audience for this tool is a [aspiring] shader developer, being someone who is familiar with or wants to become familiar with RSL and the shader development process. The goal of Shader Builder is to make the process of creating RSL shaders and the scripts that build the interface between them and DAZ Studio, easier and less prone to syntactical errors.
  • Shader Mixer - The Shader Mixer uses predefined bricks like a node network. Connecting the various bricks will create differing results in the new shader. Shader Mixer includes a range of basic bricks like: [image] map, math, noise, random, lighting models, and volumes.
  • aniMate+Lite - This is a light version of the aniMate Plus version available in the DAZ Online Store. It increases the capabilities of the DAZ Studio animation timeline.
  • 64-Bit - Availability of a 64-bit version of DAZ Studios Advanced for Windows. The Mac version is still under development. Not available in the free version.
  • Normal Maps - The ability to render with normal maps which are more defined than bump maps allowing bump settings to render more accurately.
  • 3Delight Update - This update allows improved performance, memory management improvements, and opens additional capabilities such as for area lights, glow applied to objects, and advanced shaders.
  • Selection/Bounding Box Display - Addition of preference settings allowing changes to how bounding boxes are displayed.
  • Visual Helpers for Cameras and Lights - Addition of tools from Dreamlights allowing users to set options for displaying the camera and light wireframes which provides visual cues for placing objects within the view of the camera or influence of the light.
  • DAZ COLLADA Import/Export - Addition of a DAZ COLLADA import/export option which includes specific information about the scene which provides a more accurate exchange of scenes between DAZ Studio and Carrara.
  • Ability to create and manage Content Sets in the Preferences.
  • Updates to OBJ Import/Export options with specific settings for each preset and ability to change XYZ orientation on import or export.
  • Addition of an “Always on Top” option on the View menu.
  • Updates to the Help menu.
  • Update to new version of 3Delight allowing more render options.
  • History panel added to progress dialogs.
  • Render Level option for Sub-Division Surfaces removed and render level now controlled by the Smoothing option.
  • Addition of Edge Interpolation for Sub-D Surfaces.
  • Addition of a Plug-in Registration dialog that can be displayed when DAZ Studio starts in order to remind you to register your plug-ins.
  • Ability to import settings from previous versions of DAZ Studio.
  • Ability to load log file from the Help menu in order to check error messages without having to manually search for the file.
  • Ability to choose location of temporary files.
  • Ability to view scenes in the openGL viewport using lights added to the scene or using the default distant light.
  • Added option in customize dialog to invert the mouse scroll wheel for view port navigation.

Fixed Issues

  • Fixed D-Form and Puppeteer save filters.
  • Fixed memory leak in filters.
  • Fixed weight maps to recalculate properly when changing geometry
  • Parameters tab now remembers previous scroll state for nodes correctly.
  • Tab Bar text now highlights when mouse over again.
  • Welds are now working with conversion to Sub-D.
  • Fixed an issue when rendering to the viewport multiple times.
  • Fixed the possible use of null pointer when removing geometry references.
  • Fixed tab menu to provide the missing “Show All Child Nodes” option.
  • Added missing Michael4.dmc file.
  • Closing the render window during a render will prompt a dialog asking if user wants to cancel the active render.
  • Render windows now close when the main window closes.
  • Fixed an issue that was causing crashes when subdividing a figure with LODs on the Mac.
  • On a Mac, when scrubbing RGB components of a color widget, the value no longer snaps back to the original value when the mouse is released.
  • Fixed an issue in PowerLoader where the product listview would not be displayed in the Advanced tab if it was the 'current' tab upon launch. The user would have to click the Basic tab and then click the Advanced tab again to get the listview to be displayed.
  • Fixed a bug that caused PowerLoader to fail while applying changes made in Modify mode.
  • Fixed an issue that prevented PowerLoader from removing unchecked items in Modify mode.
  • Fixed problem causing Sub-D edge interpolation mode to not be set correctly when copying meshes.
  • Fixed alpha issue in Render Album that made the background color not show in thumbnails.
  • Fixed jumping of progress dialog on Mac when a third button is displayed.

Known Issues

  • AutoHide Feature - Disabled in DAZ Studio v3.0.1. It will be fixed and turned back on in DS v3.0.2.
  • Bryce Wrapper -
    • Bryce will still need DS v2.3.3 installed to run. Since both versions can be installed simultaneously, this should not cause any issues.
  • Content with PowerLoader scripts (V4, M4, Hiro4, Aiko4, The Girl, The Dragon, etc.) will need updated PowerLoader scripts. The old scripts will run, but to be optimized, these pieces of content will need to be re-installed once the scripts are updated and then re-released.
  • .RIB Files - Any .rib files from DS v2.3.3 that have DAZ Studio shaders included will not work properly with the 3Delight render engine unless you first bring the scene into DS v3.0.1 and re-save to a new .rib file.

Refer to Known Issues for older known issues.

Support

Visit our site for further technical support questions or concerns: http://www.daz3d.com/i.x/support

Thank you and enjoy your new products!

DAZ Productions Technical Support
12637 South 265 West #300
Draper, UT 84020
Phone:(801) 495-1777
FAX:(801) 495-1787
TOLL-FREE 1-800-267-5170