User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

What's New, Updated, Resolved, or Known Issues

Feature Additions & Resolved Issues

Current Release - v3.0.1

  • New Features -
    • Figure Mixer -The Figure Mixer allows you to load similar generation figures and create new blended figures. This is accomplished by adjusting sliders to blend the figures as a percentage of each figure loaded. Once the figures are blended, the final figure can be frozen, then exported as a CR2 file or saved as a Studio scene file.
    • Map Transfer - The Map Transfer tool is used to transfer maps from one figure to another, if the figures have the same number of vertices, etc., for example, Victoria 4 and Michael 4. This allows you to convert a V4 texture to one that either M4 can use or V4 with the M4 UV Set applied.
    • Morph Follower - The Morph Follower is used to move active morphs from a base figure to any other item that has been fit to the base figure. This allows a conformed item, such as clothing or hair, to approximate the effects of the morph on the base figure in its own geometry. While the process is not perfect, it can solve many poke through issues and in many cases leave minor, or no, poke through to be corrected.
    • Render Album - While this is not a new feature, it is now included as an integral part of DAZ Studio and no longer available as a stand-alone product. The Render Album provides a means of storing recent image renders in an album format which can then be loaded into the Render Editor to perform various editing functions on the image. The editor provides options for blending two images, color adjustment, image comparison, and applying filters without having to open a separate paint program.
    • Shader Baker - The Shader Baker makes it possible to bake many of the properties of a shader down to a texture map. While the results will not always look exactly like the original shader, this feature will allow you to roughly see what the content will look like in its final render. If the baked textures are good enough, they can also be exported for use in other applications, such as for games, with no visible loss in quality.
    • Shader Builder - The Shader Builder is a plug-in for DAZ Studio 3.x that provides a data flow diagram (aka shader graph) type of visual development environment for generating RenderMan® Shading Language (RSL) shaders. The intended audience for this tool is a [aspiring] shader developer, being someone who is familiar with or wants to become familiar with RSL and the shader development process. The goal of Shader Builder is to make the process of creating RSL shaders and the scripts that build the interface between them and DAZ Studio, easier and less prone to syntactical errors.
    • Shader Mixer - The Shader Mixer uses predefined bricks like a node network. Connecting the various bricks will create differing results in the new shader. Shader Mixer includes a range of basic bricks like: [image] map, math, noise, random, lighting models, and volumes.
    • aniMate+Lite - This is a light version of the aniMate Plus version available in the DAZ Online Store. It increases the capabilities of the DAZ Studio animation timeline.
    • 64-Bit - Availability of a 64-bit version of DAZ Studios Advanced for Windows. The Mac version is still under development. Not available in the free version.
    • Normal Maps - The ability to render with normal maps which are more defined than bump maps allowing bump settings to render more accurately.
    • 3Delight Update - This update allows improved performance, memory management improvements, and opens additional capabilities such as for area lights, glow applied to objects, and advanced shaders.
    • Selection/Bounding Box Display - Addition of preference settings allowing changes to how bounding boxes are displayed.
    • Visual Helpers for Cameras and Lights - Addition of tools from Dreamlights allowing users to set options for displaying the camera and light wireframes which provides visual cues for placing objects within the view of the camera or influence of the light.
    • DAZ COLLADA Import/Export - Addition of a DAZ COLLADA import/export option which includes specific information about the scene which provides a more accurate exchange of scenes between DAZ Studio and Carrara.
    • Ability to create and manage Content Sets in the Preferences.
    • Updates to OBJ Import/Export options with specific settings for each preset and ability to change XYZ orientation on import or export.
    • Addition of an “Always on Top” option on the View menu.
    • Updates to the Help menu.
    • Update to new version of 3Delight allowing more render options.
    • History panel added to progress dialogs.
    • Render Level option for Sub-Division Surfaces removed and render level now controlled by the Smoothing option.
    • Addition of Edge Interpolation for Sub-D Surfaces.
    • Addition of a Plug-in Registration dialog that can be displayed when DAZ Studio starts in order to remind you to register your plug-ins.
    • Ability to import settings from previous versions of DAZ Studio.
    • Ability to load log file from the Help menu in order to check error messages without having to manually search for the file.
    • Ability to choose location of temporary files.
  • Resolved Issues -
    • Fixed D-Form and Puppeteer save filters.
    • Fixed memory leak in filters.
    • Fixed weight maps to recalculate properly when changing geometry
    • Parameters tab now remembers previous scroll state for nodes correctly.
    • Tab Bar text now highlights when mouse over again.
    • Welds are now working with conversion to Sub-D.
    • Fixed an issue when rendering to the viewport multiple times.
    • Fixed the possible use of null pointer when removing geometry references.
    • Fixed tab menu to provide the missing “Show All Child Nodes” option.
    • Added missing Michael4.dmc file.
    • Closing the render window during a render will prompt a dialog asking if user wants to cancel the active render.
    • Render windows now close when the main window closes.
  • Known Issues - (see bottom of page for older known issues)
    • AutoHide Feature - Disabled in DAZ Studio v3.0.1. It will be fixed and turned back on in DS v3.0.2.
    • Bryce Wrapper -
      • Bryce will still need DS v2.3.3 installed to run. Since both versions can be installed simultaneously, this should not cause any issues.
    • Content with PowerLoader scripts (V4, M4, Hiro4, Aiko4, The Girl, The Dragon, etc.) will need updated PowerLoader scripts. The old scripts will run, but to be optimized, these pieces of content will need to be re-installed once the scripts are updated and then re-released.
    • .RIB Files - Any .rib files from DS v2.3.3 that have DAZ Studio shaders included will not work properly with the 3Delight render engine unless you first bring the scene into DS v3.0.1 and re-save to a new .rib file.

Previous Releases

v2.3.3.161

  • New Features - None
  • Resolved Issues -
    • After analyzing an audio file, the LipSync plugin will now write out a file that contains data about what phonemes were found in the audio file. These phoneme data files are saved next to the audio file from which they came.
    • Fixed an issue that caused the LOD configuration dialog to pop up multiple times when clearing animation from a figure.
    • Clearing an animation no longer affects non-animatable properties.

v2.3.3.144

  • New Features - None
  • Resolved Issues -
    • Fixed crash when switching to Full Screen view.
    • Fixed an un-initialized member variable that was sometimes causing the camera selection dropdown in the viewport to be empty.
    • The OBJ Exporter now makes sure there is no whitespace in group name entries, which solves issues with incorrect grouping when importing OBJ files exported from DAZ Studio.
    • Changed the dialog that pops up when the “Delete Applied D-Formers” option is used while spawning a morph from the DForm pane. It now has “Yes to All”, “Yes”, “No”, and “No to All” buttons, making it easier to use.
    • Fixed a bug that could cause actions to never be assigned their default paths.
    • Fixed some issues with undo when adding modifiers to an object.
    • Added “Try Again” and “Choose New File” buttons to the dialog that pops up if a rendered image/movie can't be saved.
    • PZ3 importer now reads and sets the strength values for ambient, diffuse, and specular channels.
    • When adding a D-Former, then undo-ing it and redo-ing it left the D-Former in an invalid state. The undo/redo works properly now.
    • Changed the Scene Tab so that clicking on the Visible or Selectable icon for a node doesn't change the node selection state at all.
    • Made the shader folder the default location to look for DSOs and shaders.
    • Fixed an issue with the “Use Existing Groups” option when exporting a figure as an OBJ. OBJ group information is now preserved as face groups when loading a figure, and the OBJ Exporter uses these preserved groups correctly as needed.
    • Fixed an issue causing visibility and selectability buttons in the Scene Tab to be un-clickable when the pane is horizontally scrolled.
    • Fixed a problem with Display Optimizations that was causing invalid normals (exhibited as odd black spots on surfaces) and random crashes.
    • Content Manager - Improved refreshing of Category list view after various actions are performed, like adding/removing categories, removing files from categories, etc.
    • COLLADA - Added ability to specify welds, improved Joint Weight calculation, fixed weight map calculations
    • 3D Bridge - Corrected issues with dforms and fit-to rotation handling.
    • Carrara Wrapper - Fixed issues with scale, joint scaling, ERC, and various material issues.
    • Hexagon Bridge - Fixed a layout issue with the dialog when coming back from Hexagon.

v2.3.3.83

  • New Features - None
  • Resolved Issues -
    • Added a Cancel button to the progress bar when “Optimizing Images” just before rendering, so that if the image processing hangs for some reason, the user can cancel and not have to kill the process. Also improved text of progress bar to show remaining/total status.
    • Fixed a problem in the Properties Pane that was causing major slow down after extended use.
    • Content Manager - Fixed a significant memory leak in Content Manager that was causing DS crashes.
    • Content Manager - Fixed a few dangling-pointer type crash bugs that happen in certain situations when re-categorizing content.
    • D-form - Added the ability to remove a D-form after spawning a morph and the ability to apply a morph after spawning it.
    • Sub-D - Fixed an array allocation problem with Sub-D shapes.

v2.3.3.25

  • New Features - Dynamic Clothing Control plug-in added
  • Resolved Issues -
    • OBJ importer now does YZ swapping the same way OBJ exporter does it.
    • Fixed an issue where Puppeteer data for the default camera could get messed up and cause errors when saving a scene. Also made it so that “auto-zoom-on-load” when loading Puppeteer Presets works more intuitively.
    • The cancel button is now hidden once a Poser file has finished importing.

v2.3.3.21

  • New Features - None
  • Resolved Issues -
    • Authorship dialog no longer continues to pop up if your author information is empty.
    • 'Restore' actions no longer cause LOD dialogs to pop up.

v2.3.3.18

  • New Features - None
  • Resolved Issues -
    • Changed BVH I/O options dialogs to use standard DAZ Studio dialog with 'What's This' help button.
    • Added undo items for tracking changes to the lock state of properties.
    • Poser importer now automatically adds the 'obj' extension for geometry files that have no extension.
    • The Render View now hides its toolbar so that it doesn't overlay the render.
    • Content Manager now uses the Author and File info from the accompanying DAZ Script file for Poser content with DAZ Scripts.
    • Texture map settings are now copied properly when doing a copy/paste between scene items. Some older native files were causing access violations when loaded.
    • Camera is now re-established when a non-merged scene is cancelled.
    • Fixed an issue where deformers were causing an exception on Studio close.
    • Fixed bug that was causing the LOD edit dialog to pop up on new and clear scene in previous scene files.
    • Fixed crash error when re-categorizing connect.
    • Fixed some connection errors.
    • Added progress reporting while geometry is collected for OBJ export operations.
    • Poser Importer now only generates warnings (instead of error messages) for non-fatal file errors.

v2.3.3.11

  • New Features - None
  • Resolved Issues -
    • Improved file cancelling times.
    • Audio dialog now has option to automatically adjust Animation range to include the audio clip.
    • Made the morph property created by Hexagon bridge clamped between -1 and 1.
    • Added a preferences option to turn on subdivision during manipulation.
    • When a load was canceled, the cameras and background colors for the viewports were being changed.

v2.3.3.9

  • New Feaures -
    • Cancel Load - Loading of content can be cancelled
    • Clear Scene - Clearing scene when creating a new document or shutting down DAZ Studio is faster.
  • Resolved Issues -
    • Loading multiple DAZ Scene files no longer causes animation range value issues.
    • GLSL shadow maps now render properly with no all-black renders.

v2.3.3.18

  • New Features - None
  • Resolved Issues -
    • Changed BVH I/O options dialogs to use standard DAZ Studio dialog with 'What's This' help button.
    • Added undo items for tracking changes to the lock state of properties.
    • Poser importer now automatically adds the 'obj' extension for geometry files that have no extension.
    • The Render View now hides its toolbar so that it doesn't overlay the render.
    • Content Manager now uses the Author and File info from the accompanying DAZ Script file for Poser content with DAZ Scripts.
    • Texture map settings are now copied properly when doing a copy/paste between scene items. Some older native files were causing access violations when loaded.
    • Camera is now re-established when a non-merged scene is cancelled.
    • Fixed an issue where deformers were causing an exception on Studio close.
    • Fixed bug that was causing the LOD edit dialog to pop up on new and clear scene in previous scene files.
    • Fixed crash error when re-categorizing connect.
    • Fixed some connection errors.
    • Added progress reporting while geometry is collected for OBJ export operations.
    • Poser Importer now only generates warnings (instead of error messages) for non-fatal file errors.

v2.2.2.14

  • New Features
    • Lip Sync plug-in - Provides the ability to load audio and Mimic DMC files to animate a figure's speech in DAZ Studio. Audio can also be recorded on the fly and applied to the figure along with the matching text data. If the user has Mimic Pro, the files can be automatically loaded into Mimic Pro, modified, then brought back into DAZ Studio and the animation updated.
    • Morph Panel - Adds the ability to hide Parameter sliders until needed and to add favorite parameter dials to a local or figure favorites. Local favorites are available by body part while figure favorites are available no matter what body part is selected on the figure.
    • FBX and Collada Exports - Added the ability to export LOD levels and UV sets as part of the FBX and Collada exports.
    • PowerLoader - Provides the ability for developers to supply options for loading a figure with various morphs, LOD-levels, Sub-D optimization, and available presets. This allows the user to specifically select what morphs they want injected into a figure when loaded into the scene, whether to load the LODs, and what material preset to load. This saves time as it allows the user to apply basic package settings on loading a figure instead of having to search through folders to find the necessary files after loading the figure into the scene.
    • Hexagon Bridge Sub-D Support - Provides the ability to transfer Sub-D meshes into Hexagon to create morphs for use in DAZ Studio
    • Smoothing Angle - Provides control over how and what surfaces get smoothed, avoiding current and sometimes confusing workarounds. Adds the ability to calculate surface normals so that creases are displayed on the geometry when the angle between the adjacent faces is lower than a user-defined value. Smoothing can be turned on or off by material zone with a range from 0 to 180 degrees.
  • Updates
    • The Content Manager rescan for new content has been sped up by comparing folder status in the database against the user’s storage directories to see if any changes were made prior to scanning that folder.
    • Various Content Library Pane tab menu items have been moved into a new Content Manager tab in the Preferences dialog. Also included in this new tab is an option to reset the content database to the way it appears when Studio is first launched.
    • Moved the “Auto Magnetize” toggle from the Interface tab to the Content Manager tab in the preferences dialog.
  • Resolved Issues
    • Fixed crash bug when un-pinning all pins in Power Pose.
    • When loading a pose with translations, the translations are applied unless the user presses Ctrl when loading the pose. Pressing Ctrl while loading the pose will leave the figure where it is in the scene while still applying the remainder of the pose settings.
    • After saving a scene, the viewport tool bars now stay hidden if the tool bar is minimized.
    • Rendering when the viewport tool bar is docked now correctly lines up with the preview image.
    • Viewport now updates correctly when user selects the 'Active Viewport' setting in the 'Render' tab.
    • Fixed issue with DAZ Studio scenes not loading into Carrara and partial fix of Carrara freezing during interaction with DAZ Studio.
    • Content Manager -
      • Categorization dialog now correctly removes items from the un-categorized branch.
      • Fixed an occasional crash problem when moving categories via drag-and-drop.
      • Updates to DAZ content categories no longer deletes the entire database which would require a full rescan.
      • User can now cancel the loading of content when the Ask for Replace preference is set.
      • Scroll bar resets to previous position after a rescan.
      • Category views now provide an empty space at the bottom of each column.

v2.1.1.13

  • New Features
    • QuickStart Layout and Tutorials - Provides a basic user interface for new users and short tutorials to walk users through creating a basic scene.
    • Content Manager - Adds the ability to categorize content in multiple categories without affecting where the content is stored. A search option is also available for quick location of items indexed in the database.
    • Add/Replace - Adds the ability to select how objects are added to the scene, either to replace items, ask to replace, or never replace (add always).
    • Auto Magnetize - Adds the ability to automatically match deformers between a figure and clothing items and have the clothing follow any matching changes to the figure.
    • Material Preset - Added the ability to save the loaded UV set with the material preset.
    • OBJ Export - Added option to remove unused vertices and added ability to export a specific LOD, if available.
  • Resolved Issues
    • Update to OBJ exporter:
    • Current scaling and settings are remembered between exports.
    • Supports the external preset file for exporter settings
    • Collada exporter updated to newest SDK.
    • Zeroing out a figure no longer zeroes out invisible dials. Pressing Ctrl while selecting a zero option will override this and zero out all dials, visible or not.

v2.0.0.21

  • General
    • Conversion to RoboHelp format
    • Updates to text and formatting as needed
    • Addition of images and text as needed
    • Addition of Index
  • New Features
    • Hexagon Bridge - Adds ability to send a figure or other object into Hexagon, modify the mesh, bring back into DAZ Studio, and apply as a morph target including any modified materials - requires Hexagon 2.5 (upcoming release).
    • Pane Auto-Hide - Adds ability to pin/unpin panes and “hide” them as tabs at the sides of the interface.
    • Drag-n-Drop - Adds ability to drag content from the Content tab into the scene and applied to the correct figure without having to actually have a figure selected prior to adding the new content. Also provides ability to target the location to drop a figure or prop into the scene.
    • Level of Detail - Adds ability to add different levels of mesh detail to a figure and update the levels used in the scene based on need and distance from camera.
    • Multiple UVs - Adds ability to apply multiple UV sets to a figure.
    • Sub-Division Surfaces - Adds ability to sub-divide a mesh.
    • Display Optimizations - Improves performance in the display of shaded geometry.
    • Getting Started Wizard - Provides quick access to tutorials when starting DAZ Studio.
    • Resolved Issues
      • When saving a Materials Preset, the options dialog now opens correctly

Known Issues

  • General :
    • Crashing During Rendering - The memory leak fixes that have addressed most of the crash issues associated with Content Manager will also help avoid crashes during rendering, especially when rendering after a long session in DAZ Studio where the memory may have been reduced significantly by the memory leaks. Work continues on finding solutions to the issues encountered (crash) when rendering large scenes within Windows. The fundamental issue is that with both DAZ Studio and the 3DLight render engine running, the render engine will exceed the 2GB of RAM that the 32-bit Windows Operating system is capable of addressing. So far, DAZ has not settled on a permanent fix for this issue, but in the mean time, there is a workaround available. This works best in those systems with 4GB of physical RAM, but also works well with less physical RAM because this opens up virtual memory that is paged. Microsoft has published ways that individuals can configure their 32-bit OS systems to access at least one additional GB of RAM beyond the 2GB limit:

Also look at: http://support.microsoft.com/default.aspx?scid=kb;en-us;319043

  • Simplified Startup - For some users, selecting the Simplified Startup when first starting Studio may result in Studio locking up as it attempts to load the startup scene. In order to get around this, rename the startup scene located in “Studio/content/QuickStart/Scenes/QuickStart Scene.dsb” then restart Studio. You will get a file not found error message when the scene tries to load, but select to ignore it. Once Studio opens, go into the preferences and set the startup scene to “None.”
  • Display Optimizations - Clearing the scene with Display Optimization enabled may crash DAZ Studio on some systems, especially older systems.
  • Hexagon Bridge -
  • Clicking the Hexagon Bridge link with Hexagon 2.2 or lower installed will result in nothing happening, except in cases of PCs with Hexagon 2.3 installed. In that case, Hexagon will be opened but no information will be shared between DAZ Studio and Hexagon.
  • Sending conforming items over to Hexagon along with the figure is not currently available.
  • Windows Vista - Because Vista saves files to a mapped directory instead of to the correct folder in DAZ Studio, the .dso files needed to load DAZ Studio scenes cannot be found. This problem can be fixed by adding the virtual directory to the list of content folders in the Preferences. The virtual directory is usually found at: “C:\Users\[User Name]\AppData\VirtualStore\Program Files\DAZ\Studio\content\”
  • User Interface
  • Camera shortcuts in UV View do not work
  • DAZ Studio may require a restart to correct some interface redraw issues.
  • Contains some interface inconsistencies (black text color may cause some icons to appear black).
  • The “What's This?” interactive help text descriptions have not been fully implemented (see notes).
  • VIA/S3 line of integrated graphics processors provide insufficient OpenGL support for useful DAZ Studio operation. Updated drivers have corrected this issue in some circumstances.
  • Viewport Aspect Frame text (ratio) and encompassing frame do not display correctly on some graphics hardware.
  • When the main application window is re-sized very small, the 3D viewport appears as if it is sliding over top of some of the interface panes.
  • UI layout (StartupScript.ds) stored from versions prior to 1.7.1.3 may cause errors upon launch. Including those StartupScript.ds located in the Bryce Folder. (Used by DAZ Studio when starting DAZ Studio from within Bryce.
  • If a surface uses an image file of any format other than JPG, which has the same name as a different image file of the JPG format located in the same folder, DAZ Studio will use or apply the JPG image file rather than convert the referenced image.
  • Loading a .DAZ file by double-clicking it will result in the background color changing to the last background color used in DAZ Studio and the default camera's position being reset in the scene.
  • OpenGL only supports eight lights for display. If you wish to render more than eight lights in your scene you will have to use 3Delight.
  • V3's right eye does not respond correctly in the Power Pose tab.
  • When both primitives and models are selected at the same time, they will not translate correctly as a group.
  • The content tab's history is shared between activities.
  • You may experience a crash if: you have more than one figure in a scene, have had only one figure selected, are using Active Pose, and use the Un-pin All button in the tool tab.
  • Native Content
  • Earlier versions (pre-1.0) of the native format are not compatible with this version of the application due to format modifications.
  • Conformed figures, after being deleted and then having the delete undone, do not conform correctly afterwards.
  • DForm and Align Ace
  • D-formers load in with their field scaled to fit around the node that they were created on, not at 100%.
  • If two D-Formers are applied to the same node, the field will only influence the node where its mesh was before the dformer has changed it.
  • When you add a node to be affected by a D-Former that is on another node, it may not be affected as expected, even if it visually falls within the field's area of influence. A workaround is to remove the node from the D-Former and add a new D-Former on this node.
  • The Align Ace plug-in uses node selection order to perform its duties - additional notes regarding selection order are provided in the “What's This?” help for the options themselves.
  • In the Align Ace tab, the apply button is disabled unless the following criteria is met:
  • No more than one node is selected on a skeleton
  • Two or more nodes are selected for Align options (when not aligning to grid)
  • Two or more nodes are selected for Stack options
  • Three or more nodes are selected for Distribute options
  • An option other than No Change is chosen for one of the three axes
  • Imported Content
  • OBJ files imported from Bryce will be scaled incorrectly (They import in too small).
  • Poser Asset Support
  • If a PZ2 file from poser contains magnet information in it, and you opt to turn off limits during the application of the pose to V4.1, then the limits will be removed from all the JSM magnets and the figure will become distorted.
  • An issue with how transforms are applied on import has been identified and will be corrected in a subsequent build.
  • Several built-in channels (such as handGrasp, taper, etc…) are not supported.
  • Poser Inverse Kinematics (IK) is not supported.

Notes

General

  • Initialization
    • For the registration process to work correctly, Studio will need to be able to receive inbound and outbound http connections (This occurs after the browser is closed during the registration process).
    • DAZ Studio can search for Poser content folders automatically. This can take a while on large capacity or network drives. To help reduce search times, upon initial launch a dialog is displayed, prompting the user to select which drives to search.
    • Content directories remembered from installations prior to version 0.9.1.0 are ignored and treated like new installations. Upon launch, users are prompted with the content search dialog.
  • ERC/“Crosstalk”
    • ERC of an item “fitted” to a host figure is now “re-routed” to point to the host figure. This means that if the fitted item has a PBM, for example, that follows a valueParm on its own body, when that item is fitted to the host figure, it will look for a matching valueParm on the host's body. If it exists, the PBM will then listen to that host's dial, instead of its own body dial. If a user wishes to make additional value changes to the fitted item's individual body parts, then the user must change the value within the fitted item's individual PBM parameter dials. This logic is followed by all channels/properties, and is not just limited to PBM's as listed in this example.
  • Documentation
    • In the Help toolbar, near the top right of the DAZ Studio interface, you will find a “What's This?” button. This button is used to provide interactive help for elements of the DAZ Studio interface. Simply clicking the button, or pressing the keyboard shortcut (default: Shift + F1), will put you in “What's This?” mode. This will change the cursor to an arrow and question mark, at which point you can click on a widget within the interface to show a brief (and sometimes, not so brief) description on the purpose of the widget and perhaps some supporting information - if a description for the widget has been provided. The “What's This?” feature is standard in DAZ Studio.
    • A “living document” version of the documentation will be hosted on our Web site, here, and will continue to evolve as we convert/correct/update.