User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Using the Shader Mixer

These directions are very basic. They do not go into detail on which function bricks to use, how to use them together, etc. This will be added as the functionality of the Shader Mixer is completed.

To use the Shader Mixer:

  1. Create a new scene and add a primitive to the scene, preferably a sphere to match the previewer.
  2. Choose View > Shader Mixer from the main menu. The Shader Mixer pane will be displayed.
  3. Dock the tab to the left or right side of the workspace.
  4. Resize the workspace so that you have plenty of room to work with.
  5. Determine what type of shader you will be mixing up: Material, Light, or Camera.
  6. Determine how you will be creating the shader: New, Open from file, or Loading from the scene.

Opening a Saved Shader Mixer File

To open a saved material file:

  1. Choose File > Open from the Shader Mixer menu.
  2. In the Open dialog that is displayed, locate the file then click on the Open button.
  3. The material will be opened in a new tab in the workspace.

Loading a Shader from the Scene

To load a shader from the scene:

  1. Apply a shader to the object, light, or camera.
  2. From the Surfaces tab, select the surface with the shader needed.
  3. Choose File > Load from Scene from the Shader Mixer menu. The Read from Scene dialog will be displayed.

    shmx_readfromscene.jpg
  4. Click on the field and select what type of shader is being read from the scene: Material, Camera, or Light, then click on the OK button. The shader will be loaded into a new tab in the workspace.

Creating a New Shader

To create a new shader:

  1. Choose File > New from the Shader Mixer menu. The New dialog will be displayed.

    shmx_newmaterial.jpg
  2. Click on the field and select what type of shader is being created: Material, Camera, or Light, then click on the OK button. A new tab will be added to the workspace with the name of the material type as the tab name. If you selected to create a material, then the DAZ Default Material bricks will be available in the Material tab.

Mixing Shaders

  1. From the Brickyard, select the root brick you need based on the type of shader being created and drag it on to the workspace tab. Make sure you are adding the right type of root brick for your shader. Review the list on “Shader Types” if you need to check which root bricks can be place on which type shader tab.

    icon-tip.jpg TIP! You can also right-click on the workspace and choose the bricks from the menu that is displayed.
  2. Add your first Function brick from the Functions listing. The choices you make will be determined by the shader being made and the type of functions needed to create the shader.
  3. Connect the output nodes of the function brick to the input nodes of the root brick.
  4. Add additional function bricks as needed to build the shader. Adjust sliders, colors, values, and add images as needed.
  5. Click on the preview thumbnails to check how each brick looks. Use the preview on the root brick or in the brickyard to view the overall shader.

Testing the Shader

If your shader is for an object, select the surface(s) from the Surfaces tab and click on the Apply button.

If your shader is for a light:

  • If creating a new light
    1. Click on the Apply button.
    2. Choose one of the following from the Create New Light dialog:
      • Apply Default Settings
      • Apply Active Viewport Transforms
    3. Click on the OK button and the light will be created in the scene.
  • If copying the location of a current light or replacing a current light:
  1. Select the light in the scene.
  2. Click on the Apply button.
  3. Choose one of the following from the Create New Light dialog:
    • Copy Selected Item - copies selected light transforms and applies them to the new light.
    • Copy and Replace Selected Item - copies selected light transforms, deletes the selected light, and replaces it with the new light.
  4. Click on the OK button and the light will be created in the scene.

If your shader is for a camera:

  • If creating a new camera:
    1. Click on the Apply button.
    2. Choose one of the following from the Create New Camera dialog:
      • Apply Default Settings
      • Apply Active Viewport Transforms
    3. Click on the OK button and the camera will be created in the scene.
    4. Change the view to look through the camera and render.
  • If copying the location of a current camera or replacing a current camera:
    1. Select the camera in the scene.
    2. Click on the Apply button.
    3. Choose one of the following from the Create New Camera dialog:
      • Copy Selected Item - copies selected camera transforms and applies them to the new camera.
      • Copy and Replace Selected Item - copies selected camera transforms, deletes the selected camera, and replaces it with the new camera.
    4. Click on the OK button and the camera will be created in the scene.
    5. Change the view to look through the camera and render.

Once you have completed building your shader, it can be saved as a material, light, or camera preset.