User Tools

Site Tools


Universal Manipulator Tool and IK

The Universal Manipulator is a tool that allows the user to manipulate several axises either simultaneously or without having to select multiple dials. The first step is to load a figure into the scene. Next is to select the Universal Manipulator. The Universal Manipulator can be found in the Tools tab at the top of the screen. Once selected you should see something like this:

Use the Universal Manipulator on any node of a figure. For this demonstration I have chosen to use Victoria's right shoulder. With the Universal Manipulator you have a variety of options, you can rotate, translate, or even scale a figure or node. The rotations will appear as several circles on the screen when the mouse is moved over them.

If you do not like the rotation you can either undo the action from the Edit menu, or you can left-click on the House Icon next to the Universal Manipulator. This will bring up a menu. You can either select Restore Transforms which will restore the default transforms for the selected node. Or you can select Restore Figure Pose which will restore the default pose of the figure. This will not restore to a loaded pose if you have used one. Restore Figure Pose will also ignore any pins that have been placed in the figure but will not remove them.

Once you have posed the node to your satisfaction you can use one of the options in the Pin Menu to hold that node in place. Pin Translation, Pin Rotation, and Pin Rot/Tran, will help you to hold certain nodes still while moving others in the body. For example, I have posed the arm to a position that I am satisfied with, however, if I move the chest or abdomen nodes it may affect the pose of the arm. Therefore I can use pins in the collar and shoulder to hold the arm still in relation to the abdomen and chest.

If you would like to remove pins you can select Unpin All or Unpin Selected. Unpin Selected will remove the pins from the selected node while leaving all the others in the figure unchanged. Unpin All will remove all pins from the figure regardless of selection. Enable Pins should be toggled by default. If this is unselected, then all pins in the figure will be ignored although they will remain where they have been placed. Bake Figure IK to FK will change the way the figure's Kinematics are calculated. This is present mostly to help with exporting to other 3D programs that have animation functions. This option will affect every node on the figure and does not need to be applied to each node separately.

In addition to the tool in the viewport you can access additional options in the tools tab. To open the tab go to the View menu. Select Tabs, and then Tool. You must have the Universal Manipulator selected in order to see the options associated with it. Once open you will be able to see several boxes that are checked.

By un-checking these boxes with a left click you will remove the pointer associated with that axis. By default the Scale axis are not selected. In order to activate the scaling option of the Universal Manipulator you must first check the box located just above the Scale Uniformly option. This will then allow you to access all of the scaling axis.

Another option that you will find in the tab is the 'Free' button located at the end of the Rotation row. When this is selected it will activate a yellow circle at the center point of the Universal Manipulator.

This will allow you to rotate much as you would when selecting the center of the rotation control. Just below the Free button you will notice a Scale Uniformly option. This button when toggled will activate a cube at the center point of the Universal Manipulator to allow scaling that way which will cover all axis instead of going one axis at a time.

Next you will see the Guides and Snapping options. Snapping allows you to rotate and translate to specified locations. This can help with perfect angles on rotation or translation to measured distances. Scale can also be used in this way. Underneath the boxes you will see several value fields in which you can alter the values selected. The fields can be access by left clicking in the field to enter custom text, or by clicking on either of the rectangles at the end to increase or decrease the value.

In order to snap a certain option, for example rotation, you must first left click on the rotation box below Snapping. This will add a check mark to the end of the box. Now when you use the manipulator to move the object you will see several marks indicating angles. The color of the marks will change depending on the axis being used. If the user wishes to see a line indicating the selection then they must first select the box next to Guides. This will add in a color bar underneath the Guides option.

The color of the bar will change the base color of the Guide line. In order to change it you must left-click on one of the three displayed numbers and move your mouse in a horizontal direction. 255 is the highest option available and 0 is the lowest. Different combinations of these will change the overall color of the guide line. A user may also click on the blank space in between the numbers to open a color palette and select a color that way. In order to see the marks for scaling you cannot have Scale Uniformly selected.

Other options that exist in the Tool Tab are value fields to manipulate the Bounding Box. Like the value fields for the Snapping tool these fields can be edited by either typing in a value or clicking on the rectangles at the far right of the box. If text is entered you will need to click somewhere else in the viewport or press the Enter key in order for your changes to be accepted. Edge Length will change the bounding box from a solid frame to corners around the selected object. Active Opacity and Inactive Opacity will change how visible the bounding box is; both when active (with the mouse hovering over the object), or inactive (when the mouse is elsewhere in the viewport.)

The Miscellaneous section of the Tool Tab, listed at the bottom adds a few more options for customization. Line Width will change the width of the lines displayed on the Universal Manipulator itself. The higher the number the thicker the lines with 1 being the lowest option. Manip Drawstyle, short for Manipulation Drawstyle will change the style of the figure in the viewport while it is being manipulated by the tool. Wireframe Box will display the figure as its bounding boxes while the tool is actively being used in the viewport. Smooth-Shaded Box will show as solid blocks defined by the figure's bounding boxes. Off will default to whatever display is selected as the Viewport Draw Style. Sub D Draw Style follows the same functionality of the option in the Edit>Preferences>Interface tab.

At the top of the Tool Tab you will find a drop down menu. The options in this menu affect the way the Universal Manipulator is displayed in the viewport and which translations it does and does not listen too. Use Local Coordinates, the default option, will shift the manipulator based on the rotation and coordinates of the selected node. Use Object Coordinates will position the manipulator close to the node selected but rotations will not affect it. Use Camera Coordinates will force the manipulator to face whatever camera is selected. Lastly Use World Coordinates will force the Universal Manipulator to position itself relative to the world inside the viewport.