User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Migrating Presets and Objects from Bryce 5 to Bryce 5.5

Author: hamfast

Tools Needed

  • Bryce 5
  • Bryce 5.5
  • Windows 98
  • Windows 2000
  • Windows XP
  • MacOS

Introduction

The older Bryce 5 has been around for a few years and no doubt you have built up a nice collection of Material, Object and Sky Presets. Along comes Bryce 5.5 and now you are faced with the dilemma of what to do with your old presets. Are they lost? Are they compatible with the new revision of Bryce? This tutorial will help seasoned Bryce users and beginners alike to organize and manage all your presets for the move from Bryce 5 to Bryce 5.5. The tutorial is aimed primarily at Windows users, but will also work for Macintosh users.

300-03e9.jpg

Step 1 - The Bryce 5 and 5.5 Directory Structures

300-03ea.jpg

Bryce 5 and Bryce 5.5 work quite happily side by side, and you can in fact run both of them at the same time – as long as you have sufficient memory. It is important to understand the workings of the respective directory trees of Bryce 5 and 5.5. Essentially they are the same with slight cosmetic changes.

The screen grab above show how the directory trees differ between Bryce 5 and 5.5.

There is an important thing to remember that although you can have large numbers of sub-directories containing various libraries of materials, the first level can only have 14 libraries as there is a 'bug' which does not allow you to display more than this. These screen grabs should explain what I am getting at. Notice how the bottommost directories (categories) disappear off the list. (Perhaps something that we can hope to see improve in Bryce 6?)

300-03eb.jpg

300-03ec.jpg

Step 2 - Creating the new directory layout

300-03ed.jpg

Although it is everyone's prerogative to organize the preset libraries as they see fit, I strongly recommend that you in some way separate the older presets of Bryce 5 and the new presets of Bryce 5.5. It is no good mixing them all up and then struggle to manage them or find a particular preset at a later stage. I set about separating them by creating the above directory structure. There is already a 'User' directory but let us leave this alone for now.

Using Windows Explorer or your preferred file manager, (you cannot do this directly from within Bryce 5.5) create a single subdirectory in Program Files\DAZ\Bryce 5.5\Presets\Materials called 'Bryce 5 Presets', then a single subdirectory in Program Files\DAZ\Bryce 5.5\Presets\Objects called 'Bryce 5 Objects', and finally in Program Files\DAZ\Bryce 5.5\Presets\Textures, a subdirectory called 'Bryce 5 Textures'. This last directory more difficult to access in Bryce 5.5, but I will show you how that works in Step 5. Furthermore, if you are curious why I have not created a 'Sky' preset directory, the currently limitations of the Sky Presets in Bryce 5.5 do not allow a user to create separate directories. All the Sky presets are thrown together in one big library. (Perhaps this will be improved too in Bryce 6 so a user can categorize skies in a meaningful way.)

Currently any of the new directories that you might create will be empty. There is no need to go in to Bryce 5.5 just yet. If you do AND try to access these empty folders and you exit Bryce again, you will find that Bryce 5.5 has created an empty Library file of its own, which might confuse things later.

300-03ee.jpg

300-03ef.jpg

Step 3 - Exporting from Bryce 5

300-03f0.jpg

Now it is time to return to Bryce 5 to begin to export the presets. The methods described below in Steps 3 and 4 apply to all the categories of Bryce Materials, Objects and Textures and there is no need to repeat myself for each as the procedures are common to all. I will use the Material Presets as the example in this tutorial.

Go to the Bryce 5 Material Presets library. This can be done 3 ways:

Press the Ctrl+M Key (Apple users check the graphic above for the correct key to use.) to bring up the Materials Lab and then click on the small arrow on the top right edge of the small preview window to get the preset libraries or'

With any object selected press the small [M] icon of the Object Controls and then click on the small arrow on the top right edge of the small preview window to get the preset libraries or'

Click on the small arrow to the right of the Edit Palette. (This way takes you directly to the Preset Libraries – unlike the previous 2 methods)

Choose the Preset Library that you want to export from. This might differ from user to user but for this tutorial I will choose the default Miscellaneous library. With the presets displayed, you will now have to select the presets you want to export. These libraries comply with the general standards for selection of items – both in Windows and Macintosh environments. In other words the Ctrl and Shift keys (Windows) and the Command and Shift keys (Macintosh) Using the Ctrl and Shift keys and clicking on the first and then the last preset in a list will select all the presets between the first and the last presets, whereas the Ctrl key (or Command in Macintosh) used alone with clicking will select individual items here and there. Personally I prefer the latter method as it gives me more control to choose.

As each preset is selected a thin red line outline appears around it – an important visual clue. If you inadvertently select a preset that you do not want to include, do not panic! Just keep the Ctrl key pressed in and click on the unwanted preset again and it will be deselected.

300-03f1.jpg

Now with the presets selected you can click on the Export text button at the bottom of the Material Library window. A standard save dialog box will appear and you can now browse to the directory where you want to save your exported materials to, and name the file.

300-03f2.jpg

(Do not save the exported preset library directly into the Bryce 5.5 directory at this stage. It can lead to complications. However, it is important to name the saved preset library file meaningfully, because it will appear in the new library list EXACTLY as you have named it. In this example I have named it B5-Miscellaneous. Do not give it a long file name as Bryce 5.5 will truncate the name in the Library lists. It truncates after about 20 characters.

Continue to go to each and every library (including your custom and your User libraries) and export all your preset libraries. I decided to categorize my presets into broad libraries like Metals, Glasses, Rocks, Clouds etc. keeping the names short yet understandable and appropriate.

Step 4 - Importing into Bryce 5.5

300-03f3.jpg

You are faced now with 2 possible methods to get the Bryce 5 material presets imported into Bryce 5.5. The first method entails a simple copy/paste procedure, the second uses the Import function built into the Material Library window.

If you have already named the exported preset libraries in a meaningful way, you can now use the Copy and Paste function of your operating system to transfer the libraries from the exported folder to the new Bryce folders. I rarely use the 'Cut' function (Ctrl+X) as sometimes things go wrong and you might want to keep a backup of the exported files.

Just ensure that your file names are not longer than 20 characters as long file names will be truncated in the display. It seems that you can have spaces and characters like '&' in your file names, but I always am cautious, preferring to use names like 'OldMetals' (Using Capital Letters to separate the words) or the old 'underscore' trick – 'Old_Metals'. I hope you'remember to keep the .mat extensions after the names. In Windows 2000 or XP, if these file extensions don't appear you might not have them set to display. (which is the default for Windows XP)

In order to display them, double-click the 'My Computer' icon on your desktop to open it up. Select the Tools > Folder Options menu and then click on the View tab. Under the Advanced Settings ensure that the radio button of 'Show hidden files and folders' is on, and that the tick is removed from the 'Hide extensions of known file types'. OK your changes and the .mat extensions should now appear.

The 2nd method requires the Import function, but you will need to have predefined libraries set up to import into. In other words, if you have a set of metallic presets to import you will have to have a metallic library folder to import into. Currently there is no way to create a new library from within Bryce itself. You have to use your operating system's file manager to do this.

Select the library you want to import into and click on the Import text button on the bottom of the window. Browse to the folder where you have stored the exported .mat files and select the library you want to import and click on the OK button. Your library will now be imported.

300-03f4.jpg

Now here is a very interesting bit of behavior I have discovered with Bryce 5 and also with Bryce 5.5. If you import a set of presets into an existing library with no particular preset selected, the library will append itself after that last material in the existing list. However if you select (highlight) a preset before you start the import will insert itself in front of that pre-selected preset. Here is a simplified graphic to explain what I have discovered.

300-03f5.jpg

What possible use could this 'feature' have you might be asking? I have found it useful in organizing the Sky presets for the very fact that the Sky Preset do not have or support categories within the library. So I was able to use this 'eccentricity' to my advantage later when dealing with the Bryce 5.5 Sky presets!

Step 5 - Organizing and Accessing the Texture Directory

300-03f6.jpg

In Step 2, I mentioned the 'lost child' of Bryce, the Texture Library. Although it can be managed the same way as The Material Presets, accessing it is quite a mission. The Texture library was always intended to be a repository of basic textures that could be pulled into the Deep Texture Editor and combined in the various channels to create a Material preset. It resides in a separate directory from the Material Libraries.

Accessing it is only possible if you have an object selected with a texture assigned to it. A default grey colored Bryce object does not have a texture assigned to it but you can assign one by clicking in the A column of the Materials Lab grid. Now to access the Texture Libraries makes use of the Shift Key.

300-03f7.jpg

Normally clicking on the small triangle to the right of the Texture name will bring up a popup menu with all the texture names listed in their various categories. This is pretty useless unless you know exactly what a texture look like, so Bryce has an added functionality to access the Texture Libraries and show you them visually. Hold down the Shift key and click on the same small triangle next to the name of the texture. All the textures in their various categories will now appear.

300-03f8.jpg

The Standard Library controls of Add, Delete, Import, Export and the Cancel and OK (the cross and tick at the lower right) are there at the bottom of the window and work exactly the same as the Material Presets. You can now Import your texture libraries exported from Bryce 5.5 or you can copy them into the Program Files\DAZ\Bryce 5.5\Presets\Textures folder from your Export folder.

If you haven't exported the Textures from Bryce yet, you can return to Steps 3 and 4 and follow the instructions there, remembering to use the Shift key to access the Texture Library from the Materials Lab.

Step 6 - Organizing the Bryce Object Library

Most of the ground work has been covered already in this tutorial in organizing the Material preset, so I will not repeat myself except to explain a few of the limitations of the Object Libraries. (They also apply to the Materials and Texture libraries.)

There cannot be more than 14 directories under the Program Files\DAZ\Bryce 5.5\Presets\Objects folder, and within those subdirectories try to limit your libraries to not more than 40 or you will have your libraries list overshooting the top and the bottom of your screen as I have shown in this example screen grab. This same problem manifests itself in Poser 4, and believe me, using the auto-scrolling function can be a real drag (pardon the pun!)

300-03f9.jpg

Also keep the length of your directory names down to about 20 characters or you will get this display 'bug' happening.

300-03fa.jpg

Bryce Objects can be organized in simple categories. I have opted to categorize them into Primitives and other General categories, but again it is all a matter of personal preference.

Step 7 - Organizing the Sky Presets

My sky presets are by far the largest library that I have yet the limitations of Bryce in this area do not allow me to create categories, instead I am forced to jam everything into one group making browsing very difficult and clumsy. I mentioned in Step 4 that the Sky Presets library does not reside in a nice directory structure like the Material Presets, but is a single file on its own. It still has the ability to import individual presets however!

It might be a good idea to Export 'categories' of sky presets from Bryce 5 as follows:

Clear Skies

Cloudy Skies

Mist and Fogs

Sunsets/Sunrises

Bizarre Skies

Volumetric Skies

This way I can control the order in which these sky preset appear in the preset list, by importing them in this order and clicking on a place on the preset list before using the import function so that the skies in that category can be 'inserted' in the correct order – all the 'cloudless' skies at the top of the list and the really complicated skies at the bottom.

The screen captures below explain my method, firstly with the Import tool with the selected 'marker' sky preset highlighted in red. Below that is the result with the imported 'Clear Skies' library now in place and all highlighted in red. Simply put, if I want to place the 'Clear Skies' group at the top of the list I would click on the first preset in the library (top left) and then click on the Import tool, then select the exported 'Clear Skies' preset file and when I click the OK button the 'Clear Skies' would be inserted just in front of the first preset and therefore at the top of the list.

300-03fb.jpg

300-03fc.jpg

Step 8 - Conclusion

You have reached the end of this tutorial. In it you have learned how the directory structures of Bryce 5 and 5.5 look. You have been shown how to prepare Bryce 5.5 for accepting the old Bryce 5 presets, and you have been shown how to Export and Import Bryce Materials, Textures, Objects and Skies. Although this tutorial isn't a very creative one, I am sure that it has given you a better idea of how to organize your libraries in the new Bryce and how to make the migration from 5 to 5.5 (and into the future) easier and less confusing.

If there are parts that you find confusing, or if I have made some mistakes, feel free to contact me. I am always open to constructive criticism! My contact details are listed on my personal website at http://hamfast.bryce-alive.net.

Keep on Brycin'

David Wiles