User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Morph Loader, Introduction to Exporting and Importing

Author: Susurrus

Tools Needed

* DAZ Studio 1.3.1.0

* Morph Loader

* Hexagon (or other 3D modeling program)

Introduction

In your 3D modeling program you can manipulate an Exported figure from DAZ Studio by pushing and pulling groups of vertexes around, and so long as you don't create or remove any new vertexes, use the Morph Loader to Import the altered figure back onto the original figure as a morph. For this tutorial I am going to use DAZ's Victoria 3 figure to make a head morph from, as this seems to be something asked about quite often on the DAZ forums.

Step 1: Load and apply selective invisibility to your chosen figure

Load your figure into the DAZ Studio default scene, don't change its position and make sure you don't have any other figures loaded.

200-018f.jpg

Now select Victoria from the Scene tab, click the little eye on the right and Victoria should disappear.

200-0190.jpg

In the Scene tab select Victoria's head and click the little eye to the right of it to make her head visible once more.

200-0191.jpg

Step 2: Export your figure as 'Wavefront (obj)'

From the File menu select Export to bring up the Export file window.

200-0192.jpg

Make the Save type 'Wavefront Object (obj)', and name it something like 'Victoria Head' so you can find it again easily.

200-0193.jpg

Note. Also make sure you'remember where you save it.

When you click Save it will bring up the 'Export: Wavefront Object (obj)' window. I'm not an advanced user of DAZ Studio so I don't know what every one of these setting does but fortunately DAZ Studio is user friendly enough so that we only have to concern ourselves with two things in this window.

200-0194.jpg

First the Preset box, in this tutorial I'm going to use Hexagon to create my morph so I select Hexagon from the Preset dropdown list.

If you are going to use another 3D modeling program then select it or an applicable scale from the Preset dropdown list.

Second the 'Ignore Invisible Nodes' box, this is the reason we made everything but Victoria's Head invisible, by ensuring this box is ticked we will only export her head and as this is the only part we wish to work on it will prevent unnecessary computer slowdown whilst editing.

Click Accept when done.

Note. You can use the 'What's This'(?) function in the bottom left at any time, to give you more information about a specific heading in the Export window.

Step 3: Import figure into your chosen 3D modeling program

Now we have exported our figure we can Import it into either Hexagon (as I'm doing) or another 3D modeling program of your choosing.

In Hexagon, from the File menu select Import.

200-0195.jpg

In the Open window that appears find and open your previously saved figure.

200-0196.jpg

Note. If you can't find your saved figure, make sure that 'Wavefront Object (obj)' is the type of file selected under 'Files of type:'.

In the Import window that appears ensure your settings are the same as in the picture below.

200-0197.jpg

Your figure should now load into Hexagon.

200-0198.jpg

Step 4: Create your morph

For my morph I am going to do something simple, give Victoria a bulbous nose. This is very simple and quick to do in Hexagon and it makes a noticeable difference to Victoria's face.

Turn on Select Object from the Selection Palette, and click on Victoria's head to select it.

200-0199.jpg

Rotate your view to the front (hold down Alt + left mouse button, move mouse to rotate as required).

200-019a.jpg

Zoom in (role the wheel on your mouse), turn on Select Faces, and click on a polygon on the end of her nose.

200-019b.jpg

In the Properties window tick the Soft Selection box and move the slider just below it until quite a bit of her nose is selected (you will see this by the red dots that appear on her face all around your selected polygon).

200-019c.jpg

Now click and drag the little yellow dot (see pic below) on your selection to increase the size of her nose.

200-019d.jpg

This tutorial is about the Morph Loader not 3D modeling so I have only done this simple change just so you can try it for yourself; to create a more complex morph you must have a working knowledge of the 3D modeling program you are using. It is imperative that during this process you DO NOT create or remove any vertexes, if when the Morph Loader is reading the 'obj' file of your figure it detects more or less vertexes than the original figure which you are trying to load it onto it will come up with an error message.

Step 5: Export your altered figure

Go into the File menu then the Export submenu and select 'Wavefront OBJ'.

200-019e.jpg

Name your model something like 'Victoria Head Morph' and click Save.

200-019f.jpg

In the Save as window that appears ensure your settings are the same as in the picture below.

200-01a0.jpg

Note. I cannot account for the settings of other 3D modeling programs but I would think they would be similar to the ones pictured above.

Step 6: Using the Morph Loader to Import your morph

Back in DAZ Studio load Victoria into the default scene and ensure you have her selected in the Scene window.

200-01a1.jpg

In the Edit menu (assuming you have installed Morph Loader correctly) you should see Morph Loader, click this to bring up the Morph Loader window.

200-01a2.jpg

200-01a3.jpg

Under File: click the '~' button which will bring up the Open window. Select your previously edited Victoria figure, for me it's 'Victoria Head Morph' and click Open.

Under Morph Name: type something appropriately recognizable like 'Bulbous Nose'.

Under Geometry select the Preset from the dropdown list appropriate for the 3D modeling program you used, for me it's Hexagon.

If your 3D modeling program uses the Z-axis for up rather than the Y-axis like DAZ Studio does, then tick the 'Swap Y and Z orientation' box.

If you have used Victoria and Hexagon as used in this tutorial then please check to make sure your settings are the same as in the picture below.

200-01a4.jpg

Now click accept.

A little loading box should come up showing that DAZ Studio is reading your created 'obj' file.

Step 7: Apply your morph

To apply your morph, select Victoria's head from the Scene window.

200-01a5.jpg

In the Parameters window under Morphs you should now have your morph appear under whatever name you gave it, for me it 'Bulbous Nose'.

200-01a6.jpg

Click and drag the centre of the slider to the right and your morph should gradually be applied to your figure.

200-01a7.jpg

And there you have it, how to create and apply a brand new and completely original morph to your favorite figures for use in DAZ Studio.

You can now make morphs for any other part of Victoria or indeed any other figure you wish simply by using this same technique, lets recap.

  1. Make your figure invisible.
  2. Make your chosen part (or parts) visible again.
  3. Export in Wavefront format, then Import into your 3D modeling program.
  4. Push and Pull the vertexes of your model (ensuring not to create any new vertexes).
  5. Export in Wavefront format, then Import back into DAZ Studio using the Morph Loader.
  6. Use the sliders on each body part to apply your Morph.

You could also make full body morphs by exporting the whole of your figure, editing your figure in your chosen 3D modeling program, then using Morph Loader to import your morph onto your figure and using the dials for each body part to apply your morph to each body part.

The morph made in this tutorial may not be very exciting but the possibilities made available by the Morph Loader most certainly are. You can create morphs to make your characters look more individual, make clothing fit better, create bizarre new alien races or even something subtitle like the soft indentations in skin created by sitting or other specific poses which will make your work all the more realistic and unique.

I hope you have enjoyed this tutorial and will make good use of the Morph Loader and the endless possibilities it bestows upon DAZ Studio users.

Until next time, happy morphing!