User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Poser Animations in Cinema 4D

Author: kennez

Tools Needed

  • Poser
  • Cinema 4D XL6 or higher

Support Files

Introduction

You have a great animation that you created in Poser, but you don't want to use the Poser rendering engine. You have Cinema 4D on your hard drive, and you know how good the rendering engine is. Trouble is, you haven't got a clue how to transfer your Poser animation into C4D. Here's how.

Step 1 - Creating the Animation in Poser and Exporting it

400-00e13.jpg

First, create your animation in Poser, and make a note of the number of frames that your animation takes, and also the framerate. The framerate isn't as important as the number of frames, but it is good practice to use the same numbers in Cinema 4D.

When you have finished tweaking your animation, save it, and get ready to export it. We will be using the Wavefront OBJ format to export the animation. To do this, go to File > Export > Wavefront OBJ.

In the EXPORT RANGE dialog box, select Multi Frame Export, and make sure that the frames you want are in the range.

400-00e23.jpg

In the Hierarchy Selection dialog, select the items you want to export. For the purposes of writing this tutorial, I used the default options. Exporting all clothes, hair and props with the figure works fine. However, I don't recommend exporting more than one person or animal at a time.

In the next box, which looks like a regular Save box, select the directory that you want to export to, and give the files a name. I simply called mine 'f' (without the quotes), as Poser automatically adds the frame number to the file, so frame 0 would be f_0.obj, frame 1 would be f_1.obj and so on.

In the next dialog box, make sure that ONLY Weld Body Part Seams is selected. UNCHECK everything else.

400-00e33.jpg

Click OK. At this point you may want to go and get something to drink, as it may take a while to export all the OBJ files.

Step 2 - Import the First OBJ into Cinema 4D

400-00e43.jpg

Open Cinema 4D. The first step is to set up the Project to match the settings you used in Poser. Go to Edit > Project Settings and change them to match your animation in Poser. I used a frame rate of 30 and 30 frames in Poser, but I didn't bother changing them here, as I knew I was going to extend the animation in Cinema 4D.

The next step is to import the first frame of the animation. To do this, go to File > Open and navigate to the directory where you exported the animation to. Select the first frame (for me it was f_0.obj), and click Open.

The first thing you will notice is that you cannot see the figure. To correct this, go to the bottom right hand corner of the C4D window and click on the little arrow next to Size. Select Scale. Type 100 into each of the three boxes above Scale and hit Enter.

In the Perspective view window, select Edit > Frame Selected Elements. You should now see the figure in the main window.

The next thing to do is to texture the figure. To help me with this, I used Babel. I won't go into the texturing process here.

Once you have textured your figure, go to the next step.

Step 3 - Create a NULL Object

400-00e52.jpg

Rename your original imported object as MASTER.

Next, create a NULL Object (Objects > NULL Object) and click on both the little traffic lights until they are red. This is extremely important, as it hides the NULL Object and its contents to both the renderer and the camera.

Next, import another copy of the first frame in exactly the same way you did before. Rename this new figure '0' (without quotes) and drag it onto the NULL Object. It becomes a child of the NULL Object.

400-00e63.jpg

NOTE: You do not need to rescale the NULL object or the other objects you put in it. Cinema does this on its own.

Next, you can either import the following frame (f_1), or skip this and import the third frame (f_2), as Cinema will interpolate the frame in between.

Step 4 - Create a Morph

400-00e73.jpg

Open the Timeline (Window > Timeline). Right click on the MASTER figure, and navigate to Morph (New Track > Special Effects > Morph). Right click on the Morph track that appears and select New Key. A dialog appears asking where you want the key. Type 0 into the box and click OK. A new key is added at Frame 0. Double click on the key and type 0 in the box. Click OK.

Repeat this for the next object you imported, selecting the key at frame 2, and typing 2 in the Search For box.

400-00e83.jpg

Now, go back to the perspective view and scrub the frame slider at the bottom along. You should see the figure move over three frames (0, 1 and 2).

Repeat the above steps for all frames of your animation.

Step 5 - Remember

*You do not need to scale the NULL object or anything that goes inside it. You only need to scale the MASTER object.

*You only need to texture the MASTER object.

*Change the little dots next to the NULL object so that they are BOTH RED.