User Tools

Site Tools


This page exists within the Old ArtZone Wiki section of this site. Read the information presented on the linked page to better understand the significance of this fact.

Easy RSR files !

Author: Corinne

Tools Needed

Introduction

What is an RSR file ? RSR is a special format of images used in Poser to create thumbnails in your libraries.

To make your Poser stuff or products look more professional, you need to create thumbnails for your MAT files, your character, your hair, whatever.

There are plenty of ways to create rsr. I've experimented a lot of them, and here is the one I like the most.

Step 1 - rendering

First of all, you have to know that your thumbnail has to be the most descriptive, in order to make your customers' life easier :) So we will be rendering parts of the product we want to showcase. Here's my method…

1. In Poser, in modify the size of my scene to a square. For example 600×600, or 400×400, etc. Imagine this square is going to contain your thumbnail, but in bigger size. Go in Window > Document Window size…

400-006d3.jpg

2. Compose your scene (remember that in order to keep things easy to undesrtand, less is more). For an head injection, for example, I will simply render the head of my character, with some hair and a skin, so she doesn't look awfully white. I will use a good and natural lighting, and an original pose so that my .rsr will be distinctive and not boring.

3. Render and (important) save your render in Photoshop format (.PSD) as shown in the screenshot below. Saving in Photoshop format will allow you to have a transparency (alpha) saved, you will be able to select your subject easily.

400-006e3.jpg

Step 2 - first steps in photoshop

Open your recently saved .PSD file with Photoshop. Go in your “couches” section, in the layers palette. You will see that there are color ones plus a black and white one. Select the black and white one (Ctrl + click on the layer).

400-006f3.jpg

Your screen should look like this, and one area (the white or the black) should be selected.

400-00703.jpg

Now return to the layers palette. Your character (or the space around it) is selected. If the space around it is selected, invert the selection (Shift + Ctrl + I, or Selection > Inverse).

When your character is selected, copy and paste it. A new layer should be created, you can erase the background one. And you have a transparency.

Step 3 - creating a png

Now you have your character only with the transparency, you will have to reduce the size of your file. A rsr is 91×91 pixels wide. So reduce your .PSD file to 91×91. Image > Image size.

Decorate your file ! I usually fill the background with a nice tile, add some + or - symbols when it's for injections, or add some text. You can do whatever you want, but be sure that your file is 100% filled in and has no more transparencies.

When you find that the file is ready to be transformed into a thumbnail, save it in PNG format. File > Save as… and choose the PNG format.

400-00713.jpg

Step 4 - converting in rsr format

So now you have a PNG file saved somewhere on your computer.

1. Open p3Do Explorer and browse to find the PNG you've just saved.

2. When you get it, select it, and go to into Tools > Convert Rsr2Png.

400-00723.jpg

3. In the window, make sur “.Png to .Rsr” ic checked.

400-00733.jpg

4. That's it, you should now have an RSR file !

Step 5 - Having your rsr working

1. Put your RSR file in the same library folder of the file that it will execute. For example, you have a MAT file called “skin.pz2” in your Pose library, you will put your RSR file exactly in the same folder.

2. You have to name your RSR file exactly the same as the executing file. For example skin.rsr. Case sensitive !

3. Run Poser, open your library : your thumbnail should be there !