Table of Contents

New Features

Current Version

4.9

(4.9.4.122)

See the 4.9.4 section for recent additions.

Forum Announcements
Summary


Daz 3D strives to provide the ultimate user experience in each update of the Daz Studio application. Along with various bug fixes, this update provides artists with new tools and workflow improvements that enhance ease of use and efficiency. A considerable portion of the changes and improvements included in this update are targeted specifically at browsing and managing your content.

In 4.9 we have added new features that help you manage and maintain content purchased with your Daz 3D account and uses a new content delivery service: Daz Connect. Now, directly within the application, you can find, install, and update products you have already purchased. You can also now purchase products directly within Daz Studio and put the new product-centric workflow to work for you. This allows you to browse products you have not purchased, which are filtered based on content you already have installed and you are currently working with.

The render engine updates in this release include performance improvements, bug fixes, and (in the case of the NVIDIA Iray renderer) a few changes that improve the overall quality of your renders.

Daz Connect

Login Dialog

Daz Connect is basically your connection between Daz Studio and the Daz 3D Store. It allows you to leverage a collection of new web-based services. The features that make use of these services, which will grow over time, currently include the ability to:

  • Browse products you have purchased, whether they are installed or not
  • Install or upgrade products with ease
  • Automatically download any products that are missing from a scene you are currently working with
  • See product suggestions, related to your current selection, to supplement what you are currently working on
  • Easily download purchased products as needed to whichever computers you are currently working on
  • Purchase new products and add new free products to your account

See also:

New Product-centric Workflow

The new product-centric workflow makes working with your content much easier. From buying and installing new products to navigating and alternating between products and files, the workflow has been redesigned. To get started, log in to your Daz 3D account to take advantage of the new workflow.

Optional Filtering Based on Context

In earlier versions, the Smart Content pane displayed filtered assets/products based on compatibility with the selected object and assigned content types. The 4.9 update now also includes a “Filter By Context” option (on the Files Page and separately on the Products Page), that lets you disable this filtering behavior and allows you to see content that may not be strictly built to work with the selected object. For instance, after adding a figure to the scene, selecting the “Hair” category in the Category View shows hair in the Results View that fits this figure. Similarly, once you have added hair to your character, the Smart Content pane automatically filters to show accessories and hair colors (materials) that work with that specific hair object.

Filter by Context

Turning off the “Filter By Context” option shows you all of the products you own, regardless of whether or not they are currently installed, as well as all of the installed files for your products. This is a great way to see all products you own, regardless of scene selection, and it provides access to content that was not specifically built for your selection but may be a suitable candidate for Auto-Fit. This allows you to apply content originally built for one figure (e.g., Genesis 2) onto another figure (e.g., Genesis 3). Although results may vary, turning Off the “Filter By Context” option lets you try those older products on newer characters.

Synchronized Navigation and Filters

Sync Pages

The new Sync Pages option helps you more easily navigate and alternate between products and files. When enabled in the Pane (Tab) Option Menu, Sync Pages attempts to synchronize category selection in one page with the corresponding category in the opposite page. For instance, if you are looking for long hair to add to your figure, you might start on the Files Page and select the “Hair” category, followed by the “Long” sub-category. Switching to the Products Page at that point causes the “Hair > Long” category to be automatically selected.

Installing Content

Using Daz Connect, you can now install products and assets directly within Daz Studio from the Smart Content or Content Library panes, eliminating the need to visit the Daz 3D website or to use Install Manager. This makes getting and installing content faster and more convenient.

Installation Process

Viewing a Product's Contents

The Product Contents View has been redesigned to be more user-friendly. Functioning much like the Files and Products pages, the new Product Contents View now expands and collapses vertically in a familiar tree-like manner and consumes the whole page instead of a side scrolling list limited to a fraction of the space. Jump “inside” a product to view that specific product's Category and Results Views. Once inside, you can quickly access more information about the product (i.e., Read Me), update the product (if installed using Daz Connect), view the assets in the product, etc., as well as take advantage of the features described below.

Product Content View

Filtering Products by Installed State

The Install State Filter Bar filters products displayed in the Results View a step further than the categories and sub-categories can on their own. This lets you view a product based on its status. Rather than search one by one through products, this option quickly filters products to show those that are installed, those that are have not been installed, those that need updating, and those that are currently in progress.

Install Sate Filter Bar

Sorting Products/Assets

Located directly beneath the Filter Bar, the Sorting Selector lets you sort assets or products using various attributes—such as Name, Product ID, Group ID, etc.—to make assets and products easier to find.

Sorting Selector

Assigning Products and Assets to Groups

Group

Grouping helps you customize your content by letting you personalize the display of products and assets, which makes identification at glance even easier. Much like using a brightly colored marker or sticky notes, the Group feature marks assets and/or products in the Results View to help you visually group them using colors and shapes.






Purchasing Content in the Store Page

While you are logged in to your Daz 3D account, the Store Page, found in Information Panel section of the Smart Content pane, shows products and assets that can be purchased, in context to what is currently selected. For example, if you have a sword selected in the Smart Content pane, the Store page may display armor and other weapons for purchase that correspond with that sword. This page also bypasses the Install Manager, making buying and installing new content just a click away.

store

Render Engine Updates

Renderer engine updates include changes and bug fixes for both NVIDIA Iray and 3Delight render engines.

NVIDIA Iray

The NVIDIA Iray1) update provides fixes to the implementation of Sub Surface Scattering (SSS) and affects materials that make “Translucency Weight” active (not set to 0). This makes skin tones appear more blue than they do in previous versions.

The image on the left is the result of 4.8 skin settings rendered in 4.9, and the image on the right is using a modification of the “SSS Reflectance Tint” from a light blue to a light yellow color. Daz Original products will be updated to reflect the 4.9 rendering changes, but if you encounter any products that render with a bluish tint, feel free to edit the “SSS Reflectance Tint” value to adjust the result to your liking.

The Mac version now requires OS X 10.7 or later. See here for more information.

3Delight

The 3Delight2) update includes bug fixes and improvements as outlined in the 3Delight Change Log.


4.9.2

Easier Product Installation

Install Pane

The Install Pane

The new Install pane uses filters to give you an easy place to find the products you own and install them locally. Here you can see the products that are not yet installed. Once a product is installed in this new pane, you can update or uninstall it from the Smart Content pane or the Content Library pane.

The Install pane is organized similarly to the Smart Content pane with a Category View and a Results View as well as an Install State Filter Bar at the bottom. This filter bar provides options for separating the available products for installation on the Available page from the products undergoing or awaiting installation on the Pending page. You can also choose to install or cancel several selected products at one time using the Install/Cancel Selected button.

Better Content Management

Both the Smart Content and Content Library panes are updated to enhance the various ways Daz Studio users can organize their content.

The Smart Content pane relies on metadata to sort and organize your content into categories. As you may know from past experiences, older products sometimes have incorrect or incomplete data, products from other sources may have no metadata at all, and sometimes categories are updated or added to a product after the fact. In order to make cleaning things up and getting updates to that data easier, Daz Studio 4.9 introduced Daz Connect. With Daz Connect, Daz Studio connects to the Daz 3D servers and retrieves the latest metadata for the products you own.

Another new feature included in this update is a change to the “ownership” of the “Lost and Found” subcategories and the assets assigned to them; this allows you to modify the categorization of these assets and even remove the subcategories themselves so that you can organize your content the way that works best for you. Lost and Found Category

Lost and Found

The Lost and Found category is now prominently displayed above all your existing categories. On the Products Page of the Smart Content pane, the Lost and Found category shows you products containing uncategorized files. A subcategory of Lost and Found is created using the name of each product containing these files. This lets you quickly and easily find any product files that are uncategorized so that you can categorize them as you see fit.

Categorization

One of the ways you categorize assets has been improved. The way you get there is still the same; simply right-click an asset and select “Categorize…” in the context menu. However, when the “Categorize” dialog appears, you now see the categories that the selected asset is assigned to, such as the Lights category if a light asset were selected, in a way that is consistent with what is displayed in the Category View. The updated dialog removes the top-level “Categories” column, as well as the “Default” column unless a user category has been created as a sibling to the “Default” category.

To help you differentiate between the default categories and any user categories you might create, the icon for each user-created category is styled differently from the defaults and marked with a “U.”

Categorize Dialog To create a category path, right-click a category and click the “Create Category Path…” action in the menu. The “New Category Path” dialog will display and be populated with the full path of the selected category. Here you can edit the category path to meet your needs and create new user categories to assign the asset to. Once accepted, the path automatically appears in both the Categorize dialog and the Category View.

Better Filtering

Now you can find products much easier than before by using the name of the product (or a portion of the name) instead of relying solely on the keywords assigned to the assets. Files can also be filtered in much the same way, but “name::” must precede the name of the file; i.e., name::Victoria

Filter Menu Another new feature that improves filtering is the Filter Menu. In this menu you can save a filter, you can apply filters you have already saved, and you can manage your filters. Clicking the Save Filter option in the menu allows you to assign a name to a specific word/phrase/expression that you use often (or find difficult to remember) and save it to the Filter Menu. For example, if you filter using the “name::warrior knives” expression, you could then save that expression with the simplified “Warrior Knives” name. Once saved, you can then apply that filter by clicking on it in the Filter Menu.

Virtual Folders in Content Library

Products installed through Daz Connect are managed on disk by the application in order to ensure consistency and the ability to update those products at the file level. Although installed in separate folders on disk, an aggregate view of the folders is available for you in the Content Library pane and emulates the structure of files installed through Install Manager. Virtual Folders

Ongoing Metadata Updates

Metadata Consistency

If you have two or more identical user-facing files assigned to separate products, you can categorize one, and Daz Studio now automatically categorizes the other(s) the same way.

New “Edit Metadata…” and “Export Metadata…” options are now more conveniently located in the Content Library context menus to help make editing/exporting metadata easier.

A Daz JSON Link is the equivalent of a “shortcut” (on PC) or an “alias” (on OS X). Because the folder/file structure for products installed via Daz Connect must remain intact, DJLs can be generated for these files and used as placeholders for the purpose of disk-based management.

New Iray Version

NVIDIA has released a New Version of the Iray renderer with several bug fixes and additional features.

New Draw Modes

This version of Daz Studio has new Draw Modes located in the Draw Settings pane, under Drawing > Draw Mode. Here you can now choose among Photoreal, Interactive, or blend between the Draw Settings Draw Mode and Render Settings Render Mode. Draw Modes Another new option is the Manipulation Resolution property, which allows you to render quicker than before by temporarily decreasing the size of the rendered image and stretching it to fill the view during manipulation. Choose to divide the rendered pixels by 1/2, 1/4, 1/8, or 1/16 (or 1/32 for very large displays) of the selected viewport. Since there are fewer pixels to render, this new drawing option makes interactive rendering quicker by rendering fewer details during manipulation and waiting to render them when the mouse is released instead.

Iray Light Portals

Light Portals allow you to “hint” to the renderer the location of openings where light might naturally come in through windows for interior scenes. Since sun and sky lighting can often be too bright for indoor scenes, these portals account for how much and where light enters a room. How effective these portals are at “guessing” where light might appear is dependent on your scene and how large the “windows” in the scene are.

Since a significant amount of illumination comes through windows, larger windows may let in too much light when using light portals. This illumination through the windows is not dominated by direct sunlight or other very bright regions in the environment, so comparing two rendered images—one with light portals, one without—can help you see if they are beneficial to your scene.

To begin using a Light Portal, you must first enable the Caustic Sampler property in the Optimization group found in either the Render Settings or Draw Settings panes. Then add a Spotlight or a Point Light to your scene. A Light Portal property appears under the Light > Area group when the Photometric Mode is enabled and the Light Geometry property is set to Rectangle in the Parameters pane. Enabling this Light Portal property causes the light to be seen by the Iray renderer as a light portal instead of as a light.

Updated Iray Uber Material

The Iray Uber Shader now adds an extra layer in the Base > Diffuse > Overlay group. This layer is ideal for adding details like makeup or tattoos in the diffuse section of the Iray Uber Material.

Diffuse Overlay

Other Enhancements

Other bug fixes include a new “Export Measurements” action to the Measure Metrics pane and improvements that allow you to import figures that were not exported from the FBX Exporter. The FBX Importer also now handles more general weight configurations.

For other various bug fixes and details, see the Change Log.


4.9.3

NVIDIA Iray

Bridge

Updated to 2016.3 (see this post for more information)

  • Added “batch” mode (or “queueing”) support for network rendering via Iray Server and/or VCA for still images; animations are not currently supported
  • Exposed lens and aperture settings via a “Lens” property group on cameras
    • Lens Radial Bias
    • Lens Shift X (mm)
    • Lens Shift Y (mm)
    • Lens Stereo Offset (mm)
    • Lens Distortion Type (spherical, cylindrical, stereo, etc)
    • Lens Distortion K1/2/3
    • Lens Distortion Scale
    • Aperture Blades
    • Aperture Blade Rotation
  • Exposed spectral rendering settings via the Render Settings pane
    • Spectral Rendering Enable
      • Spectral Conversion Intent
      • Spectral Observer

Automatic Login

Daz Connect

Feedback from our user-base indicated a desire for the ability to automatically login to Daz Connect when the application launches. With this release of Daz Studio, you can now do exactly that. This feature is designed to be used with the “Remember Me” option. If you change your account credentials, the automatic login will silently fail and you need to login again with your new credentials.

The “Automatically Login” option can be accessed in the Account Login dialog and the Store page on the Smart Content pane, as well as a newly added “Automatically Login With Remembered Credentials” option in Edit > Preferences.

Database Driven Content Views

Modifications to the database-driven content views (e.g., the Smart Content pane and the Presets pages in the Posing, Shaping, Surfaces, Lights, Cameras, and Render Settings panes) improve its functionality and offer you greater flexibility in managing content categorization.

In previous versions, a user had the ability to remove an asset from a category, but often times the asset would be re-assigned to the category that the user removed it from when a Metadata Update was performed. This was because there was no record that indicated the user removed the asset from the category. In this version, when a user “removes” an asset from a vendor category, the vendor categorization is not “deleted,” rather it is “hidden” from view unless/until the “Show Hidden Vendor Categorizations” preference is enabled. What this means for you, the user, is you can re-categorize assets in any way you choose and Daz Studio will “remember” your changes during a Metadata Update.

Note: The state of the “Show Hidden Vendor Categorizations” preference has no bearing on the categories or categorizations displayed in the Content Library pane, the Categorize dialog if launched from the context menu of an asset in the Content Library pane, or the Content DB Editor. These particular views are provided for managing content and, as such, display all categories and categorizations that exist in the database.

"Lost and Found" Categorization

Migrated assets (i.e., assets installed via Install Manager or assets created in pre-4.9 versions) are now assigned to a “Lost and Found” sub-category if the asset has no categorization.

Content Library Pane

Creating products from selections in the Content Library pane has been improved. In addition to the previous methods, a “product” can now be created by selecting the “Create a Product from…” action in the context menu for Search and Category containers, as well as selected assets in the Asset View.

Surfaces Pane

The Surfaces Pane now behaves similarly to the Smart Content pane with extended search types to include language specific preset/materials, preset/materials/hierarchical, and preset/shader content types (i.e., MDL, RSL, OSL, LXM, MC6, MT5).

Viewport Tools

Viewport Tools

A new “Secondary Nodes” option has been added to several Viewport Tools, specifically the Universal, Rotate, Translate, and Scale view tools. When enabled, this option provides the ability to manipulate multiple selected nodes in the same manner as the primary (most-recent) selected node, using the manipulator displayed in the viewport for the primary selected node.

Geometry-Based Tools

For geometry-based tools, such as the Geometry Editor tool and the Weight Brush tool, we have added actions to their context menus that allow you to select/deselect by geometry islands. This lets you quickly select “islands” of contiguous geometry based on where they fall in relation to various axis/planes. These new options are located in the viewport context menu under Geometry Selection > (De)Select By > (De)Select Geometry Islands….

Transfer Utility

Modifications have been made to the algorithms used by the Transfer Utility to improve its results.

We have added a “Closest Vertex First” option that, when checked, uses a Bounding Volume Hierarchy (BVH) to determine how various pieces of information are projected from one object in the scene to another; this produces the same results as previous versions. When this option is unchecked, an Octree data structure is used instead and a more accurate result can be obtained.

Bug Fixes and Other Changes

We have fixed bugs in various areas and made other changes not mentioned on this page. See the Change Log for more information.


4.9.4

NVIDIA Iray

Updated to 2016.3.2 (see this post for more information)

  • Added support for chromatic subsurface scattering color
  • Added a “Scatter & Transmit Intensity” option to the “Base Color Effect” property
  • Added support for dual lobe specular

PowerPose

An extremely useful tool already, the improvements made to PowerPose in this update target usability and greatly increase the configuration abilities of the templates that define how users interact with a figure. These changes pave the way for effectively using the PowerPose pane with the Genesis figure platform (see this post for more information)

Auto-Fit & Transfer Utility

Several improvements have been made to both the Auto-Fit and Transfer Utility features, which allow items that were originally built for one figure to be automatically adjusted to fit to another figure through the use of “Clone Assets.” With this update, these “Clone Assets” are now capable of including additional information that improves the results of both tools.

Previous Versions

1) Version 2015.3.6
2) Version 12.0.27