Export As: [ PDF | ODT ]

Exporting a TriAx™ Weight Mapped Figure to Poser 9 [Pro 2012]

This tutorial requires functionality that is only present in DAZ Studio 4.0.2.66 and newer. Refer to the DAZ Studio 4.x page for information relating to current version numbers.

Summary

DAZ 3D introduced a new method of rigging figures, known as TriAx Weight Mapping, in DAZ Studio 4.x. This method of rigging produces much more aesthetically pleasing results1) than the Parametric Joint Parameter system that has been in use and considered the norm for more than a decade.

While DAZ Studio has always had its own native formats2), significant effort has been made over the years to support the Poser format and its various file extensions. With DAZ Studio 4.x, this continues to be true. DAZ 3D has worked with Smith Micro to provide support for this new technology in Poser 9 and Poser Pro 2012. And while the experience of using a TriAx Weight Mapped figure in Poser is not quite at the same level that exists in DAZ Studio, DAZ 3D has updated its CR2 Exporter plugin3) to produce files that can be read by Poser.

It is important to note that the process of exporting a TriAx Weight Mapped figure, such as Genesis™4), for use in Poser 9 is in its infancy and still needs a bit of refinement. We realize the process, in its current form, is less than ideal and we aim to significantly improve/simplify it. But, we do not want to prevent users that are knowledgeable enough and/or brave enough to go through the steps from being able to use this exciting new content in the applications they choose.

Process Overview

  • Launch DAZ Studio 4.x
  • Load a TriAx Weight Mapped figure into the scene
  • Choose the desired UV set and/or apply a Materials preset
  • Export the geometry for the figure, with the current UV set, in OBJ format
  • Export rigging, morph and texturing information in CR2/PMD format
  • Load the exported CR2 in Poser 9 / Poser Pro 2012

Foundation

  • Poser utilizes a content system that typically consists of a figure file (cr2) that references a geometry file (obj), a morph file (pmd) and several image files (jpg/png/etc). While the image files can be shared in place between the applications5), all of the other files must be generated.
  • Poser defines a “unit” at a much larger scale than many 3D applications. This has the effect of making an object at Poser scale appear much smaller in those applications if it is not converted during import. Likewise, an object that has been exported at the scale of one of these other applications will appear significantly larger when imported by Poser. So, there is an issue of scale that must be handled. DAZ Studio defines 1 unit as being equal to 1 centimeter (cm). Unfortunately, Poser has been inconsistent over the years, defining 1 unit as being equal to 8 feet (ft) or 243.84 cm and then later as 8.6 ft or 262.128 cm, and at a point in between as a mixture of the two. Due to the inconsistency, and the unreliability of version numbers being accurate in manually edited Poser format files, DAZ Studio consistently uses the originally defined 1 unit = 8 ft or 243.84 cm when interpreting data from Poser and the inverse when writing to Poser format files.
  • DAZ Studio provides an ability to change UV coordinates for an object after it has been loaded into the scene, using a property provided on each surface, in the Surfaces tab. Poser does not provide this same ability, so extra caution must be taken to ensure that the intended UV coordinates are present upon loading the figure.
  • DSF based figures, in DAZ Studio, are built with extensibility in mind. When a DSF figure is loaded, all of the file based assets, such as morphs and UV sets, that are present in the appropriate data folders are loaded as well. Poser does not handle its assets in the same way, instead requiring explicit reference to any files that are to be loaded.
  • DAZ Studio provides the ability to use a Catmull–Clark subdivision surface to represent the final shape of the 3D mesh. With an articultated figure, such as Genesis, the division of the mesh is applied at the very last stage - after the figure has been shaped and posed. This allows the base mesh of a figure to use a much lower resolution intially, which reduces the amount of system resources consumed while manipulating the figure, while also providing a very organic looking result - due in large part to the principles behind these types of surfaces. Poser does not provide the same functionality, and thereby does not produce the same result.

Step By Step

Note: These steps assume you have already launched DAZ Studio 4.x, and that you have the TriAx based figure that you want to export already loaded into the scene.

Step 1 : Prepare the Figure

  • From the Main Menu Bar, choose Edit > Figure > Zero > Zero Figure6). This prepares the figure for exporting the base mesh in its modeled state, without any influence from the rigging. This is important because the mesh needs to be in its modeled state for the rigging to work properly, as the rigging is stored and applied relative to the base mesh state.
  • In the Parameters (WIP) tab:
    • With the root/skeleton node selected7), use the left side of the pane to navigate to General > Mesh Resolution.
    • On the right side of the pane, set the Resolution Level to Base8). This determines the density and base shape of the geometry that will be exported in the next step. This value is important, as it impacts both the rigging and morphs which both depend on vertex count, order and base position to be correct.
      • Technical Issue: Setting the Resolution Level to High Resolution and the SubDivision Level to 0 does not adequately address the fact that the base mesh, and therefore the morph deltas and weight maps, are built on the concept of a subdivision surface; more specifically, the Catmull-Clark algorithm being applied after the modifier stack. Setting the Resolution Level to High Resolution and the SubDivision Level to a value greater than 0 creates a vertex count/order incompatibility between the morph deltas and the base mesh, as well as the weight maps and the base mesh. Without proper support for the Catmull-Clark algorithm being applied after the modifier stack, in Poser, the experience will remian less than desireable for organically shaped figures that utilize SubD.
  • In the Surfaces (WIP) tab, Editor page:
    • Select the Genesis figure in the list on the left side. This causes all Surfaces for the mesh to become selected and allows us to see if there are conflicting values9) and manipulate them all at the same time, if we need or want to.
    • In the Property Filter text field at the top of the right side, type UV Set. This will filter the list of properties in the view, leaving only one slider labeled (26): UV Set10).
    • Verify that the UV Set property is set to the appropriate value. The value chosen here determines which UV Set will be exported with the geometry in the next step. Be sure to note the name used as we will use it in the next steps.

Step 2 : Export the Geometry

Note: This step assumes that there is only one figure, the figure you want to export, in the scene.

  • From the Main Menu Bar, choose File > Export…
  • In the Export File dialog:
    • Choose Wavefront Object (*.obj) as the file type
    • Navigate to the ./Runtime/Geometries/DAZPeople/Genesis folder in one of your mapped Poser content directories.11) While not neccessarily important for the first time you do this, it is important to note that you should be consistent in choosing which of your mapped Poser content directories you will export geometry to. Failure to do so can result in unintended consequences when the applications attempt to resolve references that are written into the Cr2 file, while loading.
    • In the File Name12) field, provide a name that represents the current state of the Genesis mesh. For instance, if the UV Set chosen above is the one that allows you to use textures built for Michael 4, then a name you could provide here is “Genesis_Michael4UV.obj” or “Genesis_M4UV.obj”.
    • Accept the dialog.
  • In the Obj Export Options dialog:
    • Click the Show Individual Settings » button, near the bottom of the dialog, to display all of the available export options. Note that the text of this button changes to Hide Individual Settings « when the options are already being shown.
    • Using the drop down labeled To:, near the top of the dialog, select the Poser (1 unit = 8ft) preset. This will set the appropriate scale and axis orientation for the geometry.
    • Uncheck the Ignore Invisible Nodes option. If this option is checked it may cause issues with vertex count and order, which are very important for morph and joint binding.
    • Uncheck the Use Bone Welds option. This is an older option, needed before geometry pipeline changes were made in 4.0.2.x. This option may be removed in a future version.
    • Under the Write Groups group, choose the Use Existing Groups option. Not choosing this option may cause certain geometry groups (i.e. the hip of Genesis) to be missing when imported into Poser.
    • Under the Write Surfaces group, uncheck the Write Material Library option. Writing this extra file would be redundant, considering that the Cr2 generated in the next step will contain the applicable material definition already.
    • Accept the dialog.

Step 3 : Export the Rigging, Morphs and Texturing

  • From the Main Menu Bar, choose File > Export…
  • In the Export File Dialog:
    • Choose Poser Cr2 File (*.cr2) as the file type.
    • Navigate to the ./Runtime/Libraries/Character/DAZ Genesis folder in one of your mapped Poser content directories.13)
    • In the File Name14) field, provide a name that represents the current state of the Genesis mesh. For instance, if the UV Set chosen above is the one that allows you to use textures built for Michael 4, then a name you could provide here is “Genesis - M4 UVs.cr2”. The name you choose is not particularly important. What is important is that you name the file in a way that tells you the morphs that are available and/or the UV Set in use.
    • Accept the dialog.
  • In the Cr2 Export Dialog:
    • Set the Poser Version Tag to 9.
    • Set the Figure Type to Base Figure.
    • The Base Path and Cr2 Path fields should already be populated with values derived from the path chosen in the previous dialog.
    • The Uses ExP and Collect Files options should both be unchecked.
    • Accept the dialog to begin the export.
  • At this point a progress dialog will be displayed as the exporter does its work. To avoid causing alarm, it is important to note that since DAZ Studio delay loads morph delta information only when a particular morph is in use, to optimize system resources, you will notice many entries in the status text indicating morphs are being loaded. This is necessary in order to export the delta information to a PMD file that lives next to the Cr2, so that the morphs can be used in Poser.
  • In the Obj Path Selection dialog:
    • Use the Browse () button to locate the obj file that was exported in Step 2.
    • Accept the dialog to continue the export.

Step 4 : Load the Figure, in Poser

  • With the application already running, open the Poser Library window. If the window is not already displayed on the screen, clicking the icon in the upper right corner of the interface will open it, as will choosing the Window > Libraries option from the main menu.
  • On the Library tab of the window, select the first icon in the top left corner of the tab to see a list of the available Figures.
  • Navigating to the DAZ Genesis sub folder within the mapped Poser content directory you chose in step 3, locate the exported Cr2 file.
  • Load the figure into the scene, using whichever method you prefer. The item in the list can be double clicked, dragged and dropped on the viewport, or one of the two check buttons in the bottom left of the window can be pressed.

Technical Issue: In Poser, using Edit > Restore > Figure will cause the figure to “explode.” It appears that the Cr2 Exporter is not scaling some joint values (OffsetA) properly. Using Figure > Zero Figure, then Edit > Memorize > Figure, then Edit > Restore > Figure appears to work around the issue. This has been fixed in a build after 4.0.3.9.

Wrap-Up

As stated earlier, this process is in its infancy and needs refinement, but you will get good results if you follow the instructions above.

1) and much more control over deformation of the mesh as a joint bends, moves or scales
2) DSF being added in 4.x
3) included FREE in DAZ Studio 4.0.2.61 and newer
4) included in DAZ Studio 4.x
5) provided the the same directories are mapped in both applications
6) this action is also avaialble from the Parameters Tab Option Menu, at Zero > Zero Figure
7) either by using the Scene (WIP) tab, right clicking and choosing it from the context menu or double-clicking one of the figure's bones in the Viewport
8) when Resolution Level is set to Base, the SubDivision Level is ignored
9) often indicated by the value <Multiple> being displayed
10) the (26): refers to there being 26 properties with that name, distributed across all of the selected surfaces on the Genesis figure - the number may be different for other figures
11) , 13) You may need to create one or more of the directories in the path if they do not already exist.
12) , 14) this may be named differently depending on your OS