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Welcome to Carrara 
Welcome to DAZ 3D™ Carrara™ 7, the latest 3D program for desktop artists and animators, Web 
designers, and multimedia producers. Carrara is ideal for creating 3D graphics for magazines, ads, Web 
sites, or almost any illustration that would benefit from the powerful 3D impact of realistic perspective and 
shading. 

Carrara 7 software’s powerful animation features let you create professional quality animations and 
models for video, multimedia, and the Internet. With Carrara software’s key-event, dynamic, and timeline-
based animation, you can produce anything from flying logos to character animations. You can create 
broadcast quality output for square or non-square pixels, and output that is NTSC color safe. 

Carrara 7 offers a complete 3D graphic development environment in one package, allowing you to create 
a scene, model objects that populate it, and create environmental effects. You can then animate the 
results if desired and, finally, render the resulting scene, using one application. 

Carrara can also be an invaluable tool for interactive multimedia. It supports low-polygon modeling and 
popular formats such as GIF, JPEG, OBJ, 3DS, AVI, Quicklime, and sequenced movies. 

Carrara software’s open architecture allows new functionality to be added through extensions. The easy-
to-use interface is designed around the SmartFlow workflow, guiding you through the 3D creation process, 
yet allowing complete creative freedom. 

What's New in This Version 
Carrara 7 adds a number of improvements that cover its whole range of use. Whatever you use Carrara 
to do, Carrara 7 will help you do it better and faster. Here is quick description of some of those 
improvements:  

Carrara 7 
• Vertex Modeling Updates: Vertex objects can now be modified while in the Model room without 

switching back and forth between rooms. 

• Content LOD Support: Adds the ability to load and use Level of Detail meshes and control which 
meshes are used based on distance from the camera. 

• UV UI Enhancements (Standard, Pro): The UV Editor has been expanded allowing editing of 
UVs in the main viewport. 

• UV Unfolding (Pro Only): Adds the ability to unfold UV maps when in the UV Editor. 

• UV Relax Seams (Standard, Pro): Adds the ability to relax UV seams when in the UV Editor. 

• 3D Painting (Pro Only): Provides the ability to paint directly on objects using color, shaders, and 
imported textures. Also includes real bumps and specularity display in OpenGL 

• Multi-Pass Rendering (Pro Only): Adds multi-pass  rendering to Carrara so that different 
components of the final render can be rendered out individually to separate images or layers. 

• COLLADA Export: Provides export in the COLLADA file format to support the DAZ Studio 
COLLADA Exporter and further integration between Carrara and DAZ Studio. Currently only 
available for PCs. 

• COLLADA Import (Standard, Pro): Provides the ability to import files exported out in the 
COLLADA file format. Currently only available for PCs. 
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• Non-Linear Animation Merge Tracks: Provides an improved interface to create groups of tracks 
then collapse or expand the tracks in those groups. Helps optimize the screen space so you can 
focus on your animation. 

• Specularity and Bump Display in OpenGL (Pro Only): When in OpenGL mode, specularity and 
bump can be seen in real time on the object when supported by the video card. Changes made to 
the texture for bump and specularity are updated in real time. 

• Larger OpenGL Texture Display: Improves Carrara’s rendering of textured objects in OpenGL 
by using higher texture resolutions when supported by the hardware.  

• Rendering Optimizations for Transparency: Time consuming and complex transparency 
rendering operations have been optimized to provide better and faster results. 

• DAZ Studio Content Support Improvements - Includes enhanced the handling of .DAZ scene 
files being loaded into Carrara 7.0. Requires DAZ Studio Build 2.3.3.138 or higher. 

Carrara 6 

General 
• New Unicode Support: Allows you to use just about any character set you want (Chinese, 

Japanese, French, and so on). This feature not only allows you to use these characters to name 
objects, but you can also use them in the Text modeler to create text in any language. Carrara 6 
also gives you the ability to add any character font to the user interface so that it supports your 
language.  

• Multiple Selections: Support has been extended so that you can simultaneously edit some 
properties of two or more selected objects in the properties panel. For example, you can hide 
several objects at the same time, or change the intensity of several lights together, increasing 
your productivity.  

• OpenGL Improvements: An improved engine that supports texture maps with alpha channels, 
and improved textured mode display. OpenGL performance has also been improved in the Vertex 
modeler to allow editing of larger meshes.  

Animation 
• New Euler Angles for Rotations: Until now, Carrara only supported Quaternion interpolation for 

rotation, which did not allow you to edit the three rotation angles independently. Carrara's new 
"Euler angle" interpolation mode adds even more control for character animation.  

• New Hair/Fur Modeling: This major new feature adds a completely new hair primitive and a 
powerful Hair modeler and simulator. You can apply hair to an object, brush it, and style it. The 
hair can also be shaded and have various effects such as clumping or freezing.  

• New Hair Simulation: In addition to creating hair, another major new feature is the addition of 
hair simulation, which allows you to simulate the motion of the hair. Hairs interact with other 
objects and can have forces applied to them.  

• Rigid Body Simulation: Carrara's physics engine has been improved. Simulations now perform 
up to 10 times faster and are more stable. The workflow has been improved and includes a 
button that allows simulation on demand and avoids constant recalculation of the physics.  

• Non-Linear Animation: Another major new feature in Carrara 6, this new engine completes the 
Carrara animation toolset. Create clips of animation that you can reuse and combine on multiple 
tracks. Blend clips together, or use a single clip (such as a walk cycle clip) to build a longer 
animation (such as a character walking down a road). Create a walking character in one layer, 
and then add another separate layer that makes him wave. The two individual animation layers 
are combined into one fluid animated result.  
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Content Support 
• Figure Support: DAZ content is now fully supported in Carrara. This includes better support for 

skinning and morph targets. Manipulation is up to ten times faster. You can select a bone simply 
by clicking the geometry of the figure. Properties associated with a body part are displayed with 
its associated bone, and all parameters are supported.  

• Content Browser: You can now use a content browser to browse through and select DAZ 
content to add to your scene. Drag and drop figures, clothing, props, and poses into your scene 
and apply them to your figures.  

• Conforming: Conforming figures are now supported, including morph crosstalk.  

Nature Modeling 
• New Scene Scaling: You can now select the size of the scene when you create a new scene. 

Camera speed, the size of the working box, and the default size of the primitives are adjusted 
accordingly. This makes it easier to create large landscapes in real-world scale, and also 
increases realism with atmospheric effects such as clouds and atmospheric blues.  
 

NOTE! The default measurement unit in Carrara is feet. If you want to work in inches, type 
"in" after you enter a numerical value of measurement.  

• New Landscape Wizard: Use the new landscape wizard to create many different landscapes. 
Combine terrains, shading, sky, and rendering presets. This wizard makes it easy to create a 
beautiful landscape scene that you can use as a starting point for your projects.  

• New Ocean Primitive: Allows you to realistically simulate the surface of the ocean. You can 
create still and animated oceans with high realism, with complete control over the size of the 
waves or the speed and direction of the wind.  

• New Terrain Features: To add even more detail on terrains, you can use the render time 
displacement features to apply a displacement shader to the surface. The displacement is 
calculated at render time, thereby allowing you to create incredibly detailed terrains without 
adding extra geometry that uses more memory.  

Vertex Modeling 
• New Displacement Modeling: This new modeler allows you to paint displacement on your 

objects, adding complex detail to your object without adding extra geometry.  
• New Symmetrical Modeling: This new feature allows you to edit both sides of a symmetrical 

object at the same time, and is ideal for character editing. Most of the modeling tools support this 
feature, thereby cutting your modeling time in half.  

• New Edge Extrusion: The Edge Extrusion tool lets you extrude corners of objects interactively.  
• New Figure Editing: You can now edit the mesh of an imported figure, as well as create new 

morph targets and full body morphs within the Vertex modeler.  
• Vertex modeler Optimizations: A number of optimizations improve performance on larger 

meshes. You'll see improvements when you move, scale, or rotate points. Other noticeable 
optimizations are in OpenGL redraw speed and subdivision surface updates.  
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Shading and Lighting 
• New Transparency with Absorption: Transparencies now support realistic absorption functions. 

This feature is ideal for simulating shallow water.  
• New Single Scattering: This new feature is used to simulate light from small particles that are 

inside a medium. For example, you can use it to simulate steam in the atmosphere. It is an 
indirect lighting effect that can also be used to simulate water more accurately.  

Rendering 
• Blurry Reflections Optimized: Speed and quality of blurry reflections have been optimized when 

multiple blurry reflections are used, or when they are combined with soft shadows or raytraced 
depth of field.  

• Depth of Field Improvements: Speed and quality of raytraced depth of field is optimized when 
used in conjunction with multiple blurry reflections or soft shadows.  

• New Shadow Bias: A new parameter is included in raytraced shadows. It corrects self-
shadowing effects due to the low resolution of an object. Shadows are now much cleaner.  

Import/Export  
• New DirectX Import/Export: Import and export geometry, materials, skinning, and animation in 

DirectX format.  
• New DAZ Studio Import: Import complex scenes from DAZ Studio into Carrara. You can then 

manipulate the figures and props directly within Carrara.  
• Discontinued Formats: Carrara 6 no longer imports Amapi, DWG, OpenInventor/ VRML, or STL 

formats. 

Installation 

NOTE! See "Setting Imaging and Scratch Disk Preferences" for information on how Carrara uses 
the hard disk. 

Macintosh Installation 
System Requirements: 

Carrara works on any Power Macintosh® with at least the following configuration: 

• Mac®. Intel or Power Macintosh® 700 MHz (1 GHz or faster recommended). 

• Mac®OS X 10.3.9 or above. 

• 512 MB RAM minimum (1 GB recommended). 

• OpenGL compatible graphics card. 

• 300 MB free hard drive space for installation (500 recommended) 

• 32-bit graphics color depth. 

• CD-ROM drive. 
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NOTE! Will not function installed on a UNIX partition under Mac OS X. 

To install your Carrara Software (Download version): 

1. Turn off any virus protection and compression programs and close any other applications 
currently open. 

2. Double-click on the installer icon you downloaded from your DAZ 3D account and follow the 
instructions on the screen. 

To install your Carrara Software (CD-ROM version): 

1. Turn off any virus protection and compression programs and close any other applications 
currently open. 

2. Insert the Carrara 6 application CD-ROM into your CD-ROM drive. 

3. Double-click the Installer icon from the CD-ROM and follow the instructions on the screen. 

Windows Installation 
System Requirements: 

• Carrara works on any PC-compatible computer with at least the following configuration: 

• Pentium III processor, 700 MHz (1 GHz or faster recommended). 

• Windows 2000® (Service Pack 2), Windows XP®, Windows Vista®. 

• 512 MB RAM minimum (1 GB recommended). 

• OpenGL compatible graphics card. 

• 300 MB hard drive space for installation (500 recommended). 

• 32-bit graphics color depth. 

• CD-ROM drive. 

NOTE! For information on how your Carrara software uses the hard disk see "Setting Imaging and 
Scratch Disk Preferences." 

To install your Carrara Software (Download version): 

1. Turn off any virus protection and compression programs and close any other applications 
currently open. 

2. Double-click on the installer icon you downloaded from your DAZ 3D account. 

3. Follow the instructions on the screen. Click Next to confirm each option and move to the next 
screen. 

4. After your software has finished installing, click Finish. 

To install your Carrara software (CD-ROM version): 

1. Insert the Carrara 6 application CD-ROM into your CD-ROM drive and click the Install button. 
Windows locates the installation program on the CD-ROM. 

2. Follow the instructions on the screen. Click Next to confirm each option and move to the next 
screen. 

3. After your software has finished installing, click Finish. 
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About Your Documentation 
This manual provides all the information you need to get the most out of Carrara 6. It will help you learn 
the application and serve as a reference as you attempt more sophisticated procedures and effects. 

This guide assumes you are already familiar with basic Macintosh and Windows concepts—menus, 
dialogs, and mouse operations such as clicking and dragging. If you need more information on these 
subjects, or on the Macintosh Finder or the Windows Desktop, refer to the Apple Macintosh User’s 
Manual or the Microsoft Windows User’s Guide, respectively. 

Computer graphics and 3D modeling use special terms usually explained where introduced. In addition, 
the Glossary gives concise definitions of many terms. 

Conventions 
This Guide is for both Macintosh and Windows. By convention, Macintosh commands precede Windows 
commands in the text. For example: 

• Command/Ctrl+I is equivalent to the Macintosh Command-I and the Windows Ctrl+I.  

• For simplicity, the term folder refers to directories as well as folders. The Carrara interface for 
both platforms is identical unless otherwise specified. 

There are also several conventions used to identify paths to certain tools and controls:  

• The convention for a menu follows the rule of the menu name> menu item.  

• The convention for a palette or tray is palette name: button name: palette panel: palette item.  

Version Content 
This manual contains features for all versions of Carrara: 3D Express, Standard, and Pro. Many features 
are included in 3D Express but where a feature is available in both the Standard and Pro versions, or only 
the Pro version, that feature will have a note added to it. 

For example, the following list has Features 1 and 2 in all versions, Feature 3 in the Standard and Pro 
versions, and Feature 4 only in the Pro version.: 

• Feature 1 

• Feature 2 

• Feature 3 (Standard, Pro) 

• Feature 4 (Pro only) 

Technical Support 
You will find the answers to most of your questions within the documentation. If you need further 
assistance, you can contact DAZ 3D’s Technical Support for Carrara in the following ways: 
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Web Support 
Many of the answers to your questions are available 24 hours a day on our Web site: 

http://www.daz3d.com/support  

In addition to frequently asked questions (FAQs), the Web site provides troubleshooting techniques, late 
breaking product news, and other resources to help you get the most out of your Carrara product. 

Phone Support 
Phone support is available to registered users of Carrara for questions about installation, configuration, or 
functionality. For more information about phone support, check our Web site at: 

http://www.daz3d.com/support  

Creative Support 
You can also refer to forums on the DAZ 3D Web site for questions about creative techniques, or visit: 

http://www.daz3d.com/i.x/community/0/-/?  

Using Tool Tips 
Carrara displays Tool Tips by default whenever you rest your cursor over an interface element. 

To turn off Tool Tips: 

1. Choose File > Preferences. 
2. Choose General from the pop-up menu. 
3. Uncheck the Show ToolTips option. 

Carrara Overview 
This chapter introduces some of the major features and concepts of DAZ 3D Carrara 6. With Carrara, you 
can create dazzling 3D illustrations, animations, and Web output in six easy steps: 

• Create a scene using object primitives. 

• Build true three-dimensional objects with easy-to-use, intuitive modeling tools. (Standard, Pro) 

• Apply colors and textures on your objects, giving them realistic properties such as transparency 
and reflection. 

• Light your scene to enhance realism and depth. 

• Create animations of your scene. 

• Render your scene, animation, or Web output with Carrara's powerful rendering engines to 
produce extraordinary, Photorealistic illustrations or animations. 

Carrara combines power with an easy-to-use, intuitive user interface.  
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Creating Scenes 
A Carrara document is called a scene. A scene is the collection of objects, light sources, and cameras, 
saved together in a file. Each new scene has several windows associated with the different rooms. As 
you create your scene in Carrara, you'll work in the various rooms to create and place the various 
elements that you want to use.  

Before you can create a new 3D illustration, you must create a new document. A new document starts 
with a blank scene. 

Using the Scene Wizard 
The Scene Wizard is a collection of useful basic scenes that can be used as a starting point to create a 
scene. The Scene Wizard also contains some demonstration scenes that show particular features of 
Carrara. 

To open the Scene Wizard: 

1. Choose File > New.  

2. In the New Document window, click the Presets button. The Scene Wizard opens. 

3. Highlight the scene that you want to use and click OK. 
 

 

Using the Landscape Wizard 
The Landscape Wizard allows you to quickly and easily create a landscape, complete with shaders and 
lighting. 

To use the Landscape Wizard: 

1. Choose File > New. 
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2. Click the Landscape Wizard button. The Landscape Creation Wizard opens. 
 

 
3. Check or uncheck the options to keep shader and sky settings while you make your changes. 

4. Use the Landscape, Shader, and Sky tabs to choose the terrain, materials, and sky properties 
that you want to use in your new scene. 

5. Use the Settings tab to choose illumination and shadow settings for your scene. The settings 
provide options ranging from fast renders with less detail to highly detailed renders that take 
longer. 

6. Click OK to create your landscape. 

Creating an Empty Scene 
When you create an empty scene in Carrara, the document window opens in the Assemble room, using 
your default workspace setup. Your scene contains only one default light and a default camera. 

To create an empty scene: 

1. Choose File > New. The New Document dialog appears. 

2. Select the size of the scene you want to create: Small (30 in), Medium (30 ft) or Large (3000 ft).  

3. Select Empty Scene. 

NOTE! The default measurement unit in Carrara is feet. If you want to work in inches, type “in” 
after you enter a numerical value of measurement. 

Opening an Existing File 
You can open any file you created in Carrara, and can also open files saved in many other common 3D 
formats. 
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To open an existing file: 

1. Choose File > Open. The Open dialog appears. 

2. Locate the file using the dialog controls and click Open. 

Additional supported file types can be opened into the current scene file by choosing File > Open. To 
open other file types as a new document, refer to "Importing 3D Objects." 

Carrara’s Rooms 
Carrara provides five different rooms for working on your scene. Each room allows you to focus on 
designing a particular part of your scene. You don't need to use multiple software applications to create 
professional quality images or animations. Carrara allows you to seamlessly switch rooms as you work so 
that you have easy access to the tools you need while you create your scene.  

You can easily switch rooms from Assemble to Storyboard, Texture, Render, or one of the modelers, by 
clicking the Room buttons in the upper-right portion of your screen. As you change rooms, you are still 
working on the same document. The room button for the current room is highlighted, and the name of the 
room displays next to the buttons. 

 
Use the Room buttons to switch between Carrara’s rooms. 

Assemble Room 
Carrara software's SmartFlow workspace is designed to support your workflow. You can start by placing 
objects in your scene in a number of different ways: 

 
Working on your scene in the Assemble Room. 

• Drag content from the Browser Tray into your scene. 

• Use the primitive modeling tools to add content to your scene 

• Create new, original models using Carrara’s different modelers (Standard, Pro) 
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At any time, you can position multiple light sources and cameras, and shift between cameras to gain 
different perspectives on your work. 

Carrara supports multiple scene files, allowing you to easily cut and paste information between files. 

For further information about the Assemble Room and its various controls, see "Assemble Room 
Overview." 

Model Room 
Depending on the version you have, Carrara software's modelers use many of the tools standard to 2D 
drawing programs and feature a variety of time saving utilities and tools, so you can create complex 
spline-based, polymesh, and Metaball objects quickly and easily. 

There are several different modelers in Carrara depending on the version you have. The appropriate 
modeler opens in the Model room when you add one of the many different types of primitive objects to 
your scene.  

When you double-click a primitive object in the Assemble Room, Carrara switches to the appropriate 
modeler where you can model them into finished objects. 

Carrara Standard and Pro offer the following main types of modelers to create or edit objects: 

• Primitive modeler 

• Vertex modeler 

• Spline modeler 

• Metaball modeler 

 
There are also other primitive objects that open the Model room when you edit or add them to your scene: 

• Text  

• Particle Emitters  

• Terrains (shown below) 

• Plants 

• Volumetric Clouds  
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• Old Volumetric Clouds  

• Surface Replicators 

• Replicators 

• Hair 

• Ocean 

• Displacement modeler (Pro only) 

NOTE! Carrara 3D Express only provides terrains and plants. 

 
Finally, you can edit properties of the following types of objects in the Assembly Room or the Model room: 

• Fire 

• Clouds 

• Fountain 

• Formulas 
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You can edit other primitives in the Assemble room or the Model room. 

To create the objects that go into the scene, you must use a modeler. The Model room provides different 
modelers for various types of objects, including Vertex and Text. Each modeler has its own window, with 
individual tools and menu commands. 

 
The Model room allows you to model and edit the objects in your scene using one of several types of 
modelers. 

When you are using a modeler, you can view the entire scene in the Scene Preview window. This helps 
you keep the object in context. Refer to "The Interactive Renderer" to learn more about using the Scene 
Preview window. 

Although the Modeling and Assemble rooms look similar, there are a few ways you can tell which room 
you're in: 

• The title of the room displays in the upper right corner of the screen. 

• The Room Switcher icon for the currently selected room is highlighted. 

• In the Assemble room, all the objects in your scene are visible. In a modeler, only the object 
you're modeling is visible. 

• Many of the tools in the Assemble room, such as the camera, lights, and environmental object 
tools, are not visible in the modeling windows. 

To learn more about the modelers, refer to "Spline Modeling Overview," "Vertex Modeling Overview," and 
"Metaball Modeling." (Standard, Pro) 

Storyboard Room 
When you've added or created all the objects in your scene, you can use the easy-to-use features of the 
Sequencer tray to create animations.  

If your goal is to create an animation, you can animate your scene using the Storyboard room. When 
using the Storyboard room, you see several views of your scene at once. You can view multiple frames of 
your scene and specify which frames should be displayed. For example, you can show just the key 
frames of a selected object. 
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You can create the animation at the same time you create the scene. You can make changes in your 
scene over time by creating and moving objects in the various frames, creating entire animations in a 
single window. 

If you are creating an animation, you can also use the Sequencer to animate objects and apply modifiers 
or physical properties to objects that affect their behavior when animated. 

If needed, you can switch to the Assemble room to get a larger view of your scene. Refer to "Animation 
Techniques" to learn more. 

 

Texture Room 
After you add content, you can create or modify shaders to enhance the realism. Carrara features state-of 
the-art shading technology, which lets you apply colors and surface textures to your objects. You can 
apply shaders that emulate wood grain or marble, or customize effects like bump, transparency, and 
reflection. 

The Texture room is where you create, edit, and apply shaders to all or part of an object. Use shaders to 
create almost any kind of surface you can imagine. Shaders define aspects of the surface of an object, 
such as the color, texture, reflectiveness, and transparency. You can apply a Multi-Channel shader to an 
object or create a Layers List shader that combines several sub- shaders into one composite shader to 
create more complex effects. Each shader becomes a part of the scene and is referred to as a Master 
shader. 

You can also see a preview of your scene while you are shading objects or creating a shader. 

To learn more about shaders, refer to "What are Shaders?." 
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Render Room 
The Render room provides three different renderers: Draft, Photorealistic, and Non-Photorealistic. It 
provides all the features necessary to create full-color 3D illustrations and animations. Carrara Standard 
and Pro also provide Web output using Viewpoint Experience technology 

When your scene is completed, you can render it. Rendering is the process of capturing a two-
dimensional image, such as a photograph, from your three-dimensional scene. You can also render an 
animation. 

The rendered images from Carrara are compatible with popular Macintosh and Windows 2D graphics and 
page-layout programs, and can be saved for Web output in formats including JPEG, animated GIF, AVI, 
and QuickTime. You'll have no trouble compositing renderings with other images, or integrating text with 
your artwork. 

The Render room is where you specify render settings to render an image or an animation. 

After you have created primitives, added textures to your objects, and possibly animated your scene, you 
can render either a single image or a complete animation. Set up the Render options you want to use, 
then render the resulting image or animation. 

You can also use the Render room to perform a batch render of a list of files. To learn more, refer to 
"Rendering from a Batch List." 
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Carrara Interface Elements 
When you create a new file or open an existing file, you first see the Assemble Room and its main 
interface elements. These are the primary work areas. Although they are described here, instructions for 
working in these elements appear in subsequent sections: 
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Carrara Menus 
The commands you see in the menu bar vary, depending on the room and what version of Carrara that 
you are working in. Briefly, you’ll see the following menus in Carrara: 

• When you initially start Carrara, the Assemble Room includes commands in the File, Edit, 
Windows, Web, and Help menus. Most of these commands are also available in the Storyboard 
Room. Note that some commands are disabled until you have a scene open in the document 
window.  

• When you create or open a scene, the Assemble and Storyboard rooms also display View, Insert, 
and Animation menu commands. 

• When you enter the Model Room, there are additional menu commands that are particular to the 
modeler you are using. For example:  

o The Vertex modeler displays additional commands in the View, Selection, Construct, 
and Model menus. (Express, Standard, Pro) 

o The Spline modeler displays additional commands in the View, Sections, Arrange, and 
Geometry menus. (Standard, Pro) 

o The Metaball modeler displays additional commands in the Geometry menu. (Standard, 
Pro) 

• The Texture and Render Rooms include additional commands in the View and Insert menus. 
 

 

Carrara Tools 
Carrara contains toolbars along the top and left sides of the document window by default. You can move 
these toolbars to any location you choose: 

Common Tools: The tools that appear at the left side of the document window are common to the 
Assemble, Model, Storyboard, and Texture Rooms. These tools are described in "Working with the 
Common Tools." 
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Room Tools: Many of the menu commands have tools associated with them. They are located directly 
beneath the menu bar, and the tools available in the individual rooms vary depending on the room or 
modeler you are in. The tools are discussed where appropriate this manual, in conjunction with their 
associated menu commands. 

 

Document Window 
The document window shows a view of the 3D workspace. The 3D workspace itself is also called the 
Universe. 

In the Assemble room, the document window shows where objects, lights, and cameras are arranged to 
create a scene. 

 

Browser Tray 
The Browser tray, located at the bottom of the screen in the Assemble, Model, Storyboard, and Texture 
rooms, allows you to load and save content for use in your scenes. You’ll find information about the 
Browser tray in "Using Content Files." 
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Properties Tray 
The upper part of the Properties tray displays the properties of any element selected in the document 
window, Sequencer tray, or in the lower part of the Properties tray. 

The lower part of the Properties tray contains several tabs that help you manage your scene. 

For further information about the Properties tray, see "Using the Properties Tray." 

 

Sequencer Tray 
The Assemble, Storyboard, Model, and Texture rooms show a logical hierarchical representation of the 
scene, and also displays a timeline that aids in the creation of animation. All objects, cameras, shaders, 
and lights you bring into the universe are listed in the Sequencer hierarchy. You can expand or collapse 
the lists to view more or less detail.  
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The Interactive Renderer 
The Scene Preview tab (also known as the Interactive Renderer) is located in the lower part of the 
Properties tray. This renderer allows you to see a small view of the scene while you are in the modelers 
or the Texture room. 

 

Displaying the Carrara Application Windows 
Several commands in the Windows menu allow you to show and hide the various windows in Carrara: 

• Choose Windows > Maximized Window Mode to maximize the display of the current scene in 
the available document window space. Uncheck this option if you want a resizeable window. 

• Choose Windows > Full Screen Mode to display the Carrara application in full screen. Repeat 
the command to revert back to the previous state. The Toggle Full Screen Mode icon in the 
upper-right corner of the application window serves the same purpose. 

• Choose Windows > Hide Application to minimize the application window. The Minimize icon in 
the upper-right corner of the application window serves the same purpose. 
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Setting Up Carrara 
You can specify several settings that affect the way Carrara works. For example, you can set up application 
preferences, change the 3D preview settings, or modify your workspace. Carrara software's Preferences let you 
customize many of the application's default settings.  

This section describes only the preferences that affect the entire application. 

Setting Application Preferences 
To set application launch preferences: 

1. Choose File > Preferences. 

2. Choose Application from the pop-up menu. 
 

 
3. Check or uncheck the options that you want to apply when Carrara starts:  

o New Document on Launch: Check this option to automatically create a new document when 
you start Carrara. 

o Skip New Document Dialog: Check this option to prevent the New Document dialog from 
appearing when Carrara starts. 

o Check DAZ 3D News: When checked, displays news from DAZ 3D when you launch Carrara. 

o Don’t Show the Same News Twice: When checked, does not display news that was previously 
displayed when launching Carrara. 

o Check for Updates: Check this option to search for Carrara updates and receive notification 
when updates are available. 

o Don’t Show the Same Update Twice: Check this option to prevent repeated notification of the 
same update. 

o Skip Tips at Startup: Check this option to prevent the Tips window from opening when you start 
up Carrara. 

o Maximum Undo Levels: Enter the number of undo levels that you want to store. 
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Setting General Preferences 
To set general application preferences: 

1. Choose File > Preferences. 

2. Choose General from the pop-up menu. 
 

 
3. Check or uncheck the options that you want to apply: 

• Show Clock: When checked, displays the current time in the main toolbar area. 

• Show ToolTips: When checked, displays a brief description of the current tool when you hover 
the mouse over it. 

• Toolbar Hot Keys are Sticky: When checked, a tool remains selected after you release the 
shortcut keys that activate the tool. 

• Full Screen Mode: Displays Carrara in full screen mode. 

• Graphics Tablets Compatibility Mode: Check this option if you are using Carrara with a 
graphics tablet. 

• Language: Select the language (English or French) that will be used in the Carrara application. 

• Multiple Monitor Settings: If you are using multiple monitors, click the monitor icons to select or 
deselect the monitors that you want to use with Carrara. Monitors that are used are colored gray. 

• Split Big Screens in Two: Some combinations of Windows and video cards do not allow you to 
use dual monitor setups that behave like a single big monitor. If you check this option, you can 
still use Carrara in dual monitor mode. 
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Setting UI Effects Preferences 
To set user interface effects: 

1. Choose File > Preferences. 

2. Choose UI Effects from the pop-up menu. 
 

 
3. Check or uncheck the options that you want to apply: 

• UI Animations: When checked, displays animated UI windows where applicable. 

• Desktop Pattern and Gradient: Toggles the display of patterns or gradients that are applied to 
the desktop. 

• Dim Desktop for Dialogs: Check this option to dim the user interface in the background while 
dialogs are opened. 

Changing Keyboard Shortcuts 
In Carrara, you can change the keyboard shortcuts of most commands and tools. 

To edit a shortcut: 

1. Choose File > Preferences. 

2. Choose Keyboard Shortcuts from the pop-up menu. 
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3. From the Context pop-up menu select the context of the command. Choices are 3D View, Application, 
Shading Room, Spline modeler, and Vertex modeler. 
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4. From the Category pop-up menu select the menu or tool bar where the command appears. 

5. In the shortcut list, click on the name of the command or tool that you want to modify. The current shortcut, 
if any, appears in the Current Shortcut field. 

6. To add or change a shortcut, click in the "New Shortcut" input box to activate it. 

7. Press the combination of keys you'd like to use. For example press Command/Control and the S' key. If 
the shortcut is already used, the application tells you by which command. Generally, tools use a simple 
letter, while menu commands use a letter with Command/Control. 

8. Click on the Assign button and then on the OK button to record the shortcut. 

Setting Imaging and Scratch Disk Preferences 
Carrara uses free space on your hard drive to store work in progress or unsaved renderings of animations. This 
data is stored in the DAZ 3D\DazTmp folder. The partition containing the DAZ 3DTmp folder is known as the 
"scratch disk." 

 
To select the scratch disk: 

1. Choose File > Preferences. 

2. Choose Imaging, Scratch Disk from the pop-up menu. 

3. Click on the button to select the location of the DAZ 3D\DazTmp folder. 

4. Click OK. 

To set Imaging Preferences: 

1. Choose File > Preferences. 

2. Choose Imaging, Scratch Disk from the pop-up menu. 

3. Check or uncheck the following options: 

o Texture Spooling: Check Spool Texture on Disk if you want to use your hard drive to store 
texture information when the amount of memory specified by the Reserved Memory setting is 
exceeded. 
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General Scene Settings Preferences 
To set General Scene Settings: 

1. Choose File > Preferences. 

2. Choose General Scene Settings from the pop-up menu. 
 

 
3. Choose the following options: 

• Choose a measurement system (U.S. or Metric) from the 3D Unit System list. Your selection 
becomes the default unit of measure for all 3D objects. 

• Choose a measure system for time in the Time Units list. Choices are SMPTE or frames. 

• Choose the default number of Frames Per Second that you want to use in animation. The 
default setting is 24 FPS, but available options range from 1 to 60 FPS. 

• In the Interactive Render list, select the type of display you want to use for the Interactive 
Renderer. Choices are OpenGL or Software.  

• In the Tweener list, check the default option for calculating movement that is in between 
keyframes. Options are Bézier, Discrete, Formula, Linear, Noise Tweener, Oscillate, Spline, 
and Velocity. These options are discussed in more detail in "Tweeners." 

• In the Dragging a Browser Shader into the Scene section, check or uncheck the options to ask 
what to do with duplicates (shaders that are already used in your scene), or to create a new 
master shader automatically when you add a browser shader into the scene. 

Setting Units of Measurement in the Properties Tray 
When you configure General Scene Settings preferences, Carrara allows you to choose between U.S. and Metric 
measurement systems. The Interface tab in the Properties tray allows you to define the displayed units that are 
used in your scene. 
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To configure the displayed units for your scene: 

1. Open the Scene tabs in the Properties tray using any of the following methods:  

o In the document window, click the Working Box, or click outside any objects in your scene. 

o From the Sequencer tray, choose Scene Effects.  

o From the Instances tab, click Scene. 

2. Open the Properties tray: Interface tab: Displayed Units panel. 
 

 
3. Use the Displayed Unit menu to select the units of measurement. Choices are pixel, pt, pica, in, ft, mi, 

mm, cm, m, or km. 

4. Choose the desired number of decimal points (0 through 5) from the Display up to menu.  

OpenGL Preferences 
Two options appear in the General Scene Settings preferences. These settings allow you to choose between 
OpenGL or Software rendering. The difference between these options is as follows: 

• Software: This is the default renderer. It does not take advantage of hardware acceleration. However it is 
often the fastest and most reliable renderer. We recommend that you stick with it unless you get much 
better performance in OpenGL. 

• OpenGL: Carrara offers an improved OpenGL engine that improves support for texture maps with alpha 
channels, as well as an improved textured mode. These improvements also enhance performance in the 
Vertex modeler, allowing for editing of larger meshes. This renderer uses the OpenGL API to take 
advantage of your video card to display 3D objects. If your graphic card fully supports OpenGL, you 
should get better performance. However, it should be noted that many cards do not fully support OpenGL 
(especially older cards or the cheaper ones), in that case you will get a better redraw speed when using 
the Software renderer. 

The OpenGL renderer uses your graphic card to accelerate the display of 3D objects. Although it should run on 
most system configurations, there are some specific requirements for OpenGL. 

The OpenGL renderer requires a recent version of the graphic driver for your video card. (The graphic driver is 
the interface between your operating system and the graphic hardware). 

To update your graphic driver, please contact the manufacturer of your graphic card or computer. It is usually 
possible to download the latest version of the driver you need on their web site. In addition to choosing between 
OpenGL and software rendering, you can find the following option in the Preferences dialog: 
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To use display lists: 

1. Choose File > Preferences. 

2. Choose OpenGL from the pop-up menu. 

3. Check Use Display Lists to cache the geometry of existing objects on the graphic card. This speeds up 
the display of your objects but may cause problems with some video drivers. When you change this 
setting, you will need to save, close, and reopen any documents that were open at the time you changed 
the setting. 

File Format Preferences 
To choose default file format preferences: 

1. Choose File > Preferences. 

2. Choose File Format from the pop-up menu. 
 

 
3. Select the default language to use when opening files. Choices are Use Carrara’s Language, Western, 

or Japanese. 

Interface Settings Preferences 
To choose the font used in the interface: 

1. Choose File > Preferences. 

2. Choose Interface Settings from the pop-up menu. 
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3. A list of all fonts in your system appears. Select the font that you want to apply to your interface settings. 

User Interface Color Preferences 
To set interface element colors: 

1. Choose File > Preferences. 

2. Choose UI Colors from the pop-up menu. 
 

 
3. Click the color chip near the element whose color you want to change, or select the triangle to quickly 

select a color. The color chips control the Background, Major Accent, Control, Highlight, Alternate 
Highlight, and Drag and Drop colors. 

4. Select a color from the color picker that appears. 

5. Click OK. 

3D View Preferences 
To set 3D View preferences: 

1. Choose File > Preferences. 
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2. Choose 3D View from the pop-up menu. The 3DView Preferences dialog appears. 
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3. Set options as desired: 

• Update Active Pane Only: Updates the active pain automatically when you move an object. 

• Rotation Constraint Angle: Snaps the rotation to the specified angle when the rotation 
constraint is activated (using Shift). 

• 3D View Controls Size: Specifies the size of the manipulators in the 3D view. 

• Allow Gimbal Mode: The Gimbal mode is a special mode where each axis of rotation is 
displayed so that it corresponds to the actual effect of modifying a particular angle. When this 
option is off, the circles that appear in relation to axes are perpendicular to the axis to which they 
correspond. 

• Use Linear Tracking in Manipulator: When using the rotation manipulator with this option on, 
linear tracking looks at the motion of the mouse in tangent with the circle of rotation. When off, 
tracking tries to keep the position of the mouse cursor on the sphere of rotation. 

3D View Color Preferences 
To set 3D View colors: 

1. Choose File > Preferences. 

2. Choose 3D View Colors from the pop-up menu. 
 

 
3. Click the color chip near the element whose color you want to change or select the triangle to quickly 

select a color. The color chips control the colors of the Working Box, Wireframes, Ground Plane, Lights, 
Cameras, Background, Active Pane Border, Camera Names, Selected Objects, and Silhouette on Walls. 

4. Select a color from the color picker that appears. 

5. Click OK. 
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Modeling Room Preferences 
To set Modeling Room preferences: 

1. Choose File > Preferences. 

2. Choose Modeling Room from the pop-up menu. 
 

 
3. Set options as desired: 

• Master Object Ambiguity:  

• Edit the Master: Edits all instances of a particular master object. 

• Create a New Master: Creates a new master object for the current instance, and leaves 
other instances unchanged. 

• Same Choice for All Masters: This option does not display the dialog when you edit an 
instanced object, and uses previous settings. 

Shader Editor Preferences 
To set Shader Editor preferences: 

1. Choose File > Preferences. 

2. Choose Shader Editor from the pop-up menu. 
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3. The options that you can set for the Shader Editor preferences are as follows: 

• Automatically Adjust Split Bar: Automatically adjusts the position of 
the split bar in the shader editor window. 

• Filter Shaders According to Context in Popup: 

• Automatically Create Mapping Shaders for Object: 

• Filter Simple Sub-Shaders from Tree (only in Explorer View): When 
displaying complex shaders, filters out the display of sub-shaders to 
simplify the shader tree. 

Shading Room Preferences 
To set Shading Room preferences: 

1. Choose File > Preferences. 

2. Choose Shading Room from the pop-up menu. 
 

 
3. The options that you can set for the Shading Room preferences are as follows: 

• Master Object Ambiguity:  

o Edit the Master: Edits all instances of a particular master shader. 

o Create a New Master: Creates a new shader for the current 
instance, and leaves other instances unchanged. 

• Same Choice for All Masters: This option does not display the dialog 
when you edit an instanced shader, and uses previous settings. 

Resetting Application Preferences 
You can reset the preferences of the application to their default values by using the File > Reset Preferences 
command. This will exit the application and the default preferences will be used the next time it is launched. 
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Adding Objects 
Assemble Room Overview 
The Assemble room provides a large document window for working on your scene. When you create a 
scene, you assemble the objects, place lighting and cameras, and specify effects used in that scene. You 
can even apply pre-defined textures to objects in your scene while in the Assemble room. 

 
The Assemble room is where you arrange objects, cameras, and lights to form a scene. Like the 
Modeling windows, the Assemble room provides up to four separate panes, each containing a different 
view of your scene. You can change views using the view layout controls. 

The 3D workspace of the Assemble room is called the universe. The universe is where all objects are 
displayed, assembled, and manipulated. Carrara uses a coordinate system called the Cartesian 
coordinate system to reference positions in the universe. A trio of unique coordinates (X, Y, and Z) is 
associated with each position in the universe. 

The tools available in this room let you place and manipulate objects and position cameras so you can 
view, and later render, your scene from different viewpoints. By default, Carrara opens new scenes with 
one distant light and one conical camera. 

You can also begin the modeling process in the Assemble room by dropping some object primitives into a 
scene. After you add shaders in the Texture room, switch back to the Assemble room to add modifiers 
and lights as needed. You can position your cameras, adding additional cameras as needed, or you can 
view the results from the Director's camera.  

You can change the preview options for viewing objects as you assemble your scene, and you can do a 
quick test render of a small area of the scene to check your work. Refer to "Choosing a Preview Mode" to 
learn more. 

 © 2008 DAZ 3D, Inc. 33 



Carrara 7 11 December 2008 

Assemble Room Menu Commands and Tools 
The Assemble room menu commands are arranged in eight categories. 

• File menu commands allow you to open, close, import, and export various types of content. 
Many of these commands are described in "Import/Export." You’ll also find information on the 
Preferences commands in "Setting Up Carrara." 

• Edit menu commands are primarily used when making changes to various types of objects in 
your scene. Commands in this menu are described where appropriate throughout the manual. 

• View menu commands primarily deal with zooming and panning in the working box, and 
showing or hiding production frames, grids, and wireframes. 

• Insert menu commands are associated with adding and creating objects. The majority of these 
commands also have tools associated with them. You’ll find instructions for using these 
commands and tools in the following chapters:  

o See "Using Primitive Tools" for information on the Sphere, Cube, Cone, Cylinder, 
Icosahedron, Plane, Infinite Plane, and Splat tools. You’ll also find information about the 
Text and Particle Emitter tools in this chapter.  

o See "Spline Modeling Tools and Techniques" for information on working with Spline 
Objects. (Standard, Pro) 

o See "Vertex Modeling Basics" for information about the Vertex Object tools. (3D Express) 

o See "Vertex Modeling Basics" and "Vertex Modeling Techniques" for information about 
the Vertex Object tools. (Standard, Pro) 

o See "Metaball Modeling" for information on how to work with Metaball Objects. (Standard, 
Pro) 

o See "Using Formulas in Carrara" for further information about Formulas. 

o See "Using Environmental Primitives" for instructions on Terrains, Plants, Clouds 
(Volumetric, Old Volumetric, and Clouds tools), Fire, Fountains, Fog, and Oceans. 

o See "Setting Lights" for instructions on the Spot, Bulb, Distant, Moon Light, Sun Light, 
Tube Light, Shape Light, and Anything Glows tools. 

o See "Setting Cameras" for information on creating and using cameras. 

o See "Physics" for further information about the force tools (Directional, Point, Damping, 
Torque, and Flow Force tools). (Standard, Pro) 

o Refer to "Character Animation" for further information about Target Helpers and Bones. 
Standard, Pro) 

o Refer to "Adding Sound to Your Scene" for information about sound. 

o Animation menu commands are covered in "Animation Techniques." (3D Express) 

o Animation menu commands are covered in "Animation Techniques" and "Character 
Animation." (Standard, Pro) 

• Windows menu commands open and close the various windows that are available in Carrara. 

• Web menu commands open your web browser and display several different support pages that 
are located on the DAZ 3D web site. 

• Help menu commands open the reference manual in PDF format and display tool tips when you 
hover over the Carrara tools. 
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Working with the Common Tools 
You'll use many of the same tools while working in the different rooms and modelers. This section 
introduces the common tool sets you'll be using.  

Carrara provides tool tips to help you identify what each tool is. Simply place the cursor over the tool to 
display the name of that tool. 

Customizing Tool Locations 

You can customize the location of Carrara's tool sets. 

To move tool sets: 

1. Click the tool set that you want to move. 

2. Drag the tool set to a new location on the screen. The tool sets' dock areas on the left of the 
screen and under the menu bar can be used to automatically align the tool sets. 

When a tool set is floating outside a tool dock, press Control, then drag the tool set to rotate it. 

3D Object Manipulation Tools 
The 3D Object Manipulation Tools appear in the left portion of the interface window. You can position 
these tools in the left or top sections of the user interface, or float them. 

Unlike the 2D view tools, these tools manipulate the objects in your scene. You can do all these 
manipulations numerically or with the mouse. 

From top to bottom, the tools are: 

• Move tool: Repositions the objects in your scene. Refer to "Arranging Objects" to learn the 
different ways to move objects. 

• Scale tool: Increases or decreases the size of the object. Refer to "Scaling Objects" to learn how 
to scale objects. 

• Rotate tool: Shifts an object around its hot point. Refer to "Rotating Objects" to learn how to 
rotate objects. 

• Universal Manipulator tool: Moves, scales, and/or rotates the object depending on how you use 
the tool. 

• Eye Dropper tool: Selects an object's shader so that you can apply it to another object. To learn 
more, refer to "Shading an Entire Object." 
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Camera Tools 
Use the Camera Rotation tool and the different Track tools to position the camera of the current view in 
the Assemble, Storyboard, or Model rooms. When you use the camera tools, you are moving the camera 
in your scene. 

To learn more about working with the cameras, refer to "Setting Cameras." 

To position a camera, do one of the following: 

• Click one of the Camera tools, then click and drag in the document window to directly manipulate 
the camera. 

• Click a tool and drag in a direction to indirectly manipulate the camera. 
 

 
The Track tools affect the position of the camera without affecting its orientation. The objects in your field 
of view will appear to change position in relation to each other as you view your scene from many 
different angles. 

• Track YZ: Drag the mouse up and down to track the camera up and down. Drag the mouse left 
and right to track the camera toward or away from you. 

• Track XY: Drag the mouse up and down to track the camera up and down. Drag the mouse left 
and right to track the camera left and right.  

• Track XZ: Drag the mouse up and down to track the camera toward or away from you. Drag the 
mouse left and right to track the camera left or right.  

Using Shortcut Keys: 

• Use the shortcut Option/Alt + Left Mouse Button to rotate the camera (Dolly). Refer to 
"Dollying". 

• Use the shortcut Option/Alt + Right Mouse Button to track the camera horizontally and 
vertically. 

• Use the shortcut Option/Alt + Middle Mouse Button to move the camera back and forth. 

• If your mouse is equipped with a Mouse Wheel you can use it to move your camera back and 
forth 

The Camera Rotation tool has three options, which you access by clicking the arrow that appears at the 
bottom-right corner of the tool. The popup menu displays the additional options:. Select the one you want 
to use: 

• Dolly changes the camera's position and orientation while keeping it pointed at the same spot in 
the scene. . 
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• Pan works like turning your head: the camera's position in 3D space does not change when you 
orient it in any direction. Refer to "Panning." 

• Bank allows you to roll the orientation of the camera without changing its location. Imagine 
tipping your head to the side. Refer to "Banking." 

NOTE! In isometric views it is not the camera that is moved when using those shortcuts but the 
zoom and pan that are modified. 

2D View Tools 
Carrara also provides tools that allow you to pan and zoom the scene in the document window, and to 
perform test renders from within the document window. These tools appear along the left side of the 
document window by default. They are the "Test Render Tool," the "2D Pan Tool," and the "2D Zoom 
Tool." 

 

Test Render Tool 

Use the Test Render tool to render an area of your scene in the Assemble or Storyboard rooms, or in the 
Scene Preview window. You can easily check out an effect without rendering the entire scene. 

To use the Test Render tool: 

1. Choose the Test Render tool. 

2. In the document window, drag a marquee across the area to be previewed. 

3. Carrara renders the area you have selected. 
 

 
To work efficiently, keep the size of your render previews small. Larger areas take longer to ray trace and 
require more memory. If you want to ray trace more than a small portion of your scene, you might as well 
do a low resolution rendering. Refer to "Rendering." 
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2D Pan Tool 

If your scene is too large to fit within the document window, you can use the 2D Pan tool to reposition the 
view of the camera like a flat image. Drag the tool up, down, right, or left to reposition the scene in the 
document window. 

To move an area of the scene in the document window: 

1. Click the 2D Pan tool. 
 

 
2. Drag the cursor in the direction you want to move the view of the scene. 

NOTE! To reset the 2D pan, use the View >Reset 2D Pan command, or click the arrow at the right 
of the 2D Pan tool and choose Reset 2D Pan.. 

2D Zoom Tool 

As you create your 3D artwork, your scene can quickly become too large to see the entire scene in the 
Assemble room. The 2D Zoom tool allows you to zoom out to view your entire scene, if necessary. You 
can also use it to enlarge areas to precisely edit objects.  

To zoom in to an area of your scene: 

1. Click the 2D Zoom tool. 
 

 
2. Click on a point in your scene to enlarge. The scene is magnified. You can also drag a marquee 

around an area to magnify it. 

To zoom out of an area: 

1. Click the Zoom tool. 

2. Hold down Option/Alt and click an area. 

You can also zoom in or out of your scene to a selection, a specified percentage, or preset percentage 

To zoom in or out to a selection, object, or fixed percentage, use one of the following methods: 

• Choose View > Zoom, and choose a zoom option from the popup menu. 

• Click the arrow at the right of the Zoom tool and choose a zoom option from the popup menu. 

o Zoom to Selection: Choose this option to zoom into the objects that you have selected. 

o Zoom to: Choose this option to enter a new zoom percentage of your choosing. 

o Fixed percentages: Allows you to zoom in to 25%, 50%, 75%, 100%, 200%, 300%, 
400%, 500%, or 600%. 

Using the Document Window 
The document window shows a view of the 3D workspace. The 3D workspace itself is also called the 
universe. A single document window is associated with a scene in the Assemble and Storyboard rooms. 
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In the Assemble room, the document window shows where objects, lights, and cameras are arranged to 
create a scene. 

You can easily display one or up to four views in the document window. As you move an object in one 
view, it changes location in the other views as well. 

 

Displaying Multiple Camera Views 
The top bar of the document window contains several controls that allow you to view the items in your 
scene in many ways. They are broken down into four types of controls: 

The View controls allow you to display up to four different camera views in your document window. 
Options from left to right are: 

 
View controls. 

• One View: Displays one camera view in the document window. By default, the Camera 1 view is 
used. 
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• Two Views Horizontal: Displays two different views stacked one on top of the other. By default, 
the views are Camera 1 and Top. 
 

 
• Three Views Top: Displays two camera views on top and one view on the bottom. By default, the 

views are Top, Left, and Camera 1. 
 

 
• Four Views: Displays four camera views. By default, Top and Camera 1 are on the top, and Left 

and Front are on the bottom. 
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• Inset View: Displays two camera views. By default, Camera 1 appears in the main document 
window, and the Top camera appears as in inset. 
 

 

Using the Working Box 
The working box is a representation of a coordinate system and is visually presented by three 
intersecting planes. It provides a framework that helps you work in a three-dimensional universe with two-
dimensional devices: the mouse and monitor. 

The working box is a three-dimensional reference for positioning and arranging objects. Each of the views 
shows an aspect of the working box: 

• The Director's Camera and any cameras you create show a three-dimensional view of the 
working box. 

• The other views show a two-dimensional view of part of the three-dimensional space. 
 

 
You can think of the working box as a 3D ruler that helps you bring objects together more easily and 
accurately. The grids of the working box are a visual reference for the dimensions and orientation of the 
universe. By default, the working box floor is centered on the origin of the universe (0, 0, 0) and aligned 
with the axes of the universe. The ground plane, lying on the XY plane, is positioned at Z = 0. 
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Object Bounding Boxes and Projections 

The bounding boxes of all objects, including cameras and lights, cast 2D profiles called projections on 
the planes of the working box. These projections show the object's position and orientation in relation to 
each of the three planes. They help you see which objects are "farther away," "higher," or "tilted," and 
help you move the objects into the positions and orientation you want. You can drag the projection to 
scale, move, or rotate the object in the plane of the projection. 

 

Choosing the Active Plane 

You can select the active plane using the Working Box control, located in the left tool area. To set the 
active plane, simply click the working box control icon on the plane you want to activate. The active plane 
is highlighted. 

 

Changing the Working Box 

Changing the working box does not affect your existing objects. The orientation of the working box 
applies only to subsequent arrangement operations.You can change the working box in several ways to 
facilitate the assembly of your scenes: 

• Change plane colors to suit your personal preferences. For more information, refer to "Color 
Pickers." 

• Change the size of the working box to simulate the real-world size of your scene. 

 © 2008 DAZ 3D, Inc. 42 



Carrara 7 11 December 2008 

Aligning the Working Box to an Object 

The working box is moveable and scalable, so you can set it at different angles, change its size, and 
move it away from the origin. In some cases, you might want to move the working box into other positions.  

You can move the working box so it aligns with an object or group of objects. For example, if you are 
creating a spaceship, and one of the wings is at an angle to the rest of the ship, you might want to work in 
that angled coordinate system to easily maneuver objects relating to the wing. 

This feature aligns and repositions the working box around a selection, which is useful for creating large 
scenes where you would otherwise run out of grid. It is also useful for creating an object or a motion path 
that is set at an angle to the overall orientation of the scene. 

To send the working box to an object or group: 

1. Select an object or group. 

2. Choose View > Send Working Box to Object. Carrara sets the working box planes parallel to 
the bounding box planes of the selected object or group bounding box. The coordinate systems of 
the working box and the object (or group) are aligned. 
 

 
You'll find it particularly useful to move the working box when you want to model or view a specific part of 
a vertex object. You can also drag the planes of the working box separately. If you drag a plane far 
enough, you will drag the working box along with it, re-centering the working box in the universe. 

Aligning the Working Box to Specific Coordinates 

To move the working box to specific coordinates: 

1. Choose View > Send Working Box to. The Send Working Box dialog appears. 

2. Enter the coordinates where you want to position the center of the working box. 

3. Click OK. 

Returning the Working Box to its Origin 

When you center the working box in the global universe, it becomes useful for positioning objects in your 
scene. By using real-world units of measure and centering your scene at the universe's 0,0,0 coordinates, 
you always have an idea of where your objects are in relation to the overall scene. 
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To return the working box back to the global coordinate system, choose View > Send Working Box to 
Origin. 

 

Changing the Grid 
Each plane in the working box has a grid. Each grid represents an axis in three dimensional space: X, Y, 
and Z. 

Showing and Hiding Grid Planes 

Three grid plane controls appear in the upper right corner of the document window. The three visible grid 
planes of the working box shown in the different views represent the XY, ZX, and ZY planes. You can 
choose which planes to display.  
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The working box is made up of three grids that represent the X, Y, and Z axes.  

 
You can display or hide any of the grid planes in the working box as follows:  

• Click on the Grid Controls on the top of the document window.  

• Option/Alt+click on a plane in the Working Box control. The specified plane is hidden or 
displayed. 

Setting up the Grid 

The grid in Carrara can be an invaluable tool for placing objects in 3D space. 

To set up the grid: 

1. Choose View > Grid . The Grid Settings dialog appears. Options are as follows:  

o Center: Enter the X, Y, and Z axis coordinates for the center of the grid. 

o Size: Enter the X, Y, and Z dimensions to size the grid. 

o Draw a line every: Controls how often grid lines are drawn. For example, a value of 1 
draws a grid line for every grid point, as set in Spacing below. A value of 2 draws a grid 
line at every other grid point. 

o Spacing: Adjusts the spacing between grid lines in the box and specifies units of 
measure. For example, a value of 4 creates four feet of space between each grid line if 
you are using feet for units.  

o Snap to Grid: Causes objects to "snap" to the nearest grid line as you drag them. 
Another and faster way to turn on or off this option is available in View> Snap To Grid. 

2. Choose OK to apply your settings. 

In the example above, a value of 1 would draw a line every 4 inches. 

Choosing a Preview Mode 
Click an object preview tool in the Assemble or Storyboard rooms to view your work in that preview mode. 
The more detailed previews take longer to render.  

 
Click one of the Preview Quality icons to change the preview quality of the objects in the Assemble room. 
Click on the arrow to open the interactive renderer preferences dialog and to have more options. 

You can preview objects in the Assemble room at five different levels of quality: Bounding Box, Wire, Flat, 
Gouraud, and Textured (or Phong). The various preview modes are described in the sections that follow. 

To increase application efficiency, you might want to work in Wireframe or Flat mode at the outset of a 
project, then switch to Textured mode as specific details become important. 

Higher preview modes take longer to redraw, so it's a good idea to use a Wireframe or Flat mode when 
you're arranging objects. Switch to the higher modes only as specific shading detail becomes more 
important. 

Use the Test Render tool whenever possible, to preview your work. 

To change the preview quality, choose the Preview Quality tool you want: 
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Bounding Box 

The bounding box is the smallest box that encloses an object or group of objects. Bounding boxes 
appear around objects that are selected. 

 

Wireframe 

Wireframe mode displays objects as a mesh of wires. 
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Flat 

Flat mode displays objects with low faceting and colored surfaces. 

 

Gouraud 

Gouraud mode shows objects with shading at a low level of detail. 
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Textured 

Textured (Phong) mode shows objects with shading, texture maps, and paint regions in detail., but takes 
longer to calculate and draw. 

 

Using the Properties Tray 
The Properties tray is split into two parts. The upper portion of the Properties tray contains several tabs in 
the Assembly room: General, Motion, Modifiers, and Effects. As you select different objects, you'll notice 
that the content of the upper part of the Properties tray changes to reflect the options available for that 
object.  

The controls available in the Properties tray change as you select different items. For example: 

• When you select an object in the document window, the tray displays controls to change the 
object's name, position, modifiers, shading, links, and rendering settings. 

• When you select a light, the tray displays the light's properties and controls for changing the light 
type, color, and other properties. 

• When you select a camera, the tray displays the camera's name, position, and camera type 
properties. 

• When you select the scene from the list in the Properties tray, you can set scene level properties. 

• When you select a point in the Spline modeler, the tray displays the point's position and angle. 

• When you select an object in the Vertex modeler, the tray displays controls for adjusting its 
numerical position. 

• When you select DAZ Studio or Poser content that contains morphs, morph dials are located in 
the lower portion of the Properties tray. 

You can expand or collapse the options displayed in the Properties tray. In some instances, you can 
expand or collapse several levels of options.  
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The lower part of the Properties tray contains several tabs 
that help you manage your scene. 

The Instances tab shows the same hierarchy as in the 
sequencer. When you are working with complex scenes, you 
might find it easier to select small or hidden objects in the 
Hierarchy list, rather than in the document window. 

To use the Properties tray: 

1. Use one of the following methods to show the 
Properties tray:  

o Choose Windows > Properties. 

o Click the handle for the Properties tray and 
drag it open. 

o Do a short click on the Properties tray handle. 

2. To switch categories in the Properties tray, click on 
the tabs to switch between the different property 
options: General, Motion, Modifiers, or Effects.  

o Click the arrow to the left of a section name to 
expand or collapse the contents of that 
section. The arrow points down to show a 
section has been expanded, or sideways to 
show that the section has been collapsed. 

o If needed, drag the scroll bar up or down to 
scroll the contents of the tray. 

o In some sections, you can click the 
downward-pointing double arrow next to a 
section name to display a list of choices. 

o The currently selected choice displays to the 
left of the double arrow. 

o If you have selected Modifiers, click the + or - 
sign to add or remove modifiers. 

o Once you have added modifiers, you can 
expand or collapse each one. 

3. The tabs in the lower section of the Properties tray 
allow you to select or browse through the objects in 
your scene:  

o Click the Instances tab in the Properties tray 
to display the hierarchy of all the instances in 
your scene. The first line, labeled Scene, 
displays properties for the entire scene. 

o The Objects tab displays previews of the Master Objects. You can edit the name of the 
object if desired. For more information about the Master Objects, refer to "Working with 
Master Objects." 

o The Shaders tab displays previews of the Master Shaders in the scene file. 

o The Sounds tab displays the list of the Master Sounds in the scene file. 

o The Clips tab displays a list of the non-linear animation clips in your scene. 
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4. To close the tray, use one of the following methods:  

o Choose Windows > Properties. 

o Drag the Properties tray shut. 

o Do a short click on the handle. 

Choosing Interactive Renderer (3D Preview) Settings 
The Properties tray: Preview tab appears when you are in the Model or Texture rooms. It shows a 3D 
preview of your scene.  

The 3D Preview window (3D View) is also known as the Interactive Renderer. This preview window has 
a number of options that can be used to customize the display of your scene. You can select a preview 
option to optimize for speed or for image quality. For example, use Bounding Box to optimize for speed 
while initially creating your scene and positioning objects. 

You will want to set these options based on your preference for working and the capabilities of your 
system. You will probably want to experiment with different settings to find what is right for you. The 
available preview preferences are based on the renderer you are using. 

To open the Interactive Renderer Settings dialog, do one of the following: 

• Click the first button that appears in the Preview controls section of the document window tools 
(the arrow in circle symbol).  
 

 
• Click the first button that appears in the 3D Preview window in the Properties tray: Preview tab. 

 

 
 
The Interactive Renderer Settings dialog will come up. 
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When you open the Interactive Renderer Settings dialog, you are offered several different options. 

• Rendering Mode: You can choose between several rendering modes (bounding box, wireframe, 
Gouraud, textured...) Refer to "Choosing a Preview Mode" for details about each of the rendering 
modes. Select textured if viewing bump and specularity in the 3D view. 

• Texture Map Size: Choose the size of the texture map used in the rendering mode. 
Software mode can use up to a 512x512 map size while OpenGL mode can use up to a 
2048x2048 map size. 

• Performance/Quality: Use the slider to select better performance or better quality while 
in OpenGL mode. 

• Lighting Mode: Determines the lighting mode used in the 3D view. 

• Light Map: Uses a light map to light the scene in the 3D view. 

• Scene Lights: Uses the lights in the scene to light the 3D view. 

• Light Map and Scene Lights: Uses both a light map and the scene lights to light the 3D 
view. Only available in OpenGL mode. 
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• Display Options:  

• Transparency: Activates the display of transparency in the 3D view. 

• Reflection: Activates the display of reflections in the 3D view. 

• Show Backdrop: Select this option to display the backdrop image in the back of the 3D 
view. 

• Outline Polys: Shows the outline of polygons in 3D view. 

• Antialias: Turns on antialiasing of wireframes in the 3D view. 

• Draw Hidden: Draws hidden wireframes in the 3D view. 

• Show Bump Map: Shows the bump map when in the 3D view and using OpenGL mode. 
Requires a bump map layer to have been applied. (Pro Only) 

• Show Specular Map: Shows the specular map when in the 3D view and using OpenGL 
mode. Requires a specular map layer to have been applied. (Pro Only) 
 
NOTE! When in Software mode or if your video card does not support viewing bump and 
specular maps, then the Show Bump Map and Show Specular Map options will not be 
visible. 

• Silhouette: Determines the style of objects as projected onto the working box. Choices are 
Boxes Only, Active Wall Only, All Walls, Fixed Color, and Object Color. 

• Degradation Mode: Select to determine which mode the interactive renderer will switch to when 
the redraw speed drops under a certain threshold (expressed in frames per second (FPS)).  

• Active Pane: Display mode used in the active pane when the degradation mode is 
triggered. 

• Inactive Pane: Display mode used in the other panes when the degradation mode is 
triggered. 

• Level of Detail: Level of details used for the geometry when the degradation mode is 
triggered. 

• Show Normals: Displays the normals of the objects. Options are None, Per Facet, and Per 
Vertex. The Size slider is used to adjust the size of the normals. 

• Apply To: Determines which settings are modified by the dialog. You can apply the settings to 
the Active View or to All Panes in Window. 

To set preview options: 

1. Click the Interactive Renderer Settings control. The Interactive Renderer Settings dialog is 
displayed. 

2. Select the renderer (Software or OpenGL) from the menu at the top of the dialog. 

3. Select the rendering mode you want to use. See "Choosing a Preview Mode" for more 
information on the different rendering modes. 

4. Enable the features that you want to use and disable those that you don't want. These additional 
options are described in the sections that follow. 

5. Click OK. 

 © 2008 DAZ 3D, Inc. 52 



Carrara 7 11 December 2008 

Using the Sequencer Tray 
The Sequencer tray supplies animation tools and different types of information specific to the room you 
are currently using. As you work, you'll find the Sequencer tray an invaluable tool for arranging and 
animating objects in your scene. 

You can view only the animation tools by partially opening the tray.  

 
Drag or double-click the tray handle to display or hide the contents of the tray. 

 
Other than in the Render room, the Sequencer tray merges two types of information: time line and 
hierarchy. In the Time Line section of the Sequencer tray, you have control over animating the events in 
your scene. You can display only the basic animation tools, or open the tray further and show the Time 
Line and Hierarchy information as well. 

In the Hierarchy section of the Sequencer tray, you'll see an expanding/collapsing visual hierarchy that 
provides a display of how elements are grouped and linked. 

The active window and the Sequencer tray are synchronized. As you add or remove objects from one, the 
display in the other updates automatically. Note that any object selected in the Sequencer is also selected 
in the document window. 

The list in the Sequencer tray can be filtered to display information specific to the type of task you're 
working on.  

 
The Sequencer supplies certain information on the scene's construction not immediately apparent in the 
Assemble or Storyboard rooms: for example, how several elements can be grouped. 

When you're modeling or arranging objects, you'll need to see information on grouping and linking. For 
this task you can drag the tray all the way open to display the Hierarchy section of the Sequencer. The 
Hierarchy section displays all objects, groups and scene elements in an expanding/collapsing indented 
list, along with animation timing information. 

When you're creating an animation you must see key frames and tweeners. For this task you can use the 
Time Line information in the tray. 

To display the Hierarchy and Time Line information in the Sequencer, drag it all the way open until the 
Hierarchy section of the Sequencer is displayed. 
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When the Sequencer tray is fully open, you can see the key frames and tweeners in your animation. 

1. Click the drawer handle of the Sequencer tray to make it active. 

2. Drag it all the way open until the Hierarchy section of the Sequencer is displayed. 

Refer to "Building a Hierarchical Structure" for complete instructions on using the Hierarchy. 

Editing Your Scene's Contents 
Carrara has several of the basic operations you're familiar with from other applications. You can cut, copy, 
and paste any item in the document window using the Edit commands. 

To copy an item in the document window: 

1. Select the object, light, or camera. 

2. Choose Edit > Copy, or press Command/Ctrl+C. A copy of the item is placed on the Clipboard. 

To cut an item in the document window: 

1. Select the object, light, or camera. 

2. Choose Edit > Cut, or press Command/Ctrl+X. The item is removed from the scene and placed 
on the Clipboard. 

To paste an item in the document window: 

• Choose Edit > Paste, or choose Command/Ctrl+V. The object appears in the Assemble room. 

To delete items in the document window: 

1. Select the item. 

2. Choose Edit > Delete. The object is deleted from the scene. 

There are many other ways you can edit the contents of your scene. You can duplicate, move, rotate, and 
re size objects. Refer to "Arranging Objects" for more information. 

Undoing Operations 
You can reverse the effects of your last action by using the Undo command. Carrara has multiple undo 
levels so that you can undo a series of operations by choosing undo several times. The number of undo 
levels is determined by the value you set in the Carrara Preferences dialog. The maximum number of 
undo/redo levels is 64. 

To set Undo levels: 

1. Choose File > Preferences. 

2. Choose Application from the pop-up menu. 
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3. Enter a value in the Maximum Undo Levels entry box. 

To undo operations: 

1. Choose Edit > Undo, or press Cmd/Ctrl+Z. Carrara undoes the last operation. 

2. To undo the next operation, choose Undo again. 

NOTE! There are some operations you can't undo. In this case, the Undo command is replaced by 
Can't Undo. 

Redoing Operations 
You can repeat your last action using the Redo command. The command is available only after you undo 
an operation. You can redo multiple operations. 

To repeat an operation: 

• Choose Edit > Redo, or press Cmd/Ctrl+Y. Carrara repeats the last action. 

Saving Your File 
To save your scene: 

1. Choose File > Save, or Cmd/Ctrl+S. 

2. Choose a location for your file. 

3. Enter a name for the file in the File name entry box. 

4. Choose a file type from the Format/Save as type pop-up menu and click Save. 

To save your file under a different name: 

1. Choose File > Save As, or press Cmd/Ctrl+Shift+S. 

2. Select a location for the file. 

3. Enter a new name for the file in the File name entry box and click Save. 

Closing Your File 
When you're done editing a scene file you can close it. 

To close a file: 

1. Choose File > Close. 

2. If you have any changes, click Yes to save them or No to discard them. 

Using Content Files 
Carrara allows you to work with many different types of content. Along with the many scenes and objects 
that are provided with Carrara, you can also create your own content. The Browser tray stores this 
content so that you can easily add it to any scene that you create.  
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This chapter provides an overview of the Browser tray and how you can use it to manage and use your 
content as you build your scenes and animations. 

The Browser Tray 
The Browser is a visual catalog of many of the elements you can use to create a scene. The Browser has 
sections for each different category of element. Each section can display multiple directories.  

The Browser tray is composed of the following categories: Scenes, Objects, Shaders, Clip, Misc. 
(Modifiers, Constraints, Effects), Artwork, and Content. Each category lets you organize items you save 
into directories. 

 
The Browser is a visual catalog of some of the items you can use to create 3D scenes. 

After you create or customize an item in one of these categories, you can save it to the Browser, where it 
will be easy to retrieve and use again later. Most operations with the Browser are the same in all 
categories. 

NOTE! Objects, light sets, and cameras are saved as normal Carrara documents (.CAR files). 
Items in other Browser categories are saved as special Browser documents (.CBR files). 

Showing and Hiding the Browser 
The Browser tray appears at the bottom of your screen. If you need more room to create or edit your 
scene you can hide the Browser tray. 

To show or hide the browser, do one of the following: 

• Choose Windows > Browser. 

• Drag the Browser tray by its handle to open it. 

• Click the Browser tray handle. 

Choosing Your Display Mode 
The Browser offers three view modes for its contents: Text, Small Icon, and Large Icon. 

To choose a display mode for the Browser contents: 

1. Locate the View icons in the upper-right corner of the Browser tray. 
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2. Click the view icon for the desired style: 

• Small Icons: Displays half-size icons with a text label beneath. 

• Large Icons: Displays full-size icons with a text label beneath. 

• Name Only: Displays no icons, only text labels. 
 

 
If a folder contains more items than the Browser tray can display, use the scroll bar at the right side of the 
Browser tray to show additional items. 

Using the Browser File Menu 
The File menu is located in the upper-right corner of the Browser tray. It contains commands that help 
you manage your content and content folders. 

 
Use commands in the Browser’s File menu to manage your content and content folders. 
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Displaying Browser File Information 

Any item that appears in the Browser tray is saved as a separate document. When you display file 
information, you can view the name and type of file, and see the path to the folder that stores the file.  

To get information on a Browser tray item: 

1. Click the desired tab in the Browser. 

2. Select the item for which you want to view information. 

3. From the Browser menu, choose Get Info. A dialog provides Name, Type, Path, and Comment 
information on the selected item. 

4. Use the Name entry box to change the name, and optionally add a comment as a reminder of 
how to use this particular item. 
 

 

Deleting Browser Files 

The Browser menu includes a command that allows you to delete files from the Browser. When you use 
this command, it will also delete the file from your hard drive. 

To delete a Browser item: 

1. Click the desired tab in the Browser. 

2. Select the item that you want to delete. 

3. From the Browser menu, choose Delete File.  

4. Carrara asks you to confirm the deletion before the file is removed. Click OK to delete the file. 

Duplicating Browser Files 

There might be cases when you want to keep an existing Browser item, but use it as a starting point to 
create another similar item. For example, you might want to make some slight changes to a shader and 
save the modified version as a new Browser item. You can duplicate the existing item and make changes 
to the copy. 
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To duplicate a Browser tray item: 

1. Click the desired tab in the Browser. 

2. Select the item you want to duplicate. 

3. From the Browser menu, choose Duplicate File. 

4. Carrara creates a duplicate of the selected item, naming it Copy of (original object name) by 
default. You can now rename and open the duplicate for editing. 

Editing Browser Files 

Double-clicking a Shader, Modifier, Constraint, or Effects item in the Browser opens the appropriate editor 
for the item. For example, you can double-click a Shader in the Browser to open it in the Shader Tree 
Editor. 

To edit a Browser item: 

1. Click the desired tab in the Browser. 

2. Double-click the item you want to edit. Carrara opens an editable item as follows:  

o For an object, camera or light, Carrara opens it in a scene. 

o Carrara opens all other items in a document window, which contains the tools appropriate 
to its type. 

Adding Browser Folders 

Some of the Browser tabs include folders in which you can store your own content. For example, you’ll 
find empty My Objects, My Shaders, My Clips, and My Artwork folders at the top of the Objects, Shaders, 
Clips, and Artwork tab folder lists. These folders are all located within the Carrara installation folder 
hierarchy. 

You can also add other folders that reside on any drive in your system. While doing so, Carrara asks 
which tab will include your new folder. 

To create a new folder in the Browser tray: 

1. Click the desired tab in the Browser. 

2. From the Browser menu, choose Add Folder. The Browse for Folder dialog appears. 

3. Locate the folder that you want to add to the browser. Highlight the folder and click OK. 

4. If the selected folder contains different kinds of items, a dialog asks you to choose the types of 
files that you want to display in the selected Browser tab. Choices are Objects, Terrains, Clouds, 
Particles, Plants, or Leaves.  

5. Select the appropriate option and choose OK. The new folder appears at the bottom of the folder 
list in the tab that you selected. 

Removing Browser Folders 

Use the Remove Folder command to remove a folder without deleting the objects from your hard drive. 
This action is not undoable. 
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To remove a folder from the Browser tray: 

1. Click the desired tab in the Browser. 

2. Click the folder title you want to remove. Selected folders are highlighted. 

3. From the Browser menu, choose Remove Folder. Carrara removes the folder column from the 
Browser. 

Updating Browser Folders 

When you change the contents of a Browser folder, you might need to force Carrara to build a new list of 
the contents. 

To update listings in a folder: 

1. Click the desired tab in the Browser. 

2. Click the folder title you want to update. It will be highlighted. 

3. From the Browser menu, choose Update Folder. 

Resaving Browser Folders 

The Resave Folder and Resave All Folders commands update all files contained in all or the currently 
selected folders. 

To resave all files in one or all folders: 

1. Click the desired tab in the Browser. 

2. Choose one of the following:  

o To resave all items in a single folder, select the folder you want to update and choose 
Resave Folder. 

o To resave all items in all folders, choose Resave All Folders.  

3. Carrara asks if you want to overwrite the files. Choose OK to proceed. 

Browser Tabs 
There are several different tabs in the Browser tray, each of which holds a different category of files. This 
section gives an overview of the various types of content that you find in the Browser. 

Browser Tray: Scenes Tab 
The Scenes tab stores complete scenes in several different categories. You'll find scenes that provide the 
following types of examples: 

• Animations 

• Global Illumination 

• Indoor and Outdoor scenes, including space, landscapes, and skies 

• Lighting examples, such as global illumination, lighting, and lighting effects 

• Logos 
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• Packaging 

• Special Effects 

To access the Scenes Browser, click the Browser tray: Scenes tab. 

 
To load a scene from the Browser tray: 

1. Click the Scenes tab in the Browser tray. 

2. Navigate through the category list until you find the scene you want to open. 

3. Double-click the desired Small, Large, or Name Only preview in the browser tray. The scene 
opens in the document window. 

To save a scene to the Scene category in the Browser: 

1. Make sure the scene you want to save is open. 

2. Choose File > Save As. The Save As dialog appears.  

3. Select one of the Scenes subfolders in your Carrara installation folder. For example, if you want 
to save an animation, choose the Scenes: Animation subfolder, in which existing animation 
scenes appear. 
 

 
4. Click the Options. checkbox. 

5. Click Save. The Carrara Export dialog appears. 
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6. Choose where you would like to save your texture maps. The options are:  

o Save all internally: Saves all textures internally with the file. 

o Use local settings: Uses the settings of each individual texture to determine whether 
they should be stored inside or outside the file. 

o Save all externally: Saves all textures in separate files. 

7. Enable the Save Scene Preview option to generate a thumbnail for the Browser tray. 

8. Check or uncheck the Compress File option as need to save a compressed or uncompressed 
version of the file. 

9. Click OK. Your scene is saved with a .car file extension. 

Browser Tray: Objects Tab 
The Objects browser stores items that you can add to a scene that is already opened in your document 
window. There are a wide variety of objects arranged in many different folders, including, but not limited 
to, the following: 

• Nature objects such as Deserts, Plains, Mountains, Oceans, Plants, Leaves, and Clouds. 

• Particle objects. 

• Basic and Advanced modeled objects created with Carrara's modeling tools. 

• Formulas 

• Hair 

• Manmade objects such as Art, Buildings, Cities, Communication devices, and other household 
and industrial items 

• Fashion accessories such as jewelry, belts, earrings, and more 

• Transportation vehicles (land, sea, and air) 

To access the Objects Browser, click the Browser tray: Objects tab. 

 
To add an object from the Sequencer or the Properties tray by dragging them directly into the Browser 
tray. 

1. Create or open a scene. 

2. Click the Objects tab in the Browser tray. 

3. Navigate through the category list until you find the object you want to add to your scene. 

• Use one of the following methods to add the object to your scene: 

• Double-click the desired Small, Large, or Name Only preview in the Objects browser tray 
to place the object in the center of the scene. 
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4. Drag the preview from the Browser tray. You can drag it into the Assemble or Storyboard room, 
into the Sequencer or the Instances tab of the properties. If you drop an object into the 
Sequencer, it appears at the origin (X=0, Y=0, Z=0). If you drag it into the Assemble or 
Storyboard room, it appears at the point where you release the mouse button.  

To save an object to the Objects category in the Browser: 

1. Click the Objects tab in the Browser tray. 

2. Use the folder list to select the folder that will store your item. 

3. Go to the Sequencer Tray, or to the Properties tray: Instances tab. 

4. Click the name of the object that you want to add to the Browser. 

5. Drag the item's name to the Browser tray.  
 

 
6. Carrara opens a dialog so that you can name the file containing the saved item. Enter a name 

and click OK. The object is saved with a .car file extension. 
 

 

NOTE! Objects are stored in several subfolders that appear beneath the Presets folder in your 
Carrara installation directory.  

Browser Tray: Shaders Tab 
Shaders are used to define the appearance of the objects in your scene, and can range from simple 
colors to more complex materials that include textures, reflections, displacement and more. When you 
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create your own shaders (see "Creating and Editing Shader Trees"), you can save your custom presets to 
the library and load them from the Browser Tray. 

Library shaders are stored as separate files and can be loaded into the Browser: 

• When you drag a library shader from the Browser into the Sequencer, Carrara makes a copy of 
that shader.  

• When you drag a shader from the Browser onto an object, Carrara makes a copy of that shader 
and applies it to the object.  

• In either case, the shader becomes a part of the scene and is referred to as a Master Shader. 

Don't overload the Browser tray with shaders. Each shader thumbnail requires some memory. Too many 
shaders loaded into the Browser could impact your system's performance. It's a good idea to limit the 
directories listed at any given time. 

 
You can use the Browser to organize and store your personal shader library. 

You might want to organize your shader directories as logical categories. For example, a list of directories 
might read: Wood, Rocks, Plastic, Glass, Marble. 

You can set up the Browser to display a flat or spherical preview of the shaders. As with other items in the 
Browser, you can add and remove shaders from the tray. 

You can also view shaders contained in a scene by clicking the Shader button in the Sequencer. 
Remember, the shaders you use in a scene are not automatically listed in the Browser. If you create or 
use a shader in a scene that you want to reuse, be sure to save it to the Browser. 

To view shaders in the Browser: 

• Drag open the Browser tray, then click the Shaders tab to view the currently installed shaders. 

To use a shader, modifier, or constraint from the Browser: 

• Drag the item you want to use from the Browser onto the object where you want to apply it. 

• You can drag onto the object preview in the Assemble or Storyboard room or onto the listing in 
the Sequencer. 

• You can also drop the item onto the appropriate section in the Properties tray: Instances tab. 

Browser Tray: Clip Tab 
The Clips tab stores NLA (Non-Linear Animation) clips. For more information on these types of clips, refer 
to "Using NLA Clips." 
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Browser Tray: Misc Tab 
The Browser tray: Misc tab lets you save constraint settings that you can later apply to your objects. 

 
The Browser tray: Misc tab lets you save objects, groups, and full scenes that you can use later. 

To access the Misc Browser: 

• Click the Browser tray: Misc tab. 

Browser Tray: Artwork Tab 
The Artwork tab allows you to store your renders in the browser. After you render an image, save it to a 
folder of your choice. Use controls in the Browser menu to add the folder to the Artwork tab. Then save 
your images to the designated folder. 
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Using Content and Runtime Folders 
The Content tab stores content that is compatible with DAZ Studio and Poser. Content of this type is pre-
rigged and includes poseable figures, clothing, hair, poses, and more. 

 
The Runtime folder structure originated with Poser and is also supported by DAZ Studio. All content 
purchased from DAZ is arranged in this manner. In order for content to appear in Poser libraries, all 
content has to appear beneath a folder named Runtime. Beneath the Runtime folder are additional 
library folders (Characters, Props, Hair, and so on) and Textures folders that contain their respective 
types of content. 

When you add Runtime folders to your content browser, you can drag and drop Poser and DAZ Studio-
compatible content into your scene. Items in the Characters library include pre-rigged characters and 
poseable clothing and hair that fit them. Clothing has to be specifically designed for the figure that wears 
it in order to fit and pose perfectly. Props folders typically contain scenery and non-poseable clothing like 
hats, glasses, and so on. The Pose folders can contain anything from preset character poses to files that 
apply preset material settings or textures to the items they are designed for.  

Adding Runtime Folders 
Carrara allows you to add Runtime content folders to your Content Browser. This provides an easy way to 
import DAZ Studio and Poser content into your scene. You can add as many Runtime folders to your 
Content Browser as you like. 

To add Runtime folders in the Assemble Room: 

1. Go into the Browser and click the Content tab. 

2. From the Options Menu, choose Add Runtime. The Browse for Folder dialog appears. 

3. Locate the folder that contains your Runtime files. Highlight the file and click OK or press Enter. 
The folder is added to the list of folders in your Content tab. You can use this procedure to add as 
many Runtime folders as you like. The following figure shows several different Runtimes as they 
appear in the Content Browser. 
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Using Content Runtime Folders 
Once you have placed Runtime folders in your Content Browser you can quickly and easily place the 
content into your scene: 

1. Use the Content Browser to expand or collapse the Runtime Folder until you locate the item you 
want to add to your scene. When a folder contains content, icons will appear in the Content 
Browser as shown in the following figure. 

2. Drag an icon from the Content Browser and add it to your scene. You may be prompted to locate 
geometry (OBJ) files or texture maps. After you locate the appropriate files, Carrara displays a 
progress bar during the loading process. The content then appears in your scene. 
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Adding Content: Special Notes 
Of particular note are the following points that you should keep in mind when you add content from 
Runtime folders: 

• Cameras: Cameras in Poser Runtime folders will be unavailable to add. You will have to set up 
your cameras within Carrara, or import Poser cameras using the File > Import command. For 
further information, see "Importing Poser Cameras (CM2/CMZ)." 

• Faces (facial expressions and poses):  

o Drag and drop a Face pose icon over the figure in the scene that you want to apply the 
pose to.  

o Note that some face poses may contain injection morphs that apply special morphs to the 
face. See Injection Poses (below) for instructions on how to locate them. 

• Figures (Poseable Characters):  

o Poseable characters initially appear in their default poses in the default position (center) 
of the scene.  

o You can later pose your figure using standard Carrara tools or by applying a pre-defined 
pose from the Content Browser.  

o In Carrara, posing dials that are normally labeled Bend, Twist, Side-Side, Up-Down in 
DAZ Studio or Poser are found in the Properties tray: Motion tab: Transform panel. 
You can also use Carrara's Scale, Rotate, and Universal Manipulator tools to pose your 
figures. 
 

 
• Figures (Conforming Clothing): Select the icon from the Content tab, and drag and drop the 

icon over the figure that you want it to conform to. The clothing automatically conforms to the 
selected figure. 

• Hair Props: Hair props found in the Hair library folders in your Runtime will automatically parent 
to the head of the object that you drop the icon over. However, you might find that some hair 
props needs adjustment to properly position it on the figure. Though it is possible to adjust the 
position of hair props after a figure is posed, it is easier to adjust when the figure is in its default 
position. 
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• Hand Poses: Drag and drop a Hand pose over the figure you want to apply it to. Carrara prompts 
you to select the hand to which you want to apply the pose. Choose Left or Right and click OK to 
apply the pose. 

• Lights: Lights in Poser Runtime folders will be unavailable to add. You will have to set up your 
lights within Carrara, or import Poser lights using the File > Import command. For further 
information, see "Importing Poser Lights (LT2/LTZ)." 

NOTE! Poser lights may need some adjustment in intensity, color, and falloff after importing, and 
the amount of adjustment may also vary due to changes between Poser versions. Start by reducing the 
light intensity to 25-30% of the original intensity and then increase or decrease as necessary to get the 
desired affect. 

• Poses: Carrara allows you to apply all types of Pose files to your scene. Use icons in the Pose 
folder to pose your figures, change materials, apply injection morphs, and other types of Poses 
that you typically also use in DAZ Studio or Poser. Keep in mind that you may be prompted to 
locate texture maps or injection files (see below) before the pose is applied to your object. 

• Injection Poses: When you try to add poses that inject morphs into your figures, you may be 
prompted to locate injection poses on your system. For DAZ figures, these injection files are 
typically located in special folders that begin with !DAZ, followed by the name of the figure that 
they are used for. For example, injection files for Victoria 3 are located in Delta folders that 
appear beneath the Runtime > libraries > !DAZ > Victoria 3 folder, which is further separated 
into Body, Head and other subfolders. To view the files in a pose folder, select Poser Pose from 
the Files of Type menu when you are prompted to locate the files. 

• Props:  

o When loading a prop, you can drag and drop it into the Assembly window. Normally, 
props are designed to load in the center of the scene and on the floor.  

o Some props are designed to load in a particular place in the scene (for example, sails for 
a sailboat will load on the mast, or a pair of earrings will load on a figure's ears). To load 
props in their designed� position, drag the desired prop from the Browser tray and drop it 
into an empty spot in the Instances tab, or onto the word Scene in the Instances tab.  

o To attach or parent a prop to another object, locate the prop you want to attach in the 
Instance list. Then drag and drop it in the Instance list, releasing the mouse when it 
highlights the object or body part that you want to assign as the parent to the prop. 

o Smart Props (those designed to come in properly placed and parented to a figure) 
should be dragged and dropped onto the character in the Assembly window, or on to the 
main entry for the character on the Instances tab. 

o You may be prompted to locate OBJ or texture files before your prop appears in the 
scene in its default position.  

o After the prop appears in your scene you can use Carrara's Move, Scale, and Rotate 
tools (or the Universal Manipulator) to position the prop where you want it to appear.  

• Morphs: When you add content that contains morphs, You'll find the morph dials in the Assemble 
room. Click the figure or body part that you want to change, and then open the General properties 
tab. The morphs appear near the bottom of the tab, and may be arranged in groups as shown in 
the following figure. 

 © 2008 DAZ 3D, Inc. 69 



Carrara 7 11 December 2008 

 

 
• Expand the morph group, if necessary, to display the morph dials. You can move the morph slider 

left or right to adjust the setting. You can also click the numerical value of the morph and type in a 
precise value. 
 

 

Adding Level of Detail 
Carrara provides the ability to use Level of Detail (LOD) meshes on a figure which allows the user to: 

1. Use lower resolution meshes while working in the scene but render with a higher resolution mesh. 

2. Use different resolution meshes depending on how far the figure is from the camera. 
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In order to use this feature, the figure/object must already have the LOD levels available and each mesh 
must have the same vertices as the other levels. 

To load and use LOD: 

1. Load the figure into the scene and make sure the root figure is selected in the Instance tab. 

2. In the Properties tray, locate the Level of Details section under the Parameters heading. 
 

 
3. Click on the Add LOD button. The Import LOD file dialog will come up. Locate, select, and open 

the first LOD mesh file. 
 

 
4. The LOD name dialog will come up. You can leave the name as is (taken from the mesh name) 

or rename it. Click on OK to accept the name. 
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The Calculating Level of Details progress bar will come up. 
 

 
5. If more LOD meshes need to be loaded, repeat until all meshes are loaded. 

6. Once all LOD meshes are loaded, click on the LOD Options button to access the Level of Detail 
Options dialog. 
 

 
 
The LOD Options dialog is divided into two sections: 

• Auto-Switching Settings: Allows selection of LOD levels based on viewport/rendering or 
on distance from camera. 

• LOD List: Shows a listing of currently available LOD levels with options to delete, rename, 
and sort. 

7. Simple LOD - This option is the default selection for using LOD levels. It provides options to 
select which mesh level to use while working in the scene and which level to use when rendering. 
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This allows you to set up a scene with a figure with a lower resolution mesh to save on memory 
usage but switch to a higher resolution mesh for final rendering. 

• Viewport: Click on the button next to Viewport and select an LOD mesh from the listing. 
This is the LOD level that will be used as you are working in the scene. 

• Render: The default render level is the Base mesh, i.e., the highest resolution mesh 
available. This is the LOD level that will be used when you render the scene. Unless you 
need to render with a lower resolution mesh, leave the Base mesh selected. 
 

 
 
Example: 
 
Viewport level set to use the 4K Victoria 4.2 mesh: 
 

 
 
Victoria 4.2 4K mesh in the viewport: 
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And the rendered version using the Base mesh: 
 

 
8. Advanced LOD (Distance From Camera) - This option provides options to select which LOD 

level to use based on how far the figure is from the camera. This allows you to have several 
figures in the scene but to reduce the mesh resolution for figures that are further back in the 
scene and don't need as much detail available. 
 
There are three slots available for setting distance from the camera and which LOD level to use 
beyond that distance. 
 
To set the LOD levels and distance from camera: 

1. Left-click on the button next to each LOD item to select an LOD level. 
 

 
2. Left-click in each Beyond Distance field and enter the distance beyond which the figure 

will change to that specific LOD level. You can set the options from near to far as shown 
in the image above or far to near as shown below. 
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Examples: 

• Base mesh before reaching 0.08 ft from camera: 
 

 
• 4K mesh after passing 5 ft from camera: 
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• 2K mesh after passing 10 ft from camera: 
 

 
3. Click on OK to accept the changes or on Cancel to revert to the previous settings. 

LOD List 

The LOD List section provides options for deleting, renaming, and sorting the available LOD levels. 

Click on an item in the list to select it. This will activate the buttons at the bottom of the dialog. 

 
• To delete an item, click on the item then on the Delete button. In the image below, the 1.5K mesh 

was removed. 
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• To rename an item, click on the item then on the Rename button. The LOD name dialog will 
come up. Enter a new name and click on OK to rename or on Cancel to leave the name as is. 
 

 
• To sort the list, click on an item then on the Move Up or Move Down buttons. 

 

 
 
Repeat for each item to be moved until they are in the order needed. Once the items are sorted, 
they will be available in that order when selecting an LOD level in the Auto-Switching sections. 
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Using Environmental Primitives 
Carrara offers several environmental primitives: terrains, trees, fountains, fire, fog, and clouds. 

The Cloud, Fog, and Fire primitives are volumetric. With other objects, changing the size causes the 
object itself to change scale. 

The terrains, the trees and the clouds are directly in the primitive toolbars. The Environmental Volumetric 
Primitive tools are located in a pop-up menu. 

 

NOTE! Use the PhotoRealistic renderer to render the volumetric primitives. 

Creating Terrains 
The Terrain primitive simulates natural terrains. By adjusting the parameters, you can create such 
settings as rocky mountain ranges and desert dunes. 

 
To insert a Terrain: 

1. Depending on the desired location of the terrain, do one of the following: 

o To create a terrain of default size at the center of the universe, choose Insert >Terrain. 

o To create a terrain at any other location, drag the Terrain tool to the desired position in 
the scene window. 
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The Terrain editor appears. 
 

 
The terrain editor is divided into three parts: 

• The Filter Layers List is the list of operations performed to generate a terrain. 

• The Terrain Properties control the size and precision of your terrain. 

• The 3D Preview displays a preview of the terrain. 

The Filter Layers List 
The Filter Layers list represents the different filters that are used to generate a terrain. The top filter (or 
generator) is applied first, and then each of the filters is applied on the result of the previous filter. In the 
example shown in the following figure, the Canyon filter is applied on top of the Round Mountain filter 
(which means that it modifies the result of the Round Mountain filter). By combining various filters you can 
create any terrain you desire. 

To create a new filter: 

• Click on the Add button in the Filter Layers list to add a new filter at the end of the stack. 
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To create a terrain based on a height map: 

• Click on Import (in the Map section) to import a texture to use as a height field. 
 

 
To load a preset terrain: 

• Click on Load (in the Preset section) to choose from a list of Wizard scenes that are furnished 
with Carrara and installed to your hard drive. 
 

 
To edit a filter: 

1. Select the filter by clicking on it in the list. 

2. Select the type of the filter you want to use from the pop-up menu. 

3. Edit the properties of the filter. 
 

 
For a more detailed description of each filter, see "Filter Reference." 

The Terrain Properties 
The Terrain Properties control the size and precision of your terrain. 
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The properties are: 

• World Size: The reference size of your terrain for the filters. This is not the size of the terrain in 
your scene. 

• Preview Quality: Adjust the slider to view less or more detail in the 3D Preview. 

• Preview Map Size: Enter the desired dimensions for the preview map. Higher values provide 
more detail, and lower values use less resources. 

• Rendering Quality: Adjust the slider to view less or more detail in the rendered image in the 3D 
preview window. 

• Final Map Size: Enter the desired dimensions for the map used for the final render. Higher 
values provide more detail, and lower values use less resources. 

• Rescale terrain to: To change the size of the scene, check this option and enter the desired 
dimensions in the size fields. 

• Save height map in file: Ensures that the terrain is stored in the file. This avoids recalculating 
the terrain every time you load the file. However, be careful, as this option can generate large 
files. 

The 3D Preview (Landscapes) 
The 3D preview allows you to view the terrain as it is edited. You can move and rotate the point of view 
using the camera tools. The Render button will raytrace the preview to create a more realistic preview of 
your terrain. 

The preview is usually updated each time your modify your terrain. However, for complex filters, 
calculating the preview after each change can be too slow. In that case, uncheck Auto-Update and use 
the Generate button to update the preview. 

 

Creating a Custom Terrain 
Sometimes it is more convenient to edit the terrain directly. For example, you may want to make a 
mountain a little lower or place a valley in the middle of your terrain. 

To do so, click on the Map Editor button. It converts the current filter list to a static height field and opens 
a new editor. Note that once you have edited a terrain manually, you cannot modify the filter parameters 
further. You can however apply new filters on top of your terrain. 
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The Drawing area in the Map Editor provides a top view where you can create and edit a basic terrain 
shape using the Terrain tools and the Modify controls. 

 
You select Terrain tools and drag in the Drawing area to directly edit the basic terrain shape. From left to 
right, the icons represent the Elevation Paint, Raise, Crater, and Erode tools. While you paint the terrain, 
note that lighter areas represent high altitudes, while darker areas represent lower altitudes. 

 
Once in the Terrain Editor, there are many different ways that you can modify your terrain. 

Painting a Terrain 

The Elevation Paint tool acts like a paintbrush. As you drag in the Drawing area, Carrara creates 
mountain ranges based on the shape you are creating and displays them in the Preview area. 

 
When the Elevation Paint tool is active, you can adjust the brush using the following controls: 

• Paint Size: Drag right or left to increase or decrease brush size. 

• Softness: Drag left or right to increase or decrease brush softness. 

• Level: Drag the slider to adjust the brightness of the paint color. 
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To create or add to a terrain: 

• Select the Elevation Paint tool and drag in the Drawing area. 

Increasing and Decreasing Heights 

The Raise tool increases and decreases the height of a local area as you brush over it. 

When the Raise tool is active, you can adjust the area that will be affected with the Raise Size slider. 

 
To increase or decrease the height of an area: 

1. Select the Raise tool and left-click in the Drawing area where you want to modify the terrain. 

2. While left-clicking, drag up or down to increase or decrease the height. 

Adding Craters 

Use the Crater tool to create indentations in the terrain. 

 
To create a crater: 

1. Select the Crater tool. 

2. Drag over the area you want to indent. 

Simulating Erosion 

Use the Erosion tool to simulate the effect of water erosion. Carrara erosion leaves sharper peaks and 
deeper valleys. 

 
To erode an area: 

1. Select the Erosion tool. 

2. Drag over the areas you want to erode. 

Filter Reference 
The terrain editor provides a wide range of powerful filters to create a wide variety of terrains. 

 
There are three categories of filters in the Terrain Generator. 
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• Generators are generally used at the top of the filter list. They can create a landscape without 
being applied to another filter. Note that a generator is still a filter, meaning that it will be applied 
on top of the previous filter in the list (if there is one). 

• Advanced generators provide additional options such as displacement, fractals, gradients, and 
more. 

• Filters are generally used after a generator or another filter. They are used to modify an existing 
terrain. 

Generators 

The main generators that you can select from the Generator menu are: 

 
• The Crater filter generates a flat terrain with craters. Use it to create moon-like landscapes. 

Because it generates a flat terrain, you may want to combine it with another generator to make a 
more realistic terrain. 

• The Hill filter creates a gentle rolling hill on the terrain.  

• The Mesa filter creates a desert with some mesas.  

• The Mountain filter creates mountains that have the same rocky aspect everywhere. To increase 
the realism of this terrain, use other filters such as the glaciate filter or the canyon filter. 

• The Round Mountains filter creates terrains with some mountains and some flat areas. 

• The Smooth Mount filter creates a terrain with smooth raised and lowered areas. 

• The Smooth Plain filter creates a terrain with smooth hills. 

• The Straight Mountain filter creates straight mountains. 

• The Valley And Mountain filter creates very realistic landscape that includes rocky mountains 
and smooth valleys. 

• The Valley and Straight Mountain filter creates straight rocky mountains and smooth valleys. 

After you select a terrain generator, its properties appear in the terrain editor. The following figure shows 
an example of the properties that are available for the Hill generator. 
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The following settings are common to many of the generators: 

• Feature Size: Controls the scale of the feature over the existing terrain. Decrease the feature 
size to create a larger number of hills or mountains on the terrain. Increase the feature size to 
create a fewer number of hills or mountains. As you adjust the slider, a numeric indicator displays 
the relative size of the feature. 

• Height: Enter the desired maximum height for your feature. 

• Roughness: Adjust the slider to affect the smoothness or roughness of the terrain. 

• Strength: Adjust the slider to increase the amount of strength that is applied by the terrain map. 

Filters 

The Filter menus in the Terrain editor also provide a variety of filters that create the following 
modifications: 

 
• The Canyon filter creates a canyon in your landscape. You will have some flat areas at the 

bottom and at the top and between cliffs. 

• The Erosion Filter can create a realistic terrain by applying erosion to the terrain. You can apply 
four types of erosion: rain, thermal weathering, wind, and smooth erosion. The most important 
parameter is the Erosion Cycle; it controls how many cycles of erosion will be applied. Each type 
of erosion that you enable is applied at each cycle. Note that a high value of Erosion Cycle will 
lead to a very slow terrain generation. 

• The Gaussian Filter creates a terrain with a border that has a height close to zero. Use it to 
create a single mountain (See also the Zero Edge Filter). 
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• The Glaciate Filter creates flat valleys similar to the valleys that result from the erosion by a 
glacier. 

• The Invert Filter inverts the map of the terrain. You can use this filter, for example, to create all 
kinds of rivers by using the level parameter. 

• The Noise Filter adds visual noise to your terrain. The location of the noise can be controlled by 
the local shape of the landscape (altitude, slope, and orientation). Use visual noise to create an 
area that looks like a forest on your terrain. 

• The Plateau Filter adds a midland plateau to your landscape. 

• The Scale Height Filter changes the height of a terrain. 

• The Smooth Filter smoothes the terrain. 

• The Terrace Filter creates terraces on the landscape. 

• The Zero Edge Filter modifies the terrain so that all borders have a height of zero. It can be used 
to create a single mountain. 

Advanced Generators 

Finally, the Filter menu provides advanced generators that allow you to further customize the appearance 
of your terrains. 

 
• The Displacement filter is very similar to the Mountain generator. Its main advantage is that it is 

very fast. 

• The Dome filter creates a dome centered on your terrain. 

• The Fractal Function filter can be used to make most types of terrain. It provides you control of 
all parameters. This is a complex generator with more options and can be challenging to use. The 
standard generators will meet most of your needs. 

• The Gradient Generator creates a gradient of heights. 

Terrain Shading 
You can use any kind of shader to shade a terrain. The Terrain shader is specifically designed for this 
purpose and makes it easier to shade a terrain. 

When you switch to the Texture room from the Terrain Editor, or when a terrain is selected in your scene, 
you see the shader properties that are currently assigned to the terrain.  

About Terrain Layers 

Terrain layers allow you to build up different types of ground cover on your terrain. The terrain shader is 
composed of a number of different layers. Each layer in the list corresponds to a type of surface. The 
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layers are applied on top of each other (for example, the snow layer covers the grass layer, which covers 
the land layer, and so on). The last layer covers the global shader. 
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When you expand a Terrain Layer in the Shading tab, you will see a distribution and a shader surface 
associated with it. 

 
When you create your terrain layers, you should consider the order in which they appear in the Shading 
hierarchy. In other words, snow usually appears at the top of a mountain, with rocks, land, and grass 
below. Wherever none of the other layers are visible, you will see the global shader 

Distribution Types 

The distribution type determines the type of covering that is distributed on the selected terrain layer. 
There are different types of distribution, described in the following sections. Choose None if you do not 
want to apply a distribution layer. 

 
There are eight different types of distribution layers: 

• None: No distribution layer. 

• Custom: The Custom distribution type provides access to all the parameters that control a 
distribution. This allows you to create your own customized distribution layers. 

• Everywhere: The Everywhere distribution type puts the distribution layer everywhere. This 
means that no layer will be visible under it. There are no properties to set.  

• Grass: Grass distribution layers are used to distribute a grass or tree layer. The layer will be 
visible only between two altitude values and on relatively flat areas (grass does not grow on 
vertical cliffs). 

• Land: Land distribution layers are used to put a layer of land on the terrain. It is located only in 
areas that are flat enough (minimum slope). 

• Rock: Rock distribution layers are usually located in areas where the slope is steep. It is useful to 
position rocks on your terrain. 

• Simple: The Simple distribution layer distributes the layer properties randomly.  

• Snow: The Snow distribution layer distributes the layer only at the top of the mountain and in 
areas where the slope is not too steep. 

When you choose one of the distribution types, its properties appear in the right pane of the terrain 
shader editor. The properties you can set are arranged in five categories. Though these categories do not 
apply to all of the distribution layer types, the purpose of the settings are common to all layer types: 
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Bump Properties 

When you choose the Custom, Grass, Land, or Rock distribution layer type, you’ll find the following 
typical settings that adjust various bump properties: 

 
• Size (Custom only): Determines the size of the noise features you can see in the bump. 

• Amplitude (all): Determines the amplitude of the bump. 

• Follow Terrain (Custom and Rock): Adjusts the bump altitude depending on the steepness of the 
terrain. Where the terrain is steep, the bump has a bigger amplitude. This parameter controls how 
strong the variation should be. 

• Roughness (Custom and Rock): Determines the roughness of the noise used in the bump. A 
rough surface has a lot of variation. Set this value lower for smoother surfaces. 

• Shuffle (Custom only): Click this button to randomly generate bump for the terrain. 

Noise Properties 

When you choose the Custom, Grass, Land, Rock, or Simple distribution layer type, you’ll find the 
following typical settings that adjust various noise properties: 

 
• Coverage (all): Determines how much this layer covers the terrain. At 0% the layer is not visible 

on the terrain. At 100% it completely covers the terrain. 

• Noise (all): Determines the amount of noise in this layer. The variation between the area covered 
and the area not covered can be more or less noisy, based on the setting of this parameter. 

• Size (all): Determines the size of the noise features. 

• Shuffle (all): Click this button to randomly generate noise for the terrain. 

 © 2008 DAZ 3D, Inc. 89 



Carrara 7 11 December 2008 

Altitude Properties 

When you choose the Custom, Grass, or Snow distribution layer type, you’ll find the following typical 
settings that adjust various altitude properties: 

 
• Influence (Custom and Grass): Allows you to control where the layer should be visible, 

depending on the altitude. For example, you might want to put a layer of snow above a certain 
altitude. 

• Minimum (all): This layer will not cover any part of the terrain when the altitude is below this 
value. 

• Maximum (Custom and Grass): This layer will not cover any part of the terrain when the altitude 
is above this value. 

• Blending (all): . 

Slope Properties 

When you choose the Custom, Grass, Land, Rock, or Snow distribution layer type, you’ll find the following 
typical settings that adjust various slope properties: 

 
• Influence (Custom only): Allows control of the layer repartition depending on the slope. Using a 

snow layer as an example, you might not want to put snow on steep parts of the terrain. This 
parameter controls how strongly the slope limits need to be taken into account. 

• Minimum (Custom and Snow): This layer will not cover any part of the terrain when the slope is 
below this value. 

• Maximum (Custom, Grass, Land, and Snow): This layer will not cover any part of the terrain 
when the slope is above this value. 

• Blend (all): This parameter controls the fuzziness of the transitions. 
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Orientation Properties 

When you choose the Custom or Snow distribution layer type, you’ll find the following typical settings that 
adjust various orientation properties: 

 
• Influence (all): Allows control of the layer repartition depending on its orientation. Again using 

snow as an example, you might not want to put snow on the part of the terrain that is oriented 
toward the sun. This parameter controls how strongly the orientation limits need to be taken into 
account. 

• Direction (all): Defines a vector in 3D space that is used as a reference orientation. The layer will 
be visible only if the surfaces face this orientation. 

• Pitch (all): Defines a vector in 3D space that is used as a reference orientation. The layer will be 
visible only if the surfaces match this pitch setting. 

• Blend (all): This parameter controls the fuzziness of the transitions. 

Creating Plants 
The Plant primitive simulates real plants with branches and leaves, such as trees. Even if you only adjust 
a few parameters you can create many different types of trees. The number of parameters might seem a 
little bit daunting at first. However a lot of the parameters are the same for each generation. 

That is why we recommend that you always start from one of the preset trees and use this dialog as an 
exploration tool. It is usually a good idea not to modify too many parameters at the same time since the 
results can be difficult to understand. 

It is important to understand the concept of generation. The branches of the tree are hierarchical with a 
concept of generation: the trunk is generation 0, branches born from the trunk are generation 1, and so 
on. Some parameters depend on the generation of the branch they apply to, so that branches at different 
levels in the tree hierarchy can have different properties. 

To insert a Plant: 

1. Depending on the desired location of the tree, do one of the following:  

o To create a tree of default size at the center of the universe, choose Insert >Plant. 

o To create a plant at any other location, drag the Plant tool to the desired position in the 
scene window. 

2. Carrara will move to the model room where the Plant editor opens.  

Basic Plant Editing 

While editing your plant, you can at any time click on the Render button to see a raytraced rendering of 
your tree using its current shader. 
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The Plant editor contains five tabs, each of which contains different parameter settings for your plants. 
These tabs are Trunk, Branches, Leaf, Tree Shape, and Experts. 

Additionally some parameters are provided to control the appearance of the tree in the manipulation 
window. 

The Plant editor allows you to create your own plant types. Creating plants can be a challenging task so it 
is recommended to start from one of the presets delivered with the application, and to read the following 
documentation to understand the meaning of each parameter. 

 
Further information about the options in the Plant Editor are discussed in the following sections: 

General Properties 
The general properties appear directly beneath the tree preview render area. The settings available in this 
section control the general appearance of the tree. 

 
• Generation Count: This parameter controls the maximum number of generations used for a tree. 

The idea is that each branch has child branches and each series of child branch constitutes a 
generation. Setting this parameter to 0 will create a simple trunk. 
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TIP! Keep the number of generation as low as possible while modeling to speed up the 
preview redraw. Be careful when increasing this number as it can require a lot of time and 
memory to generate a very complex tree. 

• Randomness: This parameter controls the distribution of the branches and leaves in the tree. A 
value of zero will lead to an even distribution whereas a bigger value will create a more random 
tree. 

• Tree Size: Controls the size of the tree. 

• Shuffle: Clicking on this button generates a different tree using the same parameters. 

Manipulation Mesh Settings 
The manipulation mesh is the mesh you see in the interactive preview (3DView in the assemble room). 
This mesh is also the mesh that will be used if you apply a modifier to a tree, if you export your tree or if 
you convert the tree to another modeler. It is recommended to use a low resolution mesh to get good 
performance when you edit a scene containing trees. (The full resolution mesh will always be used for 
final rendering). 

 
• Visible Generations: The maximum number of generations that are used for the manipulation 

mesh. 

• Mesh Smoothness: The number of triangles used for the mesh. (a smoother mesh requires 
more triangles) 

• Full-Detail Mesh: Check this if want to see the most detailed mesh in the assemble room (this is 
useful if you want to export a tree to another program and want to apply a modifier to a tree). 
Keep in mind that the complete mesh is much more complex than the default one and will require 
a lot of memory and will redraw a lot slower. 

• Show Leaves: Check this if you want to see the tree leaves in Assemble Room. (leaves will be 
symbolized by triangles). 

• Quick Trunk Preview: 

• Load .pla file: A Tree Type is a particular set of parameters which defines a specific plant 
species. Tree types are stored as presets files on your hard disk (*.pla files). You can browse the 
installed tree types by opening the popup-menu, or save your own tree types by clicking the Save 
button - the new preset will then appear in the menu. 
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Trunk Properties 
You can control the size and complexity of the trunk using the following parameters: 

Aspect of Trunk 

 

• Trunk Width: The width of the trunk. 
Note that the width of child branches 
is defined relative to this width. 

 tree 

 
 

 
 

 

• Trunk Angle: The angle between 
the trunk and the vertical direction. 
(Can be negative to lean the
backwards). 

• Decay: Controls how fast the size of the trunk decreases with the height. 

• Base Curve: The curvature of the trunk. A value of 0 will produce a straight trunk, a positive 
value will bend it forwards, a negative value will bend it backwards. 

• Trunk Length: The length of the trunk. Note that the lengths of child branches are defined 
relative to this length. 

• Curve: Randomly curves the branches in a direction orthogonal to growth axis. A curve of 0 
produces straight branches, and a curve of 1 produces twisted branches. 

• Elasticity: Controls how a branch is sensible to tropisms - that is, gravity or light. When Elasticity 
is zero, the branch will not be changed by the Attraction parameter, while when it is 1, the effect 
of Attraction is maximized. 

• Tip: Allows the generation of a child at the end of the mother branch, in a continuing direction. 
Most plant species do have this extra child at the end of every parent branch. (used by the 
centered generator). 

• Horizontal: Forces the child branches to grow with an horizontal direction while still complying 
with the Start Angle constraint (centered and hybrid generators). 

Distribution of Main Branches 

 

• Phyllotaxy Angle: 
Controls the rotation of 
successive child
branches around and
along a same mother 
branch. For ramified
generators it sets the
angle between child
branches, and for the 

centered generator it controls the way child branches spiral around the mother-branch. A good 
value for this angle is 137.5 degrees. 

• Symmetry: Forces the generation of symmetric child branches in the centered generators. 

• Variability: Controls how much the angle varies for this generation. 
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• Branch Quantity: Controls the maximum number of branches per junction (only used for hybrid 
or ramified generators). 

• Internode Length: Represents the distance between two child branches. 

• Side Branch Qty: Controls the quantity of side branches (by opposition to a junction in a ramified 
generator). 

• Evolution: Increase/decrease of internode length (distance between two consecutive child 
branches on a mother branch). 

• Angle Amplitude: Controls the amplitude of angles that can occur along the branches of a 
ramified or hybrid tree (see Angle Rate). 

Roots 

 
• Flare: Controls the expansion of the trunk at the bottom. A flare of 0 will prevent any expansion 

• Lobes: Lobes is the number of roots in the plant. 

• Roots Definition: Represents the number of polygons used to approximate the roots. 

• Lobe Depth: Controls the depth of the roots. 

Branch Properties 
The Branches tab controls the properties of the branches on your plant. The settings are as follows: 

 

Affect all branches 

• Length Modifier: This parameter controls the length of all branches on the tree. A positive value 
will yield longer branches, whereas a negative value will shorten all branches. 

• Angle Modifier: This parameter controls the angles between all branches in the tree. A positive 
value will increase all angles while a negative value will decrease all angles. 
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Junctions’ smoothness 

• Smoothness: The number of points used to approximate a junction. 

• Generations of smooth junctions: The number of junctions that fully approximate with polygons. 

Leaf Properties 
You can control the foliage of your tree by using the following parameters: 

 
• Choose a Leaf: Click this button to open the Scene Wizard, which allows you to select one of 

many different types of leaves. After you select your leave, click OK to load the leaf shader (if 
desired) and return to the Plant Editor. 

• Load from File: Click this button to load a leaf file from your hard disk. A leaf is defined by a 
Carrara file in which the first object is assumed to be the leaf. In this file the x-axis is the length 
axis for the leaf, the y-axis its width axis, and the z-axis points out of the upper face of the leaf. 
The plug-in will automatically compute the base point of the leaf from its shape and orientation. 
The popup-menu allows you to browse through the available leaf models (*.car files). You can 
also create your own leaf models, they will automatically appear in the menu if you place the files 
in the appropriate folder (in your Carrara folder, look for the Data folder, then for a Plants 
subfolder). 

Leaves Distribution 

Settings in this section control the distribution of leaves on the tree. 

• Generations of Leaves: The number of generations of branches bearing leaves (usually one) 

• Leafless Margins: Determines the length at the beginning and end of a branch that remains 
without leaf expressed as percentages of the branch length. Since every branch grows, as a 
default behavior, a leaf at their end, you can use a non-null End Margin parameter to prevent 
branches from having a leaf at their ends. 

• Angle around Branch: Controls the increase/decrease of Leaf Angle (angle between leaf and 
bearing branch) along a branch. 
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• Evolution: Controls the increase/decrease of the leaf size along a branch. 

• Leaves Quantity: The average number of leaves along a branch segment. 

Leaf Appearance 

• Leaf Size: The size of the leaves. 

• Shape of foliage: Controls the shape of the foliage in changing the size of leaves along the 
branch - exactly the way the tree shape parameter changes the lengths of the branches along the 
trunk. A special mode, named "Use Value", selects no particular shape but rather uses the Size 
Evolution parameter to compute leaf sizes. 

• Evolution: Determines how the leaf size changes compared to the previous generation of 
branches. 

• Leaf Orientation: Controls the angle between the leaf and the vertical (an orientation of 0 makes 
the leaf point up, an orientation of 180 makes it point down). 

• Leaf elasticity: Controls the distribution of the leaves. 

• Leaf twist: The amplitude of random perturbations to leaf angle and leaf orientation, so the 
leaves on a branch do not share exactly the same orientation. 

• Leaf Angle: The angle between the branch and the main axis of the leaf. A low angle will make 
leaves point upwards, a big angle will make them bend downwards relatively to the branch they 
grow on. 

Tree Shape Parameters 
You can control the global shape of your tree using the following parameters. 

 

 © 2008 DAZ 3D, Inc. 97 



Carrara 7 11 December 2008 

Generation 

• Recursion Limit: Limits the number of times the procedural generator (centered generator or 
hybrid generator) is called recursively. This avoids generating by error hugely complex trees. 

• Pruning: Determines what shape the tree is constrained to. 

• Ramified Threshold: The generation number until which the tree will grow in a ramified way. 

• Procedural Threshold: The generation number from which a segment will spawn children 
procedurally (that is, spiraling all along the segment). Note that if Procedural Threshold is 
superior to Ramified Threshold, no child branch will be spawned using the procedural process. 

Deformation 

• Gravity: The strength of the gravity that is applied to the branches. 

• Wind: Set the Speed, Rustle, and Rustle Frequency settings as desired to control how the leaves 
react to wind forces in your scene. Use the Direction slider to control the direction that the wind 
comes from. 

• Additional Smoothness: Controls the smoothness of the animation. 

Experts Plant Parameters 
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Aspect of Branch 

• Width Ratio: Controls the ratio of the width of a branch, relatively to its parent branch. Usually 
these ratios should remain under 1 since branches grow shorter and thinner generation after 
each generation. 

• Variability: Variability parameters control the randomness of the tree. They control how much the 
randomized values can vary from the statistical average of these kind of characteristic (lengths, 
widths, angles). 

• Evolution: Increase/decrease of width ratio between child branch and mother branch. 

• Decay: Controls how fast the size of the tree branches decrease with the length. 

• Length Ratio: Controls the ratio of the length of a branch, relatively to its parent branch. Usually 
these ratios should remain under 1 since branches grow shorter and thinner generation after 
each generation. 

• Variability: Controls how much the angle varies around the value entered. 

• Evolution: Increase/decrease of length ratio between child branch and mother branch. 

• Start Angle: Control the angle between a child branch and its mother branch. The differences 
between Start Angle and End Angle determines the curvature of the branch parallel to the growth 
direction. 

• Evolution: Increase/decrease of the angle under which the child branches are grown along the 
mother branch. 

• End Angle: Control the angle between a child branch and its mother branch. The differences 
between Start Angle and End Angle determines the curvature of the branch parallel to the growth 
direction. 

• Evolution: Increase/decrease of the angle between the end of the child branch and the mother 
branch. 

• Curve: Controls the amount of curve in this generation of branch. 

• Elasticity: Controls the elasticity of the branch. 

• Tip: Check to add a tip to the branch. 

• Horizontal: Changes the orientation of the branches. 

Distribution of Subbranches 

• Phyllotaxy angle: Controls the rotation of successive child branches around and along a same 
mother branch. For ramified generators it sets the angle between child branches, and for the 
centered generator it controls the way child branches spiral around the mother-branch. A good 
value for this angle is 137.5 degrees. 

• Symmetry: Forces the generation of symmetric child branches in the centered generators. 

• Variability: 

• Internode Length: Represents the distance between two child branches. 

• Evolution: Increase/decrease of internode length (distance between two consecutive child 
branches on a mother branch). 

• Margin Length: The size of the base of the branch where no child will be spawned. 

• Branch Quantity: The average number of branches generated. at the end of each branch. 
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• Side Branch Quantity: Represents the probability that a branch will give birth to a side branch. 

• Angle Rate: Represents the probability that a branch will show an "angle" - that is, a discontinuity 
in direction. The value of the angle is controlled by the Angle Amplitude parameter. 

Creating Clouds 
Carrara 6 provides several ways to add clouds to your scenes. This section takes a look at the several 
options available for creating many different types of clouds. 

Note that you can also add cloud layers in the Sky Editor. To learn more about the sky editor see "Sky." 

Further information about Carrara's cloud primitive tools are discussed in the following sections. 

Volumetric Clouds (Standard, Pro) 
The volumetric cloud primitive allows you to create and place 3D clouds in your scene. Those clouds 
scatter light realistically. When used in conjunction with the realistic sky they can give very realistic clouds. 

• Choose Insert > Volumetric Clouds or click and drag the Volumetric Clouds tool into the scene.  
 

 
Once you insert a cloud in your scene, the cloud editor opens in the modeling room. The editor is split in 
several sections: the Light to Use panel, the Shape panel, the Properties panel and the 3D Preview. 

The following sections discuss the settings for Volumetric Clouds. 

Light to Use 

The Light to Use panel allows you to control which light will affect the cloud. 

 
You can use only the sun light (which is recommended if you are doing outdoor scenes) or all the lights 
in your scenes. 

You can also add the sky light to get more realistic lighting effects. This is especially useful if you are 
creating sunsets. Note the rendering will be slower with this option. 
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The Shape Panel 

The shape panel allows you to edit the shape of the cloud. Several types of clouds are provided. 

 
Several cloud shapes are available to choose from. 

Basic Shape 

Basic Shape fills simple shapes (cube, sphere, etc.). This does not create realistic clouds. 

 

Big Cumulus 

Big Cumulus creates large clouds. 
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Cumulus 1 and 2 Clouds 

Cumulus 1 creates generic clouds. Cumulus 2 generates shapes that are less complex than cumulus 1. 
The settings are similar for both types: 
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General Properties Panel 

This panel allows you to edit the size of the clouds as well as some basic lighting properties.  

A couple of remarks: 

• The silver lining controls how the clouds receives light depending on the direction. A high value 
will create a more directional lighting which leads the silver lining effect when the cloud is lit from 
behind. 

• The size of the cloud is very important. To obtain realistic effects, the size of the atmosphere and 
the clouds have to be realistic in relation to your scene. 
 

 

The 3D Preview (Clouds) 

The 3D preview allows you to visualize your clouds from any angle you want (use the camera tools to 
change the angle of view). 

One useful option is that you can either render the preview using a Draft Mode or Full Accuracy. It is 
usually a good idea to create the shape of your cloud in Draft Mode and then use Full Accuracy to tweak 
the lighting properties. 
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Volume Clouds 
The Cloud primitive creates a 3D volume filled with clouds. You can use this primitive to quickly add a sky 
to any scene. 

There is no on-screen preview of the cloud except its bounding box, which indicates the cloud's size and 
location. You cannot see the cloud until it's rendered. 

Tip! You can do a spot check of the cloud using the Test Render tool. Select the tool and drag over any 
area of the cloud. 

You can place objects inside the cloud or partially within the cloud. Cloud attributes can also be animated. 

To create a cloud object: 

1. Depending on the desired location of the cloud, do one of the following:  

• To create a cloud of default size at the center of the universe, choose Insert > Clouds. 

• To create a cloud at any other location, drag the Clouds tool to the desired position in the 
scene window. 
 

 
2. Click the Model button to switch to the Model room. The Cloud Primitive controls appear. 

 

 
3. Set the Cloud Primitive controls to achieve the desired effect.  

• Color sets the color of the cloud. 

• Container determines the general shape of the cloud. Choose Box, Cylinder, or Sphere 
from the list. 

• Quantity controls the number of clouds included in the bounding box. 

• Quality controls the quality of the clouds as they are rendered. The higher the quality, the 
longer the render time. 

• Size controls the size of clouds included in the bounding box. 

• Density controls the density of clouds. A low setting creates almost transparent clouds 
while a high setting creates almost opaque clouds. 

• Edge Falloff controls the appearance of the edges of the clouds. A low setting results in 
a sudden change, or shorter falloff. A high setting results in gradual change, or longer 
falloff. 

• Shuffle randomizes the order in which cloud swirls are generated. For example, if you 
duplicate a cloud object, the two objects are identical, which looks artificial. To make 
them look different while leaving all other settings identical, you can shuffle one cloud for 
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a more natural look. 
 

NOTE! The random order is expressed as the Seed value in the cloud properties. 

4. When you are finished, close the Cloud controls and go back to the Assemble or Storyboard 
room. 

Old Volumetric Clouds (Standard, Pro) 
The Old Volumetric Clouds feature creates animated volumetric clouds. There are a few tricks to getting 
them to look right. For example, if bands are appearing in your clouds, you probably need to increase the 
number of sections. 

To create Old Volumetric Clouds: 

Choose Insert > Old Volumetric Cloud and set the following options: 

 
• Octaves: Increases the complexity of the clouds. Perlin noise algorithms are used to generate, 

among other things, clouds, marble, wood, and jitter effects. A universal parameter of Perlin noise 
is the octave parameter. Each successive octave of noise has a frequency twice that of the 
previous octave. Therefore, each time you increase the octave parameter, the Perlin Noise 
becomes more detailed and intricate. 

• Persistence: Increases the granularity of the clouds. Another parameter that is common to Perlin 
noise, is persistence. This parameter defines the rate at which the amplitude decreases for each 
successive level of noise/order. Higher values of persistence lead to greater levels of noise for 
both regular and reverse Perlin noise. 

• Scale: Scales the cloud. 

• Density: Controls how dense the clouds are. 

• Size Controls: These control the cloud's size in local coordinates. Increasing these will cause the 
cloud size to increase without stretching, as scaling it in the properties panel would do. 

• Seed: This value "seeds" the random number generator. 
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• Phase: Controls the animation of the clouds. Start with a phase of 0, move the slider to the end of 
the animation, and set it to the final value. For slowly changing clouds, increase this by about 10 
per second of your animation, and 100 per second for rapidly changing clouds. 

• Color Controls: Change the color of the clouds at the corners, and the gradient from top to 
bottom. 

• Section Controls: If your clouds look banded, you will need multiple sections. Alternatively, you 
can increase the sizes, then scale the cloud in the Properties panel. This may not always work. 

• Drift: Set this to zero at the start of your animation, and a higher value at the end. This controls 
how far the cloud moves. 

• Threshold Controls: These controls behave identically to the threshold controls in Noise Factory 
(see "Noise Factory"). The threshold is a middle value, that when enabled, any numbers falling 
below it will be set to 0, any above it to 1. 

• Shape: Controls the basic shape of the cloud. Choices are Square, Ellipsoid, HemiSphere, and 
Cylinder. 

• Falloff Rate: Higher values will cause the cloud to become increasingly less dense towards its 
boundary. Using the falloff controls can help reduce banding. 

Tips 

If the banding is bad, do the following: 

1. Get your cloud looking about how you want it to. (Ignore the banding). 

2. Set all the animation parameters. 

3. Change the number of sections to a higher value. If you are using a lot of falloff, you can keep 
this at 2 or 3. If you are trying to make very large clouds, you may need as many as ten. 

4. Exit the modeler, duplicate your object, edit it. 

5. Choose "create new master." 

6. Increase the section number. 

7. Repeat steps 4 - 6 as necessary. 

Fire Primitive 
The Fire primitive creates a 3D or volumetric fire. You use this primitive to set a scene or object on fire. 
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There is no on-screen preview of the fire except its bounding box, which indicates the fire's size and 
location. You cannot see the fire until it is rendered. 

Tip! You can do a spot check of the fire using the Test Render tool. Select the tool and drag over any 
area of the fire. 

You can place objects inside the fire or partially within it. Fire attributes can also be animated. 

Changing the size of the fire by dragging a larger or smaller bounding box does not change the size of the 
flames. It only changes the area that the fire covers. 

To create a fire object: 

1. Depending on the desired location of the fire, do one of the following:  

• To create a fire object of default size at the center of the universe, choose Insert >Fire. 

• To create a fire object at any other location, drag the Fire tool to the desired position in 
the scene window. 
 

 
2. Click the Model button. The Fire Primitive controls appear. 

 

 
3. Set the Fire Primitive controls to achieve the desired effect.  

• Tip Color sets the color of the tips of the flames. 

• Base Color sets the color of the base of the flames. 

• Container determines the general shape of the fire. Choose a container from the list. 

• Completion controls the animation of your fire. Set it to 0% at the start of your animation, 
and at 100% at the end. 

• Quantity controls the quantity of flames that appear in your fire object. 

• Quality controls the quality of the fire as it is rendered. The higher the quality, the longer 
the render time. 

• Detail controls the degree of detail in the fire primitive. 

• Density controls the density of the fire. A low setting creates fire that is almost 
transparent. A high setting creates fire that is almost opaque. 

• Edge Falloff controls the appearance of the edges of the fire. A low setting results in a 
sudden change, or shorter falloff. A high setting results in gradual change, or longer falloff. 
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• Pointiness controls the percentage of your fire primitive that is points or tips of flames. A 
low setting results in few, less-tapered points, while a high setting results in many, more-
tapered points. 

• Upward Speed controls the speed at which the flames appear to shoot up during an 
animation. 

• Shuffle randomizes the order in which flames are generated. For example, if you 
duplicate a fire object, the two objects will be identical, which looks artificial. To make 
them look different while leaving all other settings identical, you can shuffle one fire object 
for a more natural look. 
 

NOTE! The random order is expressed as the Seed value in the Fire Properties. 

4. When you are finished, close the Fire controls and go back to the Assemble or Storyboard room. 

Creating Fountains 
The Fountain primitive is a particle system you can use to create objects like geysers or tornadoes. The 
fountain's attributes let you change the density of its particles and rate of animation. 

 
To create a fountain object: 

1. Depending on the desired location of the fountain, do one of the following:  

• To create a fountain of default size at the center of the universe, choose Insert 
>Fountain. 

• To create a fountain at any other location, drag the Fountain tool to the desired position in 
the scene window. 
 

 
2. Click the Model button. The Fountain Primitive controls appear. 
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3. Set the Fountain Primitive controls to achieve the desired effect.  

• Completion controls the fountain's animation. Set it to 0% at the beginning of the 
animation and 100% at the end. 

• Number of Particles controls the number of particles in your fountain. 

• Maximum Dispersion controls the angle of the spray from the fountain. When it is set to 
0° the spray goes straight up; at 180° it radiates outward from the fountain in all directions. 

• Maximum Swirl controls how much the particles rotate parallel to the ground plane as 
they fall. A low setting causes very little rotation while a high setting causes particles to 
rotate a great distance as they fall. 

• Initial Velocity controls the force of the fountain. A low setting creates a slow-spouting 
fountain while a high setting creates a fast-spouting fountain. 

• Gravity controls the amount of gravity applied to the fountain. When the setting is low, 
the particles shoot upward and float. When the setting is high, the particles fall down 
quickly. 

• Particle Size controls the size of the particles in your fountain. 

• Use Particle Life for UV Mapping determines how the shader is mapped to the fountain 
primitive. When enabled, the shader is mapped over the entire fountain, with the particles 
near the bottom of the fountain looking different from those nearer the top (depending on 
the shader content). When disabled, all the particles are mapped individually, so they all 
appear identical. 

4. When you are finished, go back to the Assemble or Storyboard room. 

Creating Fog 
The Fog primitive creates a 3D, or volumetric fog. 

 
There is no on-screen preview of the fog except its bounding box, which indicates the fog's size and 
location. You cannot see the fog until it is rendered. 

TIP! You can do a spot check of the fog using the Test Render tool. Select the tool and drag over 
any area of the fog. 

You can place objects inside the fog or partially within the fog. You'll probably want your fog object to be 
fairly large so you can place a portion of your scene inside it. Fog attributes can also be animated. 
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Scaling the fog object by dragging a larger or smaller bounding box does not scale the swirls of fog 
themselves. It only changes the area that the fog covers. 

NOTE! The Fog primitive is best for creating distinct local areas of fog, while the Cloudy Fog and 
Distance Fog controls in the Properties tray: Effects tab: Atmosphere panel are best for applying fog 
to the whole scene. 

To create a fog object: 

1. Depending on the desired location of the fog, do one of the following:  

• To create a fog object of default size at the center of the universe, choose Insert >Fog. 

• To create a fog object at any other location, drag the Fog tool to the desired position in 
the scene window. 
 

 
2. Click the Model button. The Fog Primitive controls appear. 

 

 
3. Use the Fog Primitive controls to create fog. 

4. Set the Fog Primitive controls to achieve the desired effect.  

1. Color sets the color of the fog. 

2. Container determines the general shape of the fog. Choose a container from the list. 

3. Completion controls the animation of the fog. Set this value to 0% at the start of your 
animation and 100% at the end. 

4. Quantity controls how many patches of fog are contained in the bounding box. 

5. Quality controls the quality of the fog as it is rendered. The higher the quality, the longer 
the render time. 

6. Swirls controls how the fog swirls or rotates as it rises. 

7. Swirl Size controls the size of the swirls. 

8. Density controls the amount of light that penetrates the fog. 

9. Edge Falloff controls the appearance of the edges of the fog. A low setting results in a 
sudden change, or shorter falloff. A high setting results in gradual change, or longer falloff. 
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10. Patchiness controls the regularity of the fog throughout the bounding box. A low setting 
creates a blanket of fog. A high setting creates patches of fog. 

11. Upward Speed controls the rate at which the fog rises during an animation. Use a higher 
setting for longer animations. 

12. Chaos controls the uniformity of the fog. A low setting creates more uniform fog, while a 
high setting creates fog with random patches and swirls. 

13. Shuffle randomizes the order in which fog swirls are generated. For example, if you 
duplicate a fog object, the two objects are identical, which looks artificial. To make them 
look different while leaving all other settings identical, you can shuffle one fog object for a 
more natural look. 
 

NOTE! The random order is expressed as the Seed value in the fog properties. 

5. When you are finished, close the Fog controls and go back to the Assemble or Storyboard room. 

Creating Oceans (Pro only) 
To create an ocean: 

Depending on the desired location of the terrain, do one of the following: 

• To create an ocean of default size at the center of the universe, drag the Ocean tool into the 
Hierarchy, or choose Insert > Ocean. 

• To create an ocean at any other location, drag the Ocean tool to the desired position in the scene 
window. 
 

 

Ocean Properties 
The General tab in the Assemble Room displays the following properties for oceans: 
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• Sampling Grid: Determines the amount of detail that you see in the ocean. Smaller values 
display less detail than larger values. 

• Size: Sets the length and width of the ocean (which is a square). 

• Wave Amplitude: Sets the height of the waves in the ocean. 

• Wind Angle: Determines the direction from which the wind blows. Drag the indicator along the 
indicator to change direction, or enter a numerical value between -180 and 180 in the numerical 
field. 

• Waves Follow the Wind: Check this option to make the waves respond to the direction of the 
wind. 

• Override Time: When checked, you can set the time of the ocean. This allows you to animate the 
ocean at a different speed from the scene. Otherwise, the scene time is used. 

• System Period: Defines the time it takes for the ocean’s animation to loop. 

Import/Export 
This chapter describes how you can import/export 3D objects and scenes from/to various file formats. It 
will show you how you can use Carrara to create content for the web and other applications. 

Importing 3D Objects 
You may directly import 3D objects from other applications into Carrara using the File > Import or the 
File > Open commands. With Import, the object will be imported into the current scene. With Open, the 
file opens in a new document. 

Note Most importers create compact Carrara objects that cannot be edited right away. To edit, select it, 
go to the modeling room, use the Edit menu: Convert to Other Modeler command, choose Vertex modeler. 

3DS Import (Standard, Pro) 
To import a 3DS File: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose 3DS for the file format. The 3D Studio Import dialog comes up. 
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3. Set the following options as desired:  

• AutoPosition: When checked, the imported object is centered on zero in X and Y, 
and its bottom is set to Z= 0. When unchecked, the values from the file are used.  

• Disable Auto-scaling: When checked, use the One 3DS Unit Equals field to set the unit 
conversion factor between the imported file and Carrara. When unchecked, the imported 
object is scaled to fit in the default working box. 

• Smoothing Angle: Calculates the normals for the imported objects using this value. A 
low value will keep most edges sharp, whereas a higher value will create smoother 
objects. 

• Hide BackFaces: Speeds up the interactive renderer (works on closed objects like 
spheres). 

• Show BackFaces: Displays all the facets of the imported objects in the interactive 
renderer (needed for surfaces, or objects with incoherent normals). 

4. Press OK. 

3DMF Import (Standard, Pro) 
To import 3DMF data: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose 3DMF for the file format. The 3DMF Import dialog comes up. 
 

 
3. Set the following options as desired:  

• AutoPosition: When checked, the imported object is centered on zero in X and Y, and 
its bottom is set to Z= 0. When unchecked, the values from the file are used. 

• Disable Auto-scaling: When checked, use the One 3DMF Unit Equals field to set the 
unit conversion factor between the imported file and Carrara. When unchecked, the 
imported object is scaled to fit in the default working box. 

4. Click OK. 

Biovision BVH Import (Standard, Pro) 
To import BVH data: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 
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2. Choose BVH for the file format. The Biovision Import dialog comes up. 
 

 
3. Set the following options as desired: 

• Disable Auto-scaling: When checked, you can choose to use the original object size 
described in the file, or set the height of the imported object. When unchecked, the 
imported object is scaled to fit in the default working box. 

• Import animation data at: When "Create New Skeletons" (described below) is selected, 
you have the option of importing the animation data to the skeleton in the file. You can 
also set the time you want the animation to begin, in seconds. 

• Display default skeleton at keyframe 0: When checked, the geometry of the imported 
object is loaded beginning at keyframe 0. The motion data of the file is loaded starting at 
keyframe 1. 

• Create New Skeletons: When checked, the file is imported as a new skeleton. 

• Apply to Selected Skeletons: When checked, animation data (optionally, from a 
different file) is imported to the selected skeleton beginning at the specified time, in 
seconds. 

• Match by Names: TBD 

• Disable Joint Constraints: TBD 

4. Click OK. 

To apply animation to the skeleton: 

1. Select the skeleton. 

2. Use the File > Import command to import animation from a file. 

3. Choose the BVH file with the animation you want to use. 

4. Check the Apply to Selected Skeletons option. 

5. Click OK. 
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Collada Import (Std, Pro) 
To import a COLLADA file: 

1. Use the File > Open command to create a new document or use the File > Import command to 
add the objects to the current scene. 

2. Choose COLLADA (.dae) for the file format.  

3. Locate and select the file to import. 

4. Click OK. 

DAZ Studio (DAZ format) 
Carrara allows you to import DAZ Studio (.daz) files into your scene.  

To import DAZ Studio files: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose DAZ Studio (*.daz) for the file format. The DAZ Studio Import dialog comes up. 
 

 
3. In the Constraints section, check Use Joint Limits if you want all poses in your figures to obey 

the limits set for each joint. Uncheck this option if you are not sure if the existing poses exceed 
the limits. 

4. Click OK. The objects appear in your scene. 

DXF Import (Standard, Pro) 
To import DXF data: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

 © 2008 DAZ 3D, Inc. 115 



Carrara 7 11 December 2008 

2. Choose DXF for the file format. The DXF Import dialog will come up. 
 

 
3. Set the following options as desired: 

• AutoPosition: When checked, the imported object is centered on zero in X and Y, and 
its bottom is set to Z= 0. When unchecked, the values from the file are used. 

• Disable Auto-scaling: When checked, use the One DXF Unit Equals field to set the unit 
conversion factor between the imported file and Carrara. When unchecked, the imported 
object is scaled to fit in the default working box. 

• Smoothing Angle: Calculates the normals for the imported objects using this value. A 
low value will keep most edges sharp, whereas a higher value will create smoother 
objects. 

• Hide BackFaces: Speeds up the interactive renderer (works on closed objects like 
spheres). 

• Show BackFaces: Displays all the facets of the imported objects in the interactive 
renderer (needed for surfaces, or objects with incoherent normals). 

• Import and extrude 2D objects: When checked, 2D objects from the DXF file are 
imported and given a thickness specified by the Extrusion value. When unchecked, 2D 
objects are ignored. 

• 3DFACE Separation: You can choose to import all the DXF 3DFACE(s) in a single 
Carrara object, or into multiple Carrara objects that are separated by layers and colors. 

• Import only 3DFACE entities: When checked, any DXF object that is not a 3DFACE is 
ignored. 
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• Coordinate System to Use: You can choose to use World or Current UCS coordinate 
system. 

4. Click OK. 

DirectX Import (Pro only) 
To import DirectX files: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose DirectX (*.x)for the file format. The DirectX Import dialog comes up. 
 

 
3. Set the following options as desired: 

• Disable Auto-scaling: When checked use the One DirectX Unit Equals field to set the 
unit conversion factor between the imported file and Carrara 6. When unchecked, the 
imported object is scaled to fit in the default working box. 

4. Click OK. 

Filmbox FBX Import (Pro only) 
To import FBX files: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 
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2. Choose FBX for the file format. The FBX Import dialog comes up. 
 

 
3. Set the following options as desired: 

• AutoPosition: When checked, the imported object is centered on zero in X and Y, and 
its bottom is set to Z= 0. When unchecked, the values from the file are used. 

• Disable Auto-scaling: When checked you can set the unit conversion factor between 
the imported file and Carrara 6. When unchecked, the imported object is scaled to fit in 
the default working box. 

4. Click OK. 

What is Imported 

• Skeletons are imported with their motion data. 

• A vertex primitive is created for each model in the FBX file (patches and Nurbs are converted to 
polygons). It is automatically attached to its skeleton (if any)using the weights from the file. 

Takes 

• Sometimes, an FBX file contains several animations or takes. In this case, a dialog enables you 
to select the take you want to import. After you make your selections, choose OK to import the file. 

Limitations 

Some FBX files may contain skeletons made of several pieces, or models influenced by something else 
than a bone. With such structures, the skinning information is not imported. 

• Additive skinning mode is not supported. 

• Morph targets and shading are not imported. 

• UV coordinates are not imported. 
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Characters with Control Rigs 

In Motion Builder, animating a character is generally done by editing a control rig instead of directly 
manipulating the bones. As this is not supported by the FBX importer, you need to "Plot" your characters 
in Motion Builder before you save the FBX file. Please refer to the documentation of Motion Builder for 
more information on plotting characters. 

Lightwave (LWO Import) (Standard, Pro) 
To import LWO files: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose FBX for the file format. The Lightwave Import dialog comes up. 
 

 
3. Set the following options as desired:  

• AutoPosition: when checked, the imported object is centered on zero in X and Y, and its 
bottom is set to Z=0. When unchecked, the values from the file are used. 

• Disable Auto-scaling: when checked, you can set the unit conversion factor between 
the imported file and Carrara 6. When unchecked, the imported object is scaled to fit in 
the default working box. 

• Convert to Carrara axis system: when checked, transforms the coordinates of the 
imported object so that its bottom is horizontal in Carrara. When unchecked, the 
coordinates are imported without modification. 

• Reverse polygon normals: Some object files are stored in such a way that their normals 
are backwards, facing the inside of a convex object. Checking this box will cause Carrara 
to reverse the normals of the imported object. 

• Flatten layers: Checking this box causes the importer to disregard layer information in 
Lightwave files, creating objects all in one group, rather than creating a group for each 
Lightwave layer. 
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• Show/Hide Backfaces: Toggles whether the backfaces of the object will be displayed by 
default in the 3D view. 

• Enable Smoothing: When checked, allows the user to select the maximum angle 
between faces to be smoothed. An angle of 0 results in sharp transitions between all 
polygon edges. Note that subdivision surfaces are always imported with smoothing, 
regardless of setting. 

4. Click OK. 

Wavefront OBJ Import 
To import OBJ files: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose OBJ for the file format. The OBJ Import dialog comes up. 
 

 
3. Set the following options as desired:  

• AutoPosition: when checked, the imported object is centered on zero in X and Y, and its 
bottom is set to Z= 0. When unchecked, the values from the file are used. 
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• Disable Auto-scaling: when checked, you can set the unit conversion factor between 
the imported file and Carrara. When unchecked, the imported object is scaled to fit in the 
default working box. 

• Map OBJ Y to Carrara Z axis: when checked, transforms the coordinates of the 
imported object so that its bottom is horizontal in Carrara. When unchecked, the 
coordinates are imported without modification. 

• Assume UV Coordinates Are Between 0 and 1: In most cases, you shouldn't need to 
change this option. When checked, the object's texture coordinates are imported without 
modification. When unchecked, the texture coordinates are transformed so they fit 
between 0 and 1. 

• Create Carrara Objects As: You can choose to import your objects as: 

• Facet Meshes: use less memory but cannot be edited without conversion. The import 
options used in this case are: 

• Hide BackFaces: speeds up the interactive renderer (works on closed objects like 
spheres). 

• Show BackFaces: displays all the facets of the imported objects in the interactive 
renderer (needed for surfaces, or objects with incoherent normals). 

• Smoothing Angle: If needed, calculates the normals for the imported objects using this 
value. A low value will keep most edges sharp, whereas a higher value will create 
smoother objects. 

• Vertex Primitives: can be edited in the Vertex modeler. You can choose to : 

• Create a Polymesh per Material: creates a polymesh and a shader for every material in 
the OBJ file. This is needed to properly import OBJ files with their shading information. 

• Create a Single Polymesh: this will create only one polymesh and is what should be 
used if you are doing morph targets for Poser. 

• Create Only One Object: When selected, a single Carrara object will be used to store 
the imported geometry. 

• Create one Object per Group: When selected, a Carrara object will be created for each 
group in the imported file. As groups can have several names, you can choose to use the 
first or the last ones to name the new Carrara objects. 

4. Click OK. 

Poser® Native Import 
You can now directly import Poser content without the need for the TransPoser plug-in: Poser cameras 
(CM2/CMZ), characters (CR2/CRZ), Poser prop hair (HR2/HRZ), Poser lights (LT2/LTZ), Poser props 
(PP2/PPZ) and Poser scenes (PZ3/PZZ) and also all other content linked poses or clothes. 

When using the Poser Native Importer, you can, in Carrara, edit the imported objects (adjust morph 
targets, move the objects, move the joints, import a pose or a cloth, edit a shader, etc.). For instance, if 
you import a Poser character into Carrara, it will create the model of the character and also attach a 
skeleton to it and import all morph targets. You can edit all this directly in Carrara. The Poser Native 
Importer does not support dynamic clothes and dynamic hair. 

Note You will find it much easier to use the Content Browser to add DAZ and Poser content into your 
scenes. See "Using Content and Runtime Folders." 

Carrara allows you to import Poser content in the formats that you commonly find in your Poser libraries. 
Refer to the following sections for specific information: 
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Importing Poser Cameras (CM2/CMZ) 

Poser camera files are imported with Poser scenes, but you can also import them individually. 

To import a Poser camera file: 

1. Choose File > Import. The Open dialog appears. 

2. Poser camera files are typically located in Runtime > Libraries > Camera subfolders and have 
a .CM2 or .CMZ extension. Locate the folder that contains the camera file that you want to open. 
Highlight the file and click Open. The Poser Camera Import dialog appears.  
 

 
3. Carrara prompts you to select the path to the Runtime folder that your camera appears in. Click 

the file selector button to locate the path to the runtime folder. 

4. When you return to the Poser Camera Import dialog, click OK. The camera appears in your scene. 

5. To switch to the new camera view, select the desired camera from the menu in the upper-left 
corner of the document window. 
 

 

Importing a Poser Character (CR2/CRZ) 

You can also open Poser content such as Poser Characters. The available options are similar to those 
used when importing a scene (see "Importing a Poser Scene (PZ3/PZZ)." However, a Poser character 
does not contain any animation. 

Poser character files are poseable figures, most often seen as human figures, animals, and poseable 
clothing. When you import a character, you are given the option to import morphs and deformers that are 
associated with the figure. The figures will import in their default pose, and in the default position. 
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To open or import a Poser character file: 

1. Choose File > Open or File > Import. The Open dialog appears. 

2. Poser character files are typically located in Runtime > Libraries > Character subfolders and 
have a .CR2 or .CRZ extension. Locate the folder that contains the character file that you want to 
open. Highlight the file and click Open. The Poser Character Import dialog appears.  
 

 
3. Check or uncheck the following options as desired:  

• Import Morph Targets: Check this option if you want to include morph targets with your 
Poser content when you open or import the file.  

• Create IK Targets: Check this option if you want to import the inverse kinematic settings 
for the character’s hands and feet. 

• Genitalia: Check this option if your figure uses separate geometry for genitalia and you 
want to import the figure with the alternate genitalia geometry. 

• Convert Skinning: Converts the Poser skinning to the standard Carrara skinning using a 
single weight map. 

• Import Deformers: Check this option if you want to import deformers (magnets or wave 
deformers) that are attached to your figure. 

4. Click the Browse for Folder button to select your Poser Runtime Path. If you are running Poser 7 
on a Windows operating system, the default path to the Poser executable file is C:\Program 
Files\e frontier\Poser 7. After you select the file click OK to return to the Poser Character Import 
dialog. 

5. Click OK to start the import process. A progress bar appears while Carrara imports the file into a 
new scene. 
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6. Then you can select the character in your scene to access the character properties. Those 

properties are available in the Properties tray: General tab. 
 

 

Importing Options in the Properties Tray 

Once you have imported a character, you can also use the Properties tray: General tab: Import panel 
to import poses, props, hair, clothing, and figures. 
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With the main character selected, open the Properties tray: General tab: Import panel. There you will 
see four buttons: 

 
Poser import options in the Properties tray. 

• Preset (Pose, Material): Use this button to import pose files that can be applied to the current 
figure. 

• Pose as Clip: Use this button to import an animated pose as an NLA animation clip. 

• Prop (Prop, Hair): Use this button to import props or prop hair. 

• Figure (Clothing, Hair): Use this button to import conforming clothing or hair. 

Conforming Clothing 

Conforming clothing automatically follows a poseable figure, but you have to conform the clothing to the 
figure in order for this to happen. In some cases, the clothing conforms automatically. However, if you find 
that you need to manually conform it, you can find an option in the General tab to accomplish this. 

After you load your clothing (which should be designed for the character you are conforming it to), open 
the Properties tray: General tab: Misc panel. A Conform To button appears there. Click the button and 
choose the desired character from the list. 

 

TIP! You can remove conformed clothing using the Unconform button. 

Importing Poser Hair (HR2/HRZ) 

Poser hair objects are prop files that are typically located in a Runtime > Libraries > Hair folder.  

1. Choose File > Open or File > Import. The Open dialog appears. 
2. Poser hair files are typically located in Runtime > Libraries > Hair subfolders and have a .HR2 

or .HRZ extension. Locate the folder that contains the hair file that you want to open. Highlight the 
file and click Open. 

3. You may be prompted to locate the geometry file that is associated with the HR2 file. If so, a 
dialog will display the name of the OBJ file that it needs. The geometry files are typically located 
in a subfolder beneath the Runtime > Geometries folder, in a folder named by the content 
creator. Highlight the OBJ file and click Open. The hair appears in your scene. 

4. In the Assemble tab, position the hair if necessary. Then go to the Instance list and locate the hair 
that you imported. Drag the hair upward until you locate the figure’s Head body part, and drop the 
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hair onto the head. The hair will then attach to the head so that it moves along with the figure 
when you pose it. 

Importing Poser Lights (LT2/LTZ) 

Poser light files are imported with Poser scenes, but you can also import them individually. 

To import a Poser light file: 

1. Choose File > Import. The Open dialog appears. 

2. Poser camera files are typically located in Runtime > Libraries > Camera subfolders and have 
a .LT2 or .LTZ extension. Locate the folder that contains the light file that you want to open. 
Highlight the file and click Open. The Poser Light Import dialog appears.  
 

 
3. Carrara prompts you to select the path to the Runtime folder that your light appears in. Click the 

file selector button to locate the path to the runtime folder. 

4. When you return to the Poser Light Import dialog, click OK. The light appears in your scene. 

NOTE! Poser lights may need some adjustment in intensity, color, and falloff after importing, and 
the amount of adjustment can also vary due to changes between Poser versions. Start by reducing the 
light intensity to 25-30% of the original intensity and then increase or decrease as necessary to get the 
desired affect. 

Importing Poser Props (PP2/PPZ) 

To import a Poser character file, follow these steps: 

1. Choose File > Open or File > Import. The Open dialog appears. 

2. Poser prop files are typically located in Runtime > Libraries > Prop subfolders and have a .PP2 
or .PPZ extension. Locate the folder that contains the prop file that you want to open. Highlight 
the file and click Open. The Poser Prop Import dialog appears.  
 

 
3. Check or uncheck the following options as desired:  

• Create IK Targets: Check this option if you want to import the inverse kinematic settings 
for the character’s hands and feet. 
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• Convert Skinning: Converts the Poser skinning to the standard Carrara skinning using a 
single weight map. 

• Import Deformers: Check this option if you want to import deformers (magnets or wave 
deformers) that are attached to your figure. 

4. Click the Browse for Folder button to select your Poser Runtime Path. If you are running Poser 7 
on a Windows operating system, the default path to the Poser executable file is C:\Program 
Files\e frontier\Poser 7. After you select the file click OK to return to the Poser Character Import 
dialog. 

5. You may be prompted to locate the geometry file that is associated with the prop file. If so, a 
dialog will display the name of the OBJ file that it needs. The geometry files are typically located 
in a subfolder beneath the Runtime > Geometries folder, in a folder named by the content 
creator. Highlight the OBJ file and click Open. The prop appears in your scene. 

Importing a Poser Scene (PZ3/PZZ) 

Poser scene files can contain one or several characters, props, clothing, poses, and other content that is 
already posed. After you import a Poser scene into Carrara, you can add animation and other 
enhancements to the scene that you import. In addition, you can add and conform clothing, apply pose 
files, and make other scene changes by adding additional content in the Content Browser. 

To import a Poser scene: 

1. Choose File > Open or File > Import. The Open dialog appears. 

2. Locate the folder into which you saved your Poser scene file. The file will have a PZ3 or PZZ 
extension. 

3. Highlight the file and click Open. The Poser Scene Import dialog appears. 
 

 
4. Check or uncheck the following options as desired:  

• Import Morph Targets: Check this option if you want to include morph targets with your 
Poser content when you open or import the file.  

• Create IK Targets: Check this option if you want to import the inverse kinematic settings 
for the character’s hands and feet. 

• Import Animation: Check this option if the Poser scene file contains an animation and 
you want to import all of the animation frames. If you uncheck this option, Carrara will 
only import the first frame. 
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• Genitalia: Check this option if your figure uses separate geometry for genitalia and you 
want to import the figure with the alternate genitalia geometry. 

• Convert Skinning: Converts the Poser skinning to the standard Carrara skinning using a 
single weight map. 

• Import Deformers: Check this option if you want to import deformers (magnets or wave 
deformers) that are attached to your figure. 

5. Click the Browse for Folder button to select your Poser Runtime Path. If you are running Poser 7 
on a Windows operating system, the default path to the Poser executable file is C:\Program 
Files\e frontier\Poser 7. After you select the file click OK to return to the Poser Character Import 
dialog. 

6. Click Open to start the import process. A progress bar appears while Carrara imports the file into 
a new scene.  

7. You may be prompted to locate files that Carrara cannot find. You are given the option to stop 
looking for these files which will cause Carrara to import only the files that it was able to locate. 

Realviz XML Import (Pro only) 
You can import Realviz XML data (RZML file format). This format is used to transfer camera motion data 
calculated from a movie in a match moving software. Note that only the motion of the camera, 3D trackers 
and basic geometry are imported. 

To import a Realviz File: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose Realviz for the file format. The Realviz XML Import dialog comes up. 
 

 
3. Set the following options as desired:  

• Import Locators: when checked, the 3D trackers are imported as target helper objects. 

• Locators size: determines the display size of the created helper objects. 

• Locators color: determines the display color of the created helper objects. 

4. Click OK. 
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SynthEyes™ Import (Pro only) 
You can import SynthEyes data (.syncar file format). This format is used to transfer camera motion data 
calculated by the SynthEyes match moving software. 

Note that only the motion of the camera and 3D trackers are imported. 

To download the latest Carrara 6 export script for SynthEyes, please go to: http://ssontech.com/  

TrueSpace Import (Pro only) 
To import trueSpace data (COB file format): 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose COB for the file format. The TrueSpace Import dialog comes up. 
 

 
3. Set the following options as desired:  

• AutoPosition: when checked, the imported object is centered on zero in X and Y, and its 
bottom is set to Z = 0. When unchecked, the values from the file are used. 

• Disable Auto-scaling: when checked, you can set the unit conversion factor between 
the imported file and Carrara 6. When unchecked, the imported object is scaled to fit in 
the default working box. 

• Enable Smoothing: calculates the normals for the imported objects using the smoothing 
angle. A low value will keep most edges sharp, whereas a higher value will create 
smoother objects. 

4. Click OK. 

CAD Formats (Pro only) 
Carrara 6 also allows you to import the following CAD formats. The import options are similar for all of 
these formats: 

• IGES (.igs, .iges) 

• OpenNurbs (.3dm) 

• SAT (.sat) 

• STEP (.stp, .step) 
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• VDAFS (.vda, .vdafs) 

To import CAD format files: 

1. Use the File > Open command to create a new document, or use the File > Import command to 
add the objects to the current scene. 

2. Choose any of the CAD file types for the file format. The corresponding import dialog comes up. 
 

 
3. Set the following options as desired:  

• AutoPosition: when checked, the imported object is centered on zero in X and Y, and its 
bottom is set to Z= 0. When unchecked, the values from the file are used. 

• Disable Auto-scaling: when checked, you can set the unit conversion factor between 
the imported file and Carrara. When unchecked, the imported object is scaled to fit in the 
default working box. 

• Map X, Y or Z Axis to: TBD 

• Nurbs Tesselation: TBD 
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• Adaptive (crack free): TBD 

• Max angle: TBD 

• Max chord height: TBD 

• 3D edge length: TBD 

• Min UV subdivision: TBD 

• Max aspect ratio: TBD 

4. Click OK. 

Other Formats 
The following formats can also be imported by Carrara: 

• Infini-D 3.0-4.5 (.id4, .ids, .id0) 

• RayDream 3 (.rd3, .d3d) 

• Ray Dream 4 (.rd4) 

• Ray Dream 5 (.rds, .rdd) 

Exporting 3D Objects 
You can export 3D objects to a variety of different file formats using the File > Export or the File > Save 
As commands. When you use export, only the current selection is exported. When you choose Save As, 
the whole scene is exported. 

Exporting 3D objects allows you to interact with other 3D applications. It also allows you to create 3D 
content for the Web. 

The following sections provide additional information on specific export file types. 

NOTE! Wavefront OBJ format is the only export format available for Carrara 3D Express. 

3DS Export (Standard, Pro) 
To export to 3DS: 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose the 3DS file format, type a file name, and click on Save. The 3D Studio Export dialog 
comes up. 
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3. Check on the options controls to change the export settings.  

• Scaling: Rescales all the exported objects based on the value entered in the One 
Carrara Unit Equals field. 

• Surface Fidelity: For objects with multiple levels of detail (like Splines), sets the 
precision of the export. A 100% value will export highly detailed meshes, while a lower 
value will export fewer facets. 

• Textures Format: Selects the image format to use when saving texture maps. 

• Convert Procedural Shaders to Textures: When checked, a texture map is calculated 
for each procedural shader used in the Carrara scene. This option can slow down the 
export quite a bit, especially if you select a high resolution. 

4. Press OK. 

3DMF Export (Standard, Pro) 
To export to 3DMF: 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose the 3DMF format, type a file name, and click on Save. The 3DMF Export dialog comes 
up. 
 

 
3. Check on the options controls to change the export settings. 
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• Surface Fidelity: for objects with multiple levels of detail (like Splines), sets the precision 
of the export. A 100% value will export highly detailed meshes, while a lower value will 
export fewer facets. 

• Export UV Colormap: when checked, a texture map is calculated for each procedural 
shader used in the Carrara scene. Enter the desired width and height resolution in the 
fields provided. This option can slow down the export quite a bit, especially if you select a 
high resolution. 

4. Press OK. 

Adobe® After Effects® Export (Pro only) 
The After Effects® exporter saves the animation of cameras, lights (distant, bulb and spot), and planes 
into a ".cae" file. The generated file can then be imported into After Effects by using the Carrara plug-in 
for After Effects (5.5 and above on Windows, 6.5 and above on Mac OS X). 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose the After Effects (*.cae) format, type a file name, and click on Save. The AE Export 
dialog comes up. 
 

 
3. Check on the options controls to export cameras, lights, and planes, and to filter keyframes (if 

desired). 

4. Press OK. 

COLLADA Export 
To export to COLLADA: 

1. Use the File > Save As command to export the whole scene or use the File > Export command 
to export the current selection. 

2. Choose the COLLADA (.dae) file format, type a file name, and click on Save. The DXF Export 
dialog comes up. 
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3. To export morphs as part of the COLLADA file, click in the radio button next to Active Morphs. 

To not export morphs, click in the radio button next to No Morphs. 

4. Press OK. 

DXF Export (Standard, Pro) 
To export to DXF: 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose the DXF file format, type a file name, and click on Save. The DXF Export dialog comes 
up. 
 

 
3. Set the Surface Fidelity: for objects with multiple levels of detail (like Splines), sets the precision 

of the export. A 100% value will export highly detailed meshes, while a lower value will export 
fewer facets. 

4. Press OK. 

DirectX Export (Pro only) 
To export to DirectX: 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 
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2. Choose DirectX format, type a file name, and click on Save. The DirectX Export dialog comes up. 
 

 
3. Check on the options controls to change the export settings.  

• Format Options: Choose Text or Binary format. 

• Compress File: When checked, exports the DirectX object in compressed format. 

• Colors Only: Exports basic colors only. Does not export texture maps. 

• Texture Maps: Choose this option to convert texture maps during the export. Enter the 
desired size in the Resolution fields, and select a file format using the Textures Format 
popup menu. 

• Convert Procedural Shaders to Textures: When checked, a texture map is calculated 
for each procedural shader used in the Carrara scene. This option can slow down the 
export, especially for high resolutions 

• Separate Mesh Per Shading Domain: TBD 

• Unique Vertex Per Normal: TBD 

• Map Carrara Z Axis to DirectX Y: TBD 

• Export Animation: TBD 

• Export Skinning Data: TBD 

4. Press OK. 
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Kaydara FBX Export (Pro only) 
You can export geometry, bones and skinning in the FBX format. 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose Kaydara FBX file format, type a file name, and click on Save. The FBX Export dialog 
comes up. 
 

 
3. In the options dialog, you can choose between FBX 5 or FBX 6, as well as binary or text mode. 

4. Press OK. 

Shockwave 3D Export (Standard, Pro) 
To export Shockwave 3D format: 

1. Shockwave 3D allows you to create 3D content for Macromedia Director. 

2. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

3. Choose Shockwave file format, type a file name, and click on Save. The Shockwave Export 
dialog comes up. 
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4. Check on the options controls to change the export settings.  

• Geometry Quality: Controls the accuracy of the geometry export. 

• Texture Quality: Adjust the slider to increase or decrease the quality of the exported 
texture. 

• Save Texture: When checked, exports textures with the file. Choose the desired size for 
the texture in the X and Y popup menus. 

• Export Procedural Textures: When checked, a texture map is calculated for each 
procedural shader used in the Carrara scene. This option can slow down the export, 
especially for high resolutions. 

5. Press OK. 

VRML Export (Standard, Pro) 
To export to VRML: 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose the VRML file format, type a file name, and click on Save. The VRML 2.0 Export dialog 
comes up. 
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3. Check on the options controls to change the export settings.  

• Version: Exports to VRML 1.0 or 2.0. 

• Surface Fidelity: For objects with multiple levels of detail (like Splines), sets the 
precision of the export. A 100% value will export highly detailed meshes, while a lower 
value will export fewer facets. 

• Texture Maps: 

• Mode: You can choose to save the texture map inside the VRML file (Internal 
mode) or outside it (External mode). 

• Format: The available formats for the texture map files are JPEG and GIF. 

• Convert Procedural Shaders to Textures: When checked, a texture map is 
calculated for each procedural shader used in the Carrara scene. This option can 
slow down the export, especially for high resolutions. 

• URL Prefix: this string will be added before each texture map file name 
appearing in the exported VRML file. 

• Size Threshold: TBD 

• Distance Threshold: TBD 

• Levels of Detail: TBD 

• Tessellate: you can choose to export basic primitives (Cubes, Spheres, Cones, etc.) as 
faceted objects by checking the control with the name of the primitive. Otherwise, default 
VRML primitives are used. 

• Remove white space: when checked, the exported VRML file is not indented (and is 
smaller). When checked, the VRML file is indented for easier human reading in a text 
editor. 

4. Press OK. 

Wavefront OBJ Export 

NOTE! This is the only export format available for Carrara 3D Express. 

To export to Wavefront (OBJ): 

1. Use the File > Save As command to export the whole scene, or use the File > Export command 
to export the current selection. 

2. Choose the OBJ file format, type a file name, and click on Save. The OBJ Export dialog comes 
up. 
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3. Check on the options controls to change the export settings.  

• Target: Select the target program for the export. Based on the target selected, different 
export options may be unavailable (grayed out). 
 

 
• Export Objects In Local Coordinates: when unchecked (default), the Carrara objects 

are exported with the positions and scaling they have in the scene. When checked, the 
geometry of Carrara's instances is exported without taking into account their scaling and 
position (useful for creating Poser morph targets). 

• Map Carrara Z axis to OBJ Y: when checked, transforms the coordinates of Carrara 
objects so that their bottom (XY plane) is horizontal in the OBJ file. When unchecked, the 
coordinates are exported without modification. 
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• Export objects with Morphs and Skinning: TBD 

• Export objects full path: TBD 

• Surface Fidelity: for objects with multiple levels of detail (like Splines), sets the precision 
of the export. A 100% value will export highly detailed meshes, while a lower value will 
export fewer facets (and generate smaller OBJ files). 

• Materials export:  

• None: when selected, no materials will be exported. 

• Colors only: when selected, only the color of the objects will be exported. 

• Texture Maps: when selected, texture maps and object colors will be exported. 

• Convert Procedural Shaders to Textures: when checked, a texture map is 
calculated for each procedural shader used in the Carrara scene. This option can 
slow down the export quite a bit, especially if you select a high resolution. 

• Textures Format: selects the format to use when saving texture maps. 
 

 
• Write File Names As: sets how file references are written in the OBJ and MTL files (as 

file name only, full path, or relative path). 

4. Press OK. 

Viewpoint Experience Technology Export (Standard, 
Pro) 
You can use Carrara 6 to create 3D content for your web site using VET (Viewpoint Experience 
Technology). It’s as simple as exporting your scene. Carrara converts the geometry, lighting and 
materials of your objects to VET file format. It can also embed code in an HTML page using special tags.  
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You can also add interactivity to your scene using VET-dedicated tools in Carrara. 

The following topics give more detail about Viewpoint Experience Technology export. 

Exporting a Scene 
To export a VET scene:  

1. Choose File Menu> Save As and select VET as the type of the file to export.  

2. If you selected the options checkbox in the file dialog, an option dialog will open and you can 
select the options you want. Carrara will create three files:  

• filename.html which is the actual web page in which the scene will be embedded 

• filename.mtx which contains the XML code of your file. 

• filename.mts which contains the description of the 3D objects and materials.  

3. Simply double-click on the HTML file and the scene will open in your web browser.  

For information on the many export options, see "Export Options." 
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Previewing a Scene 
You can also preview your scene from inside Carrara, useful as you are building your scene to make sure 
things are looking like you want. The options in the VET Preview dialog are similar to those described 
below under Export Options. 

To preview a scene: 

1. Choose Edit Menu> VET preview.  

2. Choose the export options you need in the dialog that opens. The preview will open and you can 
rotate around your scene with the mouse. 

VET Export Options 
The option dialog allows you to control how your scene will be converted to the VET format. Here is a 
description of each option and how to use them: 

General Settings 

• Geometry quality controls how the geometry is compressed. (100% for the best quality) 

• Texture quality controls how the texture maps and light maps are compressed. (100% for the 
best quality) 

• Compress Mtx: The MTX file is usually small but if it becomes too big, you can use this option to 
compress it. 
 

 

Rendering Settings 

• Rendering mode selects the rendering modes that will be used by the VET player. Options are 
Wire, Point, Flat, Texture, and Sketch. 

• Antialiasing: If checked the object edges will be antialiased. 
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Camera Settings 

The camera can be in two different modes:  

• Orbit: The camera turns around the scene, the center of rotation is the origin of the scene. Use 
this mode if you want the user to be able to rotate the scene. 

• Actual: The camera is at the exact same position as the camera in Carrara. In this mode the 
animation of the camera is also exported. Use this mode if you want to make a small movie-like 
animation.  
 

 

Texture Settings 

• Save texture means that the texture maps are exported with your scene  

• Export Procedural Textures: By default only shaders containing simple texture maps are 
exported. If you select this option, the procedural shaders such as marble or cellular are sampled 
and exported as texture maps. This conversion process can be slow so we advise that you only 
use it when doing the final export. 

• Size controls the size of the texture maps used for procedural textures. A bigger size means 
better quality but also more memory and a slower export. 
 

 

Animation Settings 

• Export Animators will cause the animation defined with VET Animators to be exported (see 
"VET Animators").  

• Global Animation will cause the animation of the scene to be exported (VET Animators will be 
ignored).  

• Loop continually repeats the animation once it is finished. 

• None means that no animation will be exported. 
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Shadow Settings 

• Draw Shadows decides whether drop shadows are drawn. 

• Blur Size controls the size of the blur of the shadows. A blur of 0 gives hard shadows, a bigger 
blur means softer shadows. 
 

 

LightMaps Settings 

• Light Maps are used to simulate the lighting and reflections on your objects. There are three 
different modes for Light Maps. 

• Note that in all these modes you can always override the light map for a given shader by placing 
a 256x256 texture map in the reflection channel of this shader. (see "Light Maps" for more 
information on light maps).  

• Default: A default light map is used for all the objects. You should use this mode when you just 
want to check the position and animation of your objects. This mode is fastest because it does 
not need to render any light maps. 

• Global: A single light map is used for all the objects. You can select the properties of the lighting 
you want using the highlight, shininess and reflection sliders (reflection will reflect the current 
background of the scene) 

• Per Object: In this mode, a light map is calculated for each shader that differs significantly from 
the others (only the highlight, shininess and reflection intensities are taken into 
account).Calculating light maps can be fairly slow so we recommend that you only use this mode 
once your objects are well positioned and animated. 
 

 

HTML Settings 

• Html Template file: This allows you to use a different HTML template. The HTML template is the 
file in which your scene will be embedded. 

• Copy Template Folder: When this option is selected, Carrara looks for a folder with the same 
name as the HTML template file and copies it next to the HTML file that is exported. Usually this 
folder contains all the images necessary for your HTML page to display properly.  

• Image Size controls the size in pixels of the images that will be displayed in the HTML file. 

• VMP Genie minimum version is the minimum number of the version of the Viewpoint Media 
Player that needs to be used to display this scene. Normally, there is no reason to change this. 
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• Broadcast key file URL: The URL of the broadcast key needed to publish Viewpoint content on 
your web site. (You need to contact Viewpoint to get a broadcast key). 
 

 

Getting Results with VET 

Light Maps 

In the VET technology, lighting is simulated using a texture called light maps. Carrara automatically 
generates light maps that match the lighting of your scene. You can also override the light maps used for 
a given object.  

To get good results, it is necessary to understand how light maps are built. Light maps can also allow you 
to simulate reflections (environment mapping).  

How to create good light maps: 

• We recommend that you only use distant lights in your scenes because lights maps only simulate 
distant lights. However, Carrara will also convert your other lights into light maps but the results 
may not be what you expect. 

• Objects that have the same shader or similar shading properties will use the same light maps. 
The properties that influence the light maps are the following: shininess, highlight and reflection. 
To save memory, avoid using too many different shaders.  

• Light maps will include a reflection of the background for objects where the reflection is not set to 
0. 

• You will need to set a background on your scene so as to have reflections on your objects. 

Setting your own light maps: 

• A light map is basically a 256 by 256 texture map. If you apply a texture map to the reflection 
channel of a shader, this texture will be used as a light map. You can create new light maps 
easily with Carrara. You just need to render a sphere in 256x256 so that the edges of the sphere 
touch the edges of the image. Adding lights, a background, backdrops and changing the shader 
of the sphere will all affect the properties of the light map.  

• It is very important that the texture is 256 by 256 pixels or it will not work. 

Maps (Texture, Bump, Transparency) 

The texture maps, bump maps and transparency maps that you may assign to shaders in Carrara will be 
exported. There is nevertheless a few constrains to respect in order to make them correctly.  

If you want to export a transparency map, the shader must also contain a texture map of the same 
dimensions. If the dimensions of the transparency map are different from the texture map ones, the 

 © 2008 DAZ 3D, Inc. 145 



Carrara 7 11 December 2008 

transparency map will be ignored and the transparency of the material set to the first value encountered 
on the map.  

A bump map can be exported with or without the existence of a texture map, but if there is one, its 
dimensions should be identical to the bump map's.  

A texture map can be a traditional picture but it can also be a flash movie file (SWF files). However, flash 
movies cannot be displayed inside Carrara. The shader will appear to be white in Carrara but the flash 
movie will be visible in the preview or after exporting the VET file.  

Backdrop 

The backdrop of a Carrara scene will also be exported. As for the texture maps, it is possible to assign a 
flash movie to the backdrop. The flash movie won't be visible inside Carrara but it will be in the preview or 
in the exported VET file. 

Animation 

There are some limitations to the kind of animations that can be exported. Only key-frame based 
animations are properly exported. Only the animations using object transform, the color of a light map or 
the deformation applied to an object with the Morpher Deformer can be exported. You can move, rotate, 
scale objects in your scene. Any other kind of animation will not be exported correctly. 

Add Interactivity to Your Scene 

Carrara 6 gives you the possibility to add interactivity to your scene for the VET export. You can define 
interactions such as triggering an animation when clicking on an object or displaying two dimensional text 
when the cursor slides over an invisible hot spot. Two objects in Carrara can help you to define such 
interactions: the VET Animator object and the VET Interactor. 

VET Animators 
An animation can be defined as a collection of smaller animations, each of them independent from the 
others, in order to be played separately and to be triggered at different moments. The VET Animator is an 
object that defines a piece of an animation. 

To create a new VET Animator: 

1. Choose Edit Menu>VET Animator. A dialog displays the VET animator options. 
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2. Set options as follows:  

• Name: Type the name of your animator (This is the name that appears in the object 
hierarchy). It is important that all the objects in the scene have a unique name in order to 
properly export your scene as a VET scene.  

• Animator Runs by Default: Check this option to run the animation by default (at the 
opening of the scene in a web browser). Uncheck the option to trigger the animation with 
a VET Interactor. 

• Animation Loops: Check this option to repeat the animation continuously. Uncheck the 
option to stop the animation once it is finished.  

• Add: Click this button to add one or several animations (timelines) to the list.  

• Del: Click to remove the last animation in the list.  

To edit each animation: 

1. Name your animation in order to find it more easily later. 

2. Choose the object or group of objects the animation will be applied to using the Target popup 
menu. 

3. Choose the field of the target you want to animate. (All Fields means both the transform and the 
color of the object.) 

4. Enter the start and end time in the object time line that will be used for the animation. 

To modify an Animator: 

1. Select the animator in the object hierarchy. 

2. Click on the Edit button of the Properties tray. 

NOTE! Do not forget to check the Export Animations option in the Export dialog. 

VET Interactors 
An Interactor defines a list of events (mouse left click, mouse over, ...) attached to an object of the scene 
and the actions triggered by those events.  

There are three types of actions: 

• Actions applied to an Animator to start, stop, rewind, ... the animations it contains. 

• Actions that modify a parameter of an object, like its scaling. 

• Actions that trigger VET specific actions, such as loading a MTX file or displaying 2-dimensional 
text. 

Interactors are implemented as state machines. A state machine is a collection of states and transitions 
between those states. At a given time only one state is active (current state). The state machine 
determines a transition map of how to get from one state to another based on input (events). The scene 
transitions from state to state by means of actions. 
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New Interactor 

To create a new Interactor: 

1. Choose Edit > VET Interactor. The following dialog will come up. 
 

 
2. Type the name of the Interactor (this is the name that appears in the object hierarchy). It is 

important that all the objects in the scene have a unique name in order to properly export your 
scene to VET. 

3. Next, choose the Target of the interactor. This target can be either a visible or an invisible 
geometry in the scene. An invisible geometry is called a Hot Spot. 

4. Add one or several events. 

New Event 

To add an event: 

1. Click on the Add button. (Del removes the last event of the list). 
 

 
2. Set the following options as needed:  

• Name: Assign a name to the event. 

• Type: Choose an mouse event option from the popup menu. This mouse movement will 
trigger the event. 

• Start State and End State: Choose None to assign no state. Choose Add to assign a 
name for the state The Start State of an event acts as a condition on the activation of the 
event. An event is considered only if the Current State matches the Start State of an 
event when this event occurred. Otherwise the event is ignored.  

• Edit Actions: Click this button to add, delete, or clear the associated actions.  
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3. After the execution of the action, the Current State of the scene is set to the End State of the 
Event (if there is no End State, the Current State stays untouched). Once an event is defined, the 
actions associated with it can be described.  

To define the actions associated with an event: 

1. Click on the Edit Actions button. 

2. Click on the Add button to add an action. 

3. Name the action. 

4. Choose the target of the action. 

5. Choose the property of the target that will be affected by the action from the Field popup.  

6. Adjust the desired value for that property.  

Special Actions 

These actions do not modify the state of a current object but will add something to your scene. There are 
four special actions: 

• Load MTX File allows you to load an existing VET scene. You must select the path of the MTX 
file you want to load. 

• 2D Text is very useful to add extra information to a scene. When the user points to the target of 
the interactor, the user will typically see descriptive text. 

• 2D Picture: Same as 2D text but displays an image instead of text. 

• 2D Flash: Same as 2D text but displays a Flash movie instead of text. 

Hot Spots 

A Hot Spot is the name given to the target of an interactor. This target can be a classical geometry but it 
can also be an invisible or still geometry.  

To make a geometry invisible, unchecked the Visible check box in the Properties of an object. The 
object will still exist in the VET scene and interactors will be able to use it as a target, but its geometry 
won't be visible. 

To make a still geometry, you have to define this geometry as a child of the camera. For this, click and 
drag the object to the Camera in the hierarchy. The object will then be motionless to the user. Be sure to 
choose the Actual camera when exporting your scene to keep the same relative position of the object and 
the camera.  

To modify an Interactor: 

1. Select it in the object hierarchy. 

2. Click on the Edit button of the Properties tray. 

Current Limitations 
There are several important limitations as to what can be exported. It is important to keep these 
limitations in mind when you are designing a scene for VET or you will not get the results you might 
expect. 

• Camera animation: The camera is not animated in the preview but the animation of the camera 
works in the exported file (you need to select Actual as the export mode for the camera).  
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• Animation defined by VET Animators are not visible in the preview but they are exported 
correctly.  

• Animation: Only key-frame based animation are currently supported. Animations using motion 
paths, inverse kinematics or physics will not export properly. Also note that animated hot points 
are not supported. Morph animations are not supported on the Mac platform.  

• Tweeners: Only linear and Bézier tweeners are supported, all other tweeners will be exported as 
linear tweeners. Bézier tweeners are exported with their default values. Modifying the Bézier 
curve in order to modify the exported animation will not have any effect.  

• Texture Map Size: To get optimal results, it is advised to use only the power of 2 (1, 2, 4, 8, 16, 
32, 64, 128, 256, 512 ...) for the size of the texture maps. 

• Object Naming: It is important that objects are properly named with unique names. 

Modeling Objects 
Using Primitive Tools 
Carrara provides a number of different types of primitive objects that you can add to your scene. These 
primitives are found in the Insert menu, and also have tool icons that appear directly beneath the menu 
commands. 

In this section you’ll learn how to work with the basic geometric and particle primitives. Refer to "Using 
Environmental Primitives" to learn more about the primitives that simulate natural objects such as terrains, 
clouds, and plants. 

Using Geometric Primitives 
If you are creating an object from scratch, the first thing is to break down the object to its basic 
components. What those basic components turn out to be will determine how to build it. 

If those components turn out to be all simple geometric shapes, you can create an object using the 
geometric primitives in the Assemble or Storyboard room. 

For example, when the skyscraper shown in the following figure is reduced to its basic components, you 
can see that it's made up of cylinders, cones and cubes. Therefore you could use the geometric primitives 
in the Assemble room to create the object. 

Below is a complex object on the left and the primitives used to make it on the right. 
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In the Assemble room, you can create five 3D geometric primitives (spheres, cubes, cones, cylinders, and 
icosahedra) three 2D geometric primitives (planes, infinite planes, and Splat). 

When you insert a geometric primitive object, it simply appears in the scene window, where you can move 
and resize it as necessary. 

The Geometric Primitive tools are located on a single pop-up menu. You can also use commands in the 
Insert menu to insert a primitive object. 

 
To insert a basic geometric primitive: 

1. In the Assemble or Storyboard room, choose Insert menu, then choose the >type of object.  

2. Or, choose a Geometric Primitive tool from the pop-up menu and do one of the following: 

• To create an object of default size, click in the scene window. 

• To create an object of a custom size, drag in the scene window. 

3D Primitive Tools 
Often, the easiest way to create an object is by combining a number of simple geometric primitives. 
Carrara provides a number of 3D primitive tools that you can use to build your objects and which you'll 
learn more about in this section. 

Sphere Primitives 
To insert a sphere primitive: 

In the Assemble or Storyboard room, do one of the following: 

• To create a sphere of default size, choose Insert > Sphere, or click the Sphere tool and then 
click in the document window at the desired location. 

• To create a sphere of a custom size, do one of the following:  

o Click the Sphere tool. Click in the document window to set the location and then drag 
outward to size the sphere. 
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o Select any Sphere primitive in your scene and enter a new size in the Properties tray: 
General tab: Sphere panel. 
 

 

Cube Primitives 
To insert a cube primitive: 

In the Assemble or Storyboard room, do one of the following: 

• To create a cube of default size, choose Insert > Cube, or click the Cube tool and then click in 
the document window at the desired location. 

• To create a cube of a custom size, do one of the following:  

o Click the Cube tool. Click in the document window to set the location and then drag 
outward to size the cube. 

o Select any Cube primitive in your scene and enter a new size in the Properties tray: 
General tab: Cube panel. 
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Cone Primitives 
To insert a cone primitive: 

In the Assemble or Storyboard room, do one of the following: 

• To create a cone of default size, choose Insert > Cone, or click the Cone tool and then click in 
the document window at the desired location. 

• To create a cone of a custom size, do one of the following:  

o Click the Cone tool. Click in the document window to set the location and then drag 
upward to size the cone. 

o Select any Cone primitive in your scene and enter a new size in the Properties tray: 
General tab: Cone panel. 
 

 

Cylinder Primitives 
To insert a cylinder primitive: 

In the Assemble or Storyboard room, do one of the following: 

• To create a cylinder of default size, choose Insert > Cylinder, or click the Cylinder tool and then 
click in the document window at the desired location. 

• To create a cylinder of a custom size, do one of the following:  

o Click the Cylinder tool. Click in the document window to set the location and then drag 
upward to size the cylinder. 

o Select any Cylinder primitive in your scene and enter a new size in the Properties tray: 
General tab: Cylinder panel. 
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Icosahedron Primitives 
To insert an icosahedron primitive: 

In the Assemble or Storyboard room, do one of the following: 

• To create an icosahedron of default size, choose Insert > Icosahedron, or click the 
Icosahedron tool and then click in the document window at the desired location. 

• To create an icosahedron of a custom size, do one of the following:  

o Click the Icosahedron tool. Click in the document window to set the location and then 
drag upward to size the icosahedron. 

o Select any Icosahedron in your scene and enter a new size in the Properties tray: 
General tab: Icosahedron panel. 
 

 

2D Primitive Tools 
2D Primitive tools allow you to create various planar shapes, or two-dimensional shapes that lie across 
one plane. Carrara provides three types of 2D primitives, which you will learn more about in this section. 
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Planes 
To insert a 2D plane primitive: 

In the Assemble or Storyboard room, do one of the following: 

• To create a plane of default size, choose Insert > Plane, or click the Plane tool and then click in 
the document window at the desired location. 

• To create a plane of a custom size, do one of the following:  

o Click the Plane tool. Click in the document window to set the location and then drag 
upward or outward to size the plane. 

o Select any Plane primitive in your scene and enter a new size in the Properties tray: 
General tab: Plane panel. 

Creating Infinite Planes 
An Infinite plane is a flat geometric primitive whose sides extend out to infinity in all directions. This type 
of primitive can be used to create a surface for your scene such as a sky, ocean, or ground. 

Carrara inserts Infinite planes parallel to the ground plane. You can move or rotate Infinite planes as you 
would any other object in the scene window. 

 
To insert an Infinite plane: 

1. Choose Insert > Infinite Plane, or click the Infinite Plane tool. 

2. Click in the document window. Although the plane appears finite in the scene window, it extends 
out to infinity when it is rendered. 

Shading Infinite Planes 
Applying shaders to an Infinite plane can be tricky, especially when you use texture maps or gradients. 
The plane's tiling controls can help you adjust how shaders are tiled on the plane. 

To learn more about shaders, refer to "Shading Objects." 

To adjust shader tiling: 

1. Double-click the Infinite plane. You move to the Model room and the Infinite plane modeler 
appears in it. 
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2. In the Properties tray: General tab: Infinite Plane panel, set the tiling options you want.  

• Tile UV Mapping: Repeats the shader, aligning it across the plane. If Tiling is disabled, 
the shader is stretched to cover the entire surface of the plane. 
 

 
• Mirror UV in X Axis: TBD 

• Mirror UV in Y Axis: TBD 

3. When you are finished, close the Infinite Plane controls and go back to the Assemble or 
Storyboard room. 

To adjust the size of the tiles: 

• Adjust the size of the plane by selecting the Infinite plane and using the Properties tray: Motion 
tab: Transform panel: Size and Scaling settings. For more information, refer to "Viewing and 
Setting Object Properties." 
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Splat Primitive 
A Splat primitive is a billboard plane that always faces the camera, and is most often used to display 
textures that have alpha channels. For example, you can use a Splat primitive, and apply a rendered tree 
for a texture, using an alpha channel to remove the solid background color. Repeat the Splat object 
several times and you can have a forest without the geometry overhead.  

 
To insert a Splat primitive: 

1. Do one of the following:  

• To create a Splat primitive of default size at the center of the universe, choose Insert 
>Splat. 

• To create a Splat primitive at any other location, drag the Splat tool to the desired 
position in the scene window. 

2. In the Properties tray: General tab: General panel, click the Edit button to open the Shader 
Editor, where you can assign a shader to the Splat primitive. Alternatively, click the Preset button 
to assign a preset shader to the primitive. 
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3. After you assign the shader, use the Test Render tool to view the Splat primitive in your scene. 
 

 

Creating Text Objects 
Text objects that you create in the Assemble or Storyboard room can be edited for their bevel, scale, and 
depth, and for standard text features such as font, pitch, alignment, and spacing. 

To create a Text object: 

1. Open the Text modeler using one of the following methods:  

2. To create a Text object of default size at the center of the universe, choose Insert >Text. 

3. To create a Text object at any other location, drag the Text tool to the desired position in the 
scene window. 
 

 
4. The Text modeler opens in the Model Room. In the blank section at the bottom of the window, 

type the text you want. 
 

 
5. Select a font from the list that appears at the left side of the Text modeler. You can use any 

TrueType and Type 1 fonts in your system for creating Text objects. As you scroll through the 
fonts, the text that you entered changes to reflect the new font. 
 

 
6. Use the Font controls (above the white text area) to adjust the font properties.  

• Font Style: Allows you to choose from the various styles associated with the text (such 
as Plain, Bold, Italic, or Bold Italic). 

• Font Size: Sets the size of the font, measured in points. 

• Scaling: Scales the length of the text without affecting the height (Font size) or Depth. 
For example, a setting of 200% doubles the width of the Text object. 
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• Alignment: Aligns text on the left, right, or center. 

• Leading: Sets the spacing between lines. 

• Word Spacing: Sets the spacing between words, measured in points. 

• Letter Spacing: Sets the spacing between letters, measured in points. 

7. Use the controls in the Bevel section to bevel the text if desired: 

• Front Face creates a bevel on the front face of the text. 

• Back Face creates a bevel on the back face of the text. 

• Depth and Height set the slope of the front and back bevels. 

• Type determines the shape of the front and back bevels. 
 

 
8. Use the Bevel controls to bevel your 3D text. 
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• Adjust the Depth setting to determine the extrusion depth of the text. 

• Adjust the Fidelity setting to improve the appearance of the bevel if necessary. 
 

 
9. When you are finished, go back to the Assemble or Storyboard room, where you can view the 

final results. If you need to make changes, double-click the text object to return to the Text 
modeler. 

Creating Particle Systems (Standard, Pro) 
Particle systems can be used to create complex particle effects such as sparks, erupting volcanoes, and 
explosions. 

The basic steps to creating a particle system are: 

1. Insert the particle system in your scene. 

2. Set basic particle system options. 

3. Set options to determine the behavior of particles in the system. 

4. Preview the particle system. 

5. Shade the particle system. 

To insert a particle system: 

• Depending on the desired location of the particle system, do one of the following:  

o To create a particle system of default size at the center of the universe, choose Insert 
>Particle Emitter. 

o To create a particle system at any other location, drag the Particle Emitter tool to the 
desired position in the scene window. 
 

 

Editing Particle Settings 
Particle settings are what really determine the look and behavior of your particle system. These settings 
include such parameters as the lifetime, number, speed, and color of particles, whether they are emitted 
in a straight tail or fan out, whether they bounce on impact, and whether they "spawn" other particles. 

After you create a particle system, you automatically enter the Particle modeler. The modeler consists of 
two tabs: Basic and Advanced. 

You can also enter the Particle modeler at any time when you double-click on a particle system, or select 
a particle system and click the Model Room icon.  
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Basic Particle Settings 
The Basic tab appears when you first create a particle emitter. 

 
For further information on the settings in this dialog, see the following sections. 

Particle Shape and Quantity 

The Particles section determines the shape and number of particles: 

 
• Shape: Determines the geometry of the particles. Options are Triangle 1, Triangle 2, Rectangle, 

Diamond, Sphere, Facing camera, Metaball and Objects.  
 

 © 2008 DAZ 3D, Inc. 161 



Carrara 7 11 December 2008 

NOTE! If you choose Metaball you can set the influence of metaballs that specify the 
deformation. If you choose Objects you can add particle objects as sons of the particle emitter in 
the hierarchy. 

• Maximum number of particles: Adjust the slider to determine the number of particles that the 
emitter generates. As you adjust the value, you can view the amount of memory that the particle 
emitter uses. 

• Bound to emitter: Choose this option to create particles that move with the emitter. For example, 
with the exhaust from a rocket, the exhaust would stay behind the engine rather than flying off 
into space. 

• Free in the scene: Choose this option to create particles that move independently from the 
emitter. For example, water spraying from a hose whipping back and forth flies out and falls 
where it is emitted. 

Particle Placement 

The Emitter section determines where the particles are created: 

 
• Emission cube: Creates particles in a cube around the base of the emitter object. You can offset 

the particles from the emitter object by entering values in the +/- X, Y, and Z fields. 

• Emitter object: Creates particles from the surface of another object. Click the file selector button 
to choose an object in your scene. 

• Use local orientation: Check this option to align the particles with the surfaces of the emitter 
object. Uncheck this option to align the particles in the same orientation. 

• If your emitter object has multiple shading domains, you can align particles with one part of the 
object’s surface. Choose the desired shading domain from the popup menu. 

Particle Life 

The A particle’s life section determines how many seconds the particles exist after they are emitted.  

 
• Lifetime: Enter a +/- factor to make some particles live longer or shorter than others. 
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• Freeze now: Freezes a particle system at a particular point. For instance, you can freeze the 
system immediately to create a galaxy or frozen waterfall, let it remain frozen for a moment 
(changing the camera) and then unfreeze it. 

• Unlink rotation from trajectory: By default, particles are oriented with their trajectory so that 
they always face their next position. Check this option for more realistic effects. 

• Die on impact: Useful for creating a stream of particles that is limited to a certain area, since the 
particles will not bounce and spread after impact. Since particles are recycled, this option is 
useful for creating a fast-moving flow without increasing the maximum number of particles 

• Size of particle over its life: A curve that enables your particles to get bigger over time to, for 
example, make air bubbles in a glass of soda 

Particle Shading 

Options in the Shader section are discussed in more detail in "Previewing the Particle System." 

Particle Emission 

The Emission section includes the following settings: 

 
• Emitter ON now: Active particles are created using the parameters. When unchecked, no more 

particles are created, but the ones that are alive keep moving. 

• Emit time range: A more global parameter than Emitter ON. This setting helps accelerate 
calculations by specifying the global period when you want to use the emitter. If you don't want to 
display the beginning of the creation of particles and you only want it when it is fully working, you 
can generate particles before start time during a certain amount of time. 

• Generate particles before start time: TBD 

• Shuffle: TBD 

• Particles creation determines the different parameters of the particles at their birth. Most 
parameters can be altered on each particle using a +/- factor. These are initials parameters and 
some can change with time. 

Advanced Particle Settings 
The Advanced Particle Physics settings fall into two categories: Physics and Spawning. 
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Particle Physics 

 

• Air Friction: Determines the action of air on the speed of particles. Positive numbers slow the 
system down, and negative numbers speed the particles. 

• Objects friction on collisions: Determines the percentage of friction the particles encounter on 
collision. This setting does not affect the Bounce Factor. 

• Bounce Factor: Determines how high the particles bounce as they hit other objects. The higher 
the number, the higher the particles bounce. 

• Local gravity: Specifies the magnitude and direction of the pull of gravity on the particles.  
• Uses force of the scene (only in Free mode): Lets you use the forces you already use for other 

objects in your scene. You can choose external forces you don't want to apply to this particle 
system, or choose only the external forces you want to apply. When using forces, local gravity is 
disabled. 

• Ground Level: Sets an imaginary plane in your scene that is considered ground level. The 
default is 0. Particles always collide at ground level. The ground level behaves differently 
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depending on whether you have Bound or Free particle systems set in the Particles section of the 
Basic tab:  

o For Bound systems, the ground level is measured along the local Z-axis of the emitter, 
and moves and rotates with the emitter. 

o For Free systems, the ground level is measured as a height along the Z-axis of the 
universe. If the emitter is placed or animated below ground the level, no particles are 
emitted. 

• Collide with scene objects (only in Free mode): Lets you use the other objects of the scene for 
collisions.  

o All objects except: Choose objects with which you don't want to collide, and the 
particles will collide with all the other 

o Only: Choose only the objects with which you want the particles to collide. When using 
objects colliding, ground is disabled. 

• Particles push each other (slow): Makes the particles that are too close to push each other and 
particles that are less close but not too far to attract each other. This option will likely slow down 
calculations. 

• Replicated objects (only with Object shape): The list of the objects set as particle if shape is 
set to Objects. The emitter will produce particle of each type of object randomly. To add a new 
object use the Add button. To remove an object, delete it in the assemble room. 

Particle Spawning 

The Spawning settings determine whether and how impacted particles generate further particles. 

 

• You can choose to spawn new particles as follows:  
o Never: New particles are not spawned from existing ones. 
o At Collisions: Causes particles to spawn when they collide with the ground level or with 

collision objects. 
o At Age: Causes particles to spawn when they reach a certain percentage of their lifetime. 

Enter a lower value in the percentage field to make them spawn sooner, or a higher value 
to make them spawn later. 

• Allow spawning of spawn: Causes newly-spawned particles themselves to spawn. This option 
is available only when At Collisions is set. Enabling this option can quickly lead to a very large 
number of particles, so you may need to set the Maximum value in the Systems tab very high; 
this will cause performance to lag. 

• Maximum number of Spawn: Sets the maximum for the number of new particles created when 
each particle spawns. The actual number will be a random value between 1 and this maximum. 
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• Spawn Velocity: Sets the minimum velocity that a particle must be traveling in order to spawn. 
This is useful in creating a waterfall in which the particles spawn to create splashes when they hit 
an object. 

• Spawn Radius: The dispersion area for spawned particles, much like the Emit area. 
• Spawn Force: Sets the speed at which the spawns travel, as a percentage of the original 

particle's speed. Set this value low to make the spawns be left behind by the original particle. Set 
this value higher to make the spawns shoot ahead of the original particle. 

• Angle: Determines the arc in which the spawns are emitted. This setting works in the same 
manner as the Emit Dispersion setting for the entire system (on the Emitter tab), except that it 
applies only to spawned particles. The +/- field determines how much variation there is in the emit 
angle. 

• Spawn Size: Determines the size of the newly created particles in relation to the original one. 

Previewing the Particle System 
You can see the effects of your edits to the particle settings in the Preview pane of the Particles modeler. 
The preview options you set do not affect how your particle system is rendered. 

 
To preview the particle system: 

1. In the Particles dialog, enter a Duration value to set how long the preview lasts in the Preview 
window. 

2. Use the View selector to choose whether you want to view the particles from the Front, Right, or 
Top. 

3. Click the Run button beneath the Preview window. 

4. Use the Pan and Zoom buttons to pan and zoom your view. 

Shading the Particle System 
You can use any kind of shader to shade a particle system. The Shader section in the Basic tab of the 
Particle modeler contains settings that help you define how the particles are shaded. 
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NOTE! To shade a particle system, you need to see some particles. Therefore, you need to 
advance to a frame other than 0. If you don't want to animate your shader, return to non-animated mode 
and clear the keyframes. 

Using the Particle Shader 
The particle shader is a way of shading all the particles at once but with differences depending on the 
particles properties. The value of the shader depends on a property of the particle that is shaded. The 
available settings are: 

• Use particle time for shading: When a particle is created, the shader that it uses is the current 
shader at time 0. Check this setting to cause particles to be shaded at a different time than the 
current shader. 

• Birth time is (MM:SS:FF) in shader: Enter the desired amount of time after which you want the 
shader to take effect. Time is entered in minutes, seconds, and frames. For example, if you want 
a 2 second delay, enter 00:02:00. After 2 seconds of its life, the particles will be shaded with 
current shader. 

• Use particle local space for shading: 

• Use object shader: Check this option to use the shader that is applied to the particle emitter. 

Working with Particles in 3D View 
Working with a particle system can be very time consuming, especially when there are lots of particles to 
calculate. In order to work faster you can use the 3D view particles settings that don't modify the final 
rendering but lighten the system in 3D view.  

To view these settings, select the particle emitter in the Assemble room. You’ll find the following settings 
in the Properties tray: General tab: Particle Emitter panel.  

 
• Particles displayed in 3D View: Reduces the particles displayed, and reduces the particles 

calculated. Note that this also reduces the number of particles that appear in final rendering. 

• Display: Displays the particles in the mode of your choice: None, Points, Crosses, Light Mesh, 
and Mesh. 
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• No calculation in 3D View: When you are done with your particle system and you want to work 
on another part of your scene, you can stop the calculation of particles in 3D view. When no 
calculation in 3D View is checked the system appears as it was calculated for the last time. 

• Calculate 3D View: Click this button to recalculate from the start time. 

Using the Blur Object Effect on Particles 
The Blur Object effect lets you add a blur to particle emitters. Use the Blur Object effect to create smoke 
for a rocket, or a dusty trail behind a stagecoach. 

To use Blur Object: 

1. Drag a Particle System into the scene. 

2. In the Properties tray: Effects tab: Blur panel, click the Edit button. The Blur Object dialog 
appears. 
 

 
3. Check the Enable Blur option to enable the blur object feature. 

4. Drag the Radius slider to the right to strengthen the intensity of the blur. 

5. Choose a Dropoff function (Squared, Linear, Gaussian, None) to determine the how the blur 
fades out from the center of the particle. 

6. Choose a Quality option (Low, Medium, or High) to control the appearance of the blur effect. 

7. Use the Preview renderer to preview the changes you make. You can enable the Auto Update 
option to update the preview as you make changes. 

8. Click OK to accept the settings and close the dialog. 

Vertex Modeling Overview 
The Vertex modeler lets you sculpt 3D objects by directly manipulating their surfaces but also create 
morph targets for performing advanced animation, fine tune bones weights or set UV coordinates for 
texture mapping. 
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Vertex modeling is the process of creating 3D objects by directly manipulating vertices, edges, and 
polygons. You can "sculpt" objects by changing the number and location of their vertices, edges, and 
polygons. 

You often start with a predefined object, such as a sphere or cube, or you can use the Vertex modeling 
tools to generate complex shapes. Once you've created an object, you can reshape and refine it by 
editing the points that define its surface, edit morph targets, UVs and weights. 

Enhancements in Carrara 6 allow you to edit imported content, and create new morph targets and full 
body morphs for DAZ or Poser content. You'll also notice improved performance with larger meshes when 
you move, scale, or rotate points. 

The Vertex modeler lets you sculpt 3D objects by directly manipulating their surfaces. Vertex modeling is 
the process of creating 3D objects by directly manipulating vertices, edges, and polygons. You can 
"sculpt" objects by changing the number and location of their vertices, edges, and polygons. 

You often start with a predefined object, such as a sphere or cube. Once you've created an object, you 
can reshape and refine it by editing the points that define its surface. 

Vertex Modeling Concepts 
A vertex object is any object created in the Vertex modeler, or created with another modeler and opened 
in the Vertex modeler. 

The power of vertex modeling lies in the ability to change an object by directly positioning its vertices and 
edges. 

Vertices, Edges, Polylines, and Polygons 
Three-dimensional objects can be described as sets of vertices, edges, and polygons: 

• A vertex defines a position in 3D space. 
• In the Vertex modeler, all vertices are connected by straight lines. An edge is the line that 

connects two vertices. For example, eight vertices and twelve edges describe a cube. Each face 
of the cube is a polygon. 
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A vertex object's surface is defined by its vertices. 

• A polyline is a set of connected edges.  

• A polyline that forms a closed loop is a closed polyline. A closed polyline is not equivalent to a 
polygon:but if you fill a closed polyline, it becomes a polygon. 

• A collection of vertices, edges, and the polygons that they form is called a polymesh. A 
polymesh can form a closed volume, such as a cube, or an open object such as an oval. 

Although it is possible to sculpt a complex shape in the Vertex modeler from scratch by adding and 
editing polygons and vertices, the Vertex modeler provides you with a very rich set of advanced modeling 
tools such as extrusion, sweep, loft, lathe, chamfer, Boolean operations, thickness, offset surface, Coons 
Surface (Pro version only), Gordon Surface (Pro version only) or Double Sweep (Pro version only). 

Although it is possible to sculpt a complex shape in the vertex modeler from scratch by adding and editing 
polygons and vertices, the vertex modeler provides you with a very rich set of advanced modeling tools 
such as extrusion, sweep, loft, lathe, chamfer, thickness, or offset surface. 

When an object is modeled using a small number of polygons, its silhouette is often very rough and it is 
difficult to create smooth surfaces. Subdivision surface helps to create smooth objects without adding too 
many polygons. You will see in real time your the mesh as you edit a few control points. 

The Vertex Modeling Window 
The Vertex modeler is where you create vertex objects. You enter the Vertex Modeling Window when you 
choose the Insert > Vertex Object command from the Assemble or Storyboard Room, or when you 
double-click a vertex object that is already in your scene. Like the Assemble window, the Vertex modeling 
window provides up to four different views of your object. 
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When you edit a vertex object, new menu commands are available, different tool sets appear, and the 
Properties tray describes your object. Your view switches to a close-up view of the object. The preview 
Scene window opens at the lower right of the Modeling window. This shows how your object will look in 
the Assemble room. 

Opening the Vertex Modeling Window 
You open the Vertex Modeling window by doing one of the following: 

• Double-click the vertex object in the Hierarchy or the scene window. The view will switch to the 
Model room. 

• Click on the Model button. The view will switch to the Model room. 
 

 
• Select a vertex object, then click on the Model button. 

• Select a vertex object while in the Assemble room and click on the Edit Vertex Object tool. The 
vertex modeling tools will activate (edit mode) without requiring you to enter the Model room. 
 

 
• For a new vertex object, in the Assemble room, click on the Vertex Object tool, then in the 

viewport. The view will switch to edit mode. 
 

 
When you're finished modeling, you can save your changes and enter a different room by clicking the 
appropriate room's button. 

NOTE! To avoid the memory-consuming accumulation of windows, always close the modeling 
window when you are finished modeling. 

The Vertex Modeler 3D View 
The Vertex modeler's 3D view shows a working box that contains the features for creating shapes and 
paths. Three colored lines indicate the intersections of the planes of the working box. 
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By default, the working box is centered on the origin of the coordinate system. The bottom of the working 
box sits on the ground plane of the universe, so the working box's vertical center is slightly elevated from 
the universe's ground plane. Each side of the box measures 1 foot, with a grid line at each inch. For 
information on changing these dimensions, refer to "Changing the Grid." 

You can move and rotate the working box and its planes independently of the object you are modeling. 
Any adjustments you make to the orientation and location of the working box take place in relation to the 
universe. Thus, if you move the entire working box 10 inches up along the Z axis, you are effectively 
moving it up by 10 inches in your scene. The object itself, however, remains in place both in the 3D view 
and in the scene. 

The Drawing Plane 
The Drawing plane is the plane you're currently working on, whether you are drawing a shape, adjusting a 
sweep path, or viewing your object. By default, the Drawing plane lies on the X and Y axes of the working 
box. It is highlighted as a brighter border 

NOTE! For information on changing and moving the Drawing plane, refer to "Changing Your Point 
of View." 
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Setting Preferences for the Vertex Modeler 
In the Vertex Modeler Preferences dialog, you can set preferences for the default welding tolerance, 
edge and rotation angles, the maximum number of selections you can save, and the size of vertices in the 
3D view. 

 
To set preferences for the Vertex Modeling window: 

1. Choose File > Preferences. 

2. Choose Vertex modeler from the popup menu. 

3. Set the following options as desired:  

• Welding Tolerance: Vertices within this tolerance will be welded together.  

• Edge Propagation Angle: Use this option to specify the angle determining whether a 
second edge will be selected when you double-click on the first one edge. 

• Rotation Constrain Angle: Sets the angle increment used during a constrained rotation 
(to constrain a rotation, hold down the Shift key while dragging). 

• Maximum Saved Selections: Sets the limit of the number of selections than can be 
saved using the menu Selection> Add To Saved Selections. When the number of 
saved selections bypasses this limit, the oldest one is lost 

• Handle Size: Sets the size of the vertices in the 3D view. 

• Pro Only 

• Skip Dialogs: Select which warning dialogs to skip when working with 
displacement. 

• Enable All Polymesh Displacement: Sets whether to enable displacement for 
all polymeshes or not. 

4. Click OK to apply the settings. 
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Working with the Modeling Window 
Like the Assemble room, the Vertex modeler can simultaneously display up to four separate panes. Each 
pane gives you a different view of your object. 

You can work in any view you want. For instance, you may find it convenient to work in a 2D view when 
drawing a sweep or extrusion path, then switch to the 3D view when you want to work in 3D. To work in a 
different view, simply click in the pane. 

NOTE! You cannot view objects through user-created cameras in the modeling room. 

To make your work flow easier, you can change different features of the Vertex modeler: 

• Change the display and behavior of the grid. For more information, refer to "Setting Preferences 
for the Vertex Modeler." 

• Change the active plane. 

• Change the Drawing plane. 

• Move the working box. 

• Show and hide the working box's bounding planes. 

Showing and Hiding Planes 

By default, the planes that define the boundaries of the working box are visible. You can show them using 
the Grid Controls. 

 
For information on using the Grid Controls, refer to "Changing the Grid." 

Changing the Active Plane 

The active plane is the reference plane that Carrara uses when creating points or objects in all tools. 

There are three different ways to change the active plane depending on your preferred modeling 
technique: 

• User defined plane: the active plane can be changed by clicking the plane icon in the Active 
Plane tool. 
 

 
• Automatic plane mode: the active plane is automatically defined depending on the view 

orientation. The plane which appears to be the most perpendicular to the view direction is 
selected automatically. 

• All planes mode: the active plane is the closest plane the cursor is in. 

 © 2008 DAZ 3D, Inc. 174 



Carrara 7 11 December 2008 

Changing the Drawing Plane 

To make your work easier, you can change the Drawing plane to different axes and move it to a selection 
or a specific set of coordinates. You can also drag it to any position you like. 

The easiest and quickest way to move the drawing plane and the working box to a specific position is to 
Command/Ctrl+click the vertex, edge or polygon where to move it. 

To move the Drawing plane to a selection: 

1. Select the vertex, polygon, or group of vertices with which you want to align the Drawing plane. 

2. Be sure the Selection tool is chosen. 

3. Command/Ctrl+click your mouse.  

• If the selection is a single vertex, Carrara centers the Drawing plane on that vertex 
without changing the plane's orientation. 

• If the selection is a group of vertices or a polygon, Carrara moves the Drawing plane to 
the plane shared by those vertices. If the vertices lie in different planes, the Drawing 
plane is moved so that all the selected points are as near the Drawing plane as possible. 

• To reset the working box position to its original position, Command/Ctrl+click an empty 
area of the 3D View or choose View> Reset Working Box. 

To send the Drawing plane to specific coordinates: 

1. Choose View > Send Drawing Plane to. The Send Plane to Position dialog appears 

2. Specify the universe's X, Y, and Z coordinates to which you want to move the Drawing plane. 

3. Enable a plane option:  

• Drawing plane Moves the Drawing plane on the axis perpendicular to itself by the 
amount you specify. For instance, you could move a Drawing plane lying on the X and Y 
axes by the specified amount on the Z axis only. 

• Drawing plane centered Moves the Drawing plane on the axis perpendicular to itself by 
the amount you specify, centering it on the remaining coordinates. For instance, you 
could move a Drawing plane lying on the X and Y axes by a specified amount on the Z 
axis, centering it on the X and Y axes. 

• All planes Moves the origin of the working box to the specified coordinates, centering all 
planes. Note that this option moves the working box itself. 

4. Click OK. 

Changing Your Point of View 
Without changing your point of view to examine an object from all sides, it can be difficult to determine its 
position relative to other objects in the model.  

When you perform a operation such as subtraction, this is particularly important:you must be sure that the 
objects are actually overlapping for it to work. 

You can dolly, zoom, bank, and track the Director's Camera using the camera controls, and you can pan 
and zoom the view in 2D using the pan and zoom controls. 
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Use the camera controls to dolly, pan, bank and track the view through the Director's Camera. For 
information on using these controls, refer to "Camera Navigation." 

 
Use the pan and zoom controls to perform 2D panning and zooming. For information on using these 
controls, refer to "2D View Tools." 

You can also use the camera list in the upper left corner of the Vertex modeling window to switch among 
the Director's Camera (3D view) and isometric views of the working box's sides. 

 
Use the camera list to switch between the Director's Camera and isometric views of the working box sides. 
For information on using these controls, refer to "Selecting a Camera." 

After you have changed your view, the working box may appear off-center in its pane. By sending your 
view to the working box, you can restore the view to the origin of the coordinate system. 

Previewing Objects 
You can preview objects in the Vertex Modeling window at different levels of quality. 

For more information on the Preview modes, refer to "Choosing a Preview Mode." 

In a scene, a vertex model can have several instances, with each instance having a different shader. 
When the preview quality is set to Textured in the Vertex modeler, you can choose the instance to be 
used for the shader. 

The list of instances of the object is displayed in the Properties tray: Global tab: Shaders For Object 
panel. 

 
This shader is also used when a Test Render is done in the Vertex modeler. 
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Vertex Modeling Basics 

Using the Vertex Primitives 
The Vertex Primitive tools let you create several basic 2D or 3D polymesh shapes. When inserted from 
the tool bar, the dimensions of the object are set during the insertion by dragging, other attributes are 
then set with the + or - keys and validated by clicking Enter or Return. 

NOTE! Vertex Primitive basic objects are inserted the same way primitives are inserted in the 
assemble room. For more information about how to insert an object, see "Using Primitive Tools." 

To insert a vertex object from the toolbar: 

1. Open or create a document in the Assemble room. (For more information, refer to "Creating an 
Empty Scene.") 

2. Depending on the desired location of the vertex object, do one of the following:  

• To insert a vertex object of default size at the center of the universe, choose Insert > 
Vertex Object or drag the Vertex Object tool into the Hierarchy section of the Sequencer. 

• To insert a vertex object in any other location, drag the Vertex Object tool into the scene 
window to any location. 
 

 
3. Choose a vertex primitive from the pop up. 

 

 
4. In the Modeling window, drag one corner of the bounding box to the opposite corner. Release the 

mouse button when the object is the desired size. 

5. Use + or - to set the mesh density of the primitive. 

6. Press Enter to validate the inserted primitive. 
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Inserting 3D Vertex Objects (Standard, Pro) 
When inserted from the Construct > Insert 3D menu, each primitive has its own properties dialog. The 
dialog lets you define the primitives attributes before it is inserted in the modeler. 

When inserted from the toolbar, each primitive still has its own properties dialog but you cannot define the 
primitive attributes before it is inserted in the modeler, just set the size by dragging in the viewport. 

The 3D Vertex Primitives are covered in the following sections. 

3D Spheres 

The 3D sphere vertex object can be used for spheres and ellipsoids. While creating a sphere you enter 
diameter, height, and the number of sides and sections. You can also orient the sphere to align with the X, 
Y, or Z axis.  

The following image shows a sphere with a diameter of 1 foot, height of 2 feet, 8 sides, and 8 sections. 
Object axis orients the object to the X plane. 

 
To insert a Sphere from the Construct menu: 

1. Choose Construct > Insert 3D > Sphere.  

2. The Insert Object dialog appears. Enter the following properties:  

• Diameter: The diameter of the sphere. 

• Height: The height of the sphere. 

• Number of Sides: The number of divisions along the diameter.  

• Number of Sections: This is half the number of divisions you want along the height of 
the sphere (or, the number of divisions in one hemisphere). 

• Object Axis: Click the X, Y, or Z arrow to choose the axis that you want the object to 
point to. The height of the object will be oriented along this axis. 
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3. Click OK. Your sphere appears in the scene. 

3D Cubes 

The 3D cube vertex object can be used for cubes and other box shapes. While creating a cube or box 
you enter the X, Y, and Z dimensions and the number of segments that appear along each axis.  

The image below shows a cube with X size of 1, Y size of 2, Z size of 3, and segmentation of 4. 

 
To insert a Cube from the Construct Menu: 

1. Choose Construct > Insert 3D > Cube.  

2. The Insert Cube dialog appears. Enter the following properties:  

• X size: Determines the depth of the cube. 

• Y size: Determines the width of the cube. 

• Z size: Determines the height of the cube. 
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• Segmentation: Determines the number of divisions along each axis of the cube. 
 

 
3. Click OK. Your cube appears in the scene. 

3D Cones 

The 3D cone vertex object can be used for cones, as well as 3 or 4-sided pyramids. While creating a 
cone you enter diameter, height, and the number of sides and sections. You can also orient the sphere to 
align with the X, Y, or Z axis. 

The image below shows a cone with a diameter of .2, a height of .4, 8 sides, and 10 sections. Object axis 
orients the object to the X plane. 

 
To insert a Cone from the Construct Menu: 

1. Choose Construct > Insert 3D > Cone.  

2. The Insert Object dialog appears. Enter the following properties:  

• Diameter: The diameter of the cone at its base. 

• Height: The height of the cube from base to top. 

• Number of Sides: The number of sides at the base of the cone. For pyramid shapes, set 
this value to 3 or 4. 

• Number of Sections: The number of sections from the base to the top of the cone. 

• Object Axis: Click the X, Y, or Z arrow to choose the axis that you want the object to 
point to. The height of the object will be oriented along this axis. 
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3. Click OK. Your cone appears in the scene. 

3D Cylinders 

The 3D cylinder vertex object can be used for cylindrical shapes. While creating a cylinder you enter 
diameter, height, and the number of sides and sections. You can also orient the sphere to align with the X, 
Y, or Z axis. 

The image below shows a cylinder with diameter of .1, height of .2, 8 sides, and 16 sections. Object axis 
orients the object to the X plane. 

 
To insert a Cylinder from the Construct Menu: 

1. Choose Construct > Insert 3D > Cylinder.  

2. The Insert Object dialog appears. Enter the following properties:  

• Diameter: The diameter of the cylinder at its base. 

• Height: The height of the cylinder. 

• Number of Sides: The number of divisions along the base of the cylinder. 

• Number of Sections: The number of divisions along the height of the cylinder. 

• Object Axis: Click the X, Y, or Z arrow to choose the axis that you want the object to 
point to. The height of the object will be oriented along this axis. 
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3. Click OK. Your cylinder appears in the scene. 

Polyhedrons 

Polyhedrons are 3D objects with a specified number of triangular sides. Based on the number of sides 
that you enter, Carrara uses that value to create a three-dimensional object. The minimum number of 
sides required to make a 3D object are four sides (which creates a 3-sided pyramid shape). The 
maximum acceptable number of sides is 999999. 

If it is not possible to create a polyhedron with exactly the number of sides that you enter, Carrara adjusts 
the value as necessary to create a complete three-dimensional object. For example, if you enter the 
number 5, Carrara increases the number of sides to 6 to create a cube. The image below shows a 
polyhedron with 36 sides. 

 
To insert a Polyhedron from the Construct Menu: 

1. Choose Construct > Insert 3D > Polyhedron.  

2. The Insert Polyhedra dialog appears. Enter the following properties:  

• Number of Polygons: Enter the desired number of polygons for the polyhedron. 
Acceptable numbers are 4 to 999999. 
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• Diameter: Enter the desired overall diameter of the polyhedron. 
 

 
3. Click OK. Your 3D polyhedron appears in the scene. 

3D Grid 

The Grid primitive creates a flat plane along the axis that you specify.  

The image below shows a grid with U Size of 6, V Size of 8, and 8 vertices for each side. 

 
To insert a Grid from the Construct Menu: 

1. Choose Construct > Insert 3D > Grid.  

2. The Insert Grid dialog appears. Enter the following properties:  

• U Size: Determines the first dimension of the grid. If oriented to the Z axis, this dimension 
would pertain to the side of the grid that runs along the X axis. 

• V Size: Determines the second dimension of the grid. If oriented to the Z axis, this 
dimension would pertain to the side of the grid that runs along the Y axis. 

• U Vertex Count: Determines the number of divisions along the U Size measurement. 

• V Vertex Count: Determines the number of divisions along the V Size measurement. 

• Perpendicular: Click the X, Y, or Z arrow to choose the axis that you want the grid to be 
perpendicular to. Choose the X axis to create a floor, or the Y or Z axis to create a wall.  
 

 

 © 2008 DAZ 3D, Inc. 183 



Carrara 7 11 December 2008 

3. Click OK. Your grid appears in the scene. 

3D Rectangle 

While similar to the Grid, a Rectangle creates a flat plane with one division along each side. The 
rectangle lies perpendicular to the axis you choose. 

The image below shows a rectangle with U Size of .2, V Size of .4, and Perpendicular to the Z axis. 

 
To insert a Rectangle from the Construct Menu: 

1. Choose Construct > Insert 3D > Rectangle.  

2. The Insert Rectangle dialog appears. Enter the following properties:  

• U Size: Determines the first dimension of the rectangle. If oriented to the Z axis, this 
dimension would pertain to the side that runs along the X axis. 

• V Size: Determines the second dimension of the grid. If oriented to the Z axis, this 
dimension would pertain to the side that runs along the Y axis. 

• Perpendicular: Click the X, Y, or Z arrow to choose the axis that you want the rectangle 
to lie perpendicular to. Choose the X axis to create a floor, or to the Y or Z axis to create 
a wall. 
 

 
3. Click OK. Your rectangle appears in the scene. 

3D Oval 

The Oval primitive creates flat circles or ovals with a specified number of sides. The oval can lie 
perpendicular to the axis of your choice. 
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The image below shows an oval with a U Size of .2 and a V Size of .4, aligned to the Z axis. 

 
To insert an Oval from the Construct Menu: 

1. Choose Construct > Insert 3D > Oval.  

2. The Insert Object dialog appears. Enter the following properties:  

• U Size: Determines the first dimension of the oval. If oriented to the Z axis, this 
dimension would pertain to the side that runs along the X axis. 

• V Size: Determines the second dimension of the grid. If oriented to the Z axis, this 
dimension would pertain to the side that runs along the Y axis. 

• Number of Sides: The number of sides in the oval. 

• Perpendicular: Click the X, Y, or Z arrow to choose the axis that you want the oval to be 
perpendicular to. For example, choose the Z axis to lie the oval on the floor. 
 

 
3. Click OK. Your oval appears in the scene. 

3D Polygon 

The Polygon primitive allows you to create a flat shape with any number of sides, and which lies parallel 
to the active plane.  

A polygon is similar to a 2D polyline (see "Drawing Polylines") except that the shape is filled with a solid 
surface. You create polygons with the Polygon tool, which works similar to the Polyline tool.  

You can also use the Polygon tool to add a new polygon to an existing polymesh, providing that the point 
you select for the new polygon belongs to the polymesh and is not common to more than three polygons 

To insert a Polygon from the Construct Menu: 

1. Choose Construct > Insert 3D > Polygon.  

2. You enter Edit Mode in the Vertex modeler. Click to set each point that makes up the polygon. 
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3. After you set the last point in the polygon, press the Enter key to complete the process. 
 

 

Inserting 2D Vertex Objects (Standard, Pro) 
The Vertex modeler also features a number of different 2D primitives that you can use to create your 
models. The available 2D primitives are Polyline, Interpolated Curve, Curve, Rectangle, and Circle. 

 
You can insert a 2D primitive using the tools, or by using the Construct > Insert 2D commands in the 
Vertex modeler. 

Drawing Polylines 

A Polyline is a set of vertices and edges that are joined but do not branch. An open polyline includes one 
or more edges that do not meet, while a closed polyline begins and ends at the same vertex. Examples 
are the outline of a square or a triangle. Use the Polyline tool to create polylines. 

You can draw open and closed polylines, which can be used as cross-sections, paths, and lathe profiles. 

To draw a polyline: 

1. From the Assemble room, choose Insert > Vertex Object to enter the Model room. The Vertex 
modeler opens with the working box displayed. 

2. Use the Working Box control to select the active plane. The polyline will be created parallel to the 
active plane. 
 

 
3. From the Vertex modeler, use one of the following methods to select the tool:  
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• Click the Polyline tool. 
 

 
• Choose Construct > Insert 2D > Polyline. 

4. Set the desired options in the Properties tray:  

• Weld with Snapped Points: When you add a vertex on top of an already existing vertex, 
the two vertices are merged into one. Uncheck this option to prevent this from happening.  

• Snap to Grid: Check this option to automatically snap to the grid in the modeling window.  

• Close: Check this option to automatically create a closed polyline. Uncheck the option to 
create an open polyline. 
 

 
5. Click in the modeling window to create each vertex in the curve: 

• Vertices are added to the current drawing plane except if you click on an existing point 
not lying in this plane. In this case, the subsequent points are created in a plane parallel 
to the active plane and passing through the existing point. This is very convenient for 
starting polylines attached to existing points of curves or polygons. 

• Edges are automatically drawn to connect the vertices. 

6. If necessary, close the curve by clicking on the first point. You will not have to close the polyline 
manually if you have selected the Close option in the Properties tray. 

7. Press Enter to complete the shape. 

Converting Closed Polylines to Polygons 

You can fill a closed polyline to turn it into a polygon.  

To fill a polyline or polygon: 

1. Select the polyline you want to fill. 

2. Choose Model > Fill Polygon. The open polyline becomes a filled polygon. 

Drawing Interpolated Curves 

A Curve is a smooth representation of a polyline. It is created like a polyline but each point acts like a 
magnet for the curve. Interpolated Curves pass through control points.  

To draw an interpolated curve: 

1. From the Assemble room, choose Insert > Vertex Object to enter the Model room. The Vertex 
modeler opens with the working box displayed. 

2. Use the Working Box control to select the active plane. The polyline will be created parallel to the 
active plane. 
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3. From the Vertex modeler, use one of the following methods to select the tool:  

• Click the Interpolated Curve tool. 
 

 
• Choose Construct > Insert 2D > Interpolated Curves. 

4. Set the desired options in the Properties tray: 

• Range: Adjust the setting to the desired number of intermediate steps between each 
vertex that you add. Lower values use less resources, higher values create smoother 
curves.  

• Close: Check if you want to automatically create a closed curve. Leave unchecked to 
create an open curve, or one that you will close manually. 
 

 
5. Click in the modeling window to create each vertex in the curve.  

• Vertices are added to the current drawing plane except if you click on an existing point 
not lying in this plane. In this case, the subsequent points are created in a plane parallel 
to the active plane and passing through the existing point. This is very convenient for 
starting curves attached to existing points of curves or polygons. 

• Additional vertices appear between the points that you click, equal to the Range value 
that you set in Step 4. 
 

 
6. If necessary, close the curve by clicking on the first point (or by selecting the Close option in the 

Properties tray). 

7. Press Enter to complete the shape. 
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Drawing Curves 

The Curves tool creates smooth polyline curves that do not pass through control points. 

To draw a curve: 

1. From the Assemble room, choose Insert > Vertex Object to enter the Model room. The Vertex 
modeler opens with the working box displayed. 

2. Use the Working Box control to select the active plane. The polyline will be created parallel to the 
active plane. 
 

 
3. From the Vertex modeler, use one of the following methods to select the tool:  

• Click the Curve tool. 
 

 
• Choose Construct > Insert 2D > Curve. 

4. Set the desired options in the Properties tray: 

• Range: Adjust the setting to the desired number of intermediate steps between each 
vertex that you add. Lower values use less resources, higher values create smoother 
curves.  

• Close: Check if you want to automatically create a closed curve. Leave unchecked to 
create an open curve, or one that you will close manually. 
 

 
5. Click in the modeling window to create each vertex in the curve.  

• Vertices are added to the current drawing plane except if you click on an existing point 
not lying in this plane. In this case, the subsequent points are created in a plane parallel 
to the active plane and passing through the existing point. This is very convenient for 
starting curves attached to existing points of curves or polygons. 

• Additional vertices appear between the points that you click, equal to the Range value 
that you set in Step 4. 
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6. If necessary, close the curve by clicking on the first point (or by selecting the Close option in the 

Properties tray). 

7. Press Enter to complete the shape. 

Drawing Rectangles 

The Rectangle tool allows you to create rectangular and square shapes. 

1. From the Assemble room, choose Insert > Vertex Object to enter the Model room. The Vertex 
modeler opens with the working box displayed. 

2. Use the Working Box control to select the active plane. The polyline will be created parallel to the 
active plane. 
 

 
3. From the Vertex modeler, use one of the following methods to select the tool:  

• Click the Rectangle tool. 
 

 
• Choose Construct > Insert 2D > Rectangle.  

4. Rectangle options appear in the Properties tray. Enter the width and height of the rectangle and 
press Enter. The rectangle will be created in the scene. 
 

 

Drawing Circles 

The Circle tool provides three different methods to create a circle. These methods are described below. 

1. From the Assemble room, choose Insert > Vertex Object to enter the Model room. The Vertex 
modeler opens with the working box displayed. 
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2. Use the Working Box control to select the active plane. The polyline will be created parallel to the 
active plane. 
 

 
3. From the Vertex modeler, use one of the following methods to select the tool:  

1. Click the Circle tool. 
 

 
2. Choose Construct > Insert 2D > Circle.  

4. Circle options will show up in the Properties tray. Use the Number points slider or field to enter 
the desired number of sides. 
 

 
5. Choose one of the Build 

and continue to create yo
Mode options (From center, From diameter, or From three points), 
ur circle as described in the following manner. 

scribed previously, the Build Mode options appear in the 

2. Select the From Center build mode. 
 

To create a "From center" circle: 

1. After you choose the Circle tool as de
Properties tray. 

 
3. Adjust the Number points value to set the number of vertices in the circle. 

t the radius. 

rcle is complete. 

 Mode options appear in the 

2. Select the From Diameter build mode from the Properties tray.  
 

4. Click in the Scene window to define the center point. 

5. Drag the mouse outward from the center to se

6. Click to fix the radius. The ci

To create a "From diameter" circle: 

1. After you choose the Circle tool as described previously, the Build
Properties tray. 

 
3. Adjust the Number points value to set the number of vertices in the circle. 
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4. Click in the Scene window to define the first point. 

points" circle: 

ode options appear in the 
roperties tray. 

2. Select the From three points build mode from the Properties tray.  
 

5. Drag the mouse and click to set the second point. The circle is complete. 

To create a "From three 

1. After you choose the Circle tool as described previously, the Build M
P

 
3. Adjust the Number points value to set the number of vertices in the circle. 

nt. 

complete. 

You can select vertices, edges, or polygons in an object and then modify them with the many different 
tools that Carrara provides. There are several different ways to make selections in Carrara, each of which 
will be discussed in the sections that follow. 

4. Click in the Scene window to define the first point. 

5. Drag the mouse and click to set the second poi

6. Drag the mouse to click and set the third point. The circle is 

Working with Selections 

 

Selection Tools 
The left toolbar in the Model room contains three selection tools, which can be used as follows: 
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• Marquee Selection: Drag a rectangular area to surround the objects, edges and vertices yo
want to select. 

u 

nd 
vertices you want to select. 

over the elements you want to select. 

l so 
odeling tools. You can assign names to your 

a later point in your modeling. You can also assign 
ph area. 

r, Vertex, Edge, and Polygon. 
Click their icons at the top of the Properties tray to switch the selection mode from one to another. 

By default, selected vertices, edges and polygons are highlighted in red. 

• Lasso Selection: Drag to define an irregularly-shaped area around the objects, edges a

• Paint Selection: Click and drag the paint cursor 

Vertex Modeler Selection Modes 
Selection controls in the Vertex modeler allow you to select vertices, edges, or polygons in your mode
that you can modify your geometry using Carrara's m
selections so that you can easily retrieve them at 
selected areas to a shading domain or mor

Choosing a Selection Mode 

There are four different modes of selection in the Vertex modeler: Regula

 
• Regular Selector: Vertices, edges and polygons can be selected. Furthermore, this mode 

automatically completes' the selection when possible. For example, if you select two vertices 
es around a polygon are selected, the 

• Edge Selector: Selects only the edges that you click. 

elects only the polygons that you click. 

. 

pen the model that you want to modify in the Vertex modeler. 

2. Click the Selection tool. 
 

linked by an edge, the edge is also selected. If all the edg
polygon is also selected. 

• Vertex Selector: Selects only the vertices that you click. 

• Polygon Selector: S

Selecting Vertices 

You can use the Regular selector or the Vertex selector to select vertices

To select vertices: 

1. O

 
S3. 

r mode from the Properties tray, and click to select a vertex. 
 

Press the Shift key while selecting 
single or multiple vertices to add to the selection. Press the Ctrl/Cmd key while selecting 

elect vertices as follows:  

• Choose Regular Selecto
Shift+Click additional vertices to add to the selection. Ctrl/Cmd+Click vertices to remove
them from the selection. 

• Choose Vertex Selector mode from the Properties tray, and click individual vertices or 
draw a selection rectangle around multiple vertices. 
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single or multiple vertices that you want to remove. 
 

 

Selecting Edges 

You can use the Regular selector or the Edge selector to select edges. 

 want to modify in the Vertex modeler. 

lick the Selection tool. 
 

To select edges: 

1. Open the model that you

2. C

 
3. Select edges as follows:  

• Choose Regular Selector mode from the Properties tray, and click to select an edge
(the line between two vertices). Shift+Click additional edge

 
s to add to the selection. 

 

ess the Ctrl/Cmd key while selecting 
ingle or multiple edges that you want to remove. 

 

Ctrl/Cmd+Click edges to remove them from the selection. 

• Choose Edge Selector mode from the Properties tray, and click individual edges. You 
can also begin a rectangular selection from the outside of the object and drag inward to
draw a selection rectangle around multiple edges. Press the Shift key while selecting 
single or multiple edges to add to the selection. Pr
s
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Selecting Adjoining Edges 

An adjoining edge is considered to lie in the same direction if the angle formed between the selected 
edge and the adjoining edge is equal to or less than the value that you set in the Properties tray: Tool 
Options: Edge Propagation field. 

If the adjoining edge lies in the same direction, it is selected and the angles formed between it and any 
adjoining edges are evaluated. In this way, the selection propagates until there are no more adjoining 
edges that meet the selection criteria. 

 
To select an edge and all connected edges in the same direction: 

1. Open the model that you want to modify in the Vertex modeler. 

2. Click the Selection tool. 
 

 
3. Set the Edge Propagation setting in the Properties tray to the highest angle of edges that you 

want to select. 

4. Double-click an edge in the object. All connecting edges below the set angle value are selected. 
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Selecting Polygons 

You can use the Regular selector or the Polygon selector to select polygons. 

To select polygons: 

1. Open the model that you want to modify in the Vertex modeler. 

2. Click the Selection tool. 
 

 
3. Select polygons as follows:  

• Choose Regular Selector mode from the Properties tray, and click to select a polygon. 
Shift+Click additional polygons to add to the selection. Ctrl/Cmd+Click polygons to 
remove them from the selection. 

• Choose Polygon Selector mode from the Properties tray, and click individual polygons. 
You can also start from outside the object to draw a rectangular selection around multiple 
polygons. Press the Shift key while selecting single or multiple polygons to add to the 
selection. Press the Ctrl/Cmd key while selecting single or multiple polygons that you 
want to remove. 
 

 

Selecting Objects 

To select an entire object: 

1. Click the Selection tool. 
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2. Double-click in the middle of any polygon. The entire object is selected. 
 

 

Soft Selections 

Complementing the selection modes, there is a Soft Selection option that smoothly increases the 
influence around the active selection. 

This feature is especially handy for when you want to create morphs for a human character. For example, 
select a polygon that corresponds to a part of the cheek on a face. If you move the selected polygon 
without Soft Selection, it will be the only element that moves.  

 
When you activate the Soft Selection feature, an influence area appears around the selected element. 
The area is represented by red polygons (maximum influence) whose color becomes grey (minimum 
influence). When you move the soft selection you will see that a part of the nose is modified as well while 
it smoothly follows your manipulation. 
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Two parameters, in the Properties panel, will allow you to fine-tune the Soft Selection: 

 
• Radius: defines the size of the influenced area around the selection. 

• Softness: the influence ratio in the soft selection area. The higher the value, the less flexible the 
modified surface. 

Viewing Selection Statistics 

The Properties tray: Model tab: Statistics panel allows you to keep track of the number of polymeshes, 
polygons, edges, and vertices that are currently selected. This panel is located at the bottom of the Model 
tab. 

 

Selection Menu Commands 
The Selection menu in the Model room provides several different commands that allow you to work with 
selections in many different ways. You can assign names to selections and recall them at any time. You 
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can also select specific shading domains or morph areas in an object. The following sections describe 
how to use these commands.  

Saving Selections 

When you're working with complex objects, it's often convenient to save selections of objects so that you 
can easily reselect them. 

Note You can have as many saved selection as you want. To set the maximum number of saved 
selection, use the Vertex modeler preference dialog (see "Setting Preferences for the Vertex Modeler"). 

To save the current selection: 

• Choose Selection > Add To Saved Selections. Carrara adds the current selection to the others 
that can be recalled. 

Restoring Selections 

You can use the Restore Selection command to toggle through the saved selections until you find the one 
you want to work with. 

To restore the saved selection: 

• Choose Selection > Restore Selection. The previous saved selection is restored. 

• To restore additional previous selections, choose Selection > Restore selection again. 

Working with Named Selections 

You can assign names to polymeshes, polygons, edges and vertices. Once named you can reselect the 
selection by name. Named selections are also used by some exporters. 

Even though you can use the Select By Name feature to select large parts of your vertex object, the 
selection only directly applies to vertices. For example, when you select an edge, two vertices are 
selected.  

In some cases, this means that you may actually select edges unintentionally. For example, when you 
select two edges of a triangular polygon, the third edge also becomes selected because all three vertices 
in the triangle are selected with the first two edges. 

To name a selection: 

1. Create a selection of polymeshes, polygons, edges, or vertices. 

2. Choose Selection > Name, and then select the type of selection you have made: Polymesh, 
Polygons, Edges, or Vertices. A dialog prompts you to assign a name to the selection. 
 

 
3. Enter a name for the selection and click OK. 
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To select named objects: 

1. To select by name, choose Selection > Select by > Name. The Select by Name dialog appears. 
 

 
2. Choose the type of selection (polymesh, polygon, edge, or vertex) that you want to reselect. If 

selections of that type have been assigned, their names appear in the Name List. 

3. Select the name you want to select. 

4. Click OK. 

To deselect named objects: 

1. To select by name, choose Selection > Deselect by > Name. The Deselect by Name dialog 
appears. 
 

 
2. To deselect, choose Selection > Deselect by Name. 

3. Choose the type of selection (polymesh, polygon, edge, or vertex) that you want to deselect. If 
selections of that type are selected, their names appear in the Name List. 

4. Select the name you want to deselect. 

5. Click OK. 

Hiding Selections 

When you're editing a complex object, you might want to hide parts of the object to make it easier to view 
and select the vertices and edges you want to work with. 
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To hide a selection: 

1. Select the vertices, edges, or polygons that you want to hide. 

2. Choose View > Hide Selection. 
 

 
To reveal hidden vertices in an object: 

1. Select the object. 

2. Choose View > Reveal Hidden Vertices. All previously hidden vertices reappear. 

Deselecting Items 
To deselect all selections: 

1. Click the Selection tool. 
 

 
2. Click in an empty area of the modeling window. 

Using the Properties Tray Selection Tools 
A number of different selection tools appears in the Properties tray in the Model Room. From left to right, 
they are the Loop, Ring, Between, Invert, Shrink, and Grow Selection tools. 
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Looping from a Selection 

The Loop tool lets you expand a selection along a surface by continuing it as far as possible in the 
direction you started. The Loop tool works with polygons and edges, but not with vertices. For polygons, 
you must have at least two polygons selected to indicate the direction to expand the selection. 

To select a loop: 

1. Select an edge, or two polygons to start. 

2. Do one of the following:  

• Click on the Loop icon, in the property panel. 

• Choose Selection > Loop. 
 

 

Ring from Selection 

The Ring tool is similar to the Loop tool, but it expands a selection in parallel (like the rungs on a ladder). 
The selection expands along a surface by continuing it as far as possible in the direction you started. The 
Ring tool works only with edges. 

To select a ring: 

1. Select an edge. 

2. Do one of the following:  

• Click on the Ring icon, in the property panel. 

• Choose Selection > Ring. 
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Selecting Between (or Select Connect) 

The Between tool lets you connect a selection on a surface after defining its start and finish. The tool only 
works on simple cases, like a direct path. Since this tool is based on Loop and Ring, it will stop at the 
same types of problems which would stop those other tools. 

To select between: 

1. Select an edge or polygon as start element. 

2. Select an edge or polygon as end element. 

3. Do one of the following:  

• Click on the Btw icon, in the property panel. 

• Choose Selection > Connect. 
 

 

Inverting the Current Selection 

Inverting the selection deselects the current selection and selects all other items. 

To invert the current selection: 

Do one of the following: 

• Click the Inv icon in the Property panel. 

• Choose Selection > Invert Selection. 
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Shrinking Selections 

The Shrink Selection tools allows you to reduce the selection by unselecting the items located on the 
outer limit of the currently selected items. 

To shrink the selection: 

1. Create a selection of vertices, edges, or polygons. 

2. Do one of the following:  

• Click on the - icon, in the property panel. 

• Choose Selection > Shrink. Repeat as many times as necessary to shrink the selection 
as needed. 

 

Growing Selections 

The Grow Selection tools allows you to add to the selection faces, edges or points close to the currently 
selected items. 

To grow the selection: 

1. Create a selection of vertices, edges, or polygons. 

2. Do one of the following:  

• Click on the + icon, in the Property panel. 

• Choose Selection > Grow. 
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Working with Vertices and Edges 
The power of Vertex modeling lies in the ability to directly position vertices and edges. By joining separate 
objects and moving vertices, edges, and polygons, you can model just about anything you can imagine. 

Using the Magnet to Attract Vertices (Standard, Pro) 
You can selectively move vertices in an object with the Magnet tool. This tool behaves like a magnet, 
attracting the vertices within its sphere of influence. The effects of the Magnet tool are most noticeable 
when you use it on a highly defined object. 

 
• The radius of the sphere of attraction. 

• Whether nearby edges and vertices are attracted or only the selected vertices and edges are 
attracted. 

To attract a group of vertices: 

1. Select the vertices you want to move or attract. 

2. Click the Magnet tool. 
 

 
3. Adjust the settings in the Properties tray as needed: 
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• Choose the shape of the attraction curve. Previews are shown in the Properties tray of 
the approximate shape that you will get from each shape. Choices are Cubic, Linear, 
Spiky, or Bumpy. 

• Choose Move Selection, Attract Other Vertices to move the selected vertices as they 
would be with the Selection tool. Other vertices within the sphere of attraction are moved 
towards the selected vertices. 

• Choose Attract Only Selected Vertices to move selected vertices only. 

• Set the Radius of Attraction to determine the area around the tool that will be affected. 

4. Drag the Magnet tool in the direction in which you want to move the vertices. 

5. To constrain the move operation to the direction perpendicular to the Drawing plane, hold down 
the Command/Ctrl key. 

Repositioning Vertices Numerically 
In the Vertex modeler, you can precisely reposition vertices in two ways: 

• Offset a selection from its current location with the Move tool. 

• Change the coordinates of a vertex, edge, or polygon using the Properties tray. For information 
on using the Properties tray, refer to "Checking Object Properties." 

To offset a selection by a specific amount: 

1. Select the object or portion of the object you want to move. 

2. In the Move tool options of the Properties tray, specify the amounts you want to move the 
selection on the X, Y and Z axis. 
 

 

Deleting Vertices 
Removing a vertex also removes the edges that connected the vertex to other vertices, unless the edges 
connected to this vertex are two. In that case, a new edge is created to replace the two previous ones. 

To delete a vertex (all versions): 

1. Select the vertex or vertices to delete. 

2. Do one of the following: 

• Choose Edit > Dissolve (creates new edges). 

• Press the Backspace key (creates new edges). 

• Press the Delete key (removes edges). 
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To delete a vertex (Standard, Pro): 

1. Click the Delete tool. 
 

 
2. Click the vertex you want to remove. 

Adding Vertices (Standard, Pro) 
You can edit existing polylines or edges by adding vertices on them. Adding vertices is useful when you 
need more control over the object than is provided with the existing vertices. 

To add a vertex: 

1. Click the Add Vertex tool. 
 

 
 
The Add Vertex tool options show in the Properties Tray.  
 

 
2. Choose one of the following options:  

• Constrain Position: The new vertex is added at 1/4, 1/3, or 1/2 of the edge.  

• Free Position: Adds a vertex at any position on the edge. You can also drag with the 
Add Vertex tool to add and immediately move a new vertex. 

3. When two vertices are added consecutively to the same polygon, they are automatically linked 
with an edge. This behavior can be switch off by unchecking the Auto-link option. 

4. Click an edge where you want to add the vertex. The new vertex is highlighted in red.  

Welding Vertices (Standard, Pro) 
There are three ways to weld vertices: with the Weld command, or with the Weld or Target Weld tools. 

Using the Weld Command 

You can join separate objects by welding selected vertices. Normally, if two vertices are within a specified 
distance from each other, they are welded when you use the Weld command. However, if welding the 
vertices would cause a single edge to be shared by more than two polygons, the vertices are not joined. 
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To weld vertices using the Model > Weld command: 

1. Select the vertices to be welded. 

2. Choose Model > Weld. The Weld Selected Vertices dialog appears. 
 

 
3. Set weld options: 

• Align but do not weld aligns the vertices but does not make two or more objects one, as 
the Weld command does. The vertices move to the average position of all the vertices 
that lie within the threshold. 

• Use default tolerance welds the vertices if the distance between them is within the 
default tolerance specified in the Vertex modeler preferences. 

• Weld all selected vertices welds the selected vertices no matter how far apart they are. 

• Use custom tolerance specifies the maximum distance vertices can be from each other 
and still be welded. 

• Custom tolerance determines how close the vertices must be to be welded. Enter a 
value. 

4. Click OK. The welded vertices are joined into a single vertex. 

Using the Weld Tool 

Two vertices can also be welded together using the Weld tool or the Target Weld tool. The Weld tool 
welds points and moves the result at mid distance of the two selected points, whereas the Target Weld 
tool welds vertices and moves the first selected vertex to the position of the second vertex. 
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To Weld vertices using the Weld tool: 

1. Click the Weld tool. 
 

 
2. Click on the two vertices to be welded together. 

Using the Target Weld Tool 

The Target Weld tool allows you to weld two vertices so that the first selected vertex is moved to the 
second selected one and merged with it. 

The Target Weld tool can also be used to weld edges. 

To weld a vertex or edge to another vertex or edge using the Target Weld: 

1. Click the Target Weld tool. 
 

 
2. Click on the vertex to weld to another vertex. 

3. Click on the target vertex. The first vertex is moved to the second vertex position and the two 
vertices are welded. 
 

 

Linking and Unlinking Vertices (Standard, Pro) 
Linking vertices creates an edge between them. Unlinking vertices removes the edge that connects them, 
but does not affect the vertices themselves. 

Linking can be used for breaking a polygon in two between two of its vertices, or for closing or extending 
a polyline. 

It is not possible to create an edge on a polymesh if the two vertices do not belong to the same polygon. 
For instance, linking two vertices on the border of a hole is not possible. 
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To link vertices: 

1. Click the Link tool. 
 

 
2. Select the first vertex. This vertex will turn yellow. 

3. Select the second vertex. An edge is created to connect the vertices. If the two vertices are part 
of the same polygon, the polygon is divided into two smaller polygons. 
 

 
To unlink vertices: 

1. Select the vertices you want to unlink. 

2. Choose Model > Unlink. The edge connecting the two vertices is removed. 

TIP! You can also unlink two vertices by clicking the edge with the Delete tool or by selecting the 
edge and using the Dissolve tool or hitting the Backspace key. 

Deleting Edges 
To delete an edge (all versions): 

1. Select the edge or edges to delete. 

2. Do one of the following: 

• Choose Edit > Dissolve (creates new edges). 

• Press the Backspace key (creates new edges). 

• Press the Delete key (removes edges). 

To delete an edge (Standard, Pro): 

1. Click the Delete tool. 
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2. Click the edge you want to remove. 

Removing an edge does not remove the vertices that it connected. 

Deleting Polygons 
To delete a polygon (all versions): 

1. Select the polygon or polygons to delete. 

2. Press the Delete key. 

To delete a polygon (Standard, Pro): 

1. Click the Delete tool. 
 

 
2. Click the polygon you want to remove.  

• Removing a polygon does not remove the edges around it. 

• Deleting a polygon is the same as emptying it (with the Model > Empty Polygon 
command). 

Detaching Polygons (Standard, Pro) 
You can detach polygons from objects and move them to another location. The main object will have a 
hole where you detached the polygon. 

To detach a polygon: 

1. Select the polygon you want to detach from the main object. 

2. Choose Model > Detach Polygons. 

3. Drag the polygon to any position you like. 

Advanced Edge Tools (Pro only) 
The Vertex modeler provides several advanced tools to manipulate edges quickly. These tools can be 
used to improve the topology of polygonal objects. 

Quick Fillet 

The Quick Fillet tool lets you extract a selected edge along the edges next to it. The result is similar to 
using the Fillet tool set to range 0. 

To use the Quick Fillet tool: 

1. Select one or several edges on a surface or a volume. This command also applies to edges in 
selected vertices or polygons. 

2. Do one of the following:  

• Select the Quick Fillet tool. 
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• Choose Model > Fast Fillet Edge. 

3. Click the selection and drag in the direction that you want the new edges to move, until they 
reach their new position. The new edges are colored green until you release the mouse button. 
 

 

Extract Around 

The Extract Around tool lets you create two edges parallel and around the original selected edge, or 
edges. Unlike the Quick Fillet tool, the original edges remain. This command is handy for creating a 
raised button or a pushed-in area. 

To extract edges around: 

1. Select one or several edges of a surface or volume. This command also applies to edges in 
selected vertices or polygons. 

2. Do one of the following:  
• Select the Extract Around tool. 

 

 
• Choose Model > Extract Around Edge. 

3. Click and drag on the selected edge or edges, and move it to define the offset of the newly 
created edges. 
 

 

Extract Along 

The Extract Along tool lets you extract a selected edge along the edges next to it. This tool is useful for 
fine-tuning a model, for example adding a loop of edges around an existing edge. 
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To extract edges along: 

1. Select one or several edges on a surface or volume. 

2. Do one of the following:  

• Select the Extract Along tool. 
 

 
• Choose Model > Extract Along. 

3. Click and drag on the selected edge and move it to define the placement of the newly created 
edges. 
 

 

Move Along 

The Move Along tool lets you move an edge along its adjacent face. It is a very useful tool for fine-tuning, 
for example, moving an "edge loop" on an existing surface, like around an eye. 

To move edges along: 

1. Select one or several edges on a surface or a volume. 

2. Do one of the following:  

• Select the Move Along tool. 
 

 
• Choose Model > Move Edge Along Edge. 

3. Click-drag on the selection of edges, and move them to their new position. 
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Working with Objects 
The Vertex modeler provides a number of ways to manipulate an object without directly editing individual 
vertices and edges. This section describes how you can perform the following: 

Transforming Objects and Selections 
The Vertex modeler provides a number of ways to move, scale, and rotate vertex objects or selections. 
The most convenient way consists of using one of the 3D manipulators. But it can be necessary to use 
one of the other methods, such as entering values numerically to define a scale factor, for instance. 

The 3D Manipulator 

The 3D manipulator is displayed in the graphic view at the center of the selection. Depending on the 
selected mode (move, rotate, scale or universal) it shows several colored handles that can be used to 
transform the selection. 

You can choose which manipulator to display by selecting its icon in the left tool palette or by using 
keyboard shortcuts. 

 

The Move Manipulator 

Shortcut: T 

 
This manipulator moves (translates) the selected elements. The manipulator is symbolized by arrow 
points (2D and 3D). 

If you click on an axis, the movement of the selected item is restricted to that axis. 

If you click on a triangle on the same plane as the two axis, the movement is restricted to that plane. 

If you click drag on the selected element, the object is moved in the active plane. 

The Scale Manipulator 

Shortcut: S 
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This manipulator scales the selected elements. It is symbolized by cubes. If you click on a cube on the 
end of an axis, the scaling of the selected element is limited to that axis. 

If you click on one of the grey cubes on the same plane as the two axes, the scaling is restricted to that 
plane. 

This manipulator also shows a global interactive box which surrounds the object. Click on a face of this 
box to scale the object as if you were pulling on the face. Click on an edge of this box to pull on both 
faces that touch that edge. Click on a corner of the box to scale the box proportionally away from the 
opposite corner. 

The Rotate Manipulator 

Shortcut: R 

 
This manipulator rotates the selected elements. It is symbolized by circles. If you click on a circle 
corresponding to an axis, the rotation of the selected element is limited to that axis. 

The Universal Manipulator 

Shortcut: U. 

 
This manipulator is a combination of the three fundamental manipulators. It lets you perform moves, 
rotations and scalings without changing the tool. 

Using this manipulator is practical to move the objects globally. However, for precise manipulations of 3D 
entities like vertices or edges, the number of clickable modifiers on each axis may become a problem. 

3D Manipulator Properties 

When one of the manipulators is selected, the following options are available from the property panel: 

 
• Hidden: It is sometimes necessary to hide the manipulator for being able to select or view small 

details that can be hidden by the numerous controls of the 3D manipulator. Check the Hidden 
option to hide the manipulator. 
 

NOTE! You can still move, rotate,or scale selected items even if the manipulator is not 
visible but only in the active plan. 

• Three options determine how the manipulator transforms the selected objects:  

o World (default mode): the 3D manipulator transforms the selection relatively to the 
world axes. 
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o Camera: the manipulator transform takes place in the camera plane. Changing the 
camera orientation changes the transform plane. This mode is useful for tweaking 
selections. 

o Selection: the manipulator is oriented in the main plane of the selection. For instance, if 
a polygon is selected, the XY plane of the manipulator will be the plane of the polygon. 
This mode is convenient for modeling precisely while keeping the orientation of the 
selection. 

Moving Objects to the Drawing Plane (Standard, Pro) 
To move a selection to the Drawing plane: 

1. Select the vertices, edges, polygons, or objects you want to move to the Drawing plane. 

2. Choose Model > Move to Drawing Plane. 
 

 

Converting Spline and Metaball Objects 
You can create objects in the Spline modeler or Metaball modeler and then convert them to vertex objects 
that can be modified further in the Vertex modeler.  

NOTE! If you edit a spline or metaball object in the Vertex modeler, its conversion is permanent; 
you cannot reopen it in the native modeler. 

To convert a spline or metaball object: 

1. Open the Spline modeler or the Metaball modeler and select an object. 
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2. Choose Edit > Convert to Other Modeler. The Convert to Another Modeler dialog appears. 
 

 
3. Choose the Vertex modeler from the Available Modelers list. 

4. Specify the fidelity for the conversion using the Fidelity slider. The default, 100%, divides the 
object's surface into the optimum number of polygons. A higher percentage generates more 
polygons, providing more points of control. 
 

NOTE! Regardless of the fidelity of the conversion, some data may be lost and the model 
altered. 

5. Click OK. The model opens in the Vertex modeler. 

Duplicating Objects 
Duplication creates a new object with the position, orientation, and scale attributes of the original object. 
Duplication is an efficient way of working and has a number of practical applications. 

When you choose Edit > Duplicate, a second copy of the object is created at the same location as the 
original. 
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To duplicate an object: 

1. Select one object. 

2. Choose Edit > Duplicate. The duplicate occupies the same space as the original. Pull the 
duplicate away by dragging it or moving it numerically. 

3. Perform any number of position, orientation, and scale operations without deselecting the object. 

4. Choose Duplicate again. Each time you duplicate, the new copy receives the positioning, 
orientation, and scaling of the last duplicated object. 

Using Multiple Duplications 

You could use the Duplicate feature to build a DNA strand as follows: 

1. Create the first base and place it between two helixes. 
 

 
2. Then duplicate the base, raise the duplicate to the level where the next base would be located, 

and rotate it an appropriate amount. 
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3. Choose duplicate again and again until you have built a DNA strand. 
 

 

Duplicating Objects with Symmetry 
When you choose Duplicate with Symmetry, the copy mirrors the original object. The Drawing plane 
behaves differently from usual in that neither the object nor its duplicate is placed on the Drawing plane, 
but on either other side of it. 

To duplicate an object with symmetry: 

1. Move the Drawing plane so that it will reflect the original object in the desired location. For further 
instructions see "Changing the Drawing Plane." 

2. Select the object you want to mirror. 

3. Do one of the following:  

• Choose Edit > Duplicate with Symmetry.  

• Press Cmd/Ctrl+Shift+D. 
 

 

Replicating Objects or Selections 
When an object is made of a repeated pattern, a model of the pattern can be created and then be 
replicated as many times as needed. 

You can replicate complete objects in the Assemble room. You can also replicate portions of an object 
(selected polygons, for example) in the Model room. 
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To replicate an object: 

1. Select the object (or part of the object) to be replicated. 

2. Choose the Edit > Replicate. The Replicate dialog appears. 
 

 
3. Choose a replication option:  

• Linear: Arranges the replicated copies in a straight line from the original selection. 

• Array: Arranges the replicated copies in a grid, with the original object in one of the 
corners of the grid.  
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• Circle: Arranges the replicated copies in a circle, with the original selection in its center. 
 

 
4. For Linear replications, set the following options:  

• Number of Copies: Enter the desired number of copies (in addition to the original) that 
you want to create. 

• X Offset: Enter the desired distance between objects along the X axis. Enter 0 if you do 
not want to replicate along this axis. 

• Y Offset: Enter the desired distance between objects along the Y axis. Enter 0 if you do 
not want to replicate along this axis. 

• Z Offset: Enter the desired distance between objects along the Z axis. Enter 0 if you do 
not want to replicate along this axis. 
 

 
5. For Array replications, set the following options:  

• U Number: Enter the number of rows that you want to appear in the array. 

• U Offsets (X, Y and Z): Enter the desired distance between each copy in the row. 
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• V Number: Enter the number of columns that you want to appear in the array. 

• V Offsets (X, Y and Z): Enter the desired distance between each copy in the column. 
 

 
6. For Circle replications, set the following options:  

• Number of Copies: Enter the number of items that you want to include in the circle or 
arc. 

• Arc Angle: Enter the number of degrees for the circle or arc. For example, enter 360 to 
create a full circle, or 180 to create a half-circle. 

• Radius: Enter the dimension of the radius. 

• Axis: Select the axis along which you want the copies to be created. 

• Rotate Copies: Check this option to rotate the copies along the path of the circle or arc. 
 

 
7. Click OK. The items are replicated as you specified. 

Aligning Objects 
You can adjust the alignment of two objects by attaching them at selected vertices, edges, or polygons. 

To align one object with another: 

1. Select the vertices, edges, or polygons that you want to align on the first object. 

2. Shift-select the vertices, edges, or polygons that you want to align on the second object. You 
must make the same type of selection (vertices, edges, or polygons) on both objects. 

3. Ctrl+Alt+Click one of the selected vertices on the object you want to be the reference for the 
alignment. The vertex will turn yellow. 
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4. Choose Edit > Align. Your objects are aligned or distributed in the manner you specified. 
 

 

Flipping Objects 
You can flip entire objects in the Assemble room, and can also flip selected portions of an object in the 
Model room. An object can easily be flipped using Edit > Flip. The selection is then flipped using the 
active drawing plane as a reference. 

To flip an object: 

1. Use the Working Box control to select the active plane. 
 

 
2. Do one of the following:  

• In the Assemble room, select the object that you want to flip. 

• In the Model room, use the Selection tool to select all or part of an object to flip. 

3. Choose Edit > Flip. The selected object or portion is flipped along the plane that you specify. 

Checking Object Properties 
You can use the Model tab to check statistics on the contents of the working box, to name a selected 
polymesh, and to move selected vertices and objects to particular X, Y, and Z coordinates. The 
Properties tray: Model tab displays the properties of the selected vertex, edge, or polygon. 

The information shown in the Modeling tab depends on the current selection. To use the Modeling tab to 
reposition vertices, you must select either a vertex, an edge, or a polygon of no more than four sides. 

• When a vertex is selected, the Properties tray displays the coordinates of the vertex. 

• When an edge is selected, the Properties tray displays the coordinates of the edge's vertices. 
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• When a polygon of no more than four sides is selected, the Properties tray displays coordinates 
of each vertex. 
 

 
The Properties tray statistics show: 

• The total number of polymeshes, polygons, edges, and vertices in the working box. 

• The total number of each that are currently selected. 
 

 
 

NOTE! You can also use the Modeling tab to specify an object's shading domain. For more 
information, refer to "Setting a Predefined Mapping." 
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Editing Selection Properties 
The Properties tray also allows you to edit settings and parameters for the selected object. For example, 
when you select an object and then choose the Move tool, the options for the tool allow you to enter 
specific X, Y, and Z values for the new position. 

To specify object properties in the Properties tray: 

1. Select the object whose properties you want to change. You can change the name or the 
coordinates of the current selection. 

2. Directly edit the displayed values in the X, Y, and Z fields. 

Using an Image as a Model 
It is often useful to place as reference image in the backdrop when you draw polylines. Any image stored 
as an external file can be placed in the backdrop of the Vertex modeler. 

The image is not displayed in the Director's Camera view, but is visible in all other views. For example, 
you can configure your document window to display the Top, Left, and Front views and display drawings 
or photographs of the top, left, and front of an object in the respective viewport. This image is just a tool to 
help you in the construction of a vertex object and will not be visible in the rendering. 

Note that the image uses the working box dimensions to set the size on the screen. Therefore, you can 
use the Zoom and Pan tools to assist in viewing your object while you model. 

 
To place an image in the backdrop: 

1. In the Model room, choose the Properties tray: Global tab: Backdrop panel. 
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2. Click the choose an image file button. The Image File Chooser dialog appears. 

3. Locate the file that you want to open and click Open.  

4. Check the Enable option to display it in the appropriate viewport. 

Basic Vertex Modeling Functions (Standard, Pro) 
The following topics regarding vertex modeling procedures are discussed in this section. 

Changing an Object's Definition 
The Vertex modeler provides four commands that allow you to change the number of vertices and edges 
used to describe an object: Subdivide, Tesselate, Decimate, and Triangulate. You can apply these 
actions to an entire object, or to portions of an object. 

You can learn more about these tools in the following sections. 

Subdividing an Object 

Subdividing an object adds vertices and edges to give you finer-grain control over an object's surface. 

To subdivide selected polygons: 

1. Select the polygons you want to subdivide. 

2. Choose Model > Subdivide. 
 

 

Tessellating Objects 

The Tesselate tool and command allows you to change the number of vertices in the object, based on 
one of three different tessellation patterns. To switch from one mode to the other, click their respective 
icons in the tool options of the Properties tray. 
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• Vertex To Center Links the center of the polygon to its vertices. 
 

 
• Mid-Edge To Center Creates new vertices in the middle of the edges of the polygon and links 

them to the center of the polygon. 
 

 
• Mid-Edge To Mid-Edge Creates vertices in the middle of the edges and links them consecutively 

one to the other. 
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To tessellate a single polygon: 

1. Do one of the following: 

2. Click the Tesselate tool and select the type of tesselation desired from the Properties tray. 
 

 
3. Choose Model > Tesselate. 

4. The Tesselate options show up in the Properties Tray. Choose Vertex to Center, Mid-Edge to 
Center, or Mid-Edge to Mid-Edge from the submenu. 
 

 
5. Click the polygons that you want to tessellate. 

 

 
To tessellate multiple polygons: 

1. Select the polygons that you want to tessellate. 

2. Choose Model > Tesselate. 

3. Choose Vertex to Center, Mid-Edge to Center, or Mid-Edge to Mid-Edge from the submenu. 

Decimating an Object 

Decimating an object removes information, such as a percentage or number of vertices. Decimating is an 
easy way to simplify imported models that contain more detail than you need. 
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TIP! To get the best results when you're decimating an object, alternate between decimating and 
triangulating the object. 

To decimate an object: 

1. Select the object or portion of an object that you want to decimate. 

2. Choose Model > Decimate. The Decimate dialog appears. 
 

 
3. Set the following options:  

• Decimation: Adjust the percentage to specify the percentage of vertices to be removed. 
The higher the number, the more vertices will be removed. 

• Decimate by: Choose Vertex count to remove the percentage of vertices specified in 
the Decimation field. Choose Fidelity to remove the required number of vertices to meet 
the Criterion setting, up to the threshold percentage. 

• Criterion: Choose Distance to remove vertices based on their distance from the planes 
shared by their neighbors. Choose Angle to remove vertices based on the angles formed 
by the polygons that connect the vertices to their neighbors. 

4. Click OK. 
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Triangulating and Untriangulating Polygons 

The Triangulate command divides selected polygons with more than three sides into several triangular 
polygons, without affecting the number of vertices. 

TIP! Triangulate can also be used in conjunction with the Decimate command to produce more 
satisfactory results. 

NOTE! Triangulating a three-sided polygon has no effect, but you can subdivide a triangle. 

 
To triangulate selected polygons: 

1. Select the polygons you want to triangulate. 

2. Choose Model > Triangulate Polygon. 

To untriangulate selected polygons: 

1. Select the polygons you want to untriangulate. 

2. Choose Model > Untriangulate Polygon. 

Cleaning Topology 
In some cases, after a long modeling process, complex objects may contain incorrect topologies that can 
create bad display when rendering. A set of tools can be used to fix these type of problems. These tools 
are located in the Model menu and work on the current selection. 

Triangulating Non-Planar Faces 

Non-planar faces are four-sided polygons that do not have all four vertices aligned on the same plane. 
They often present problems when rendered, because you can see the individual triangles in the polygon 
and half of the polygon can appear darkened. The Triangulate Non-Planar Faces command detects non-
planar faces in a selection and automatically converts non-planar quad polygons into two triangular 
polygons. 
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To triangulate non planar faces: 

1. Select some or all of the polygons in the model that you want to repair. 

2. Choose Model > Triangulate non planar faces. 
 

 

Triangulating N-Gons 

N-gons generally refer to polygons that have more than four sides. Because they might not render 
properly, it is generally best to use 3 or 4-sided polygons in your models as a result. 

The Triangulate N-Gons command detects polygons that have more than four sides, and converts them 
to multiple triangles. 

To triangulate n-gons: 

1. Select some or all of the polygons in the model that you want to repair. 

2. Choose Model > Triangulate n-gons (>4 points). 
 

 

Removing Duplicate Points 

Duplicate points are two or more vertices that occupy the exact same position. You can economize on the 
size of your model by removing them with the Remove Duplicate Points command. 
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To remove duplicate points: 

1. Select some or all of the polygons in the model that you want to repair. 

2. Choose Model > Remove Duplicate Points. 

Merging Coplanar Faces 

Coplanar faces are facets that share an edge and are in the same plane. You can merge coplanar faces 
with the Merge Coplanar Faces command. 

To merge coplanar faces: 

1. Select some or all of the polygons in the model that you want to repair. 

2. Choose Model > Merge Coplanar Faces. 

Creating and Filling Holes in an Object 
Vertex objects do not have to be completely solid. You can cut holes in an object by emptying polygons 
on the object's surface, or you can detach polygons to create an effect such as a can with a half-open lid. 

NOTE! You can also cut away parts of an object by using the operation. For more information refer 
to "Using Boolean Operations." 

 
To create a hole in an object: 

1. Select the polygons you want to remove to create the hole. 

2. Choose Model > Empty Polygon. 

3. If the process leaves isolated vertices behind, select the stray vertices and delete them. 

TIP! You can also empty polygons with the Delete tool. 

NOTE! Filled and emptied polygons appear the same in the Wireframe views. To view the hole, 
switch to one of the shaded modes. 

To fill a hole in an object: 

1. Select the closed polyline that you want to fill. 

2. Choose Model > Fill Polygon. 
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Closing a Curve 
The Close Curve command located in the Model menu can be used to close an open curve in a single 
click. 

To close curves: 

1. Use Edge selection mode to select an open curve in the Vertex modeler. 

2. Choose Model > Close Curve. The open ends of the open curve are joined into a closed curve. 
 

 

Extracting Edges from Curves 
The Extract Curve tool located in the Model menu allows you to create a curve by transforming a 
selection of edge into a curve. 

To extract curves: 

1. Select one or more edges in an existing 2D or 3D vertex object. 

2. Choose Model > Extract Curve. Carrara turns the selected edges into a new curve that is 
independent of the original object. The edges that you originally selected remain intact in the 
original curve. 
 

 

Modifying the Polygon Normals 
Some situations require the polygons to be oriented in a certain way. This is the case with models that 
are exported to some other software that use this information for display purposes. It is also the case with 
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the Non-Photorealistic Renderer. The polygons oriented toward the camera are rendered whereas the 
others are not. 

In the Vertex modeler, switching the orientation of one polygon will also switch all the adjacent polygons 
so that the mesh stays consistent. 

To switch the normals orientation on a mesh: 

1. Select one or more polygons on the mesh. 

2. Use the menu Model >Reverse Polygon Normals. 

Flattening Objects 
The Flatten command allows you to flatten selected objects or vertices to the plane that lies closest to the 
selected vertices. 

To flatten selections: 

1. Select the objects or vertices you want to flatten. 

2. Choose > Model > Flatten. 
 

 

Adding Thickness to an Object 
The Add Thickness command lets you extrude polygons at right angles to the plane of the surrounding 
polygons. 
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To add thickness to an object: 

1. Select all or some of the polygons on the object you want to extrude. In this case the entire object 
was selected. 

2. Choose Model > Add Thickness. The Add Thickness dialog appears. 
 

 
3. In the Distance field, specify how thick you want the surface to be:  

• Enter a positive value to add thickness toward the outside of the object. 

• Enter a negative value to add thickness toward the inside of the object. 

4. Click OK. Thickness is added to the selected polygons. 

Offsetting an Object's Surface 
When you offset the surface of an object, the surface expands like a balloon. All selected vertices are 
moved outward at right angles to the average plane of the surrounding polygons 

 
To Offset the surface of an object: 

1. Select the polygons that you want to offset from the object. 
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2. Choose Model > Offset Surface. The Offset Surface dialog appears. 
 

 
3. In the Distance field, specify the amount you want to move the selected polygons. 

4. Click OK. 

Filleting Vertices or Edges 
Most real objects seldom have truly sharp edges. An example is right in front of you: look at your 
computer screen, whose shell probably has rounded edges, whether for safety or design or both. To get 
this effect, use the Fillet tool to create smooth angles and corners, by rounding chosen edges or vertices 
of a polymesh. 

The Fillet tool has two properties to set: Radius and Range. 

To fillet selected edges: 

1. Select one or several edges on a surface or a volume. 

2. Do one of the following:  

• Select the Fillet tool. 
 

 
• Choose Model > Fillet. 

3. Set the following properties as desired:  

• Radius: Defines the size of the rounded section that makes the edge or vertex rounded. 

• Range: Defines the number of sections that will be created to form the rounded edge. 
Lower numbers result in fewer polygons, while higher numbers provide higher quality. 

4. If using the Fillet tool, press the Enter/Return key to complete the process. 
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To fillet unselected edges: 

1. Select the Fillet tool. 
 

 
2. Do one of the following:  

• To fillet a single edge, click on the desired edge to complete the fillet. 

• To fillet multiple edges, Shift-click to select multiple adjacent edges. Then release the 
Shift key and click on the selection to complete the fillet 

3. Set the following properties as desired.  

• Radius: Defines the size of the rounded section that makes the edge or vertex rounded. 

• Range: Defines the number of sections that will be created to form the rounded edge. 
Lower numbers result in fewer polygons, while higher numbers provide higher quality. 

4. Press the Enter/Return key to complete the process. 
 

 
To fillet rounded corners from vertices: 

1. Select the Fillet tool. 
 

 
2. Do one of the following:  

• To fillet a single vertex, click on the desired vertex to complete the fillet. 

• To fillet multiple vertices, Shift-click to select multiple adjacent vertices. Then release the 
Shift key and click on the selection to complete the fillet 

3. Set the following properties as desired.  

• Radius: Defines the size of the rounded section that makes the edge or vertex rounded. 

• Range: Defines the number of sections that will be created to form the rounded edge. 
Lower numbers result in fewer polygons, while higher numbers provide higher quality. 
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4. Press the Enter/Return key to complete the process. 
 

 

Using the Bridge Tool 
The Bridge tool allows you to connect selected polygons between two objects in the Vertex modeler.  

To use the tool: 

1. Select the polygons, edges, or vertices that you want to connect.  

2. Select the Bridge tool.  
 

 
 
The following options appear in the tray: 
 

 
3. In the Options section, choose any of the following options:  

o Twist specifies how many times the bridge should twist before it connects to the other 
side. 

o Segments defines the number of segments in the bridge. The default setting is 0, which 
adds no additional segments to the bridge. 

o Check the Invert option to reverse the direction of the twist. 

4. Click the Commit button to complete the bridging operation. 
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Working With Subdivision Surfaces 
When an object is modeled using a small number of polygons, its silhouette is often very rough and it is 
difficult to create smooth surfaces. If you use more polygons, it becomes more difficult to make changes 
to your model, due to the higher number of vertices. 

 
When you subdivide the surfaces of your model, you can continue to model a low-polygon model while 
viewing the result as if there are more polygons. Subdivision surfaces help you create smooth surfaces 
without increasing the number of control points of your model. With subdivision surfaces you can see, in 
real time, your final mesh as you edit its control points. The image below shows the same model as 
above but with subdivision surfaces set to 4. 

 
The Subdivision Surfaces can be applied to either a closed or an open polymesh. On an open polymesh, 
the resulting surface is smoothed along its edge and no distortions are created in respect to the rest of 
the surface. 
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Subdividing a Polymesh 

Subdivision is done in the model room after you select any portion of the model. 

To use subdivision surfaces: 

1. In the Assemble room, do one of the following to display the desired model in the Model room:  

• Double-click one of the facets on the polymesh you want to smooth. 

• Select the desired object in the Instances tab and switch to the Model room. 

2. Create a selection on the object to display options in the Model tab: Selection panel. 
 

 
3. In the Subdivision section, adjust the following settings as necessary:  

• None: Choose this option to turn off subdivision smoothing. 

• Smooth: Choose this option to enable subdivision smoothing. 
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• Modeling Level: Increase the modeling level until you add the desired amount of 
smoothing to your low-resolution mesh. 
 

NOTE! A high subdivision level can slow down modeling operations, so you 
should keep the level low while modeling and only turn it up once your object is finished. 

• Rendering Level: Increase the rendering level to achieve the desired amount of 
smoothing during rendering. 
 

NOTE! You can set the rendering level higher than the modeling level. 

• UV Subdivision: TBD 

• Convert: Click this button to convert the model to the number of polygons that are 
required to achieve the amount of detail in the current modeling level setting. Each 
incremental increase in the modeling level quadruples the number of polygons from the 
next lowest setting. For example, a model that contains 400 polygons would increase to 
1600 polygons at Modeling Level 1, 6400 polygons at Level 2, and 25600 polygons at 
Level 3. 

4. Displacement: TBD 

5. Symmetry: TBD 

6. Shading Domain: TBD 

Edge Creasing 

In the process of subdividing a polymesh, the smoothing of the edges has a primary importance. Creased 
edges will still display a sharp angle after the subdivision is applied. 

When an object such as a sphere is rendered, the individual polygons are shaded to appear smooth. In 
some cases, you do not want smooth shading:you might want an edge to represent a crease in the 
object's surface, such as an edge on an auto body. A crease separates regions that are flat or appear 
smoothly curved. 

 
Following is an example of a Subdivision applied to a cube with none, some or all of its edges smoothed. 
The resulting meshes are radically different and underline the importance of this parameter in the 
Subdivision Surfaces. 
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The Vertex modeler provides two different ways to smooth or crease edges on an object's surface: 

• Use the Model > Smooth Edges or Model > Crease Edges command to smooth or crease 
selected parts of an object. 

• Use the Crease tool to crease an edge so that it remains creased, regardless of how you 
redefine the object through subdivision. 
 

 
Creasing an edge will prevent it from being rendered as smooth or curved. In this example, the Crease 
tool was used to create the sharp ridges on the left side of the smoothed sphere. 

To smooth or crease selected edges: 

1. Select the edges you want to be rendered as smooth or creased. Creased edges are highlighted 
in yellow when selected. 

2. Do one of the following:  

• To smooth edges, choose Model > Smooth Edges. The Smooth Selected Edges dialog 
appears. 

• To crease edges, choose Model > Crease Edges. The Crease Selected Edges dialog 
appears. 

3. Enter a value in degrees for the crease angle.  

• For smoothing, any edges that meet at an angle greater than the crease angle will be 
rendered as smooth; any edges that meet at a lesser angle will be rendered as creased. 

• For creasing, any edges that meet at an angle less than the crease angle will be 
rendered as sharp; any edges that meet at a larger angle will be rendered as smooth. 

4. Click OK. 

To crease an edge: 

1. Click the Crease tool. 
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2. Select all edges you want to be rendered as straight. Creased edges will be highlighted in yellow 
when selected, in blue when deselected. 

To uncrease an edge: 

1. Click the Crease tool. 

2. Command/Ctrl +click all creased edges that you want to uncrease. 

Symmetrical Modeling 
When working with polymeshes in the Vertex modeler, a new Symmetry section in the Model tab allows 
you to make symmetrical modeling changes to your meshes. 

 
To use symmetrical modeling: 

1. Create a selection on the model that you want to model symmetrically. 

2. Check the Symmetry option to enable Symmetrical modeling. 

3. Select the axis of symmetry (X, Y, or Z) to display the correct symmetrical plane.: X (front to back), 
Y (side to side) or Z (top to bottom). 

4. Make the desired changes to your model. When Symmetrical modeling is enabled, any changes 
you make on one side of the axis will be repeated on the other side. 

5. When your symmetrical modeling is completed, uncheck the Symmetry option to resume normal 
modeling. 

Displacement Painting (Pro only) 
Carrara 6 includes a new displacement modeling feature in the Vertex modeler. This feature allows you to 
increase the detail in your model without increasing the geometry. The typical workflow is to take a model 
and paint your displacement using the Displacement Painting tool. After the displacement painting is done, 
you save the displacement map, which you later apply to the original model to restore the detail. 
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Showing, Hiding and Deleting Displacement  

By default, Carrara enables the Displacement option so that you can see changes you make while you 
paint with the Displacement Painting tool. You can enable or disable this display while you work so that 
you can compare the base model to the displaced model.  

To enable displacement: 

1. Select a model and open it in the Vertex modeler. 

2. Create a selection on the model to display the options in the Model tab: Selection panel. 

3. Do one of the following:  

• To enable displacement, check the Enable option in the Displacement section. 

• To turn displacement display off, uncheck the Enable option in the Displacement section. 

• To completely remove the displacement painting from the model, click the Delete button.  
 

 

Using the Displacement Painting Tool 

When you use displacement painting on a subdivided mesh, you can increase the number of subdivisions 
to increase the detail of the displacement painting. Checking the Symmetry option when available also 
applies the displacement symmetrically along the axis that you select. 

The Displacement Painting tool allows you to control the size and shape of the brush as you paint. There 
are also several different alpha images that can be used to add texture to your brush strokes. For 
example, the preceding figure shows the results of the Crackles alpha image being used to paint the hair, 
and the Horns alpha image used for the beard and eyebrows. 

To paint with the Displacement Painting tool: 

1. Select the model that you want to change. 

2. To enable the Selection options in the Model tab, switch to the Model room and make a selection 
using one of the following methods:  

• Choose Selection > Select By > Name to select a polymesh, polygon, edge, or vertex 
selection to which you have previously assigned a name. 
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• Choose Selection > Select By > Shading Domain to select all polygons that appear in 
a shading domain. Repeat the command to add to the selection. 

• Use the selection tools in the Properties tray to create a selection. 
 

 
3. Adjust the following settings in the Selection panel:  

• Use the Name field to assign a name to the current selection, if desired.  

• In the Subdivision section, select the Smooth option to enable subdivision smoothing. 

• Set Modeling Level to a high enough value to achieve the desired amount of detail while 
you paint your model.  

• Set Rendering Level equal to or greater than the Modeling Level so that you can view a 
rendered version of your displacement map on occasion. 

• Check the UV Subdivision option if you want to smooth the UVs with the surface. When 
checked, the UVs will be much smoother, but in some cases they may appear to slide 
over the surface. When not checked, the UVs of the original vertices will remain 
unchanged. They will follow the deformation of the original surface but may cause some 
perturbation in the UV map. 

• Click the Convert button to convert the model from the original low-polygon mesh to a 
higher polygon mesh based on the subdivision settings. For example, if the Subdivision 
Modeling Level is set to 2 before conversion, the converted model will have 16 times the 
number of polygons after conversion. Note also that converting the model will also make 
the displacement painting a permanent part of the mesh. You will not be able to delete 
displacement painting after a model is converted. 

• In the Displacement section, check the Enable option to display existing or new 
displacement while you paint. While in this mode, every transformation of the mesh 
(including point translations) is considered as displacement, so the original mesh is not 
modified. However, if a transformation is applied to the whole mesh (such as moving), the 
transformation is applied to the original mesh. 

• Click the Delete button to remove existing displacement painting from the model.  

• If you want to paint symmetrically, enable the Symmetry option and choose X (front to 
back), Y (left to right) or Z (top to bottom) symmetry plane. 
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4. Click the Displacement Painting tool in the toolbar.  

 

 
 
The options appear in the Properties tray. 
 

 
5. Choose a mode for painting:  

• Choose Displace to paint raised or lowered areas onto the mesh. Paint normally to raise 
areas, and press the Shift key while painting to lower areas. 

• Choose Smooth to soften the areas between the raised and lowered areas, to blend 
them together. 
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6. Set parameters for the brush as follows:  

• Increase or decrease the Size to displace wider or finer areas of the mesh. 

• Adjust the Strength of the brush to increase or decrease the amount of displacement you 
can achieve in a single stroke. 

• Increase or decrease the Hardness of the brush to create a brush that has less or more 
falloff around the edge of the brush. 

• Click the Alpha Mask button to select an alpha mask image that will be used to texture 
the brush. 
 

 
7. Paint on your model in the areas that you want to displace. Adjust brush size and strength while 

painting to achieve desired results. Press the Shift key while painting to displace the model 
inward instead of outward. 

Exporting Your Displacement Map 

After you have finished painting your displacement map, you can export the map for use on a similar 
model with the same UV maps and shading domains.  

Carrara allows you to generate displacement maps for each shading domain in your model, each of which 
can be a different size. The displacement maps are calculated relative to the UV coordinates. 

NOTE! You will need to create multiple maps if your object contains UVs that are overlapping. 

The Export Displacement Map dialog allows you to select a subdivision level, texture map size, and 
shading domain, and file location.  
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To export displacement maps: 

1. Displacement maps are calculated relative to the UV coordinates when they are created and 
exported. From the Model room, select the UV Map tab in the Properties tray. Verify that the 
Mapping option is set to Custom.. Any other UV mode will result in unexpected results.  

2. Choose Selection > Export Displacement Map. The Export Displacement Maps dialog appears. 
 

 
3. In the Export Options section, set the following options to determine the amount of displacement 

to be exported in the maps. Carrara outputs a grayscale image that increases the subdivision 
level based on the difference between the reference mesh and the export level. For example, if 
you have your Reference Mesh Subdivision Level at 0 and your Export Subdivision Level at 4, the 
resulting map will produce a 4-level change. If your Reference Mesh Subdivision Level is set to 1, 
and your Export Subdivision Level is set to 3, the resulting map will produce a 2-level change:  

• Reference Mesh Subdivision Level: Set this value to the subdivision level that will be 
set for your geometry. 

• Displaced: This option determines whether the displacement is calculated relative to the 
original mesh, instead of being relative to the selected reference level or relative to the 
displaced mesh. For example, if you want to export a displacement map for a DAZ or 
Poser figure, make sure that the option is unchecked to prevent changes to the number 
of polygons of the original mesh. If you are modeling your own object, it may be beneficial 
to check this option to obtain maximum precision on the final object when you export the 
base mesh with the displacement included. 
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• Export Subdivision Level: Set this value to the subdivision level that you want to arrive 
at by adding the displacement map. Normally, this will be equal to the level of subdivision 
that you used while painting the map. 

4. In the Maps section, you can create a displacement map for one or more shading domains in 
your model. Sizes can range from 64-pixel to 2048-pixel square texture maps. Do the following 
for each displacement map that you want to create and assign:  

• Click the Add button to choose a folder and assign a name for the displacement map in 
the Export Displacement Maps dialog.  

• Choose a file type from the Save as Type list. You have the option to save in 16-bit TIF 
format as well as other 8-bit image formats. 

• Click Save to store the information. 

• Choose the desired texture map size from the Size popup menu. 

5. In the Shading Domain section, click the texture button beside each shading domain that will 
use one of the displacement maps that you created in step 3. Choose the displacement map from 
the menu that appears. 

6. Click OK to export your displacement map or maps to the locations that you specified in step 3. 

7. To assign the displacement maps to an object, see "Displacement Mapping." 

Using Morph Targets (Standard, Pro) 
Morph targets are a powerful animation tool that allow you to define deformations to a Vertex Primitive 
and then animate the morph between the original object and the deformed version. For example, on a 
model of a face, you might define a morph target for the eyes blinking, another for the jaw opening, and 
another for the tongue moving. Then, when animating speech, it is easy to add all of these deformations 
in turn to provide realistic facial motion, without having to move the vertices by hand each time. 
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Defining a Morph Area 
The set of vertices on which Morph targets are defined is known as the Morph Area. You can create any 
number of Morph Areas, each with its own collection of Morph targets. 

To create a Morph Area: 

1. Open the model in the Vertex modeler. 

2. Click the Properties tray: Morph tab. 
 

 
3. Select the vertices of the object to be included in the Morph Area. 

4. Click the Create button. 

5. Assign a name for the morph area in the Current Area field and press Enter. 

To add or remove vertices from the Morph Area: 

1. Select the vertices that you want to add to a morph area. 

2. Choose Model > Add to Morph Area. 

3. A dialog prompts you to select the morph area that you want to modify. Highlight the morph area 
and click OK. 

To remove vertices from the Morph Area: 

1. Select the vertices that you want to remove from a morph area. 

2. Choose Model > Remove from Morph Area. 

3. If you have selected to remove all vertices from a morph area, a dialog informs you that some 
morph areas are not used any more and asks if you want to remove them. Choose Yes to 
remove the unused morph areas. A dialog prompts you to select the morph area that you want to 
modify. Highlight the morph area and click OK. 

Creating Morph Targets 
You can create multiple Morph targets on the Morph Area. These are the steps to create and edit a 
Morph target. 
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To create a Morph target: 

1. In the Model room, open the Properties tray: Morph tab. Select one of the Morph Areas that you 
created. The name of the selected morph area appears in the Current Area field. 

2. Press the Current Area menu button and choose Create Target from the pop-up menu. 
 

 
3. Enter a name for the morph in the New Target Name dialog and click OK. The new Morph target, 

with slider bar and Edit button, appears in the list.  
 

 

Editing Morph Targets 
After you create a morph area and add a morph target to it, you can modify the shape of the geometry to 
achieve the desired morphed shape. 

To edit a Morph target: 

1. Click the Edit button next to the Morph target's slider. The edges in the target being edited turn 
green while you are editing a Morph target. 
 

 
2. Move or rotate the vertices to their new positions. Note that you cannot edit vertices outside the 

current Morph Area while editing the Morph target. 
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3. After the morph is complete, click the Valid button in the Properties tray: Morph tab: Morph Target 

panel. This defines the Morph target deformation. 
 

 

Animating Morph Targets in the Model Room 
Morph targets can be animated from either the Modeling room or the Assembly room. In both cases, the 
Morph target sliders appear in the Properties tray and can be moved from 0 to 1 to control the degree to 
which the Morph target is applied. A value of 0 results in no change from the original mesh, while a value 
of 1 results in the Morph target being fully applied to the mesh. Changing a slider value inserts a 
keyframe with the new value at the current time on the Timeline. See "Animation Techniques." 

The Modeling room has two modes: 

 
• In Modeling Mode, Morph targets can be edited, but when you're not editing a Morph target, the 

mesh is displayed without any deformations applied. This mode lets you define multiple Morph 
targets, starting with a non-deformed mesh each time. 

• In Animation Mode, you can see the effects of Skinning and Morph targets on your mesh, 
allowing you to animate them conveniently. 
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To animate Morph targets in the Modeling room: 

1. Switch to Animation Mode by clicking the Animation button at the top of the Properties tray. 

2. Click on the Morph tab in the Properties tray. 

3. Select the Morph Area whose target you want to adjust from the list appearing under the Morph 
tab. 

4. Move the Morph target slider to the desired value. 
 

 

Animating Morph Targets in the Assemble Room 
It's generally most effective to animate Morph targets from the Assembly room, where you can see the 
changes to the Morph Area in context with the rest of your scene. 

To animate Morph targets in the Assembly room: 

1. Click on the Vertex object to be animated. 

2. Select the Properties tray: General tab. 

3. Select the Morph Area whose target you want to adjust from the list appearing in the Vertex 
object section of the Properties tray. 
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4. Move the desired Morph target slider or sliders to the desired value. 
 

 

Using Morph Targets on DAZ Studio/Poser Figures 
Many DAZ Studio and Poser figures are provided with a multitude of morphs that are used to modify the 
appearance and expression of the figures. You can create your own morph targets in addition to those 
that are provided. The process is very similar to those discussed in the previous sections, except that you 
can also export the morph target for use in applications such as DAZ Studio or Poser. 

Creating Figure Morph Targets 

To create a new morph target on a DAZ/Poser figure: 

1. From the Content tab, double-click the icon of the selected DAZ or Poser figure to load it into your 
scene in its default position. 

2. Select the figure and switch to the Model room. If you want to create symmetrical morphs, make a 
selection on the model. Check the Symmetry option in the Properties tray: Model tab: 
Selection panel, and select the X axis for symmetry. 
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3. Click the Morph tab to see a list of existing morphs in the Figure Morphs panel. 
 

 
4. From the Body Part list select Figure if you want to create a full body morph. Otherwise, select 

the body part that you want to morph from the Body Part list. 

5. If the selected body part has morphs that are arranged in multiple groups, select the group that 
you want the new morph to appear in. 

6. Click the Create .New Morph Target in Selected Group button. The New Target Name dialog 
appears. 

7. Enter a name for the new morph and click OK to continue.  
 

 
8. The new morph name appears at the bottom of the list in the morph group that you selected. 

Select the new morph name. 

9. Click the Edit Selected Morph Target button. The vertices associated with the selected body part 
turn green. 
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10. Select the vertices that you want to modify, and use the Move or Rotate tools to modify their 

positions. 
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11. When your changes are complete, click the Validate Changes to Morph Target button. 
 

 

Editing Figure Morph Targets 

To edit a morph target on a DAZ Studio/Poser figure: 

1. From the Content tab, double-click the icon of the selected DAZ or Poser figure to load it into your 
scene in its default position. 

2. Select the figure and switch to the Model room. 

3. Click the Morph tab to see a list of existing morphs in the Figure Morphs panel. 
 

 
4. From the Body Part list select Figure if you want to modify a full body morph. Otherwise, select 

the body part that uses the morph that you want to modify. 

5. Expand the Morph Target list to select the morph target that you want to modify. 

6. Click the Edit Selected Morph Target button. The morphed area turns green, and the object 
morphs to the target morph shape. 

7. Select the vertices that you want to modify, and use the Move or Rotate tools to modify their 
positions. 
 

NOTE! In order for morphs to be compatible with the original figures, you cannot make any 
changes to the geometry other than changing the positions of existing vertices. If you add or 
remove vertices to the original geometry, the morphs will not work because the number of 
vertices must be identical between the original model and the morphed version. 

8. When your changes are complete, click the Validate Changes to Morph Target button. The morph 
is saved, and the geometry reverts to its unmorphed shape. 
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Exporting Figure Morphs 

After you create or edit a morph target you can export an OBJ file so that you can apply the same morph 
to another figure. When Carrara exports the OBJ file it exports the full OBJ file, rather than the selected 
body part. Later you can reimport this morph and use it in another copy of the same figure. 

To export a morph target from Carrara: 

1. With the DAZ Studio or Poser figure open in the Model room, click the Morph tab to see a list of 
existing morphs in the Figure Morphs panel. 

2. From the Body Part list select the body part for which you want to export the morph. 
 

 
3. Expand the Morph Target list to select the morph target that you want to export. 

 

 
4. Click the Export Morph Target button. The Save As dialog appears. 

 

 
5. Locate the folder to which you want to save the OBJ file, and assign a name to the morph target. 

6. Click Save to export the complete OBJ file. 
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Importing Figure Morphs 

When you save morphed OBJ files you can later reimport the morphed file as a morph target when you 
use the same figure again. For example, if you create and save a morph for Victoria 4.1, you can import 
the morph target the next time you add Victoria 4.1 to a scene. 

To import a morph target into another version of the same figure: 

1. From the Content tab, double-click the icon of the selected DAZ or Poser figure to load it into your 
scene in its default position. 

2. Open the figure in the Model room. 

3. Click the Morph tab to see a list of existing morphs in the Figure Morphs panel. 

4. From the Body Part list select the body part for which the morph target was originally created. 
 

 
5. Expand the Morph Target list to select the category under which you want to import the morph 

target. 
 

 
6. Click the Import Morph Target button. The Open dialog appears. 

7. Locate the folder that contains the OBJ file for the morph target. Select the file and click Open. 

8. The New Target Name dialog displays the filename in the Name field. Rename the morph target, 
if desired, and click OK. The morph target appears at the bottom of the morph list in the selected 
category.  
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Vertex Modeling Techniques 
The Vertex Modeler provides several 2D and 3D objects from which you can begin the modeling process. 
After you add one or more of these objects, you can use standard modeling techniques to create objects 
that are more complex. 

Carrara’s Construction Tools (Standard, Pro) 
Carrara provides a number of different construction tools that assist with building objects in the Vertex 
Modeler. 

Extruding Cross-Sections 
Extruding or sweeping a polygon creates an object similar to that created with the Spline Modeler. You 
can use an open or closed polyline to define the cross-section of an extrusion or sweep. Using an open 
polyline as a cross-section creates a shell with the shape of the polyline. 

The cross-section can be a separate polyline object, or a set of selected edges in a larger object. 

There are two ways of extruding a cross-section: 

• Use "Dynamic Extrusions" to click and drag the cross section.. 
• Use a "Path Sweep" to sweep polylines along a path. 

Dynamic Extrusions 

The Dynamic Extrusion tool is a very easy and fast tool to create the rough shape of a model starting 
from a simple primitive or to add details to a particular part of a model after its creation. 

When several polygons or polylines are selected, they are all independently extruded following the 
extrusion of the last selected one. Very complex models can so be created with a simple click and drag 
action. 

The extrusion method can be chosen among the four available in the tool options of the Properties tray. 
There are several options that are common to the four extrusion modes. 

 
Dynamic Extrusion options in the Properties tray. 

• Link Polygons: Check this option to keep the adjacent polygons linked together during the 
extrusion. 

• Edge Extrude: Check this option to enable Edge Extrusion mode. This allows you to extrude 
edges into corners. 
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• Snap To Grid: Check this option to snap the extrusions to the grid. See "Changing the Grid" for 
further information on setting grid preferences. 

• Manual Offset: If you want to manually enter an offset value for the extrusion, enter it in the 
Manual Offset field in the tool options of the Properties tray. All the selected polylines will then be 
offset at this distance. 

The following sections provide further information on the four types of dynamic extrusions. 

Normal Extrusions 

Normal Extrusion creates an extrusion that is perpendicular to the original cross-section. The size of the 
extrusion can be different than the original cross-section. 

 
To create a Normal Extrusion: 

1. Select the polygon(s) that you want to extrude. 

2. Do one of the following:  

• Choose Construct > Extrude.  

• Click the Dynamic Extrusion tool. 
 

 
3. In the Extrusion Mode section of the Properties tray, choose the Normal Extrusion mode. 

 

 
4. Click and drag the polygons or polylines to be extruded.  

• Hold the Shift key down during the extrusion to constrain the extrusion to the plane of the 
original cross-section. 

• Hold the Command/Ctrl key down during the extrusion to constrain the size of the 
extrusion to the size of the original cross-section. 
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Parallel Extrusions 

Parallel Extrusion creates an extruded cross-section parallel to the original one, but with a rotation of its 
center. By default the size of the extruded cross-section is the same as the original one, and the rotation 
of the center is done in the active drawing plane.. 

 
To create a Parallel Extrusion: 

1. Select the polygon(s) that you want to extrude. 

2. Do one of the following:  

• Choose Construct > Extrude.  

• Click the Dynamic Extrusion tool. 
 

 
3. In the Extrusion Mode section of the Properties tray, choose the Parallel Extrusion mode. 

 

 
4. Click and drag the polygons to be extruded.  

• Hold the Shift key down during the extrusion to adjust the size of the extruded section. 

• Hold the Command/Ctrl key down during the extrusion to constrain the rotation in a 
plane that is perpendicular to the drawing plane. 

Irregular Extrusions 

Irregular Extrusion rotates the new cross-section from the original one. By default, the extruded cross-
section and the original cross-section have the same size. The rotation of the cross-section is done in the 
active drawing plane. Depending on the angle between the two cross-sections, the extrusion may appear 
to shrink. 
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To create an Irregular Extrusion: 

1. Select the polygon(s) that you want to extrude. 

2. Do one of the following:  

• Choose Construct > Extrude.  

• Click the Dynamic Extrusion tool. 
 

 
3. In the Extrusion Mode section of the Properties tray, choose the Irregular Extrusion mode. 

 

 
4. Click and drag the polygons to be extruded. 

• Hold the Shift key while extruding to set the size of the new cross-section. 

• Hold the Command/Ctrl key down during the extrusion to constrain the rotation in a 
plane perpendicular to the drawing plane. 

Regular Extrusions 

Regular Extrusion is similar to Irregular Extrusion with the difference here that the new cross-section is 
scaled so that the extrusion will appear to have a constant section, whatever the angle between the two 
cross-sections is. 
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To create a Regular Extrusion: 

1. Select the polygon(s) that you want to extrude. 

2. Do one of the following:  

• Choose Construct > Extrude.  

• Click the Dynamic Extrusion tool. 
 

 
3. In the Extrusion Mode section of the Properties tray, choose the Regular Extrusion mode. 

 

 
4. Click and drag the polygons to be extruded. 

• Hold the Shift key while extruding to fix the rotation of the extrusion. 

• Hold the Command/Ctrl key down during the extrusion to constrain the angle of rotation 
to preset limits. 

Path Sweep 

The Path Sweep tool uses the same principles as Dynamic Extrusion. However, the extrusions are made 
along a predefined path rather than by manually clicking and dragging the polylines and polygons to 
extrude. 

Like cross-sections, the sweep path can be defined by a separate polyline object or a set of selected 
edges of a larger object. The vertices of a sweep path do not have to lie on the same plane, allowing you 
to easily define complex 3D paths. 
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To sweep a cross-section: 

1. Create one or more cross-sections. For this, you can use the Polyline tool, select an existing 
polygon or closed polyline, or create a 2D primitive. 

2. Draw the sweep path with the Polyline tool, or select an existing polyline to use as the path. 
 

TIP! You may find it convenient to switch to a 2D view to create an extrusion path 
perpendicular to the cross-section. 

3. Select the cross-sections. You can also optionally select the path at this time. 

4. Do one of the following:  

• Choose Construct > Sweep. 

• Click the Path Sweep tool. 
 

 
5. Choose the sweep mode in the tool options of the Properties tray. There are 4 ways of sweeping 

a cross-section along a path:  

• Irregular Sweep The cross-section remains perpendicular to the sweep path and its size 
remains constant. 
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• Regular Sweep The cross-section remains perpendicular to the sweep path and its size 
is modified so that the section of the created volume is constant. 
 

 
• Parallel Sweep The cross-section remains parallel to the original one. 

 

 
• Envelope The cross-section remains parallel to the original one and is scaled to follow 

the path. In this mode, the position of the path relative to the original is very important 
since the distance between the path vertices and the cross-section determines the 
scaling value. 
 

 
6. If you want to use a group of polygons as a single cross-section, check the Link Polygons option 

in the tool options of the Properties tray. 
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Lathing with Polygon and Polyline Profiles 
When you lathe objects in the Vertex modeler, you control both the lathe profile and the lathe axis. The 
lathed object is created by revolving the profile around the specified axis. The lathe profile is always 
rotated a full 360 degrees around the axis. 

Both polylines and polygons can be used as lathe profiles. The lathe axis can by defined by any edge. 

To lathe an object: 

1. Create the lathe profile with the Polyline tool, or select a set of connected edges to use as the 
lathe profile. 
 

 
2. Select the profile that you want to lathe. 

3. Choose Construct > Lathe, or click the Lathe tool. If the profiles are open polylines, new edges 
will appear in red. These new edges can also be used as an axis for the lathing. 
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4. Select an edge to use as the axis. 
 

 
5. The lathed object appears in the workspace. You can increase or decrease the number of 

sections with the + or - keys, or by manually entering the number in the Number of Sections 
field in the Properties tray. 
 

 
6. Validate with Enter or Return. 

 

 

Lofting with Polyline Cross-Sections 
Lofting enables you to construct a surface over a series of cross-sections. In the Vertex modeler, the 
cross sections can have the following characteristics: 

• Cross-sections can be defined by open or closed polylines. 

• They can be separate polyline objects, or selected edges in a larger object. 

• You can define as many cross-sections for a single lofted object as you need, but you cannot mix 
open polylines and closed polylines. They must all be the same type. 
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• Cross-sections must lie on different planes. 

• In certain situations, not all of the cross-sections you define are used. This might happen if two of 
the cross-sections lie very close to the same plane; one of them is used and the other ignored. 

 

NOTE! Lofting can also be done using the Ruled Surface tool. 

To loft an object: 

1. Create the cross-sections with the Polyline tool or choose existing polylines to use as cross-
sections. 
 

 
2. Select the cross-sections. 

3. Choose Construct > Loft. 
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Creating Organic Models 
Complex models can be created very simply by using flat polygons and applying Organic functions to 
them. 

To create organic models: 

1. Create a filled polygon using one of the following tools:  

• 3D Rectangle or Oval. 

• 2D Polyline, with the Close option checked in the Properties tray. After the polyline is 
created, use the Model > Fill Polygon command to fill it. 

2. Select the filled polygon. 

3. Choose Construct > Organic. The polyline becomes a three-dimensional object. 
 

 

Ruled Surface 
The Ruled Surface tool is another way to create Lofted surface. It's ergonomics allows you to select each 
section curve so that you can choose which curve is connected to the current curve by hand. 

Sections curves must be all closed or all open. Closed curves must be empty (not filled). Polygon edges 
cannot be selected as section curves without being extracted first. 

To create a Ruled surface: 

1. Create the curves that you want to loft. 

2. Do one of the following:  

• Choose Construct > Ruled Surface. 
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• Select the Ruled Surface tool. 
 

 
3. Click on the first curve. It turns blue. 

4. Click each successive curve that you want to connect. The surface appears between each 
selected curve as you click. 

5. After you click the last curve, press Enter or Return to stop. 
 

 

Coons Surface 
The Coons Surface tool lets you create a surface between a closed curve, or several open curves 
connected together. 

This tool is very useful for the creation of complex shells, such as for a car hood when two profiles and 
two sections are necessary. Here we can see that it could be difficult to create such a complex form 
quickly. 

Using the Coons Surface tool, you can define a curve for the lateral part, one for the center, and one for 
the front, and finally another for the back. 

To create a Coons Surface: 

1. Create the curves to be used by the Coons Surface tool. Make sure each curve is connected on 
both ends so that the curves define a closed loop. 
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2. Do one of the following:  

• Choose Construct > Coons Surface. 

• Select the Coons Surface tool in the Surface modeling tab. 
 

 
3. Click on each of the curves with the Coons Surface tool. The selecting order is not important. 

4. Once all the connected curves are selected, the surface is automatically created. 
 

 

Gordon Surface 
The Gordon Surfaces tool is generally used in product design. It allows you to create complex surfaces 
based on very precise curves, like a custom bottle for example. The surface is defined by a series of 
latitudinal cross sections and longitudinal profiles. The cross-sections and profiles must be created before 
the use of this tool. 

NOTE! There is no Close option for the Gordon Surface tool. 

To create a Gordon surface: 
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1. Use any of the 2D vertex object tools to create the cross-sections for your model. You might find 
it easier to accomplish this while you view your scene in Four Views mode (Top, Left, Front, and 
Director’s Camera views). 
 

  
2. Select the Polyline tool. Profiles must be open shapes, so uncheck the Close option in the 

Properties tray if necessary.  
 

 
3. Create the profile shapes, connecting the cross-sections together. A small square appears beside 

the cursor when you hover over a connection point.  

4. Press Enter to complete each profile shape. Profiles are colored red while you create them. 
 

 
 

NOTE! Make sure that each point of a profile passes through a point on each of the cross-
sections. All sections and profiles must be connected, and the ends of the profiles must connect 
to the first and last cross-sections. Profiles cannot go past a cross-section. 

5. Click outside the shape to deselect all current selections. 
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6. Do one of the following:  

• Choose Construct > Gordon Surface. 

• Select the Gordon Surface tool. 
 

 
7. Select the cross-sections.  

8. Press Enter to complete the selection. The cross-sections turn from red to blue. 
 

 
9. Select the profiles, which are colored green during the selecting process. 
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10. Press Enter to complete the shape. 
 

 

NOTE! If your curves are not properly connected, Carrara generates the surface as best as 
possible. The results may not be satisfactory if points are missing. Undo the operation, verify your 
connections, and try again. 

Double Sweep Surface 
The Double Sweep tool lets you create a surface or volume from a section and two profiles connected to 
it. 

To create a Double Sweep surface: 

1. Create three curves: one cross-section curve and two profile curves. 
 

 
2. Do one of the following:  

• Choose Construct > Double Sweep. 

• Select the Double Sweep tool. 
 

 
3. Click the cross-section curve. It turns blue. 
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4. Click the two profile curves (in no particular order. Upon clicking the second profile, the surface is 
created. 
 

 

Using Boolean Operations 
Boolean operations are used to produce a complex object from two simpler objects. You can perform 
Boolean operations in the Vertex Modeler and the Spline modeler. 

Using Boolean operations enables you to quickly produce certain types of complex models. For example, 
suppose that you want to create a cylindrical hole through a sphere that originates on the top of the 
sphere and exits to the sphere's left side. 

Using normal modeling techniques, this would be nearly impossible, but with Boolean subtraction it's easy. 
It's just a matter of aligning a bent pipe and a sphere and then subtracting the two. 

Before you perform a Boolean operation, it is important to verify that the objects are aligned the way that 
you want them. Use the camera orientation controls and take advantage of the scene window's multiple 
views to look at the objects from a variety of viewpoints. You might also want to check the Properties tray 
to verify the location of the objects. 

There are three types of Boolean operations. In order to perform them, two objects have to be arranged 
as follows: 

• You must have two overlapping objects. 

• Both objects should be closed. Holes in the surface of a volume can prevent Boolean operations 
from producing the desired results. 

Note When you perform a Boolean operation on two objects, a single object is produced with its own UV 
coordinates, so be sure that shading is applied the way you want it. 

The Boolean tool can perform the three most commonly used operations (Union, Intersection and 
Subtraction), and it can also create all the possible operations such as the closed intersections, open 
intersections, intersection lines, and so on. 

 
There are 12 possible combinations, accessible in the property panel, either by clicking on the chosen 
icon, or by using the +/- keys to cycle through the choices. 
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Boolean Unions 
The union of two objects is an object whose surface encompasses the visible surfaces of both objects. 
For example, if you spray-paint two overlapping spheres, the painted surface represents the union of the 
two spheres. 

To join two objects with the Boolean Union command: 

1. Align the objects that you want to join. 

2. Double-click to select the first object that you want to join. 

3. Press the Shift key while you double-click the second object to join. 

4. Choose Construct > Boolean > Boolean Union. 

5. Rename the resulting object if you like. 

To join two objects with the Boolean tool: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the first object that you want to join. 

4. Click on the second object. A Boolean operation is performed and a result is displayed. 

5. Use the cursor or the +/- keys on your keyboard to select Union from the Operation section in the 
Properties tray. 
 

 
6. Rename the resulting object if you like. 

Boolean Intersections 
If you take the intersection of two objects, the resulting object is the volume shared by both objects. 
Carrara provides a number of different ways that you can intersect two objects: 

NOTE! In the examples below, the smaller cylinder is object 1 and the larger is object 2. 

Intersection 

To intersect two objects with the Boolean Intersection command: 

1. Align the objects that you want to intersect. 

2. Double-click to select the first object that you want to join. 
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3. Press the Shift key while you double-click the second object to join. 
 

 
4. Choose Construct > Boolean > Boolean Intersection. The intersection object is created. 

 

 
5. Rename the resulting object if you like. 

To intersect two objects with the Boolean tool: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the first object that you want to intersect. 

4. Click on the second object. A Boolean operation is performed and a result is displayed. 

5. Use the +/- keys on your keyboard or click to select Intersection from the Operation section in 
the Properties tray. 
 

 
6. Rename the resulting object if you like. 
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Surface 1 Intersects Volume 2 

To intersect surface 1 with volume 2: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the first object that you want to intersect. 

4. Click on the second object. A Boolean operation is performed and a result is displayed. 

5. Use the +/- keys on your keyboard or click to select Surf1 Inter Vol2 from the Operation section 
in the Properties tray. 
 

 
6. Rename the resulting object if you like. 

 

 

Surface 2 Intersects Volume 1 

To intersect surface 1 with volume 2: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the first object that you want to intersect. 

4. Click on the second object. A Boolean operation is performed and a result is displayed. 

5. Use the +/- keys on your keyboard or click to select Surf2 Inter Vol1 from the Operation section 
in the Properties tray. 
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6. Rename the resulting object if you like. 

 

 

Surface 1 Intersects Surface 2 

To intersect surface 1 with surface 2: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the first object that you want to intersect. 

4. Click on the second object. The Boolean intersection is created.  

5. Use the +/- keys on your keyboard or click to select Surf2 Inter Vol1 from the Operation section 
in the Properties tray. 
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6. Rename the resulting object if you like. 
 

 

Boolean Subtractions 

Boolean Subtractions 

Boolean subtraction is similar to the concept of compounding shapes in the Spline modeler. However, 
compounding shapes only enables you to create holes through extruded objects. Boolean subtraction 
enables you to work directly with 3D objects and remove overlapping volumes. 

To subtract one object from another with the Boolean Subtraction command: 

1. Align the objects that you want to intersect. 

2. Double-click to select the first object that you want to join. 

3. Press the Shift key while you double-click the second object to join. 
 

 
4. Press the Cmd/Ctrl+Alt keys while you click a point on the polymesh that represents the object 

you want to subtract from. The selected point turns yellow. 
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5. Choose Construct > Boolean > Boolean Subtraction. The intersection object is created. 
 

 
6. Rename the resulting object if you like. 

Additional subtraction options are also provided. Refer to the following sections for variations on the 
Boolean Subtraction options. 

Volume 2 Cut by Volume 1 

To cut volume 2 by volume 1: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the object that will be used to cut an area from the second object (Volume 1). 

4. Click the object that the area will be cut from (Volume 2). The Boolean object is created. 

5. Use the +/- keys on your keyboard or click to select Vol2 Cut by Vol1 from the Operation section 
in the Properties tray. 
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6. Rename the resulting object if you like. 
 

 

Volume 1 Cut by Volume 2 

To cut volume 1 by volume 2: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the object that the area will be cut from (Volume 1). 

4. Click the object that will be used to cut an area from your first selection (Volume 2). The Boolean 
object is created. 
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5. Use the +/- keys on your keyboard or click to select Vol1 Cut by Vol2 from the Operation section 
in the Properties tray. 
 

 
6. Rename the resulting object if you like. 

 

 

Surface 1 Cut by Volume 2 

To cut surface 1 by volume 2: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click to select the object that the surface will be cut from (Surface 1). 

4. Click the object that will be used to cut the area from your first selection (Volume 2). The Boolean 
object is created. 

5. Use the +/- keys on your keyboard or click to select Surf1 Cut by Vol2 from the Operation 
section in the Properties tray. 
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6. Rename the resulting object if you like. 
 

 

Surface 2 Cut by Volume 1 

To cut surface 2 by volume 1: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click the object that will be used to cut the area from your first selection (Volume 1).  

4. Click to select the object that the surface will be cut from (Surface 2). The Boolean object is 
created. 

5. Use the +/- keys on your keyboard or click to select Surf2 Cut by Vol1 from the Operation 
section in the Properties tray. 
 

 
6. Rename the resulting object if you like. 
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All Parts 

To keep all parts of the Boolean intersection: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click the first object for the Boolean operation.  

4. Click the second object. The Boolean object is created. 

5. Use the +/- keys on your keyboard or click to select All Parts from the Operation section in the 
Properties tray. 
 

 
6. Rename the resulting objects if you like. 

 

 

All Parts of Object 2 

To keep all parts of the second object: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click the first object for the Boolean operation.  

4. Click the second object. The Boolean object is created. 

5. Use the +/- keys on your keyboard or click to select All Parts of Obj2 from the Operation section 
in the Properties tray. 
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6. Rename the resulting objects if you like. 

 

 
The resulting Boolean operation, with parts moved for demonstration. 

All Parts of Object 1 

To keep all parts of the second object: 

1. Align and select the objects that you want to join. 

2. Click the Boolean tool. 
 

 
3. Click the first object for the Boolean operation.  

4. Click the second object. The Boolean object is created. 

5. Use the +/- keys on your keyboard or click to select All Parts of Obj1 from the Operation section 
in the Properties tray. 
 

 
6. Rename the resulting objects if you like. 

 © 2008 DAZ 3D, Inc. 287 



Carrara 7 11 December 2008 

Using the Cut Tool (Standard, Pro) 
The Cut tool is very similar to the Boolean tool in that it allows you to punch a volume with a polyline or a 
curve. 

NOTE! When you perform a Boolean operation, you lose the UV coordinates of the original objects 
and surface shading can become more complex. 

The Cut tool can be used to punch a volume with a polyline or a curve. 

To cut an object with a line: 

1. Draw the line that must cut the object. If the line has more than three points defining a plane, the 
cut will take this plane as the reference plane for cutting. The curve will be projected 
perpendicularly to that plane. Otherwise, the current active plane is used. 

2. Select the object to cut. 

3. Select the Cut tool. 

4. Click on the line. 

5. The Boolean operation is performed and a first result is displayed. 

6. Click on the operator icon in the property tray or use the +/- keys to select the operation required. 

7. Hit Return to stop. 

Spline Modeling Overview (Standard, Pro) 
The Spline modeler in Carrara lets you create objects by converting 2D shapes into 3D objects. You use 
the Spline modeler tools to draw 2D shapes, known as cross-sections, and then convert them to 3D 
objects by extruding them. Once you've created a 3D object, you can refine its shape using an extrusion 
envelope. This chapter covers spline modeling concepts and describes how to use the Spline modeler. 

Spline Modeling Concepts 
The Spline modeler is based on a concept called extrusion. You create an object by drawing a 2D shape, 
then drawing a path perpendicular to the shape. Carrara extrudes the shape along the path to form a 3D 
object. 
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Straight Extrusion 
Straight extrusion is the most basic type of spline modeling. In a straight extrusion, a 2D shape is placed 
on a cross-section and swept along a straight sweep path, creating a "cookie cutter" effect. 

 
The cross-section doesn't have to consist of a single 2D shape:it can consist of several distinct shapes. 
You can even create an object with a hole in it by extruding a shape along a compound path. For more 
information on extrusions, refer to "Cross-Sections and the Sweep Path." 

Scaling 
You can also shape objects by changing the scale of the 2D shape as it's extruded along the sweep path. 

 
Simply changing the scale of a shape produces very basic shapes, but when combined with an extrusion 
envelope, you can create a much wider variety of objects. For more information on scaling, refer to 
"Understanding the Envelope". 

 

Lathing 
You can model many symmetrical objects using a technique known as lathing. Carrara creates lathed 
objects by extruding a lathe profile around a sweep path. You can think of the lathe profile as the outline 
of the object when it's cut in half. For more information on lathing, refer to "Lathing with the Extrusion 
Envelope." 
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Cross-Sections 
Cross-sections are 2D shapes that act as the skeleton of your object. The Spline modeler extrudes from 
each cross-section to the next, basing the contours of the object's surface on the shapes in the cross-
sections. 

 
This modeling technique is sometimes referred to as skinning:the Spline modeler stretches a "skin" over 
the shapes in the cross-sections. 

 
Each cross-section can have any number of 2D shapes. However, the more shapes you add, the more 
complicated your extrusion gets. 
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For more information on cross-sections, refer to "Working with Cross-Sections." 

Complex Sweep Paths 
The sweep path determines the shape and size of the extrusion. A straight sweep path creates a straight 
object; a more complex sweep path creates objects with bends and curves. 

 
The Spline modeler allows you to draw a true 3D sweep path, meaning it can be adjusted in the X, Y, and 
Z axes. You can also close the sweep path to create a continuous object like a chain link. Carrara also 
supplies tools for automatically creating complex sweep paths like spirals. For more information on 
working with the sweep path, refer to "Drawing a Sweep Path in 3D." 

 
For a mini-tutorial on creating different types of spirals, refer to "Tutorial: Spirals." 

Choosing a Spline Modeling Technique 
The Spline modeler offers several ways of creating spline objects:lathing and skinning between different 
2D shapes, to name two. You must decide which technique is best suited for your object before you begin 
modeling. 

An easy way of determining which technique you must use is to take an imaginary knife and cut your 
object into slices. The slices you end up with will tell you which technique you should use. 
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If you get identical shapes, use straight extrusion. If you get congruent shapes that differ only in size, use 
an extrusion envelope. 

 
If shapes vary dramatically in size and geometry, you must use a more complex modeling technique. Use 
lathing if the shapes are symmetrical. If not, use shape numbering and multiple cross-sections. 

 

The Spline Modeling Window 
The Spline modeling window defines the drawing environment and provides you with planes for drawing 
sweep paths, cross-sections, and extrusion envelopes. 

 
When you are using the Spline modeler, the Spline modeling window opens, new menu commands are 
available, different tool sets appear, and the Properties tray describes your object. Your view switches to 
a close-up view of your object. 

In addition, the Scene Preview window shows how your object will look in the Assemble room. 

As with the Assemble room, the Spline modeling room provides up to four separate panes, each offering 
a different view of your object. 
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The Spline Modeler 3D View 
The Spline modeler's 3D view shows a working box (also known as the Modeling box) that contains the 
features for creating cross-sections and paths. 

 
The Drawing plane is highlighted as a darker shade. By default, each side of the working box measures 
14 inches, with a grid line drawn every inch. For information on changing these dimensions, refer to 
"Resizing the Modeling Box." 

You can move and rotate the working box along with the object to get a better view of your work. You can 
also resize the working box and choose whether to resize the object along with it. 

The Drawing Plane 
The Drawing plane is the plane you're currently working on, whether you're drawing a shape, adjusting a 
sweep path, or viewing your object. In 3D view, the Drawing plane is highlighted as a darker shade. 

.  

Cross-Section Planes 
The cross-section planes are where you create the 2D cross-sections that make up the skeleton of your 
object. You use the Spline primitives and drawing tools to draw and edit shapes on the cross-section 
planes. 

A cross-section plane contains only one cross-section, which can consist of any number of 2D shapes. 
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For more information on cross-sections and cross-section planes, refer to "Working with Cross-Sections." 

The Sweep Path 

The sweep path, also known as the extrusion path, is the path along which cross-section shapes are 
extruded. The path is indicated by two lines that appear on the bottom and side walls of the working box. 

 
You can think of these lines as horizontal and vertical projections of the same sweep path. They let you 
edit the sweep path in both the XY and YZ plane. You can draw a sweep path of any shape or angle 
including curved, straight, or closed paths. 

For more information on the sweep path, refer to "Working with the Sweep Path." 
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The Extrusion Envelope 

The extrusion envelope lets you control the curvature of the 3D object around (as opposed to along) its 
sweep path. You do this by scaling the object's cross-sections. You can scale cross-section shapes 
symmetrically or asymmetrically. 

 
Carrara does not display the envelope when you first open the Spline modeling window. You add it using 
one of the Extrusion Envelope commands in the Geometry menu. It is indicated by four Bézier curves, 
two on each sweep path plane. Separate colors are assigned to the YZ and XY plane. Corresponding 
colored dots appear on the cross-section plane indicating where these curves cut through it. You can 
scale the object's cross-sections by editing these Bézier curves. 

For more information on the extrusion envelope, refer to "Using the Extrusion Envelope." 

Setting Preferences for the Spline Modeler 
In the Spline modeler's Preferences dialog you can set preferences for the grid, for naming objects, and 
for resizing shapes and groups of shapes. 

To set preferences for the Spline Modeling window: 

1. Choose File > Preferences. The Preferences dialog appears. 

2. Click the menu and choose Spline modeler from the list. 
 

 
3. Set the following options as needed The options that you can set are as follows:  

• Resize Shapes And Groups specifies whether an object is resized from its center or 
from its opposite corner when you resize by dragging. 
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• Grid Settings specifies grid settings for the Spline modeler. 

• Spacing adjusts the spacing between grid lines in the box and specifies units of measure. 

• Draw a line every controls how often grid lines are drawn. 

• Show toggles the display of grid lines. 

• Snap to causes objects to "snap" to the nearest grid line as you drag them. 

• Colors lets you set up a specific color scheme for the Modeling box. When you click a 
color swatch, the Color Picker appears. Refer to "Color Pickers" for more on choosing 
colors. 

• Show 3D Object in Preset 2D Views lets you display the 3D object even in the preset 
2D views such as Front, Top, and Left. 

4. Once all options have been set, click on OK.  

Opening the Spline Modeling Window 
You open the Spline modeling window by doing one of the following: 

• Double-click the object in the Sequencer or the scene window. 

• Select a spline object, then click the Model button. 
 

 
• If you're creating a new spline object, the modeling window opens automatically. 

When you're finished modeling, you can save your changes and enter a different room by clicking the 
appropriate room button. 

NOTE! To avoid the memory-consuming accumulation of windows, always close the modeling 
window when you are finished modeling. 

To create a new spline object: 

1. Open or create a document in the Assemble room. (For more information, refer to "Creating an 
Empty Scene.") 

2. Depending on the desired location of the spline object, do one of the following: 

• To insert a spline object of default size at the center of the universe, choose Insert > 
Spline Object or drag the Spline Object tool into the Sequencer. 

• To insert a spline object in any other location, drag the Spline Object tool into the scene 
window, to any location  
 

 
• To insert a spline object of a specific size, select the Spline Object tool, then click and 

drag anywhere in the scene window. 
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Working with the Modeling Window 
As with the document window, the Spline modeling window can simultaneously display up to four 
separate panes. Each pane gives you a different view of your object. 

You can work in any view you want. For instance, you might find it convenient to work in a 2D view when 
drawing a sweep or extrusion path, then switch to the 3D view when you want to work in 3D. To work in a 
different view, simply click in the pane. 

NOTE! Use the "Show 3D Object in Preset 2D Views" option in the Spline modeler Preferences 
dialog to hide or show your object in the isometric views of the modeler (Front, Left, Current Section...). 

To make your work flow easier, you can change different features of the Spline modeling window: 

• Change the display and behavior of the grid. For more information, refer to "Setting Preferences 
for the Spline Modeler." 

• Resize the Modeling box. 

Resizing the Modeling Box 

The Modeling box opens at a scale consistent with the proportions of objects in the scene. If you want to 
work with an object at some other scale, you can reset the Modeling box's size. You also have the option 
to resize the object along with the box. 

To set Modeling Box and object size: 

1. Choose Geometry > Modeling Box Size. The Modeling Box Size dialog appears. 
 

 
2. Set the options you want: 

• Box Size sets the length of one side of the (square) Modeling box. 

• Scale object with Modeling Box resizes the object along with the Modeling box. 

3. Click OK. 
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Changing Your Point of View 
Without changing your point of view to examine an object from all sides, it can be difficult to determine its 
position relative to other objects in the model. When you perform a operation such as subtraction, this is 
particularly important:you must be sure the objects are actually overlapping for it to work. 

You can dolly, zoom, bank, and track the Director's Camera using the camera controls. 

 
You can also pan and zoom the view in 2D using the pan and zoom controls. For information on using 
these controls, refer to "2D View Tools." 

 
You can also use the camera list in the upper left corner of the Spline modeling window to switch among 
the Director's Camera (3D view) and isometric views of the working box's sides. For information on using 
these controls, refer to "Camera Navigation." 

 

Previewing Objects 
You can preview objects in the Spline Modeling window at seven different levels of quality. 

For more information on the Preview modes, refer to "Choosing a Preview Mode." 
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Spline Modeling Tools and Techniques 
(Standard, Pro) 

Creating Shapes and Objects 
To create spline objects, you create cross-sections and extrusion paths on the appropriate planes in the 
Spline Modeling window. 

All 2D shapes and paths you draw in the Spline modeler are Bézier curves. A Bézier curve is an 
interpolated curve whose shape is determined by the relative positions of its vertices and control points. 
vertices and Each segment of a Bézier curve connects two vertices. The control points (handles) 
extending from each vertex determine the curvature of the path segments. 

 
Carrara's drawing tools are similar to those found in traditional Bézier-based 2D drawing applications. The 
drawing tools enable you to create curves and shapes, and to edit and modify those shapes point-by-
point. 

Working on the Drawing Plane 
This section discusses tools and techniques you'll need when creating objects in the Spline modeler. 

Inserting Primitive Shapes 
The most basic way to create an object in the Spline modeler is to start with a 2D primitive shape. 

 
You can place a rectangle, rounded rectangle, ellipse, or polygon on a cross-section plane and then apply 
a spline modeling technique such as extrusion or sweeping. 
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After creating a shape with one of the Spline Primitive tools, you will not immediately be able to edit its 
points:you must ungroup it first. For more information, refer to "Grouping Shapes." 

To insert a rectangular shape: 

1. Click the Spline Primitive tool and choose the Rectangular Shape tool. 
 

 
2. On the Drawing plane, drag from one corner of the shape to the opposite corner. Release the 

mouse button when the shape is the desired size. 

3. To create a square, choose the rectangle shape and hold down the Shift key while dragging. 

To insert a circular shape: 

1. Click the Spline Primitive tool and choose the Circular Shape tool. 
 

 
2. Drag on the Drawing plane. 

3. To create a circle, choose the ellipse shape and hold down the Shift key while dragging. 

To insert a rounded rectangle shape: 

1. Click the Spline Primitive tool and choose the Rounded Rectangle Shape tool. 
 

 
2. Drag on the Drawing plane. The Round Rectangle dialog appears. 

 

 
3. Set the curvature on the corners and click OK. 

4. To create a square with rounded corners, hold down the Shift key while dragging. 

To insert a polygonal shape: 

1. Click the Spline Primitive tool and choose the Polygon Shape tool. 
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2. Drag on the Drawing plane. The Number of Sides dialog appears. 
 

 
3. Set the number of sides for the polygon and click OK. 

4. To keep all angles equal, hold down the Shift key while dragging. 

Drawing Shapes 
You can create open and closed paths of any shape you like with the Pen tool. 

 
The Pen tool works in two ways: you can click and drag to draw curves, or you can add one point at a 
time like playing connect the dots. As you add points, Carrara connects them by drawing segments. 

Points are classified as either corner points or curve points: 

• A curve point's handles are bound together, creating a straight tangent for the path and resulting 
in a smooth curve. 

• A corner point's handles can move independently of one another or retract them completely, 
allowing you to create abrupt changes in the direction of the path. 

 
To use the Properties tray to transform shapes you create with the Pen tool, you must group them first. 
For information on grouping shapes, refer to "Grouping Shapes." For information on setting object 
properties, refer to "Setting Object Properties." 

To draw a new path: 

1. Deselect all existing paths and shapes by clicking in an empty area of the Drawing plane with the 
Selection tool. 

2. Click the Pen tool. 

3. Click anywhere on the Drawing plane to start the new path with a corner point. Or, drag to start 
with a curve point. 

4. Click or drag to add each subsequent point. As you add each point, Carrara draws the segments 
to connect the path. 
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To add a corner point: 

1. Choose the Pen tool. 

2. Click (do not drag) at a point on the Drawing plane. 

3. Hold down the Shift key to draw the path in 45° increments. 

To add a curve point: 

1. Choose the Pen tool. 

2. Drag the Pen tool at a point on the Drawing plane. As you drag, a pair of handles extends from 
the point. By default, each pair of handles is bound together, creating a curve point:the two 
handles remain parallel to one another.  

• Hold down the Shift key while dragging to move the handles in 45° increments. 

• Hold down the Option/Alt key while dragging to break apart a pair of handles, creating a 
corner point. You can then move each handle independently. Continue to hold the 
Option/Alt key down while dragging. If you release the key before releasing the mouse 
button, the handles snap back together. 

When you click a curve handle, the handles extending from the point will move independently. 

To close a path: 

• With the Pen tool, click the first point you added. 

Editing Shapes 
You can edit custom or primitive shapes and paths in the following ways: 

• Add and delete points 

• Delete segments 

• Convert corner and curve points 

• Move points 

• Adjust curves 

To view all points on a path or shape: 

1. Click the Selection tool. 

2. Click a path or shape. 

3. All the points on the curve become visible, but none are individually selected. A point appears 
black when it is selected and white when it is deselected.  

• Hold down the Shift key, then click additional paths to view the points on multiple paths. 

• Hold down the Shift key, then click a path whose points are visible to make them invisible. 

• Click in an empty area of the Drawing plane to make all points invisible. 

To select points one at a time: 

1. Click the Selection tool. 

2. Click a point on a path or shape to select it. 

3. The point color changes from white to black and its handles, if it has any, become visible.  

• Hold down the Shift key, then click additional points to increase your selection. 
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• Hold down the Command/Control key, then click a path to select all the points on the path. 
Or, double-click the path. 

• Hold down the Shift key, then click a selected point to deselect it. 

• Click in an empty area of the Drawing plane to deselect all points. 

To select points by dragging: 

1. Click the Selection tool. 

2. Drag a marquee around the points you want to select. 

To add points to either end of an open path: 

1. Select one of the endpoints of an open path with the Selection tool. 

2. Click the Pen tool. 

3. Click or drag to add the next point. Carrara draws a segment to continue the path to the new point. 

4. Continue adding points until you're satisfied with the path. 

To add a point between two existing points: 

1. Click the Add Point tool. 
 

 
2. Click anywhere on a path or shape. Carrara determines whether to add a corner point or a curve 

point, depending on the shape of the path. The new point is automatically selected so it can be 
moved with the Selection tool. 

3. When you add a point to the sweep path, you can simultaneously add a cross-section plane at 
that point:just hold down the Option/Alt key as you click. 

To delete a point: 

1. Click the Delete Point tool. 
 

 
2. Click a point on a shape or path.  

• When you delete a point in the middle of a path, the points on either side of the deleted 
point become connected by a new segment, changing the shape of the path. 

• When you delete the endpoint of an open path, the last path segment disappears, leaving 
a new endpoint. 

• If you delete a point on the sweep path, any cross-section associated with that point is 
deleted as well. 

To delete a segment: 

1. Click the Delete Point tool. 

2. Click a path segment on a shape. Removing a path segment leaves adjacent path segments 
unchanged. When you delete a path segment from a closed path, the path becomes an open 
path. 

When you delete a path segment from an open path, the path is split into two separate open paths. 

Note The delete segment feature applies to cross-section shapes only:you cannot delete a segment from 
the sweep path or the extrusion envelope. 
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To convert a corner point to a curve point: 

• Click the Convert Point tool. 
 

 
To convert a corner point to a curve point: 

1. Click the Convert Point tool. 
 

 
2. Drag a point on a shape or path. As you drag, a pair of handles extends from the point. 

To convert a curve point to a corner point using the tools: 

1. Choose the Convert Point tool. 

2. Click a curve point on a shape or path. The point's handles retract. 

To convert a curve point to a corner point using the Properties tray: 

1. Select a point on a cross-section plane. 

2. You can only use the Properties tray controls for points on a cross-section plane. 

3. In the Properties tray, click either the Corner Point or Smooth Point button. 

To move points: 

1. Click the Selection tool. 

2. Select the points you want to move. To move an entire path, select all the points on the path. 

3. Drag the selected points to a new location.  

• Hold down the Shift key while you drag to move the points in 45° increments. 

• You can also move points in cross-sections in the Properties tray. Select a point and 
enter values for X and Y. 

• All selected points move together. As you drag, Carrara redraws the path segments 
affected by the move. 

To adjust a curve interactively: 

1. Click the Selection tool. 

2. Click a point on a path or shape to select it. 

3. Drag the point's handles.  

4. As you drag, Carrara redraws the curve.  

• When you move a curve point handle, the opposite handle moves to remain parallel to 
the one you are moving. 

• Hold down the Shift key while you drag to move the handle in 45° increments. 

• Hold down the Option/Alt key while you drag to break apart a pair of parallel handles. You 
can then move each handle independently. 

To adjust a curve numerically: 

1. Select a point on a cross-section plane. You can only use the Properties tray controls for points 
on a cross-section plane. 
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2. In the Properties tray, enter values for Next and Previous Control Handle. 
 

 
The Next and Previous Control Handle identify the two control points for the selected vertex. The Next 
and Previous Controls are relative to the selected control point, based on the order in which points were 
drawn. 

 
The curve above shows the order in which points were added. Using this order, the Next Control Handle 
would be to the right of the selected vertex and the Previous Control Handle would be to the left. 

 
Here the order is reversed so the Next Control Handle would be to the left of the selected point and the 
Previous Control Handle would be to the right. 

The dx and dy values refer to the distance from the selected vertex along the X and Y axis. 

Breaking Apart Text Objects 
Once you have created text, you can break the text object into individual characters, which you can 
reposition, rotate, and continue modeling like any other object. 
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To break apart a text object: 

1. Select the text object. 

2. Select Arrange > Convert Text to Outlines. The letters are separated into discrete cross-
section shapes on the Drawing plane. 

Working with Shapes 
Working on the Drawing plane, you can manipulate shapes and cross-sections in several ways: 

• Perform simple operations such as changing the scale, position, and orientation of individual 
shapes. 

• Group shapes in a cross-section to edit them together. 

• Compound the shapes on a cross-section to hollow out a 3D object. 

This section includes general instructions for working on the Drawing plane. For specific information on 
cross-sections and sweep paths and how they relate, refer to "Working with Cross-Sections" and 
"Working with the Sweep Path." 

Importing 2D Shapes 
Carrara lets you import cross-section shapes, sweep paths, and envelopes in Adobe Illustrator or EPS 
format. The file can include one or several 2D shapes. You should, however, avoid unnecessary 
complexity. 

Some information from the imported file will be translated or lost: 

• Paint characteristics such as stroke and fill are ignored. 

• Compound paths are preserved. 

• Text is automatically converted to outlines. 

For more information on importing files, refer to "Importing 3D Objects." 

To import shapes to a cross-section: 

1. Click the cross-section plane you want to work with. You can also create a new cross-section 
plane using Sections > Create. 

2. Choose File > Import. The Import dialog appears. 

3. In the dialog, select the file you want, then click Open. Carrara places the artwork on the Drawing 
plane. 

4. Click OK. 

To import a shape as a sweep path or envelope: 

1. Choose Geometry > Extrusion Envelope to turn on the extrusion envelope. You can use any 
type of envelope. 

2. Click one of the sweep path planes to make it the Drawing plane. 

3. Choose File > Import. The Import dialog appears. 

4. Select the file you want, then click Open.  

• If the file you choose contains more than one path, only the first path will be imported. 
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• Another dialog appears, allowing you to specify whether the path should be used as the 
sweep path or the envelope. 

5. Specify sweep path or envelope. 

6. Click OK. Carrara imports the sweep path or envelope. 

NOTE! Importing a sweep path or envelope replaces the current sweep path and envelope. 

Grouping Shapes 
You can group one or more shapes using the Group command. Grouping two or more shapes lets you 
manipulate them all at once.  

NOTE! Grouping is allowed only on cross-section planes, not the sweep path. 

To group shapes: 

1. Select the shape(s) you want to group. 

2. Choose Edit > Group. A bounding box encompassing the grouped shapes indicates the size and 
location of the group. 

To ungroup: 

1. Select the group you want to ungroup. 

2. Choose Edit > Ungroup. 

Scaling Shapes 
You can scale a shape or group of shapes directly by using the Resize tool, or numerically by using the 
Scale dialog. For information on using the Resize tool to scale objects, refer to "3D Object Manipulation 
Tools." 

NOTE! Scaling is allowed only on cross-section planes, not the sweep path. 

You can also scale an entire object by scaling the Modeling box. Refer to "Resizing the Modeling Box." 

Scaling shapes directly is not always necessary. The extrusion envelope, described in "Using the 
Extrusion Envelope," can often accomplish the same results more simply and powerfully. 

To scale shapes numerically: 

1. If necessary, group the curves or shapes you want to resize. 

2. Choose Arrange > Scale. The Scale dialog appears. 
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3. Enter horizontal and vertical scale factors. 

4. Click OK. 

Moving Shapes 
You can move shapes using standard dragging techniques. 

To move shapes manually: 

1. If necessary, group the curves or shapes you want to move. 

2. Click the Selection tool. 

3. Drag the shape wherever you like. 

To move shapes numerically: 

1. With the Selection tool, click the shape. 

2. In the Properties tray, enter values in the top and left fields. Shape position is measured relative 
to the top and left edge of the Drawing Plane. 

Rotating Shapes 
You can rotate an object in two ways: 

• Free rotate an object in relation to the Drawing plane (2D rotation). 

• Rotate an object a specific angle using the Rotation dialog. 

The Rotation tool rotates a shape around its center. The Rotation dialog can rotate a shape around either 
its center or the Drawing plane's center. 

NOTE! Rotating is allowed only on cross-section planes, not the sweep path. 

To free rotate a cross-section in 2D: 

1. Set the Drawing plane to the plane on which you want to rotate the shape. If necessary, group the 
curves or shapes you want to rotate. 

2. Click the Rotation tool. 
 

 
3. Drag the shape in a circular motion. Hold down the Shift key to rotate the shape in 45° 

increments. 

To numerically rotate a cross-section on the Drawing plane: 

1. If necessary, group the curves or shapes you want to rotate. 
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2. Select the shape(s), and choose Arrange > Rotate. The Rotation dialog appears. 
 

 
3. Enter the Angle of rotation. 

4. Enable degrees clockwise (CW) or counterclockwise (CCW). 

5. Enable the Twist Surface option if you want to twist the surface of the object as you rotate. For 
more information on this option, refer to "Twisting An Object." 

6. Enable a rotation center:the shape's center or the Drawing plane's center. 

7. Click OK. 

Beveling Shapes 
The bevel menu contracts or expands a shape: it replaces the original shape by one that follows its 
outline at a given distance. 

 
A 0.5 inch bevel was applied to the outer shape to produce the middle shape. In comparison, the inner 
shape is the result of a 50% scaling of the outer shape. 

To apply a bevel to one or more shapes: 

1. Select the shapes(s) you want to bevel. 

2. If you want to keep the original shape(s), select Edit > Copy and then Edit > Paste. 

3. Choose Arrange > Bevel. 
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4. Enter a bevel value (a negative value will expand the shapes). 

5. Click OK. 

Centering Selections 
You can center selected shapes on the Drawing plane using the Center Selection command. If several 
shapes are selected, they maintain their spatial relationship to each other. 

Unlike using the Center command in the Sections menu, Center Selection only centers the selected 
shape, not all shapes in the cross-section. This makes it ideal for creating compound cross-sections.  

NOTE! You can also center everything on the cross-section, maintaining the spatial relationships 
among shapes. For more information, refer to "Centering Cross-Sections." 

To center a selected shape on the Drawing plane: 

1. Select the shape or shapes you want to center. 

2. Choose Arrange > Center Selection.  
 

 

Setting Object Properties 
The Properties tray displays the properties of the selected point, control handle, shape, group, or 
compound cross-section. 

You can edit shapes and cross-sections by making numerical adjustments in the Properties tray. When 
you select a point, Carrara displays the X and Y coordinates. 

• When you select a curve point, Carrara displays the X and Y positions of its handles (Control 
Handle). When these controls are active, you can retract a control handle using the Retract 
button. 

• When you select a grouped cross-section, Carrara shows its height and width, top and left 
coordinates, and shape number. 

• No information is available for ungrouped shapes or for partially selected shapes. 

 © 2008 DAZ 3D, Inc. 310 



Carrara 7 11 December 2008 

By default, Carrara shows all values in inches. You can change the units of measure using the 
Preferences: General Scene Settings dialog. For more information, refer to "General Scene Settings 
Preferences." 

To change the properties of a cross-section: 

1. Drag open the Properties tray if needed. 

2. Select a cross-section group or point. 

3. Adjust the values you want. 

4. If you selected a closed cross-section, enable the Keep Proportions check box to maintain the 
shape's aspect ratio as you resize it. 

5. If you selected points on a cross-section, do one of the following:  

• Click the Corner Point button to convert the curve point to a corner point.  

• Click the Smooth Point button to convert the corner point to a curve point. 

6. If you selected a curve point, click the Retract button to retract the point's handles. 

Setting Surface Fidelity 
Carrara renders an object by breaking it into hundreds of tiny polygons. This helps the renderer 
understand the contents of the scene. 

The number of polygons Carrara uses for each object is based on the size of the object, its distance from 
the camera, and the rendering resolution. This calculation usually results in a smooth object. 

If an object does not render as smoothly as you'd like, you can increase its surface fidelity. This forces 
Carrara to break it down into a greater number of polygons. 

If none of the objects in your scene renders as smoothly as you would like, you can increase the 
rendering Silhouette Quality, instead. However, this option uses more memory and increases rendering 
time. For more information, refer to "Rendering Engines." 

The surface fidelity value is resolution-independent. That is, if a particular value yields good results for a 
given object in a given scene at high resolution, it should yield good results at lower resolutions as well. 

To set surface fidelity: 

1. Choose Geometry > Surface Fidelity. The Surface Fidelity dialog appears. 
 

 
2. Enter a percentage to increase or decrease the object's surface fidelity. The default value is 

100%. 

3. Click OK. 
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Working with Cross-Sections 
A basic spline object, such as a box, has one cross-section at the start of the path. The shape on this first 
section is swept to the end of the extrusion path. To create more complex forms, you can add any 
number of cross-sections along the path. Because each cross-section, in turn, can contain any number of 
shapes, you can use multiple cross-sections to model intricate objects. 

As you begin to work with the Spline modeler, you will find that the sweep path and cross-sections are 
closely tied. Although separated here for the sake of clarity and organization, these concepts go hand in 
hand. Be sure to read "Working with the Sweep Path." 

Creating and Removing Cross-Sections 

Creating and Removing Cross-Sections 

You can add as many cross-sections as you like to an object. Each cross-section must correspond to a 
point on the sweep path. If you want to create a cross-section where there is no point, you must first add 
a point. 

 . 

Although modeling with multiple cross-sections enables you to achieve otherwise impossible effects, be 
careful not to add cross-sections unnecessarily. Editing an object with too many cross-sections can 
become difficult and tedious. Often, you can accomplish similar results using the extrusion envelope. 
Refer to "Using the Extrusion Envelope." 

To create a new cross-section: 

• If there is a point on the sweep path where you want the new cross-section, select the sweep 
path and choose Sections > Create. 

• If there is no point, choose the Add Point tool. Hold down the Option/Alt key and click the sweep 
path at the point where you want to create the new cross-section. Carrara adds a point to the 
sweep path and creates a new cross-section at that point. 

• If you're working on a cross-section plane, choose Sections > Create. 

• If there is a shape on the previous cross-section, Carrara copies it to the new cross-section. You 
can delete the new shape without deleting the new cross-section. 
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To remove a cross-section: 

1. Click the cross-section you want to remove, or select the corresponding point on the sweep path. 

2. Choose Sections > Remove. 

To remove a cross-section and its sweep path point: 

• Use the Delete Point tool to delete the point from the path. 

Generating Intermediate Cross-Sections 

You can have Carrara create a specific number of cross-sections between the current cross-section and 
the next one. 

To generate intermediate cross-sections: 

1. Click a cross-section plane. 

2. Choose Sections > Create Multiple. The Create Multiple Cross-Sections dialog appears. 
 

 
3. Enter the number of sections you want. 

4. Click OK. 

Carrara creates the intermediate cross-sections, spacing them evenly between the current cross-section 
and the next one. Carrara adds a new point to the sweep path for each cross-section it creates. 

The shapes on the new cross-sections are interpolated from the shapes on the existing cross-sections. 
This process is similar to blending between two shapes in a 2D illustration program:each shape on the 
new cross-sections is like one "step" in the blend. 

Moving Among Cross-Sections 
If you have multiple cross-sections, you can move the Drawing plane to any cross-section. 

To move to an adjacent cross-section, do one of the following: 

• Choose Sections > Next or Previous. 

• Hold down the Command/Ctrl key and press the right or left arrow key to move to the next or 
previous cross-section. 
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To move to a specific section: 

1. Choose Sections > Go to. The Go To cross-section dialog appears. 
 

 
2. Enter the number of the section you want to go to. Cross-sections are numbered from back to 

front. 

3. Click OK. 

Displaying Cross-Sections 
If you have multiple cross-sections, you can display them all at once or show only the current one. 
Displaying only the current one gives you a better idea of the appearance of your object; displaying all 
lets you easily identify the cross-section shapes you have to work with. 

To show all cross-sections or only the current one: 

• Select Sections > Show> Current or All. 

Centering Cross-Sections 
Often when you're creating cross-sections, you can end up with a number of sections whose centers 
aren't aligned, which can lead to unexpected results. It's usually a good idea to center sections when 
you're finished drawing them. 

To center a cross-section on the sweep path: 

1. Select the section you want to center. 

2. Choose Sections > Center. The shape(s) on the cross-section will be centered around the 
sweep path. 

NOTE! You can also center specific selections. For more information, refer to "Centering 
Selections." 

Compounding Shapes 
Compounding shapes is like grouping them, with one significant difference:any shape completely 
enclosed by another in the same compound "cuts away" from the larger shape. This leaves a hollowed 
out shape, which can be extruded to produce an object such as a pipe or a hollow log. 
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To compound shapes: 

1. Select the shapes you want to compound. 

2. Choose Arrange > Combine as Compound. 

To break apart a compound: 

1. Select the compound you want to release. 

2. Choose Arrange > Break Apart Compound. 

NOTE! Compound shapes are allowed only on cross-section planes. 

Filling and Emptying Cross-Sections 
You can fill a cross-section to make an object "solid." For example, a cylinder with its endcaps filled would 
be something like a solid can; a cylinder with its endcaps emptied would be a tube that you could look 
through. 

An object's first and last cross-sections are often referred to as endcaps:you can turn endcaps "on" by 
filling them or "off" by leaving them unfilled. 

To fill and empty cross-sections: 

1. Click a cross-section plane. 

2. Choose Sections > Cross-Section Options to open the cross-section Options dialog. 
 

 
3. Enable Fill Cross-Sections to create solid sections, or disable the option to create empty sections. 
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You can also use the cross-sections dialog to disconnect cross-sections and choose skinning options. For 
more information, refer to "Disconnecting Cross Sections." 

Modeling with Multiple Cross-Sections 
Modeling with multiple cross-sections lets you increase your control over the shape of your object's 
surface. 

With each section you add, you increase your control over how the surface is created. You can add subtle 
variations in your object's surface by creating more cross-sections with different shapes. 

 
Of course, the more cross-sections you add, the more complicated it becomes to work in the modeler. 
However, the Spline modeler has some features to help you model with multiple cross-sections, 
described in this section. 

Numbering Shapes 

Carrara automatically numbers the shapes in each cross-section, establishing a correspondence between 
the shapes in adjacent cross-sections. In cross-sections containing multiple shapes, this shape 
numbering determines which shape sweeps to which other shape. 

You can renumber the shapes to change the shape-to-shape correspondence. Each shape's number is 
displayed in the Properties tray. 
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To control shape-to-shape correspondence: 

1. Select a shape to number. You must select every point on the shape, or regroup the shape. 

2. Do one of the following:  

• Choose Sections > Set Shape Number. The Shape Number dialog appears. 
 

 
• Display the Properties tray. 

3. In the Shape Number field, type in the number you want.  

• If you enter the number of another shape in the same plane, Carrara swaps those 
numbers. 

• If you enter a unique number, make sure you assign the same number to the appropriate 
shape in the adjacent cross-section(s). 

• Carrara does not extrude any shape that has no correspondence (that is, its number 
does not match any shape number in an adjacent section). 

4. Click OK. 

Disconnecting Cross-Sections 

You can create multiple and "intermittent" objects by disconnecting adjacent cross-sections. 

 
To disconnect cross-sections: 

1. Select the cross-section you want to disconnect. 

2. Choose Sections > Cross-Section Options, or open the properties. 

3. Enable the Disconnect from next cross-section checkbox. 
 
Carrara turns off extrusion between the selected cross-section and the next one. 

Setting Skinning Options 

The Spline modeler automatically extrudes between each cross-section and the next, basing the surface 
of the object on the shapes in the cross-sections and on the skinning options. 
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The skinning options make your surface either sharp-edged or smoothed. 

 
To set skinning options: 

1. Choose Sections > Cross-Section Options to open the cross-section Options dialog, or open 
the properties. 

2. Set a Skinning option:  

• Skin shape-to-shape is especially well suited for creating smooth, organic surfaces 
whose cross-section shapes are significantly different from one another. In fact, if 
adjacent cross-sections have different numbers of vertices, shape-to-shape skinning is 
the only option available. 

• Skin point-to-point can be used when adjacent cross-sections contain very similar 
shapes and you want each vertex in one cross-section to be connected directly to the 
corresponding vertex in the next cross-section. This option is useful when you model an 
object that requires straight, sharp edges. 

3. Click OK. 

Twisting An Object 
When you rotate a cross-section shape, you can specify that the rotation be applied to the surface of the 
object to give it a twisted appearance. 

 
To twist an object: 

1. Select a cross-section. 

2. Hold down the Option/Alt key while rotating the cross-section with the Rotation tool. 

3. Hold down the Shift key to rotate the shape in 45° increments. 

To twist an object numerically: 

1. Select a cross-section. 

2. Choose Arrange > Rotate. The Rotation dialog appears. 

3. Specify the direction and degree to rotate the selection. 

4. Enable the Twist Surface option.  

• Carrara twists the surface the specified number of degrees. 

• Use rotation values greater than 360° to specify multiple twists. 
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Adding Bevels to a Cross-Section 
With controls very similar to those used by the text object (as discussed in "Creating Text Objects"), you 
can add a front and a back bevel to a cross-section. The shapes in the beveled section will stay the same, 
but one or two automatic cross-sections will be created. In those sections, new shapes will be 
automatically calculated from those contained in the beveled section, and updated if you modify the 
originals. 

To bevel a cross section: 

1. Select the cross section that you want to bevel. The Properties tray displays the options available 
for that section. 
 

 
2. Click the Front Face box if you want to add a bevel between the selected section and the next 

point on the sweep path. 

3. Click the Back Face box if you want to add a bevel between the selected section and the previous 
point on the sweep path. 

4. Enter a Depth value for the front/back face. It determines the size of the bevel along the sweep 
path. This value must be smaller than the distance between the selected section and the 
next/previous sweep path point. 

5. Enter a Height value for the front/back face. This determines the size of the bevel along the cross 
section plane. A negative value will expand the section's shapes. A positive value will contract 
them. When using a positive value, it should be much smaller than the size of the shapes in the 
section. 

6. Select a bevel Type for the front/back face. This determines the shape of the bevel by modifying 
the envelope of the object. 
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TIP! To get better results, you should set the point-to-point skinning option on the beveled cross-
section. 

Working with the Sweep Path 
The key to working with the sweep path is understanding how the 2D path description lines define the 3D 
sweep path. There are two path description lines, one on each sweep path plane. Although the path 
description lines appear to be two separate planes, they are actually projections of the same path. 

 
Each point on one path description line corresponds to a point on the other path description line. In fact, 
each pair of points represents a single 3D point on the sweep path. 

The sweep path projection on the ground plane describes the sweep path's horizontal position; the 
projection on the side plane describes its vertical position. 

 
A sweep path curved on the side plane but straight on the ground plane would create an object whose 
shape curves up and down, but not side to side. 
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A path that curves on both planes would create an object whose shape curves both side to side and up 
and down. 

 

Drawing a Sweep Path in 3D 
The best way to start drawing a sweep path is to consider how you want your object to look, both from the 
side and from the top. An object that has a lot of curves when viewed in profile, but looks straight when 
viewed from the top, indicates that the sweep path will remain straight on the ground plane and curved on 
the right plane. 
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Unfortunately, few objects are this simple. Most objects have some variation from both the top and the 
profile. You can easily draw this type of sweep path by adjusting the point on the two sweep path 
projections. 

In some cases, simple adjustment might not be enough. You might want to draw the sweep path 
continuously from the first point to the last, switching back and forth between the two planes as you work. 

Cross-Sections and the Sweep Path 
When you're working with the sweep path, it's important to understand the relationship between the path 
and the cross-sections. You can think of the sweep path as an object's spine. Whenever you move a 
point on the sweep path, any cross-section at that point will move as well. 

The opposite is not true, however. When you drag a cross-section shape along the cross-section plane, 
the sweep path is not affected; you are simply moving the cross-section off its center. 

 
Cross-sections don't have to be centered around the sweep path. You can move a cross-section off the 
center of the sweep path. 

Translation vs. Pipeline 
The Spline modeler can extrude cross-sections along the sweep path using one of two extrusion methods: 
translation or pipeline. 

With the translation method, each cross-section remains perpendicular to the ground plane of the Spline 
Modeling window, regardless of the sweep path's curvature. 

With the pipeline method, the orientation of each cross-section depends on the direction of the sweep 
path at the point where the cross-section is located:all cross-sections remain perpendicular to the sweep 
path, rather than to the ground plane. 
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NOTE! Changing methods can reset your sweep path and extrusion envelope. 

To choose an extrusion method: 

• Choose Geometry > Extrusion Method> Translation or Pipeline. 

TIP! With the pipeline extrusion method, using the Current Section view makes working on the 
shapes of the current cross-section much easier.. 

Using Extrusion Presets 
Carrara has three extrusion presets, which automatically generate specific types of sweep paths. When 
you apply an extrusion preset, Carrara replaces the current sweep path and envelope with the preset 
path. 

To straighten the sweep path: 

• Choose Geometry > Extrusion Preset> Straight. 

Carrara moves all of the points on the sweep path into a straight line. Cross-section shapes are 
unaffected. 

Working with Spirals 

When you use the Spiral extrusion preset, only the first cross-section of your existing object is kept:the 
remaining cross-sections, sweep path, and envelope are all replaced. 

To make a spiral: 

1. Draw a 2D shape on the cross-section plane and select the shape. 

2. Choose Geometry > Extrusion Preset> Spiral. The Spiral dialog appears. 
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3. Set the options you want.  

• Number of turns is the number of loops in your spiral. One turn equals 360°. 

• Length determines the length of the sweep path. This affects how tightly the spiral will be 
wound. 
 

 
• Distance to axis determines the size of each coil by setting the distance between the 

cross-section shape and the spiral's central axis. The relationship between the number of 
turns and the length determines how tightly the coils of the spiral are spaced. 

 
• Cross-Section Scaling lets you shrink or enlarge the cross-section shape as it sweeps 

along the spiral path. Values less than 100% shrink the shape; values greater than 100% 
enlarge the shape. 

• Spiral Scaling lets you decrease or increase the distance to the axis as the cross-
section shape sweeps along the path. Values less than 100% taper the spiral; values 
greater than 100% widen it. 

4. Click OK. Carrara creates the spiral sweep path you have specified and automatically switches to 
pipeline extrusion. 

The Torus Extrusion Preset 

The Torus extrusion preset automatically creates a perfect circular sweep path. For more information, 
refer to "Lathing." 

Using the Extrusion Envelope 
To a large extent, the contours of a spline object are determined by the cross-sections you place along 
the sweep path. Wherever you change the size or shape of a cross-section, the object's surface changes 
accordingly. 
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To create some complex objects, you might find that you'll need a finer degree of control than cross-
sections alone can provide. The extrusion envelope lets you specify how an object's surface should curve 
from one cross-section to the next, giving you precise control over the object's form. 

For the best results, you should model the object as completely as possible using the sweep path and 
cross-sections, then adjust the extrusion envelope as a final step. 

Understanding the Envelope 
By default, Carrara does not use the extrusion envelope: it stretches the object's surface over the cross-
sections as simply as possible. When you turn the envelope on, it appears as four description lines, two 
on each sweep path plane. (The different colored line on each sweep path plane is a path description 
line:refer to "Working with the Sweep Path"). 

Initially, the envelope conforms to the dimensions of the object's cross-sections, widening and narrowing 
if the cross-sections vary in size. 

 
The envelope description lines are Bézier curves. By editing these curves, you can alter an object's 
contours. The envelope has three modes: Symmetrical, Symmetrical in Plane, and Free. 

With the Symmetrical envelope setting, all the envelope lines maintain symmetry. 

 
Symmetrical in Plane lets you edit the envelope description lines in pairs. 
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Free lets you edit each line individually. This allows you to model asymmetrical objects. 

 

How the Envelope Relates to the Sweep Path 

Each point on the extrusion envelope corresponds to a point on the sweep path. When you add a point to 
the extrusion envelope, Carrara also adds a point to the sweep path. Likewise, when you delete a point 
from the envelope, Carrara deletes the corresponding point from the sweep path. 

Moving an envelope point perpendicular to the sweep path controls the scaling of the object at that point 
on the path. Moving an envelope point parallel to the sweep path moves the corresponding point on the 
sweep path as well. 

When you are using the pipeline extrusion method, envelope points can move only perpendicular to the 
sweep path. 

How the Envelope Relates to Cross-Sections 

Editing the extrusion envelope can also affect an object's cross-section shapes. If you edit the envelope 
at a point where there is no cross-section, only the surface between cross-sections is affected. However, 
if you edit the envelope at a point where a cross-section exists, the shapes on the cross-section are 
scaled accordingly. If you delete a point from the envelope, you will also delete any cross-section located 
at that point. 

When you use the extrusion envelope on multiple-shape cross-sections, the center point is the sweep 
path:not the center of each shape. If you want to scale a cross-section's individual shapes around their 
own center points, you should resize each shape individually on the cross-section plane rather than use 
the extrusion envelope. 
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Using the Envelope 
To use the envelope, you turn it on and set a symmetry constraint other than the default of None. After 
that, you can directly modify it. 

To use the envelope: 

• Choose Geometry >Extrusion Envelope >and select one of the options described below. If the 
envelope is not already enabled, the four envelope description lines appear on the sweep path 
planes.  

o Symmetrical uses the same curve for all four envelope description lines:when you edit 
one line, the others update automatically. 

o Symmetrical in Plane uses the same curve for the description lines in either plane:when 
you edit one line, the other in its plane updates (as a mirror image) automatically. 

o Free allows each description line to have a unique curve. 

To modify the extrusion envelope: 

• Use the drawing tools to edit the envelope description lines.  

o You can add and delete points, as well as adjust existing points and control handles. As 
you adjust one of the envelope description lines, the other lines are updated in real time. 

o For instructions, refer to "Editing Shapes." 

To reset the extrusion envelope: 

• Choose Geometry > Reset Envelope. Or, choose Geometry > Extrusion Envelope > None. 

Lathing 
Lathing lets you create symmetrical objects by rotating a 2D profile around a straight axis. Rotation can 
be circular or angular, a full 360º or less. 

Because your lathe object is actually a spline object, you can edit it in ways that traditional lathing tools do 
not allow. For example, you can create a symmetrical lathe object, then deform it using the Spline 
modeler's other tools. 

You can choose from two different lathing methods, which are described next. 

Lathing with the Extrusion Envelope 

You can create nearly any lathe object by extruding a circle or a regular polygon and using the extrusion 
envelope to draw the object's lathe profile. 

For more information on the extrusion envelope, refer to "Using the Extrusion Envelope." 
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To create a lathe object with the extrusion envelope: 

1. Click a cross-section plane. 

2. Draw a cross-section using one of the Spline primitive tools or the Pen tool. Use an appropriate 
size and shape for the object you are creating. The initial diameter of your object depends on the 
size of the cross-section. For example, the size of the first circular cross-section determines the 
diameter of the glass's base. 

3. Hold down the Shift key to create circles or squares.  

o Choose Sections > Center to center the cross-section on the sweep path. 

o Choose Geometry > Extrusion Method> Translation. 

o Choose Geometry > Extrusion Envelope> Symmetrical. 
 
Don't worry about trying to edit the envelope's description lines:they disappear when you 
start drawing your own lathe profile. 

4. Click one of the sweep path planes to make it the Drawing plane. You might find it easier to draw 
the lathe profile in a 2D view. 

5. Click an empty space on the plane, being careful not to select the sweep path or either of the 
envelope description lines. 

6. Using the Pen tool, place the second point of the lathe profile. To create a curve point, drag the 
Pen tool. 
 

 
7. Make sure you draw the lathe profile above the sweep path. 
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8. Continue drawing the lathe profile, placing additional points with the Pen tool. 
 

 
9. You can also use the drawing tools to edit the points you have already placed. For best results, 

be careful not to cross over the sweep path as you draw the lathe profile. 

Lathing with a Circular Sweep Path 

Some lathe objects are difficult to create with the extrusion envelope. An object with a hole in the center 
can be particularly difficult. To create this type of object, you can draw the lathe profile in the cross-
section plane and sweep it around a circular sweep path. 

The Torus extrusion preset, available from the Geometry menu, creates a precise circular path. 

Metaball Modeling (Standard, Pro) 
The Metaball modeler lets you create organic shapes by blending primitives called blob elements. You 
use negative and positive blobs to build an object by adding and subtracting primitives, and then finish it 
with a smooth or a spiky surface. This makes the Metaball modeler ideal for objects such as water 
puddles, teddy bears, and bushes. You can also open a metaball object in the Vertex modeler and use 
vertex modeling techniques to define it further. 

Metaball modeling lets you fashion organic-looking objects as if you were manipulating clay. You use blob 
primitives to shape a metaball object, which is unified by a smooth or spiky skin. The blob primitives are 
not solid 3D primitives, but are defined by a 3D influence field that blends itself with surrounding blob 
primitives. The blending defines a skin, computed in real-time by the Carrara Metaball modeler. 

 
Unlike the geometric primitives in the other modelers, blob primitives can be negative or positive. 

Positive elements add to an object's volume. They are said to be attractive, since they blend when they 
get close together. You set the surface threshold to control just how close positive elements must be 
before they blend. The following image shows surface thresholds of 20% and 80%. 
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Negative elements are repulsive. They push away the skin surface of any surrounding blob elements, 
making smooth wells or holes in the object. The surface threshold also controls how close negative blobs 
must be before they push away surrounding blobs. 

 
This chapter covers the concepts involved in metaball modeling and describes how to use the Metaball 
modeler. 

The Metaball Modeling Window 
The Metaball modeler is where you create metaball objects. 

 

 © 2008 DAZ 3D, Inc. 330 



Carrara 7 11 December 2008 

When the Metaball Modeling window opens, new menu commands are available, different tool sets 
appear, and your view is replaced with a close-up view of the object. 

The Metaball Modeler's 3D View 
The 3D view of the Metaball modeler's working box has a dark background and colored grids. The origin 
of the universe is indicated by a trident showing the X, Y and Z axes. 

 
When you move an object, another triplet of colored lines appears to indicate the starting point of the 
object. In addition, whenever you move an object lines extend from its center to show its movement along 
each axis. 

 

The Ghost Menu 
The Ghost menu is a set of interactive commands that appear whenever you right -click (Win) or Control-
click (Mac) anywhere in the modeler. The menu remains visible as long as you press the mouse button. 
You select commands by rolling over them and then releasing the mouse button. 

Once a command is selected, it changes the behavior of the cursor. For example, if you select one of the 
Primitive commands on the Ghost menu, the next click you make adds a primitive blob. 

The menu contains commands for adding both positive and negative primitives, moving, scaling and 
rotating objects as well as commands for viewing your metaball object. 
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You can also access the Alternate Ghost Menu, which lets you quickly switch between view of your scene. 
Refer to "Working with the Modeling Window" for more. 

To use the Ghost Menu: 

• Command/Right-click and roll over the command you want and release the mouse button. 

• Option-Command/Alt-Right-click and roll over a view. 

Setting Preferences for the Metaball Modeler 
In the Metaball modeler Preferences dialog, you can set preferences for the grid, for workspace and 
object colors, for naming objects, and for selecting blobs in an object. 

To set preferences for the Metaball modeler: 

1. Choose File > Preferences. The Preferences dialog appears. 
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2. Choose Metaball Modeler. 

3. Set the options you want and click OK. 

The options for the Metaball modeler preferences are as follows: 

• Remember last command in the Ghost Menu lets you store the last command you accessed 
through the Ghost Menu. The next time you open the Ghost Menu, the last selected menu item 
will be displayed right under your cursor. 

• Grid settings Sets up the grid for the Metaball modeler without affecting the grid settings used 
for the Assemble window and other modelers.  

o Spacing Adjusts the spacing between grid lines in the box, using the unit of measure you 
choose. 

o Draw a line every Controls how often grid lines are drawn. 

o Show When enabled, shows the grid lines. 

o Snap to When enabled, causes objects to "snap" to the nearest grid line as you drag 
them. 

• Cycling Sets the amount of time before Carrara selects the next blob for Selection Cycling. For 
more information about Selection Cycling, refer to "Selecting Blobs." 

Opening the Metaball Modeling Window 
You open the Metaball Modeling window by doing one of the following: 

• Double-click the object in the Sequencer or the scene window. 

• Select a metaball object, then click the Model button. 
 

 
When you're finished modeling, you can save your changes and enter a different room by clicking the 
appropriate room button. 

NOTE! To avoid the memory-consuming accumulation of windows, always close the modeling 
window when you are finished modeling. 

To create a new metaball object: 

1. Open or create a document in the Assemble room. (For more information, refer to "Creating 
Scenes.") 

2. Depending on the desired location of the metaball object, do one of the following:  

o To insert a metaball object of default size at the center of the universe, choose Insert > 
Metaball Object or drag the Metaball Object tool into the Sequencer. 

o To insert a metaball object in any other location, drag the Metaball Object tool to into the 
scene window to any location. 
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Working with the Modeling Window 
You can use the Alternate Ghost Menu to switch between the 3D view and the six isometric views. 

 
You can work in any view you want. For instance, you may find it convenient to work in a 2D view when 
aligning blobs, then switch to the 3D view when you want to work in 3D. 

To switch between 3D and 2D views: 

1. Hold Option/Alt while Command/right-clicking to activate the Alternate Ghost Menu. 

2. Roll over the view you want to work in and release the mouse button. 

To restore the 3D view to the default: 

• On the Alternate Ghost Menu, roll over Ref. 

To restore the 3D view to the previous camera position: 

• On the Alternate Ghost Menu, roll over Last.  

o If your last view of the 3D window was dollied, panned, or zoomed, the camera position 
will be the same. 

To make your work flow easier, you can change different features of the Metaball modeling window: 

• Change the display and behavior of the grid. For more information, refer to "Setting Preferences 
for the Metaball Modeler." 

• Change the Drawing plane (which follows).  

• Show and hide the Working Box's planes.  

Changing the Drawing Plane 

To make your work easier, you can change the Drawing plane. 

To change the Drawing plane: 

1. Click the Selection tool. 

2. Click a plane in the Working Box control to switch between the planes. 
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Changing Your Point of View 
Without changing your point of view to examine an object from all sides, it can be difficult to determine its 
position relative to other objects in the model. When you blend objects this is particularly important:you 
must be sure that the objects are actually overlapping for blending to work. 

The Metaball modeler also lets you dolly while moving an object. 

To dolly while moving a selection: 

1. Hold the Command/Ctrl key while dragging. 

2. Release the mouse key and continue dragging to move the object. 

Previewing Objects 

There are several ways in which you can preview objects in the Metaball modeler: 

• Choose surface preview quality. 

• Choose shading preview mode. 

• Set preview precision. 

• Assign colors to blobs. This is useful for distinguishing blobs from one another in a blended object. 

• Turn the display of negative blobs on or off. 

The shading preview mode is independent of the surface preview quality. You can choose between 
shading previews of Wireframe and Gouraud Shaded. 

Note Unless they are turned off altogether, negative blobs always display as Wireframes. 

• In Primitive Preview, Carrara displays no positive or negative interactions between blob 
elements. Primitives behave as they do in the Spline modeler, passing through each other when 
they are placed on the same coordinates. The following images show negative and positive blobs 
in Wireframe and Shaded mode. 
 

 
• In Particles Preview, interactions between blob primitives are shown and the surface is defined 

by small triangles, or particles. 
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• In Mesh Preview, interactions between blob primitives are shown and the surface is defined by a 
mesh. Objects display in white; individual blob colors do not show. The following images show 
negative and positive blobs in Wireframe and Shaded mode. 
 

 
To change the preview quality: 

• Choose the Preview Quality tool you want. 

 
To set preview precision: 

1. Drag left or press (-) on the numeric keypad to decrease the precision. 

2. Drag right or press (+) on the numeric keypad to increase the precision.  

• In Particles Preview, increasing the precision increases the number of particles in an 
object. 

• In Mesh Preview, increasing the precision increases the number of polygons used to 
describe the surface of the object. 

• In Primitive Preview, the precision settings have no effect. 

• Higher rates of precision may slow the redraw rate. 

To change the color of blobs: 

1. Select the blobs) you want to change. 

2. Choose the Assign Color tool. Roll out to the color you want and release the mouse button. All 
objects you subsequently create will use this color. 

NOTE! In Mesh Preview mode, objects appear white regardless of the color you apply. 

To toggle the display of negative blobs: 

• Choose the Display Negative Blobs tool.  

When you turn off the display, you are still able to perform all modeling and editing functions using 
negative blobs. Selected negative blobs will show their bounding boxes. 
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Creating Metaball Objects 
This section discusses how to use the Metaball modeling tools. 

Inserting Blob Primitives 
The first step in creating a metaball object is to insert one or more blob primitives. 

To insert a blob primitive: 

1. Choose the negative or positive pop-up, depending on which type of primitive you want to insert. 
 

 
2. On the Drawing plane, drag from one corner of the blob to the opposite corner. Release the 

mouse button when the blob is the desired size. The blob is inserted on the Drawing plane. 

NOTE! You can also insert blob primitives from the Ghost Menu. 

 

Selecting Blobs 
You can select blobs with the Selection tool, or you can select all blobs of a specific color with the Select 
By Color tool. You can also select each blob in an object cyclically. This is useful if you want to select a 
blob that is behind or partly embedded in another blob. 
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To select all blobs of a specific color: 

1. Click the Select By Color tool, color swatches appear. Roll over to the color of blobs you want to 
select. 
 

 
2. Click a color swatch on the Select By Color tool to pick a group of objects. 

For information on coloring blobs, refer to "Previewing Objects." 

To cycle through the blobs in an object: 

1. Deselect all objects by clicking in an empty area of the workspace. 

2. Click a blob in an object and hold the mouse button down. In a few seconds, Carrara selects the 
next blob in the object, continuing until all the component blobs have been selected in turn. The 
cycle begins again if you continue to hold the mouse button. 

3. Release the mouse button when the blob you want is selected. 

To set the amount of time between the change of selected objects, refer to "Setting Preferences for the 
Metaball Modeler." 

Moving Blobs 
You can move blobs using standard dragging techniques. 

When you move an object, an additional triplet of colored lines appears to indicate the starting point of the 
object. In addition, as you move, lines extend from the center of the object to show its movement along 
each axis. 

 
To move blobs: 

1. Select one or more blobs. 
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2. Choose the Selection tool or choose Ghost > Move.  
 

 
3. Drag the blob wherever you like. Blobs move parallel to the Drawing plane unless you do one of 

the following:  

• Press the Command/Ctrl key to drag blobs perpendicular to the Drawing plane. 

• Hold down the Shift key to constrain the drag angle to increments of 45°. 

You can also dolly your view while moving blobs. For more information, refer to "Changing Your Point of 
View." 

Resizing Blobs 
You can resize blobs proportionally or on a designated axis. 

To scale a blob proportionally: 

1. Select a blob. 

2. Select the Scale tool or choose Ghost > Scale.  

3. Drag the mouse left or right to decrease or increase the blob's size. 
 
Carrara displays three colored lines that represent the local axis of the blob element. 

To scale a blob on one axis: 

1. Select a blob. 

2. Choose Ghost > X, Y, or Z near the Scale button. 

3. Drag the mouse left or right to decrease or increase the blob's size along the selected axis. 
 

 
 
Carrara displays a colored line that represents the local rotation axis of the blob element. 
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Rotating Blobs 
You can rotate an object in several different ways: 

• Free rotate in three dimensions. 

• Rotate on a designated axis. 

• Rotate perpendicular to the Drawing plane. 

To free rotate a blob: 

1. Select a blob. 

2. Select the Rotate tool or choose Ghost > Rotate.  

3. Drag the mouse to rotate the blob. 
 
Hold down the Shift key to constrain the rotation angle to 45° increments. 

To rotate a blob on one axis: 

1. Select a blob. 

2. Choose Ghost > X, Y, or Z near the Rotate button. 
 

 
3. Drag the mouse to rotate the blob along the selected axis.  

 
Hold down the Shift key to constrain the rotation angle to 45° increments. 

To rotate a blob perpendicular to the Drawing plane: 

1. If you are not already in an isometric view, use the Alternate Ghost Menu to select one. 

2. Select a blob. 

3. Select the Rotate tool or choose Ghost > Rotate.  

4. Drag the mouse to rotate the blob. 

Duplicating Blobs 
You can duplicate blobs, placing the duplicate objects on top of each other or mirrored on the other side 
of the Drawing plane. 
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To duplicate a blob: 

1. Select a blob. 

2. Choose Edit > Duplicate.  
 
The blob is duplicated, with the duplicate placed in the same location as the original. 

To duplicate a blob with symmetry: 

1. Select a blob. 

2. Choose Edit > Duplicate with Symmetry.  
 
The blob is duplicated, with the duplicate mirroring the original object on the other side of the 
Drawing plane. 

Blending Blobs 
To blend blobs, simply drag them close together. The proximity required for blobs to blend depends on 
the surface threshold. 

To set the surface threshold: 

1. Choose Geometry > Surface Threshold. The Threshold dialog appears. 
 

 
2. Enter a value to change the surface threshold.  

• A lower value will give smaller blobs and longer blends. 

• A higher value will give larger blobs and smaller blends. 

Examples: 

• Low and high surface thresholds with positive blobs. 
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• Low and high surface thresholds with negative blobs. 
 

 

Setting Surface Fidelity 
When Carrara renders, it breaks each object into hundreds of tiny polygons. This helps the renderer 
understand the contents of the scene. 

The number of polygons used for each object is based on the size of the object, its distance from the 
camera, and the rendering resolution. This calculation usually results in a smooth object. 

If an object does not render as smoothly as you'd like, you can increase its surface fidelity. This forces 
Carrara to break it down into a greater number of polygons. 

If none of the objects in your scene renders as smoothly as you would like, you can increase the 
rendering Silhouette Quality instead. However, this option uses more memory and increases rendering 
time. For more information, refer to "Previewing Objects." 

To set surface fidelity: 

1. Choose Geometry > Surface Fidelity. The Surface Fidelity dialog appears. 
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Use the Surface Fidelity dialog to control the smoothness of an object's rendering. 

2. Choose the options you want. 

• Mesh Mode generates a smooth surface, more or less as seen in the Metaball Modeling 
window.\ 

• Fidelity determines the number of polygons in the object. The higher the number, the 
smoother the surface and the longer the rendering time. 

• Spike Mode generates a spiky surface. This is useful for creating furry animals or bushes. 

• Size controls the length of the spikes. 

• Amount controls the number of spikes. 

3. Click OK. 

Putting It All Together 
Arranging Objects 
As you build a scene in the Assemble room, you scale and position objects in relation to the global 
universe and to each other. This chapter describes the techniques you use to arrange objects in your 
scene. 

Arranging is the process of positioning, scaling, and orienting objects. The most significant part of an object's 
arrangement is its position as it relates to other objects. Its absolute arrangement (relative to the universe) is 
generally important only for orientation.  
For example, it is important to position a glass of wine on a tabletop rather than having it intersect with or 
float above the table. At the same time, you should also use the glass's absolute arrangement to position 
a filled glass in its upright orientation, so that the full glass does not appear to be spilling the liquid. 

When you arrange one object in relation to another, you may need to perform a series of positioning, 
orientation, scaling, and alignment operations. Many of these commands operate under the constraints of 
the working box. Setting the working box appropriately before starting an operation greatly simplifies the 
procedure. Refer to "Using the Working Box" for further information. 

Note Except where noted, all of the positioning, orienting, aligning, and scaling commands work with 
either simple or grouped objects. For information on grouping objects, refer to "Building a Hierarchical 
Structure." 

Adding and Deleting Objects 
You can add existing objects to a scene (from other scenes or from clip art folders) in several ways:  

• Using the Scene Browser. For more information on using the Browser, refer to "The Browser 
Tray." 

• Dragging between windows. 

• Using the Copy and Paste commands. 

• Import an entire scene. For more information on importing objects from other 3D modeling 
applications, refer to "Importing 3D Objects." 

When you add an existing object, its shading, position, orientation, and size characteristics are brought 
with it. You can, of course, change any of these in the new scene. 
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Adding Objects from Other Scenes 
You can add objects from one scene into another by dragging an item from the Sequencer Tray or from 
the Instances tab in the Properties tray. 

To add an object from another scene by dragging: 

1. Choose File > Open to open each scene file. 

2. Select the scene that contains the object you want to use. 

3. Open the Sequencer Tray, or the Instances tab in the Properties tray. 

4. Drag the name of the object you want from the source scene to the destination scene window. 
 

 

Adding Objects from the Browser 
To add an object from the Scene Browser: 

1. Create or open a scene. 

2. Open the Browser, and select the tab that holds the type of object you want to add. 

3. Drag the object's icon from the Browser into the scene window or into the Hierarchy. When you 
drag into the Hierarchy, you can drag directly onto an object or a group. The object you dragged 
becomes a child of the object it is dropped onto. 
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Deleting Objects 
To delete an object: 

1. Select the object in the scene window or Hierarchy. 

2. Choose Edit > Delete or press Delete/Backspace 

NOTE! When you delete a parent object within a group, you automatically delete all of its child 
objects. If you want to delete an object but not its children, drag the children to the Universe level before 
proceeding. For details on parent and child objects, refer to "Linking Objects." 

Hiding and Showing Objects 
To hide or show an object: 

1. Select the object that you want to show or hide, from the scene (if visible), or from the hierarchy in 
the Sequencer or Properties tray (if either visible or hidden). 

2. Choose Edit > Hide/Show in 3D View.  

Selecting Objects 

Selecting Objects in the Assemble Room 
In order to arrange objects, you first have to select the object or objects that you want to arrange. Carrara 
provides several ways to select objects:  
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When an object is selected, you’ll notice the following: 

• It displays its bounding box.  

• Its projections onto the working box planes are highlighted.  

• The name of the object is highlighted in the Hierarchy in the Sequencer tray and in the Properties 
tray: Instances tab. 

Selecting with the Manipulator Tools 

To select an item in the document window, click the object preview or one of the projections with a 
manipulator tool (the Move, Scale, Rotate, or Universal Manipulator tool).  

To select objects with a manipulator tool: 

1. Choose the manipulator for the type of action you want to perform (Move, Scale, Rotate, or 
Universal Manipulator). 
 

 
2. Click the object in the document window, or one of its projections on the working box. 

3. To select or deselect additional objects:  

• Hold down the Shift key and click other objects to add to the selection. 

• Shift+click an object that's already selected to subtract it from the selection. 
 

 
4. If a number of objects overlap, right-click over the objects. A pop-up menu lists all of the objects 

beneath the cursor at that point. Select the object you want. 
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Selecting Objects in the Hierarchy 

To select one or more items in the Sequencer tray, or in the Properties tray: Instances tab, click an item 
or drag a marquee over one or several items. 

To select objects in the Hierarchy: 

• To select a single item, click the object's name in the Hierarchy. 

• To select multiple objects:  

o Drag a marquee around several contiguous objects. 

o Hold down the Shift key and click other objects (or drag another marquee) to add to the 
selection.  

o Ctrl/Cmd+Click to select additional items that are not contiguous. 

o Shift+drag or Ctrl/Cmd+Click over items that are already selected to subtract them from 
the selection. 
 

 
For complete information on working with the Hierarchy, refer to "Working with Objects". 

Selecting Objects in the Assemble Room 
In order to arrange objects, you first have to select the object or objects that you want to arrange. Carrara 
provides several ways to select objects:  
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When an object is selected, you’ll notice the following: 

• It displays its bounding box.  

• Its projections onto the working box planes are highlighted.  

• The name of the object is highlighted in the Hierarchy in the Sequencer tray and in the Properties 
tray: Instances tab. 

Selecting with the Manipulator Tools 

To select an item in the document window, click the object preview or one of the projections with a 
manipulator tool (the Move, Scale, Rotate, or Universal Manipulator tool).  

To select objects with a manipulator tool: 

1. Choose the manipulator for the type of action you want to perform (Move, Scale, Rotate, or 
Universal Manipulator). 
 

 
2. Click the object in the document window, or one of its projections on the working box. 

3. To select or deselect additional objects:  

• Hold down the Shift key and click other objects to add to the selection. 

• Shift+click an object that's already selected to subtract it from the selection. 
 

 
4. If a number of objects overlap, right-click over the objects. A pop-up menu lists all of the objects 

beneath the cursor at that point. Select the object you want. 
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Selecting Objects in the Hierarchy 

To select one or more items in the Sequencer tray, or in the Properties tray: Instances tab, click an item 
or drag a marquee over one or several items. 

To select objects in the Hierarchy: 

• To select a single item, click the object's name in the Hierarchy. 

• To select multiple objects:  

o Drag a marquee around several contiguous objects. 

o Hold down the Shift key and click other objects (or drag another marquee) to add to the 
selection.  

o Ctrl/Cmd+Click to select additional items that are not contiguous. 

o Shift+drag or Ctrl/Cmd+Click over items that are already selected to subtract them from 
the selection. 
 

 
For complete information on working with the Hierarchy, refer to "Working with Objects". 

Selecting Objects in the Assemble Room 
In order to arrange objects, you first have to select the object or objects that you want to arrange. Carrara 
provides several ways to select objects:  
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When an object is selected, you’ll notice the following: 

• It displays its bounding box.  

• Its projections onto the working box planes are highlighted.  

• The name of the object is highlighted in the Hierarchy in the Sequencer tray and in the Properties 
tray: Instances tab. 

Selecting with the Manipulator Tools 

To select an item in the document window, click the object preview or one of the projections with a 
manipulator tool (the Move, Scale, Rotate, or Universal Manipulator tool).  

To select objects with a manipulator tool: 

1. Choose the manipulator for the type of action you want to perform (Move, Scale, Rotate, or 
Universal Manipulator). 
 

 
2. Click the object in the document window, or one of its projections on the working box. 

3. To select or deselect additional objects:  

• Hold down the Shift key and click other objects to add to the selection. 

• Shift+click an object that's already selected to subtract it from the selection. 
 

 
4. If a number of objects overlap, right-click over the objects. A pop-up menu lists all of the objects 

beneath the cursor at that point. Select the object you want. 

 © 2008 DAZ 3D, Inc. 350 



Carrara 7 11 December 2008 

 

 

Selecting Objects in the Hierarchy 

To select one or more items in the Sequencer tray, or in the Properties tray: Instances tab, click an item 
or drag a marquee over one or several items. 

To select objects in the Hierarchy: 

• To select a single item, click the object's name in the Hierarchy. 

• To select multiple objects:  

o Drag a marquee around several contiguous objects. 

o Hold down the Shift key and click other objects (or drag another marquee) to add to the 
selection.  

o Ctrl/Cmd+Click to select additional items that are not contiguous. 

o Shift+drag or Ctrl/Cmd+Click over items that are already selected to subtract them from 
the selection. 
 

 
For complete information on working with the Hierarchy, refer to "Working with Objects". 
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Moving the Hot Point 
The hot point is the single point of an object or group that identifies its center of rotation. 

The hot point of selected objects and groups appears in the Assemble room as a black point that casts 
2D projections. 

 
By default, an object's or group's hot point is at the center of its bounding box, but you can move the hot 
point anywhere in the scene. 

The type of operation you want to perform determines where you put the hot point. For example, when 
you want to show a bell ringing, you need to rotate the bell from near its top. When the hot point is at the 
center of the bell, the Rotate tool rotates the object in place. However, when you place the hot point near 
the top, the bell rotates more realistically. 

 

Dragging the Hot Point 
You can use the Move tool to reposition the hot point of an object or group. 

To move a hot point by dragging: 

1. Choose the Move tool. 

2. Select the object or group whose hot point you want to move. 

3. If you drag the hot point when Caps Lock is off, the object moves with it. Turn on Caps Lock on 
your keyboard to unlock the object and its hot point.  

4. Drag the hot point in 3D or drag one of its 2D projections. The hot point moves parallel to the 
active plane. 

5. Hold down Command/Ctrl to drag the hot point perpendicular to the active plane. 

6. Turn off Caps Lock when you are finished. 

 © 2008 DAZ 3D, Inc. 352 



Carrara 7 11 December 2008 

Moving the Hot Point Numerically 
To move a hot point numerically: 

1. Select the object or group. 

2. Open the Properties tray: Motion tab: Transform panel.  

3. Enter the desired X, Y and Z coordinates in the Hot Pt. fields. For more information on these 
settings, refer to "Viewing and Setting Object Properties." 

Centering the Hot Point 
If you move the hot point for an object or group, you can easily return it back to the center of the object or 
group (its default position). 

To send the hot point to the center of the object: 

1. Select the object or group. 

2. Choose Edit > Center Hot Point. Carrara moves the hot point to the center of the object or group 
bounding box. 

Viewing and Setting Object Properties 
When you select an object, you can view its properties in the Properties tray. The Properties tray allows 
you to rename objects and move, scale, or rotate them based on numerical values. 

Naming Objects 
By default, new objects are named Type n, where Type is the object description (Sphere, Text, etc.) and 
n is the number of similar objects in the order created:Sphere 1, Sphere 2, and so forth. 

You can change the names of objects and groups. Giving objects and groups descriptive names can 
make them easier to locate and select. 

To change the name of an object or group: 

1. Select the object or group. 

2. On the Properties tray: General tab: General panel, enter any name you like in the Name field. 
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Arranging and Scaling Objects Numerically 
You can use the options in the Properties tray: Motion tab: Transform panel to perform most of the 
basic arranging operations discussed in this chapter. You can set properties for an object or for a group. 
The Properties tray lets you make numerical adjustments:as opposed to dragging or nudging:for moving, 
positioning, scaling, and rotating an object. 

 
By default, numerical changes use the units of measurement currently specified in the general scene 
preferences (File > Preferences: General Scene Settings) For more information on setting these 
preferences, refer to "General Scene Settings Preferences." 

To arrange objects numerically: 

1. Select the object or group that you want to modify. 

2. Display the Properties tray: Motion tab: Transform panel. 

3. Select the Coordinate >System you want to use from the popup menu:  

• World lets you specify the object's arrangement relative to the universe. Use this for 
absolute positioning, scaling, and rotating operations. 

• Local lets you specify the object's arrangement relative to the center of the object or 
group bounding box. For instance, you can move the hot point out from the center on a 
specific axis. 

4. From the Lock popup menu, choose Hot Point and Center to make the object move when you 
change either the Center or Hot Point value. 
 

 
5. Enter new X, Y, and Z values for the object property you want to change:  

• Center coordinates reposition the object from its center. 

• Hot Pt coordinates reposition the hot point numerically as described in "Moving the Hot 
Point Numerically." 

• Orient coordinates change the rotation of the object in relation to its hot point. 
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• Rotation coordinates rotate the object along one or more axes. For details on orientation, 
refer to "Rotating Objects." 

• Mirrored: Check this option to mirror (or flip) the object around its hot point or around the 
object’s center as described in "Mirroring an Object's Orientation." 

• Size: Sets the dimensions (height, width, and depth) of the object's bounding box.  

• Scaling: Sets the scaling percentages on each axis. One hundred percent is the scale at 
which the object was created. Check the Uniform option to disable individual scaling 
axes, and use the Overall scale feature instead. 

• Overall: Scales the X, Y, and Z axes uniformly by the value that you enter, with 100 
equaling the original size of the object. 

Mirroring an Object's Orientation 
You can automatically mirror an object or group's orientation across the ground plane. 

To mirror an object or group's orientation: 

1. Select an object or group. 

2. Position the hot point to describe the location you want for the mirror plane. 

3. In the Properties tray: Motion tab: Transform panel, enable the Mirror option. 

4. From the Around popup menu, select whether you want to mirror the object or group around its 
hot point, or around its center. 
 

 

Positioning Objects 
In addition to moving, scaling, and rotating objects numerically, you can also use the manipulator tools 
and other keyboard controls to accomplish similar tasks. 

Dragging Objects 
The easiest way to move an object is to drag it with the Move or Universal Manipulator tool. 

Dragging operations use the working box planes as the dimensional reference: 

• Remember that you can orient the working box to a particular attitude before dragging an object. 
For information on moving and orienting the working box, refer to "Changing the Working Box."  

• Remember also that the planes of the working box extend throughout the universe. The visible 
grid is merely a reference of the orientation of those planes and does not restrict you to the visible 
space. 
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To drag an object: 

1. Choose the Move tool or the Universal Manipulator tool. 

2. Use one of the following procedures:  

• Click and drag the object itself to move it parallel to the active plane.  

• Ctrl/Cmd-click the object to move it perpendicular to the active plane. 

• Drag the object’s projection along the desired working box plane. 

• Drag the manipulator by the X (red), Y (green) or Z (blue) arrow indicator to move along 
the desired plane. 

• Hold down the Shift key to constrain the drag angle to increments of the rotation angle. 

Moving Objects with the Manipulators 
When an object is selected with the Move tool or the Universal Manipulator, three colored arrows let you 
move the object along the global X, Y, and Z directions. As you move the mouse cursor near one of them, 
the cursor changes to a cross. You can then click and move the cursor in the direction of the arrow. This 
constrains the movement of the object to the direction indicated by the selected arrow. 

To move an object with the manipulator: 

1. Choose the Move tool, or the Universal Manipulator tool. 

2. Use one of the following procedures:  

• Drag the manipulator by the X (red), Y (green) or Z (blue) arrow to move along the 
desired axis. 
 

 
• Ctrl/Cmd+drag the arrow to move perpendicular to the desired axis. 

 

 
• Hold down the Shift key to constrain the drag angle to increments of the rotation angle. 
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Centering Objects in the Universe 
You can send an object or group to the center of the universe. The object maintains its orientation, and its 
center (not its hot point) is placed at 0,0,0. 

To center an object in the universe: 

1. Select the object. 

2. Choose Edit > Send To Origin. 

Nudging with the Keyboard 
You can use the keyboard to nudge objects or groups in small steps. 

To use the keyboard to nudge an object: 

• Press and hold the Command/Ctrl key, and then press the arrow keys to move the object in the 
active plane. 

• Press the Command/Ctrl and Option/Alt keys at the same time to move the object perpendicular 
to the active plane. 

• Press the Command/Ctrl and Shift keys at the same time to move in smaller steps. 

Scaling Objects 
When you create an object in a modeler, you model it at a particular size. In the scene in the Assemble 
room, you can scale the object to new dimensions. 

Because Carrara allows you to work with real- world units (inches, feet, centimeters, meters, etc.), many 
artists scale objects equivalent to their size in the real world. For example, you could create life-size 
models of several boxes:one at 12 x 12 x 15 inches, one at 13 x 18 x 12 inches, and one at 14 x 20 x 14 
inches:and a life-size model of a ladder at 48 inches. When you put all the objects together in the same 
scene, the objects have the correct size relationship. 

 
Carrara allows you to work with real world units to maintain true size relationships between objects. 

In all cases, you can scale an object proportionately or disproportionately. Scaling in the scene does not 
change the size of the original object; if you reopen it in a modeler, it will be the same size as when you 
created it. 
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You can scale an object or group several ways: 

• Use the Scale tool to drag its bounding box. This is useful if you want to scale one object "by 
sight" and then apply the same scaling factor to other objects. 
 

 
• Use the Size and Scaling controls (numerical scaling) in the Properties tray: Motion tab: 

Transform panel. For details, refer to "Viewing and Setting Object Properties." 

Scaling an Object by Dragging 
To scale an object by dragging: 

1. Select an object. 

2. Choose the Scale or Universal Manipulator tool. 

3. Depending on how you want to scale, drag one of the following on the object's bounding box or 
projection:  

• Corner This maintains the object's proportions; it is scaled along all three axes. 
 

 
• Edge This scales the object on two of its axes. 
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• Side This scales the object on one of its axes. 
 

 
 
The reference:which remains anchored in place:is the corner opposite to the one you 
drag. To use the hot point as the reference, open the Properties tray: Motion tab: 
Transform panel. Click the Lock popup menu near the bottom of the Transform section, 
and choose Hot Point Only. The hot point stays in place, and all eight corners of the 
bounding box move to scale the object.  
 

 
4. When you are satisfied with the object's new size, release the mouse. The object's Scaling 

factors change as you scale the object. You can use this information to scale other objects by the 
same amount. 

NOTE! Scaling may change the relative positions of two objects. For instance, a glass on a table, if 
enlarged, may go through the table, and if shrunk, may seem to float over it. To prevent this, use the 
plane at the bottom of the glass as the scaling anchor—that is, drag a corner at the top of the bounding 
box, not at its bottom. 

Scaling an Object with the Manipulators 
When an object is selected with the Scale tool, three colored cubes let you scale the object along its local 
X (red), Y (green), and Z (blue) directions. As you move the mouse cursor near one of them, the cursor 
changes to a cross. You can then click and move the cursor in the direction of the line under the cube. 
This constrains the scaling of the object to that line. If you press the Shift key at the same time, the 
scaling is uniform (the same in each direction). 
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You can still use the bounding box of the object to scale it. 

To use the keyboard to nudge the scale of an object: 

• With the Scale tool selected:  

o Press and hold the Command/Ctrl key, and use the arrow keys to nudge the object. 

o If you press the Shift key at the same time, the object scales with smaller steps. 

Rotating Objects 
Most real-world objects have a logical upright position and some have a logical front. For example, 
airplanes and automobiles have both. In simple terms, think of an object's orientation as the direction it 
faces. 

Carrara interprets the native upright position and front of objects by the way they are modeled. 

Note Orientation applies to objects and groups, as well as to lights and cameras. 

Carrara allows you to change an object's orientation in several ways: with the Rotate tool (free rotation), 
and numerically. You can also choose whether to rotate an object around its center or its hot point. 

To choose an object's center of rotation: 

1. In the Properties tray: Motion tab: Transform panel: Around list, select Object Center or Hot 
Point. 
 

 
2. If desired, position the object's hot point. For information on positioning an object's or group's hot 

point, refer to "Moving the Hot Point." 

3. Select the object or group. 

4. Choose the Rotate tool. 
 

 
5. Drag the object in a circle. 
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To constrain rotation to a particular plane: 

1. Orient the working box and position the object's hot point. This allows you to control the plane 
and axis of rotation.  
 

NOTE! For information on aligning the working box to a group or object, refer to "Changing 
the Working Box". For information on positioning an object's or group's hot point, refer to "Moving 
the Hot Point." 

2. Choose the Rotate tool. 

3. Drag one of the object's projections in a circle to rotate the object parallel to that plane. Hold 
down the Shift key while you drag to constrain rotation to increments of the Rotation Angle. 

To orient an object or group numerically: 

1. Select the object or group. 

2. Enter the X,Y,Z rotation values you want on the Properties tray: Motion tab: Transform panel. 
For more information on these settings, refer to "Viewing and Setting Object Properties." 

Using the Manipulators to Rotate 
You can use the manipulators to rotate objects. 

 
To rotate an object using the manipulators: 

• Select an object with the Rotate tool. 

• Three colored arcs let you rotate the object around its local X (red), Y (green) and Z (blue) 
directions.  

o A ring encompasses the three arcs and makes the object rotate around the direction of 
the camera.  

o As you move the mouse cursor near one of the arcs or the ring, the cursor changes to a 
cross.  

o You can then click and move the cursor along the arc. This constrains the rotation of the 
object.  

o To rotate freely in all directions, click inside the ring (without clicking on one of the arcs) 
and move the mouse. 
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To use the keyboard to nudge the rotation of an object: 

• Press and hold the Command/Ctrl key, and use the arrow keys to nudge the object. 

• If you press the Shift key at the same time, the object rotates with smaller steps. 

Changing the size of the manipulators: 

To easily manipulate big or small objects, the size of the manipulators depends on the size of the 3D 
View.  

To make the manipulators bigger or smaller: 

1. Choose File > Preferences. 

2. Choose 3D View in the pop-up menu. 

3. Adjust the 3D View Controls Size slider. 

Arranging Objects with Constraints 
By default, when an object has a position constraint, dragging it respects the constraint. For example if 
the constraint is a ball joint, the object can only be rotated and cannot be moved. This Use Constraints 
mode can be toggled on and off by using the View > Use Constraints command, or by clicking on the 
Use Constraints icon on the top of the 3DView window. 

 
When the Use constraints mode is off, the objects can be moved and rotated freely, even if they have a 
constraint. See "Applying Constraint Properties." 

Arranging Objects Without Modifying its Children 
When you move, scale or rotate an object, its children follow the movement. But if you want to adjust an 
object in a hierarchy without affecting the children: you have to move the parent and then move back the 
children to their previous position. 

The Lock Children mode simplifies that: enable it and you will be able to move, rotate or scale an object 
without changing its children. This can be useful in a lot of cases, for instance, to adjust the joints of a 
skeleton. 

 

NOTE! Be careful when using this mode on animated objects. This mode is only for adjusting, you 
should avoid using it in the middle of an animation as it may modify the movement of the children of the 
object you are modifying. 

Aiming Cameras and Lights 
All of the positioning and orientation commands work on cameras and lights as well as simple objects. 
The Point At command directs the light beam or camera view toward an object you specify. As the object 
moves, the light or camera continues to point to it. 
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NOTE! Because the current camera is not visible as an object, manipulation by dragging isn't 
possible. 

To point a camera or light at an object: 

1. Select the camera or light, and the object you want to point at. You may select multiple cameras 
and lights, but only one object or group. If you don't select a camera or light, Carrara points the 
current camera.  

2. Choose Edit > Point At. The light or camera points at the hot point of the selected object or 
group. 
 

 

Aligning Objects 
Carrara's relative alignment feature lets you arrange objects with respect to each other. You align objects 
on each axis separately. The selected axis is called the axis of constraint.  

NOTE! When aligning many objects, you may want to start by aligning only two of them. Once the 
two objects are aligned, group them, then align a third object to the group. Continue to group and align 
objects until all are aligned. 

To align objects relative to each other: 

1. Orient the working box to set the axes of constraint you want to use. For information on orienting 
the working box, refer to "Changing the Working Box." 

2. Select two or more objects. The first object you select becomes the anchor object. 

3. Choose Edit > Align. The Align dialog appears. 
 

 

 © 2008 DAZ 3D, Inc. 363 



Carrara 7 11 December 2008 

4. Click the X, Y, and/or Z axis indicators in the right side of the dialog to choose one or more axes 
of constraint. Click again to deselect an axis. If you choose all three axes, the second object will 
be embedded in the anchor object. 

5. For each axis, select an option from the Alignment popup menu. You'll often use a different 
command on each axis.  

• Align sets the reference point of each object colinear with the reference point of the 
anchor object along the axis of constraint. 

• Contact brings the Max of each object into contact with the Min of the next object along 
the axis of constraint. 

• Space puts the specified distance between the reference points of each object along the 
axis of constraint. Enter a spacing value. 

• Distribute aligns three or more objects at an equal distance from each other along the 
axis of constraint. By default, the first two objects you select serve as anchors, while the 
third and subsequent objects are the ones that move. 

6. Choose an option from the Reference menu. Object reference points that are grayed out are 
unavailable for the selected alignment command.  

• Hot Point aligns the objects by their hot points (two of which have been moved from 
center in the following figure). 
 

 
• Min specifies the side of each object's bounding box with the lower coordinate value 

along the axis of constraint. 
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• Center specifies the center of each object's bounding box. 
 

 
• Max specifies the side of each object's bounding box with the higher coordinate value 

along the axis of constraint. 
 

 
• Sides specifies the sides of the object's bounding box. 

 

 
7. If you want to add a buffer around the distribution of the objects, enter a value for the buffer in the 

Space field. 

8. Click OK. 

9. When you have achieved the alignment you want in one constraint axis, move on to the next one. 
(Return to step 3.) 
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Working with Objects 
This chapter explains how to use the hierarchical structure of a Carrara scene to add objects and 
determine their behavior. 

You start building a scene by adding, deleting, and replacing objects. 

Jumping into Groups and Editing Objects 
You can select an object or group and "jump into" it. Editing an object opens the object in its native 
modeler, where you can further modify the object. 

 
Jumping into a group allows you to rearrange the objects within the group. After you jump out, the objects 
remain grouped. 

To edit an object: 

• Do one of the following:  

o Double-click the object in the scene window or the Hierarchy. 

o Select the object in the scene window or the Hierarchy, then click the Model button to 
move to the modeler. 

To jump into a group: 

• Double-click the group in the scene window. 

Carrara opens the group in the local universe. The coordinate system of the local universe is parallel with 
the walls of the group's bounding box, with its origin at the center. 

NOTE! Usually, the Universe level is the root of the Hierarchy section of the Sequencer. However, 
if you jump into a group, the Hierarchy displays the group as the current root and the contents of that 
group as the only elements of the Hierarchy section of the Sequencer. 

To jump out of a group: 

• Click the Jump Out button in the local universe. 
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Editing an Object in a Different Modeler 
Normally, editing opens the object in its native modeler, or the Minimum modeler for primitives and 
imported objects. You may prefer to open the object in a different modeler. 

Working with an object in a different modeler changes its type. This may limit your options for future 
editing. For example, you can't edit a Spline object in the Vertex modeler, then take it back into the Spline 
modeler. Also, some modification options may not be available under certain modelers. 

Note Carrara constructs 3D surfaces using facets and patches. Facets are triangular. Patches are 
polygons derived from Bézier curves. Some objects may be entirely facets, others may be a mix of facets 
and patches. When you open a 3D primitive, Metaball, Text, or Spline object in the Vertex modeler, all 
patches are converted to facets. 

To edit an object in a different modeler: 

1. Select the object. 

2. Double-click the object to open it in its modeler. Choose Edit >Convert To Other Modeler. 
Carrara opens a dialog that shows your modeler options. 

3. Select the modeler you want. 

4. If you select the Vertex modeler, drag the slider or enter a value to set a fidelity level for creating 
facets from patches. More facets creates smoother surfaces, but increases the file size and 
memory required for the model. 

5. When you have set your options, click OK. Carrara opens the object in the selected modeler. 

Building a Hierarchical Structure 
Working primarily in the Hierarchy, you can structure a scene by grouping and constraining objects. This 
simplifies arrangement operations and can save you time and trouble. 

TIP! You'll find it easier to keep track of objects that you've individually named than it is to manage 
generically named objects. For information on naming objects, refer to "Naming Objects." 

Every object in your scene appears in the Hierarchy section of the Sequencer and in the Instances tab of 
the Properties. The Hierarchy is shown as a tree of objects, each represented by a listing. The 
hierarchical structure of a scene changes as you introduce and group objects and create constraints. 

In addition to primitives and modeled objects, hierarchy elements include groups, cameras, and lights. 
The highest level of the scene's hierarchical structure is its Universe list, which encompasses your entire 
scene. Beneath this level, there may be any number of branches and sub-branches 
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Navigating the Hierarchy 
You can expand and collapse the items in the Hierarchy to view more or fewer elements in your scene. 
You may need to open a series of groups to find a particular object deep in the hierarchical structure of a 
scene. 

To return to the topmost view, close the group at each level until only the Universe level is displayed. 

An expand or collapse arrow appears to the left of every group. When the group is closed, the arrow 
faces to the right. When the group is open, it faces down. 

 
The expand icon is a small arrow pointing to the right. The collapse icon points down. 

To open or close a group: 

• Click the arrow beside the group.  

Once a group is opened or closed, the arrow changes direction. 

Changing the Structure 
You can combine multiple elements in the Hierarchy in two ways: grouping and linking. You can nest 
groups within other groups or create a chain with multiple links. 

You can reorganize your groups and links by dragging them from one location in the Hierarchy to another. 
Don't worry about making a mistake. You can drag an element to another level at any time. 

You can drag objects individually or select several and drag them at once. 

To select multiple items in the Hierarchy: 

• Hold down the Shift key and click the items you want to select, or drag a selection marquee 
around the items you want to select. 

To remove a single object from a multiple selection: 

• Hold down the Shift key and click the item. 

Selecting elements in the Hierarchy applies not only to the selected object, but, in the case of a group, to 
its contents, and in the case of a parent object, to its children. 

Groups and Links 
Groups and links are similar:both let you combine multiple objects in your scene so that you can 
manipulate them as a single unit:but their usage is quite different. 

Grouping creates collections of objects that make structuring and navigating your scene more 
manageable. Groups are static in that they don't change the relationship between the objects in the 
groups; they only contain them. This is similar to the group function in 2D illustration and drawing 
programs. 

Links let you define a parent-child relationship between objects. By applying various types of links you 
can tie such objects together so that moving the parent affects the child, but moving the child does not 
affect the parent. 
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The exception to this is the Inverse Kinematics behavior applied to a child object in a linked chain. For 
more information on Inverse Kinematics, refer to "Inverse Kinematics." 

Grouping Objects 
As you build your scene, you'll want to group related objects. Grouping allows you to control a set of 
objects as a single unit. 

You can arrange a group just as you do a single object. During any positioning or orientation operation, 
the objects in a group retain their spatial relationship to one another. 

How you organize your groups is up to you. You'll often create groups based on the logical context of a 
set of objects:for example, "bench side, boards, and bolts." When arranged properly and grouped, the set 
of objects becomes a single object you could name "bench," which you could duplicate, move, or 
otherwise manipulate as a single object. 

 
You can also create groups based on the proximity of a set of objects:for example, "all objects on a city 
block." 

 
You can nest groups within groups to as many levels as you like. As you build a complex scene, you'll 
find nesting groups helps manage the multitude of elements. 

Don't worry about perfecting the shape of an object before putting it in a group. You can always open the 
group, then open the object for further modification. 

To create a new group: 

1. Select the objects you want to group. You can select the objects in either the scene window or 
the Hierarchy. 
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2. Choose Edit > Group. 
 
A group listing appears in the Hierarchy under the current root object. 
 

 
By default, groups are named Group x, where x is a sequential number (1, 2, 3...). 

NOTE! You can rename a group by selecting it and changing its name in the Properties tray. For 
more information, refer to "Using the Sequencer Tray." 

To add objects to a group: 

• Drag the listings of the objects you wish to add onto the group listing. 
 

 

TIP! You can bring an object into the scene and immediately place it in a group. Drag the object 
from its source (Browser tray or other scene's Hierarchy) and drop it directly onto a group listing. 

To remove objects from a group: 

• Drag the selected objects to another level in the Hierarchy. 

Opening and Closing Groups 

You can open and close groups while you work. When the group is closed, you can manipulate the entire 
group as a single object. When a group is open, you can select and move each component object 
independently. 

This is a great time saver and gives you maximum flexibility. You can easily adjust the objects in your 
groups, but maintain their places in the scene's hierarchical structure. 

Note Opening a group is different from Ungrouping. Ungrouping dissolves the group so that all the 
components appear at the same level of the Hierarchy. 

To open or close a group: 

• Click the arrow beside the group listing in the Hierarchy. 

A group listing is the root of the group's contents. While you open a group, its contents are displayed on a 
sub-branch. When you close a group, its content listings collapse into the group listing. 
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Group Bounding Boxes 

In the scene window, the elements of a group are enclosed in a single bounding box, which is visible 
when the group is closed. When you create a group, the group bounding box is set parallel to the planes 
of the working box. The group maintains this orientation until you change it. 

 
The group bounding box is the smallest box with the same orientation as the working box that encloses 
all bounding boxes of the group's contents. If you add objects to the group or remove them from the group, 
the dimensions of the group bounding box may change. The orientation of the group bounding box, 
however, does not change as you add or remove elements 

Jumping In and Out 

You can jump into a group to modify the positions of its objects. When you jump into a group, the 
Hierarchy displays the group listing as the current root and its contents as the only elements of the 
Hierarchy. Simultaneously, the scene window redraws to display only the contents of this group. 

Within a group, a coordinate system called the Local Universe is used. This system's axes are parallel to 
the walls of the group's bounding box, with its origin at the center. 

To jump into a group: 

• Double-click the group in the scene window or the Hierarchy. 

When you jump into a group, the working box is oriented parallel with the group's bounding box. This 
enables you to orient objects to the group's Local Universe. 

To jump out of a group: 

• Click the Jump Out button in the local universe. 

When you jump out, the Hierarchy and scene window return to the Global Universe. 
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Linking Objects 
Linking creates a physical connection between objects. In a linked pair, one object is the parent and the 
other is the child. When you change the position or orientation of the parent, the child moves with it. 
However, you can still move or rotate the child independently of the parent. 

Linking is used to create articulated structures, such as an arm. The hand is linked to the forearm, which 
is linked to the upper arm, which is linked to the shoulder. 

 
For information on how to constrain the child object's movement, refer to "Applying Constraint Properties." 

To link an object to another: 

• In the Hierarchy, drag the object or group's listing onto the listing of the desired parent. 

To attach an object to a parent that is off screen in the Hierarchy, drag the new element on the first or last 
visible line of the Hierarchy while holding the mouse button. This automatically scrolls the window's 
contents to reveal additional elements. 

 
To link an object, drag the object's listing onto the parent. 

NOTE! Duplicating a parent object also duplicates all of its child objects. 

To break a link: 

• Select the child object's listing and drag it to another level in the Hierarchy. 

Note You cannot link a child object to a simple group. To do this, you must first promote the group to a 
Master object. Then you can link the object (child) to the group (parent). For more information, refer to 
"Master Object Operations." 

 © 2008 DAZ 3D, Inc. 372 



Carrara 7 11 December 2008 

Applying Constraint Properties 

Linked objects have properties that constrain the child's movement relative to the parent. An excellent 
real world example of this is the human hand. The hand is linked to the forearm. Its range of motion 
(relative to the forearm) is limited:you can't bend it forward or back more than 90° or side-to-side more 
than 45°:anything more would break the wrist. These are the kinds of limits you can impose with 
constraint properties. 

 
Links become a more powerful tool for creating spatial relationships between objects when you apply a 
Constraint Property. This is especially true when setting up your scene for animation. Not only can you 
use constraints to constrain the movement of objects, but by applying the Inverse Kinematics behavior, 
you can create kinematic chains that allow you to manipulate the parent by moving the child. 

 
To apply a constraint property: 

1. Position the child object or group where you want it in relation to the parent. 

2. Position the child object or group's hot point where you want it. 

3. Select the child object or group. 
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4. In the Properties tray: Motion tab: Constraint panel, choose the type of constraint you want to 
apply from the list. Each is described in the next section. 

5. Choose your options for the specific Constraint Property. For information on doing this, refer to 
"Setting Constraint Controls." 

Types of Constraints 

There are several constraint types available: None, 2D Plane, 2D Plane, Axis, Ball Joint, Custom, Shaft, 
Lock, and Slider. For information on setting rotation controls, refer to "Setting Constraint Controls." 

Note You may have difficulty setting up some constraints on joints. As the constraints work in local space, 
you may have to orient the joints first.  

None 

None is the default constraint property. You can position the child object anywhere in your scene. 

2D Plane 

The 2D Plane constraint restricts the movement of your object to a specific plane. This plane is relative to 
the child object's axis, not the Global Universe. For example, if you rotate the object, the plane that the 
object moves on tilts. Click the radio button for the plane you want: XY, XZ, or YZ. 

 

Axis 

The Axis constraint lets a child object rotate around its hot point on one of the three axes. Examples of 
the limited axis constraint in the human body are the elbow and the knee. The rotation options are: 

• Locked prevents any movement on the selected axis. 
• Limited allows you to place limitations on movement in both directions. 
• Free lets the object move anywhere along that axis. 

 

 

Ball Joint 

The Ball Joint constraint lets you rotate the child object around its hot point. By default, the child object 
can rotate freely around any axis, but you can limit or even lock the rotation on each axis. An example of 
a limited ball joint constraint in the human body is the shoulder. 
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Custom 

The Custom constraint lets you build your own combination of constraints using sliders and axis rotation 
controls. 

 

Lock 

The Lock constraint locks the child object to the parent object. You cannot select the child object and 
move it, but it does move in relation to the parent when the parent is moved. 

There are no options for the Lock constraint. 

Shaft 

The Shaft constraint lets the child object both rotate around one of its axes and move up and down the 
same axis. One way to think of a shaft constraint is to visualize a firehouse pole. The firefighters can slide 
down the pole while rotating around it. 

Choose the axis of rotation and set both rotation and slider controls. For details on setting these controls, 
refer to "Setting Constraint Controls." 
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Slider 

The Slider constraint sets constraints for the child object's movement along its X, Y, and Z axes. The axis 
movement options are: 

• Locked prevents any movement on that axis. 

• Limited allows you to place limitations on movement in both directions. 

• Free lets the object move anywhere along that axis. 
 

 

Setting Constraint Controls 

All constraint properties use two primary types of controls: slider and axis rotation. 

The constraint slider controls are found in the Custom, Shaft, and Slider constraint options. 

The Axis rotation controls are found in the Axis, Ball Joint, Custom, and Shaft constraint options. 

To set a constraint slider control: 

1. In the Properties tray: Motion tab: Constraint panel, choose Custom, Shaft, or Slider from the 
list. 

2. For the constraint you've chosen, select the type of slider control:Locked, Limited, or Free. 
Carrara displays the controls for the chosen constraint. 

3. Drag the slider controls to set position limits and a new position. 

In Free mode, the slider has one control. Drag the control to move the object along that axis. You can 
double-click the slider to set the current position numerically. 
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In Limited mode, the slider has three controls: 

• The control on the left sets the outer constraint in the negative direction away from the object's 
hot point. Drag the control to change the limit. 

• The control on the right sets the outer constraint in the positive direction away from the object's 
hot point. Drag it to set a new limit. 

• The control in the middle sets the current position of the object. Drag the control to move the 
object along that axis between the limits you have set. 
 

 
The text field to the right displays the position of the currently selected control. 

• If you want more precise control in the slider range, click the plus (+) magnifying glass icon to 
zoom in on the scale. 

• If the slider range is not large enough for you to set the constraint limit where you want, click the 
minus (-) magnifying glass icon. Click it as many times as necessary to zoom out on the slider 
scale. 

To set axis rotation controls: 

1. In the Properties tray: Motion tab: Constraint panel, choose Axis, Ball Joint, Custom, or Shaft 
from the list. 

2. For the constraint you've chosen, select the type of axis rotation control:Locked, Limited, or Free. 
 
Carrara displays the controls for the chosen constraint. 
 

 
3. Drag the controls to set position limits and a new position. 

• In Free mode, the angle ring has one control. Drag it to rotate the object up to 360° 
around the chosen axis. 
 

 
• In Limited mode, the angle ring displays three controls.  

• The top control defines the rotation constraints on the positive side of the axis. 
Drag the control to change the limit. 

• The lower control defines rotation constraints for the negative side of the axis. 
Drag the control to change the limit. 
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• The middle control sets the current position of the object. Drag the control to 
rotate the object between the limits you have set. 

Controlling Constraints Directly 

The Direct Manipulation option for Constraint properties provides an on screen description and control of 
the objects' motion and rotation range. You can drag handles on the wires to control these properties. 

NOTE! There are no Direct Manipulation controls if the constraint type is None. 

To use the Direct Manipulation controls for constraint properties: 

1. Follow the previous instructions to apply a Constraint property to an object and set constraint 
controls on it. 

2. After you've chosen the constraint type, click the Direct Manipulation button in the Properties tray. 
 

 
The controls appear on the object as a set of wires with "handles" at certain points. The appearance of 
the wires depends on the type of constraint. 

 
For slider controls, you'll see a straight wire. If the constraint is Limited, the handles at the ends determine 
the limit for sliding on that axis. 

NOTE!  If you don't see the wire, it's probably inside the object. Use the constraint slider to extend 
the range.  

To set slider options directly: 

1. Drag the handle at the end of the wire to change the limit in that direction. 

2. Drag the object to change its position along the wire. The object's hot point slides along the wire 
until it reaches the end. 
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For rotation controls, you'll see a wire arc that describes the object's angular rotation range. The line 
within the arc describes the current rotation. 

To set rotation controls directly: 

1. Drag the handles at the end of the arc to change the rotation limit. 

2. Drag the center handle on the arc to rotate the object within the range. 

Building Chains of Constraints 

The parent-child constraint enables you to easily manipulate multiple objects from a number of reference 
points by creating chains of constrained objects. This feature is useful for creating articulations, especially 
when used in conjunction with the Inverse Kinematics feature. 

For example, if you want to create a fully articulated arm:one that could bend at the shoulder, elbow, wrist, 
and each of the five finger joints:you should arrange the objects to construct the arm, then constrain them 
into a chain with the fingers at the deepest level of the Hierarchy and the shoulder at the root. 
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Collision Detection 
Collision Detection instructs objects to "respect each other's space." With Collision Detection enabled, 
you can drag one object toward another, and the object stops when its surface contacts the other object. 
If you continue to drag, the object snaps through to the other side, but you can't leave it embedded. 

Collision Detection is a great feature for bringing the surfaces of two objects together:for example, putting 
plates and silverware on a dinner table. Without Collision Detection, you might accidentally leave a knife 
floating just above the table or embed it in the table itself. 

To enable or disable Collision Detection: 

• Choose View > Use Collision Detection or click on the Collision Detection icon on the right of 
the 3DView window. 
 

 

NOTE! Collision Detection is effective only when you reposition objects by dragging. Nudging and 
numerical repositioning are not affected by Collision Detection. 

Working with Master Objects 
Whenever you add a new object to a scene, you create a Master object. Most scenes use one or more 
duplicates of Master objects. These duplicates are not independent objects but Instances of the Master 
object. For example, you may create a chair using one Master object called "chair leg" and three 
Instances of it. 

 
The position, orientation, size, hot point location, and shading of each object Instance may be unique. 
The shape, however, is common. 

 © 2008 DAZ 3D, Inc. 380 



Carrara 7 11 December 2008 

Creating an Instance of a Master Object 
Every time you add a new object to a scene, you create a Master. You create an object Instance of the 
Master in one of three ways: 

• Use Edit > Duplicate. 

• Use Copy and Paste. 

• Drag the object from the Master category into the scene window. 

For information on special duplicating features, refer to "Duplicating Objects." 

Objects and Masters in the Hierarchy 
The Hierarchy in the Sequencer contains three categories that change your view of the objects displayed 
in the Hierarchy.  

The Universe category displays all the objects and object instances in your scene.  

 
The Master Objects category displays only the Master objects.  

 
The Scene Effects category displays any rendering effects you may have applied to your scene. 

 
Unlike the Universe category, the Master Objects and Scene Effects categories do not let you structure or 
group objects. 

Editing an Instance 

When you edit an object Instance, Carrara displays a dialog in which you can modify the Master object of 
this class or create a new Master from this Instance. 
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NOTE! You may have multiple Instances with the same name, but you may not have two Master 
objects with the same name. When you create a new Master object by modifying an object Instance, 
Carrara names the new Master object by appending a number to the old name. 

Master Object Operations 
When you modify a Master object, all object Instances are automatically updated to the new form. Their 
individual position, orientation, scale, symmetry, and region shading remain unchanged. 

If you modify an Instance when you had intended to modify the Master object, you can easily get back on 
track by replacing the Master with your modified Instance.  

To modify a Master object: 

1. In the Hierarchy, click the Master Objects category. 

2. Double-click the listing of the Master object you wish to modify. 

3. Modify the object using the modeler or the set of controls that appears. 

To use a group as a Master object: 

1. Select the group. 

2. Choose Edit > Promote to Master. 

A Master group operates under the same rules as a Master object. If you jump into a Master group and 
modify its contents in any way:the number of elements, their relative positions, or orientations:those 
changes will update to the group Instances. If you jump into one Instance of the Master group and modify 
its contents, you separate this group Instance from its Master, thus creating a new Master group. 

Changing an Object's Symmetry 
Many real-world objects exhibit symmetry. Airplanes, automobiles, and the human body are a few 
examples. To help you build complex symmetrical objects, Carrara provides the Flip and Duplicate with 
Symmetry commands. 

The Symmetry Plane 
The symmetry commands let you choose the plane across which objects are reflected or flipped. 

The attitude of the working box and the Local universe's Z coordinate are important for a successful Flip 
or Duplicate with Symmetry operation. Flip repositions or reorients the object, while Duplicate with 
Symmetry makes a second copy in a symmetrical attitude. 

• To flip an object in place, position the center of the object at Z=0 in the working box's coordinate 
system. 

• To create a mirrored duplicate precisely alongside the original, set the ground plane of the 
working box parallel to the plane that will be the center of the symmetrical object. (This will be 
parallel to one side of the object's bounding box). Move the working box to put working box Z=0 in 
contact with that side of the object's bounding box. 

To flip an object: 

1. Orient and position the working box to put the plane of symmetry where you want it. 

2. Select the object you want to flip. 
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3. Choose Edit > Flip. The Flip dialog appears. 
 

 
4. Click to select the plane axis along which you want to flip the object. 

5. If you want to offset the plane along which the object flips, enter a value in the Plane Offset field. 

6. Click OK. Carrara flips the object across the plane of symmetry. 

To duplicate with symmetry: 

1. Orient and position the working box to put the plane of symmetry where you want it. 

2. Select the object. 

3. Choose Edit > Duplicate with Symmetry. The Duplicate with Symmetry dialog appears. 
 

 
4. Click to select the plane axis along which you want to duplicate the object. 

5. If you want to offset the plane along which the object duplicates, enter a value in the Plane Offset 
field. 

6. Click OK. Carrara duplicates the object across the plane of symmetry. 
 

 

Splitting Objects 
You can split objects into their component pieces. For example, you can split a line of text into individual 
letters or you can break a vertex object into polymeshes. 
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To split an object: 

1. Select the object you want to split. 

2. Choose Edit > Split Object. The object splits into its component pieces. 

Replicating Objects (Standard, Pro) 
Duplicating objects can sometimes be a very long process for scenes like a city or a forest, especially 
when you don't want your objects to be exactly the same. To help you duplicate objects in very little time 
and using little memory, Carrara 6 provides two tools: the Replicator and the Surface Replicator. They do 
almost the same thing, replicating your objects, but in different ways. 

The Replicator 
The Replicator duplicates objects along basic shapes: grid, rectangle, circles, etc. It can be used to create 
armies, walls or cities. Once you have created the replicator and set the objects you want to replicate, 
choose the settings in the Replicator modeler. 

• The Grid Cell determines different things according to the replication method, but basically it is 
the distance between two neighboring objects. 

• The Autogrid replication method will set the grid cell to biggest bounding box of the replicated 
objects. 

• The Random Transform lets you create objects that are not positioned uniformly by changing 
rotation, scale or position randomly on each object. The settings are the amplitude of the error on 
each parameter. 

• The Seamless option can only be used with the Autogrid replication method and switches the 
orientation of one of two replicated objects. For example, if you set a terrain as the duplicated 
object, this will result as a large, continuous terrain. 

The Surface Replicator 
The Surface Replicator duplicates objects randomly on the surface of another object. You could use this 
to quickly generate forests, vegetation or rocks on terrain, or hair on a character. Once you have created 
the replicator and set the objects you want to replicate, choose the settings in the Surface Replicator 
modeler. 

 
The surface used to generate objects is the surface of the Source Object that can be a plane or a terrain, 
for example. Use the choose button to select it from the scene. The replicated objects will be linked to the 
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source object: if you modify the source object, the generated objects will move; if you delete it, the 
generated objects will disappear. 

• The number of objects you can choose is only an approximate number as there may not be 
enough space on the surface to place all the objects. If this is the case, you will see a warning at 
the bottom of the dialog. 

• The Random Transform lets you create objects that are not all the same by changing rotation or 
scale randomly on each object. The settings are the amplitude of the error on each parameter. 

• Align object to normal determines whether the objects should be orientated like the original 
object or be orientated like the surface they lay on, using the local normal. To generate a forest 
you will prefer to uncheck this, where as for hairs it is better to have it checked. 

The distribution of the objects can be automatic, but you can also choose globally where you want to put 
your objects. 

• If the source object has several shading domains, you can limit the distribution of replicated 
objects to a shading domain. 

• Use shader sets the distribution of objects to follow the shader of the generator. The generator 
will try to place objects on bright areas first and black areas won't get any objects. 

• If your objects should not overlap (as is the case most of the time) you can set a Minimum 
distance between objects. 

• If you want to make thickets of trees or other clustered objects, you can use Objects try to 
cluster. Specify the average distance objects should have in clusters and apply a Strictness. 
High strictness will tend to leave no object by itself. 

Using the Replicators 
To replicate objects 

1. Insert one type of replicator in your scene by the method you choose:  

• Insert > Replicator or Insert > Surface Replicator. 

• Drag one of these tools to the scene window. 

2. Insert the objects to generate as sons of the generator:  

• In the hierarchy move the object or the group you want to generate on the replicator, or; 

• In the replicator properties use the button Add. 
 
If you want to randomly generate different types of objects, such as different types of 
trees or buildings, reiterate step 2 above. For example, if you want to create a forest with 
75% pine trees and 25% maple trees, insert three pine trees and one maple tree as sons 
of the generator. 

3. Choose the generating point on each object: objects are generated from their hot point. For trees 
you will want to generate them from their base, so move the hot points to the bases of the trees. 

4. Edit the generator properties by:  

• Double clicking on the generator, or; 

• Selecting the generator and the switching to the Model Room. 

5. In the Assemble Room you can adjust the display of the generated objects. This setting won't 
affect the final render but lets you work with a clean scene. 
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6. If you are happy with your replication, you can create instances for real to work with it using the 
Create button in the modeling room. But in most cases you should not do this because:  

• The properties of the generators won't be accessible 

• Carrara might be slower because of all these objects especially the 3D View 

Using the Counter 
The counter tracks the complexity of the objects and geometry in the scene. The counter displays: 

• The selected object 

• The number of objects in the scene 

• The number of modeled facets 

This information may be useful if you intend to export the scene for use in another program. The number 
of triangles has a direct correlation to file size in the exported document. 

To view the counter: 

• Choose Edit > Counter. 

The counter keeps track of the number of objects in the scene and their complexity. 

Modifiers 
Modifiers are a special set of tools that let you easily manipulate objects in ways that would otherwise 
require many arranging and remodeling operations. 

For example, using the Explode modifier, you can make an object appear to explode by setting only a few 
parameters. Without the modifier, you would have to remodel the object several times to achieve the 
same effect. Some modifiers, like Bounce and Spin, automatically animate common types of motion. 
Others, like Point At and Track, animate one object based on the position or orientation of a second 
object. 

Modifiers can also be animated. You can create complicated animation effects like explosions and 
dissolves just by applying different modifiers to your objects. 

Modifiers also allow you to easily animate the shape of objects and groups without having to edit them in 
a modeler. They can also be used to animate models you import from other applications. 

Applying Modifiers 
You can access all the modifiers available in Carrara from the Modifiers tab on the Properties tray. Each 
modifier has its own settings, but they're all applied in the same way. You can apply one or more 
modifiers, as well as remove, replace, and reorder modifiers. 

To apply one or more modifiers: 

1. Select the object or group you want to modify. If you want to apply a modifier to more than one 
object, you must group the objects together with the Edit > Group command, then apply the 
modifier to the group. 

2. If the Properties tray is not open, choose Windows > Properties to display it. 

3. Click the Modifiers tab 
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4. Click the plus (+) icon to select a modifier from the list. 
 

 
5. Specify the modifier's parameters by adjusting the sliders and enabling the relevant options. 

 

NOTE! When you apply a modifier, it remains in the object's modifier list for the duration of 
an animation. However, some modifiers can be turned on and off at different points along the time 
line. 

6. To apply another modifier, click the plus (+) icon to select another modifier from the list. 
 

NOTE! Some modifiers are exclusive:they cannot be used together. For example, it 
wouldn't make sense to assign the Point At modifier to an object and also apply Spin:these 
modifiers combined would produce contradictory results. 

To remove a modifier from an object or group: 

1. Select the object or group that carries the modification. 

2. Click Properties tray: Modifiers tab. 

3. Click to select the title of the modifier you want to remove. The title bar changes color to indicate 
it is selected. 

4. Click the minus (-) icon or press the Delete key. The modifier is removed from the list. 

To replace a modifier: 

1. Select the object or group that carries the modification. 

2. In the Properties tray, click the Modifiers tab. 

3. Click the Modifier list pop-up menu on the panel of the modifier you want to replace. 

4. Choose the new modifier you want. The modifier is replaced. 

If you are using more than one modifier for an object, you can change the order of the modifiers as they 
appear in the Properties tray. Where two or more applied modifiers conflict, those further down the list 
override those above. 
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To change the order of modifiers: 

1. Select the object or group that carries the modification. 

2. Click Properties tray: Modifiers tab. 

3. Drag the title bar of a modifier to its new location. A locator line indicates where the modifier will 
be moved. 

Applying Modifiers in the Model Room (Standard, Pro) 
The Assemble Room modifiers can also be applied to a selection or an object. 

To apply a modifier on a selection: 

1. Select the polygons to be affected. 

2. Choose the menu Model > Deform. The Deform Selection dialog appear. 
 

 
3. Choose a modifier and adjust their settings. 

4. Click OK. 
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Controlling a Modifier Directly 
The Direct Manipulation control lets you adjust a modifier's attributes directly on the object. Direct 
Manipulation controls appear as a set of wires with "handles" at certain points. The handles represent 
attributes you can change by dragging. 

A modifier's title bar contains one of three icons to describe the status of Direct Manipulation. You can 
turn Direct Manipulation On, Off, or On When Selected (Direct Manipulation is on whenever the object is 
selected). 

• Direct Manipulation On 
 

 
• Direct Manipulation Off 

 
 

• Direct Manipulation On When Selected 
 

 
With some modifiers, you cannot use Direct Manipulation. For those modifiers, the title bar always 
displays Direct Manipulation off. 

To use Direct Manipulation on a modifier: 

1. Select an object. 

2. In the Properties tray, click the >Modifiers tab and apply a modifier to the object. 

3. Click the Direct Manipulation icon in the modifier title bar until the On icon appears. The modifier's 
control handles appear on the object in the scene. 
 

 

Bend and Twist 
The Bend and Twist modifier bends and/or twists the surface of an object. This modifier is particularly 
useful for fine-tuning complex models such as bent compound shapes, which are otherwise tricky or 
impossible to achieve. 
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To bend or twist an object: 

1. Select the object you want to twist. 

2. Click Properties tray: Modifiers tab. 

3. Choose Bend and Twist from the modifiers list pop-up menu. 

4. If you want to use Direct Manipulation, click its icon in the title bar until the On or On When 
Selected icon appears. A bounding box with twelve points appears around the object. 
 

 
5. Do one or both of the following:  

• To twist an object: Drag one of the corner points in the direction you want to twist. Or, 
drag the Twist Angle slider to control the direction and intensity of the twist. 

• To bend an object: Drag one of the middle points in the direction you want to bend. Or, 
drag the Bend Angle slider to control the intensity of the bend, and the Bend Axis Angle 
slider to control the direction of the bend. 

6. Adjust the following properties in the Properties tray: Modifier tab: Bend and Twist panel:  

• Bend Axis Angle: Use the Bend Axis Angle slider to control the direction of the bend. 

• Limits: Controls the portion of the object on which the twist or bend is applied. The slider 
contains two controls. The left control sets the bounding box for one side of the axis, and 
the right control sets the bounding box limit for the other side. For example, if the slider is 
set at 25% and 75%, the bend or twist starts at 25% from the bottom of the object and 
continues to the upper 75% of the object. At 0% and 100%, the entire object is modified. 
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• Axis: Select the radio button for the Axis where you want the modification to occur. The 
controls move to the selected axis. 

• In: Check the axes in which you want the bend or twist action to apply. 
 

NOTE! You cannot enable the checkbox for the selected Axis. For example, if the 
Axis X radio button is selected, you cannot enable the In X checkbox. 

• Flip Along Major Axis: If you want to reverse the direction of the bend or twist, check or 
uncheck the Flip along major axis checkbox. 

Bulge 
The Bulge modifier bulges the middle of an object in or out in a uniform fashion. The bulge occurs most in 
the middle of the object and not at all at the very top and bottom. The selection bulges uniformly based on 
the axis and points you choose. 

 
To set Bulge attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Bulge from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Bulge panel:  

• Bulge: Controls the direction and intensity of the bulge. 

• Limits: Controls the portion of the object on which the bulge is applied. The slider 
contains two controls. The left control sets the bounding box for one side of the axis, and 
the right control sets the bounding box limit for the other side. For example, if the slider is 
set at 25% and 75%, the bulge starts at 25% from the bottom of the object and continues 
to the upper 75% of the object. At 0% and 100%, the entire object is modified. 

• Axis: Select the radio button for the Axis where you want the modification to occur. The 
controls move to the selected axis. 

• In: Check the axes in which you want the bulge action to apply. 
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NOTE! You cannot enable the checkbox for the selected Axis. For example, if the Axis X radio 
button is selected, you cannot enable the In X checkbox. 

Explode 
The Explode modifier causes the object to burst apart. 

 
To explode an object: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Explode from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Explode panel:  

• Completion: Use the Completion slider to control how much the object explodes. In an 
animation, set this value to 0% in the first frame and 100% in the last. If you apply gravity, 
the pieces gradually fall to the ground as the explosion progresses. 

• Size of Pieces: Use the Size of Pieces slider to control the range of sizes for the pieces 
created by the explosion. The right control sets the size of the largest pieces, and the left 
control sets the size of the smallest pieces. With the controls set farther apart there is a 
greater variety of sizes for the pieces. With the two controls set closer together the 
difference between the largest and smallest pieces is less dramatic. 

• Speed: Controls the speed of the pieces as they move away from the original position of 
the object. The slider contains two controls. The left control sets the speed for the slowest 
moving particles; the right control sets the speed for the fastest moving particles. With the 
left control set to the far left (0%) and the right control set to the far right (100%), you 
have the greatest variety of speed. 

• Gravity: Controls the amount of gravity applied to the pieces. The higher the setting, the 
faster the pieces fall downward. 

• Slow Down at End: Control the rate at which the pieces slow down as they get farther 
from the center of explosion. A higher value makes the pieces move more slowly at the 
end of an animation. 

• Rotational Speed: control the speed at which the pieces rotate as they move away from 
the original position of the object. The slider contains two controls. The left control sets 
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the speed for the slowest moving pieces; the right control sets the speed for the fastest 
moving pieces. 

• Large Pieces Move Slower: Enable this checkbox if you want larger pieces to move 
more slowly during the explosion 

• Pieces Stop at Bottom: Enable this checkbox if you want all the pieces to stop falling 
when they reach the bottom of the original object's bounding box. 

• Explode from Top: Enable the Explode from Top checkbox if you want the object to 
explode starting from the top and working down to the bottom. 

Formula 
The Formula modifier uses mathematical equations to modify a selected object. You can use the Formula 
Editor to input variables, operators and parameters. Formula modifying is a technical process; for more 
information refer to "Using Formulas in Carrara." 

Punch 
The Punch modifier punches a dent into one side of an object, or bulges it outward. 

 
To set Punch attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Punch from the modifiers list pop-up menu. 

4. If you want to use Direct Manipulation, click its icon in the title bar until the On icon appears. A 
square with five points appears in the specified axis. 

5. Adjust the following options in the Properties tray: Modifier tab: Punch panel:  

• Strength: Drag the Strength slider right to increase the strength of the Punch, or to the 
left to create a bulge instead of a dent. 

• Radius: Drag the Radius slider to the right to increase the area of the object that is 
punched, or to the left to decrease the area. 

• Axis: Select the radio button for the Axis where you want the punch to occur. The punch 
controls move to the selected axis. 

• Punch Other Side: Enable the Punch other side checkbox if you want to place the dent 
on the other side of the object. 
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Stretch 
The Stretch modifier is particularly suitable for simulating the exaggerated, cartoon-style effects of squash 
and stretch actions. A squashed object seems to bulge; a stretched object elongates while thinning in the 
middle, much like chewing gum. 

 
To set Stretch attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Stretch from the modifiers list pop-up menu. 

4. If you want to use Direct Manipulation, click its icon in the title bar until the On icon appears. A 
bounding box with eight points appears around the object. 

5. Adjust the following options in the Properties tray: Modifier tab: Stretch panel:  

• Strength: Adjust the value of the Stretch slider to stretch or squash the object. A value 
lower than 100 compresses and bulges the object; a value greater than 100 elongates 
and thins the object. 

• Axis: Select the radio button for the Axis where you want the stretch to occur. The stretch 
controls move to the selected axis. 

Basic Deformations 
Basic deformations allow you to perform the following modifications to an object: 

Offset 
The Offset modifier translates an object in relation to its default position, within one or more specified 
axes.  
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To set Offset attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Basic Deformations > Offset from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Offset panel:  

• Offset: Use the slider to adjust the amount of offset from -150% to 150%.  

• In: Check the axes in which you want the offset action to apply. 

Rotate 
The Rotate modifier turns an object on the specified axis.  

 
To set Rotate attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Basic Deformations > Rotate from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Rotate panel:  

• Rotation Angle: Use the slider to adjust the amount of rotation from -180 to 180 degrees.  

• Axis: Check the axes in which you want the offset action to apply. 
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Scale 
The Scale modifier resizes an object along the specified axes. If all three (X, Y, Z) axes are selected, the 
object scales uniformly. You can use the Limits sliders to control the area that is scaled. 

 
To set Scale attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Basic Deformations> Scale from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Scale panel:  

• Scale: Use the slider to adjust the amount of scale from 0 to 300%.  

• Limits: Use the sliders to control the portion of the object on which the scale is applied. 
The left control sets the bounding box for one side of the axis, while the right control sets 
the bounding box limit for the other side. For example, if the slider is set at 25% and 75%, 
the scale starts at 25% from the bottom of the object and continues to the upper 75% of 
the object. At 0% and 100%, the entire object is modified. 

• In: Enable the checkboxes for each axis on which you want the scale to occur. 

Shatter 
Shatter is a facet-based modifier you can use to simulate object explosions. 
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To set Shatter attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Basic Deformations > Shatter from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Shatter panel:  

• Drag the Scale slider to the right to increase the scale of the shatter or left to decrease 
the scale. 

Shear 
Use the Shear modifier to tilt an object while leaving the top and bottom parallel to one another. This 
creates a "windblown" effect. You can use the Limits sliders to control the area of the object that is 
sheared. 

 
To set Shear attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Basic Deformations> Shear from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Shear panel:  

• Shear: Use the Shear slider to control the amount of the shear effect. 

• Limits: Controls the portion of the object on which the shear is applied. The slider 
contains two controls. The left control sets the bounding box for one side of the axis, and 
the right control sets the bounding box limit for the other side. For example, if the slider is 
set at 25% and 75%, the shear starts at 25% from the bottom of the object and continues 
to the upper 75% of the object. At 0% and 100%, the entire object is modified. 

• Axis: Select the radio button for the Axis where you want the modification to occur. The 
controls move to the selected axis. 
 

NOTE! You cannot enable the checkbox for the selected Axis. For example, if the 
Axis X radio button is selected, you cannot enable the In X checkbox. 

• In: Check the axes in which you want the bend or twist action to apply. 

• Flip Along Major Axis: Check this option to shear the object in the opposite direction. 
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Taper 
The Taper modifier adjusts the scale of an object at one end only. 

. 

To set Taper attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Basic Deformations> Taper from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Taper panel:  

• Taper: Use the Taper slider to control the amount of the shear effect. 

• Limits: Controls the portion of the object on which the taper is applied. The left control 
sets the bounding box for one side of the axis, and the right control sets the bounding box 
limit for the other side. For example, if the slider is set at 25% and 75%, the taper starts 
at 25% from the bottom of the object and continues to the upper 75% of the object. At 0% 
and 100%, the entire object is modified. 

• Axis: Select the radio button for the Axis where you want the modification to occur. The 
controls move to the selected axis. 
 

NOTE! You cannot enable the checkbox for the selected Axis. For example, if the 
Axis X radio button is selected, you cannot enable the In X checkbox. 

• In: Check the axes in which you want the taper action to apply. 

• Flip Along Major Axis: Check this option to taper the object in the opposite direction. 

Complex Deformations 
In the Modifiers area, you can perform complex deformations on objects. 

Atomize 
The Atomize modifier replaces the surface of the selected object with small balls which are then slightly 
scrambled or wiggled. 
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To set Atomize attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab.  

3. Choose Complex Deformations> Atomize from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Atomize panel:  

• Wiggle Effect: Controls the amount that the particles move. 

• Particles Density: Drag the slider to the left to decrease the density, or to the right to 
increase the density. A setting of 10 makes the object solid again. 

• Size of Particles: Drag the Size of Pieces slider to the right to increase the size of the 
balls on the object's surface. Drag to the left to decrease the size of the balls. 

Black Hole 
The Black Hole modifier creates a vortex effect, similar to the way water swirls as it is being sucked down 
a drain. In an animation the Black Hole modifier creates a whirling, circular motion that tends to form a 
cavity or vacuum at the center of its action. 
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To set Black Hole attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Complex Deformations> Black Hole from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Black Hole panel:  

• Completion: Controls the state of the vortex. Set this value to 0% at the beginning of an 
animation, and 100% at the end. 

• Winding: Controls the rotation as the Black Hole deforms. A negative setting creates a 
counter-clockwise rotation. 

• Spin Speed: Drag the slider to the right to make the object turn faster as it travels down 
the vortex. 

• Depth: Use the slider to control how far below the object the center of gravity is placed. A 
low setting results in little gravity pull. A high setting results in a stronger pull. 

Dissolve 
The Dissolve modifier reduces the object to triangles or polygons then diminishes the object so that it 
gradually fades away or disintegrates. You can use this modifier to create interesting sci-fi effects such as 
a transporter, or a mummy dissolving before your eyes in a horror movie. 

 
To set Dissolve attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Complex Deformations> Dissolve from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Dissolve panel:  

• Completion: Drag the slider to the right to dissolve more. In an animation, set this value 
to 0% in the first frame and 100% in the last. 

• Size of Pieces: Drag the slider to the right to increase the size of the pieces into which 
the object dissolves. This slider controls the size of the pieces the object dissolves into. 
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Spherical Morph 
The Spherical Morph modifier turns the selected object into a sphere.  

 
To set Spherical Morph attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Complex Deformations> Spherical Morph from the modifiers list pop-up menu. 

4. Adjust the following setting in the Properties tray: Modifier tab: Spherical Morph panel:  

• Completion: Drag the slider to the right to make the object more like a sphere. In an 
animation, set this value to 0% in the first frame and 100% in the last frame. 

Spike 
The Spike modifier adds needle-like pointed spikes to the selected object. Use the Spike modifier to add 
stubble to a character's chin or create a field of grass blowing in the wind. 
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To create Spikes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Complex Deformations> Spike from the modifiers list pop-up menu. 

4. Adjust the following options in the Properties tray: Modifier tab: Spike panel:  

• Spike Density: Drag the slider to the right to apply a greater number of spikes to your 
object. 

• Length: Drag the slider to the right to make the spikes longer. 

• Radius: Drag the slider to the right to set a larger radius for the spikes. 

• Messiness: Use the Messiness slider to control how wavy the spikes appear. A low 
setting results in straighter spikes while a high setting results in wavier spikes. 

• Flow: Use the Flow slider to control the wiggles of the spikes during animations. This 
slider works with the Messiness slider. The higher the value, the more the spikes appear 
to move in an animation. 

• Gravity: Use the Gravity slider to control the strength of gravity on the spikes. The higher 
the value, the more the spike will bend downward. 

• Keep Original Object: Enable the Keep Original Object checkbox if you want to keep the 
original object while adding the spikes around it. Disable it to replace the object with 
spikes. 

Warp 
The Warp modifier takes the object's surface points that are farthest from the center of the object and 
moves them out farther. At the same time, surface points that are nearest the center of the object move in 
closer to the center. 

NOTE! The Warp modifier has no effect on spheres because all the surface points are the same 
distance from the center. 

 
To set Warp attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab .  
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3. Choose Complex Deformations> Warp from the modifiers list pop-up menu. 

4. Adjust the following option in the Properties tray: Modifier tab: Spike panel:  

• Strength: Use the Strength slider to control the amount of warping. A negative setting 
moves surface points near the center away from the center and surface points far from 
the center in toward the center. A positive setting moves surface points far from the 
center farther away from the center and points near the center closer to the center. 

Behavior Modifiers 
Behavior modifiers allow you to give objects sets of instructions that give them an "activity" during an 
animation. Behaviors reduce the number of key frames you need to create and allow you to create 
actions that are not otherwise possible. The behavior modifiers basically fall into two categories: 

• The Bounce, Spin, and Shake behaviors assign complex actions to an object.  

• Point At and Track define or modify the motion of one object based on the location or motion of 
another object. 

NOTE! For information on the IK Terminator and Inverse Kinematics modifiers, see "Inverse 
Kinematics." (Standard, Pro) 

Bounce 
The Bounce behavior instructs an object to bounce up and down along the global Z-axis. You can set the 
upper and lower limits for the bounce, and specify the number of bounces per second. 

NOTE! The bounce behavior does not control an object's lateral movement (along the X and Y 
axes). However, if the object is already moving along the XY plane, it bounces while moving. 

The Bounce behavior is useful when you have a specific effect in mind and wish to specify Bounce 
parameters (like height and frequency) by hand. However, natural bouncing is much easier to create 
using physics. For details, refer to "Physics (Standard, Pro)." 
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To set bounce options: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Behaviors> Bounce from the modifiers list pop-up menu. 

4. Adjust the following settings in the Properties tray: Modifier tab: Bounce panel:  

• Bounce per Second: Drag the slider to the right to increase the number of bounces per 
second. 
 

TIP! For a realistic effect, you can change the number of bounces per second at 
the beginning and end of your animation. 

• Floor: In the text field, enter the lower limit of the bounce. This 
value is the distance from the global universe Z=0 plane that is 
the lower limit of bouncing. 

• Height: In the field, enter the distance above the floor level that 
is the upper limit of bouncing. 

• Start and Stop: Enter values in the Start and Stop fields to limit 
the bounce to a particular range in time. 

Point At 
The Point At behavior instructs an object to orient itself "toward" another object through all or part of the 
animation. 

Use the Point At behavior to get a camera or light to follow a particular object or group. You can also use 
it to animate an object that always faces or points at another, such as a satellite dish as it tracks a 
satellite, or a sunflower as it follows the path of the sun. 
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NOTE! Edit >Point At differs from the Point At modifier in two respects. First, Edit >Point At only 
operates on cameras and lights. Second, it only makes the change "right now," so it's not an animation 
tool. 

To set attributes for Point At: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Behaviors> Point At from the modifiers list pop-up menu. 

4. Set the following options in the Properties tray: Modifiers tab: Point At panel:  

• Towards: Click the button to open a dialog where you can select the object that should 
be followed. 

• Axis: Select an Axis radio buttons to choose which face of the object should point at the 
target object.  
 

NOTE! It is not necessary to set the Axis for a camera or light. By default, the face 
with the light beam or the camera lens is selected. Any other setting points the light beam 
or camera lens at 90° or 180° to the target. 
 

NOTE! For objects other than cameras or lights, you'll need to specify which face 
of the object should be oriented toward the target. For example, if you're working with a 
"pointing finger" object, select the axis that describes the direction the finger points. 

• Enabled: Check this option to turn the behavior on and off at 
specific points in an animation. A key frame is created each time 
you turn the behavior on or off. 

Shake 
The Shake behavior instructs an object to jump in an animation. You can set the number of jumps per 
second, as well as the amplitude of the jumps. 

 
To set Shake attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

 © 2008 DAZ 3D, Inc. 405 



Carrara 7 11 December 2008 

3. Choose Behaviors> Shake from the modifiers list pop-up menu. 

4. Set the following options in the Properties tray: Modifiers tab: Shake panel:  

• Jumps per second: Drag the slider to the right to increase the number of times an object 
jumps in a second. 

• Amplitude: Enter the length of the jumps. 

Spin 
The Spin behavior instructs an object to rotate on one of its axes. You can set the number of cycles of the 
spin per second. 

 

NOTE! To make the object spin in the opposite direction, enter a negative value. 

To set Spin attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Behaviors> Spin from the modifiers list pop-up menu. 

4. Set the following options in the Properties tray: Modifiers tab: Spin panel:  

• Cycles per second: Drag the slider to the right to increase the number of times the 
object spins in a second. (A cycle is one complete 360° rotation.) 

• Axis: Select the axis of rotation. 

• Start and Stop: Enter values in the fields to limit the spin to a specific time range. 

Track 
The Track behavior instructs an object to "shadow" another as its moves through the universe. 
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To set Track attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Behaviors> Track from the modifiers list pop-up menu. 

4. Set the following options in the Properties tray: Modifiers tab: Track panel:  

• Towards: Click to open a dialog where you can select the object that should be tracked. 

• In: Enable the checkboxes for each axis on which you want the tracking behavior to 
occur. 

• Track Rotation: Check this option if you want the object to track the rotation as well as 
position. 

• Enabled: Check the box to toggle the behavior on and off at specific points in the 
animation. A key frame is created each time you turn the modifier on or off. 

Waves 
Carrara includes several types of Waves modifiers so you can add waves to objects. 

Circular Wave 
The Circular Wave modifier distorts an object with a wave effect that ripples the surface in a circular 
fashion. 
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To set Circular Wave attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Waves> Circular Wave from the modifiers list pop-up menu. 

4. Set the following options in the Properties tray: Modifiers tab: Circular Wave panel:  

• Height of Waves: Drag the slider to the right to create a higher wave. 

• Frequency: Use the slider to control the number of waves that occur within a given time 
interval. 

• Phase: Use the slider to control the position of the wave within a given time interval. 

• Limits: Use the sliders to control the portion of the object on which the wave is applied. 
The left control sets the bounding box for one side of the axis; the right control sets the 
bounding box limit for the other side. For example, if the slider is set at 25% and 75%, the 
wave starts at 25% from the bottom of the object and continues to the upper 75% of the 
object. At 0% and 100%, the entire object is modified. 

• Wave Function: Select the 1 - cos or sin radio button to toggle between a cosine and 
sine wave pattern. 

• Axis: Select the radio button for the axis on which you want the wave to occur. 

Linear Wave 
The Linear Wave modifier distorts an object using a wave effect that ripples the surface in a uniform 
fashion. 

 
To set Linear Wave attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Waves> Linear Wave from the modifiers list pop-up menu. 

4. Set the following options in the Properties tray: Modifiers tab: Linear Wave panel:  

• Height of Waves: Drag the slider to the right to increase the height of the waves. 

• Frequency: Use the slider to control the number of waves that occur within a given time 
interval. 

• Phase: Use the slider to control the position of the wave within a given time interval. 
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• Limits: Use the slider to control the portion of the object on which the wave is applied. 
The left control sets the bounding box for one side of the axis; the right control sets the 
bounding box limit for the other side. For example, if the slider is set at 20% and 80%, the 
wave starts at 20% from the bottom of the object and continues to the upper 80% of the 
object. At 0% and 100%, the entire object is modified. 

• Wave Function: Select the 1 - cos or sin radio button to toggle between a cosine and 
sine wave pattern. 

• Axis: Select the radio button for the Axis where you want the wave to occur. 
 

NOTE! You cannot enable the checkbox for the selected Axis. For example, if the 
Axis X radio button is selected, you cannot enable the In X checkbox. 

• In: Enable the checkboxes for each axis on which you want the wave to occur. 

Wave 
The Wave modifier distorts the object by pulling it along an imaginary wavy sweep path. Use this modifier 
to simulate air or water currents. 

 
To set Wave attributes: 

1. Select the object you want to modify. 

2. Click Properties tray: Modifiers tab. 

3. Choose Waves> Wave from the modifiers list pop-up menu. 

4. If you want to use Direct Manipulation, click its icon in the title bar until the On icon appears. A 
bounding box with a number of control handles appears around the object. Drag the Number of 
Waves slider to the right to increase the number of waves applied to the object. 
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5. Drag one of the corner handles to adjust the height of the wave. Dragging away from the object 

increases the wave's height. Or, use the Height of Waves slider to set the wave height. Dragging 
to the right increases the wave height. 

6. Drag the center handles, or use the Phase slider to control the wave position within a given time 
interval. 

7. Select the radio button for the Axis where you want the wave to occur. 

8. In the Shape section, choose a shape for your wave. The available shapes are:  

• PlanarA: Wave moves along the plane A. 
 

 
• PlanarB: Wave moves along the plane B. 
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• Radial: Wave moves from center point outward. 
 

 
• Cylindrical: Wave moves around the outside of the object as if it were in a cylinder. 

 

 
The direction in which the wave is applied depends on which Axis radio button is selected.  

Smart Pack 
The Smart Pack modifiers are covered in the section that follows. There are two modifiers in this category: 

Morpher 
Morpher allows one object to morph into another. The only restriction is that targets must have the same 
number of vertices as the object being morphed. See "Using Morph Targets," for the preferred way of 
creating morph targets (Standard, Pro). 

To use the Morpher: 

1. Create your base shape, using the Spline, Metaball, or Vertex modeler. 

2. If necessary, convert your object to a vertex object and open it in the Vertex modeler. 

3. If the polygons are not triangulated, select all of the polygons in your model and triangulate the 
polygons with the Model > Triangulate Polygon command. 

4. Return to the Assembly room. Choose Edit > Duplicate to create a copy of the object.  

5. Select the duplicate and switch back to the Vertex modeler. When Carrara asks if you want to 
create a new master or edit the master, choose Create new master. 
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6. Modify the geometry but do not add any vertices. Repeat steps 2 - 5 as many times as desired; 
there is no limit on the amount of morphs you can apply. 

7. In the Assembly room, select the object to be morphed, and the morph targets you created. 
Choose Edit > Group to group the object to be morphed and the targets into one group. 

8. Scale your targets down to 1% and move them out 10000 in any direction. Do not hide your 
object! An error will be generated if the targets are set to invisible. 

9. Add a morpher modifier to your base object. Enter the name of the target in the target field. If the 
object was found and has the right number of vertices, the name you typed in the field will remain, 
otherwise 'Error' or 'Not Found' will appear. 

10. Use the morph slider to change the degree of the effect. Negative values also work.  
 

 
 
If you edit one of your targets, and it doesn't seem to modify your base object, just hit the 'reload 
now' checkbox on that morph. 
 

 

Noise Deformer 
This deformer adds noise to the geometry of an object. It can be used to simulate dilapidation and decay. 
This example illustrates the effect: 
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These settings will deform an object. 

 
Set the following options: 

• Seed This value "seeds" the random number generator. 
• Scaling Scales the noise each direction. 
• Order and Persistence Please refer to the introduction to noise present in the section covering 

Noise Factory. See "Noise Factory." 
• Limits Upper and Lower limits on the Magnitude of the noise. 
• Magnitude Changes the magnitude of the disturbance. 

Using Formulas in Carrara 
Carrara allows you to create mathematical formulas that in turn create custom features. Using formulas, 
you can define your own objects, deformers, tweeners, shaders, gels, backgrounds, and backdrops. The 
interface for creating formulas is common for all items. The valid input and output variables differ for each 
item you create. Formula editing becomes technical quickly. Higher math or programming experience is 
recommended. 

Creating Formula Objects 
Formula objects are 3D objects you create using mathematical equations. The Formula Editor lets you 
enter parameters, variables, and operators to create unique objects. 

To create a formula object: 

1. Do one of the following:  

• To create a formula object of default size at the center of the universe, choose Insert > 
Formula. (Standard, Pro) 

• Click the Formula tool and drag it into the scene window or Hierarchy section of the 
Sequencer. 
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2. Double-click the object. The Formula controls appear. 
 

 
3. Set the Formula controls to create an object of the shape you want. Enter a formula into the 

editing panel on the top, or edit the existing one.  

• Parse tests and compiles the formula. If there are any errors, Carrara gives you an error 
report. 

• More displays the Formula Editor. 
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4. When you are finished, return to the Assemble or Storyboard room. 
 

 
5. When your formula object is finished you can edit it by adjusting its parameters. 

 

 

Creating Formula Items 
The method for creating a formula item depends on the item you want to create. You can create the 
following items using formulas: 

• Primitive objects 

• Deformers 

• Tweeners 

• Shaders 

• Gels 

• Backgrounds and Backdrops 

To create a Formula primitive: 

1. Drag the Formula Primitive icon into the scene, or choose Insert > Formula. 

2. Double-click the object to display the formula controls, or click the Model room button. 

To create a Formula deformer: 

1. Click the Properties tray: Modifiers tab. 

2. Choose Formula from the pop-up. The formula controls appear in the Modifiers section. 
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To create Formula tweeners: 

1. Double-click the gap between key events on the time track. Carrara opens the Transition Options 
dialog. 

2. Choose Formula from the pop-up. The formula controls appear in the Transition Options dialog. 

To create Formula shaders: 

1. Display the Shader Tree Editor by double-clicking a shader in the Browser. 

2. Select the shader tree component where you want to use a formula. 

3. Select Pattern Functions > Formula from the list. The formula controls appear on the selected 
branch of the shader tree. 

To create Formula gels: 

1. Select a light other than Distant light. 

2. Display the Properties tray: Effects tab: Gel pane l.  

3. Choose Formula from the list. The formula controls appear in the dialog. 

To create Formula backgrounds or backdrops: 

1. In the Properties tray, select the scene, then click the Effects tab. 

2. Select Background or Backdrop. 

3. From the (Background or Backdrop) pop-up, choose Formula. The formula controls appear in the 
Effects section in the Background or Backdrop controls. 

Formula Controls 
The formula controls include a readout of the formula itself, sliders for adjusting parameters, a Parse 
button, and a More button. 

 
For a few items, the controls also include a preview of sorts. (For the tweener formula, the preview is a 
graph.) 
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Editing Formulas 
To create or edit a formula: 

1. In the formula controls, click More. Carrara opens the Formula Editor.  

o You can type into the window to build your formula. Be careful, the editor is case-
sensitive. 

o Each statement must end with a semicolon. 

2. When you are finished in the Formula Editor, click OK. 

3. In the formula controls, click the Parse button. Parsing compiles the formula to run. 

4. If appropriate to this formula, you can adjust the parameter sliders. 

Formula Operators 
sin(x)  sine of x 

cos(x)  cosine of x 

tan(x)  tangent of x 

asin(x)  arcsine of x 

acos(x)  arccosine of x 

atan(x)  arctangent of x 

atan2(y,x)  arctangent of y/x 

sinh(x)  hyperbolic sine of x 
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cosh(x)  hyperbolic cosine of x 

tanh(x)  hyperbolic tangent of x 

sqrt(x)  square root of x 

pow(x,y)  x raised to the power of y 

exp(x)  exponential 

log(x)  logarithm 

log10(x)  base-10 logarithm 

floor(x)  floor of x (The largest integer that is less than or equal to x) 

ceil(x)  ceiling of x (The smallest integer that is greater than or equal to x) 

abs(x)  absolute value of x 

mod(x,y)  x modulus y 

Comparison Operators 

<  less than 

<=  less than or equal to 

==  equal to 

!=  not equal to 

>  greater than 

>=  greater than or equal to 

&&  logical "and" 

||  logical "or" 

Conditional 

variable=((comparison)?(value if TRUE):(value if FALSE)) 

For example: 

a=((b>1)?1:b);  

The expression (b>1) is the comparison. If it's true, the formula returns a=1. If it's false, the formula 
returns a=b. 

Constants 

PI 

E 

Animatable Input Parameters 

p1, p2, p3, p4 

These parameters can be set between -1 and +1. 
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Variables 

The variables valid for a particular item depend on its type. Refer to the section below that describes the 
variables for the formula item you are creating. To define a variable, just use it. Its initial value will be 0. 

Formula Shader 

Output Variables 

value (output is a grey level) or red, green, blue (output is a color) 

The expected output is between 0 (black) and 1 (white or color maximum intensity). 

You can use any of these output variables, however, the program can't use value' and any of red', green', 
and blue' simultaneously. If the shader is used in a color based channel, then color output variables will 
have priority (meaning if value' and red' are defined, then only red' will be used). The opposite applies 
when using the shader in a value based channel, like Shininess. (If value' is defined, value' will be used). 

Input Variables 

u and vu and vu and v  These are parametric mapping coordinates. 

x, y and z  These are the local space coordinates of the point being 
shaded. 

nx, ny and nz  These are the normal local coordinates (normalized vector). 

X, Y and Z  These are the global space coordinates of the point being 
shaded. 

NX, NY and NZ  These are the normal global coordinates (normalized vector).

Formula Deformer 

The Formula Deformer iterates on all the points of an object, deforming them one by one. 

Output Variables 

dx, dy and dz The local coordinates of the deformed point. The range is -1 to +1 (0 is the center.) 

Input Variables 

x, y, z The local coordinates of the point to be deformed. 

Formula Tweener 

Output Variables 

value 
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Input Variables 

t, tmin, tmax t is time. One t unit is 1/1800th of a second. t is between tmin and tmax. 

Formula Backdrop 

Output Variables 

value or red, green, blue 

Refer to "Formula Shader." 

Input Variables 

u,v (u,v) defines a point on the backdrop. The range is between 0 and 1. (0,0) is the lower left corner, (1,1) 
the upper right. 

Formula Background 

Output Variables 

value or red, green, blue 

Refer to "Formula Shader." 

Input Variables 

x,y,z (x,y,z) is the global coordinates of the direction vector, from the camera eye to the background. The 
vector (x,y,z) is normalized and each coordinate ranges between -1 and +1. 

Formula Gel 

Output Variables 

value or red, green, blue 

Refer to "Formula Shader." 

Input Variables 

u,v (u,v) defines a point on the backdrop. The range is between 0 and 1. (0,0) is the lower left corner, (1,1) 
the upper right. 

Formula Primitive (Object) 

Output Variables 

x,y,z local coordinates of the point defined by (u,v). 
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Input Variables 

u,v The parametric space coordinates. The range is between 0 and 1. 

Using Scene Effects 
Carrara provides some environment options to help complete the appearance of your scene in renderings. 
These options include Ambient Light, Atmospheres, Backgrounds, and Backdrops. 

You’ll find the scene effects option in the Properties tray: Effects tab after you select Scene from the 
Instances tab or from the Sequencer tray. 

 
To apply a scene effect: 

1. Click the working box to deselect any selected objects, or select Scene from the Properties tray: 
Instances tab. 

2. Click the Properties tray: Effects tab. 

3. Select the effect you want: Ambient, Atmosphere, Background, or Backdrop. 

4. Set the options for the effect in the panel that drops down. 

NOTE! The results of Scene Effects settings are visible in the final rendering or when you render 
an area with the Test Render tool. You can return to these settings, make changes, and render again. 

Ambient 
Ambient light is uniform throughout the scene. It radiates in every direction, having no specific origin and 
casting no shadows. 

Ambient light is useful for scene building, but you will want to turn it down or even off for rendering, since 
it tends to reduce the feeling of depth by washing out shadows and contrast. Instead, concentrated light 
sources (from specific lights) bring out shadows and highlights and emphasize your subject's form and 
surface features. 

TIP! A properly placed distant light is actually more effective than ambient light for simulating a 
daylight scene. 

Ambient light characteristics are scene settings. Choose color and brightness to achieve the effect you 
want. Remember, a strong ambient light level washes out the effects of your specific lights. 

TIP! Use a warm color to simulate indoor light and a cool color to simulate outdoor light. 
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To set ambient light: 

1. Display the Properties tray: Effects tab: Ambient panel. 

2. Click the color chip and select a color from the color picker. 
 

 
3. Enter a percentage for the brightness. 

4. To view your changes, use the Test Render tool. 

Atmosphere 

Atmosphere 
Carrara offers two fog effects:Distance Fog and Cloudy Fog:and two different simulations of sky :Sky and 
Realistic Sky. 

 

NOTE! Choose None if you do not want your scene to use atmosphere effects. Choose one of the 
other options to add fog or sky atmospheric effects to your scene. 
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Cloudy> Fog 
Cloudy Fog produces an effect that simulates the irregular clumping of clouds. 

To use Cloudy Fog: 

1. In the Properties tray, choose Scene from the Instances tab. 

2. In the Properties tray: Effects tab: Atmosphere panel, choose Cloudy Fog. The available 
settings appear. 
 

 
3. Set the Cloudy Fog settings:  

• Top and Bottom define the vertical range (along the Z axis), where fog appears. When 
you are setting this option keep in mind that altitude Z=0 runs through the center of the 
working box when the working box is in its default position. 

• Density determines fog thickness. 

• Lumpiness determines how much the fog clumps together. 

• Global Scale determines the spacing between the wisps of fog. 

4. Click the color chip to set its color. For information on Carrara's color picker, refer to "Color 
Pickers." 

Distance Fog 
Distance Fog produces an effect like a haze, which is more apparent across greater distances. This fog 
has uniform density. 

To use Distance Fog: 

1. In the Properties tray, choose Scene from the Instances tab. 

2. In the Properties tray: Effects tab: Atmosphere panel, choose Distance Fog. 
 

 
3. Set the Distance Fog settings: 

• Start Radius sets the distance from the camera to where the fog begins. 
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• Extent Radius sets the distance beyond the start of the fog where it becomes so thick 
that visibility becomes zero. 

4. Click the color chip to set its color. For information on Carrara's color picker, refer to "Color 
Pickers." 

Realistic Sky 
Realistic Sky enhances the simulation offered by Sky, using an even more accurate model to simulate the 
optical phenomena created by the atmosphere. You have probably noticed that the color of an object 
changes slightly with its distance from the viewer (e.g. remote mountains appear bluish). Realistic Sky 
enables you to create this natural effect (called aerial perspective) on your scene. Additionally, the 
physical model involved is used to render the sky and the clouds, which makes them more realistic than 
in previous versions of Carrara. 

To use Realistic Sky: 

1. In the Properties tray, choose Scene from the Instances tab. 

2. In the Properties tray: Effects tab: Atmosphere panel, choose Realistic Sky. 
 

 
3. Adjust the general settings of your Realistic Sky:  

• Enable Ground: If you don’t yet have a terrain in your scene, enable this checkbox to 
display an infinite plane as the Ground. 

• Ground Color: Click the color swatch to set the color of the ground plane. 

• Horizon Altitude: Set the Horizon Altitude in relation to the working box. Cameras 
located below the horizon altitude won’t see much. 

• Clouds Animation: Controls the Clouds Animation by giving each keyframe an elapsed 
time value. 

• Click the Edit button to open the Atmosphere Editor, described next. 

For further information on Realistic Sky, see "Using the Realistic Sky Atmosphere Editor." 

Using the Realistic Sky Atmosphere Editor 

When you click the Edit button with Realistic Sky selected in the Properties tray: Effects tab: Atmosphere 
panel, the Atmosphere Editor displays various properties for realistic sky. These settings are similar to 
those used for the Sky editor discussed in "Using the Sky Atmosphere Editor." 
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The Atmosphere Editor contains: 

• The Preview section in the top left corner. 

• The Sun Editor and the Moon Editor in the top right corner. 

• The Atmospheric effects section in the bottom half. 

The following sections will guide you through the fast and simple process of creating a realistic sky in 
Carrara. The first step is to configure the Preview Renderer options. 

Configuring the Realistic Sky Preview 

The Preview renderer is located in the upper-left corner of the Realistic Sky editor.  

To render the preview: 

 © 2008 DAZ 3D, Inc. 425 



Carrara 7 11 December 2008 

1. Select the scene that you want to use in the preview renderer:  

• Choose My Scene to use your current scene in the preview renderer. 

• Choose Default Scene to use a default grassy plain for your preview. 

2. Click the Render button, on the right side. The preview shows the Realistic Sky using the current 
settings from the editor. 

3. If you want changes to any parameter to automatically refresh the preview, then check Auto 
Refresh. If not, you will have to click Render each time you make a change. 
 

 

Setting the Aerial Perspective 

If you are using your own scene in the Preview renderer, you must first specify the size of your world to 
get the correct aerial perspective effect on your scene 

To get the correct aerial perspective: 

• Indicate, in the lower Atmosphere section, the scaling factor of your scene. Give an estimated 
correspondence between the distances in the scene and what they stand for in reality. 

• You can tweak these values to get more or less aerial perspective effect on your scene. 
 

 

NOTE! This scaling factor also takes into account the cameras. Thus, a big scale can make them 
go out of the atmosphere. 

Putting the Sun in Place 

Now that you have visualized the default settings and applied the desired aerial perspective, use the Sun 
section to adjust the Sun settings: 
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To put the Sun in place: 

1. Click the trackball and drag in a direction. The correspondence between the cardinal points and 
the working box orientation helps you position the sun in your scene. 

2. Set the following additional properties as desired:  

• Sun: Click the color swatch to set the color of the Sun. 

• Aura: Click the color swatch to set the color of the aura. 

• Night: Check this option if you want to put the sun behind the Earth. 

• Sun Size: Move the slider to set the size of the Sun. 

• Aura Size: Move the slider to set the size of the aura. 

3. For more accurate settings, click the Advanced button to open the Sun properties dialog.  
 

 
4. Set the following properties in the Sun Properties dialog as desired:  

• Year: Enter the desired year that you want to represent. 

• Month: Enter the desired month that you want to represent. 

• Day: Enter the desired day that you want to represent. 
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• Hour (GMT/Decimal Format):Enter the desired time, in decimal format, that you want to 
represent. For example, 6:45 PM would be 18.75. If entering time for a location other 
than GMT, you'll need to know the number of hours to offset by (also allowing for daylight 
savings time). For example, California time is 7 hours behind GMT on September 10, so 
you enter 11.75 to correspond with 18.75 GMT. For further information, see 
www.greenwichmeantime.com. 

• Latitude of Viewer’s Position: from -90 in the South Pole to 90 in the North Pole. 

• Longitude of Viewer’s Position: from -180 to 180, negative (positive) in the West (East) 
of Greenwich. 

• Compute Sun Position: Click this button to calculate the position of the sun based on 
the above values. 

• Altitude Angle: The altitude from the horizon based on the computations. You can also 
enter a value manually. 

• Azimuth Angle: The azimuth (clockwise movement) of the sun based on the 
computations. You can also enter a value manually. 

Putting the Moon in Place 

The Moon editor is located directly beneath the Sun editor, and has similar settings as those found in the 
basic Sun editor. 

 
To put the Moon in place: 

1. Check the Show the Moon option to enable the moon controls. 

2. Click the trackball and drag in a direction. The correspondence between the cardinal points and 
the working box orientation helps you position the moon in your scene. 

3. Set the other properties as needed:  

• Moon: Click the color swatch to set the color of the moon. 

• Aura: Click the color swatch to set the color of the aura. 

• Aura Size: Adjust the slider to set the size of the aura. 

• Phase: Adjust the slider to adjust the phase of the moon, ranging from new moon to full 
moon. 

• Tilt: Adjust the slider to adjust the tilt of the moon. 

Modifying the Atmosphere 

You may want to change the visual impact of the atmosphere on your scene. For this purpose, you have 
several options in the Atmosphere Layer, which is displayed by clicking the Atmosphere icon (the top one) 
on the left side. 
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To adjust the luminosity: 

• Move the Global Exposure slider to adjust the luminosity of the scene. 

To modify the sky color 

The sky color mainly depends on the effect of the air molecules on the light and the default color is 
calculated for our planet's air. If you want to modify the sky color, you can either: 

• Move the Red, Green and Blue Intensities sliders, or; 

• Pick up a color by clicking the Color swatch, which will automatically calculate the associated 
Red, Green and Blue Intensities. 

NOTE! The Sky simulation is based on a physical model and the default Red, Green and Blue 
Intensities stand for measured values of the air properties. 

To set the haze: 

The haze lies at the bottom of the atmosphere and adds a visual effect that doesn't exist on the top of the 
atmosphere. Control this effect with the Atmosphere Layer. 

 
1. If you want the haze more dense where it lies, increase the Haze Density slider. 

2. If you want the haze to be more present in your sky, increase the Haze Altitude slider. 

3. You can modify the haze color by using the Red, Green and Blue Filters sliders: the more a 
color is filtered by the haze, the less it is present in the horizon (but still present up in the sky). 
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Adding Some Fog 

While you can change the color of the sky at the horizon thanks to the haze settings, you may also want 
to add some fog that affects your objects in the scene. For that purpose, click the Fog icon (the second 
one) on the left side, which shows the Fog Editor. To be able to use it, check Enable. 

 
To set the fog: 

1. The fog will appear in the region between the horizon altitude (the ground) and an altitude that 
you control with the Altitude slider. 

2. If you want your fog to be more opaque, increase the Intensity slider. 

3. Finally, apply a Fog Color by clicking the color swatch. 

Adding Some Clouds 

Realistic Sky provides you with four independent cloud layers. To use a cloud layer, make sure you have 
its Enable option checked. To modify the settings of a cloud layer, click its icon on the left side, which 
shows the Cloud Layer Editor. 
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To shape the clouds: 

1. If you want big thick clouds, then you can move up the Thickness and Coverage sliders. If you 
want thin Cirrus-like clouds, you must have a small Thickness value. 

2. If you want your clouds to be more uniform, you can decrease the Lumpiness value. 

3. Control the amount of intricate details of a cloud with the Micro Details Level slider. 

4. Apply scaling factors to the clouds by moving the X Ratio and Y Ratio sliders. 

5. If you want to change the clouds' distribution, click Shuffle to compute a brand new one. 

To position the clouds 

1. Increase the Altitude slider if you want this layer's clouds to appear higher in the sky. 

2. To adjust the clouds' position to your scene, you can rotate the layer around the z axis with the 
Layer Rotation slider. 

To animate the clouds 

1. Set the Movement Direction of this layer's clouds by moving the circular slider. If you want them 
to move in the East (y axis) direction, move the cursor up to 90 degrees from the South (x axis). 

2. Set the Movement Speed of this layer's clouds by typing in the distance they traverse in one 
hour. 
 

NOTE! Type in a distance in a certain unit and Carrara automatically converts it in miles if 
you prefer Imperial units or kilometers if you prefer metric units. 

3. If you want the clouds' shape to evolve quickly over time, move up the Transformation slider. 

Realistic Sky Tips and Tricks 

To speed up your workflow 

1. Unless you want to check the effect of Realistic Sky on the objects located under the Horizon 
Altitude, you can enable the Ground option to quickly render this region. 

2. Clouds are mainly responsible for the computation time of Realistic Sky. You may want to start 
by setting the other features without any cloud layers and then add the clouds. 

3. Check Auto Refresh if you want to immediately visualize each of your changes. 

To get beautiful (realistic) skies 

1. In the Insert menu, choose a Sun Light or a Moon Light to lighting your scene accordingly to 
the Sun's or Moon's position. 

2. The Red, Green and Blue Filters sliders for the haze should have about the same values. It 
comes from the fact that the light scattering (and absorption) processed by the haze is almost 
independent of the wavelength. Increasing their values makes the haze thicker. 

3. The Red, Green and Blue Intensities sliders for the sky color stand for the amount of light 
scattered by air molecules. Since these are measured physical values, you should not change 
them too much if you want your sky to keep looking terrestrial. The Reset Button allows you to 
restore the original settings. 

4. If you want a beautiful sunset, set the Sun near the horizon and see how realistic the sky color 
looks! Add clouds and see how their lighting is nicely affected by the Sun. 
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TIP! A very hazy sunset has a big bright halo around the Sun. Reproduce this effect by 
increasing the Haze Density. 
 

 
5. If you want overcast weather, you can use several cloud layers, with high values for Thickness 

and especially the Coverage parameters. Use the Layer Rotation and Altitude sliders to have 
the different layers superimposed as you like. Decrease the Global Exposure of the Atmosphere 
Editor. 

6. You may observe some artifacts in your sky if you use some unusual settings. To correct them, 
increase the Accuracy slider, on the top right corner of the Atmosphere Editor. 

7. Combine Realistic Sky with other environment effects:  

• Volumetric Clouds (refer to "Volumetric Clouds"). (Standard, Pro) 

• Backgrounds and Backdrops: You can load a map as a background and apply Realistic 
Sky on it. See "Backgrounds and Backdrops." 

To create a nice animation 

1. Every parameter can be modified from a keyframe to another to create an animation: the Sun's 
position, the fog intensity, the clouds' color and so on. 

2. If you want your clouds to change direction during the animation, create a keyframe with a 
different value for the Movement Direction. You will see the clouds turning in the sky. 

You can control the speed of your clouds animation by attributing each keyframe a number of run out 
seconds. This way, you can choose to simply follow the Time Line or have a time control (and not 
necessarily linear) dedicated to the clouds.  

Sky 
Sky simulates the interaction between light and the earth's atmosphere. Based on a physical model of a 
real atmosphere, Sky creates a realistic surrounding for objects in your scene. 

With the Sky effect, you can create various haze, fog, rainbows, cloud, sun and moon effects. 

To use Sky: 

1. In the Properties tray, choose Scene from the Instances tab. 
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2. In the Properties tray: Effects tab: Atmosphere panel, choose Sky. 
 

 
3. Adjust the Sky settings as appropriate:  

• Ground Height defines the altitude of the ground in your scene. 

• Maximum Altitude defines the overall size of the Sky atmosphere. This value scales the 
atmosphere in every direction. For example, if Maximum Altitude is set to 200", the haze, 
fog and cloud layers altitudes can be set from 0" (the ground) to 200". Generally, you 
should set the Maximum Altitude to a value greater than the overall size of your scene. 
 
For special effects, you can set an Maximum Altitude that is smaller than your scene. 
This makes cloud layers appear below the highest object in a scene, simulating the effect 
of an airplane or mountain going through the clouds. The atmosphere always starts at 
altitude zero (z=0). Objects below z=0 are invisible. 
 

NOTE! The camera must be at an altitude greater than zero. If your camera is 
below zero, you'll see the atmosphere from below the ground, which leads to interesting 
but unpredictable results. 

• Shuffle resets the random shape of the clouds. 

• Completion defines when clouds start to move and when they stop. Use this slider in an 
animation. Typically, you would set the time to 0% at the first frame of your animation and 
100% at the last frame. 

4. To quickly and easily set up an atmosphere, choose a setting from the Use Preset pop-up menu. 
Carrara automatically sets all the parameters for you. Or, to control each effect, click the Edit 
button. The Atmosphere Editor appears. 

For further information about Sky, see "Using the Sky Atmosphere Editor." 

Using the Sky Atmosphere Editor 

To access the Atmosphere Editor, in the Sky workspace, click the Edit button. The Atmosphere Editor 
appears. 
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The Atmosphere Editor contains: 

• Preview section 

• Sky Editor 

• Sun Editor 

• Moon Editor 

• Layer Manager 

• Layer Editor 
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The Preview Section 

The Preview section renders the atmosphere based on the current settings. Each time you modify a 
parameter, the preview updates to show the result. What you see in the Preview is exactly what you get 
in your scene. 

The Preview has two display modes: 

• Standard Camera Mode 

• Fish-Eye Camera Mode 

Standard Camera Mode gives you a view of the atmosphere using a conical camera looking to the West. 

 
Standard Camera Mode only renders a small area of the atmosphere but it is perfect for setting up a 
sunrise or a sunset. 

To simulate Standard Camera Mode in your final rendering: 

1. Set the rendering camera to Front position. 

2. In the Camera Palette, set the lens type to Conical. 

3. Raise the camera (Z=8 in). 

Fish-Eye Camera Mode renders the whole atmosphere as viewed from the ground through a fish-eye 
lens. You can use this mode to preview the entire sky, not just the western horizon. 
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The Sky Editor 

The Sky Editor lets you change the color of the sky and the ground. You can also add or remove 
rainbows. 

 
To set the sky or ground color: 

1. Click the Sky or Ground color Swatch. You can also click the arrow next to the swatch. 

2. Choose the desired color. 

3. The Rainbow slider controls the intensity of the rainbow in your atmosphere. By default, the 
rainbow intensity is 0% (invisible). Dragging the Rainbow slider to the right to change the intensity 
of the rainbow. 

The rainbow rendering is made of two parts: the primary rainbow and the secondary rainbow. The 
intensity of the primary rainbow is about ten times greater that the intensity of the secondary one. By 
adjusting the intensity setting you can make the secondary and primary rainbows appear or disappear. 

NOTE!  The Sky rainbow reacts just like a real one. To see a rainbow, you must carefully move the 
sun behind the camera. 

The Sun Editor 

The Sun Editor lets you change the position, color, aura (or halo) color and size of the sun. 

The virtual trackball at the center of the Sun editor lets you set the position of the sun. 
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To set the sun's position: 

1. Click anywhere on the trackball and drag in the direction you want to move the sun. 

2. When the sun is in the desired position, release the mouse button. The sun's position and sky 
color are updated automatically. 

Sky uses the convention illustrated below to map geographic directions to the Carrara perspective 
window. To predict where the sun will appear, keep the convention in mind. 

 

TIP! To see the sun in the Dynamic Preview, drag it to the West. 

To switch between day and night: 

• Check the Night check box in the upper right corner of the editor. 

This moves the sun from one side of the Earth to the other. When the Night check box is selected, the 
Sun is not visible in the atmosphere (since it is on the other side of the Earth) and the sky darkens. 

To set the sun's color: 

1. Click the arrow next to the Sun color swatch to open a color palette. Or, click the swatch to open 
a Color Picker. 

2. Select the desired color. 

To adjust the sun's aura size: 

1. Use the Aura control to adjust the size of the sun's aura. 

2. Drag the Aura control to the right to increase the aura or halo size, or to the left to decrease it. 

To select a color for the sun's aura: 

1. Click the arrow next to the Aura color swatch to open a color palette. Or, click the swatch to open 
a Color Picker. 

2. Select the desired color. 
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The Moon Editor 

The Moon Editor lets you change the position, color, phase, aura (or halo color), and size of the moon. 

 
The virtual track ball at the center of the Moon editor lets you set the position of the moon. 

To set the moon's position: 

1. Click anywhere on the trackball and drag in the direction you want to move the moon. 

2. When the moon is in the desired position, release the mouse button. 

The moon's position and sky color are updated automatically. 

Sky uses the convention illustrated below to map geographic directions to the Carrara perspective 
window. To predict where the moon is going to appear, keep the orientation of the directions in mind. 

TIP! To see the moon in the Dynamic Preview, drag it to the West. 

To switch between day and night: 

• Click the Night check box in the upper right corner of the editor. 

The Night check box moves the moon from one side of the Earth to the other. 

To set the moon's color: 

1. Click the arrow next to the Moon color swatch to open a color palette. Or, click the swatch to open 
a Color Picker. 

2. Select the desired color. 

Use the Aura control to adjust the size of the moon's aura or halo. 

To adjust the moon's aura size: 

• Drag the Aura control to the right to increase the halo size, or to the left to decrease it. 

To select a color for the moon's aura: 

1. Click the arrow next to the Aura color swatch to open a color palette. Or, click the swatch to open 
a Color Picker. 

2. Select the desired color. 

To change the moon's tilt and phase: 

• Click the Moon Phase and Tilt selectors and drag each one in the direction you want to tilt the 
moon. 
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The Layer Manager 

The Layer Manager lets you edit the layers in your atmosphere and display or hide them. 

. 

To display or hide a layer: 

• Click the Enable check box next to the layer. When the layer is displayed, there is a check in the 
Enable check box. 

To edit a layer: 

• Click the layer's icon. The settings for this layer are displayed in the Layer Editor. 

NOTE! When you edit a layer, you must display it to see the result in the dynamic preview. 

The Layer Editor 

The Layer Editor lets you edit the various types of layers you can add to an atmosphere. Its appearance 
varies, depending on which layer is selected for editing. 

The Layer Editor types are: 

• Haze layer 

• Fog layer 

• Cloud layer 

Haze Layer Editor 

Haze is a light fog that appears due to the humidity found in the atmosphere. 
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To edit the haze color: 

1. Click the arrow next to the color swatch in the upper left corner of the Layer editor to open a color 
palette, then choose the desired color. Or, click the color swatch to open the Color Picker. 

2. Adjust the sliders to the appropriate settings.  

• Intensity sets the intensity of the haze. 

• Altitude sets the altitude of the haze. The value set in this slider is the height of the 
ground. 

• Distance sets the distance at which the haze begins to be visible. 

The altitude and distance percentages are based on the Maximum Altitude. For example, if you set the 
Maximum Altitude to 200", the haze layer altitude can be set from 0" (0%) to 200" (100%). 

Fog Layer Editor 

The Fog Layer editor lets you set the color, intensity, altitude, and distance of fog in your atmosphere. 

 
To edit the fog color: 

1. Click the arrow next to the color swatch in the upper left corner of the Layer editor to open a color 
palette, then choose the desired color. Or, click the color swatch to open the Color Picker. 

2. Adjust the sliders to the appropriate settings.  

• Intensity sets the intensity of the fog. 

• Start and End define the altitudes where the fog starts and stops. 

• Distance defines the distance at which the fog begins to be visible. 
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The distance, start, and end sliders use percentages based on the Maximum Altitude. For example, if you 
set the Maximum Altitude to 200", the fog layer altitudes can be set from 0" (0%) to 200" (100%). 

Cloud Layer Editor 

Your atmosphere can have up to four layers of clouds. The Cloud Layer editor lets you set the color, size, 
altitude, and density for each cloud layer. When adjusting these settings, keep in mind how the cloud 
layers you use will interact. You can see this interaction in the Preview. 

To edit the cloud color: 

1. Click the arrow next to the Clouds color swatch to open a color palette. Or, click the color swatch 
to open the Color Picker. 

2. Choose the desired color. 

The Cloud Layer editor provides seven graphic cloud controls for adjusting the density and altitude of 
clouds in the layer. 

 
To adjust a cloud control setting: 

Use the three first sliders to set the cloud's contrast, thickness and coverage. Together these settings 
determine the quality of the weather. 

• The Thickness control lets you set the cloud thickness from almost transparent clouds to thick 
clouds in a heavy storm. 
 

TIP! The cloud thickness setting is the most important of the settings because it controls 
the density of the clouds and this affects how light interacts with them. Like in the real world, thin 
clouds scatter light and thick clouds absorb light. To create beautiful sunsets, drag the sun near 
the horizon and add several layers of thin clouds. 

• The Coverage control determines the cloud coverage. Use this control to choose between a blue 
sky and a completely overcast sky. 

• The Lumpiness control sets the cloud's contrast. 

The next four sliders are used to change geometry of the cloud layer. 

• The Rotation slider affects not only the appearance of clouds, but the direction they move in an 
animation as well. 

• The X and Y ratio controls control the size of the clouds in the layer. 

• The Altitude control controls the altitude of the cloud layer. 
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NOTE! By default, Cloud Layers are arranged with Layer 1 set to the lowest altitude and Layer 4 at 
the highest. 

Cloud Animation Sliders 

The two sliders on the right let you control the animation of the cloud layer. Use the first slider to set the 
speed of the clouds. If you do not want the clouds to move, set the slider to 0%. 

Use the second slider to control the transformation of the clouds over time. At 0% the shape of the clouds 
remains the same. 

Rendering the Sky 

After you're satisfied with the settings in the Atmosphere Editor, click OK. Render the image as usual. 
You'll soon see the atmosphere surrounding your objects. 

Animating Sky 

The Sky effects can be animated. Just by dragging the sun, you can create a photo-realistic sunset. 
Carrara handles everything for you, including the reddening of the sun as it approaches the horizon, 
moving clouds, darkening skies, and scattering light through the clouds. You can even modify the 
atmosphere parameters to render alien planets. 

To use Sky in an animation: 

1. Create your animation as usual. 

2. With the Current Time Bar at 0:00:00, select Scene from the Properties tray. 

3. Select Properties tray: Effects tab: Atmosphere panel: Sky. 

4. Edit the Sky parameters. 

5. Set the Completion slider to 0%. 

6. Jump to the end of your animation. 

7. Set the Completion slider to 100%. 

8. Render your animation as usual. 

You can also use various Sky parameters over the course of an animation. To do this, apply different 
parameters to different key frames. For example, you could make the sky seem to become overcast over 
time by setting the Sky parameters in the first frame to create a clear day, and then creating a key frame 
and adjusting the Cloud density parameters to create a cloudy day. When animated, the sky appears to 
become overcast. You can animate any of the Sky parameters in this way. 

Backgrounds and Backdrops 
When you render your scene, regions where there are no objects are considered background areas.  

Carrara offers two features for filling in the space between objects:background and backdrop.  

• Backgrounds: The background gives you control over the scene environment. The background 
is sometimes called an environment map. During rendering, the background is projected on the 
inside surface of a giant sphere that surrounds your scene. Any region of a rendering not 
occupied by an object will show the background. The background is also the environment 
reflected by reflective objects. There are several types of backgrounds available, which are 
described in the following sections. 
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NOTE! An isometric camera cannot record a Background. If you are using an isometric 
camera for your final rendering, use a Backdrop instead. 

• Backdrops: A backdrop is a 2D plane placed behind your scene, and that stays perpendicular to 
the camera. The backdrop appears in regions of the rendering where there are no objects. The 
backdrop does not appear in reflections or interact with the lighting. 

Tip You may want to use both a backdrop and a background. In this case, Carrara uses the background 
for the reflection environment and places the backdrop behind the objects. 

There are several options for backgrounds and backdrops, covered in the sections that follow. 

None 
By default, or by selecting None, these areas appear black in the renderings.  

Bi Gradient Controls 
A Bigradient Background or Backdrop creates a paired gradation for the background. This is an easy way 
to create a sky and horizon. 

To use a bigradient for the background or backdrop: 

1. In either the Properties tray: Effects tab: Background or Backdrop panel, choose Bigradient. 
 

 
2. Set the Bigradient settings as you like. 

3. Select colors for Start Sky, End Sky, Start Ground, and End Ground.  

4. Use the Horizon slider to set the height of the horizon. 

Color Controls 
Color sets a solid color as the background. 

To use color background or backdrop: 

1. Choose either the Properties tray: Effects tab: Background or Backdrop panel: Color.  

2. Adjust the color in the color chip. 
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Formula Controls 
The Formula control creates a color pattern from a formula. You can devise your own formula to create a 
new pattern. 

The formulas for a Background or Backdrop differ. The Background is projected onto a sphere, so it uses 
a 3D system. The Backdrop is rectangular, so it uses a 2D system. 

To select a formula for the background or backdrop: 

1. In either the Background panel: Properties tray: Effects tab: Background or Backdrop panel, 
choose Formula. 

2. Double-click the object. The Formula controls appear. 
 

 
3. Enter a formula into the editing panel on the top, or edit the existing one. 

4. Set the Formula controls to create an object of the shape you want:  

• Parse tests and compiles the formula. If there are any errors, Carrara gives you an error 
report. 

• Animatable Parameters increase and decrease the value of parameters. 
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• More displays the Formula Editor. 
 

 
For more information on creating Formula objects, refer to "Using Formulas in Carrara." 

HDRI Controls 
The HDRI background uses a High Dynamic Range Image (HDRI) as a background (Note that there is no 
HDRI backdrop). Using the HDRI background is especially useful if you want to create realistic reflections 
on your objects or simply create complex lighting (using the sky light option of the renderer). 

What is HDRI? A HDR image (.hdr file) is a special file format that stores an image with a lot more 
precision than a regular bitmap format (such a JPEG). In the real world, the intensity of the light varies a 
lot more than on a regular photo. You can see this when taking pictures of scenes lit by the sun: the areas 
in the shadows appear black whereas the areas under the sun appear almost white. An HDR image will 
contain details in both the bright areas and in the shadows. 

What type of map is supported? There are several types of HDRI maps (cube maps, sphere maps....). At 
this point, only one type is supported: simple spherical maps. They are easy to recognize: if you look at 
the image the contains the map, it should completely fill the rectangle of the image. 
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To use a HDR image for the background: 

1. In the Properties tray: Effects tab: Background panel, choose HDRI. 

2. Click on the button to open the file dialog and select a.hdr file to use as your background. 

3. Adjust the following settings:  

• Intensity: Increase or decrease the intensity of the map. 

• Flip Horizontally or Vertically 

• Rotation: Rotates the map 

• Tile: Repeats the image. (You can use the Horizontal and Vertical sliders to select the 
number of repetitions). 

• Seamless: Creates tiling where the map is flipped so that the side of each tile is 
continuous. 

• Interpolation: Use to create a smoother map 

Map Controls 
The tools and methods for using a map are the same for the background or backdrop. 

Map uses a bit-mapped image file as the background. This is the best choice when you want specific 
images in reflections. 

Ideally, images for the background should have an aspect ratio of 2:1 (twice as wide as they are tall). 
Images for the backdrop should have the same aspect ratio as the final rendering and be equal or greater 
in resolution. 

To select a map for the background or backdrop: 

1. In either the Properties tray: Effects tab: Background or Backdrop panel, choose Map. 

2. Click the folder icon to locate and open a bitmapped image file. When you've opened an image, a 
preview appears in the right panel. 
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3. Set the Map controls:  

• The directional buttons under the folder icon change the image's orientation. 

• Tile causes the image to repeat. The Horizontally and Vertically sliders set the number 
of tiles in each direction. 

• Seamlessly tiles the image without visible seams between tiles. Carrara flips adjacent 
tiles vertically and/or horizontally as necessary to avoid seams. 

• Invert Color inverts the image's colors. 

• Interpolate gets cleaner results in your rendering. 

• Brightness slider increases and decreases the image's brightness. 

• Filtering determines the quality of the render: 

• Sampling produces the fastest but lowest quality render. 

• Summed Area Table produces a better quality render, but uses more memory. 
You may want to avoid it for large texture maps. 

• Gaussian Filtering produces the best quality render. 
 

TIP! You can apply a filter to the map. For more information, refer to 
"Rendering Effects." 

4. Save Internally - TBD 

5. Save Externally - TBD 
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Movie Controls 
You can use a sequence of images in the background of your scene. Use movies only when you create 
an animation. 

 
To select a movie for the background or backdrop: 

1. In either the Properties tray: Effects tab: Background or Backdrop panel, choose Map. 

2. Click the folder icon to locate and open an AVI or QuickTime movie file. When you open a move 
file, a preview appears, with a preview player below it 

3. Set the Movie controls as you like: 

• The directional buttons change the image's orientation. 

• Tile causes the image to repeat. The Horizontally and Vertically sliders set the number 
of tiles in each direction. 

• Seamlessly tiles the image without visible seams between tiles. Carrara flips adjacent 
tiles vertically and/or horizontally as necessary to avoid seams. 

• Invert Color inverts the image's colors. 

• Interpolate gets cleaner results in your rendering. 

• Brightness slider increases and decreases the image's brightness. 

• Filtering determines the quality of the render: 

 © 2008 DAZ 3D, Inc. 448 



Carrara 7 11 December 2008 

• Sampling produces the fastest but lowest quality render. 

• Summed Area Table produces a better quality render, but uses more memory. 
You may want to avoid it for large texture maps. 

• Gaussian Filtering produces the best quality render. 

Flash Controls 
TBD 

Casting Shadows on Background Objects 
The Shadow Catcher feature allows you to generate true shadows for 3D objects, so they appear on 
background imagery in a realistic way. 

The surface you apply to the Shadow Catcher object provides the color and transparency level of the 
shadow. A Shadow Catcher object is rendered only in the areas where it is in shadow. All other parts of 
the object display the background color or image. Objects behind a Shadow Catcher object are not visible. 

NOTE! Shadow Catcher objects work with Ray Tracing or Hybrid Ray Tracing rendering only. In all 
other rendering modes, they appear as normal objects. 

To cast a shadow on a background: 

1. Create a simple model of the background object. Use the background image to align the objects 
and the camera's point of view. In the following example, we want to cast the shadow of the 
saucer on a cityscape background image.  
 

  
2. Select the object or objects to which you want to apply the Shadow Catcher. 

3. Position the object that is casting the shadow over the Shadow Catcher object. 

4. Go to the texture room and change the top shader to Shadow Catcher (in the Lighting Models 
category). 

5. Disable the Cast Shadows checkbox. Otherwise, Shadow Catcher objects that cast shadows on 
other objects can create an undesirable effect. 

6. Render the scene. During rendering, the background becomes visible, as though the image itself 
is shadowed. 
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Adding Sound to Your Scene 
Carrara provides tools for adding a sound track to animations you create. The sound track can have any 
number of individual channels, each with sounds placed at times you choose. When Carrara renders an 
animation, it saves the sound track to the final movie file. 

Sound can be integrated in your workflow in two ways. First, you can synchronize sound effects to events 
in your animation. For example, if you have an explosion in your animation, you can add an explosion 
sound effect and place it in the sound track at the appropriate time. 

Second, you can create a sound track for your animation in an audio production package, and then add 
the sound track to your animation so that you can synchronize the events in the animation to the sound 
track. 

Creating Animations With Sound 
When you create a new file or open a file saved with an older version of Carrara, the Sound track is 
empty and the document has no sounds loaded. You can add sound to an animation by first loading 
sound files as master sounds, and then placing instances of them in the sound track. Currently, Carrara 
supports sound files in uncompressed Microsoft WAV and Apple AIFF formats. See "Animation Features 
of the Sequencer Tray" for more information about using the Sequencer tray. 

Adding Soundtrack Channels 
When you create a new document, or open an existing document without sounds, the soundtrack has a 
single, empty channel. The soundtrack can have any number of simultaneous channels, each with 
multiple sounds. Soundtracks appear at the bottom of the hierarchy in the Sequencer Tray. 

.  
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To add channels to the soundtrack: 

• Click the + button next to the word Soundtrack in the Sequencer tray. 

To remove channels from the soundtrack: 

1. Select the channel to be removed by clicking on the channel's name. 

2. Do one of the following:  

• Click on the - button next to the word Soundtrack in the Sequencer tray. 

• Right-click the sound channel and choose Delete from the menu that appears. 
 

NOTE! When you remove a channel from the soundtrack, all sound instances in 
that channel will be deleted with it. 

Adding a Master Sound to Your Project 
Before you add sounds to your soundtrack you have to add a master sound to the project. Use the 
Properties tray: Sounds tab to add one or more sounds to your project. When a master sound is loaded, a 
small preview icon appears in the Sounds tab. 

To load a master sound into the document: 

1. Click on the Sounds tab in the Properties tray. Alternatively, choose the Insert > Insert Sound 
command. 

2. Click the Add button. 

3. Select the sound file to load, click OK. 
 

 

Removing Master Sounds 
When you no longer want to have the master sound in your document you can remove it. For example, 
when you want to replace it with another sound. Removing a master sound removes all instances of that 
sound in the soundtrack. 

To remove a master sound from the document: 

1. Click on the Sounds tab in the Properties tray. 

2. Select the master sound icon to be removed. 
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3. Click the Remove button. 
 

 

Adding Sounds to the Soundtrack 
After you add a master sound in the Sounds tab of the Properties tray, you can drag and drop the icon 
from the Sounds tab into the soundtrack to create an instance of the sound. 

To add sounds to the soundtrack: 

Drag a master sound preview icon into the sound track and release it. 

 
A preview of the sound will appear, beginning at the cursor location when you released the sound. Sound 
instances can be positioned within their channel by clicking and dragging them. 

 

Rendering Animations With Sound 
When rendering animations with sounds in the sound track, the sounds are automatically written to the 
resulting movie file after all frames have been rendered. If you abort a render in progress, sounds will be 
written to the animation up to when the render aborted. 

NOTE! Not all of Carrara's output file formats support sound writing. A warning message is 
displayed if you try to render an animation with sound to a format where the sound track would be lost. 
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Setting Cameras 

Setting Cameras 
Just as a live action photographer strategically places cameras for different views of a scene, you can set 
up cameras for viewing and rendering your scene. This chapter covers how to create and use cameras. It 
includes descriptions of the different camera types and settings and how to manipulate them to achieve 
dramatic viewing angles. 

Cameras for Viewing and Rendering 
In the Assemble and Storyboard rooms, cameras provide your viewpoints of the scene. For instance, you 
can think of the scene window's 2D presets as views through fixed cameras that point straight at different 
sides of the working box. As you build your scene, you can add and position new cameras and shift your 
view to any of them to get the best view for working. 

Once you are finished building and lighting your scene and are ready to render, you select a camera as 
the viewpoint for your scene. Using this camera, you set the Production Frame of the view that you want 
to render, just like looking through a viewfinder. The Production Frame, described in the next section, 
shows you exactly how much of your scene will be rendered.  

NOTE! Carrara also lets you create camera effects like lens flare, filters, and depth of field. For 
information on these and other rendering effects, refer to "Rendering." 

Creating and Setting Cameras 
A new camera appears in your scene as an object that faces downward. Cameras are objects with 
projections, just like lights and modeled objects. You can move the camera as you would any other object. 
You'll learn about special features for moving and orienting cameras later in "Positioning and Aiming 
Cameras." 

Creating a New Camera 
Cameras are objects with projections, just like lights and modeled objects. You can move the camera as 
you would any other object. You'll learn about special features for moving and orienting cameras later in 
"Positioning and Aiming Cameras." 

In the Hierarchy, cameras are listed as numbered camera objects. You can rename a camera just like any 
object. If you set up several cameras, you might want to name them according to their viewpoints. This 
makes it easier to select the view you want. For more information on naming objects in the Hierarchy, 
refer to "Naming Objects." 
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The current camera is not visible in the scene window. Because you are viewing the scene through it, it is 
not visible within the scene. You create specific lights in the Assemble or Storyboard room. All the light 
tools come off a single pop-up menu. 

To create a new camera: 

1. Choose the type of camera you want from the Create Camera tool pop-up menu. Choices are 
Conical, Isometric, and Spherical. 
 

 
2. Drag the camera into the scene window. The new camera appears in your scene as an object 

that faces downward. 

To create a new camera from the Insert menu: 

1. From the Assembly or Storyboard room, choose one of the following:  

• Choose Insert >Conical to create a conical camera. 

• Choose Insert >Isometric to create an isometric camera. 

• Choose Insert >Spherical to create a spherical camera. 

2. The camera appears in the center of your scene. Position the camera to the desired location. 

TIP! To make a camera easier to see (or see around), you can change its size with the scale 
control in the Properties tray: Motion tab: Transform panel just as you can with any other object. This 
does not affect your view through the camera. 
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Setting Camera Properties 
You can change the properties of the current camera using the Camera controls on the Properties tray: 
General tab: Camera panel. 

NOTE! For more information on camera properties, refer to "Carrara's Cameras." 

To change a camera's properties: 

1. Select the camera you want to change. 

2. Display the Properties tray: General tab: Camera panel. 

3. Expand the Camera list and choose the type of camera you want:  

• Conical: This camera has four settings: Wide, Normal, and Telephoto cameras have 
preset focal lengths. When you choose Zoom, you can set a focal length between 6 and 
500 mm. The Distance to Near Plane setting TBD. 
 

 
• Isometric: This camera provides a view in which object size is not related to distance 

from the camera (that is, there is no vanishing point). There are two settings for this 
camera: Zoom (which increases or decreases the zoom of the camera view), and 
Distance to Near Plane, (which TBD). 
 

 
 
With the isometric camera, use a Backdrop, not a Background. For more information on 
using a Backdrop, refer to "Backgrounds and Backdrops." 

• Spherical: This camera renders all items in your scene, including objects that are behind 
it. There are two settings for this camera: Zoom (, which increases or decreases the 
zoom of the camera view) and Distance to Near Plane (which TBD) 
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Carrara's Cameras 
Carrara provides two types of cameras: conical and isometric. This section explains the basic functions of 
these cameras and the best usage of them. If you are familiar with basic photography concepts you may 
skip this section. If you want more detailed information, the techniques given in most reference books on 
still and live action photography may be applied to viewing and photographing scenes in Carrara. 

The Conical Camera 

A conical camera views a scene or object much as the human eye does: from a single point that widens 
as the distance from the eye increases. This creates perspective and the illusion of distant objects being 
smaller than close objects. 

A conical camera is most useful for visualizing how this perspective affects your scene or model. It is 
generally the type of camera you use for rendering, since it most accurately reproduces how our eyes 
perceive distance and depth. 

 

Conical Camera Lenses 

With the conical camera, you can choose a lens setting of Wide, Normal, Telephoto, or Zoom. These 
correspond to lenses used on a real-world 35 mm camera. 

 
• Wide has a focal length of 25 mm. This provides a wider field of view and a smaller image of your 

subject. 
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• Normal has a focal length of 50 mm and most closely approximates the human field of vision. It is 
the default lens for the Reference view camera. 

• Telephoto has a focal length of 200 mm. This provides a larger image of your subject but a 
narrower field of view. 

• Zoom lets you set any focal length between 6 and 500 mm. The shorter the focal length, the 
more of your scene you see and the smaller your subject appears. 

Distortions of the Conical Camera 

In real life, a conical camera creates certain distortions that do not equal what the human eye perceives. 
Some of these distortions are present in the Carrara conical camera while others are not. 

The conical camera's view appears to bend in at the sides while shrinking objects in the center of the 
frame and enlarging objects at the sides. 

When you move a conical camera away from the subject and then zoom in, there is less distortion. 

 
To achieve exaggerated perspective, move the camera closer and set the zoom to a lower number. 

 
One distortion that is not captured by Carrara's conical camera is background blur; with a real-life camera, 
this occurs when you use a long focal length.  

You can simulate this background blur using the Depth of Field controls. For more information, refer to 
"Using the Depth of Field Effect." 
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The Isometric Camera 

While the conical camera views a scene from a single point, the isometric camera views a scene from a 
plane. In an isometric view, object size is not related to distance from the camera, every edge appears 
the size it actually is, and parallel lines appear parallel instead of tapering as they would in a perspective 
view. In contrast, from a conical camera, the scale of objects diminishes as their distance from the 
camera increases. 

The isometric cameras view the scene without perspective. These views are similar to architectural and 
engineering drawings, where placement and absolute relations between objects are important. 

NOTE! that six isometric cameras can't be repositioned: Top, Bottom, Front, Back, Left and Right. 
They are attached to the working box and move with it. 

 

 
The most effective way to work is to model and align objects using an isometric camera, then examine 
and render your work with a conical camera. The 2D presets are views through isometric cameras. 

Zooming with the isometric camera simply scales the view, making objects appear larger or smaller. 

TIP! Use an isometric camera to render logos without perspective or distortion. 
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The Spherical Camera 

When doing a final rendering with the spherical camera, the output image shows all objects that can be 
seen from the camera's position, including objects behind it! 

This is useful when creating an immersive view of a scene. Certain software products enable you to take 
this image rendered with the spherical camera in Carrara and save it as a QuickTime VR file. It can then 
be used in a web browser, giving you an interactive, 360° view of the original scene. 

In the assemble room, the spherical camera behaves like the conical camera and renders the portion of 
the scene in front of it from a single point. 

 

 

Working with Multiple Cameras 
Multiple cameras help you arrange your objects by providing different views of your scene. You can 
switch between these views or use them simultaneously by using a multi-pane layout of your scene 
window and looking through a different camera in each pane.  

When you are ready to render, you select one of the cameras for the view to render. For details, refer to 
"Cameras and Rendering." 

Changing Views 

All views are shown through cameras; you can animate many of them, render through them, and use 
modifiers on them, and so on.  

Click the view controls to select how many views are displayed. These controls are discussed in 
"Displaying Multiple Camera Views." After you display your views, you can select the camera to display in 
each view. 
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Selecting a Camera 

The default view of your scene is through the default camera. You can send the camera to many default 
positions and orient it using the Camera tools. You can also add additional cameras to the scene. 

A camera selection menu appears in the upper-left corner of the document window. You can use this 
menu to easily switch cameras so that you can see one or more different views of your scene. 

 
To choose a camera to view your scene: 

• Choose the camera you want to use from the camera menu in the document window. 

• If you have multiple views displayed, you can specify a camera for each view.  

o Conical cameras view the scene as the human eye would: objects far away appear 
smaller, and parallel lines converge at a vanishing point. 

o Choose one of the isometric camera views such as Left, Right, Top, Bottom, Front, or 
Back to use one of Carrara's preset cameras.  

o The Director's Camera is a perspective, non-animatable camera that allows you to see a 
perspective view of your scene. You can reposition the Director's camera as needed. It is 
useful for navigating around in the scene without accidentally animating a camera. 

o If you ever "get lost" or aim a camera so you can't see where you are oriented, change to 
the Reference position to re-orient yourself and re-aim the camera. For further 
information, see "Saving and Using Camera Positions." 

Positioning and Aiming Cameras 
Cameras (other than the current camera) appear in the scene window as objects. You can move them 
anywhere in the 3D workspace and change their angle with any of the standard positioning and 
orientation features. 

Camera Navigation 
Carrara lets you directly manipulate the current camera by using the camera controls to track, dolly, pan, 
and bank the camera. 
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TIP! You can also select the current camera and use the Position (Center and Hot Point) and 
Rotation controls in the Properties tray: Motion tab: Transform panel to move and aim the camera 
numerically. 

To work faster, you can move and orientate the camera with a 3-button mouse using the following 
shortcuts: 

• Option/Alt + Left Mouse Button will rotate the camera (Dolly). 

• Option/Alt + Right Mouse Button will Track the camera horizontally and vertically. 

• Option/Alt + Middle Mouse Button will move the camera back and forth. 

• If your mouse is equipped with a Mouse Wheel you can use it to move your camera back and 
forth. 

NOTE! In isometric views it is not the camera that is moved when using those shortcuts but the 
zoom and pan that are modified instead. 

Tracking 

You can track the current camera in the following ways: 

• Vertical and depth track 

• Horizontal and vertical track 

• Horizontal and depth track 

• Depth track only 

Tracking affects the camera's position without affecting its orientation. The objects in your field of view 
appear to change position in relation to each other as you view your scene from different vantage points. 

The camera tracks in screen space, not on the axes of the universe or working box. 

To perform vertical and depth tracking: 

• Click the YZ Track control and drag in the scene up, down, left, and right. You can also drag on 
the Track control itself. 
 

 
• Drag left and right to perform depth tracking. 

• Drag up and down to perform vertical tracking. 
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• The YZ Track control moves the camera up, down, in, and out in screen space. This changes 
your field of view and perspective if you are using a conical camera. 

To perform horizontal and vertical tracking: 

• Click the XY Track control and drag in the scene. You can also drag on the Track control itself. 
 

 
• Drag up, down, left, and right.  

• The XY Track control moves the camera up, down, left, and right in screen space. 

To perform horizontal and depth tracking: 

• Click the XZ Track control and drag in the scene. You can also drag on the Track control itself. 
 

 
• Drag left and right to perform horizontal tracking. 

• Drag up and down to perform depth tracking. 

• The XZ Track control moves the camera left, right, in, and out in screen space. This changes your 
field of view and perspective if you are using a conical camera. 

To perform depth tracking only: 

• When using any of the camera controls, hold down the Command/Ctrl key and drag upward to 
move the camera forward. 

• Hold down the Command/Ctrl key and drag downward to move the camera back from your 
subject. 

Dollying 

Dollying changes the camera's position and orientation while keeping it pointed at the same spot in the 
scene. The visual effect is similar to rotating an object, except in this case, it's the camera that moves. 

To dolly the camera: 

1. Select the object around which you want to rotate the camera. If you deselect all objects, the 
current camera rotates around the origin of the universe. 

2. Click on the arrow at the bottom right corner of the camera orientation control. 

3. A choice of controls will be displayed. Select the Dolly tool. 
 

 
4. Drag in the scene window to dolly the camera. You can also drag on the camera orientation 

control itself.  

Panning 

Panning only changes the camera's orientation. To visualize panning, imagine standing in place and 
looking through your camera's viewfinder. Turn side to side and tilt up and down. The objects in your field 
of view do not change position in relation to each other. 
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To pan the camera: 

1. Click on the arrow at the bottom right corner of the camera orientation control. 

2. A choice of controls will be displayed Select the Pan tool. 
 

 
3. Drag in the scene window to pan the camera. You can also drag on the camera orientation 

control itself. 

Banking 

Banking changes the camera's orientation only, rotating the camera on the Z axis. This creates the effect 
of a tilted horizon, which is useful for creating tilted cockpit views. 

To bank the camera: 

1. Click on the arrow at the bottom right corner of the camera orientation control. 

2. A choice of controls will be displayed. 
 

 
3. Drag left and right to bank left and right. You can also drag on the camera orientation control itself. 

Pointing a Camera at an Object 
In addition to the camera controls, Carrara offers several methods of aiming cameras, including the Point 
At command, the Point At modifier, and the Direct Manipulation controls.  

TIP! To direct a camera to a particular area in your scene, create a temporary object for the 
camera to point at, then delete the object. Remember that the camera points at the hot point of the 
selected object. 

The Point At Command 

The Point At command is usually the easiest way to aim a camera in the general direction of an object. 
This command points the camera at the hot point of the object. Then, you can make precise adjustments 
to the camera's position and aim using the camera orientation controls.  

The Point At command does not link the camera to the object selected. That is, if you move either the 
object or the camera, the camera no longer points at the object. To make a camera follow an object, use 
the Point At modifier, described in the next section. 

NOTE! You cannot point a camera at a light. 

To point a camera at an object: 

1. Select the camera that you want to aim. 

2. Select the object or objects you want to point at. You'll probably find it is easiest to select them 
from the Hierarchy in the Sequencer tray or in the Properties tray. 
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3. Choose Edit > Point At. 
 

 

The Point At Modifier 

If you want the camera to follow an object, apply the Point At modifier. If either the object or the camera 
moves, the camera automatically reorients itself to point at the object in its new position. 

To have a camera follow an object: 

1. Select the camera you want to aim. 

2. On the Properties tray: Modifiers tab, click the + sign to expand the list and choose Behaviors 
> Point At. 
 

 
3. The Point At panel appears in the Modifiers tab. Click the Towards button to select one or more 

objects from the Point At dialog.  
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4. The Axis option sets which axis of the object points at the target. In most cases, you can leave 

this option as is. 

5. Check the Enabled option to turn the Point At modifier on. 

6. After you apply the Point At modifier, the camera reorients to point at the object when you move 
either the camera or the object that it points toward. 

Controlling a Camera Directly 
The Direct Manipulation controls for a camera provide an on-screen description of the camera's aim, 
zoom level, and position. You can drag control handles to change these properties. 

NOTE! These features are not available for the current camera. You must view the camera as an 
object to control it directly. 

To display a camera's Direct Manipulation controls: 

1. Select a camera in your scene window. Note that you will not be able to select the camera from 
the viewport that looks through the selected camera. 
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2. Display the Properties tray: General tab: Camera panel. 

3. Click the Direct Manipulation button to display the controls on the selected camera. 
 

 
 
The controls appear as a set of wires with handles at certain points. Each handle represents a 
control you can drag to set properties.  
 

 
4. Drag the wireframe and projection handles to aim the camera and set its properties. 

TIP! You may want to aim the camera with the Direct Manipulation controls while looking through 
that camera. You can do this by looking through the camera in a different pane. 

To aim the camera: 

The cursor turns into a crosshair when placed over the camera aim control, which appears in front of the 
camera. When you move the camera aim control, the camera rotates to aim where you place the handle. 

• Drag the camera aim control to move parallel to the active plane. 

• Click the camera aim control then hold down the Option/Alt key to drag the target handle parallel 
or perpendicular to the active plane. 

• You can drag the aim control out, extending the wire all the way to the point you want to aim at. 
The wire shows the direction of the camera's aim. 
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As you drag the Camera Aim control, the camera rotates around the Camera Position control. 

To move the camera: 

The cursor turns into a crosshair when placed over the camera position control, which appears behind the 
camera. When you move the camera position control, the camera moves to the new position and orients 
itself to point at the target. 

• Drag the handle behind the camera preview. 
 

 
 
As you drag the Camera Position control, the camera rotates around the Camera Aim control. 

To change the camera’s zoom: 

The rectangle in front of the camera represents the production frame.  

• Drag a corner of the rectangle in front of the camera to change the zoom.  

• Drag toward the target object to zoom in. 
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Saving and Using Camera Positions 
You can save any camera position you set. Saved positions are available from the camera list in the 
upper left corner of the scene window. 

To save a position as a preset: 

1. Select the camera with the position and orientation you like. 

2. Expand the view menu in the upper-left corner of the document window, and choose Set 
Position to >Save Position. The Save Camera Position dialog appears. 
 

 
3. Type a name for your camera position. 

4. Click OK. Your new camera position now appears as a choice in the view menu. 
 

 
To remove a preset from the list: 

1. Expand the view menu in the upper-left corner of the document window, and choose Set 
Position to > Delete Position. The Remove Position dialog appears. 
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2. Select the position you want to remove and click OK. 
 

 
To move a camera to a preset position: 

You can use the camera view menu to move the camera to any preset position. When you jump into an 
object or group using any of the default preset positions, the camera goes with you:that is, it establishes 
the preset position and orientation relative to the local universe you've jumped into. A custom position, on 
the other hand, is kept as is when you jump in. This could result in an empty window when you jump into 
a group. Choose a default preset or select an object and Point At it to see the contents of the group. 

NOTE! There is a difference between the Left, Right, Top, Bottom, Front, and Back presets on the 
top level of the camera list and those within the Set Position To menu. On the top level, these settings 
refer to isometric cameras that you cannot manipulate. The settings in the Set Position To menu refer to 
physical locations to which you move the current camera. 

1. Select the camera you want to look through from the camera list. Choose one of your own 
cameras or the Director's Camera. Since the Carrara preset isometric cameras are fixed, you 
cannot use the Set Position To option for them. 

2. From the camera list, choose Set Position To, then choose a position from the list:  

• Left, Right, Top, Bottom, Front, and Back: These presets move the camera to the 
position of the isometric preset cameras. 

• Director's Camera: This preset moves the camera to the current position of the 
Director's Camera. 

• Reference: This preset moves the camera to the original view of the scene window. 

• User-created: Any preset positions you have created and saved appear here. 
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Cameras and Rendering 
What you see in the scene window does not necessarily equal what will be rendered. For example, you 
might adjust your view with the 2D Pan and 2D Zoom tools, but these adjustments are not updated to the 
settings of the current camera. The Production Frame and the camera settings are the key elements to 
determining the size and framing of the rendered scene. 

The Camera's Field of View 
The inner, dashed-line rectangle is called the Title Safe Margin. This is an "out of bounds warning" for 
objects that approach the edge of the frame. Use this reference when developing video output. Because 
the edges of the video frame are often cut off, the Title Safe Margin can keep objects fully within the 
visible area when the animation is displayed on video. 

 
For more information on the Production Frame and Render Settings, refer to "Viewing the Production 
Frame" and "Rendering." 

Viewing the Production Frame 
The Production Frame shows you exactly what portion of your scene will be rendered, just as looking 
through a camera's viewfinder shows you what portion of a real-life scene will actually be captured on film. 
By default, the Production Frame appears as a rectangle on top of your view. 

To view the Production Frame: 

• Choose View > Show Production Frame. The Production Frame appears as a colored rectangle 
in the Universe. 

To resize the Production Frame: 

1. Choose the Selection tool. 

2. Click the outer rectangle to select it. Handles appear on each corner 
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3. Drag a corner handle to resize in two dimensions. Hold down the Shift key while you drag to 
constrain proportions. The camera position does not change when you move or adjust the 
Production Frame. Only the camera's view is affected. 

Setting the Production Frame Safe Area 
When you create animations and graphics for video or broadcast media, allowances must be made to 
keep the most important visual elements within a safe viewable area. If you don’t make allowances for 
overscanning, you may find that some elements are not seen on the screen. This is known as the 
production frame safe area (also known as the title safe area). 

Carrara provides a visual guide that helps you keep the important content in your scene within this safe 
area. An inner, dashed-line rectangle serves as an "out of bounds warning" for objects that approach the 
edge of the frame. 

You may need to experiment with the percentage setting to find the setting that's right for your video 
output system. 

To adjust the Production Frame Safe Area: 

1. Choose View > Production Frame. The Production Frame Setting dialog appears .  

2. Adjust the Production Frame Safe Area slider, or enter the percentage you need. 

3. Click OK. The inner dashed line updates to reflect the setting you choose. 

Using the Depth of Field Effect (Standard, Pro) 
Normally, every object appears in focus regardless of its distance from the rendering camera. The Depth 
Of Field effect simulates the lens of a real life camera. It blurs the objects according to their distance from 
the rendering camera. 

 
To set Depth of Field options: 

1. Select the camera that you want to use for the Depth of Field effect. Usually it is the camera that 
you will use for your render. 
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2. In the Properties tray: Effects tab: Depth of Field panel, check the Enable box and click the 
Edit button. 
 

 
 
The Depth of Field dialog comes up. 
 

 
3. In the Parameters section, set the following options in the Depth of Field dialog:  

• Enable Depth of Field: Check or uncheck this option to enable or disable depth of field. 

• Raytraced Depth of Field(Slow): Check this option to get a better quality depth of field 
result. 

• Focus: The focus is the distance from the camera to the objects that appear sharp in the 
image (the object is in focus). To set the focus, simply type in the distance or use the 
Focus tool. The Focus tool allows you to pick the distance directly in the preview. When 
you click in the preview, a red arrow appears and the focus distance will change to match 
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the distance of the closest object at the center of the arrow. 
 

 
• Blur Intensity: Determines how much blur will be applied. When set at zero, you get a 

perfectly sharp image. 

• Quality: Choose Fast, Good, or Best quality for your depth of field render. Higher 
settings consume more resources. 

4. Use the Preview section to fine tune the image as follows:  

• Zoom and Pan controls: Use these controls (above the preview image) to get a better 
view of the details in the preview image. 

• Reset View: Click this button to return the preview image to its default size and position. 

5. Use controls in the Rendering Mode section as follows:  

• Rendering Mode: Choose Draft or Full Rendering to select the quality of the preview 
image. Full Rendering will take longer but will use the same settings as your final render. 

• Auto Update: Check this option to update the preview automatically while you change 
depth of field settings. 

• Render: Click this button to manually render the preview image. 

6. Click OK to accept the settings and close the Depth of Field dialog. 

Setting Lights 
How objects appear in a Carrara scene is influenced greatly by the light in which they are viewed. 
Lighting contributes to effects such as shadows and colors. Lighting also influences the shaders applied 
to your objects. Sometimes you can adjust the lighting instead of editing a shader to create a specific 
result. 

This chapter covers how to create and use lights. It includes descriptions of the different types of lighting 
and how you set the options for each. 

Carrara supports several different types of lights. You may add as many lights as you like, but as the 
number increases, so does the rendering time. Most scenes can be lit with one, two, or at most three well-
placed lights. 

Tip Carrara also lets you create visible light spheres and cones as rendering effects. The visible light 
cone effect is like a searchlight cutting through the fog. For more information, refer to "Rendering Effects." 

Lighting Concepts 
This section explains basic lighting concepts. If you are already familiar with the subject, you may skip this 
section. If you want more detailed information, the techniques given in most standard reference books on 
lighting and photography can be applied in Carrara. 

A good set of lighting conditions is an important step toward creating high-quality artwork. The same 
scene rendered under varying light can provide strikingly different results. For example, rendering with all 
lighting at zero brightness is like taking a photograph:without a flash:in the bottom of a coal mine. 
Conversely, too much lighting washes out subtle effects. 
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Three-Point Lighting 
Three-point lighting is the classic way to place lights. It provides illumination while preserving shadows 
and the illusion of depth. 

Place two lights at 45° angles to the front of your scene. Make one of these a key light. This is the main 
source of illumination and strong shadows. Make the other a fill light, which softens the shadows and 
supplies the mid-tones. 

 
It is also a good idea to color one of these lights warm and the other cool:which one you color warm and 
which cool depends on the mood and effect you want to achieve. To simulate outdoor light, choose a cool 
color for the key light; to simulate indoor light, choose a warm color for the key light. 

Set a backlight behind your subject to separate it from the background, adding a feeling of depth. If you 
want to create the effect of light creeping over the subject's features, elevate the light slightly. 
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Other Lighting Arrangements 
Here are some of the effects of different light placements. 

• Frontlighting is placing a light source in front of your subject. This allows clear rendering of 
details and colors, but reduces shadows and depth. 
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• Sidelighting creates dramatic light-and-shadow effects. If you don't want some objects to be 
completely obscured by shadows, you can place a softer fill light in the scene on the opposite 
side of the subject from the sidelight. 
 

 
• Backlighting is placing a light source behind your subject. This creates silhouettes. You can 

combine backlighting with spots set at the side or front of the subject to cast shadows from 
behind while brightly illuminating a small area, such as a face. 
 

 
• Bottomlighting is placing a light source below your subject. Like backlighting, this also creates 

silhouettes. It can be very effective if you are lighting a transparent subject. However, if you want 
to show more detail, add a fill light above your subject. 
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Working with Lights 
A new light appears in the scene as a colored object that points toward the center of the universe. 

 
Lights are objects with projections, just like cameras and modeled objects. You can move the light as you 
would any other object. You'll learn about special features for moving and orienting cameras later in 
"Shadow Options." 
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In the Hierarchy, lights are listed as numbered light objects. You can rename a light just as you can an
object. 

y 
If you set up several lights, you can name them according to their position and type to make it 

easier to select the light you want. For information on naming objects, refer to "Using the Sequencer 
Tray." 

You create specific lights in the
up menu. 

 Assemble or Storyboard room. All the light tools appear off a single pop-

1. Choose the type of light you want from the Create Light tool pop-up menu. 
 

To create a new light source: 

 
2. Click in the scene window where you want to place the light. 

You can also choose Insert > (Type of) Light to add a light at the center of the universe and then dr
to any position you like. 

ag it 

 an existing light, select the existing light, then 
. 

After creating a light, you can change its properties. 

If you want to create a light with the same settings as
choose Edit > Copy and Paste, or Edit > Duplicate

TIP! To make a light easier to see (or see around), you can change its scale using the Scale 
control in Properties tray: Motion tab: Transform panel as you would any other object. This does not 

light characteristics. 

 created a new light, you can specify the type of light you want to use, and then set its 
options in the Properties tray. You can use the light controls at any time to adjust the settings of a 
selected light. 

affect the brightness of a light or any other 

Setting Light Properties 
Once you have

NOTE! You can also use these controls to adjust the default distant light. 
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To set a light's properties: 

1. Select the light that you want to modify. 

2. Display the Properties tray: General tab: Light panel. 

3. Choose the type of light you want. When you change the light type, the panel displays the 
parameters appropriate to that type. 
 

 

Setting Common Light Characteristics 
The characteristics of color, brightness, and shadow control are common to distant, bulb, and spot lights. 

To set common light characteristics: 

1. Display the Properties tray: General tab: Light panel. 
 

 
2. Adjust the controls as appropriate:  

• Brightness sets the light's brightness. The color chip launches the Carrara color picker, 
which you can use to set a color for the light. 

• Casts Shadows makes the light cast shadows. 

• Shadow Intensity sets the intensity of shadows. A lower setting creates weaker 
shadows. By default, all lights except ambient light cast shadows. Shadows appear only 
in renderings. Use the Test Render tool or render the image to view the changes. 

For more control over shadows, refer to "Shadow Options." 
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Viewing Lighting Effects 
You can quickly view your lighting effects using the Test Render tool to preview lighting and shading 
effects. 

 
To view the entire image, use the Render room. For details, refer to "Rendering." 

Carrara’s Light Types 
Carrara offers several different types of lights that you can add to your scenes and landscapes.  

Spot Lights 
A spot light emanates from a single point and casts light in a specific direction. It works the same way as 
a stage spotlight by making what appears in the light the center of attention. 

Spot lights appear in the scene window. You can move them anywhere in the 3D workspace and change 
their direction with any of the positioning and orientation features, including the Selection tool, the Rotate 
tool, and the Properties tray: Motion tab: Transform panel controls. 

 

Setting Spot Light Characteristics 
To insert a spot light and set its characteristics: 

1. To insert a spot light, do one of the following:  

• Choose Insert > Spot. 

• Drag the Spot Light tool into your scene. 
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2. With the light selected, display the Properties tray: General tab: Light panel. 
 

 
3. Set the following properties as needed: 

• Half-angle is the angle of the radius of the cone. A narrow angle creates a beam like that 
of a spot light. A wide angle creates a beam like that of a floodlight. 
 

 
• Brightness: Adjust the Brightness setting to increase or decrease the strength of the 

distant light. 

• Color chip: Click to set the color of the light. 

• Angular Falloff: Drag the slider to set how the brightness of the light diminishes toward 
the edge of the light cone. A falloff of 10% means that the light has full intensity from the 
center to 90% of the radius of the light cone, then decreases linearly to the edge of the 
cone. 

 © 2008 DAZ 3D, Inc. 481 



Carrara 7 11 December 2008 

 

 
• Range : Enter a value for the distance from the light itself to the point where the light has 

no effect.  The units of measure are those currently set in File > Preferences> General 
Scene Settings.  
 

 
• Range Falloff : Drag the slider to determine how the brightness of the light diminishes 

toward the edge of its range. A falloff of 10% means that the light has full intensity from 
the source through 90% of its range, then decreases linearly to the end of the range. 

• Cast Shadows: Check this option to generate shadows with the light. Uncheck the option 
if you do not want the light to cast shadows. 

• Shadow Intensity: Adjust the slider to increase or decrease the strength of the shadow. 

Directly Controlling Spot Lights 
You can use the Direct Manipulation controls to change all the characteristics of a spot light except color. 

To aim the spot light: 

• Drag the control handle in front of the light cone.  

o The handle moves parallel to the active plane. 

o Hold down the Option/Alt key to drag the handle perpendicular to the active plane. You 
can drag the handle out, extending it all the way to the point you want to aim at. The wire 
shows the direction of the light beam. 

o You can also drag the target handle on one of the light's projections to aim the light on 
that plane. 
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o The light rotates to aim where you place the handle. 
 

 
To move the position of the spot light: 

• Drag the handle behind the light cone. 
 

 
You can also drag the handle on one of the light's projections to position the light on that plane. 

The light moves to the new position and orients itself to point at the target. 

To check the light cone diameter at a given point: 

• Drag the handle on the direction wire, centered in the ring. 
 

 
The ring around the direction wire describes the cone diameter at that point. Notice that as you drag the 
handle closer to the target, the ring expands. 

NOTE! The Cross-Section control is intended to help you visualize the diameter of the light cone at 
different ranges. It does not change any of the light's properties. 

To change the spot light's half angle: 

• Drag the handle on the ring perimeter. 
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TIP! If you have the Properties tray: General tab: Light panel displayed, you can see the effect 
of your changes in the preview and settings. 

To change the Angular falloff: 

• Hold down the Cmd/Ctrl key while dragging in toward the center of the ring. 
 

 

TIP! If you have the Properties tray: General tab: Light panel displayed, you can see the effect 
of your changes in the preview and settings. 

To change the brightness: 

• Drag the handle on the wire that extends from the light perpendicular to the direction wire. 
 

 
• Drag away from the light to increase the brightness, or towards the light to decrease brightness. 

Bulb Lights 
A Bulb Light emanates from a single point and casts light evenly in all directions, like a naked bulb in a 
lamp. 

You can move bulb lights anywhere in the workspace with any of the positioning features, including the 
Selection tool, Rotate tool, and The positioning controls in the Properties tray: Motion tab: Transform 
panel. Because bulb lights shine equally in all directions, you do not need to aim them. 

Bulb light controls appear in the Properties tray: General tab: Light panel. 
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Setting Bulb Light Characteristics 

To insert a bulb light and set its characteristics: 

1. To insert a bulb light, do one of the following:  

• Choose Insert > Bulb. 

• Drag the Bulb Light tool into your scene. 
 

 
2. With the light selected, display the Properties tray: General tab: Light panel. 

 

 
3. All the parameters interact with each other. For example, using a soft-colored light with a low 

brightness setting may generate a result similar to a darker-colored light with a higher brightness 
setting. However, different results are produced when you animate the individual parameters. Set 
the following properties as needed:  

• Brightness: Adjust the Brightness setting to increase or decrease the strength of the 
bulb light. 

• Color chip: Click to set the color of the light. 

• Range: The distance from the light itself to the point where the light disappears. The units 
of measure are those currently set in file preferences. 
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• Range Falloff: Drag the slider to set a percentage. This setting determines how the 

brightness of the light diminishes toward the edge of its range. A falloff of 10% means 
that the light has full intensity from the source through 90% of its range, then decreases 
linearly to the end of the range. 

• Cast Shadows: Check this option to generate shadows with the light. Uncheck the option 
if you do not want the light to cast shadows. 

• Shadow Intensity: Adjust the slider to increase or decrease the strength of the shadow. 

Controlling a Bulb Light Directly 

On a bulb light, brightness is the only control available with Direct Manipulation. 

To change a bulb light's brightness: 

1. Select the bulb light that you want to change. 

2. Click the Direct Manipulation icon in the Properties tray: General tab: Bulb Light panel. 
 

 
3. Drag the handle on the wire that extends sideways from the bulb light. Drag inward to decrease 

brightness or outward to increase brightness. 
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TIP! If you have the Properties tray: General tab: Light panel displayed, you can see the effect 
of your changes in the preview and settings. 

Distant Lights 
A Distant Light source's position is conceptually outside of the scene's universe, although you may 
choose to place the shape representing its direction inside the working box. The rays are parallel as they 
enter your scene and they affect all objects. An example of distant light is the way the sun lights the earth. 

 

Setting Distant Light Characteristics 

To insert a distant light and set its characteristics: 

1. To insert a distant light, do one of the following:  

• Choose Insert > Distant. 

• Drag the Distant Light tool into your scene. 
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2. With the light selected, display the Properties tray: General tab: Light panel. 
 

 
3. Set the following properties as needed:  

• Brightness: Adjust the Brightness setting to increase or decrease the strength of the 
distant light. 

• Color chip: Click to set the color of the light. 

• Cast Shadows: Check this option to generate shadows with the light. Uncheck the option 
if you do not want the light to cast shadows. 

• Shadow Intensity: Adjust the slider to increase or decrease the strength of the shadow. 

Setting Distant Light Direction 

No matter where you position a distant light in your scene, it behaves as if the source is a distant object, 
sending parallel rays into your scene. To change the direction of a distant light, change the orientation of 
the light. 

To set the direction of a distant light: 

1. Select the distant light arrow. 
 

 
2. Use the Rotate tool to point the arrow in the direction in which you want the rays to shine. 

 

 

TIP! As with ambient light, you can use a distant light to soften the shadows cast by other light 
sources. Position a distant light above your scene, then experiment with light settings to diffuse the 
shadows from the other lights. 

Moon Light 
Moon light is used with Sky or Realistic Sky.  

To set moon light characteristics: 
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1. To insert a moon light, do one of the following:  

• Choose Insert > Moon Light. 

• Drag the Moon Light tool into your scene. 
 

 
2. With the light selected, display the Properties tray: General tab: Light panel. 

 

 
3. Adjust the slider to increase or decrease the brightness of the moon light. 

Sun Light 
Sun light is used with Sky or Realistic Sky.  

To set sun light characteristics: 

1. To insert a sun light, do one of the following:  

• Choose Insert > Sun Light. 

• Drag the Sun Light tool into your scene. 
 

 
2. With the light selected, display the Properties tray: General tab: Light panel. 

 

 
3. Adjust the slider to increase or decrease the brightness of the sun light. 

Tube Lights 
To insert a tube light and set its characteristics: 

1. To insert a tube light, do one of the following:  

• Choose Insert > Tube Light. 

• Drag the Tube Light tool into your scene. 
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2. With the light selected, display the Properties tray: General tab: Light panel. 
 

 
3. Set the following properties as needed:  

• Brightness: Adjust the Brightness setting to increase or decrease the strength of the 
tube light. 

• Color chip: Click to set the color of the light. 

• Range: The distance from the light itself to the point where the light disappears. The units 
of measure are those currently set in file preferences. 

• Range Falloff: Drag the slider to set a percentage. This setting determines how the 
brightness of the light diminishes toward the edge of its range. A falloff of 10% means 
that the light has full intensity from the source through 90% of its range, then decreases 
linearly to the end of the range. 

• Fall Off Rate: Select how the light goes from full brightness to zero: Linear, Distance 
Squared, or Logrithmic. 

• Length: Enter the length of the tube light. 

• Cast Shadows: Check this option to generate shadows with the light. Uncheck the option 
if you do not want the light to cast shadows. 

• Shadow Intensity: Adjust the slider to increase or decrease the strength of the shadow. 

Shape Lights 
To insert a shape light and set its characteristics: 

1. To insert a Shape light, do one of the following:  

2. Choose Insert > Shape Light. 

3. Drag the Shape Light tool into your scene. 
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4. With the light selected, display the Properties tray: General tab: Light panel. 
 

 
5. All the parameters interact with each other. For example, using a soft-colored light with a low 

brightness setting may generate a result similar to a darker-colored light with a higher brightness 
setting. However, different results are produced when you animate the individual parameters. Set 
the following properties as needed:  

• Brightness: Adjust the Brightness setting to increase or decrease the strength of the 
shape light. 

• Color chip: Click to set the color of the light. 

• Range: The distance from the light itself to the point where the light disappears. The units 
of measure are those currently set in file preferences. 

• Range Falloff: Drag the slider to set a percentage. This setting determines how the 
brightness of the light diminishes toward the edge of its range. A falloff of 10% means 
that the light has full intensity from the source through 90% of its range, then decreases 
linearly to the end of the range. 

• Fall Off Rate: Select how the light goes from full brightness to zero: Linear, Distance 
Squared, or Logrithmic. 

• Width: Sets the width of the shape light. 

• Height: Sets the height of the shape light. 

• Shape: Select the shape that you want to use for the shape light. Choices are 
Ellipse, Rectangle, and Ring. 

• Cast Shadows: Check this option to generate shadows with the light. Uncheck the 
option if you do not want the light to cast shadows. 

• Shadow Intensity: Adjust the slider to increase or decrease the strength of the 
shadow. 

Anything Glows 
Anything Glows is a light that allows you to use any object as a source of light. Anything Glows helps 
you create glowing objects that really cast light, realistic lighting effects, and it allows you to control many 
lights at the same time using Master Lights. 
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To make any object glow: 

1. Create a scene with the desired number of objects. The glow from Anything Glows affects 
surrounding objects. 

2. Do one of the following:  

• Choose Insert > Anything Glows. 

• Drag the Anything Glows tool into your scene. 
 

 
3. Set Anything Glows properties as follows:  

• Brightness: Controls the intensity of the light. 

• Color chip: Controls the color of the light when the Color option is set to Light Color. 

• Range: Controls how far away the light illuminates. 

• Range Falloff: Controls how the brightness decreases at the end of its range, Fall Off 
Rate controls how it goes from full brightness to zero. 

• Fall Off Rate: Options are Linear, Distance Squared, and Logarithmic. The image 
below shows the three falloff rates with Range at 10 feet and Range Falloff at 70. 
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• Cast Shadows: Turns shadows on and off. Anything Glows 2 doesn't require that the 

Cast Shadows option be turned off for Anything Glows Items, but some scenes look 
better with it that way. 

• Shadow Intensity: Sets how dark the shadows are. 

• Color: Determines what drives the light's color. Options are Light Color (fastest), 
Object Color, or Object Glow. If you are far from the object Anything Glows uses, set 
the Color to Light Color instead of Object Color or Object Glow. The image below shows 
color settings from left to right as Light Color (when set to white), Object Color (the 
checkerboard shader), and Object Glow (a blue gradient). 
 

 
• Item: Enter the name of the object that you want to use as the light source. If the name of 

the object is not unique in the scene you may get unpredictable results. If Anything Glows 
cannot match the name it will not emit any light. 

• Origin: Controls the starting point of the light rays. Options are Bounding Box (fastest), 
Vertex, and Facet (slowest). If you are far away from the object Anything Glows is using, 
turn Origin to Bounding Box or Vertex. Turn it back to Facet when you get close enough 
to see the details. On rough surfaces (heavy bump) or surfaces with lots of color changes, 
you often won't be able to tell the difference between an Origin of Facet or Vertex. If your 
light only illuminates those kinds of surfaces, use Vertex, it's much faster. 

• Fidelity: Controls the amount of detail that will be used when Origin is set on Vertex or 
Facet. Higher Fidelity settings allow for greater mesh detail. Set the Fidelity to the lowest 
setting that give the results you need. The lower the Fidelity, the faster Anything Glows 
renders. 

• Standoff: Specifies how far away from the mesh the light ray starts. This keeps the 
Anything Glows light ray from intersecting the rendered mesh and causing unwanted 
shadows.  

• Minimum Distance: Controls how far away from the mesh a point must be to be 
illuminated. This keeps Anything Glows from illuminating its own mesh. 

• Resynch Position or Mesh: Tells Anything Glows you have moved the object or 
changed the geometry. If you render, make a change, and then want to render again, 
press this button to tell Anything Glows to synch up with your object.  
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Tips and Tricks 

• Gels are a great way to control Anything Glows output without changing the shader's color or 
glow. Putting a slightly blurred version of the objects glow map in Anything Glows' gel is a great 
way to simulate monitors or TV screens. 

• Use Light Smart Sampling on your render settings. Anything Glows is about three times faster 
with Light Smart Sampling on and most of the time you won't be able to tell the difference in the 
resulting image. 

Setting up Environmental Lighting 
Environment Lighting works by breaking up the mesh into little chunks and assigning an Anything Glows 
light to each chunk. The plane primitive, which only has two facets regardless of the Fidelity, makes a 
poor emitter. To create a flat emitter, build a grid in the Vertex modeler. 

To activate Environment Lighting: 

1. Select an object in the 3DView. 

2. Click Edit > Environment Lighting. 
 

 
3. Set the following options:  

• Mesh Fidelity controls how detailed a mesh Anything Glows will use when Origin is set 
on Vertex or Facet. The higher the Mesh Fidelity, the more detailed the mesh. 

• Quality specifies how many lights will be used. At 1 Anything Glows will use 1 light for 
every 10 facets, at 6 Anything Glows will use 1 light for each facet. 

• Color determines what drives the light's color. 

4. Click OK to apply the settings. 
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Setting Master Lights Characteristics 
To set Master Lighting options: 

1. Choose Edit > Master Light. The Master Light dialog appears. 
 

 
2. Use the Apply To section to control the types of lights that will be changed. Check or uncheck 

Spot, Bulb, Tube, Shape, Anything Glows, or Distance as needed. 

3. In the Brightness section:  

• Apply: Enables the brightness controls. 

• Brightness: Use the slider to control the intensity of the light.  

• As Percentage of Current Value: Check this option to multiply the light's current value 
times the Brightness setting to get the light's new value. 

4. To control the color of the light, check the Apply option near the color chip. Then click the color 
chip to select the color of the light . 

5. To control how far away the light illuminates, check the Apply option in the Range section and 
enter the desired distance in the Range field.  

6. To control how the brightness decreases at the end of the range, check the Apply button in the 
Range Falloff section, and adjust the slider to obtain the desired amount of falloff. 

7. Check the Cast Shadows option to turn shadows on, or uncheck to turn shadows off. The Apply 
option enables or disables this feature. 
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8. Use the Shadow Intensity slider to control the darkness of the shadow. Check the Apply button 
to enable the feature. 

9. Click the Default button to restore the Master Light options to the default values. 

10. Click the Last Run button to restore the settings of the Master Light to the values stored the last 
time you clicked OK. 

Shadow Options 
Objects block light and, therefore, cast shadows on other surfaces. For each light, you can choose 
between two methods to calculate shadows: Raytraced shadows and Shadow buffer shadows. Each of 
those methods allows you to create two types of shadows: 

• Hard shadows have sharp edges. The transition from complete shadow to full light is immediate. 
 

 
• Soft shadows create an obscurity at the shadow edge. The shadow has a soft transition 

between complete shadow and full light. 
 

 
To set shadow options for a light: 

1. Select the light you want to set. 

2. On the Properties tray: Effects tab: Shadow panel, choose the method you want to calculate 
your shadows. 
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Enabling and Disabling Shadows on Objects 
By default, all objects that are not transparent cast shadows. There may be an instance where you don't 
want an object to cast shadows. Carrara allows you to turn Shadow Casting on and off for individual 
objects. 

To set shadow casting for the selected object: 

1. In the Assemble room, select the object on which you want to change the shadow properties. 

2. In the Properties tray: General tab: General panel:  

• Check the Casts Shadows option to turn shadow casting on for the selected object. 

• Uncheck the Casts Shadows option to turn shadow casting off for the selected object. 

Raytraced Shadows 
The Raytraced shadow is the default. It is the most accurate method for calculating shadows. It will create 
very nice soft shadows but tends to be slow with this type of shadow. 

You can adjust the following settings: 

• Enable Soft Shadows will create soft shadows instead of the simple hard shadows (Note that 
soft shadows take a quite a bit more time to render). 

• Light Radius only affects soft shadows. It determines how big the light source is and thus how 
soft the shadows will be. Note that you need to take into account the distance of the light to the 
scene. A light that is far away will only create soft shadows if the radius is very big (this is 
especially true for distant lights that are always far from the scene). 

• Quality only affects soft shadows. It determines how many rays are used to evaluate the 
shadows. It recommended to use the lowest quality setting that works with your scene and to only 
increase it if there is a visible artifact. 
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Shadow Buffers 
Shadow buffers should be mostly used to create soft shadows. They are usually much faster than 
raytraced soft shadows, especially for complex scenes. However they are not as accurate as Raytraced 
Soft Shadows and do not let light go through objects (even when the Light through transparency option of 
the renderer is checked). 

To set the Shadow buffers options: 

1. Select a light. 

2. On the Properties tray: Effects tab: Shadow panel, choose Shadow Buffer. 

3. Set shadow buffers controls.  

• Resolution determines the quality of the shadow effect. A higher resolution uses more 
memory. 

• Blur Size increases the area of softness. You need a higher setting here if you have set 
a high Resolution. 

• Bias controls the placement of the shadow. Increase this setting if your objects are self-
shadowed. Decrease this setting if shadows appear too far away from the objects 
themselves. 

Positioning and Aiming Lights 
You can position lights as you would any object in your scene:by dragging a light or its projection, or 
numerically by using the controls in Properties tray: Motion tab: Transform panel.  

Note You can also use the Direct Manipulation controls to move and aim lights. Refer to "Controlling 
Lights Directly." 

For information on positioning and orienting lights numerically, refer to "Arranging Objects." 

Positioning Lights by Dragging 
You can drag lights as you would any other object in your scene. 

To move a light: 

1. Select the light. 

2. Select the Selection tool. 

3. Drag the light to where you want it.  

• The light moves parallel to the active plane. 

• To move the light perpendicular to the active plane, hold the Option/Alt key while you 
drag. 
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• You can also drag one of the light's projections to position the light on that plane. 
 

 

Pointing a Light at an Object 
Carrara provides other methods of aiming lights, including the Point At command, the Point At modifier, 
and the Direct Manipulation controls. 

TIP! To direct a light to a particular area in your scene, create a temporary object for the light to 
point at, then delete the object. Remember that the light points at the hot point of the selected object. 

The Point At Command 

The Point At command lets you point a light directly at an object. 

To point a light at an object: 

1. Hold down the Shift key and select both the light and the object you want to point it at. You may 
select multiple lights, but only one object. 

2. Choose Edit > Point At. Carrara reorients the light to point at the hot point of the selected object. 

The Point At command does not link the light to the object. That is, if you move either element, the light 
no longer points at the object. If you want to maintain the distance between a light and the object it points 
at, group them. For more information, refer to "Grouping Objects." If you want the light to follow the object, 
apply the Point At modifier, described in the next section. 

The Point At Modifier 

The Point At modifier aims a light at an object. If the object moves, the light automatically reorients itself 
to point at the object in its new position. 

To have a light follow an object: 

1. Select the light you want to use. 

2. On the Properties tray: Modifiers tab, click the + sign to expand the list and choose Point At. 
The Point At controls appear. 
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3. Adjust the Point At controls as appropriate:  

• Towards Enter the name of the target object:the one you want the light to follow. Enter 
the name exactly as it appears in the Hierarchy area of the Sequencer. (The text field is 
case-sensitive.) 

• Axis Leave this option as is. The axis option sets which axis of the object should point at 
the target. For a light, you only want to use the axis that emits the light. 

• Enabled Check this box to turn on the Point At modifier. 

4. When you move the target object, the light reorients to point at it. 

Controlling Lights Directly 
The Direct Manipulation controls provide an on-screen description of a light's aim and properties. You can 
drag a light's control handles to change light properties. 

To display the Direct Manipulation controls on a light: 

1. Select a light. 

2. Display the Properties tray: General tab: Light panel. 

3. Click the Direct Manipulation button to display the control handles on the selected light. 
 

 
The controls appear as a set of wires with handles at certain points. Each handle represents a control you 
can drag to set properties. 

The Direct Manipulation controls for a spot light are shown below. The appearance and number of these 
controls depend on the type of light you have selected. 
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Using Gels 
You can place an image as a mask or transparency in front of a light to project complex patterns and 
images on your scene. The image you place in front of the light is called a gel. Gels are typically used on 
spot lights. 

If the gel is a 1-bit image (see image below), it becomes a mask. White regions of the mask transmit the 
light, and black regions block it. Bitmap gels can create intricate effects, such as the shadow of a chain-
link fence, or the dappled shade under a tree. 

 
Grayscale or color images create transparencies when used as gels. Their image is projected into your 
scene, just as a slide projector sends an image across the room. With a color image, you can achieve 
many effects, such as sunlight filtering through a stained glass window. 
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Blinds, Gradient, and Blinds, Gradient, and Formula are built-in gels. You may also load a texture map or 
movie to use as a gel. An 8-bit gel will probably provide all the color you need. 

As you adjust the settings for these gels, a preview displays at the right. Specific blend controls are 
described later in this chapter. 

NOTE! Gels have no effect on distant lights. 

To place a gel on a light: 

1. Select a light. Gels are generally used on spot or bulb lights. Your choice depends on the effect 
you want. 

2. On the Properties tray: Effects tab: Gel panel, choose a type of gel:  

• None is the default. The light has no gel. 

• Blinds Options 

• Formula Options 

• Gradient Options 

• Map Options 

Blinds Options 
The Blinds option creates horizontal or vertical stripes such as venetian blinds or prison bars. 

 
To set blinds options: 

1. On the Properties tray: Effects tab: Gel panel, choose Blinds. 
 

 
2. Set the Blinds controls:  

• Horizontal Count sets the number of horizontal slats. 

• Vertical Count sets the number of vertical slats. 
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• Horizontal Size sets the width of the vertical slats. The width is expressed as a 
percentage of the gel frame. 

• Vertical Size sets the height of the vertical slats. The height is expressed as a 
percentage of the gel frame. 

Formula Options 
The Formula option uses a mathematical formula to create colors and patterns in the gel. You can devise 
your own formula to create a new pattern. 

 
To select a formula for the gel: 

1. On the Properties tray: Effects tab: Gel panel, choose Formula. 
 

 
2. If the current formula uses Parameter values, you can adjust them to change the formula result. 

3. If you want to edit the formula or create your own, click More. The formula editor appears. 

Carrara uses the Formula Editor in several places. Use of the editor is common, but the type of formula 
you're creating determines the valid input and output variables. Refer to "Using Formulas in Carrara" for 
details on using the Formula Editor. 
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Gradient Options 
The Gradient option uses a blend of two colors as a gel. A gradient gel can be vertical or circular. 

 
To set gradient options: 

1. On the Properties tray: Effects tab: Gel panel, choose Gradient. 
 

 
2. Set the Gradient controls: Horizontal, Vertical, or Circular sets the gradient pattern. Click the 

top color chip to select a start color, and the bottom color chip to select an end color.  

• For a Horizontal gradient pattern, the start color appears on the top and the end color on 
the bottom. 

• For a Vertical gradient pattern, the start color appears on the left and the end color on 
the right. 

• For a Circular gradient pattern, the start color appears on the inside and the end color on 
the outside. 

Map Options 
The Map option uses a bit-mapped image file as the gel. This is the best choice when you want specific 
images in the gel. 
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You can use any 2D graphics program to create an image for the gel. You might scan a photograph and 
use filters to accentuate or nominalize some aspects of the image. The gel does not need to be high-
resolution. If you intend to use this gel on a bulb light, create the image at an aspect ratio of 2:1. If you are 
going to use this gel on a spot or distant light, use an aspect ratio of 1:1. 

Save the image file in a format that Carrara supports and in a convenient folder. 

For a list of the image file types that Carrara supports, refer to "Importing 3D Objects." 

To load a map image as a gel: 

1. On the Properties tray: Effects tab: Gel panel, choose Map. 
 

 
2. Click the Folder icon to display the Open dialog. 

3. Use the Open dialog to locate and open the map image you saved. A preview appears on the Gel 
panel with the image's dimensions given in pixels. 

To set map controls: 

1. Click the directional buttons next to the Folder icon to change the image's orientation. 

2. Choose among the following options:  

• Tile makes the image repeat. Use the Horizontally and Vertically sliders to set the 
number of tiles in each direction. 

• Seamlessly smoothes the transitions between tiles. 

• Invert Color inverts the image's colors. 

• Interpolate smoothes out textures for zooming. This option works best with low 
resolution textures, and may slow the rendering. 

• Brightness sets the image's brightness. 

NOTE! You can use Map options to place movies. To do this, load movie images as a gel, just as 
you would load map images. 
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Light Effects (Standard, Pro) 
You can add effects to your scene that simulate the results obtained from photographic cameras and 
special lighting. You apply light effects on a light-by-light basis. 

NOTE! Light effects are post-render filters. Although they simulate adjustments to your lights and 
cameras, they do not actually change any of your light or camera settings. 

Using the Preview 
All the light effects dialogs have a rendered preview that helps you to adjust the settings of a specific 
effect. 

You can use the Zoom and Pan tools at the bottom of the preview to get a better view of the details of the 
image. 

Clicking on the Render button after zooming in will increase the quality of that part of the image you are 
viewing. To display the full image again, click on the Reset View button. 

When you check the Auto Update box, the preview is re-rendered each time you adjust a control, 
otherwise you will need to click the Render button after changing one or more controls. 

CrossScreen 
The CrossScreen effect adds a glow and star-like rays to every visible light source. 

 
The light source must be visible from the camera to produce an effect. It must be within the production 
frame and not hidden behind or inside an object. 

To set CrossScreen options: 

1. Select the light to which you want to apply an effect. 

2. In the Properties tray: Effects tab: Light Effects panel, check the Enable CrossScreen box, 
then click Edit. The CrossScreen dialog appears. 
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3. Set the CrossScreen options:  

• Glow Size sets the diameter of the glow. 

• Star Size sets the star radius. 

• Angle rotates the stars around the light source center. 

• Branches sets the number of rays. 

• Intensity sets the effect intensity. 

Glow (Lights) 
Glow simulates a photographic filter by adding a glow around every visible light source. The effect of the 
glow depends on the light's position, color, and intensity. 

 
The light source must be visible from the camera to produce a glow. It must be within the production 
frame and not hidden behind or inside an object. 

To set Glow options: 

1. Select the light to which you want to apply an effect. 

2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Glow box, then click 
Edit. The Glow dialog appears. 
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3. Set the Glow options:  

• Glow Size sets the diameter of the glow. 

• Intensity sets the strength of the glow. 

Nebula 
The Nebula effect adds multicolored streaks around every visible light source. 

 
The light source must be visible from the camera to produce a nebula effect. It must be within the 
production frame and not hidden behind or inside an object.  

NOTE! Render on a dark background to see the Nebula effect. 

To set Nebula options: 

1. Select the light to which you want to apply an effect. 

2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Nebula box, then 
click Edit. The Nebula dialog appears. 
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3. Set the Nebula options:  

• Radius 1 sets the streaks' starting radius. 

• Radius 2 sets the streaks' ending radius. 

• Angle rotates the streaks around the light source center. 

• Branches sets the number of streaks. 

• Thick makes the streaks thicker. 

• Intensity sets the streak intensity. 

Pulsator 
Pulsator adds dotted streaks around every visible light source. 

 
The light source must be visible from the camera to produce a pulsator effect. It must be within the 
production frame and not hidden behind or inside an object. 

To set Pulsator options: 

1. Select the light to which you want to apply an effect. 
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2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Pulsator box, then 
click Edit. The Pulsator dialog appears. 
 

 
3. Set the Pulsator options:  

4. Size sets the streak radius. 

o Thickness sets the streaks' thickness. 

o Angle rotates the streaks around the light source center. 

o Intensity sets the streak intensity. 

Stars 
Stars adds a star around every visible light source. 

 
The light source must be visible from the camera to produce a star effect. It must be within the production 
frame and not hidden behind or inside an object. 

To set Stars options: 

1. Select the light to which you want to apply an effect. 

2. In the Properties tray: Effects tab: Light Effects panel, check the Enable Stars box, then click 
Edit. The Stars dialog appears. 
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3. Set the Stars options:  

• Size sets the stars' radius. 

• Thickness sets the stars' thickness. 

• Angle rotates the stars around the light source center. 

• Branches sets the number of rays. 

• Diffraction splits the stars into rainbow colors. 

• Intensity sets the stars' intensity. 

VarioCross 
The VarioCross effect adds two streaks around every visible light source. Use the VarioCross effect to 
simulate the light streaks produced by distant bright lights. 

 
The light source must be visible from the camera to produce a VarioCross effect. It must be within the 
production frame and not hidden behind or inside an object. 

NOTE! Render on a dark background to see the VarioCross effect. 

To set VarioCross options: 

1. Select the light to which you want to apply an effect. 
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2. In the Properties tray: Effects tab: Light Effects panel, check the Enable VarioCross box, then 
click Edit. The VarioCross dialog appears. 
 

 
3. Set the VarioCross options:  

• Size sets the streak radius. 

• Thickness sets the streaks' thickness. 

• Angle 1 rotates the first streak around the light source center. 

• Angle 2 rotates the second streak around the light source center. 

• Diffraction splits the streaks into rainbow colors. 

• Intensity sets the streaks' intensity. 

Light Cone 
In the real world, light rays are visible when the atmosphere contains small particles of dust or vapor that 
diffuse light. The Light Cone effect simulates the interaction between light from a spot light and smoke, 
fog, and dust. 

 
The Light Cone effect post-processes the rendered picture by adding visible light beams from spot lights. 
The visible light beams accurately describe the half angle of each spot light in the scene. 

To set Light Cone options: 

1. Select the spot light to which you want to apply an effect. 
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2. In the Properties tray: Effects tab: Light Cone panel, check the Enable box, then click Edit. 
The Light Cone dialog appears. 
 

 
3. Set the Main Settings: 

• Color - To change the color of the fog, click on the color chip. Carrara opens the system 
color picker so you can choose a color. The color of the visible light cone results from the 
interaction of the light's color and the fog color. Yellow light in a white fog produces a 
yellowish light cone. In a blue fog, yellow light produces a green cone. 

• Intensity sets the strength of the light cone effect. 

• Fall Off - This setting determines how the brightness of the light diminishes toward the 
edge of its range. 

4. Set the Fog options:  

• Use Gel allows you to use any gel on the lights in the light cone effect. Enable this option 
only if you've applied gels to your spot lights. 

• Gel Buffer Size sets the quality of the gel effect in the light cone. Drag to the right to 
increase quality of the gel in the light cone. 
 

NOTE! To render textured light rays, the filter pre-processes and stores buffers for 
each spot light in your scene. High buffer values produce better results, but are costly in 
rendering time and memory requirements. Don't use values higher than 200 unless you 
have a powerful computer and are working on high-resolution pictures. Always start with 
a small value. 
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5. Set the Turbulence options:  

• Enable produces swirls in the fog medium. 

• Animate makes the fog medium change over time. This option slows down the rendering. 
Enable it only when creating animations. 

• Turbulence Scale sets the mean size, in inches, of the wreath of smoke. This slider 
ranges from 0.01 inches to 489 inches. 

• Lumpiness sets the contrast level in the wreath of smoke. 

6. Set the 3D Shadows options:  

• Enable makes objects in the light cone cast shadows in the fog. 
 

NOTE! 3D Shadows is a powerful but costly effect. The filter must pre-process and 
store buffers for each spot light in your scene. High values are costly in rendering time 
and memory requirements. Do not use values higher than 200 unless you have a 
powerful computer and you are working on high-resolution pictures. Always start with a 
small value. 

• Shadow Buffer Size sets the quality of the 3D shadow effect in the light cone. 

Light Sphere 
The Light Sphere simulates the interaction between light from a bulb light and smoke, fog, and dust. 

 
The Light Sphere effect post-processes the rendered picture by adding a light sphere around each bulb 
light. 

To set Light Sphere options: 

1. Select the bulb light to which you want to apply an effect. 

2. In the Properties tray: Effects tab: Light Sphere panel, check the Enable box, then click Edit. 
The Light Sphere dialog appears. 
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3. Set the Main Light Sphere options:  

• Intensity changes the strength of the light sphere effect. 

• Radius sets the size of the light sphere 

• Realistic TBD 

• Quality TBD 

4. Set the Turbulence options: 

• Enable produces swirls in the fog medium. 

• Animate makes the fog medium change over time. This option slows down the rendering. 
Enable it only when doing animations. 

• Turbulence scale sets the mean size, in inches, of the wreath of fog. 

• Lumpiness sets the contrast level in the wreath of fog. 

Lens Flare 
Lens flares are reflections of a strong light source on the various components of the lens. Flare color and 
size depend on the kind of glass and shape of each lens component. 

 
The Lens Flare effect adds lens flares to one or more light sources in your final rendered image, 
according to their positions, colors, and intensities. 

To get a lens flare effect, a light source must be visible to the rendering camera. The light source must be 
within the production frame and not hidden behind or inside another object:even if it is a transparent 
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object. A spot light must be aiming toward the rendering camera to produce a lens flare. The camera 
must be within the light cone. 

The Lens Flare effect uses three parameters to render the effect: Light source color, Light source 
intensity, and Lens Flare intensity. 

To get brighter lens flares, use brighter light sources. It also helps to lower the ambient light and use 
darker backdrops. 

NOTE! If you are rendering with a white background, you won't see the result of the lens flare 
effect. Select a dark color for the background. 

To set Lens Flare options: 

1. Select the light to which you want to apply an effect. 

2. In the Properties tray: Effects tab: Lens Flare panel, click Edit. The Lens Flare dialog appears. 
 

 
3. Set the General controls:  

• Settings sets the type of lens flare. Choose a Carrara preset and edit it as needed. If you 
choose None, there is no lens flare. 

• Brightness controls the overall intensity of the entire flare. 

• Colored renders the lens flare in color. When disabled, the lens flare is rendered in 
grayscale. 

4. Set >The Light Glow controls. Enable the option you want to apply, then click the color chip to 
choose a color:  

• Color enables and sets the color of the light itself. 

• Glow enables and sets the color of the glow immediately surrounding the light. 

• Inner enables and sets the color of the inner glow gradation. 

• Outer enables and sets the color of the outer glow gradation. 
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• Intensity sets the strength of the light glow effect. 

• Scale sets the size of the light glow. 

5. Adjust the Streaks controls. This section sets the appearance of the streaks you see when 
looking at a light (such as a car headlight or street lamp). You can animate all the attributes of a 
halo, but you cannot change the type of streaks over time in an animation.  

• Type sets the streak type. Choose a Carrara preset or choose None. 

• Intensity sets the strength of the streak effect. 

• Scale sets the size of the streaks. 

• Rotation rotates the streaks for animated effects such as a photon torpedo, which spins 
as it moves. 

• Color sets the color of the streaks. 

6. Set the Halo controls. This section sets the appearance of the ring you see when looking directly 
at a light source. You can animate all the attributes of a halo, but you cannot change the type of 
halo over time in an animation.  

• Type Choose Filled for a solid color ring, or Lenticular for a ring in the full spectrum of the 
rainbow that gradually fades in intensity. Choose a color for a Filled halo, or a starting 
color for a Lenticular halo. 

• Intensity sets the strength of the halo effect. 

• Scale sets the size of the halo. 

7. Set the Reflection controls. This section sets the appearance of the set of circles that emanates 
from the light on a line toward the camera lens. You can animate all the attributes of a halo, but 
you cannot change the type of reflections over time in an animation.  

• Type sets the reflection type. Choose a Carrara preset or choose None. 

• Grayscale turns off color for the reflections. 

• Intensity sets the strength of the reflection effect. 

• Scale sets the size of the reflection. 

8. Click OK when you are done. 

Working with Shaders 
Shading 
You use Shaders to define an object's appearance. They define not only the texture and color of an object, 
but how it responds to light. Carefully selected and properly applied shaders enhance the realistic 
appearance of your scene. 

This chapter introduces shaders:what they are and which types of shaders are available:and it provides 
background information you must know when you create your own shaders. It also introduces the Texture 
room, including the windows, trays, palettes, and tools you use when applying or creating shaders. 

To learn how to apply shaders to your objects, refer to "Shading Objects." Refer to "Creating and Editing 
Shader Trees" to learn how to create shaders. 
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Thinking about Textures as Shaders 
When you learn to think in 3D, you must analyze surfaces around you to determine how to recreate the 
same effects in Carrara. As you start to use shaders, experiment to learn which shaders you can use to 
recreate different types of effects. 

 
Carrara comes with a library of predefined shaders ready to use right out of the box; however, you can 
also purchase shaders from other vendors or create your own. 

To locate other sources of shaders, visit the DAZ 3D Web site. To learn how to create your own shaders, 
refer to "Creating and Editing Shader Trees." 

The best way to learn about shaders is to try them. As you experiment with different shaders, keep a log 
of how you think each shader looks so you can quickly select an appropriate shader for the desired effect. 

What are Shaders? 
A shader is a set of surface characteristics. Each shader can contain settings for one or more of the 
following attributes: Color, Alpha, Highlight, Shininess, Bump, Reflection, Transparency, Refraction, Glow, 
Subsurface Scattering, and Translucency. 

In time, you'll build your own collection of shaders by editing existing shaders and creating new ones from 
scratch.  

NOTE! As you learn how to build your own shaders, you'll find the pre-defined shaders to be 
invaluable. Examine them closely: they demonstrate techniques you might not immediately discover 
through experimentation or reading these chapters. 

Refer to "Learning from Existing Shaders" for more information. 

How Shaders Work 
To work effectively with shaders, it helps to have an understanding of how they work. In traditional 
animation, images are drawn on different layers of celluloid. For example, one layer is used for 
background, another for items in the mid range, and another for the foreground. 

Shaders work in a similar way. Each channel of a shader is a different layer. Instead of celluloid layers 
that display background, midground, and foreground layers in an animation, shader channels display 
Color, Alpha, Highlight, Shininess, Bump, Reflection, Transparency, Refraction, Glow, Subsurface 
Scattering, and Translucency. 
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Shaders can get quite complex, but you can start with a simple example. For example, imagine how to 
create a simple shader for a piece of fruit, such as an orange.  

• You begin by placing a shade of the color orange in the Color channel. 

• Real oranges have some highlights and shine, so you need to set some values in the Highlight 
and Shine channels. 

• Oranges have a distinctive bumpy texture, so you can either place a bump texture or a Cellular 
shader into the Bump channel. 

• Oranges aren't reflective or transparent. They don't reflect or refract light, and they don't glow. So 
you do not need any values for the Transparency, Reflection, Refraction, or Glow channels. 
 

 
• And the result: 

 

 
Carrara makes it easy to create complex shaders, where you use functions, operators, and even other 
shaders are used to create new shaders. Refer to "Creating and Editing Shader Trees" to learn more. 
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Carrara applies one Master shader to each object. Though each object has only one Master shader 
applied to it, that shader may contain other sub-shaders. Refer to "Choosing a Top Shader" to learn more. 

To learn more about using shaders, refer to "Shading Objects." 

Master Shaders 
Once you create or place a shader in a scene, Carrara adds it to the Master Shaders list, which you can 
find in the Sequencer tray.  

 
You'll also see a list of the shaders in your scene in the Properties tray: Shaders tab. These shaders are 
stored in the document as a part of the scene. They can be edited or animated. 

 
When you add objects to your scene, they are assigned the first Master Shader in the list (named 
Default). You can modify this Master Shader as described in "Modifying the Default Shader for a Scene." 

You always apply a single shader to an object; however, that shader might be composed of other shaders 
in what is known as a shader tree. 

You can vary the effect of using a shader on more than one object by using a Layers List shader and 
applying layers to the object. To use the chair example, if you wanted to add some scuffs to the chair legs, 
you could create and position layers, then place a scuff texture in them.  

Assigning a Master Shader to an Object 

You can assign any Master Shader from the list to one or more objects in your scene. For example, if you 
make a shader for an antique chair leg, you could apply the shader to all four legs of the chair. When you 
make any changes to a Master Shader, all objects that use that master shader are automatically updated. 

There are two ways that you can apply master shaders to the objects in your scene: 

• Drag a master shader from the Master Shaders list in the Sequencer tray and drop it onto an 
object in your scene. 

• Drag a master shader from the Shaders tab in the Properties tray and drop it onto an object in 
your scene. 
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Editing a Master Shader 

If your scene contains several objects using the same Master Shader, you can use the Master Shader to 
make changes to the shading of all these objects. 

When you create an object based on a Master object, Carrara automatically applies an instance of a 
specific Master shader to all these objects. You can then assign different Master Shaders to each 
individual object. . 

For example, you might create a bottle and shade it with a green glass shader. You could then duplicate 
the bottle so that three copies appear in the scene. Suppose you decided later that you wanted marble, 
rather than glass bottles:you could reopen any object using that shader, affecting all three bottles. Carrara 
prompts you to confirm whether you want to apply the change to all the objects using that shader or 
whether you want to create a new Master Shader. 

 
If you apply the change to all the objects, the Master Shader and all the objects using that shader are 
updated. If you want to create a new Master Shader, then Carrara switches to the Shader Tree Editor so 
you can create the new shader. 

If you use a Master object and want to create variations of a shader, the individual objects will not share 
the same Master Shader. For example, if you want to create a series of bottles with different labels, you 
must create separate Master Shaders for each one. Each bottle will use a different Layers List shader. 

You can assign a Reference shader as the bottle layer so that several Master Shaders can refer to the 
same sub-shader. This allows you to edit the Reference shader and automatically update all the Master 
Shaders that use that Reference shader. 

To edit a Master shader: 

1. Switch to the Master Shaders tab in the Sequencer. 

2. Double-click the icon for the Master Shader your want to edit. The shader opens in the Shader 
Tree Editor window. Or you can select a Master Shader and switch to the Texture room. 

Removing Unused Shaders 

Carrara allows you to purge any unused shaders from your document using the Edit > Remove Unused 
Shaders command. You'll want to do so periodically to reduce unnecessary overhead from your scene. 

Using Master Shaders in Other Scenes 

To store a Master Shader for reuse in another scene, you must add it to the Browser. See "Browser Tray: 
Shaders Tab." 
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Editing Master Shader Names 

Once a Master shader becomes part of a scene, it is listed in the Sequencer. You can rename the shader 
if you want to. 

Renaming Master Shaders 

To rename a master shader: 

1. Switch to the Assemble room by clicking the Assemble room button. 

2. Display the Sequencer tray by dragging it open if needed. 

3. Click the Master Shaders button in the Sequencer. 

4. In the Master Shaders list in the Sequencer, select the name of the shader you want to change. 

5. Display the Properties tray if needed. 

6. Edit the name of the shader in the Properties tray. 

Tracking Usage of Master Shaders 

To see to which objects a Master Shader is applied: 

1. Click the Master Shaders button in the Sequencer tray. Previews of all of the Master Shaders 
display. 

2. Double-click the Master shader to switch to the Texture room. 

3. Click the pop-up menu in the upper left corner of the Preview window. A list of objects that use 
that shader displays. 

Editing an Object's Shader 

To edit an object's shader: 

1. Click an object to select it. 

2. Click the Texture room button to switch to the Shader Tree Editor. 

3. Edit the shader tree by adding, removing, and modifying shader components. 

Editing a Layer's Shader 

To edit a layer's shader: 

1. Choose the layer component within the Shader Tree Editor and make your changes to that layer. 

2. If you want to revert your changes, use Undo. 

The Object Surface 
Every object has a surface that covers the entire object. A shader gives a surface its characteristics. The 
basic default surface for a new object is a simple gray color, but you can easily assign another shader to 
the object. 
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To replace an object's surface: 

1. Locate the shader that you want to use in one of the following areas.  

o The Master Shaders list in the Sequencer tray. 

o The Shaders tab in the Properties tray. 

o The "Browser Tray: Shaders Tab." 

2. Drag the desired shader onto an object in the document window. Carrara automatically applies 
the shader to the object. 

3. If you change your mind, use Undo to undo your changes. 

TIP! You can also use the Eyedropper tool to "grab" the shader from an object in the document 
window. Then click the object to apply the shader. 

Shading Domains 
Real objects are often composed of different textures in different areas of the object. For example, a log 
has bark on the outside and tree rings on the sliced cross-section. 

Shading domains allow you to easily texture different areas of an object in a logical manner. For example, 
when you model a log as a cylinder it can have several different shading domains: 

• The side face 

• The front face 

• The back face 
 
(In this example, the front and back face could use the same tree ring texture, but that isn't 
always the case.) The modeler of the object determines the number of shading domains. The 
shader domains are separate UV mapping spaces of the object, and each one has a separate 
number. 

You have two ways to assign different shaders to each shading domain: 

• The simplest way is to use the shading properties where you can directly assign a shader to a 
specific shading domain. This panel is available in the Shading tab in the Assemble room when 
you have selected an instance. It is also available in the shading room. The Global shader is the 
shader that is going to be used if a particular shading domain is empty. Note that it is overridden if 
you assign a shader to one shading domain. To learn more how to apply a shader to an object 
with multiple shading domains, refer to "Shading Part of an Object." 
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• Or you can use the Layer List shader. You need to create a Layers List shader that contains 

mapping shaders that allow you to assign layer shaders to specific domains, and the layer 
shaders themselves. For example, when creating the component shaders used on a log object, 
the side of the log would have a bark shader, and the ends of the log would have a tree ring 
shader. The resulting Layers List shader would be known as a log shader, containing the two 
different component shaders. To learn more, refer to "Mapping Shaders." 
 

 
Before you learn more about shaders, you must know more about the windows and tools available in the 
Texture window. 

The Texture Room 
The main elements in the Texture room are the Shader Tree Editor, Shader Preview, and Layers tools. 
You use the Browser, introduced earlier, extensively when applying shaders or saving them for reuse. 

The Shader Tree Editor 
The Shader Tree Editor gives you complete control over the appearance of your shaders. You can use 
the Shader Tree Editor to edit shaders stored in the Browser or shaders you've applied to objects in your 
scene. The Shader Tree Editor lists the type of shader and displays the appropriate branches and 
parameters. 
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Previewing the Shader  

The small previews in the left hand side of the dialog show you a quick view of the whole shader tree. 
This helps you to easily identify a part of the tree or sub-tree. 

The shader preview window shows you how your shader will appear on the surface of an object and 
supplies you with immediate feedback when you change shading parameters. 

Navigation in the Tree  

The shader tree editor window displays the type of shader and the components used to create it. You 
have two ways to navigate through the tree: 

• You can select an interesting part of the tree displayed in the left hand side part of the dialog. You 
will see the detail for this element, or; 

• You can use the Edit button in the right hand side part of this editor to jump in and see a sub-
element. You can also use the Parent button to go from a child to its parent in the tree. 

If you'd like to see a very condensed view of the tree, you can use the Filter Simple Shader function by 
enabling the checkbox located at the top of the editor. This mode will filter the information and display 
only the interesting nodes in the left hand side tree. 

Wizard  

At each level in the tree you have access to the shader wizard. You can easily import a shader from the 
library and assign it to the whole tree on only part of it. 
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Multiple Editors  

When you select one or more objects and click the Texture room button, you'll see a Shader Tree Editor 
window for the shader used in each selected object. For example, if you selected three objects and two of 
them used the same shader, you'd see two Shader Tree Editor windows. 

You can edit multiple shaders at the same time. This allows you to easily drag and drop between shader 
tree editors. 

Shader Preview Window 
You can set up the Shader Preview window to preview your shader in a flat preview, sphere, or even on 
any of the objects that use that shader. 

 
Refer to "Building and Editing Shaders" to learn how to change the preview modes. 

The shader preview is rendered every time you modify the shader. You can change this by disabling the 
Auto Update checkbox. In that case, to see the result after modifying a parameter you will have to press 
the Render button. This mode can be useful when working with very complicated and slow shaders. 

Layer Tools 
The Layer tools help you create layer shaders and mapping shaders interactively in the shader preview 
window. You can also create layer shaders and mapping shaders in the Shader Tree Editor and position 
them numerically or with the Select Layer tool. 

Here are the four available layer tools: 

• Select Layer 

• Polygon Layer 

• Rectangle Layer 

• Oval Layer 

To learn more, refer to "Using Layer Shader Tools." 
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Managing Shaders 
To view shaders in your scene: 

1. Drag open the Sequencer tray. 

2. Click the Shaders button to display previews of the shaders. 

To add shaders to the Sequencer: 

• Drag a shader from the Browser to the Sequencer. 

To remove a shader from the Sequencer: 

1. Select the shader you want to remove from the Sequencer. 

2. Choose Edit > Delete or press Cmd/Ctrl+D to delete it. 

If an object was using that shader, the default shader will be applied instead. 

To remove all unused shaders from the Sequencer: 

• Choose Edit > Remove Unused Shaders. 

Previewing Shading 
Once you have created or edited a shader, you'll want to see how it looks when applied to a particular 
object. When you view the shader in the Texture room, you'll always see it in a high-quality mode. 

In the Assemble or Storyboard room you need to use the Textured preview mode to accurately see the 
color variations created by the shaders over the surface of your objects. Other preview modes use a 
single color for each object. To preview the final result in the rendered image, you can use the Test 
Render tool. 

To use the Test Render tool, refer to "2D View Tools." 

Learning from Existing Shaders 
One of the best ways to learn about shaders is to closely examine the shaders provided with Carrara. As 
you view a shader in the Shader Tree Editor, you'll find out how it was composed and learn tricks you can 
use when creating your own shaders. 

For a thorough discussion of shader channels and settings, refer to "Shader Structure and Content". 

Shading Objects 
This chapter explains shading, the process of assigning surface properties to your objects. By designing 
and applying shaders, you can precisely control the color, texture, and finish on your objects. When 
Carrara renders your final artwork, these characteristics determine whether an object appears rough or 
smooth, shiny or dull, transparent or opaque. 

Carrara's drag-and-drop interface for applying shaders makes shading easy. You'll keep a collection of 
shaders in the Browser tray and simply drop them onto your objects in the Assemble, Storyboard, Texture 
rooms, or the Scene Preview window. As you add a shader to the scene, Carrara stores it in the Master 
Shader List for the scene. You can also drag shaders from the Sequencer to apply them to objects. 
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You can apply shaders several different ways: you can apply a shader from the Browser; apply a shader 
from the Sequencer; create a layer on an object, then apply a shader to that layer; or drag a shader from 
one scene to another. 

You can apply shaders to the entire surface of an object or only to certain areas, such as to layers in a 
Layers List shader or to the front face of a cylinder. Refer to "Mapping Shaders" to learn how this is done. 

 

Shading Vertex Objects 
Since vertex objects can have a large number of sides and complex geometry, it can be difficult to apply 
shaders to vertex objects. Using standard mapping you may get unexpected results. In some cases, you 
may need to specify the mapping mode for a specific model to get the results you want. 

The Shader room provides a number of controls for adjusting mapping on objects in a scene. The Vertex 
modeler provides additional control by allowing you to specify how shaders are mapped to individual 
objects in a model. 

Shading an Entire Object 
When you create a new object, Carrara creates a default surface for it. To shade an entire object, you 
simply apply a shader to the object's surface. You can drag and drop a shader from the Shaders Browser 
or from another object. 

You can also edit an object's existing shader. For instructions, refer to "The Shader Tree Editor." 

By default the shader is assigned to the shading domain located under the mouse cursor. If you want to 
assign a shader to the whole object surface (not just one of the shading domains) you can force that by 
pressing the Shift key. 

To apply a shader to an object's surface (drag and drop): 

• Press the Shift key and drag a shader from the Browser: Shaders category onto an object in 
the document or Scene Preview window, or onto an object's name in the Sequencer tray. 

• Press the Shift key and drag a shader from the Sequencer tray onto an object in the document or 
Scene Preview window. 

To apply a shader from another object: 

1. Select the Eyedropper tool. 
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2. Click an object in the Assemble, Storyboard room, or Scene Preview window to "grab" its shader.  

• Press Shift+Click to apply the shader and keep the Eyedropper "full" of the current 
shader so you can apply it to additional objects. 

• Press Cmd/Ctrl+click to select a different shader instead of applying the shader currently 
selected by the Eyedropper tool. 

3. Click the Eyedropper on an object to apply the shader. 

To apply a shader from an object in another scene: 

1. Select the Eyedropper tool and click to "grab" the shader from an object in the document or 
Scene Preview window. 

2. Switch scenes using the Scene Preview window. Refer to "The Interactive Renderer." 

3. Click an object to apply the shader. The shader is automatically added to the Sequencer as a 
Master Shader. 

You can also drag and drop a shader from the Master Shaders list in the Sequencer window onto an 
object in the Assemble or Storyboard rooms, or in the Scene Preview window. 

If you are creating a non-animating scene, you might want to apply a shader only to the facing surfaces of 
an object. 

Shading Part of an Object 
There are several methods for shading part of an object. 

Objects with Multiple Shading Domains 
If an object has more than one shading domain, you can drag and drop a shader from the master shader 
tab directly onto one shading domain. While dragging over the 3D View window, the shading domain 
candidate for the drop will be highlighted in red. You can quickly shade an object with multiple shading 
domains using this technique 

You can also drag your shader in the Shading tab (this tab is located in the properties when you select 
the object) and drop it on the correct shading domain. In this tab, you can also access the shader wizard 
as well as assign a shader to one shading domain by using the popup that lets you choose one of the 
master shaders of the scene. 

Creating Shading Domains on a Vertex Object (Standard, Pro) 
In many cases, it can be useful to apply different shaders to different parts of a vertex object. On a model 
of a face for example, we might want to separate the texture of the skin from the one of the eyes, the 
teeth, or other specific parts. This is in order to have a shading tree easier to create and a UV mapping 
simpler to edit. 

The part of the object where different shaders are applied is called Shading Domains. For more 
information, see "Shading Domains." 

Note that to be able to apply different shaders on the shading domains, the shader should be in the Layer 
List of the Parametric Mapping shaders. 

By default, all the polygons of a vertex object are part of the default Shading Domain called Texture 0'. 
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You can then create a new Shading Domain for each polygon of the model and give them different names. 
These names are important since they are the names that will then be displayed in the shaders of the 
shading room. 

To create a new Shading Domain: 

1. Select the polygons on which you want to create a new Shading Domain. Their current shading 
domain is displayed in selection panel of the Modeling tab. 

2. If several polygons are selected, they may have several different Shading Domains. In that case, 
"Multiple Domains" is visible in the pop-up menu. 
 

 
3. Select New Shading Domain at the bottom of the Shading Domain pop-up menu. The Shading 

Domain dialog appears. 

4. Enter a name for the new Shading Domain. 

5. Click OK. 

To change a Shading Domain to an existing one: 

1. Select the polygons for which you want to change the Shading Domain. Their current shading 
domain is displayed in the selection panel of the Modeling tab. 

2. If several polygons are selected, they may have several Shading Domains. In that case, "Multiple 
Domains" is visible in the popup menu. 

3. Select in the Shading Domain pop-up menu the shading domain you want to set the selected 
polygons to. 

To open the Shading Domain Management panel: 

The Shading Domains in a vertex model can also be managed from the Shading Domain Management 
panel. The Shading Domain Management panel gives you the option to add, delete or modify the names 
of the Shading Domains. 

• Open the Properties tray: Global tab. 
 

 
To modify the name of a Shading Domain: 

1. Select it in the Shading Domain list. Its name appears in the Name text field. 

2. Enter a new name in the text field. 

3. Validate with Enter. 
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Specifying an Object's Mapping Mode 
In addition to the three projection mapping modes supported at the scene level, the Vertex modeler 
supports a custom mode that allows you to specify UV coordinates for particular vertices. For more 
information about mapping modes, refer to "Mapping Shaders". 

If you specify mapping modes for individual objects in the Vertex modeler, and then specify a projection 
mapping mode for the entire model at the scene level, the modes you specified in the Vertex modeler are 
overridden. To use the settings specified in the Vertex modeler, use the Parametric Mapping mode at the 
scene level. 

To change an object's mapping mode: 

1. Select the object in the Vertex modeler. 

2. Switch to UV Editing Mode by clicking the UV Editing button at the top of the Properties tray 
(Standard, Pro). 
 

 
3. In the Properties tray: Model tab, click the Mapping menu and choose a mapping mode: 

Custom, Box Face, Cylindrical, or Spherical. (The 3D Express Properties tray will have 
different tabs available.) 
 

 
4. Set your options as described in the sections that follow. 

5. Apply your settings. 

You can use predefined mappings or create your own custom mapping.  

Setting a Predefined Mapping 

There are three types of predefined mapping modes: 

• Box Face is designed for mapping 6-sided cubic shapes like cubes and 3D rectangles. 
• Cylindrical is designed for cylindrical objects like tubes 
• Spherical is designed for spherical shapes, such as globes and planets 
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Box Face Mapping 

To set Box Face options: 

1. In the Vertex modeler, select the object that you want to map. 

2. Switch to UV Editing Mode by clicking the UV Editing button at the top of the Properties tray. 

3. In the Model tab, click the Mapping menu and choose Box Face. 
 

 
4. Enable the mode you want to use:  

• Full Box: Wraps the 2D image onto the box much like you'd wrap a package. 

• Top: Projects the mapping on the top of the object, with projection continuing through to 
the bottom. 

• Left: Projects the mapping on the left of the object, with projection continuing through to 
the right. 

• Front: Projects the mapping on the front of the object, with projection continuing through 
to the back. 

• Bottom: Projects the mapping on the bottom of the object, with projection continuing 
through to the top. 

• Right:: Projects the mapping on the right of the object, with projection continuing through 
to the left. 

• Back: Projects the mapping on the back of the object, with projection continuing through 
to the front. 
 

 
5. By default the image is aligned with the object's bounding box axes (i.e. Align with Global Axis is 

enabled). If you need to, you can change the orientation of the image on the object. 

6. Enable Custom to change the orientation. 

7. Enter values in the X, Y and Z rotation fields to change the orientation of the image. 
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Cylindrical Mapping 

To set Cylindrical options: 

1. Switch to UV Editing Mode by clicking the UV Editing button at the top of the Properties tray. 

2. In the Model tab, click the Mapping menu and select Cylindrical. 
 

 

 

 
3. Enable an alignment option: Align with X, Align with Y, or Align with Z. 

4. You can also design your own orientation: 

• Enable the Custom option. 

• Enter values in the X, Y and Z rotation fields to change the orientation of the image. 
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Spherical Mapping 

TBD 

Setting a Custom Mapping 

When you choose the Custom mapping mode in the Properties tray: UV Editing Mode: Model tab: UV 
Mapping panel you can specify how UV coordinates from the shader should be applied to the selected 
vertex or group of vertices. 

When the mode is set to Custom, the UV values determined by the previous mode are assigned on the 
vertices. So, if you want to create a custom UV mapping that is similar to a spherical, cylindrical, or box 
mapping, set the mapping to one of these before setting it to Custom. 

When you enable Wrap, the shader is wrapped around the object from the specified U or V coordinate. 

To view the UV coordinates that are set for a particular vertex: 

1. Select the vertex. 

2. Switch to UV Editing Mode by clicking the UV Editing button at the top of the Properties tray. 

3. In the Model tab, make sure the UV Mapping Mode is set to Custom. 
 

 
4. Update the settings as needed: 

• The current U and V values are displayed in the number fields. 

• The UV mapping on an object might not be continuous. This means that one single 
vertex can have different UV values used by polygons sharing this vertex. When a vertex 
is selected, all its existing UV values are displayed. 
 
An example of non-continuous mapping is the box mapping when applied to all the faces 
of a cube. In this case, the vertices at the corners will have 3 UV values each. 

• The mapping on a polymesh can also wrapped in U and/or V values. Wrapping a texture 
map avoids going through all the texture maps when a vertex has a U or V value near 1 
and is linked to a vertex with a value near 0. 

• A vertex can also be in Interpolated mode. In that case, its UV values are determined by 
the UV values of its surrounding vertices. 
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Editing Custom UV Values (Standard, Pro) 
The UV Editor contains a 3D view of the polymesh, a 2D display of the UV values on the polymesh 
vertices, and a set of tools to manipulate them. 

To edit the UV mapping on a polymesh: 

1. Select the polymesh or part of it. 

2. Switch to UV Editing Mode by clicking the UV Editing button at the top of the Properties tray. 
 

 
3. The view should automatically change to the UV View but if not, choose UV View from the View 

menu. If needed, select the Two Views Vertical layout. 
 

 
 
The viewport should look similar to the following image: 
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1. The pane on the left is the 3D view and the vertices and polygons can be selected and 
manipulated using the default view controls. You can select the vertices in the 3D View 
and their corresponding UV values will be selected in the UV View. 

2. The pane on the right (UV View) is where you manipulate the UV mapping. See "The UV 
View" for more on using this view. 

4. Edit the UV values in the UV Editing tabs. 

If there is no texture on the object, the 2D view will only display the mesh of the vertices in their UV 
values. If the shader has a 2D texture map, it appears in the background of the mesh. 

The UV View 

The UV View displays a flattened mesh of the model using the UV values of the vertices to determine 
their position. When you modify the position of the point in the UV View, you modify the mapping on the 
object but do not affect the geometry of the polymesh. 

 
The Zoom and Pan tools can be used in the 2D View to display more specific areas of the texture. 

To select one or several points in the 3D or UV Views: 

1. Click on one of the Selection Mode buttons in the Properties Tray. 
 

 
• Regular Selector: Allows selection of polygons (3D View only), edges, or vertices 

• Vertex Selector: Only allows selection of vertices. 

• Edge Selector: Only allows selection of edges. 

• Polygon Selector: Only allows selection of polygons in the 3D View. 

2. Select the vertices, edges, and polygons: 

• Click on the vertices, edges, or polygons. Hold down Shift to select multiple items. 

• Click in an empty area and drag to use a Marquee Selection. 
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• If there is more than one Shading Domain on the polymesh, selecting the one you want 
to edit in the Shading Domain List (on the Display tab) will select all the points of that 
domain. 
 

 
 
When a shading domain is selected, its associated texture is displayed in the 2D view. 
For more information about Shading Domains, see "Creating Shading Domains on a 
Vertex Object." 

3. Depending on the tool currently selected, move, rotate or scale the selected vertices, edges, or 
polygons. 

4. To move the selected items in snap to grid mode, press Command/Ctrl before moving the items. 

5. You can also move a selected vertex by directly entering its U and V values in the Model tab. 

The UV Editor Model Tab 

The Model tab provides options for mapping the current selection. 

The top of the tab shows options available for the current mapping mode (shown further down) while the 
bottom of the tab displays the current statistics for the mesh. See "Setting a Predefined Mapping" and 
"Setting a Custom Mapping" for information on using these mapping modes. 

 

The UV Editor Display Tab 

The Display tab provides several options for displaying the UV values. 
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The Display tab provides the following options: 

• Shading Domain List: Choose a shading domain from the list of shading domains set on the 
polymesh. Each shading domain can be selected by clicking on its name. By default, only the 
current shading domain is displayed in the 2D view. To display them all at once, check the Show 
All option. 

• Merge Candidates: Select to merge different UV values when they are shared by a single vertex 
on the polymesh. 
 
To merge several UV values on a single vertex: 

1. Check the Show Merge Candidates option in the Display tab. 

2. Click on the Move tool. 

3. Select the point you want to merge. If the UV mapping has a discontinuity on this point 
(several UV values for one vertex), the other UV values shared by this vertex will be 
highlighted in the 2D View. 

4. Drag the point over another highlighted point to merge them together. 

• Show Split Handles: Select to create or remove the discontinuities on a vertex. see "Editing 
Custom UV Values" for more on discontinuities when UV mapping. 
 
To create a discontinuity on a specific vertex: 

1. Check the Show Split Handles option in the Display tab. The points are now surrounded 
by other small handles, each handle corresponding to one of the polygons attached to 
the vertex. 

2. Click on the Move tool. 
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3. Click on one of the handles to split the UV value. The same vertex on the polymesh will 
now have different UV values depending on which polygon it is. 

• Show Grid: When selected, shows a grid under the UV map. 

• Mesh Color: The mesh color can be modified in order to see it no matter what the texture 
underneath might be. 

• Display Mode: As a background of the mesh, a color (white by default) or a low- or high- 
resolution texture can be displayed. 

• Instance List: If there are different instances of the vertex object in the scene, each instance 
could have a different shader on it. You can choose the shader you want to work with by selecting 
it in the Instance List. 

• Export: The mesh can be exported in an image file. Note that only the mesh and the background 
color will be exported. The texture map, the grid or the points won't be exported. 

The UV Editor Operations Tab 

The Operations tab offers a list of projection methods that can be applied to the current selection. 

Misc Section 

The Misc section provides a tool which splits a set of vertices from the mesh. 

To split a set of vertices: 

1. Select the set of vertices to be split. 

2. Click the Detach Polygons button. 
 
The vertices around the selection will be split to "free" the selected polygons. 
 

 

Projection Section 

The Projection section is where custom UV maps can be set and modified. If the current mapping is not a 
custom mode, you will be asked if you want to convert the current mode to custom. 

To apply a projection: 

1. Select the vertices to apply the projection to. 

2. Choose among these four available projection methods: Box, Cylindrical, Spherical, and Planar. 

3. Adjust the settings on the chosen projection. 

4. Click the Apply button. 
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The following options can be adjusted for the different projection methods: 

• Framed: When selected, adds a small space between the faces so they are more easily visible. 

• Box projection options: 
 

 
• Box Mode: 

• Cover All: Projects all faces of the box, one over the other. 

• Cover Front/Back: Projects the faces 2x2, creating three distinct areas - the 
front and back sides together, then the left and right sides, and finally the top and 
bottom sides. 

• No Cover: Projects the six faces of the box separately so none of them overlap 
each other. 

• Cylindrical and Spherical projection options: Sets the axis of projection and an offset for 
the center of projection. 
 

 
• Planar projection options: Provides options that let you split the mesh by orientation or by 

the offset position from the center. You can also display the projected mesh horizontally 
or vertically. 
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The UV Editor Unfold Tab 

The Unfold tab allows you to unfold a UV map. This is done by defining seams and, if necessary, 
pinpoints, which are points where the unfolded template will be stitched. 

 
In order to unfold a UV map, the seams must be defined on the mesh. A seam is a selection of 
contiguous edges on the 3D model from which the UV map will be unwrapped. Seams must be defined in 
specific areas and created in order to get the optimal unfolded model and avoiding UV distortions which 
are too obvious. 

In addition, pinpoints will help the tool make a uniform and well proportioned unfolding since the unfolding 
will be performed "around" the pinpoints. 
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To unfold a map using seams: 

1. Select the edges that will define the seam. 
 

 

2. Select Seams from the Define menu. 
 

 

3. Click on the Plus (+) button to add the selection to the Seams selection. To remove the selection 
from the seam set, click on the Minus (-) button. 

4. Define the Projection Axis of the Unwrap tool. Carrara uses a planar projection to perform the 
unfolding operation so generally, the best axis is the one perpendicular to the planar projection. 
 

 

5. Click on the Unfold button. 

6. If the mapping mode of the object is not currently set to Custom, a confirmation dialog will come 
up asking if you'd like to change the UV mode to custom. Click on Yes (or on Always if you'd like 
it to change the mode without asking). 
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The UV map will be unfolded along the selected seam line which will show as a light blue line. 
 

 

To add to an unfold selection using pinpoints: 

1. Select the pinpoints that will define the seam to be added. 

2. Select Pins from the Define menu. 

3. Click on the Plus (+) button to add the selection to the Seams selection. To remove the selection 
from the seam set, click on the Minus (-) button. 

4. Define the orientation of the Pinning Axis, in U or V, which lets you perform a 90° rotation when 
unfolding. 
 

 

5. Click on the Unfold button. 

6. If the mapping mode of the object is not currently set to Custom, a confirmation dialog will come 
up asking if you'd like to change the UV mode to custom. Click on Yes (or on Always if you'd like 
it to change the mode without asking). 
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The seam between the selected points will be added to the unfolded map set. 

Projection Mapping Shaders 

When you model an object such as a beveled text object, you assign shading domains that define 
different materials. For example, a can of soup might contain three shading domains:Â Label, Top, and 
Bottom. Mapping allows you to easily texture different logical areas of the object. 

Projection Mapping shaders identify UV spaces and UV coordinates. They determine to which shading 
domain to apply themselves. You can use a Projection Mapping shader to define how each of the shading 
domains apply the shader to the 2D surface of the object.Â You can apply cylindrical mapping, flat 
mapping, spherical mapping, or projection mapping to an object or a layer.  

Objects that you import from other applications often contain limited material and shader information. 
When you shade an imported object, you must choose one of Carrara's projection mapping modes: Flat 
Mapping (for flat planes or boxes), Spherical Mapping (for spheres and elliptical shapes), or Cylindrical 
mapping (for cylinders and similar shapes). Parametric mapping may be difficult to apply to imported 
objects that are very complex. 

In the different projection mapping modes, Carrara maps the image onto an invisible primitive (a box, a 
sphere, or a cylinder) that encloses the object. Carrara then projects the image from the invisible primitive 
onto the object itself. When you choose Flat mapping, you can specify which face of the box primitive you 
want to map onto. When you choose cylindrical or spherical mapping, you can specify the orientation of 
the primitive in relation to the object.  

Note For the best results, you should choose the primitive that best resembles the object you are 
mapping. For example, spherical mapping would be appropriate for a basketball and cylindrical mapping 
would be right for a juice can. 

 
To add a mapping shader to a shader tree: 

1. Select an object and view its shader in the Shader Tree Editor. 
2. If the top shader of the Master Shader is not a Layer List Shader, click the top branch list item 

and change it to one of the Projection Mapping types (Cylindrical Mapping, Flat Mapping, 
Parametric Mapping, or Spherical Mapping). 
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3. Carrara displays the options that are appropriate for the selected mode. Set your options as 
described in the sections that follow, and apply your changes. 
 

 

Cylindrical Mapping Shader 

To set the mapping alignment:  

• Click the icon to choose the alignment you want:X, Y, or Z axis. 

If you slice a cylindrical object, each slice uses the same front face and back face information. 

 

Flat Mapping Shader 

The Single Face mappings project the image on one side of the object. The projection continues through 
to the other side of the object.  
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This is how the various face Flat mapping options appear on an object. 

By default, the image is aligned with the object's bounding box axes. 

 

Parametric Mapping Shader 

Carrara's default mapping mode is known as parametric mapping. Parametric mapping is like applying a 
decal to an object's surface:each pixel in your image maps directly to a specific point on the surface of 
your object. This straightforward approach minimizes distortion and loss of image quality. You'll want to 
use parametric mapping for most objects you create in Carrara. However, parametric mapping cannot be 
used on Metaball objects. 

 

Spherical Mapping Shader 

To set the mapping alignment:  

• Click the icon to choose the alignment you want:X, Y, or Z axis. 

If you slice a cylindrical object, each slice uses the same front face and back face information. 
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Layer Shaders 
Many real-world objects have non-uniform surfaces. Variations on an object's surface might be as simple 
as a painted-on logo, or as complex as an intricate inlaid wood design. 

To achieve effects such as these, you can use Carrara's layers. These tools are located in Texture room, 
directly beneath the menu bar. 

 
The Layers tools enable you to create a Layers List shader. This allows you to apply different shaders to 
various regions on the surface of an object. These regions, called layers, take the form of geometric 
shapes. Once you create them, layers can be selected, moved along the surface of the object, modified 
(in shape, size, or shader content), overlapped, or deleted. You can create any number of layers on the 
surface of an object. Each layer exists in the Layers List shader and you can edit its shape, component 
shader, or opacity mask in the Shader Tree Editor. 

Because the Layers tools allow you to place other shaders in the layers, you're not limited to painting with 
color. You can paint with gold, marble, or concrete and apply not only color, but bump, reflection, 
transparency, and the other shading attributes as well. 

This section introduces the Layers tools and explains how to use them. It also explains how Layers List 
shader layers relate to each other and to the object's surface. Finally, it discusses advanced topics such 
as mapping modes, and the Master and Object shading layers. 

Using Layer Shader Tools 
Carrara's Layers tools allow you to create layers directly on your 3D objects. Each tool provides visual 
feedback to show you how your layer appears on the surface of your object. 

The Layers tools work best on objects created in Carrara. You can create layers on an object imported 
from another application, but you might need to change the object's mapping mode to achieve 
satisfactory results. For more information, refer to "Editing Layer Shaders." 

To use a Layers tool: 

1. Choose a Layers tool. The behavior of each tool is described below. 

2. Draw on the surface of an object in the Shader Preview window. 
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Rectangle Tool 

 
Drag to create a rectangle. As you drag, Carrara draws a "rubber band" preview in real time, to show you 
the boundaries of the rectangle. Carrara shades the layer when you release the mouse button. 

Polygon Tool 

 
Click once to position each vertex of your polygonal layer. As you position vertices, Carrara draws the line 
segments connecting the vertices. Double-click at the last vertex to automatically close the shape. 

Although you can later resize or "stretch" a polygonal layer, you won't be able to re-edit its vertices. 

Ellipse Tool 

 
Drag to create an ellipse. As you drag, Carrara draws a "rubber band" preview in real time, to show you 
the perimeter of the ellipse. 

When you draw with the Rectangle or Ellipse tool, your first mouse click positions one corner of your 
layer's bounding rectangle, then you drag to position the opposite corner. Carrara normally uses the 
shortest path to connect these opposite corners:that is, the layer will not wrap all the way around the 
object. If you want the shape to wrap "the other way" around your object, hold down the Option/Alt key as 
you drag. 

Working with Layers 
Once you've created layers, you can move, resize, overlap, and delete them. 

To select a layer: 

1. Choose the Layer Selection tool. 
 

 
2. Click the layer you want to edit. Carrara shows the layout of the layer. The layer has four handles, 

one at each corner. 

To move a layer: 

• With the Layer Selection tool, drag the shape along the surface of the object. 

• You can also use the Shader Tree Editor to numerically reposition a layer. Type the numeric 
value in the parameters to reposition the specified layer. 

To delete a layer: 

1. Select the shape. 

2. Click the Trash can in the Shader Tree Editor. 
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To resize a layer: 

• With the Layer Selection tool, drag one of the corner handles on the shape's bounding rectangle. 
Drag toward the center of the shape to shrink it. Drag outward to stretch it. 

• You can also use the Shader Tree Editor to numerically resize a layer. Type the numeric value in 
the parameters for the specified layer. 

When you use the Shader Tree Editor to edit a Layers List shader, the layers are listed in the shader tree. 
You can edit the contents of the layer layers from within the Shader Tree Editor. Refer to "Creating and 
Editing Shader Trees" to learn more. 

Layering: How Layer Shaders Interact 
When you create a layer on the surface of an object, the layer's shader overrides the shading 
characteristics of the object's surface. Likewise, when several layers overlap, the topmost layer's shader 
overrides those below. That is, the last layer in the list will appear to be "in front" of the other layers. 

There is one important corollary to this rule, however. When a layer's shader has one or more empty 
channels, it inherits the settings for these channels from the layer immediately above it (or from the 
surface, if there is no layer above). 

For example, if you create a layer on an object with a bumpy surface, any layer you create will also be 
bumpy unless the shader you're using specifies different bump settings. To create a smooth layer on a 
bumpy object, you would use a shader with a constant value in the Bump channel. 

The Shader Tree Editor allows you to control the opacity of an object's layers. Unlike a shader's 
Transparency setting, layer opacity does not affect an object's translucence; rather, it controls how layers 
interact. If a layer's opacity is less than 100%, its shader does not fully override the shaders of the surface 
and layers above; rather, the shaders effects are mixed. 

Editing Layer Shaders 
The parameters for the different branches in the Shader Tree Editor allow you to edit the position and size 
of an object's layer with numerical precision. You can also add and delete layers, change layering, specify 
a layer's opacity, convert a layer from one type to another, remove an object's surface, and change an 
object's mapping mode. 

The Layers List shader displays the component shader and opacity mask for each applied layer. Select 
which type of component shader you want to use and the appropriate branches display in the Shader 
Tree Editor. 

To change the layering order: 

1. Select the layer you want to reorder in the Shader Tree Editor. 
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2. Drag the layer into the order you want. In a moment, the object preview updates to your changes. 
 

 
To create a new layer shader: 

1. Click the Plus icon from within a Mapping branch of the Shader Tree Editor. 
 

 
2. Select the type of layer from the list. 

3. Carrara creates a new layer on the surface of the object. The new shape has the default size, 
position, and shader:all of which you can change. 
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To delete a layer shader: 

1. Select an element in the Shader Tree Editor. 

2. Click the Trash can icon, or press Delete. 
 

 
To change the layer type: 

• Choose the type you want from the Shape pop-up menu that lists the name of the current type of 
layer. 
 

 

Mapping Shaders 
Most shader content is two-dimensional. Texture maps, for example, are nothing more than 2D images. 
Many procedural shader functions:including Carrara's checkers and wires:also produce two-dimensional 
image data. 

Carrara uses a process known as mapping or projection mapping to apply this 2D shading information to 
the surface of a 3D object. 

Carrara's interface allows you to shade objects without worrying about the internal "nuts and bolts" of 
mapping. Most of the time, you can simply apply shaders on objects with the Layers tools and let Carrara 
take care of the details. Occasionally, however, you might find that changing an object's mapping mode 
makes it easier for you to achieve the results you want. 

When you change an object's mapping mode, Carrara changes the method it uses to map 2D shapes and 
images to the object's surface. As a result, the Layers tools behave differently on the object. Depending 
on the shape of your object and the mapping mode you choose, the difference can be subtle or quite 
dramatic. 

The four different mapping shaders are: 

• Parametric Mapping shader 

• Flat Mapping shader 

• Cylindrical Mapping shader 

• Spherical Mapping shader 

Each of these mapping shaders allows you to change the way sub-shaders are projected on the object. 

Mapping shaders also allow you to define to which shading domain of the object they can be assigned. 
When you use the Layer Shader tools, Carrara automatically inserts Mapping Shaders for you so that 
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your layer shaders get applied to the appropriate shading domain of the object. You can also add 
Mapping Shaders manually. Refer to "Shading Channels Reference." 

Texture Maps 
You can use a texture map to apply an image to an object. You can create a texture map with a separate 
2D drawing program such as Painter, Photoshop, or Paint Shop Pro. Then, the map is applied to the 
object. If the image file has an alpha channel associated with it, you can use that information as well. 

Texture maps allow you to create effects that would be cumbersome or impossible to create using other 
methods. Texture maps are useful when you must create 2D effects, such as signs of wear on an object 
or lettering. 

 
Note If any of the shaders in your shader files contain Texture Map components that reference external 
image files, you must maintain the relative path from the shader files to the image files. 

If you move either the shader files or the image files to a different folder, Carrara prompts you to locate 
the missing image files when it loads the shader files into the Browser tray. 

Refer to "Layer Components" to learn how to load a texture map and apply it to an object. 

Here is an example of a spacecraft created using a texture map. 

 
Here is a similar spacecraft created without using a texture map. 
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Modifying the Default Shader for a Scene 
When you create new objects in a scene, they are assigned the Master Shader named "Default." You can 
modify this master shader to control what will be the default shading of the objects in your scene. 

To modify the default shader for a scene: 

1. Switch to the Master Shaders view in the Sequencer. 

2. Double-click the icon for the Master Shader named "Default." The shader opens in the Shader 
Tree Editor window. Or you can select the Master Shader and switch to the Texture room. 

3. Edit the shader in the Shader Tree Editor. 

Creating and Editing Shader Trees 
Shaders are a powerful way of bringing your 3D objects to life. You can use Carrara's extensive libraries 
of shaders to add life to your objects, but because there is no limit to the types of objects you can create, 
you might need to build a unique shader to suit each object you create. 

Carrara's shader structure makes it possible to create your own custom shaders. Much like mixing your 
own colors for painting on an artist's palette, you'll use the Shader Tree Editor to create an infinite number 
of different textures, colors, and surfaces. 

This chapters explains the Shader Tree Editor and guides you through the process of creating your own 
shaders. 

Shader Structure and Content 
Shaders are composed of a number of different elements, each of which combine to create a realistic 
material. This section describes the basic elements of a shader, and also points to a number of other 
topics that you can study as well. 

The basic elements of shaders in Carrara are as follows: 

• A Shader Tree: In Carrara, the shader tree is a modular structure that allows you to define the 
different properties in your shader. The shader tree is described further in this section, under 
"Shader Tree." You can also read "Building and Editing Shaders" for a more detailed look at the 
Shader Tree Editor. 

• A Top Shader: The topmost element in a shader tree is the Top Shader, of which Carrara 
provides several different models. The top shader that you select determines the material 
properties that you can use in the shader. The various types of top shaders are described in 
"Choosing a Top Shader." 

• Shader Channels: Shader channels are the individual properties that are combined together to 
create a realistic material. Some shaders might use only a Color channel, while other shaders 
might use a combination of color, bump, reflection, glow, transparency, and so on. A shader does 
not have to utilize all of the channels that are available in a top shader. Shader Channels are 
described in "Shader Channels Reference." 

• Shader Components: Once you determine the types of channels that you want to use in your 
shader, you then plug shader components into those channels. For example, to define the 
properties of a Color channel, you can use a solid color, a texture map, a procedural texture, or a 
formula that defines the colors used. The various shader components are described in "Shader 
Components Reference." 
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Shader Tree 
A shader is a set of surface properties that you can assign to an object. Carrara features a modular 
structure for defining shaders: the shader tree. The shader tree's modular nature allows for great 
flexibility in shader content. 

A shader tree is a set of shaders assembled in a hierarchical way. Each shader in the tree uses the 
output of its branches in the tree and combines these outputs to provide the final appearance of the 
surface. 

In simple cases, the tree is only one level deep. This is the case with the default Multi-Channel shader. 

 
In more complex cases, the tree has multiple levels. For example, the glow branch of a Multi-Channel 
shader can contain a mixer shader that, in turn, uses several sub-shaders. The tree can be as deep as 
necessary. However, the deeper the shader tree, the longer it will take to be calculated. 

You can use shaders as components when creating other shaders. A sub-shader is simply a shader used 
within another shader. You can use any type of shader as a sub-shader. The only distinction is whether 
the shader is at the top of the tree or located under one of the branches. 

Editing the Shader Tree 
You build a shader by placing components and sub-shaders on the branches of the shader tree. To edit a 
shader tree, you simply add, remove, and replace shader components. 

You can select options from the pop-up menus to create your shader. Notice that you can nest shaders 
within other shaders to create complex effects. Depending on the type of shader you are creating, you'll 
see a plus sign or the Trash can icon, which you can click to add or remove branches. 

Carrara's drag-and-drop interface pertains not only to applying shaders, but also to building them. You 
can drag a component or sub-shader from one branch of the shader tree to another. You can also drop a 
shader from the Shaders Browser onto a branch of the shader tree or drag a sub-shader from the tree 
into the Browser for storage. 
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To place a shader component or sub-shader on the shader tree: 

1. Choose a shader from the pop-up menu. 

2. Choose the component you want to add from the pop-up menu corresponding to the branch you 
want to edit. 

For complete information on the components, refer to "Shader Components Reference." 

To move components by dragging: 

• Drag a sub-shader or component onto the branch of the shader tree where you want it.  

o You can drag a shader from the Browser. 

o You can drag a component from another open Shader Tree Editor window. 

Carrara copies the component or sub-shader you drag onto the branch where you drop it, replacing any 
contents that might have been there before. 

When you drop a shader onto any branch of a Multi-Channel shader, Carrara places only the contents of 
the applicable channel on the branch. If the shader you're dropping has no components in the applicable 
channel, Carrara notifies you, and adds nothing to the branch. 

Note When you drop a shader onto the Source 1 or Source 2 branch of a Multi-Channel Mixer shader, 
Carrara places the entire shader you're dropping (all eight channels) on the tree. 

To remove the contents of a branch: 

1. Select a component or sub-shader. 

2. Choose Edit > Delete, click the Trash can icon, or press the Delete/Backspace key. 

To copy a component or sub-shader to another channel: 

• Hold Cmd/Ctrl, then drag a component or sub-shader from its branch and drop it on a different 
channel tab. Carrara replaces the entire contents of the channel with the component or sub-
shader you drop. 

Building and Editing Shaders 
Most of the work in building and modifying a shader takes place in the Shader Tree Editor. The Browser: 
Shaders category and shader document windows are also useful. 

You can use the Shader Tree Editor to design a new master shader, modify a master shader already 
used in your scene, or modify a master shader you've stored in the Browser. 

Displaying the Shader Tree Editor 

In order to display the Shader Tree Editor, you need to select one or more objects in your scene. 

• When more than one object is selected, and they all use the same shader, a single Shader Tree 
Editor displays and you can select which object you want to display in the Preview window by 
clicking the pop-up menu in the upper left corner of the preview window. 

• When more than one object is selected, and they all use different shaders, a separate Shader 
Tree Editor window displays for each shader. 

For example, if you select three objects and two use the same shader, Carrara displays two Shader Tree 
Editors, one for each shader. 
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If you select two of three objects that use the same shader and start to edit the shader, Carrara prompts 
you whether you want to modify that shader (and apply the changes to all three objects), or clone the 
shader and apply the new shader with changes to only the selected objects. 

The Shader Preview window shows you what the shader you are editing looks like. Each time you change 
the shader tree, Carrara updates the preview to show how your change affects the shader. 

To display the Shader Tree Editor: 

1. Select one or more objects in the Assemble or Storyboard rooms, then click the Texture room 
button to switch to the Texture room. 

2. Carrara displays a Shader Tree Editor for each Master Shader. You can resize the Shader Tree 
Editor windows as needed to view the contents of the Editor. Select the control in the lower right 
corner and drag to resize the window. 
 

 

Choosing a Shader Preview Mode 

You can choose a spherical preview (as shown in the previous figure), which shows you how your shader 
will look on the surface of an object, a flat preview, which gives you an undistorted view of 2D image data 
like texture maps, or a preview of any object primitives that use this shader. 

 
To switch between spherical, flat, and object preview: 

1. Click the text in the top left corner of the Shader Preview window. 

2. Choose one of the preview options from the list. 

This change affects only the preview of the shader you are currently editing, 
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Creating a New Shader 

To create a new shader: 

1. Switch to the Texture room. 

2. Choose Edit > New Master Shader. This menu is also available if you use the left click on the 
tab that contains the master shaders. 

3. Use the Shader Tree Editor tools and features to design the shader.  

• Choose a shader type, and add a component from the lists. 
 

NOTE! Refer to "Shader Components Reference" for information on the shader 
components. Instructions for navigating and editing the shader tree appear below. 

• Drag a shader from the Browser into an appropriate place in the Shader Tree Editor, 
where it becomes a sub-shader. 

• Open a shader document from the Browser and drag its components or sub-shaders into 
the Shader Tree Editor. 
 

NOTE! If you drop a shader or sub-shader onto a place holder where its type is 
inappropriate, Carrara alerts you. For example, you can't put a Single Channel shader at 
the top of a shader tree. 

4. When you're finished designing the new shader, either apply it to an object or add it to the 
Browser. 

Adding New Shaders to the Browser 

To add the current shader to the Browser: 

1. Drag the shader preview from the Sequencer to the Browser. 
 

NOTE! You must drop the shader under a directory column. 

2. Carrara prompts you to name the new shader. 

3. Enter a name and any comments, then click OK. 

Editing Shaders from the Browser 

To open/edit a shader from the Browser: 

1. Double-click on the shader you want to edit. Carrara opens it in a Shader Tree Editor window.  

2. Edit the shader by adjusting sliders and other settings. 
 

NOTE! In the Browser, Carrara saves shaders as documents. 
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NOTE! If you don't see the Shader Tree Editor window right away, it might be hidden under one of 
the floating palettes such as the Sequencer or Browser trays. 

You can drag and drop components or sub-shaders from another Shader Tree Editor window or other 
open shader documents. 

You can also add or change components using the lists in the Shader Tree Editor. The lists display 
appropriate choices that you can use for the level of shader tree you are currently editing. 

Adding Modified Shaders to the Browser 

To save the modifications to the shader: 

1. Make sure the Shader Tree Editor window for the shader you want to save is the active window. 

2. Choose File > Save.  

3. Carrara saves the changes into the Browser document file. 

4. If you want to save the shader under a different name:  

• Drag the preview into the Browser. 

• Enter a new name. 

5. Close the Shader Tree Editor window when you're done. 

Choosing a Top Shader 
The properties that you can assign to a shader vary, depending on the top shader that you select. Carrara 
offers several different types of top shaders that you can use to build your materials.  

To specify a top shader: 

• Choose a shader from the pop-up menu such as Multi Channel, Multi-Channel Mixer, or Layers 
List. This replaces the current contents of the Shader Tree Editor with an empty shader tree of 
the appropriate type.  
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Hair Shader (Standard, Pro) 

Hair Shaders are specifically used to control properties of dynamic hair. Further information on the Hair 
Shader can be found in "Using Hair Shaders and Presets." 

• The Hair Color shader is discussed in more detail in "Controlling Hair Color with Shaders" and 
"Using Hair Shaders and Presets."  

• Hair Thickness, Length, Density, Frizz, King, Wave, and Clump shaders are discussed in more 
detail in "Styling Hair with Shaders." 
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Multi Channel Shader 

Choose a Multi Channel shader when you want to create a shader that combines several different shader 
properties. This shader allows you to combine color, alpha, highlight, shininess, bump, reflection, 
transparency, refraction, glow, subsurface scattering, and translucency, or any combination of them. 
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Terrain Shader 

Terrain shaders are commonly used to control the appearance of the terrains in your scene. When you 
choose Terrain as a top shader, the Texture room displays several properties in the right panel of the 
Shader editor. This allows you to control the size, amplitude, and roughness of the terrain, and also 
allows you to choose the type of global shader you want to assign to the terrain. 

Though you can assign any shader component or function to the terrain's Global Shader, the Terrain 
Distribution shaders are most commonly assigned. See "Terrain Distribution" for further information on the 
terrain functions. 
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Projection Mapping 

Projection mapping shaders relate to how an object takes a flat texture map and applies it to the object or 
part of an object. For further information, see "Projection Mapping Shaders." 

Lighting Models 

A lighting model is a special shader that defines the way light interacts with the material. If there is no 
lighting model in your shader tree, the default lighting model (Phong) is used. A lighting model should be 
placed at the root of the shading tree. It can also be placed in a layer as long as there is no lighting model 
above it (only the top lighting model is used). 

There are currently three lighting models in Carrara: Anisotropic, Phong, and Shadow Catcher. 
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Anisotropic 

Anisotropic simulates a material that reflects light differently depending on the direction. It can be used 
to simulate brushed metals, for instance. 

 
Anisotropic lighting allows you to set the direction of the highlights in the shader, through the Tangent 
Direction settings: 

• Latitude: Highlights run in a north/south (or up/down) direction. 

• Meridian Line: Sets a main direction of the material that is perpendicular to the latitude. 

• Customized: Choose this option to set the direction with the direction indicator, relative to the iso 
U and iso V lines (line of constant U / V). The angle is the angle relative to the iso U line, with a 
value of zero meaning that the direction is set by the iso U line. 

Phong 

Phong is the default lighting model that is used if you do not choose an alternative lighting model. There 
are no additional properties to set other than to select the shader that it controls. 

Shadow Catcher 

Shadow catcher is a special shading mode that is used to cast shadows on a background object (see 
"Casting Shadows on Background Objects"). 

Layers List 

Using a Layers List component as the root of your Shader Tree enables you to use Layer Shaders and 
Mapping Shaders, and add any number of Layer Shaders to the object. 

When you apply different textures to areas of an object, you are using a Layers List shader. The layers in 
a Layers List shader are stacked, as if one was painted on top of another. You can modify the layer 
ordering within the list. 

Carrara specifies layers either by the shading domains of the object or by the use of layer components. 
Refer to "Shading Domains" or "Objects with Multiple Shading Domains" to learn more. 
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Multi Channel Mixer 

The top level of a Multi-Channel Mixer shader tree has only one branch, which affects all of its shading 
channels. The Multi-Channel Mixer operator always appears on that branch. The Multi-Channel Mixer 
operator functions identically to the Mixer operator, except that it mixes complete shaders rather than 
individual shader components. These complete shaders can be Multi-Channel shaders, as in the example 
above, part of Layered List shaders, or other Multi-Channel Mixer shaders. You can achieve complex 
shading effects by nesting Multi-Channel Mixer shaders. 

A Multi-Channel shader contains eight channels. You can use any type of shader component in each of 
those channels. The settings within the different channels combine to determine the shader's overall 
appearance, but settings in one channel have no effect on the settings in the other channels. Refer to 
"Shader Channels Reference" for more information about the various types of shader channels. 

Suppose you want to create a shader that mixes attributes in all the shading channels at once. For 
example, you might want to create a checkerboard pattern with alternating squares of shiny, reflective 
gold and rough granite. To accomplish this with a Multi-Channel shader, you would need to apply the 
same mixer function to each channel. Fortunately, Carrara provides another type of tree structure, the 
Multi-Channel Mixer, which makes it easier to achieve effects like this. The diagram below illustrates 
how a Multi-Channel Mixer shader works. Any component you place under the Multi-Channel Mixer 
affects all the shading channels. 
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The checker pattern applied to this object has alternating squares of gold and granite. It was created 
using the Multi-Channel Mixer shader. 

 

Reference Shader 

A reference shader component allows you to specify an existing shader by reference. When you edit that 
other shader, Carrara automatically updates all references to it. 

For example, if you created a series of wine bottles with different labels, you could set up the glass in the 
bottle to be a reference shader. Then when you edit the Glass shader, Carrara automatically updates all 
of the bottles that refer to that shader. 

To specify a reference shader: 

1. In a Layers List shader, select Reference Shader. 

2. Select one of the shaders listed in the Shaders list. 

Shader Recipes 
Here are a few shader recipes to get you started creating your own shaders. 

When using refraction, you should have something behind your object to refract. You can set a 
background in the scene settings. 
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Chrome 
Chrome is a simple shader to create yet it can create interesting effects in a scene as the chrome object 
reflects what surrounds it. 

 
To create chrome: 

1. Create a Multi-Channel shader. 

2. Set Color to Black. 

3. Set Highlight to White. 

4. Place a Value slider in the Shininess channel, and set it to 9%. 

5. Place a Value slider in the Reflection channel, then set it to 90% or 100%. 
 

 

Ice 
Ice is another simple shader to create. Simply select a shade of blue, and set a value in a few of the 
channels. 
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To create Ice: 

1. Create a Multi-Channel shader. 

2. Set Color to a black. 

3. Place a Value slider in the Highlight channel and set it to 35%. 

4. Place a Value slider in the Shininess channel, and set it to 15%. 

5. Place a color in the Transparency channel, then set it to an aqua (H-52, L-90, S-100). 

6. Place a Value slider in the Refraction channel, then set it to 19%. 

7. Set Glow to Black. 
 

 

Pine 
Pine uses a Mixer in the color channel. You can change the colors used to create other types of wood. 
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To create pine: 

1. Create a Multi-Channel shader. 

2. Set Color to Mixer. 

3. Place a Value slider in the Highlight channel and set it to 20%. 

4. Place a Value slider in the Shininess channel and set it to 7%. 

5. Set Glow to color, and select Black. 
 

 
To set up the Color channel Mixer: 

1. Set Source 1 to light yellow. 

2. Set Source 2 to light tan. 

3. Set Blender to the Wood function and set the following values: 

4. Set Global Scale to 50%. 

5. Set Undulation to 37%. 

6. Set Vein Count to 6. 

7. Set Vein Blending to 50%. 

8. Set Perturbation to 100%. 

Beach Ball 
This beach ball is created by using two Mixers and the Checkers shader. You can add more colors to 
your beach ball by placing another Mixer in the Source 2 channel (where yellow is currently selected) and 
selecting two colors. Other than selecting the new colors, you would set it up like the Mixer placed in the 
Source 1 channel. 
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To create a beach ball shader: 

1. Create a Multi-Channel shader. 

2. Place a Mixer in the Color channel. 

3. Place another Mixer in the Source 1 channel. 

4. Place the color yellow in the Source 2 channel. 

5. Set Blender to Checkers, and set the Checkers options as follows:  

• Set Squares H to 12. 

• Set Squares V to 0. 

6. Place a Value slider in the Highlight channel and set it to 89%. 

7. Place a Value slider in the Shininess channel and set it to 3%. 

8. Place the color black in the Glow channel. 
 

 
To set up the secondary Mixer in the Source 1 channel: 

1. Set Source 1 to Blue. 

2. Set Source 2 to Red. 

3. Set Blender to Checkers and set the following options:  

4. Set Squares H to 6. 

5. Set Squares V to 0. 

Shader Channels Reference 
Shader channels define several attributes of an objects appearance. Shaders can consist of one or more 
of the following types of channels: color, alpha, highlight, shininess, bump, reflection, transparency, 
refraction, glow, subsurface scattering, and translucency. For more information about shader channels, 
refer to "Shader Channels Reference." 

When shading is calculated, several shading channels are evaluated: Color, Alpha, Highlight, Shininess, 
Bump, Reflection, Transparency, Refraction, Glow, Subsurface Scattering, and Translucency. 

To specify shader settings, you add components to the shader tree in one or more of the channels. The 
components beneath a particular channel represent that channel's settings. Depending on the 
components you use, the settings in each channel can be simple or complex. The Color channel might 
specify either a plain color or a multi-color pattern. Likewise, the Reflection channel might specify uniform 
or varying levels of reflectiveness across the surface of an object. You can also place functions in a 
channel. For example, you could place the Marble or Wood functions in the Color channel, instead of a 
color. 
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A shader need not contain settings in all of the channels. If you don't want to define a particular shading 
attribute, you can simply leave that channel empty. 

In addition to the shading channels, the shader also defines displacement mapping that is applied to the 
surface of the object. The displacement mapping uses a function defined on the surface (shader) to 
displace the surface of the object. To learn more about displacement mapping, refer to "Displacement 
Mapping." 

Color 
No shading channel has a more obvious effect on the appearance of an object or layer than the Color 
channel. Depending on the components you place beneath the Color channel, you can specify anything 
from a plain color to a complex, multi-color pattern. 

• To specify a plain color, simply place a Color component. 

• To specify a multi-color pattern, use a Texture Map component or combine colors with the Mixer 
operator. 

If you find that your single-color objects look unrealistic, try using the Mixer operator with the Spots 
function to create minute color variations. Simply mix two slightly different hues in a pattern of tiny spots, 
with Blending set to 0 for smooth blends. When viewed from a distance, these subtle color variations can 
give an object a more realistic appearance. 

The default content of the Color channel is a Color component set to a shade of gray. Carrara assigns the 
default content of each channel, as part of the default primer, to each new object you create. Carrara also 
uses the default content to calculate the preview of a shader in the Shader Tree Editor when a particular 
channel is empty. 

Alpha 
The alpha channel controls the opacity of the material. An alpha value of 0% will make the shader fully 
transparent, whereas an alpha value of 100% will make it fully opaque. 

The alpha channel differs from the transparency channel in the way the transparency is calculated: 

• The transparency is additive, which means that adding transparency to an object will only make it 
brighter. 

• The alpha creates a fading effect: as the alpha decreases, the object disappears. 

The alpha channel is usually used for compositing, whereas the transparency channel is used to simulate 
transparent materials (such as glass). 

Texture Map with Alpha Channel 
Texture map files can contain an alpha channel. When you put such a texture map in the color channel, 
its alpha channel is multiplied by the value in the alpha channel to calculate the alpha of the material. So 
if the alpha value is 100% and you put a texture map in the color channel, its alpha channel will be 
directly applied to your material. 

Highlight and Shininess 
Most objects in the real world show highlights when illuminated. These bright spots or streaks are direct 
reflections of light sources, like the sun glinting off a chrome bumper. 

 © 2008 DAZ 3D, Inc. 570 



Carrara 7 11 December 2008 

Metallic objects have small, bright highlights. Plastics have dim, but large, highlights. And stones usually 
have no highlights, unless polished. 

You can control the color, intensity, and size of an object's highlights by placing shader components 
beneath the Highlight and Shininess channels. 

' 

The Highlight channel controls highlight intensity. A high value produces bright highlights; a low value 
produces dim highlights. 

The Shininess channel controls highlight size. A high value produces small highlights; a low value 
produces large highlights. 

Note Typically, highlights that are extremely bright are very small; those that are softer spread larger. 

By default, highlights are white. You can specify color highlights by placing a Color component (or any 
component that produces color information) in the Highlight channel. Color has no effect on the Shininess 
channel; any color information in the Shininess channel is internally converted to values. 

The default content of both the Highlight channel and the Shininess channel is a Value component set to 
a value of 50. 

If you want varying levels of highlight or shininess across the surface of an object or Layer, you can use a 
texture map or a function. 

Bump 
Bumpy and rough surfaces are difficult to model geometrically. Imagine modeling the irregularities of the 
skin of an orange, point after point:the task would quickly become a nightmare. Fortunately, Carrara 
allows you to use a shader to simulate variations on the surface of an object. 

By placing shader components in the Bump channel, you can "perturb" a smooth surface to produce 
irregularities. This technique is known as bump mapping. Bump mapping can produce subtle effects like 
the bumps and pits on the surface of an orange, or more pronounced effects like the seams on a baseball. 
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Bump mapping does not change the actual topography of an object:no points are displaced. Rather, it 
changes the angle at which light rays reflect off the surface at certain points. This technique tricks the eye 
into perceiving texture. Because the bumpiness is just an illusion created by the renderer, the edge of the 
object remains smooth. In most cases, this is not a problem. However, if you require true surface 
variations to appear on the silhouette of your object, you must create them in the modeler. 

To simulate bumps, the components you place beneath the Bump channel must specify some variation in 
the colors or values of adjacent pixels. Consequently, placing a simple color or value in the Bump channel 
does not produce bumping. 

Texture maps and functions produce the best results in the bump channel. As with the other non-color 
channels, the Bump channel always converts color information to grayscale. 

When you use a grayscale image in the Bump channel, lighter areas appear to be raised; darker areas 
appear to be lowered. When you use a function that produces values, areas with higher values appear to 
be raised; areas with lower values appear to be lowered. 

• For the most convincing results, you should create a smooth blend between extreme values like 
black and white or 0 and 100. 

• If a grayscale image with hard edges between black and white does not produce a satisfactory 
bump effect, try applying a blur effect to the image in an image-editing application. 

• The relative height or "steepness" of the bumps depends on how rapidly you blend between 
extreme values. A blend that occurs over the range of many pixels produces shallow, gradual 
bumping. A blend that occurs over the range of a few pixels produces steeper, more sudden 
bumping. 

The default content of the Bump channel is a Value component set to a value of 0. This produces no 
bumping because there is no variation from pixel to pixel. 

To change the amount of bump: 

1. Adjust the Bump Amplitude slider located after the glow channel in a multi-channel shader. 

2. This slider lets you strengthen or weaken the Bump effect. 

3. Apply your changes to the object. Use the Test Render tool to check the results on the object. 

Reflection 
Many real-world surfaces are at least somewhat reflective. Most types of metal and glass are partially 
reflective. A mirror is so reflective that it takes nearly all of its color from the environment around it. 

The reflection channel contains a reflection shader which controls the properties of the reflection. You 
can adjust the following parameters for the reflection: 

• Fresnel Term: In most materials, the amount of light reflected from a surface depends on the 
angle of view. This is the Fresnel effect that can be noticed in glass, water and other transparent 
materials. The reflection is most intense at low angles of view and less intense when directly 
facing the material surface. 

• Blurry reflections: Reflections are not always as sharp as a mirror. Most materials have much 
more diffuse reflection. Enabling blurry reflections allows you to simulate that effect. 

• Maximum ray depth: Controls how many times a ray of light can bounce against the reflective 
surface. 

• Maximum Attenuation: Determines when an extra ray of light should be sent for reflections 
depending on the attenuation of the previous bounces. This way, if you see a reflective object 
through a barely transparent object, the reflection is not calculated which speeds up the 
calculations. 
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Carrara allows you to specify reflectiveness by placing shader components beneath the reflection shader. 

 
Although a Value component works fine in the Reflection channel, you can achieve both subtler and more 
fantastic effects by using a Color component instead. 

• When you use color data (a Color component, a Texture Map component, or a complex sub-
shader) in the Reflection channel, its hue affects the tint of the reflection and its brightness 
determines the amount of reflection. Darker colors produce less reflection; brighter colors 
produce more. 

• Using values in the Reflection channel produces the same effect as using shades of gray. Only 
the amount of reflection is affected. 

Of course, if you want varying levels and tints of reflection across the surface of an object or layer, you 
can use a texture map or a function. 

The default content of the Reflection channel is a Value component set to a value of 0. 

Transparency 
When light strikes an opaque surface, it simply bounces off. When it strikes a semitransparent surface, 
some light bounces off, but some passes through. As a result, you can see through a semitransparent 
object. Glass, water, and clear plastic are examples of semitransparent materials. 

The transparency channel contains a transparency shader. You can adjust the following parameters for 
the transparency: 

• Fresnel Term: In most materials, the amount of light transmitted through the surface depends on 
the angle of view. This is the Fresnel effect that can be noticed in glass, water and other 
transparent materials. The transparency is less intense at low angles of view and most intense 
when facing the material surface. 

• Maximum ray depth: Controls how many times a ray of light can go through the surface. 

• Maximum Attenuation: Determines when an extra ray of light should be sent for transparency 
depending on the attenuation due to the previous bounces. 

You can specify transparency by placing shader components beneath the Transparency shader. 

Try using a function or a black and white texture map in the Transparency channel to create a shader that 
makes transparent "holes" in an object. 

For example, placing the Wires function in the Transparency channel creates a wireframe effect. 
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• When you use color data (a Color component, a Texture Map component, or a complex sub-

shader) in the Transparency channel, its hue affects the appearance of colors viewed through the 
transparent shader. Its brightness contributes to how transparent the shader is. Darker colors 
produce less transparency; brighter ones more. 

• Using values in the Transparency channel produces the same effect as using shades of gray. 
Only the amount of transparency is affected. 

• A 100% transparent surface might not be completely invisible:depending on the settings in the 
other channels, it might still refract and show highlights. 

The default content of the Transparency channel is a value component set to 0. 

Refraction 
When light rays pass through a semi-transparent object, their trajectories are deflected. This 
phenomenon is known as refraction. Glass, fluids, and other translucent materials refract light to some 
degree. This results in a distorted view of objects behind the refractive surface. The distorted view of the 
straw below was created by using refraction on the water glass. 

 
Try a simple refraction experiment: Stand a pencil in a glass of water. Refraction "bends" the pencil where 
it enters the water. 
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A single Value component is generally all you'll need to place in the Refraction channel. 

NOTE! The setting in the Refraction channel affects only a shader with some degree of 
transparency. Light must pass through to be refracted. 

Shaders simulating glass should have Refraction values around 20. Shaders simulating water or ice 
should have values somewhat lower. Try experimenting with different values until you achieve the effect 
you want. 

Color has no effect on the Refraction channel. Any color information in the Refraction channel is internally 
converted to values. 

The default content of the Refraction channel is a Value component set to a value of 0. 

Glow 
The settings in a shader's Glow channel determine the shader's luminance. An object whose shader has 
a high degree of luminance will appear bright, even if it is not lit by ambient light or external light sources. 

You can use glowing shaders to simulate things like neon tubing, lit windows in a cityscape at night, or 
the LED display of a digital clock. You can also use them for the subtler purpose of brightening a 
particular object in a dimly lit scene. This allows you to emphasize an object without affecting the lighting 
and mood of your entire scene. 

 
Objects with glowing shaders do not cast light on other objects in the scene. 

Although you can use a Value component in the Glow channel, a Color or Texture Map component is 
more appropriate. For realistic results, try using similar colors in the Color and Glow channels. 

To create unusual effects, you can place markedly different colors in these two channels. For example, 
you might create a shader which appears green when well lit, but glows red when covered in shadow. 

When you use color data (a Color component, a Texture Map, or a complex sub-shader) in the Glow 
channel, its hue determines the color of the glow, and its brightness determines the intensity. 

For a related glow technique, refer to "Rendering with an Aura." 

Subsurface Scattering 
Subsurface scattering is the light that scatters through the volume of translucent materials. It is most 
visible in semi-opaque materials such as marble, milk, wax, skin, etc. It is characterized by a very smooth 
and diffuse lighting that filters through the material. 
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Here is a quick description of the parameters used for subsurface scattering: 

• Intensity is the intensity of the effect. 

• Translucency is the most important parameter of the subsurface scattering shader. It represents 
the depth to which the light diffuses into the material. The higher the translucency value, the 
deeper the light penetrates into the material. 

• Diffuse Reflection controls the intensity of the scattering at the surface. 

• Refraction Index controls the index of refraction of the material (it has some impact on the 
scattering intensity) that is used for the subsurface scattering calculations. 

• Fresnel Effect controls how the subsurface scattering and the rest of the lighting is mixed. 100% 
is the most physically realistic. In that case, when the surface is facing the observer, the light is 
96% of subsurface scattering and 4% of light reflected from the surface. When the surface is 
seen from the side it is the contrary. When the slider is at 0, the subsurface scattering is simply 
added to the light reflected by the surface. 

NOTE! Subsurface scattering varies depending on the size of the objects to which it is applied. 
The shader works in a way that a given shader will simulate the same material properties for all the 
objects it is applied to. However, if you want to get the same effect at a bigger scale, you will need to 
increase the translucency. 

Displacement Mapping 
Displacement mapping uses a shading function to displace the surface of the object. Contrary to the 
Bump channel that only modifies the surface normal to simulate the appearance of a bumpy surface, the 
displacement mapping creates actual geometry. It can be used to create all kinds of bumpy materials 
(bark, tiles, rocks, etc.) or simply to add details to an object. 

The advantage of using displacement mapping is that you get correct shadows and edges. 

 
To add displacement: 

1. In the Assemble room, select the object that you want to change. 

2. In the Properties tray: General tab: General panel, click the Edit button to open the shader 
editor. 

3. Click on the displacement tab of the shader document. Options for displacement appear in the 
Shader Editor. 
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4. Choose the Top Shader to configure the following options:  

• Enable Displacement: Check this option to enable the displacement shader. 

• Displace in 3D View: Displacement mapping is applied to the mesh that is visible in the 
interactive preview (3D view). Otherwise, the displacement is only visible when rendering 
the object. 

• Amplitude: Sets the height of the displacement. 

• Offset: Decides which value of the shading function is 0. The offset is subtracted from 
the shading function so if the shading function is below the offset the displacement is 
done in the opposite direction of the normal. 

• Smoothing Angle: Controls which edges will be smoothed. If the angle between two 
triangles is smaller than the smoothing angle, the edge is smoothed, otherwise it is 
creased. 

5. Enable or disable subdivision as discussed in "Using Subdivision with Displacement Shaders." 

6. Choose the type of shader that you want to use for displacement. "Using Texture Maps for 
Displacement" describes how to assign a displacement texture map. 

Using Subdivision with Displacement Shaders 
To achieve good precision on the displacement, it is often useful to subdivide the mesh as discussed in 
"Working With Subdivision Surfaces." However, it is often better to use the native subdivision of the object. 
For instance, if you are displacing an object created with subdivision surface, it is recommended to 
increase the subdivision count instead of using the displacement shader subdivision scheme. (Standard, 
Pro) 

The displacement shader offers its own subdivision method, which you can configure as described in the 
steps that follow.  
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To use subdivision with displacement maps: 

• In the Subdivision section, configure the following settings as desired:  

enable subdivision in the displacement shader. 

rface before the actual 

ion. This will create a uniform sampling of the mesh. 

h in 

o Enable: Check this option to 

o Smooth Surface: Check this option to smooth the subdivided su
displacement is applied 

o Min. Sample Count: Defines the minimum number of vertices that the mesh should 
contain after the subdivis

o Extra Adaptive Steps: This is extremely useful if the displacement function is smoot
most places with some big discontinuities (for instance a checked board). 

NOTE! Each extra adaptive step multiplies the number of triangles by four. Increase this parameter 
carefully. 

 Texture Maps for Displacement 
an assign a shader type to the 

 type of displacement you want to 

bject. If you want to choose a texture map to control the amount of displacement, choose 

Using
After you assign the Top Shader properties for displacement, you c
Displacement channel. Click the Displacement button to select the
assign.  

One common option is to use a grayscale texture map to control the amount of displacement in a UV-
mapped o
Texture Map. The appropriate items then appear in the Shader Editor. 

To set properties for displacement maps: 

1. Select Texture Map as the displacement type.  
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2. The shader editor displays texture map options in
 

 the right panel. 

 
3. Configure the settings for the displacement map as described in "Texture Map." 

Shader Transforms 
se shaders appear in the 

The Shader Transform tab allows you to move, scale, and rotate a shader. Use it for fine adjustments to 
the look of a shader in your scene, or for creating interesting animated effects. Transforms are particularly 
applicable to projection mappings and noise shaders. You can transform Cylindrical, Spherical, and Flat 
mapping shaders, and the transform will affect all the shaders under the mapping. 

Some shaders can be transformed before they are applied to an object. The
shader tree with a pair of tabs, one of which is Transform. 

 
In the image above, the left sphere has a Lumber Yard shader applied. The sphere on the right has the 
same shader, but with the following transform applied to the Lumber Yard shader. 
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Shader Components Reference 
This section describes Carrara's different shader components. It explains what each component does and 
how to set each component's unique parameters. Within this section, the components are divided by type 
into groups: basic components, operators, functions, layers, and mapping modes. 

"Building and Editing Shaders" explains how to use the Shader Tree Editor to place shader components 
on the shader tree. 

You might have received other shader components in addition to those described here. Carrara's open 
architecture allows developers to program their own shader components in the form of plug-ins. These 
third-party extensions join seamlessly with Carrara's built-in shading tools. 

There are several types of shader components: basic components, operators, functions, lighting models, 
layers, and mapping components. These are discussed in more detail in "Shader Components 

Shader Components 

Reference." 

Basic Components 

Basic components are the fundamental building blo ks of shaders. Colors, values, and texture maps are 
ree built entirely with basic 
ccurs below the level of the 
 "Choosing Components

c
examples of basic components. The diagram below shows a shader t
components. Notice the structural simplicity of the tree:no branching o
channels. For more information on specific basic components, refer to ." 

 
ithin a shading channel. The arithmetic operators (Add, Subtract, and Multiply) 

s 

Operators 

To create more complex and varied shading effects, you can use operators to combine the effects of two
basic components w
combine components mathematically. An additional operator, the versatile Mixer operator, uses function
to combine components in many different ways. For more information on specific operators, refer to 
"Operators." 

The diagram below demonstrates the use of an operator. In this particular example, the Mixer operator is 
d function to mix two colors in a wood grain pattern. Notice that placing 
uses the tree to branch. 

used in conjunction with the Woo
an operator in the shader tree ca
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The wood grain a
wood grain funct

pplied to the object below was created by using the Mixer operator with two colors and a 
ion. 

 
When a component such as the Mixer operator has branches extending below it, the component and all 
the branches below are referred to as a sub-shader. Sub-shaders allow you to create truly complex 
effects:anywhere you can place a component on the shader tree, you can place a sub-shader instead. 

The shader in the example below uses the Mixer operator with the checkers function to create a complex 
checkerboard pattern in the Color channel. Half the squares in the checkerboard are spotted:the spot 
pattern is produced by a second Mixer operator, nested as a sub-shader within the first. The appearance 
of the remaining squares is determined by a texture map, loaded into Carrara from a 2D image file. This 
image file might contain a multi-color gradient or fractal pattern, for example. 

 
The checkerboard pattern applied to the object below contains a second Mixer operator that produces 
spots in one half of the squares in the checker pattern. 

 © 2008 DAZ 3D, Inc. 581 



Carrara 7 11 December 2008 

 

Function Components 

By choosing which function to use, you control how the Mixer operator combines a pair of components. 
Carrara comes with several functions, including Cellular, Checkers, Wires, Wood, Spots, Gradient, 
Psychedelic, and Marble. You can also define your own function with a formula. 

For more information on specific functions, refer to "Functions." 

You can specify the following types of layers: 

• Rectangular 

• Elliptical 

• Polygonal 

Each Layer uses two sub-shaders: 

• A primary sub-shader used to define the appearance within this layer 

• An opacity mask sub-shader used to define where the primary shader is applied within the layer 

o effect on the contents of your final 
ways renders RGB images. You can use 

vert rendered images to CMYK for separation. 

icker dialog. 

cker type from the list by clicking the name in the upper left corner. The available 
:  

K Sliders

Layer Components 

Color Pickers 
Carrara provides several different types of color pickers you can choose from when you are selecting 
colors for shaders or lights. In most cases, the color picker is in a floating window that can remain open 
as long as needed. 

Your choice of a color model is for your convenience only:it has n
rendered image. As with other rendering applications, Carrara al
an image processing application to con

To select a Color Picker type: 

1. Click a color chip to display the Color P

2. Select a color pi
color pickers are

• CMY  

er• Color Mix  
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• HLS Wheel 

• Lab Sliders 

• RGB Sliders 

• RGB Wheel 

• Web Colors 

3. Depending on which color picker you choose, adjust the value in one of the following ways:  

• Type a value 

ar in the color picker. The upper square is the color that is currently 
s using one of the following methods: 

er left to decrease the setting or right to increase the setting. 

erical value that appears at the right of the slider and enter a new value. 

 in your object. 

• Drag the sliders 

• Click a color to select it 

CMYK Sliders 
To use the CMYK Sliders Color Picker: 

1. Two color squares appe
assigned. Change the C, M, Y, and K value

• Drag the slid

• Click the num

2. Your color will update
 

 

NOTE! If you are using CMYK, the closest color match will be displayed in the color picker window. 

C
The color mixer allows you to mix four colors together to create a blend of colors that you can choose 
from.  

To use the Color Mixer: 

1. Click the first corner color square that you want to change. 

2. Click in the vertical HSV color bar to choose a color. 

olor Mixer 
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3. The saturation bar at the right of the v
w

ertical HSV color bar updates to reflect your color choice 
ith varying degrees of saturation. Click in the Saturation bar to increase or decrease saturation. 

4. Repeat steps 1 through 3 for each corner color that you want to change. 

5. Click inside the large blended color area to choose your final color. The currently selected color 
displays in the top color chip on the left. 
 

 

HLS Wheel 
The HLS Wheel allows yo
HLS values manually or choo

u to choose a color based on hue, light, and saturation values. You can enter 
se a color from the color matrix.  

nter the values manually in the H, L, 

r downward to make the color lighter or darker. 

• Drag the color indicator toward the left to desaturate the color, and toward the right to 
make the color more saturated. 
 

If you want to reproduce a specific color and know its HLS values, e
and S text boxes.  

To visually select a color with the HLS Wheel: 

1. Use the outer ring to select the hue. Drag the color marker around in the circle to select the hue 
value. 

2. Adjust light and saturation for the color inside the color triangle as follows:  

• Drag the color indicator upward o
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Lab Sliders 
The Lab Sliders color mixer allows you to create colors that approximate those seen in human vision. Th
L component is used to adjust lightness contrast, and the A and

e 
 B components are used to adjust the 

 color with the Lab sliders: 

nter the desired value in the text field at the right. 

 b slider or text field to select the balance of blue to yellow. 

balance of green/red and blue/yellow opponent colors. 

To visually select a

1. Set the Light value with the L slider, or e

2. Use the a slider or text field to select the balance of green to red. 

3. Use the
 

 

RGB Sliders 
The RGB Sliders color mixer allows you to create colo a d on the Red, Green, and Blue values. Each 
slider can be adjusted to a setting of 0-255. 

olor with the Lab sliders: 

1. Set the Red value with the R slider, or enter the desired value in the text field at the right. 

 desired value in the text field at the right. 

rs b se

To visually select a c

2. Set the Green value with the G slider, or enter the desired value in the text field at the right. 

3. Set the Blue value with the B slider, or enter the
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RGB Wheel 
The RGB Wheel allows you to select an RGB color within a wheel, and then modify the color based on 
HSV values. You can also adjust lightness or darkness with a Value bar at the right side of the color 
picker. 

To visually select a color with the RGB wheel: 

1. Position the color selector in the RGB wheel to select the color that most closely approximates 
the color you want to pick. 

2. Adjust Hue, Saturation, or Value (lightness/darkness) with the HSV number fields in the left side 
of the color picker. 

3. Use the vertical Value bar at the right side of the color picker to make the color lighter or darker. 
 

 

Web Colors 
The Web Colors color picker allows you to choose from colors that are most compatible with Web 
browsers. Only web-safe colors appear in this color picker. 

To select a web-safe color: 

1. Click inside the color selector area to find the color that is closest to the color you want to use. 

2. Other web-safe colors that are close to the selected color appear in a horizontal bar beneath the 
main color selector area. Choose another alternative that is more suitable, if desired. 

3. The color formula for the web-safe color appears in the text field in the left side of the color picker.  

4. Web-safe colors always consist of three rs of the numbers 00, 33, 66, 99, CC, or FF. You can 
enter numerical values other than these xt entry box, but the color will no longer be “web 

sest color match will be displayed in the color picker window. 

pai
in the te

safe.” The clo
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Choosing Components 
ponents that you can assign to a shader channel. The basic components at the top 
 are frequently used for a number of different types of shader channels. 

n to choose a component from the menu. 

There are several com
of the components list

To choose a component from the Shader Tree List: 

1. Select a channel (such as Color, Alpha, Bump, or other) in the Shader Tree List. 

2. Click the menu butto

3. Set the options for the selected component in the right portion of the shader tree editor. 
 

 
You can also use controls in the Shader Tree Editor to choose a component for the selected shader 
channel. There are three controls in the right portion of the Shader Tree Editor: 

• Selection Menu (1): Click the arrow to choose a shader component using a menu similar to that 
shown in the previous figure. 

• Wizard (2): Click the Wizard button to select a shader preset from the Scene Wizard. 

• Parent (3): Click the Parent button (available in a multi-channel shader) to move up one level in 
the Shader tree to view all shader channels contained in the parent shader. 

 © 2008 DAZ 3D, Inc. 587 



Carrara 7 11 December 2008 

 

 

Common Shader Components 

None 
Choose None when you do not need to assign a component to a shader channel. Existing channel 
information will be removed. 

Color 
The Color component allows you to choose any color from any of the color pickers, including a small 
color-picker that appears when you click the arrow at the right of the color chip.  

 
To use the Color component: 

1. Select the object for which you want to create a shader and switch to the Texture room. The 
Shader Tree Editor displays the current shader. 

2. Locate the channel that will use the Color component.  

• Though you can place the Color component anywhere on the Shader Tree, it is best 
suited for use in the Color, Highlight, Reflection, Transparency, and Glow channels 
(which are designed for Color input). 

• A Color component will not produce an effect in the Bump channel, because it gives a 
constant value across the entire surface. To create the illusion of bumpiness, the Bump 
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channel requires variation across the surfac
the Bump channel, refer to "

e of an object. For a thorough discussion of 
Bump." 

• In a non-color channel such as Shininess or Refraction, Carrara converts colors to values. 
Dark colors convert to low values, and light colors convert to high values. 

• For further discussion of how colors affect each channel, refer to "Shader Channels 
Reference." 

3. Click the component selector menu, and choose Color from the options that appear. 
 

 
4. Choose your color using one of the following methods:  

• Click the color chip in the right section of the Shader Tree editor, and select a color from 
the Color Picker that appears. 
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• Click the arrow to the right of the color chip to select a color from a mini-color picker. 
 

 

Color Gradient 
The color gradient shader is used to transform a black and white mapping into a color mapping. It uses 
two parameters: 

• The first parameter defines the colors in the gradient. 

• The second parameter defines the black and white shader that you want to transform to the color 
mapping. 

The Color Gradient can be animated. Modifying or adding a key at a time that is different from 0 will 
create a keyframe. 

 room. The 

2. r Gradient component.  

3. Click the component selector menu, and choose Color Gradient from the options that appear. 
Two parameters now appear in the tree: A  Color Gradient parameter, and a Shader parameter 
beneath it. 
 

To use a Color Gradient component: 

1. Select the object for which you want to create a shader and switch to the Texture
Shader Tree Editor displays the current shader. 

Locate the channel that will use the Colo
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4. Select the channel
pane of the Shader Tre

 that has the Color Gradient assigned to it. The parameters appear in the right 
e editor.  

ient. At a minimum, there is one color key 
 

g the color picker in the Gradient Picker. 

modify the position of a key
d 1) in the text field at the right side of the gradient editor. 

ey' 
, or click in the graduated scale area to add 

e 

5. Click the gradient to define the colors that you want to use in the gradient. Use the Gradient 
Picker as follows:  

• Two or more keys define the colors in the grad
at the beginning of a gradient, and another at the end.

• To change the color of a key, select the key to be modified. Then change the color 
usin

• To , either click and drag the key to a new position, or enter 
a value (between 0 an

• To add a new key to the gradient, click in the area of the color gradient to set the 
position of the new key. You can then add a key in one of three ways: Click the 'Add k
button, modify the color with the color picker
the key, then modify its color. 

• To delete a key, select the key to be deleted then click on the 'Del key' or use the Delet
or Backspace keys of the keyboard. 
 

 
6. After you define your gradient, choo r (the black and white image or procedure that 

 in 

se the Shade
you want to use in conjunction with the gradient). You can select the Shader component in one of 
two ways:  

• From the Shader component (shown directly beneath the Color Gradient component
the Shader tree). 
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• Click down arrows at the left of the Edit button in the Shader Tree editor. 
 

 
7. After you configure your Color Gradient and Shader, you can adjust the settings for both as 

needed to refine your shader. The following images show an example of the results when a Color 
Gradient is used in conjunction with a Psychedelic component for a shader. 
 

 

Flash Shader 
The Flash Shader component allows you to use a Flash animation (SWF extension) as a shader. 
Ho
anima

wever, in order for this shader to be visible in your final animation, you must export the finished 
tion to the Viewpoint Experience Technology (VET) format (Standard, Pro). 
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To assign a Flash Shader component to a shader: 

1. Select the shader channel that you want to configure. 

2. Choose Flash Shader from the component menu. The options appear in the 
Shade

right pane of the 
r Tree Editor. 

 

 
3. In the Flash Shader tab, choose the following options:  

• Flash File: Click the Load button to locate the Flash (SWF) file that you want to assign to 
the shader. 

 default, the Flash file repeats once across the entire width and height of the 
 which it is assigned. You can use the Horizontal Count and Vertical Count 

sliders to increase the number of times that the Flash file is repeated.  

rotate the 
SWF file. 

• Center: To change the center point for the SWF file, enter the new coordinate(s) in the X, 
Y, or Z fields. 

• Scaling: To change one or two dimensions of the SWF file, enter the new size in the X, Y, 
or Z fields. 

• Overall: To change the size in all three dimensions at once, enter a new value in the 
Overall field. 

• Rotation: To rotate the SWF file in one or more directions, enter the degrees of rotation 
in the X, Y, or Z fields. 

• Tile: By
object to

4. In the Transform tab, choose the following options:  

• Enable Transform: Check this option if you want to reposition, rescale, or 

 © 2008 DAZ 3D, Inc. 593 



Carrara 7 11 December 2008 

Index of Refraction 
Light changes speed and bends when it passes through a transparent medium like glass or water. A good 
example of this is when you place a straw in a glass of water. The straw appears to bend in a different 
direction above the water than it does inside the water. 

The amount of bend depends on the type of medium that the light passes through, and is referenced by a 
number called the Index of Refraction. Carrara provides a number of preset refraction index settings for 
many different types of transparent or semi-transparent objects including liquids, glasses, and gemstones. 
You can also manually add other values as needed to reproduce materials not available in the drop-down 
list. 

The image below shows perfume bottles before (left) and after (right) Index of Refraction is added to the 
bottles and liquid. Crystal is selected for the bottles and alcohol is selected for the perfume. 

 
To assign an Index of Refraction component to a shader: 

1. After you create your transparent or semi-transparent object, select the Refraction channel in the 
Shader Tree editor. 

2. Choose Index of Refraction from the component menu. The options appear in the right pane of 
the Shader Tree Editor. 
 

 
C3. g options in the Shader Tree Editor:  

cted object is made of.  

u can manually enter an Index of Refraction value for other 
of 

other materials. 

hoose one of the followin

• Material: Select a material from the list. Choose the one that most closely approximates 
the material that the sele

• If the desired material does not appear on the list, choose (Other). This enables the 
Other Value field so that yo
materials. Chemistry textbooks (as well as other resources) sometimes provide index 
refraction values for 
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Single Channel 
Use the Single Channel component when you want to assign a specific channel to a shader component. 
The menu allows you to assign a Color, Alpha, Highlight, Shininess, Bump, Reflection, Transparency, 
Refraction, or Glow channel. 

 
To

1. 

2. Cho  menu. The options appear in the right pane of the 
Shader Tree Editor. 

 assign a Single Channel component to a shader: 

Select the shader channel that you want to configure. 

ose Single Channel from the component
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3. Cho g options in the Shader Tree Editor:  

• Channel: From the popup menu, choose one of the channel options (Color, Alpha, 
Highlight, Shininess, Bump, Reflection, Transparency, Refraction, or Glow). 

• Shader: To set the shader, click the Edit button in the Shader Tree editor to select from 
the Shader popup menu. 

Texture Map 
The Texture Map component allows you to use a 2D image, such as a scanned photograph or paint-type 
illustration, in your shader. You can also use animated formats such as AVI and MOV as texture maps.  

Used effectively, texture maps can lend your shaders unparalleled realism. Many complex real-world 
surfaces are nearly impossible to simulate through other means. 

You can use a 2D editor to create a texture map. When you place a Texture Map component on the 
shader tree, you must click the folder icon. Then the standard Open dialog displays, prompting you to 
choose an image. 

ose the followin

 
A discussion of the Shader Tree Editor's display options and instructions for navigating the shader tree 
appears in "Building and Editing Shaders." 

To assign a Texture Map component to a shader: 

1. Select the shader channel that you want to configure. 

2. Choose Texture Map from the component menu. The options appear in the right pane of the 
Shader Tree Editor. 

3. Use the controls in the upper-left area of the Shader Editor to select and orient your image: 

• Load: Click this button to open a dialog that allows you to select a texture. 

e texture map in its original condition. 

 object. 

es the texture 90 degrees clockwise on the object. 

• Reload: Click this button to reload th

• Flip Vertical: Flips the texture vertically on the

• Flip Horizontal: Flips the texture horizontally on the object. 

• Rotate: Rotat
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• Rotate Direction: Indicates the current direction of rotation. 

re • Texture Preview: A thumbnail preview of the image appears on the left of the Textu
map controls with the image's dimensions in pixels displayed below it. 
 

 
4. The tiling controls allow you to specify how you want to tile the image on your object:  

• Tile: Check this option to tile your image. 

• Seamlessly: If you want Carrara to rotate and flip neighboring tiles to maximize 
continuity, click the Seamlessly check box. If your image is specifically designed for 
seamless tiling, you don't need to enable this option. 

• H: Adjust the slider to the number of times you want to tile the image horizontally. 

• V: Adjust the slider to the number of times you want to tile the image vertically. 
 

 
5. The Filtering menu determines how the texture is filtered during rendering:  

• Sampling: Sampling is the fastest and lowest quality. 

• Summed Area Table: Summed area table takes a lot of memory and is not 
recommended for big texture maps. 

• Gaussian Filtering: Gaussian provides the best quality. 
 

 
6. Additional options determine how certain colors are represented or rendered in the image:  

 type of 
ly white pixels in the image. For 

 an irregular shape on the surface 
nd place it in the Color 

er there is a white pixel 

• Interpolate: Select the Interpolate check box, to specify that the texture map be 
interpolated. 

• White is Invisible: The White is invisible check box allows you to achieve a
masking effect by instructing Carrara to ignore any pure
example, you could use this option to place a logo with
of an object. Simply create a map with a white background a
channel, then apply it to an object using the Polygon tool. Wherev
in the map, the layer or surface below shows through. 
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• Invert Color: Check this option to invert the colors in the image. (For example, in a 
grayscale image, black inverts to white, and white inverts to black). 

• Brightness: Drag the slider to the right to increase the brightness. 
 

 
7. By default, Carrara saves copies of all texture maps internally. You can also have Carrara save 

only a reference to an external file. Use the options in the Save area to determine how images 
are saved with the scene:  

• Internally: In general, you can store maps internally unless your file contains particularly 
large texture maps (or many smaller maps). Storing maps internally avoids organizational 
hassles, because you don't need to keep track of any external files. However, internally 
saved maps greatly increase the size of a file, which can result in slower loading and 
saving.  

 you don't 
ard drive, 

le the next time you open your scene file or a 

• Externally: With an external map, you can modify it with another program, and
need to reload the map. If you move an externally referenced image on your h
Carrara prompts you to locate the image fi
shader Browser document. 
 

 
8. The last options control how the alpha channel is used in your texture map:  

• Premultiplied Alpha: TBD 

• Color and 

nly color info

 Alpha: Choose this option to use both the color and alpha channels in your 
shader. 

• Color Only: Choose this option to use o rmation when an image also 

n from your selected 

contains an alpha channel. 

• Alpha Only: Choose this option to use only the alpha informatio
image. 
 

 

Using Color Images as Texture Maps 

Texture maps using color images are extrem   in the Color channel. You might import an actual 

icate 
it a specifie

ely useful
product logo as a texture map and apply it like a decal to a 3D package model. Or to mimic an extremely 
detailed natural surface, you could import a small photographic sample of the surface and tile it:dupl

d number of times:to cover your entire object. 
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mColor texture 

If you u

You can u
CM
importing it. 

Black & White and Gray

You can use a black and white or grayscale texture map in any channel (besides Color) to specify varying 
es the level of the 

attribute for the co ct or Layer. 

If you use a black and rns the attribute on (sets it to 100%); each white 
pix  
each p a grayscale blend from white to black in the Transparency channel would make 
an obje

You can al cale texture map with the Mixer operator, in place of a 
func

aps are also appropriate in the Highlight, Reflection, Transparency and Glow channels. 

se a color image in a non-color channel, Carrara internally converts it to grayscale. 

se an image of any color depth as a texture map. Note, however, that Carrara cannot use 
YK images as texture maps. If you want to use a CMYK image, you must convert it to RGB before 

scale Images as Texture Maps 

levels of a particular shading attribute. The shade of each pixel in the image determin
rresponding point on the obje

white image, each black pixel tu
el turns the attribute off. An 8-bit grayscale image allows subtler effects, with 256 possible shades for

ixel. For example, 
ct or layer fade smoothly from opaque to transparent. 

so use a black and white or grays
tion. For more information, refer to "Layer Components." 
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Value 
There are two Value components. One allows you to set a value between 0 and 100%, and the other 
allows you to set the value from 1 to 10000%. You'll use the Value component frequently in every channel 
but the Color channel. The control appears as a slider in the right portion of the Shader Tree Editor. 

To assign a Value component to a shader: 

1. Select the shader channel that you want to configure. 

2. Choose Value (0-100%) or Value (1-10000%) from the component menu. A slider appears in the 
right pane of the Shader Tree Editor. 
 

 
3. Drag the Value slider or enter a value. The number to the right of the slider displays the curre

value.  
nt 

• When used by itself, a Value component specifies a constant level for a particular 
0% value in the 
transparent. 

pacity Mask of a layer in a Layers List 

b-

Add (+) 
The Add operator sums the values of two components. When you place the Add operator on the shader 
tree, it appears as a node with two branches extending below. 

attribute across the surface of an object or Layer. For example, a 3
Transparency channel means the shader will make an object 30% 

• When used beneath a Color channel, Carrara converts its value to a shade of gray. 0 
converts to black, 100 to white. 

• You can use a Value component to set the O
shader. 

Operators 
Operators allow you to create complex shading effects by combining two or more components or su
shaders within a single shading channel. 

 © 2008 DAZ 3D, Inc. 600 



Carrara 7 11 December 2008 

 
The two branches are placeholders for the components you want to combi . o ch point on a layer or 

C
The Cu

ne  F r ea
object, the Add operator sums the values of the two components. 

urve Filter 
rve Filter shader modifies the levels of a black and white image. 
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Two parameters can be set: 

• the first parameter is the shader to which the filter will be applied. It can be selected by the 
Shader popup menu. 

• the second parameter defines the curve. The default curve doesn't modify the image. To edit the 
curve, click on the curve button to open the curve editor. 
 

 
Four tools are available to edit the curve: 

• Move tool: Modifies the point's location by clicking and dragging it. 

• Add Point tool: Adds a new point to the curve when it is clicked on. 

• Delete Point tool: Removes a point from the curve. 

• Convert Tangent tool: Links or unlinks two tangents of a point (when the curve is a smooth 
curve) 

The curve can be smoothed by checking the Smooth option (note that a smooth curve will be slower to 
render than a linear one). 

Mixer 
The Mixer operator is one of Carrara's most versatile shading tools. It can produce a wide variety of 
results, depending on which function you choose to mix the two source components. 

When you place a Mixer operator on the shader tree, it appears as a node with three branches below it. 
The Source 1 and Source 2 branches are placeholders for the two components you want to mix. The 
mixing function resides on the Blender branch. 
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For each point on an object, the Blender function generates a value between 0 and 100. The Mixer 
operator uses this value to combine the component's sources. When the value is closer to 0, more of the 
Source 1 component is used. When the value is closer to 100, more of the Source 2 component is used. 
You can also use a shader in the Blender branch. 

Some functions, like Checkers and Wires, generate a value of 0 or 100 for each point. These functions 
result in clear divisions between the two components. Other functions, like Wood and Spots, generate a 
range of values between 0 and 100. These functions result in gradual blends between the components. 

TIP! The mixer function is very useful when you want to create a shade
black and white shader. For instance, if you want a red and green checkerbo

r with two colors from a 
ard, you would create a 

n as the blender. 

rator multiplies the values of the source components. 

mixer with the two colors (red and green) and select the checker board functio

Multiply (*) 
The Multiply ope
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You can use the Multiply Operator to tint a grayscale bitmap by multiplying the bitmap shader by a color 
shader. 

Overlay 
The Overlay operator multiplies the values of its two sources but keeps the general look of the first one 
predominant. 

This operator is not a symmetrical operator, so the order of the two sources is important. A 'Swap 
Shaders' checkbox is available to invert their order easily. 

This operator can be used to bring noise to another shader. 

 

Subtract (-) 
The Subtract operator subtracts the value of the Source 2 component f
component. 

rom the value of the Source 1 
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You can use the Subtract operator to invert the value of another component. Just place the component 
you want to invert in the Source 2 branch and a Value component set to 100 in the Source 1 branch. Try 
this technique on a complex shader if you want to invert its colors. 

Functions 
In general, you'll use Functions almost exclusively with the Mixer operator. You can, however, use them 
by themselves. A function generates a value between 0 and 100 for each point on an object or layer. 

When you place a function on the Mixer operator, the operator uses the values generated by the function 
to mix the components on the Source 1 and Source 2 branches. Where the value equals 0, Carrara uses 
the Source 1 component; where the value equals 100, Carrara uses the Source 2 component. 
Intermediate values produce a blending of the two components. 

When you place a function in a channel by itself, it assigns a value directly to each point on the object or 
Layer. In a non-color channel, Carrara uses each value "as is." In any of the channels designed for color 
input (Color, Highlight, Reflection, Transparency or Glow), Carrara converts each value to a shade of gray, 
with 0 translating to white and 100 to black. 
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Pattern Functions 

Bricks 

The Bricks function produces a pattern like a wall of bricks. It assigns a value of 100 to the bricks and a 
value of 0 to the mortar. Bricks is a 2D function. 

 
To create bricks: 

1. Use the Horizontal and Vertical control the number of bricks. 

2. Grout controls the percentage of each row that is grout. 

3. No Grout on Border leaves the grout off of the edges. 

4. Curved Surfaces smoothes the transition between brick and mortar. 

5. Orientation changes the direction of the brick pattern. 

Caution 

The Caution function produces a pattern of diagonal stripes. It alternates a value of 100 and a value of 0 
to the bands. Caution is a 2D function. 
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To create a caution band: 

1. Bands control the number of stripes. 

ttern controls the pattern of the stripes. 

3. Orientation changes the direction of the pattern. 

The Checkers function produces a checkerboard or striped pattern. Every point is assigned a value of 
exactly 0 or 100, so no blending occurs. Checkers is a 2D function. 

2. Pa

Checkers (and Stripes) 

  
To set Checkers options: 

1. Drag the Squares H slider to set the number of horizontal squares. 

2. ares V slider to set the number of vertical squares. Drag the Squ
 

 
By setting one of the sliders to 0, you get stripes:either horizontal or vertical, depending on which slider is
at 0. 

 

You can use Checkers to create tile effects, checkerboards, striped objects such as wall papers, beach 
balls, or umbrellas. 

To create stripes: 

• Drag one of the sliders to 0. 
 
The stripes will be either horizontal or vertical, depending on which slider is set to 0. 

Formula 

The Formula function lets you design a mixing function with a mathematical formula. 

For more information, refer to "Using Formulas in Carrara." 
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Gradient 

The Gradient function produces a gradual blend from one color to another. Gradient is useful in the Color 
and Transparency channels. Gradient is a 2D function. 

 
To set Gradient options: 

1. Choose Direction > Horizontal or Vertical to set the direction of the blend. 

o mix up the colors as they change. 

nd. 

2. Adjust the Turbulence slider t
 
A low setting results in a uniform blend. A high setting increases irregularity in the ble
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Julia Set 

The Julia Set pattern 

 

Mandelbrot Set 

The Mandelbrot set pattern. 

 

Plank Shader 

This shader was designed primarily as a supplement to the wood shader. It has many of the same 
parameters. Here is the suggested procedure for using this extension: 
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To use the plank shader: 

1. Use Lumber Yard first to get your wood looking just how want it to. 

 from the color channel to the highlight channel. Change the color channel to a 

cond slot of your new mixer. 

4. Press Control and drag the lumber yard shader from its spot in the old mixer to the mix spot in the 
new mixer. 

5. Change the lumber yard in the new mixer to 'planks'. 

6. This will set all the parameters in the plank shader identical to your wood. 

7. Copy into the bump channel, if desired. 

Options 

• Direction: Z, the default, provides a view as if one cut a tree down and attempted to count the 
rings. X and Y provide a view as if one cut a tree into planks along each respective axis. 

• Mapping: Choose between three - 3D Local, 3D Global, 2D UV. 3D local is the default value. The 
difference between global and local is fairly simple; each object has its own local coordinate 
system, choosing that option will cause the shader to look identical even when animated. If global 
mode is selected, the appearance will differ based on the object's global location. UV mapping 
uses UV coordinates, this can often result in distortion; nevertheless, it is still useful, especially 
when used on an object you plan to morph. 

lue "seeds" the random number generator. 

• Scaling: Scales the shader. 

 

2. Move your mixer
new mixer. 

3. Move wood to the se

• Seed: This va

• Order and Persistence: Please refer to the introduction to noise introduction in the section
covering Noise Factory. See "Noise." 

• Perturbation: This parameter sets the amplitude of the turbulence. Higher values lead to a more 
knotty looking surface. 

• Grain Edge: The default value for this parameter, 1, leaves a definite edge between each band of 
wood. Decreasing this value makes for successively more even blending of bands. 
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• Threshold Controls: These controls behave identically to the threshold controls in Noise Factory. 
See "Noise Factory." 

• Plank Controls: Controls the density of planks (if desired). The default values of zero provide no 
paneling. Increasing the density increases the number of bands in each plank. To increase the 
amount of planks visible, scale the texture accordingly. 

• Z Offset: This parameter creates random variation in the Z length of any given plank. The higher 
the value, the greater the average offset. 

• Value Variation: This parameter controls the maximum amount by which the intensity varies from 
plank to plank. 

Psychedelic 

The Psychedelic shader function creates unusual textures, including swirls of color reminiscent of the 
psychedelic Pop Art of the 1960s. When animated, the Psychedelic function can create hypnotic or trippy 
effects. Psychedelic is a 3D function. 

 
This shader should be used with a mixer if you want to give color to your shader (see "Add (+)"). 
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To set Psychedelic options: 

1. Adjust the three Interference sliders to control the amount of interference applied to each plane. 
The sliders range from -1.00 to 1.00. Each slider controls the stripes applied on the specific plan
A setting of 0 results in no interference on that plane. Us

e. 
ing all three planes, you can create more 

 box to use the Global Coordinates for the Psychedelic 

ult, the psychedelic function uses the individual Object's coordinate system. The 
shading is constant as you move and rotate the object. 

en Use Global Coordinates is enabled, the shading remains static in global space 
when the object moves. The object behaves as a "window" on the shading. This is like 

rol the size of the design elements. 

4. Adjust the Number of Stripes slider to control the number of stripes in each element. 

5. Adjust the Density slider to control the density of the pattern. 

6. Adjust the Phase slider to set the current position in the psychedelic cycle.  

• The Phase slider ranges from 0.00 to 1.00. The two extreme settings display the cycle at 
the same point. 

• Use the flat preview to see how the shader changes when you adjust the Phase. 
 

interesting design elements. 

2. Enable the Use Global Coordinates check
function.  

• By defa

• Wh

moving your hand through the dappled shadows under a tree. Instead of shadows, 
though, the psychedelic shading passes across the moving object. 

3. Drag the Scaling slider to cont

NOTE! Phase settings are particularly useful in animations. Set key events to 
animate the Phase from 0 to one using the Oscillate: Saw/Loop tweener. 

The Scanlines function produces scan lines. 

Scanlines 
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To use scanlines: 

 the number of lines. 

 sure to check the 'Global' option. In addition to setting the global option, be sure to set 
the displ

1. Scan Lines controls

2. Orientation controls the direction of the lines. 

Spherical Gradient 

This shader is most useful when designing explosions using particles. When applying this shader to a 
particle system, be

acement values identical to the center of your particle system. 

 
Options 

his value "seeds" the random number generator. 

: Experiments with different combinations of x, y, and z scales to observe the various 

• Displacement: These values set the center of the sphere. 

• Order and Persistence: Please refer to the introduction to noise present in the section covering 
Noise Factory. See "Noise Factory

• Seed : T

• Scaling
effects. 

." 

• Global: When this box is checked, the shader will use global coordinates, meaning the 
appearance is dependent on the location of object. 

• Turbulence: This box enables turbulence. 

• Level: This parameter sets the amplitude of the turbulence. 

Squares 

The Squares function produces a pattern of random grayscale squares. Squares is a 2D function. 
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To use squares: 

• Horizontal and Vertical control the number of squares. 

rightness controls how light or dark the squares are. 

e is greater or 

t like bricks. 

settings make great spaceship hulls. Put a squares in the 

in the Glow channel to make lit portholes or 

Tile 

The Tile function produces a pattern like a floor of tiles. It assigns a value of 100 to the tile and a value of 

• B

• Threshold makes the square black or white depending on if the grayscale valu
lower than the threshold value. 

• The Seed value provides the starting point for the grayscale values. 

• Bricks Mode changes the pattern of the squares to be offse

Tips and Tricks 

• Random mixtures of different square 
Mix operator with Threshold on and in the right and left channels put Squares with different 
Horizontal and Vertical settings. 

• Use the Multiply function with the Tile shader 
windows at night. 

0 to the grout. Tile is a 2D function. 
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To use Tile: 

• Horizontal and Vertical control the number of tiles. 

• Mortar controls the percentage of each row that is grout. 

• Radius controls amount of curve on the corners and edges of tiles. 

• No Mortar on Border leaves the grout off of the edges. 

 smoothes the transiti le and grout. 

size horizontally and vertically. 

machines. 

ore believable tiles. 

r Layer. Specifically, it assigns a value of 100 to the lines of 

• Curved Surfaces on between ti

• Try Equalize Ratios if your grout lines don't render the same 

• Negative inverts the output. 

• Orientation changes the direction of the tile pattern. 

Tips and Tricks 

• Use Tile with a large Grout setting in the transparency channel to add air vents to 

• No tile is perfect, so combine with Noise in the Bump channel to create m

Wires 

The Wires function produces a grid of lines. As with the Checkers function, Wires assigns a value of 
either 0 or 100 to each point on an object o
the grid and a value of 0 to the spaces. Wires is a 2D function. 
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To set Wires options: 

 the Horizontal count slider to set the number of lateral wires. 

ckness of the horizontal/vertical 
he entire object or Layer. You can 
rcentage by the number of wires. For 

e thickness of each wire is 

s. 

t to smooth the transitions between the spaces and the 

s between wires and spaces. 

his option is especially useful in the Bump channel, where gradual transitions produce 
 or 

l Functions 

The Cellular function creates a surface that looks like a network of cells. Cellular is a 2D function. You 
can use it effectively in the Color and Bump channels. You can experiment with it in the other channels 
for other effects. Use Cellular to create organic surfaces such as alien skins, leather, or exotic plant 
textures. 

1. Drag

2. Drag the Height slider to set the size of the lateral wires. The thi
wires is expressed as a percentage of the height/width of t
determine the thickness of a single wire by dividing the pe
example, if ten horizontal wires represent 50% of a Layer's height, th
5% of the height. 

3. Drag the Vertical count slider to set the number of longitudinal wire

4. Drag the Width slider to set the size of the longitudinal wires. 

5. Enable the Gray Scale option if you wan
wires. 

• The grayscale option smoothes the transition

• T
striking results. You can create textures for objects to create, for example, a pumpkin
corrugated sheet metal. You can also use it along with the Checkers function to create 
grouted tile. 

Natura

Cellular 
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To set Cellular options: 

1. Use the Shape menu to select the basic shape of the cells. 

2. Drag the Intensity slider to adjust the contrast between the two colors. The slider ranges from 0%
to 200%. Negative settings invert the image. 

3. Drag the Scale slid

 

er to change the size of the cell shape. The slider ranges from 1% to 200%. 

 range of values created by 
wo (light and dark) components. 

s the upper limit. 

raw and to 

Fire 

The Fire shader simulates a flame. You can adjust the effect from a steady candle flame to a turbulent 
 this shader. 

4. Drag the markers on the Upper and Lower Limits slider to controls the
the function. The range determines the balance between the t
The left marker controls the lower limit. The right marker control

5. Enable the Fractal Version to use fractals instead of more regular shapes for the cells. 

• Using the Fractal Version can significantly increase the time required to red
render your image. 

wood fire. You can also animate
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TIP! To create a good fire shader, you should put the same fire component in the color and glow 

ps. Typically, 
If you use 

nel. 

5. Use the Transparency button when this shader is placed in the Transparency channel. 

Lumber Yard 

 realistic 3D procedural wood. It has a clear advantage 
over texture maps. 3D objects will appear to actually be cut out of a block of wood. 

channels. 

To set Fire options: 

1. Set the Color parameter to control the color of the fire. Typically, you'll choose an orange color. 

2. Set the Turbulence parameter to change the turbulence of the fire. At 0%, it looks like a candle. 
At higher values, it flickers like a flame in the wind. 

3. Set the Completion slider to define when the flame starts to move and when it sto
set this value to 0% for the first frame of your animation and to 100% for the last frame. 
the Fire shader in multiple channels, the Completion value should be the same in every chan

4. Use the Shuffle button to randomize the turbulence. 

Lumber Yard can be used to create amazingly
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To set Lum

ection: Z, the default, provides a view as if one cut a tree down and attempted to count the 
s if one cut a tree into planks along each respective axis. 

e 

l 
n the object's global location. UV mapping 

e 2D version of this extension. Experiment 

• Order and Persistence: Please refer to the introduction to noise in "Noise

ber Yard options: 

• Dir
rings. X and Y provide a view a

• Mapping: Choose between three - 3D Local, 3D Global, 2D UV. 3D local is the default value. Th
difference between global and local is fairly simple; each object has its own local coordinate 
system, choosing that option will cause the shader to look identical even when animated. If globa
mode is selected, the appearance will differ based o
uses UV coordinates, this can often result in distortion; nevertheless, it is still useful, especially 
when used on an object you plan to morph. 

• Seed: This value "seeds" the random number generator. 

• Scaling: All four scaling values are useful, even in th
with different combinations of x, y, and z scales to observe the various effects. 

." 

: This parameter sets the amplitude of the turbulence. Higher values lead to a more 
knotty looking surface. 

 of 

• Threshold Controls: These controls behave identically to the threshold controls in Noise Factory. 
See "Noise Factory

• Perturbation

• Grain Edge: The default value for this parameter, 1, creates sharp edges between each band
wood. Decreasing this value smooth the transition between the bands. 

." 

• Plank Controls: Controls the density of planks (if desired). The default values of zero provide no 
paneling. Increasing the density increases the number of bands in each plank. To increase the 
amount of planks visible, scale the texture accordingly. 

• Z Offset: This parameter creates random variation in the Z length of any given plank. The higher 
the value, the greater the average offset. 

• Value Variation: This parameter controls the maximum amount by which the intensity varies from 
plank to plank. 
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Marble 

The Marble function produces a marble pattern. It assigns a value of 100 to the veins and a value of 0 to 
the spaces between the veins. Like Spots and Wood, Marble is a 3D function. 

 
To create realistic looking marble, use the Marble function in a layered shader to create layers of mar
depths throughout your object. 

To set Marble options: 

1. Adjust the Global Scale slider to set the size 

bled 

of the marble pattern in relation to the object. 

es produce dense vein patterns; low 

rn. 

t. 

s appearance is only skin-deep:all the objects you create in Carrara, these 

The snow component allows you to apply snow to positive shapes, negative shapes, or both types of 
shapes. For best results, you should use Snow with the mixer or multiply operators. 

2. Adjust the Vein count slider to set vein spacing. High valu
values produce sparse vein patterns. 

3. Adjust the Perturbation slider to control the size of the "waves" in the veins. 

4. Adjust the Undulation slider to control the frequency of the waves in the patte

5. Adjust the Vein Blending slider to determine whether the transitions between veins and spaces 
are abrupt or gradual. 

6. Use the Direction pop-up menu to set the orientation of the marble pattern in relation to the objec

7. Click the Shuffle button to randomize the marble pattern. 

Objects shaded with 3D functions like Spots, Wood, and Marble appear to be carved or sculpted from 
solid blocks of material, but thi
objects are still "hollow." To illustrate this point, if you make a marble object partially transparent, you 
won't see veins running through the inside of the object. 

Snow 

The Snow shader simulates snow. When you apply snow to an object, it creates an effect according the 
surfaces of your object. 
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To set Snow options: 

• Click the checkboxes to apply snow to positive, negative, or both types of shapes. 

Spots 

The Spots function produces a random pattern of spots. The spots are irregular, more li  leopard spots ke
than polka dots. You can use spots to create skin and building textures. Spots is a 3D function. 

 
To set Spots options: 

just the Size slider to control the size of the spots. 

2. Adjust the Blending slider to control how the spots blend together.  

-
ots, with gradual blending. 

 

3. Click the Shuffle button to randomize the spot pattern. 

1. Ad

o When Blending is set to 0%, the function produces equal numbers of zero-value and 100
value sp

o When Blending is set to 50%, the function produces equal numbers of zero-value and
100-value spots, with abrupt transitions. 
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Water: Ripples 

The Ripples component simulates ripples in water. By adjusting the parameters of concentric waves, you 
can simulate disturbances on the surface of a calm pool of water. You can animate this shader. It looks 
best when placed in the Bump channel. 

 
To set Ripple options: 

1. Use the Time parameter to set the appearance over time when creating an animation. Set the 
value to 0% in the first frame and to 100% in the last frame. 

2. Set the Scale parameter to control the spacing of the ripples. Low values create small, closely 
spaced ripples; high values create fewer, widely spaced ripples. 

3. Set the Amplitude parameter to control the height of the ripples. When applied to the Bump 
channel, higher values will create a greater degree of depth. 

4. Set the Damping parameter to create a fading effect in the ripple. Higher values cause the ripples 
to appear to fade as they move away from the center. 

5. Set the Center H and Center V sliders to control the horizontal and vertical position of the center 
of the ripples. 

6. Use the Perturbation slider to control the amount of distortion in the ripple. This parameter is 
dependent on the size of the object to which the shader is applied. To obtain good results on 
small objects, use very small values (2% to 9%). 

To create a body of water: 

1. In the Assemble room, add a Plane object. 

e as desired. 

ree and apply it to the object. 

6. l and set parameters as desired. 

To
and Center V

2. Scale the plan

3. Create a Multi-Channel shader in the Shader Editor T

4. Set the color to blue. 

5. Set the transparency to 30%. 

Apply the Ripple shader to the Bump channe

 create a shader with more than one ripple effect, use the Plus operator (+) and set different Center H 
 values for each ripple. 

 © 2008 DAZ 3D, Inc. 622 



Carrara 7 11 December 2008 

Water: Waves 

The Wave shader simulates water environments such as oceans and lakes. By adjusting the parameters, 
you can simulate a wide range of wave effects ranging from a calm sea to a turbulent ocean. You can 
also animate this shader. It works best when you apply it to the Bump channel. 

 
To set Wave options: 

1. Use the Time parameter to set the appearance over time when creating an animation. Set the 
value to 0% in the first frame and to 100% in the last frame. 

2. Set the Scale parameter to control the spacing of the waves. Low values create small, closely 
spaced waves; high values create fewer, widely spaced waves. 

3. Set Compute interferences to control the interactions between waves. When enabled, waves can 
eliminate each other. When disabled waves can be added on top of each other. 

e more depth and color gradations. 

 most effective when you apply it to the Bump 

ividual waves. 

tortion of the wave. Higher values create more agitated waves. 

. Use lower 
 smaller objects. 

r in the Shader Editor Tree and apply it to the object.  

4. Set the Perturb value to add extra depth to the waves. When disabled, waves appear flatter, with 
less variation. When enabled, the waves appear to hav

5. Click the Add checkboxes to add additional waves to your shader. 

For individual waves, you can set the following options: 

• Angle controls the orientation of the wave. 

• Amplitude controls the height of the wave. This is
channel. 

• Scale controls the frequency of ripples in ind

• Perturbation controls the dis

Scale and Perturbation are dependent on the size of the surface on which they are applied
values when you apply them to

To create a body of water: 

1. In the Assemble room, add a Plane object. 

2. Scale the plane as desired. 

3. Create a Multi-Channel shade
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• Set the color to blue. 

• Set the transparency to 30%. 

d white in the Color 
channel. You can also create Sand by mixing brown and yellow, setting a high perturbation value, and 
turning on Perturb values. 

Wood 

The Wood function produces a wood grain pattern. It assigns a value of 100 to the veins and a value of 0 
to the spaces between the veins. Wood is a 3D function. 

• Apply the Waves shader to the Bump channel and set parameters as desired. 

You can also use the Waves shader to create a denim texture by mixing blue an

 
To create different wood textures, use the Wood function as a sub-shader in a Layers List shader to 

rn in relation to the object. 

High values produce dense vein patterns; low 

 Undulation slider to control the frequency of the waves in the grain. 

sitions between veins and spaces 

-up menu to set whether the wood grain pattern is taken from the center of the 
re of the veins is quite pronounced or from a point farther from the center, 

are three settings to choose from. 

ndomize the wood grain pattern. 

create more realistic types of wood. 

To set Wood options: 

1. Adjust the Global Scale slider to set the size of the wood grain patte

2. Adjust the Vein count slider to set vein spacing. 
values produce sparse vein patterns. 

3. Adjust the Perturbation slider to control the size of the "waves" in the veins. 

4. Adjust the

5. Adjust the Vein Blending slider to determine whether the tran
are abrupt or gradual. 

6. Use the Direction pop-up menu to set the orientation of the wood grain pattern in relation to the 
object. 

7. Use the Center pop
tree, where the curvatu
where the curvature is more gradual. There 

8. Click the Shuffle button to ra
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Environment Functions 

En

be 

3 tabs of settings are available to modify this shader. 

Altitude 

vironment 

The environment shader can be used to shade landscapes. The black and white image generated can 
modified with the altitude, the slope and the orientation of a geometry. 

 
• Influence: the influence of the altitude can be set between 0 and 100%. An influence of 0% 

means that the altitude parameter won't modify the shader at all. 

• Altitude Min: the altitude from which the grayscale will start. If under this altitude setting, the 
shader will be all white. 

• Altitude Max: the altitude to which the grayscale will go. If over this altitude setting, the shader 
will be all black. 

• The Invert check box inverts the grayscale values. 

Slope 

 
• Influence: the influence of the slope can be set between 0 and 100%. An influence of 0% mean

that the slope paramete
s 

r won't modify the shader at all. 

• Slope: set the slope value in degrees here. 

• Blend: blends around the Slope value. 

• The Invert check box inverts the grayscale values. 
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Orientation 

 
• Influence: the influence of the Orientation can be set between 0 and 100%. An influence of 0% 

means that the Orientation parameter won't modify the shader at all. 

• Blend: blends around the Orientation value. 

• Pitch: angle of the orientation axis with the z axis. Modifies the up/down position of the 
orientation axis. 

• Direction: the direction in the ground plane. 

ns a value of 0 to 

Slope 

The Slope function creates a pattern based on the slope of the surface. It assig
everything below the slope and a value of 100 to everything above. Slope is a 3D function. 

 
Use the Slope function to create interesting effects. 

To use slope: 

1. The Seed value provides the starting point for the Wiggle function. 
2. The Global Scale slider stretches the Wiggle function. 
3. Slope sets the dividing line between light and dark. 
4. Blend adjusts the distance over which the Slope change occurs. 
5. Wiggle changes the amount of variation in the dividing line. 
6. Space selects from between Global and the object's Local coordinates. 

eight. It assigns a value of 0 to everything below the 
levation is a 3D function. 

1. The Seed value provides the starting point for the Wiggle function. 

2. The Scale slider stretches the Wiggle function. 

3. Height sets the dividing line between light and dark. 

Elevation 

The Elevation function creates a pattern based on h
height and a value of 100 to everything above. E

To create an elevation: 
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4. Blend adjusts the distance over which the Height change occurs. 

5. Wiggle changes the amount of variation in the dividing line. 

6. Orientation changes the axis that drives Height. 

7. Space selects from between Global and the object's Local coordinates. 

Tips and Tricks 

• Elevation isn't just for outdoor scenes. Use it for oozing barrels, flames, a sharpened pencil, or 
anything else where the color changes based on distance along an axis. 

• A good rule of thumb for the Space option is, if it moves set it on Local, if not set it on Global. 

dom noise pattern between black and white. The fractal nature of this shader 

Noise Functions 

Fractal Noise 

Fractal noise makes a ran
gives more detail and subtlety to the pattern. 

 
Five noise presets are available. They can be selected by clicking on the corresponding images. 

ess: specifies the average value of the noise from a black value (-1) to a white value (1). 

st: sets the scale of the oscillations of the noise around the average value. 

k box inverts the grayscale values. 

 set of values. 

The following parameters can then be adjusted: 

• Scale: modifies the global scale of the texture. 

• Brightn

• Contra

• The Pattern and Density parameters modify the way the fractal computation is done and are 
only available if the Fractal option is checked. 

• The Invert chec

• Reset restores the default values. 

• Shuffle makes the random generator build a new

• Noise can be set in a local space or a global space. 
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Noise 

The Noise function produces a noise pattern. 

 
To use noise: 

1. The Seed value provides the starting point for the Turbulence function. 

2. Brightness controls how light or dark pattern is. 

3. Global Scale makes the pattern larger or smaller. 

4. Scale X makes the pattern larger or smaller along the X axis. Scale Y makes the pattern larger or 
smaller along the Y axis. Scale Z makes the pattern larger or smaller along the Z axis. 

5. Space selects from between Global, Local, and UV coordinates. 

6. Threshold makes the pattern black or white depending on if the grayscale value is greater or 
lower than the threshold value. 

7. Limits constrain the high and low values. 

Noise Factory 

ords are interchangeable. 
Noise is simply a field of random numbers. A type of noise that is more interesting is referred to as Perlin 
noise, or turbulence. Generally speaking, these w
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Perlin noise is a technique used to impose self-similarity on noise. Perlin noise algorithms are used to 
generate, among other things, clouds, marble, wood, and jitter effects. A universal parameter of Perlin 
noise is the octave parameter. Each successive octave of noise has a frequency twice that of the 

e. Therefore, each time you increase the octave parameter, the Perlin Noise becomes 
stead of an octave 
" Perlin noise. In this 

crease imposes more order on the 
ber Yard uses order. Another parameter that 
efines the rate at which the amplitude 

ree - Basic Noise, "Linoleum" Pattern, and Perlin Noise. 
derstand what it does. 

n three - 3D Local, 3D Global, 2D UV. 3D local is the default value. The 
n global and local is fairly simple; each object has its own local coordinate 

system, choosing that option will cause the shader to look identical even when animated. If global 

 it is still useful, especially 

• Smoothing: When checked the shader averages the value of each pixel with its neighbors. 

• Seed: This value "seeds" the random number generator. It is important to note that if Noise 
Factory is used twice, and all the values remain the same, both instances will be identical. 

• Scaling: These parameters control scaling. 

• Intensity: Controls the brightness of the noise. 

• Phase: Can be used to animate the texture. This really only works in 2D mode, in 3D mode it will 
appear as if the texture is simply raising vertically. This can be useful for glowing effects, and so 
on. 

previous octav
more detailed and intricate. Some shader extensions have an order parameter in
parameter. When order is a parameter, the extension is using so-called "reverse
case, a low order gives a very noisy result, and each successive in
noise. Noise Factory uses the traditional Octaves, and Lum
is common to Perlin noise, is persistence. This parameter d
decreases for each successive level of noise/order. Higher values of persistence lead to greater levels of 
noise for both regular and reverse Perlin noise. 

Options 

• Noise Type: Choose between th
Experiment with the linoleum pattern to un

• Mapping: Choose betwee
difference betwee

mode is selected, the appearance will differ based on the object's global location. UV mapping 
uses UV coordinates, this can often result in distortion; nevertheless,
when used on an object you plan to morph. 
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• Limits: Upper and lower limits. Any values that fall below the lower limit will be set to that number, 
any reaching above the upper limit will be set to that limit. 

• Perlin Noise Parameters: Read the introduction to Perlin noise to learn more about its 
parameters. 

• Threshold controls: Very similar to limits. The threshold is a middle value, that when enabled, 
any numbers falling below it will be set to 0, any above it to 1. The blending value blends values 
close to the threshold. 

• Interpolation Settings: Three options - none, linear, and cubic. When None is used, any values 
that occupy more than one pixel are not interpolated, giving them a harsh, pixelated look. This 
can be desirable in certain situations. Linear and cubic are fairly similar, one uses a simple linear 
function to perform interpolation, and the other uses a cubic function. Cubic, generally speaking, 
is more CPU intensive and looks better, though at a distance, it is nearly impossible to distinguish 
linear from cubic. 

Turbulence 

 
To use turbulence: 

• The Seed value provides the starting point for the Turbulence function. 

• Octaves controls the number of layers in Turbulence, each layer is finer than the last. 

• Brightness controls how light or dark pattern is. 

• Global Scale makes the pattern larger or smaller. 

• Scale X makes the pattern larger or smaller along the X axis. 

• Scale Y makes the pattern larger or smaller along the Y axis. 

e Z axis. 

r than the threshold value. 

• Limits constrain the high and low values. 

• Scale Z makes the pattern larger or smaller along th

• Space selects from between Global, Local, and UV coordinates. 

• Threshold makes the pattern black or white depending on if the grayscale value is greater or 
lowe
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Hair (Standard, Pro) 
For information on hair shaders, see "Dynamic Hair and Fur." 

Layer Components 
You can create layer components with the Layers tools or you can add them in the Shader Tree Editor, 
then size and position them numerically. Each layer is displayed in a Layers List shader and can have a 
sub-shader applied to it, as well as an optional opacity mask sub-shader. 

 
• Oval: The Oval layer creates a round or oval layer. 

• Rectangle: The Rectangle layer creates a rectangular or square layer. 

• Polygon: The Polygon layer creates a layer with multiple sides. 

• CoverAll: The CoverAll layer creates a layer that covers the entire UV space of the object. 

You can adjust the layer order, layer position, and opacity of a layer in a Layers List shader. 

To change the layer order: 

1. Click a layer to select it. 

r to a new location within the list. The Shader Tree Editor changes to indicate where 
ce the layer. 

eview updates to show 

umeric values for the new location 
nge. 

view updates to show your 

2. Drag the laye
you can pla

3. Release the mouse button to drop the layer into the new location. The pr
your change. 

To adjust the position of a layer: 

1. Click a layer to select it. 

2. Drag it into a new location in the Preview window, or type the n
in the Shader Tree Editor. The preview updates to show your cha

To adjust the layer opacity: 

1. Click Opacity Mask and choose Value from the pop-up menu. 

2. Drag the slider or enter a number to choose a new value. The pre
change. 

To specify a different compositing method: 
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• Click Opacity Mask and cho
 

ose one of the other shaders from the pop-up menu. 

 

Using Other Components as Functions 
You can actually use any component as a function in the Mixer operator, or in the Blender channel. This 
allows you to mix components in ways not supported by Carrara's basic functions. 

When you use a component as a function, Carrara automatically converts its output to values so that the 
Mixer operator or Blender channel can use it to mix the components on the Source 1 and Source 2 
branches. 

 place of functions. 

e 1 and Source 2 
 two components evenly. 

 the Source 2 component. 

r uses the 
ponent. 

 produce a blending of the two components. 

rence shader as a Blender component. 

) 
ainting was added as part of the Assembly room. A texture can be edited, selected, 

s channels and shading domains will also be taken into account. Only 
can be recognized by and edited in the 3D Paint tool. 

 New Texture 

he 3DPaint tool. 

Value and Texture map components are especially useful in

• You can use a Value component to blend the components on the Sourc
branches of the Mixer operator in a given ratio. A value of 50 blends the
Lower values favor the Source 1 component; higher values favor

• You can use a black and white or grayscale texture map to mix the Source 1 and Source 2 
components in a custom pattern. For each white pixel in the image, the Mixer operato
Source 1 component. For each black pixel, the Mixer operator uses the Source 2 com
Intermediate shades

You can also use a shader or refe

3D Painting (Pro
In Carrara 7 Pro, 3D P
or assigned to an object for variou
simple shaders made of textures 

The 3D Paint tool supports layers, image stamping, tablet support, and the ability to save a brush for later 
use. 

Load or Create
1. Create or build the object to be painted. 

2. Click on t
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If the object does no
one needs to be added. Cli
up each time you start pain
before clicking on OK. 
 

t have a texture active, a message dialog will come up letting you know that 
ck on OK to close the dialog. If you do not wish this message to come 
ting a new object, click in the checkbox next to Skip from now on 

 
3. The Properties Tray for the tool will activate with the Textures tab active. 

 

 
 
If you click on any of the arrows next to the channels, it will show that there are no textures 
assigned to the channel. 
 

 
4. Left-click on the Open Texture icon to bring up the file open dialog where you can locate and 

select a texture for that channel. 
 

 
 
OR 
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5. To create a new texture, click on the New Texture icon. 
 

 
 
A message dialog will come up cautioning you that the instance shader will be changed. Click on 
OK to continue or Cancel to stop the change. If you do not wish this message to come up each
time you create a new t
O

 
exture, click in the checkbox next to Skip from now on before clicking on 

K or Cancel. 
 

 
6. If loading a texture, the Load Texture panel will come up. 

 

 
 
Select the needed channels from the
as needed. 
 

 Channel menu then click on OK to load the texture. Repeat 
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7. If creating a texture, the Create Texture panel will come 
 

up with the current channel selected. 

 
 
Select which channels to create a new texture for by clicking in the checkbox next to each 
channel. 
 

 
8. From the Size menu, select the dimensions of the texture(s). 

 

 
9. From the Color chip, left-click on the chip to bring up the Color Picker or on the arrow next to 

the chip to bring up the gradient color picker. Select a color for the image background from the 
applicable color picker. 
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10. Select the color mode from the Mode menu, either RGB or RGBA (RGB with alpha): 

 

 
11. In the Shading Domains section, if there is more than one domain available, left-click on the one 

to use for this texture. 

12. Click on OK to accept the setting for the new texture. The Save File dialog will come up. Select a 
file type from the file type menu, enter a file name, locate the save directory, and click on Save. 
Repeat for each texture for each channel selected, i.e., one for color, one for bump, one for 
displacement, etc. As each file comes up for saving, the file type will revert to .gif format, so if you 
eed a different format, make sure you change it for every texture. n

 

 
 

TIP! If the texture you will be creating will contain layers, select PhotoShop as your file 
type. 

13. The texture will be applied to the object. 
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and the Texture tab will be updated to show the new or loaded textures for the selected channels. 
Each channel group can have multiple layers which overlay or underlay other layers. See "Layer 
Properties and Options" for more on working with layers. 
 

 
1 C

c

4. lick on the arrow next to the layer group you will be working with then select the actual layer to 
paint on. Make sure that when you need to paint on a different layer or a layer in a different 
hannel group, that you select that layer before you begin painting. 

NOTE! ppens, change to the Textures tab and make sure 
the correct layer is selected.  

 When you begin to paint and nothing ha
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Paint Tools 
When the 3D Paint mode is active, the 3D Paint toolbar is activated with six different tools available. The 
image below shows the available tools, from left to right: Paint Brush, Air Brush, Stamp, Line, Erase 
Brush, and Eyedropper. 

 
Each tool is described below along with its available options. 

Paint Brush 
The Paint Brush is the default 3D Paint tool and is the tool automatically activated when the 3D Paint 

sections: 3D Paint, Color, and Tool. 

mode is selected. 

Symmetry and Color 

1. Click on the Tool tab to activate it. This tab contains three 
 

 
2. In the 3D Paint section, select whether to use symmetry on a specific axis or not (None). This 

will determine whether the painting on the object will only be where you paint or if the texture will 
be mirrored on the selected axis. 
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3. Select a color to be used as the paint color in the Color section. See "Color Pickers" for more on 

choosing colors. 
 

TIP! If you will be using an image on the brush or as a stamp and need the actual colors of 

 brush. 

smoot ss. 

• Mode: From the Mode menu, select either Normal Projection or Fast UV. 
 

the image to show through, set the brush color to white, otherwise, the image will take on the 
color of the

Tool Options 

In the Tool section, choose the options for the brush mode, size, orientation, opacity, shape, and 
hne

 
• Size: Set the brush size by entering a number in the field or clicking on the up/down arrows. If 

using a tablet, click in the checkbox next to Link to tablet pressure to link the brush size to your 
tablet. This option will use the selected brush size as the starting point for the brush size, then 
adjust as needed based on the current pressure applied to the tablet. 
 

 
 
The brush size can also be changed on
object and dragging left to decrease the 
 
The image below shows examples of t
 

 the fly by pressing the Ctrl key, then left-clicking on the 
brush size or right to increase the brush size. 

he brush size at 0.5, 1.0, and 2.0. 
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• Orientation: Select an orientation for the brush by dragging this slider left or right, or by left-
clicking in the value field and entering the degrees manually. This option is only applicable when 
an image is being used on the brush. 
 

 
• Opacity: Set the opacity for the brush by dragging this slider left or right, or by left-clicking in the 

cted 
y setting as the starting point for the brush, then adjust as needed based on the current 

value field and entering the percentage manually. If using a tablet, click in the checkbox next to 
Link to tablet pressure to link the brush opacity to your tablet. This option will use the sele
opacit
pressure applied to the tablet. 
 

 
 

s The first image below shows the opacity at 100%, 50%, and 25%, while the second image show
how painting over the areas increases the amount of paint applied as each brush stroke overlays 
the stroke below. 
 

 
• Shape: The shape of the brush refers to whether it is sharp, smooth, or uses an image. 
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If the brush shape selecte , the Image properties will activate. See "Image Shaped is Image " for 

 50%. Set the smoothness lower for an even sharper brush or 
igher for a smoother one. 

Image Shape 

When using the Image shape brush, an options palette is activated with various options available for 
selecting an image and setting brush pro

more on using an image on the brush. 

• Smooth: Set how smooth the brush is by dragging this slider left and right, or by left-clicking in 
the value field and entering the value manually. This option is only applicable when the brush is 
set to the Sharp or Smooth shapes. The default for the Sharp shape is around 27% while the 
default for the Smooth shape is
h

perties.  

 
• Select File: Click on the Browse button to open the Open File dialog. Select a file type from the 

file type field, locate the file, select it, and click on Open. The selected image will show up in the 
thumbnail to the left of the brush options. 
 

 
• Is Mask:  

• If the Is Mask option is selected, the loaded image will be used as a mask with the 
current brush color used as the "stamp" color. The image below shows an apple image 
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that has a black background so the background is opaque while the apple is partially 
opaque. 
 

 
• If the Is Mask option is deselected, the loaded image will be "stamped" as is on to the 

object. 
 

 
• Invert Image: When selected, this option will create a negative image of the loaded image. 
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•  
d (sprayed) on to the object with the image overlapping as you paint. 

setting higher spaces the images further apart. Adjusting the setting lower will 
space the images closer together. 
 

Spacing: When an image is loaded as a brush, the spacing is set to 25 by default. This allows
the image to be painte
Adjusting the 

 
U• e E e Falloff: Enables or disables edge falloff for the loaded image. 

• When deselected, the entire image is used as the brush. 
 

s  dg

 
• When selected, the edge falloff is applied based on the amount of smoothness selected 

from the Smooth slider. 
 

 
 
Examples: 
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• Orientation: The orientation option is available under the Brush Size option. Drag the slider or 
enter a percentage in the value field to rotate the brush image. Only applicable if an image is
loaded as a brush. 
 

 

 

Air Brush 
The , and Opacity options, however, 
it adds two additional settings, Pressure and Rate, that can be linked to tablet pressure. The Air Brush is 
a softer version of the Paint Brush and works much the same as similar tools in many paint programs. 

Air Brush tool is very similar to the Paint Brush with Size, Orientation

 
• Pressure: This setting determines how much "pressure" is applied to the Air Brush tool. A lower 

setting will result in a softer spray while a higher setting will result in a harder spray. 

• Rate: This setting controls how quickly the paint is applied to the object as the user paints. So, at 
a low setting the paint will be very light such that more of the original color will still be visible while 
at a high setting, more paint will be applied. 
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Stamp 
The Stamp tool is similar to using an image as a brush except, instead of spraying the image as you paint, 
it stamps the image once each time you left-click on the object. 

 
To stamp an image on to an object: 

1. Select the Stamp tool. 

2. Set the stamp size, orientation, and opacity. 

 Image shape option. 

age and set options as shown in "Image Shape

3. Select the

4. Load an im ." 

7. If the stamped image is too transparent, left-click on the same spot again to overlay another copy 
of the image. Repeat as needed. 

To resize the stamp on the fly, left-click on the object and drag the mouse left to decrease the stamp size 
or right to increase it. 

To rotate the stamp on the fly, left-click on the object and rotate the mouse left or right. You'll see the 
brush axes rotate as you do this. Let up on the mouse button to stamp the image at the current 
orientation. 

5. If the stamped image needs to have the exact colors as on the original image, set the brush color 
to white and make sure Is Mask and Invert Image are deselected. 

6. Left-click on the object to stamp the image on to the object. 

Line 
The Line tool provides options for the size, orientation, and opacity which are used when creating the 
line on the object. 

 
To add a line to the object texture: 

1. Select the Line tool. 

2. Set the line size, orientation, and opacity. 

3. Left-click and hold on the object where you want the line to start. 

4. Without letting up on the mouse button, drag the line where you want the line to end. A white line 
will extend from where you started to where the brush tool is currently located. 
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5. Let up on the mouse button. 

 

 
6. Repeat as needed. 

 

 

Eraser 
ser and removed sections of the texture from the object based The Erase Brush works like any other e

on brush size and opacity. 
ra
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You can adjust the size and opacity o

s
f the eraser and link the pressure to your tablet, plus, if you use an 

image a  the eraser, you can erase parts of the texture to create some cool effects. 

 

Eyedropper 
The Eyedropper tool provides a means of selecting color from a section of the object's texture and 
replace the current brush color with the new color. Simply select the tool, move the mouse over the object 
texture, and left-click on top of the new color. 

 

 © 2008 DAZ 3D, Inc. 647 



Carrara 7 11 December 2008 

Layer Properties and Options 
Each texture channel is created with a default background layer but additional layers can be added or 
removed as needed. 

To paint on a specific layer, left-click on the layer in the listing to activate it. 

As you paint on the object, the Background layer will update to show the painted texture. 

 
Right-click on the main texture thumbnail to access its context menu. 

 
• Save: Saves the texture and any changes to file. No confirmation. 

gs up a default save dialog to save the texture to a new file and the image file 
d by the texture is changed to use this new file. Available options shown below: 

 

• Save As: Brin
reference use

 
 

TIP! To save a texture with multiple layers, select the PhotoShop file type. 

• Export As: Saves the texture to a new image file without changing the reference in the shader 
(so it will still point to the old file). 

• Reload: Reloads the original blank texture. A confirmation dialog will come up to make sure you 
want to do this as it cannot be undone. 
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• Add layer: Adds a new sub-layer at the top of the 
 

layer tree. 

 
• Right-click on the Background or another layer to access the layer context menu. 

 

 
• Mode: Shows the current RGB mode of the layer, either RGB or RGB with Alpha. If the 

layer does not need an alpha transparency, deselect the Alpha option. 

grayed o

• Edit layer properties: When selected, brings up the Layer Properties dia

• Fill: When selected, fills the entire layer with the current brush color. You will not be 
asked to confirm the operation. 

• Clear: When selected, clears the layer. You will not be asked to confirm the operation. 

• Add layer Above: When selected, adds a layer above the current layer. 

• Add layer Below: When selected, adds a layer below the current layer. 

• Delete layer: When selected, deletes the current layer. You cannot delete the original 
Background layer and this option will be ut. 

• Duplicate layer: When selected, duplicates the current layer and places the new layer 
above it but with the same name. 

log where the 
name of the layer can be changed. 
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The image below shows a layer added before and after the background layer with the 
result shown in the second image. Note how the yellow in Layer 1 overlays the 
Background layer while the blue in Layer 2 underlays it. 
 

 
 

 

Laye

• lighted in yellow and the 3D Paint icon on the left will be 

con will be 

r Options 

Active Layer: An active layer will be high
solid. 

• Inactive Layer: An inactive layer will be the default color (blue) and the 3D Paint i
grayed out. 
 

 
• Hide/Unhide: To hide a layer, left-click on the eye icon under the 3D Paint icon for the layer. The 

"eye" will close and any textures applied to t n the viewpo
the eye icon again to unhide the layer. 

he layer will be hidden i rt. Left-click on 

 

 
• When a layer is added, the Layer section nd the Mode and Opacity can be modified. 

When und layer is selected, these options are grayed out. 
 activates a

 the Backgro
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• Mode: Provides options for setting the layer mode. These are similar to those found in 

paint programs and work similarly to them.  
 

 
• Opacity: Set the layer opacity by dragging left or right on the slider, or by left-clicking in 

the value field and entering the percentage manually. 

Animating 
This chapter explains general concepts about the motion of Carrara objects: 

In this chapter: 

• For a list of the steps involved in creating , see "What is Animation? an animation ."  

nciples to keep in mind as you create your animation see "Animation • For useful animation pri
Principles." 

• Refer to "Key Frame Animation" for an overview of using key frames to create animation in 
Carrara.  

e 
n animation features are: 

eatures of the Sequencer Tray

In addition, this chapter introduces the main animation tools in Carrara and briefly describes how to us
those tools. The mai

• "Animation F ." 

• "Storyboarding." 

• Finally, there is a brief overview of animation features found in other chapters: 

• Refer to "Additional Animat resion Featu ." 

• For specific information on applying animation features, see "Animation Techniques." 

• For specific information on character animation, see "Character Animation." (Standard, Pro) 
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What is Animation? 
When you animate with Carrara, you add a fourth dimension:time:to your 3D illustrations. To create an 
animation, you change the arrangement  r cene at different key points in time. Carrara then fills in 
the gaps to complete the animation. 

You can a

• the motion of objects, lights, and cameras 

• object size, shape, and shading attributes 

• object modifier settings 

• camera and light parameters 

• ambient lighting, background, backdrop, and atmospheric effects. 

Animatable Properties 
Each characteristic of an object or effect that can be a called a property. A typical object or 
effect has m
are commo  of objects. 

perties like brightness, falloff and gels. 

ckgrounds, backdrops, and atmospheres, have their own special properties. 

dividual object depend on several factors, including what type of object it is, 

ental primitives (like Fountain, Cloud and Fire) have special properties that determine 

, 

ent points in time and making changes in the 
f the action at that moment. These changes are called key frames. Carrara 

s between key frames to create the illusion of motion. This can be done 
hich are 

tion methods introduced in "Animation Techniques

of you  s

nimate almost everything in your scene. For example, you can animate: 

nimated is 
any animatable properties. Some properties, like those that define position and orientation, 

n to all objects. Other properties are specific to certain types

• Lights have special pro

• Scene effects, like ba

• The properties of an in
and what types of components are used in its shader. 

• Environm
their shape. 

• When you apply a modifier to an object, you add special animatable properties. 

Steps to Creating an Animation 
Animation is an extension of creating an illustration. For example, to create a scene you set up scene 
properties. To create an animation, you change those properties over time. When you play the animation
the changing properties create action. 

In Carrara, you create an animation by moving to differ
scene to define the state o
automatically fills in the transition
through the Storyboard room or through the animation features in the Sequencer tray, w
described in this chapter, or by using one of the mo ." 

2. Build the scene by arranging objects and setting lights and cameras. 

3. Animate the scene by making changes to the properties of the elements in your scene at different 
points in time. 

4. Render the final animation. 

To create an animation: 

1. Create objects using the basic geometric primitives and the modelers. 
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Animation Principles 

imation. 

need not be as complex as a typical illustration scene. 
wn toward motion and foreground elements. Static objects and 

sually. . 

s and keep the size of your 
ollowing guidelines in mind: 

cts as simple as possible. Detail is usually lost in an 

of the animation, try substituting a 

cene, consider rendering a still image with 

bjects don't give the trick away. 

Motion and Timing Principles 

Motion and Timing Principles 

xaggerated and cartoonish. No matter how good a 3D modeler 

 falls it stretches; as soon as it hits the ground it is squashed. If the 
ball failed to change shape, the audience would interpret it as a solid, rigid mass. 

The following sections include some helpful animation principles and concepts to help you use Carrara. 
This is by no means an exhaustive explanation of computer animation, but some issues you should take 
into account when you create your an

Simplifying Your Scenes 
In general, the 3D scenes you create for animation 
The viewer's eye tends to be dra
background elements are scanned only ca

By reducing unnecessary detail, you can dramatically reduce rendering time
scene files manageable. When preparing a scene for animation, keep the f

• Refine your animation. Keep the obje
animation. 

• Use fewer objects, and limit the number of reflective and transparent objects. 

• Use the minimum number of lights required to achieve an effect. Additional light slow down the 
rendering. 

• If a complex model remains in the background for the duration 
simpler version. 

• Avoid using a modeled background. Use an image or a procedural one instead. 

• If your camera view remains unchanged for an entire s
just the scene's background elements. Then use this image as a backdrop and animate only the 
foreground elements. This technique requires some planning to make sure that shadows and 
transparent o

As an animator, the most important skill you can master is the ability to portray motion convincingly, 
whether it is intended to be realistic or e
you are, the timing of the events in your animation are of paramount importance. 

Many of the principles of timing and motion developed by cel animators apply to 3D animation with 
Carrara as well. Many of these principles apply especially to character animation, but most are useful for 
any subject matter. For more information, you can refer to one of the many excellent books on cartoon 
animation. . 

Squash and Stretch 
Squash and stretch are animator's terms for the exaggerated redistribution of an object's mass as it 
moves or shifts positions. Squash and stretch portray the qualities of elasticity and weight in a character 
or an object. 

Think of a bouncing rubber ball. As it
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You can accomplish squash and stretch in Car
modeler, the Spline modeler, the Metaball mod

rara by animating an object's shape using the Vertex 
eler, or the Stretch modifier. 

This moon's bouncing motion is exaggerated by deforming its shape so that it stretches as it descends 
and squashes when it hits the surface. 

 

Lag and Overlap 
When an object moves from one point to another, not everything has to move at once. For true-to-life 

y lead, followed by his torso, and finally by his arms and legs. In Carrara, the Inverse 

movement, action that is secondary to the main activity can lag and overlap. For example, when you 
animate a character in pursuit of a bus, different parts of the body move at different speeds. The 
character's head ma
Kinematics modifier can be used to experiment with poses that convey this type of motion. 

 
A flag waving back and forth is another example of lag and overlap. It lags at one end of the arc and 

 can use the sweep path and the envelope in 
apping effects. 

 of a straight line. Most 

Motion paths are also great for this effect. Refer to "Motion Paths

overlaps when moving in the opposite direction. You
Carrara's Spline modeler to create lagging and overl

Arc vs. Straight-Line Movement 
Character motion appears more realistic if it follows an arc or curved path instead
objects affected by gravity also follow curved, rather than straight trajectories. 

Carrara's Bézier tweener is optimized for arc-type movements. Try experimenting with its Tighten In and 
Tighten Out settings to produce narrower or wider arcs.  

" to learn more about creating and using 

tion adds realism and credibility to a scene. A character turning his head to stare at 

motion paths. (Standard, Pro) 

Secondary Motion 
Secondary mo
something in disbelief shouldn't just turn his head; his jaw should drop and his eyes should blink as well. 
The viewer focuses on the main action, but registers the secondary motion as supporting it. Carrara's 
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Time Line gives you enough control to manage even the finest details of your animation, so you can 
this kind of secondary detail. 

add 

-through 
In anticipation of a major action, an animated character often makes a small preliminary action in the 
opposite direction. For example, a character about to move screen right might first make a slight 
movement screen left, then strike a pose before moving screen right. 

Anticipation and Follow

 
Follow-through is the continuance of motion after a major action is completed. A baseball bat does not
stop moving after hitting the ball; rather, it continues along its arc of motion. Anticipation and follow-
through make actions more believable. 

Exaggeration 

 

Exaggerating an action emphasizes it, making it more prominent. For example, if intrigue is called for, 
have a character sneak instead of walk. 

If you want your animation to resemble footage from a hand-held camera, give your camera an 
exaggerated bobbing motion. Virtually any type of action can be exaggerated to get an idea across. 

Timing 

 
real. 

 out the sequence yourself, timing how long each 
watch. 

ne your timing. Test your 

re satisfied with the timing. 

space, it usually makes sense to render your animation without 
ou'll have a high quality copy of the animation to work with. 

ession 

Timing is as important in animation as it is in any dramatic form. Consider the difference between an 
abrupt stop and a gradual slowdown. Each conveys a completely different impression. In general, a
motion that continues at the same pace lacks interest and seems un

If you are trying to animate realistic character action, act
pose is held and how long each action takes with a stop

Timing is one of the most difficult aspects of animation to master. The key frames you define at different 
points on the Time Line must be synchronized with those that came before and those that follow. 
Fortunately, you can use the interactive nature of computer animation to fine-tu
animation frequently by previewing it in the 3D view or by dragging the Current Time bar back and forth 
between key frames. Adjust the event's position until you'

Compression 
If you are not pressed for hard disk 
compression. This ensures that y

Working from your uncompressed original, you can save copies, experimenting with various compr
settings until you are satisfied with both the image quality and playback rate. 
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An animation compressed multiple times degrades significantly, so you should render without 
compression if you intend to do any post processing in another application. 

See "Rendering" for information on compression. 

Key Frame Animation 
In Carrara, you animate objects by moving to different points in time, then making changes in the scene 
to define the state of the action at that time. These states are called key frames. 

Key frames are tied to real-world time increments, seconds and minutes. You can determine how many 
key frames you want to run for your animation (from 8 to 60 frames per second) so that you can run a fast 
draft, or create more seamless movement. This means you can create key frames at specific points in 
time without worrying about the number of frames in your final rendered animation. 

You can edit a series of key frames in the Storyboard room or using the Time Line in the Sequencer tray 
from any other room. 

Multiple key frames in the Storyboard r om are useful when you want to see the effect of changes on 

ork 

al methods for creating key frames. Refer to "Animation Techniques" to learn 
. 

en 
e 

s in your animation. 

ny different types of tweeners: linear (for a constant rate of change), Bézier (for 
smooth motion paths and greater control over acceleration and deceleration), discrete (for instantaneous 

t 

ctor 

 

• Animation Preview Controls 

o
objects over several frames. 

Viewing a single frame in the Assemble room or a Modeling room is more useful for doing detailed w
on individual frames as you animate. 

Carrara provides addition
about the other methods

Tweeners 
Carrara uses formulas called tweeners (from "be tween" ) to calculate the state of each object betwe
key frames. By specifying which tweener to use for each transition, you can control the rate of chang
between key frame

Carrara includes ma

change), and oscillate (for alternating back and forth between key frames). 

Animation Features of the Sequencer Tray 
All of the grouping, linking, and organization tools you use in the Sequencer tray to produce a 3D 
illustration are the same tools you use to produce an animation. 

In addition, the Sequencer tray also contains most of the primary tools you need to create an animation. I
contains: 

• The Hierarchy list 

• Frame Rate Sele

• Time Information

• Render Range 

• The Scrubber 

• Key Frame and Tweener Markers 
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The Sequencer tray is available in the Assemble, Model, Storyboard, and Texture rooms. Refer to "Using 
the Sequencer Tray" for general information on using the Sequencer tray. This chapter focuses on the 

mation. areas in the Sequencer tray that are specific to ani

 

Hierarchy List 
The Hierarchy list of the Sequencer tray displays a textual representation of the scene's hierarchical 
structure that includes objects (such as cubes or spheres), cameras, lights, links, groups. 

The Hierarchy is non-animatable. This means that you can't add or remove objects at specific points in 
time. Nor can you change groups or links over time. 

In other words, the values of the properties on the Sequencer may change over time, but the properties 
themselves must be constant. For example, a spot light can't become a distant light over time; a bitmap 

• Select a child object by expanding its parent object in the list, then clicking the child object. 

e Line expansion triangles to reveal individual Time Lines. 

how the animatable properties of each object contained in it. This 

background can't become a bi-gradient. 

To use the Hierarchy: 

• Click an object's name to select it. 

• Click an object's name and drag it onto another object name to link it to that object. Unlink by 
dragging it to any other level in the Hierarchy. 

• Click on Tim

Collapsing and Expanding the Hierarchy 
The Hierarchy list can be expanded to s
allows you to animate each property individually. 

It can also be collapsed to show fewer properties. 

To expand or collapse the Hierarchy: 

• Click the triangle to the left of the property. 

• Click the plus (+) or minus (-) sign to the left of the child property. 
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Creating Groups 
Groups of tracks can be grouped together which can then be collapsed or expanded. This helps to 
optimize the screen space so you can focus on your animation. 

To create a group: 

e grouped together. 

rarchy listing and choose Group from the menu or press Ctrl+D. 
 

1. Select the tracks to b

2. Right-click on the hie

 
 
The group will be created with the selected tracks as part of the group. 
 

 
3. Add additional tracks as needed by selecting the track and dragging it on to the group. 

k and dragging it out of the group. 

2. Right-click on the group and choose Ungroup from the menu or press Ctrl+U. The group will be 
removed and the tracks that made up the group will be placed back into the hierarchy as before. 

Displaying Specific Time Lines in the Hierarchy List 
Large scenes may have more time lines in the Hierarchy than you want to work with at one time. To 
minimize the number of time lines displayed in the Sequencer, you can select buttons on the Sequencer 
tray to show only certain categories: 

4. Remove tracks by selecting the trac

To ungroup a group: 

1. Select the group. 
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Select this button in the Seque

•

ncer to specify which properties are displayed. 

 Hide Non-Animated Tracks sets the Sequencer to display only animatable properties that have 
n.) 

play only motion properties. (This 
imatable properties that are constant throughout the animation.) 

cer to exclude animatable properties that have not 

ide Empty Group Tracks sets the Sequencer to exclude properties that can't be animated. 

Frame Rate Selector 
The frame rate selector lets you choose between 1 and 60 frames per second (fps). Typical frame rates 
are 15 or 18 fps for multimedia (CD-ROMs), 24 fps for film, and 30 fps for NTSC video. You'll probably 
want to use a lower frame rate for previewing, then increase the rate for final rendering. 

The Frame rate you select will appear on the Time Line axis. 

To change the frames per second: 

1. Click the Sequencer tray: fps bu t n (frames per second).  

key frames. (This excludes animatable properties that are constant throughout the animatio

• Hide Non-Transform Tracks limits the Sequencer to dis
excludes an

• Hide Null Group Tracks sets the Sequen
been applied to the object. 

• H

t o  
 

 
2. Select frames per second from 1 to 60. 

Time Information 

move them to different points in time using points on the line. 

n in the 
ore 

The Time Line is located to the right of the Hierarchy in the Sequencer tray, and provides a linear visual 
representation of the key frames that make up an animation. It allows you to manipulate key frames and 

The Time Line displays a time track for each item (object, effect, or property) currently show
Hierarchy. Key frame markers on these tracks represent key frames in the animation. For m
information on key frames, refer to "Creating Explicit Key Frames." 

Allocated Time 
The allocated time is roughly the entire length of the animation you're working on. The non-allocated time 
is displayed as a dark shaded area on the right side of the sequencer. When you move the Current Time 
bar past the end of the allocated time, it is automatically adjusted. If you then need to set the allocated 
time to a smaller value, you can use the Allocated Time control. 
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Elements of the Time Line 
A key frame marker on a particular time track indicates a key fra
effect, or property. 

me that modifies the associated object, 

 
You can create, copy, delete, or move key frame markers along the Time Ruler by dragging them. 

The Time Ruler 
The Time Ruler extends across the top of the Time Line. The ruler marks indicate time increments 
(minutes, seconds, and frames). 

 

The Current Time Bar 
The Current Time bar or Current F
time or frame on the time/frame ax

rame bar is a slider with a triangular handle that points to the current 
is. You can switch between working with time or working with frames. 

As you slide the bar along the time axis, the time or frame updates in the time scale/frame rate indicator. 

 
The Current Time Bar in the Time Line window indicates the current time in the Time Ruler. 

To change the current time or frame with the time bar:  

• Drag the Current Time bar to a different point along the Time Ruler. The time or frame is reflected 
in the Sequencer. 
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Time Scale and Frame Rate 
The time scale is the amount of time between each mark on the Time Ruler. You can change the scale of 
the axis to see more or less time displayed. 

The frame rate indicates the number of frames displayed in each second, when previewing and rendering. 

Carrara has a display time/display frames toggle button to swap the time ruler between the two types of 
information. The frame rate also determines the number of tics (or marks) between major time divisions 
on the Time Ruler. 

 

Snap 

nd key frame markers will snap to individual frame 

To control snapping to frame boundaries: 

When Snap is turned on, the Current Time bar a
boundaries when you drag them. 

• Click the Snap checkbox at the top of the Sequencer tray. 
 

 

The Render Range 

The render range depicts the portion of the animation to be previewed or rendered. It is represented by 
the non-shaded area of the Time Line. Two yellow arrows in the Time Ruler also indicate the beginning 
and the end of the render range. 

 © 2008 DAZ 3D, Inc. 661 



Carrara 7 11 December 2008 

 
The render range must extend past all key frames if you want to preview or render the entire animation. 
The animation stops at the right boundary of the render range. If your animation does not preview or 
render to the end, verify that the render range extends beyond the last key frame. 

In theory, the maximum render range is one frame short of one hour (the entire length of the Time Ruler). 
In practice, an animation that long would exceed the capacity of most hardware configurations. Lengthy 
animations should be produced in several short clips, which can then be edited together in a video-editing 
application. 

To change the render range start and end times: 

1. Drag the right edge of the render range to set the end time. 

2. Drag the left edge of the render range to set the start time of the animation. 

Scrubber 

The Scrubber is the bar above the Time Ruler. It shows the current time, and 100% of the render range. 

 
To use the scrubber: 

ove the Current Time marker to preview the animation. 

ong a track. The Time Line displays a time track for each 
element (group, object, effect, property category, or individual property) currently shown in the Sequencer. 

ine for each object in the scene. 

Key Frames and Tweener Markers on the Time Line 
A key frame marker on the tracks of the Time Line may represent a single key frame or several coincident 

ifferent properties of the same object (the object on the Sequencer to the 

• M

Key Frames and Tweeners in the Sequencer Tray 
Key frames are stored animation values al

Key frames and tweeners are indicated with markers on the Time L

key frames, each relating to d
left of the Time Line). 

Tweeners appear between key frames. The location of a key frame marker along its track indicates the 
time at which the key frame occurs. 
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Key Frames and the Hierarchy 
A key frame modifies a single property. However, whenever two or more coincident key frames modify 
properties of the same object or effect, they are represented on higher levels by a single key frame 
marker. So, when you move, copy, or delete a key frame marker that represents several coincident key 
frames, all of the key frames it represents are affected. 

To manipulate the key frames separately, expand the Hierarchy to the individual property level, where the 
two key frames are represented by different key fra e markers on separate tracks. m

Following is a key frame marker on a collapsed Hierarchy. 

 
When you expand the Hierarchy, you see that there are actually several individual ke
represented. 

y frames 

 

Overlapping Key Frame Markers 
Sometimes two or more key frame markers appear on the same time track at nearly, but not exactly the 
same place (they may represent key frames modifying the same property, or key frames modifying 
different properties of the same object or effect.) 

Depending on the current time scale (how closely you have zoomed in on the view of the Time Line area), 
these markers may overlap. 
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This is what two overlapping key frame markers look like on the Time Line. 

Zooming in usually makes it easier to distinguish between overlapping key frames. You can zoom in with 
the Zoom tool. 

 
To zoom in and out in the Sequencer, click the Zoom tool in the Sequencer tray and click the location 
where you want to zoom in. 

To zoom out of the Sequencer, hold Alt, then click while the Zoom tool is selected. 

Animation Preview Controls 
 your 

in the Assemble room, moving forward or back one frame, and moving to the beginning or 
end of the render range. 

The animation preview controls consists of VCR-like buttons for previewing and moving through
animation with

 
The render range is the yellow area of the Time Ruler, which determines the starting and ending points 
for previewing or rendering an animation. 

You can use the animation preview controls to preview your animation at the current display quality. 
Textured preview quality will slow down animations. 

Following are the buttons used with the animation preview controls. 

 
Rewind  Jump directly to the first frame of the render 

range. 

 
Previous Frame  Step back one frame. 

 
Stop  Halt play. 

 
Play  Preview the animation forward from the 

current time. 

 
Next Frame  Advance one frame. 

 
Fast Forward  Jump directly to the last frame of the render 

range. 

 
Loop  looping. 

Loop when you play. Click again to disable 
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Animation Preview Tips 
When you preview an animation in the Assemble room, Carrara does not skip any frames. If it can't draw 
frames fast enough to maintain the c rrent frame rate, the preview takes longer to play. 

 closer to real time. Lowering 
sacrificing smoothness of 

r a low-resolution animation for preview purposes, rather than 
preview the animation in the Assemble room. 

 The storyboard helps 
n of the animation. 

sequence, it is easy to make changes. Any 
oard to update the entire animation. 

You can access the Storyboard room from any other room by clicking the Storyboard room button to 
modify an existing scene in the Storyboard room, or t w scene file using this room. 

u

Reducing the frame rate produces choppier motion, but the preview will play
the current display quality to wireframe or box will speed up the preview without 
motion. 

In some cases, you may want to rende

Storyboarding 
A storyboard is a series of drawn images showing the key actions in an animation.
you quickly work out the viewpoint, framing, and compositio

Because several frames of your animation are visible in 
change you make in a frame of your animation causes the Storyb

Features of the Storyboard Room 

o start a ne

 
The a all of the storyboard frames, with the first frame as a key frame. 

To make changes to a fram ion tools. If you wish to use features 
that a e ble in the Ass e to those rooms with the selected 
frame as the active image. You can the me, then return to the Storyboard room to see the 
effects s on 

In addition to the features of the Sequencer tray, you can press Update to update the key frames shown 
in the storybo ss U n you press Update while 
Sele io e k s for the selected item in the Sequencer are updated in the 
Storyboard. 

im ge initially appears identically in 

e, you select it and use editing or animat
emble or Modeling rooms, you can mov

n edit the fra
r  availa

of your change the animation. 

ard or pre
n is selected, th

p or Down to scroll through the frames. Whe
ey framect
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Working with Key Frames and Tweeners 
When you first switch to the Storyboard room with a new document, the objects in the scene appear the 
same in all of the frames. Your first frame is automatically a key frame. As you modify frames on the 
Storyboard, those frames also become key frames. All of the other frames are interpolated. 

Carrara identifies each frame containing key frames with a dot next to the time/frame number so you can 
tell them from the other frames. 

 
The number at the bottom of the frame, to the left of the key frame indicator, shows the time position of 
this frame in relationship to the frames per second selected. (For example, if you have selected 6 fram
per second, your first frame will say 00, your second frame 01, your third 02 up to your 7th fram

es 
e, which 

will say 1.00 to indicate the completion of a second of time). 

 
To work on key frames: 

• Select Uniform to show frames with equal increments of time according to the storyboard frames 
per second indicator. 

• Select Selection to show only the key frames of the selection. 
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Changing the Number of Key Frames 
You can view from 8 to 28 frames at any one time. 

To change the number of visible key frames: 

1. Select Storyboard room. 

2. Click the Frames button at the bottom of the Storyboard window. 

3. Select a number of frames from the list. 
 

 
If you reduce the number of frames (for example, if you have been working with 20 frames and decide to 
only work with 10) only the first 10 of the 20 appear. Use the Up and Down button to scroll the storyboard
and view other frames. 

 

If you expand the number of frames (for example, if you have been working with 8 and decide to work 
with 28), the additional frames are appended to your original frames. 

Changing Frames per Second Displayed 
You can adjust the frames per second for the storyboard, from 1 to 60 fps. See "Time Scale and Frame 
Rate." 

To change the frames per second: 

1. Click the fps button (frames per second) located at the bottom of the Storyboard window. 

per second value from 1 to 60. 2. Select a frames 
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Changing the Camera 
You can change the camera for all of the frames in the Storyboard room. 

m: Toolbar: Camera. All of the frames change to the selected 

To change the camera in the Storyboard room: 

• Select the Storyboard roo
camera. 
 

 

Creating Explicit Key Frames 
In Carrara, key frames a e   real-world time increments:minutes and seconds:rather than to 

cators look like in the Storyboard room and Sequencer 

re ti d to
individual animation frames. This means you can create key frames at specific points in time without 
worrying about the number of frames in your final rendered animation. 

The following image shows what Key Frame indi
Tray 

 
You might work at a low frame rate (6 frames per second is the default) to preview your animation on 
screen. Then increase the frame rate to render your final animation. . 

Once you have defined a key frame, you can remove it, copy it, or move it along the Time Line to fine-
tune the timing of your animation. 
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Adding Key Frames 
Key frames are changes to the properties of objects and effects in your scene at specific points in time. 

reate your animation. You define key frames to set the changes that c

After creating key frames, you may want to modify the rule (tweener) Carrara uses to calculate the 
transitional states between keys. For more information, see "Applying the Tweener". 

Typically, you create a key frame at the beginning and end of a particular action. 

To add key frames: 

1. Select an object (or effect) in the Assemble room or a frame in the Storyboard room. 

2. Either click the object, or open the Sequencer tray and click the Time Line for that object. 

3. Drag the frame bar to the time position on the time axis where you want to add a key frame on 
that Time Line. 

4. Use the standard Carrara tools, editors, trays, and dialogs to modify the properties of the selected 
object. Carrara places a key frame marker on the appropriate track in the Time Line for that 
object. 

 Time Axis. 

y frames using tweeners. The 
transitions before and after the new key frame use the tweener options established for the previous key 

ou've created several key frames, you may want to change the timing of your entire animation, or 
synchronize individual events within the animation. 

You can edit the Time Line to adjust the timing and content of your animation. You can add key frame 
markers, delete them, or move them along the Time Axis. 

Editing Key Frames 
You can delete key frames, change their timing, duplicate them while dragging, stretch a series over time 
or copy them. You can also use a series of key frame actions, such as snap, reverse, repeat, and mirror. 

Deleting Key Frame Markers 
To delete a key frame marker, you select a key frame marker then select Edit > Delete. 

To delete a key frame marker: 

1. Open the Sequencer tray. 

2. From the Time Line, select one or more key frame markers. 

rs you want to select. 

4. Choose Edit > Delete, or press Delete. Carrara recalculates the tweeners. 

5. Continue creating key frames at various points along the

Carrara automatically calculates the transitional states between ke

frame. 

Editing the Time Line 
After y

3. Click the desired key frame marker.  

• Hold down the Shift key and click any additional marke

• You may also drag a marquee around one or several markers to select them. 
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Changing the Timing of Key Frames 
To change the timing of key frames, you move key frame markers horizontally along the time tracks to 
different points along the Time Axis. 

 
To move one or more selected key frames: 

 several 
cted key 

e 

 
 key while you drag a key frame marker. You may use this to return an object or effect to the 

same state at any point during an animation. 

1. Open the Sequencer tray. 

rements of one pixel each. 

 the Time Line. 

e marker one screen pixel to the left or right. You can 
also hold the Shift key down and press the arrow keys to move one frame at a time. 

erties. Likewise, 
ts into other scenes, they carry their key frames. 

ime 
e, while maintaining the proportional timing between the 

events. 

This is  want the 

• Drag the key frame marker along the Time Axis to the desired point. If you've selected
markers, drag one of them and they all will move. The time intervals between the sele
frames remain the same. 

• Carrara lets you move a key frame marker past neighboring key frame markers on the same tim
track. 

• To restrict a key frame marker to stay between the previous and next key frame markers, hold 
down the Shift key as you drag the key frame marker. 

Duplicating Key Frames 
You can duplicate a key frame and move it to another location on the same time track by holding down a
modifier

To duplicate key frames: 

2. Hold down the Option/Alt key, and drag one or more key frame markers along their time track(s) 
on the Time Line. 

Nudging Key Frame Markers 
You can move key frame markers in inc

To nudge selected key frame markers: 

1. Open the Sequencer tray. 

2. Select one or more key frame markers on

3. Press the left or right arrow key to move th

When you duplicate or Copy and Paste an object, you duplicate all of its animatable prop
when you copy and paste objec

Stretching a Series of Key Frames over T
You can stretch a series of key frames over tim

useful when you're satisfied with the relative animation of a particular sequence, but you
entire sequence to speed up or slow down. 

To compress or expand the timing between a series of key frames: 
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Stretch or compress a series of key frames by dragging the key frame markers. 

1. Open the Sequencer tray. 

2. Select three or more key frame markers on the Time Line. 

d drag one of the selected key frame markers. 

g 

 also adjust the positioning of the events 
so that they coincide with the start of the next frame. 

3. Hold down the Command/Ctrl key an
 
The entire series of key frames will be stretched or compressed, retaining the proportional timin
between the key frames. 

Key Frame Actions 
Carrara provides some special features for duplicating and modifying a series of key frames. You can 
snap, reverse, repeat, or mirror a key frame sequence. You can

 
To use a Key Frame Action: 

1. Open the Sequencer tray. 

2. On the Time Line, adjust the display to show the desired sequence of key frames. You may need 
perties of an object. 

ay drag a marquee or press Shift+click. 

to change the time scale or expand the pro

3. Select each marker in the sequence. You m
 

 
4. Select the desired action from the action selections. 

 

 
• Snap adjusts the positioning of the selected events so that they coincide with the start of 

first and vice versa. 

• Mirror duplicates the sequence, reverses the duplicate, and places it after the selected 

the next frame. 

• Reverse flips the order of the events so that the last becomes 

• Repeat duplicates the sequence and places the duplicate after the selected sequence. 

sequence. 
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Using Tweeners 
You can use tweeners to create interesting and subtle changes in the transitions between key
Tweeners save you time by automatically creating movements and changes that would be ex
difficult with key frames alone. Tweeners make your animation motions, and other changes, more natural 
and sophisticated. 

 frames. 
tremely 

? 

You won't always want a smooth, linear transition. Sometimes you want an abrupt change of state. Other 
times you want a transition that starts slowly and accelerates to finish in a rush. You might even want a 
transition that quickly alternates between the before and after states, like a fluorescent light flickering on. 

All of these transitions are possible by setting your options for the tweener used between each pair of key 
frames. 

A tweener requires a beginning and an ending key frame, although you can place the ending key frame 
far out in time. 

r 

o states. 

What is a Tweener
The time period between any two key frames is considered a transition. In the Time Line, you see the 
transition as the "gap" between key frame markers. Carrara uses a formula (the "tweener") to create the 
transitional states so that the object or effect changes smoothly between the two key frames. 

Applying the Tweene
Carrara automatically applies a tweener in every "gap" between key frames on the Time Line. The default 
tweener is linear, which produces an even rate of change between the tw

You can achieve a different sort of transition by applying a different tweener. 
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To apply a tweener: 

1. Open the Sequencer tray. 

2. On the Time Line, set up beginning and ending key frames. 

ent between the two key frame markers. 

m the list. 

mall graphic on each segment of the time track. This graphic indicates the kind of 

3. Click the time track segm

4. Select a tweener type fro

5. Set the appropriate controls for the tweener. The controls for each type of tweener are described 
in the sections that follow. As you move the handles on a slider, the graph reflects the new 
settings. 
 
Notice the s
tweener that is applied. 
 

 

Bézier Tweener 
ner creates smooth motion paths. For best results, use it on an object's transformation 

track. 

at you can adjust:Ease-In/Out and Tighten-In/Out. 

The Bézier twee

The Bézier tweener has two controls th

 
To set Bézier tweener options: 

1. Open the Sequencer Tray. 

2. On the Time Line, click the time track segment between the two key frame markers. The 
Transition Options display in the Properties tray. 

3. Select a Bézier from the list. The Bézier tweener controls appear. The two handles on the Ease-
In/Ease-Out slider on the Linear tweener to modify the rate of change at the beginning and end of 
the transition. 

4. Drag the left handle to the right to start slowly. 
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5. Drag the right handle to the left to finish slowly. The Tighten In/Out slider allows you to adjust the 
e "path" the values take as they change from one key frame to the 

r the extremes (0% and 100%) 
 linear). Values near 50% result in looser (less direct) 

trajectory of the transition:th
next. 

6. Drag the left handle to change the initial trajectory. 

7. Drag the right handle to change the finishing trajectory. Values nea
result in tighter trajectories (closer to
trajectories. The default settings (33% in and 67% out) are optimized for natural, smooth motion. 
 

 

Discrete Tweener 
The Discrete tweener maintains the values from the key frame that begins the transition until a specific 

e values abruptly change to those of the key frame that ends the 
weener when you want a property to change immediately, like switching on a 

Open the Sequencer Tray. 

. The 
Transition Options display in the Properties tray. 

3. Select Discrete from the list. 
 

time in the transition is reached. Then th
transition. Use the Discrete t
light. 

To set discrete tweener options: 

1. 

2. On the Time Line, click the time track segment between the two key frame markers
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4. Adjust the Threshold slider to specify the exact point during the transition where you want the 
change to occur. 
 
The threshold value is a percentage of the transition'
the discrete change to occur halfway between the k

s entire duration. For example, if you want 
ey frames, set the threshold to 50%. If you 

Formula Tweener (Animation) 
Formula creates a transition curve or pattern from a formula. You can devise your own formula to create a 
custom tweener. 

To use a formula for the tweener: 

1. Open the Sequencer tray. 

2. From the Time Line, click the time track segment between the two key frame markers. The 
Transition Options display in the Properties tray. 

he list. The Formula controls appear. 

want the change to occur at the time of the first or last key frame, set the threshold to 0% or 
100%, respectively. 

3. Select a Formula from t
 

 
4. Set the Formula controls to create a tweener of the shape you want. Enter a formula into the 

editing panel on the top, or edit the existing one.  

• Parse Click this button to test and compile the formula. If there are any errors, Carrara 
gives you an error report. 

• Parameter Use these sliders to increase and decrease the value of parameters. 

• More Click this button to display the Formula Editor. 

Linear Tweener 
The Linear tweener creates gradual, direct transitions between actions. 

When the graph line is straight, from the bottom left to the top right corner, the transition proceeds at an 
even rate from start to finish. This is the default, but you can change it. 

To set Linear tweener options: 

1. Open the Sequencer tray. 

2. On the Time Line, click the time track segment between the two key frame markers. The 
Transition Options display in the Properties tray. 

3. Select Linear from the list. 
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4. Adjust the two handles on the Ease-In/Ease-Out slider on the Linear tweener to modify the rate
change at the beg

• Drag the left handle to the right to start slowly. 

• Drag the right handle to the left to finish slowly. 
 

 of 
inning and end of the transition.  

 

Nois
Noi s noise. 

e Tweener 
se creates a transition based on a random value, also referred to a
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• Seed This value "seeds" the random number generator. 

• T Scale Changes the frequency. 

• Magnitude Changes the amplitude. 

• Limits Upper and Lower limits on the amplitude. 

• Interpolation Controls Changes the type of interpolation. None will result in sharp 
(instantaneous) changes, linear will smooth the transition, but changes in direction are very sharp. 
Cubic provides smooth transitions. 

Oscillate Tweener 
The Oscillate tweener switches back and forth between the start and end values several times during the 
transition You can choose between several wave forms to describe the alternation. 

 
To set Oscillate tweener options: 

1. Open the Sequencer tray. 

2. From the Time Line, click the time track segment between the two key frame markers. The 
Transition Options display in the Properties tray. 

3. Select Oscillate from the list. 

4. Click one of the Wave Shape radio buttons to choose the desired wave shape. The graph of the 
wave shape shows how the switch occurs between up and down phases.  

• The Sine wave uses a sine curve to alternate the before and after values. 

• The Square wave alternates back and forth between the first and last key frames with no 
interpolation. One way to make a light blink at one second intervals is to turn the light on 
and off by setting key frames every second on the light's time track. A more efficient way 
is to turn a light on at Event A and then turn it off, perhaps ten seconds later, at Event B. 
Afterwards, apply the Oscillate tweener, and specify ten oscillations (using the Square 
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wave so that the switches are abrupt). The Oscillate tweener switches the light on and off 
cond interval, using only two key frames and a single tweener. 

early from its beginning value to its ending value, 
he beginning value in each oscillation. You can use this 

g a gong. The character's arm is first placed in 
g, and then snaps back. You can also use 

ten times during the ten-se

• The Saw/Loop wave interpolates lin
then snaps back abruptly to t
option to replicate an action, such as hittin
a drawn back position, moves to strike the gon
Saw/Loop to play a movie from start to end in a loop. 
 

 
• The Triangular wave shape causes the transition to alternate back and forth abruptly. 

• The Bounce wave shape causes the transition to alternate, with abrupt change in and out 
of the second position and gradual change in and out of the first position. This works well 
when the first position is a ball at height, and the second position is the ball on the floor. 

5. Adjust the Nbr Oscillation slider to set the number of times the values should alternate. 

 to progressively diminish the amplitude of the oscillations. After each 
iminishes by the damping factor percentage. 

w much of each oscillation is dedicated to the "up phase." 
 

 B to A. 

The spli raph Editor

6. Adjust the Damping slider
oscillation, the amplitude d

7. Adjust the Up Phase slider to control ho
For example, if you set the Up Phase value to 90%, the object spends 90% of the oscillation
changing from A to B and only 10% changing from

Spline Tweener (Pro only) 
ne tweener is used in the graph editor where you can control the tangents. See "G ." 
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Gra
The graph e
control
animation. 

Mini-graph Editor 
In the timeline where you can edit the key frames, you can display a mini graph editor for a parameter. 
This mini-graph editor is only available for parameters that support it. This depends on each parameter 
type and also the parameter need to be animated (its timeline must contain more than one key frame). 

To display it, click on the + icon just before the name of the parameter. It will open a small graph bellow 
the timeline where the interpolated curve will be visible. 

ph Editor (Pro) 
ditor gives you the ability to see, understand and edit your animation with a high level of 

. You do not just see key frames but also their values and how they are interpolated during your 

 

Using the Graph Editor 
To switch back and forth between the graph editor and the timeline mode, use the following button: 

 
The graph editor mode is like the mini-graph but he  you can display multiple curves all together. You 
have more room to clearly see the details. Also, having multiple curves at the same time is useful if you 
want to adju

To displ

• 

stance, 

To select and edit key frames, use the Pick tool. Just select the key frame and drag. Note that you can 
e by selecting them while pressing the shift key at the same 
an also use the key modifiers (alt/option or control) to scale, 

duplicate, etc. For more information on this, see "Editing Key Frames

re

st two different curves, one according the other, or to align two key frames for instance. 

ay a curve in the graph editor 

Select the parameter that you want to see in the hierarchy on the left. If you want to select 
multiple parameters, you can select more than one while holding the shift key down. 

• You can also select a group of parameters to see all children displayed in the editor. For in
if you select the group Position, the three curves for X, Y and Z will be visible. 

Editing Key Frames in the Graph Editor 

also move several key frames at the same tim
time or by using the marquee selection. You c

." 

Editing Tangents 
The main purpose of the graph editor is to let you adjust the tangents that influence the interpolation 
between two key frames. This gives you precise control over the animation. 
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Tangent Presets 
You can quickly setup the tangents using the predefined presets. First select the key frames (one or a
multiple selection) that you want to modify and select one of the following buttons: 

 

 
• The first one will create tan

• The second button means l

gents to have a smooth interpolation. 

inear interpolation. This preset will remove the tangents. 

it 

The tangent for a key frame is composed of two half-tangents: the left and the right. 

You can create or remove one of the half-tangents (left or right one) by clicking on one of the following 
buttons: 

• The last one creates flat tangents. This is a quick way to create tangents for a key frame and ed
it manually afterward. 

Half-tangents 

 
Half-tangents can be used in two modes: 

stance, the control point of the left half-tangent, the right 
 half-tangents aligned. 

To change the tangent mode, you can use these buttons: 

• In linked mode, when you move, for in
one will be modified as well to keep both

• In unlinked mode, moving one control point will not modify the other one. 

 

Editing Tangents Control Points 
dify 

ents mode while dragging 

here. Also, using the tangent 
eener and replace it with a Spline. 

upport tangents. This is the case, for instance, for the rotation and the 
hot point, due to the fact that the way they are interpolated is not compatible with tangents. For 

ener 

After creating tangents, select one control point using the Pick tool and drag to move it. This will mo
the tangent according to the current mode (linked or unlinked). 

If, while dragging, you hold the shift key, the direction of the tangent is constrained. You will only be able 
to modify the length of this tangent. 

You can also press the alt/option key to switch between linked and unlink tang
the control point. 

Notes on Tangents 
• The tangents are only available if the tweener used is a Spline tweener. This means that if you 

use an Oscillate tweener you will not be able to have a tangent 
presets may change this tw

• Some parameters do not s

this kind of parameter, you can only move the values in the graph editor and use another twe
to control the interpolation, like a Linear or Bézier tweener. 
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Additional Animation Features 

• Modifiers (see "Modifiers

Carrara also allows you to animate several other types of objects and effects, including the following: 

"). 

• Shapes of spline, vertex, and metaball objects. For more information, refer to "Animating in Other 

s or rising 

the following additional ways: 

 to your scenes. 

s using motion paths or the physical behaviors of objects. 

tent with the laws of 

Rooms." 

• Characteristics of environmental primitives, to achieve effects such as flickering flame
fog. 

You can also use animation in 

• Add rotoscoping

• Create animation

• Use Physics to let your objects accelerate, move, and interact in ways consis
physics. For more information, refer to "Physics." (Standard, Pro) 

Animation Techniques 
In "Animating," you learned about key frame animation and were introduced to the animation features in 

• Motion paths 

• Physics 

ut animating in other rooms. 

See "Character Animation

Carrara. 

In this chapter: 

This chapter discusses the following motion methods: 

• Explicit (key frames) 

In addition to these motion methods, you'll also learn abo

" to learn about animating using skeletons. (Standard, Pro) 

e, you create key 

arrara calculates the motion. 

ect or group you are animating. 

y: Motion tab: Motion panel: and select a method from the motion 

 

All of the motion methods used by Carrara create key frames. However, in some cases you create them 
directly, and in other cases, Carrara calculates the movement for you. For exampl
frames when you use the Storyboard room or the Sequencer. Yet, when you use physics, you can create 
key frames to set up the scene, but C

To choose your motion method: 

1. Select the obj

2. Choose the Properties tra
method pop-up menu.  
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3. Select Still to create a non-moving object. 

4. If a warning message appears telling you that you are changing motion methods, move the slider 

hod 

to determine the quality of the conversion. 

Explicit Motion Met
In "Animating," you learned about key frames and the basic techniques for creating explicit key frames. 

ific information on key frames, refer to "Key Frame Animation

The sections that follow introduce additional ways you can animate scenes using explicit key frames. 

For more spec " and "Creating Explicit Key 
Frames."  

Tip Although you can use different motion
method per object. What you can do is dupli

 methods within a scene, you cannot use more than one motion 
cate objects and use different motion methods on each copy. 

(translating) an object to various positions along the 
each position. You can then apply the Bézier tweener 

to smooth the motion. 

otion using rotation rather than translation. You might want to do this using a motion path. 

s around its hot point. By default, an object or group's hot point is at the center of 
 anywhere, even some distance from the object. 

camera at an object and move the camera's hot point to the center of the 
tate the camera around its own hot point to animate a "fly-around" of the object. 
requires fewer key frames than creating a similar motion path in the usual way, 

l or better results. 

Then cloak and uncloak the objects to switch between them at the right moments. 

Animating with Rotation 
You generally animate complex motion by moving 
desired path of motion and creating key frames at 

However, when animating along simple, curved paths, it is often easier to offset an object's hot point and 
animate its m

An object always rotate
its bounding box. However, you can move the hot point

For example, you can point a 
object. You could then ro
This approach generally 
and produces equa

 
For instructions on working with hot points, refer to "Moving the Hot Point." 

Duplicating Relative Motion with Groups 
Duplicating an object or effect also duplicates its animation data (its key frames and tweeners). 

When key frames are duplicated in this fashion, the values of the original object's properties are copied 
exactly to the duplicate. In the ca f motion, this does not always produce the desired results. se o
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Suppose you have animated an object, and you decide to create a flock of identical objects, all moving in 
the same way. The following figure illustrates what happens when you duplicate your object and offset the 
duplicate from the original. 

 

 
'Since the numerical coordinates of the original object at the second key frame were copied exactly to the 
duplicate object, the two objects end up in the same location. 

You can avoid this problem by nesting the original object within a group before duplicating. When an 
object is animated within a group, its position is animated relative to the group, not relative to the global 
coordinate system. Therefore, when the group is duplicated and offset, the animated object in the 
duplicate group moves along its own motion path, within the group. 

 

' 
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Rotoscoping 
Rotoscoping lets you add live action or moving textures by incorporating existing animations or digitized 
videos (movies). You can use QuickTime or Microsoft Video AVI (Windows) files as texture maps or 
layers on objects, backgrounds, backdrops and light gels. 

Rotoscoping is a general term that describes using video selectively inside another movie. You can add 
live action or moving textures to your scene by rotoscoping with animations or digitized videos (movies) in 
your animation. Rotoscoping adds realism and visual excitement to your animations. 

You can use any movie file for rotoscoping. You can use movies in any of the following places: 

• Texture map or layer on an object:including in non-color channels, like Bump. 

• Background or backdrop. 

• Light gel. 

 

 
The movie is referenced as a separate file. Its path name is relative to the animation file in which it is 
used. When you move a scene file that uses rotoscop re to maintain the relative path to the 
movie file. 

Rotoscoping is visible on objects in Textured mode, but is not displayed on backgrounds, backdrops and 
in gels until you render the animation. 

ing, be su
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Synchronizing Movie Frames with Animation and Looping 

e. When you apply a movie, Carrara creates two key frames:one at the start and one at the end of the movi
You see the markers on the time track. 

 
The ending event marker is placed according to the duration of the movie:not the numbe
This means that the frame rate of the movie should be compatible with the rate of the a

r of frames it has. 
nimation. 

gin at the first frame (frame 1). You can start at a later frame by 
vie to the animation. 

To synchronize a movie with the animation: 

1. Set the current time bar to the moment (frame) where you want to synchronize the animation. 

2. Select the object or light onto which the move is rotoscoped. (This is not necessary for a 
background or backdrop.) 

3. Display the rotoscoped movie controls  

• For a texture map, display the Shader Tree Editor. 

• For a light, display Properties tray: Effects tab: Gel panel. Then choose Map from the 
pop-up menu. 

• For the background or backdrop, display the Properties tray, select the Scene from the 
Find list, then click the Effects tab and choose Background or Backdrop controls. 

4. Use the animation preview controls to advance to the movie frame you want synchronized with 
the current frame of the animation. 
 

It isn't necessary that the movie be
synchronizing the mo

 
To loop a movie: 

1. Apply the movie at the start of the animation. 

2. Drag the end-of-movie key frame marker out as far as you want the movie to continue. 

3. Double-click the track between the two movie key frame markers. 

4. Choose the Oscillate tweener. 

5. Select the Saw/Loop Wave Shape. 

6. Set the Up Phase slider to 100%. This rewinds the movie instantly after each cycle. 

ach 7. Adjust the Number of Oscillations slider to set the number of times the movie should repeat. E
up slope in the graph represents one time playing the movie. 
 
For precise work, you should calculate the correct number of oscillations based on the number of 
frames in the movie and the duration of the animation. You can adjust the end-of-movie marker, if 
necessary. 
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Motion Paths (Standard, Pro) 
Motion paths let you create and edit an animation in a scene from points on a straight or curving line. This 
gives you a visual representation of the movement of the scene. 

A motion path is a line curving through space that visually depicts both the path of the object during 
animation and the position of key frames. 

 

C

To assign motion path animation to an object: 

1. Select Properties tray: Motion tab: Motion panel: Motion Path. 

2. A dialog appears, warning you that you are about to change the motion method (from the default 
of Key Frame). Set the level of conversion you want. 

After you assign motion path animation, the Motion vailable. These tools appear 
ct an object with motion path animation 

rrara 

set the active plane. This is where the path will be placed. 

reating Motion Paths 
To move an object along a motion path, you assign a motion path method to an object, then create and 
edit the path. 

Path tools are a
whenever you sele

To draw a motion path: 

1. Position and orient the object at the start of the path. If you move the object later on, Ca
automatically redraws the motion path to start at the new location. 

2. Use the Working Box control to 
 

 
3. Select the Extend tool. 
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4. Use the Extend tool to place the turning points an
draws the path, using Bézier curves to connect th

d ends of the path on the active plane. Carrara 
e points. You can convert these curves to 

corners using steps given later in this section. 

e distance along the path is the 

 of the following methods: 

• To drag the object, Command/Ctrl click the object and drag it along the path. 

• To move the object to a specific position on the path, enter a value for Distance Along Path in the 
Properties tray: Motion tab: Motion panel. Carrara uses the unit of measurement set in File 
preferences (General Scene Settings). 

Moving the Motion Path 
After creating a motion path, you may want to move it to a different location in the scene. 

To move a motion path to a different location: 

1. Select the object that has a motion path. 

2. Select the Move Entire Path tool in the motion path tools. 

3. Click anywhere on the motion path and drag the mouse. 

 
You can edit the path and change the way the object moves along it in several ways: 

nd vice versa 

ls to add, delete, and convert points. Use the manipulation handles to reshape 

5. Select the Selection tool to stop drawing the path. To see your object move along the motion path, 
you must place the object along the path at key points. Th
animatable parameter. 

To move the object along the path use one

Modifying Motion Paths

• Delete points 

• Change points from curves to corners a

• Directly manipulate Bézier curves 

• Bank and reorient the object as it moves along the path 

Editing Points 
Use the Motion Path too
the Bézier curves. 

To delete points from the path: 

1. Select the Delete Point tool. 
 

 
2. nts on the path that you want to delete. 

r points: 

1. Select the Convert Point tool. 
 

Click the poi

To convert curve points and corne
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2. Click corner points to convert them to curve points. Click curve points to convert them to corner 
points. 

To directly manipulate Bézier curves: 

1. If the manipulation handles are not visible, enable Display Handles in the Properties tray: 
Motion tab: Motion panel.  

2. Drag the manipulation handles to reshape the path. 
 

 

TIP! You can show or hide the projections of the motion path on the working box by checking 
tion panel. When the handles and the 

es on the working box to manipulate the Bézier curve 
in a plane. 

ligning Objects 
ath appear more realistic by using the align and bank options. 

lly reorients itself to follow the path. For 
 direction of its motion, not the direction 

it maintains its global orientation throughout its movement along the path. 

Display Projections in the Properties tray: Motion tab: Mo
projections are visible, you can even drag the handl

Banking and A
You can make an object's motion along a p

When you align an object on the motion path, the object continua
instance, a toboggan aligned on a path would always point in the
of its original position. 

If an object is not aligned, 

 
Whe  the alig ment option is set, the object changes its orientation to follow the curves of the path. n n
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When you bank an object, it swings in and out as it turns corners and curves. 

To keep an object with a motion path aligned to global coordinates: 

1. Select the object. 

2. In the Properties tray: Motion tab: Motion panel, select Not Aligned. 

As the object moves along the path, its rotation around the X,Y and Z axis do not change. 

To align an object to the motion path without banking it: 

cally bank an object as it moves along the path: 

2. In the Properties tray: Motion tab: Motion panel, select Align and Bank. 

oordinate System 
When an object inside a hierarchy moves along its motion path, there are several ways to interpret the 
positions of the path in the scene. This is controlled by the Coordinate System radio buttons in the 
Properties tray: Motion tab: Motion panel .  

• Parent: the motion path follows the movements of the object's parent. This was the only option 
available prior to Carrara 4. In the example that follows where the sphere is a child of the cube, 
you can see how the sphere keeps moving around the cube as it goes right. 
 

1. Select the object. 

2. In the Properties tray: Motion tab: Motion panel, select Align. 

To automati

1. Select the object. 

3. Set the Maximum Bank slider to set the maximum amount the object can tilt on the path. A setting 
of 100% allows the object to bank 45° on each side. 

Motion Path C

 
• World: the motion path stays at the same place regardless of the object's parent movement.

the example below, the sphere is still a child of the cube but doesn't follow it as it goes right. 
 In 
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Non-Linear Animation (Standard, Pro) 
Non-linear animation allows you to create smaller animation clips that you can later repeat, layer, and 
combine to create a more complete animation.  

Creating an Animation Group 
ne animation group. In the case of a 

is already created for you 

 from the main menu. 

 group appears in the Sequencer. An animation track appears, with the items 
see the Animation Group and 
oom. 

enu Commands 

vements, head turns, and facial expressions. 
rward or backward in the timeline without 

If you right-click an Animation Group, Track, or editable clip in the sequencer, a context menu appears. 
 

To begin with non-linear animation, you have to first create at least o
figure, an animation group 

To create a new animation group: 

1. Select the object that you want to add to the animation group. 

2. Choose Animation > Create Animation Group
 
The new animation
contained in the animation group listed beneath them. You’ll also 
the associated objects listed in the Instance tab in the Assemble R

Track and Clip M
You can use an animation track to combine several clips that contain individual portions of the animation. 
For example, you can create an animation track for one character in your scene. The track can then 
include four individual clips that contain a walk cycle, arm mo
The beauty of this approach is that you can move the clips fo
affecting the contents of other clips. 

The command options that are available depend on whether you have an animation group, track, or clip
selected. 
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• Cut: Cuts the selected item and places it into the clipboard. 

 item into the current track. 

d track. 

 tracks can be grouped into. Drag tracks onto 

ate the items that are assigned to an Editable Clip. 

Using NLA Tracks 

Adding NLA Animation Tracks & Groups 

After you create an Animation Group, you can add one or more tracks to it. Each track can hold the 
animation clips for any object in your scene (or multiple objects, if you prefer). Tracks are used to layer 
animations&ldots; for example, you can use a track to override the motion of a hand in a walk cycle. 

To create a new NLA Track, 

1. Scroll through the Sequencer to find the Animation Group that you want to add a track into. 

2. Right-click on one of the tracks in the animation group. The menu described in "Track and Clip 

• Copy: Copies the selected item and places it into the clipboard. 

• Paste: Pastes the selected

• Delete: Deletes the selected item. 

• Duplicate: Duplicates the selected item. 

• Group: Groups two or more animation groups together. 

• Ungroup: Removes grouping from items that have previously been grouped. 

• Add NLA Track: Adds a new animation track below the currently selecte

• Add NLA Track Group: Creates a group that NLA
the group as needed. 

• New Editable Clip: Click this button to open the Clip Creation dialog. You are prompted to enter 
a name for the clip, and whether to use the current frame as a starting point, or a custom time 
that you enter. You also specify the length of the clip. After making your choices, click OK to 
continue. 

• Edit Clip: Allows you to anim

• Finished Editing Clip: Exits Edit mode and applies all changes to the editable clip. 

Menu Commands" appears. 
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3. Choose Add NLA Track from the menu. The new track appears directly beneath the track you 
initially selected. 

To group NLA Tracks: 

1. Scroll through the Sequencer to find the Animation Group that you want to add a track group into. 

2. Right-click on one of the tracks in the animation group. 

3. Choose Add NLA Track Group from the menu. The new group appears immediately below the 
selected track. 

4. Select and drag NLA Tracks into the group or create new NLA Tracks within the group. 

Animation Track Properties 

After you create and select a track, you will notice the following properties in the Assemble Room, in the 
Properties tray: General tab: NLA Clip Track panel. 

 
• Name: Assign a name fo

• Mute: Check this option 

r the track in this field. 

to turn the track off so that it has no affect on the animation. 

he track will use the offset between clips. 

• Blend: Check this option to make the track blend with previous tracks in areas where there is no 

want 
e track to the values of the clip. 

ms 
 

• Use Offsets: Check this option to determine whether t

clip, or in the blend zone of clips. 

• Mode: The mode decides how blending is applied. Choose Override if you want the tracks to 
override the values of the parameters that are controlled by the clip. Choose Additive if you 
to add the values of th

• Parameters: Click this button to open the Parameters Selection dialog, which displays the ite
that are included in the current NLA Track. Check or uncheck the items that you want to include
in the animation track. 
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• New Editable Clip: Click this button to open the Clip Creation dialog. Carrara prompts you to 
enter a name for the clip, and to choose the starting point for the clip. You can use the current 

g point, or enter a custom time in minutes, seconds, and frames (MM:SS:FF). 
th of the clip in MM:SS:FF format. After making your choices, click OK to continue. 

e Clips 

Clips are small segments of animation that can be moved forward or backward in time and looped over a 
n, clips can be layered with each other to combine several 

tion. For example you can create a clip that makes your 

r backward in time without affecting the walk cycle. A 
third clip can contain facial expressions … a blink, for example, that you can reuse in several places in 
the animation and move wherever you want the blinks to occur.  

The more you layer these clips, the more complex your animation becomes. Later, when you need to 
make changes to the animation, you only edit the clip that contains the portion you want to change. The 
other clips leave the rest of the animation intact until you edit other clips. 

When you first create a clip, it’s always editable because you have to create the desired actions within it. 
The Clip Creation dialog shown below appears when you create a new editable clip.  

time as a startin
Specify the leng

Using NLA Clips 

Creating Editabl

longer range of animation frames. In additio
individual motions into a single, fluid anima
character move its arms and legs to create one segment of a walk cycle (left foot, then right foot). Stretch 
the clip over time to make the character walk across the screen. A second clip can make the character 
look right or left, and you can move the clip forward o

 
To create an editable clip: 

t menu discussed in “Creating an Animation 

se this option to start the clip at the current frame. 

 the timeline if you enter an incorrect start 

6. Click OK to create the clip. 

1. Right-click in an animation track to display the contex
Group.” 

2. Choose New Editable Clip. The Clip Creation dialog appears. 

3. Enter a name for the new clip in the Name field. 

4. In the Start Time section, choose one of the following options:  

• Use Current Time: Choo

• Use Custom Time: Choose this option to start the clip at a specified frame in your 
animation. Time is entered in minutes, seconds, and frames (MM:SS:FF). Note that you 
can always drag the clip forward or backward in
time. 

5. Specify the length of the clip in minutes, seconds, and frames in the Length field. 
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Adding Animation to Editable Clips 

At this point, you’ve created an animation group that can contain one or more tracks. Each track can 
contain one or more editable clips. The next step is to edit the clip and add the keyframes necessary to 
produce the actions you want to include i
to create one segment of a wa

n the clip. For example, you can create the keyframes necessary 
lk cycle. 

To add animation to objects in an editable clip, follow these steps: 

lip that you want to change. Editable clips are bounded by a red box. 

te 

1. Right-click on the Editable C

2. Choose Edit Clip from the menu. The clip is highlighted in red in the NLA track, and is labeled 
Clip (Editable). 

3. Move the scrubber into the region of the editable clip. Add keyframes as necessary to anima
the objects to complete your desired animation sequence. 

4. When you are finished with the animation sequence for the clip, right-click on the Clip (Editable) 
clip in the NLA track, and choose Finished Editing Clip. 

Clip Properties 

When an editable clip is selected in the Sequencer, the General tab in the Assemble Room allows you to 
set the following properties: 

 
• 

•  

• ays the start and end times of the clip in minutes, seconds, and frames 

Name: Displays the current name for the editable clip. This field is editable. 

Color: Click the Color square to open a color picker. This allows you to choose a display color for
the selected track. The clip displays this color in the timeline when it is not selected. 

Time Range: Displ
(MM:SS:FF). 

• Blending: 
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o Auto Blend: Choose Auto Blend to au
previous clip and the next clip in the tra

tomatically compute the blend zone based on the 
ck.  

 
se offset to match the position of the foot between two walk cycle clips so that 

X, Y, and/or Z axes where you want 

X, Y, and/or Z axes where you want 
rotation offsets to occur. 

revious Position: Click this button to open the Match Previous Clip dialog 
following figure. 

o Start: Enter the location in the timeline where you want the blending to start. Time is 
entered as MM:SS:FF. 

o End: Enter the location in the timeline where you want the blending to end. Time is 
entered as MM:SS:FF. 

• Offsets:  

o Offsets Relative to Previous Clip: The offsets control how the position is matched 
between the end of the previous clip and the beginning of the current clip. For example,
you can u
the character starts the second walk cycle from the end of the first one.  

o Translation: Enter the location or locations on the 
translation offsets to occur. 

o Rotation: Enter the degrees of rotation along the 

o Match P
shown in the 
 

 
 
Options are:  

 Current Time: Matches the end position of the previous clip in the timeline to the 
curre on in the timeline. 

ip in the timeline to 

want 
to match. 

nt positi

 Clip Start Time: Matches the end position of the previous cl
the beginning of the current clip. 

 Previous Clip End Time: Matches the beginning of the current clip to the end of 
the previous clip in the timeline. 

 Reference Object: Click the button to select the reference object that you 
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 Match Translation: Check or uncheck options to match the reference object 
along the X, Y, and/or Z axes. 

 Match Rotation: Check or uncheck options to match the rotation of the 
reference object along the X, Y, and/or Z axes. 

clip, 

 Master Clip: Click this button to convert the editable clip to a master clip as described 

• Edit Clip/Finished Editing Clip: Click this toggle button to edit the animation in the current 
or to finish editing the clip. 

• Convert to
in "Creating Master Clips." 

ting Master Clips Crea

Maste  
displ t. 

Whe ce 
an ances of the same clip. For example, if you create a clip of a 
figure da
tim

To conve p to a Master Clip: 

1. In the Sequencer, click the Editable Clip that you want to convert. 

2. The General tab displays the properties for the editable clip. Scroll to the bottom of the properties 
and click the Convert to Master Clip button. The Clip Conversion dialog appears with the 
following options:  

• Loop Offset: Click to select an object in the clip that will determine how loop offsets are 
calculated. If you use a clip to create a loop on the animation, you still need to offset the 
motion inside the clip itself. The Loop Offset controls how this offset is calculated, which 
body part is used as a reference (foot or hip, for example) and the offset vector between 
two repetitions. 

• Parameters: Check or uncheck the items in the hierarchy that you want to include in the 
master clip. This controls which parameters are controlled by the clip. If the clip does not 
control some parameters then the current value of the track and/or previous track 
(depending on the blending options) are used for those parameters. 

3. Click OK to exit the dialog. If not previously present, a new Master Clip tab appears in the right 
portion of the screen, behind the General tab. This tab later allows you to adjust the loop offset of 
the master clip whenever you need to. 

Using Existing Master Clips 

When you create maste
following figure.  

1. Dra
2. Drag the clip o reposition the clip if necessary. 
3. Use the Loo

and to co

r Clips are displayed in the Sequencer in the Master Clips category. You can expand the section to
ay all Master Clips in your current projec

n you add multiple instances of a master clip into your scene, you can make changes to one instan
d the changes will apply to all other inst

ncing and apply it to several characters, you can change the timing in one instance and the 
ing will update in the other figures. 

rt an editable cli

r clips in your project, they appear in the Clips tab in the Browser, as shown in the 

g and drop any of the clips into the sequencer, and drop them onto any NLA track.  
forward or backward in the timeline t

p Offset settings in the General tab to control which body part is used for a reference, 
ntrol how the offset is calculated. 
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Blending Animation Clips 

To blend clips, extend the blending area to the left and right of the clip. If two clips overlap, the two 
motions are blended, much like a crossfade between audio or video tracks in a non-linear editor. 

Physics (Standard, Pro) 

 create realistic animations that would be excessively complex with key frame 
motion alon
other u  
existing anim

The physics motion method specifies that your objects accelerate, move, and interact in ways consistent 
with the laws of physics. 

Using physics allows you to
e. You can get objects to slide down a slope, bump into each other and bounce away, and 

seful motions. You can learn a lot about physics and how to use it by experimenting, or by viewing
ations. 

NOTE! Physics may not work with some of the modifiers. 

 

Physics and Key Frames 
Physics precludes arbitrary position settings in key frames. For example, if you apply Directional Force to 
get an object to fall, you can't also make it float in the air, defying gravity. The object must either obey 
physics (and fall) or float. 

When you assign physics to an object, Carrara removes all key frames except the starting key in frame 1 
that would arbitrarily set position or orientation on the object. Its other properties, like shading, remain 
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animatable with key frames. To preserve physics logic, Carrara won't let you move an object that has 
physics applied later than frame 1. 

You can't set position or orientation key frames for objects that use physics. You can, however, set key 
frames for the property values in the physics themselves. For example, you can accelerate an object, and 
then apply damping to stop it, and then accelerate it in a different direction. You'll learn more about this 
later in this section. 

Note Initial Velocity describes the object's inertia in frame 1. Therefore, this force cannot be changed with 
a key frame. 

You might want an object to respect physics, but still be animated with key frames. The primary 
application of this is to create an object that can move with key frames while having objects responding to 
physics bounce off of it. However, such an object will be unaffected by forces. 

Another possibility is to develop the animation using p s, and then translate the result into key frames 
y frame. 

You can change the physics settings to create key frames. Before you try this, you need to understand 
y. (Initial Velocity does set velocity, but it is only the initial 

For example, you can start an object moving with a Directional Force of X=10. A couple of seconds into 

ct will not stop at the moment of the key frame. It will continue 

Applying Directional Force is equivalent to an engine burn. Shut off the engines and the rocket coasts 
along on its trajectory. Without friction to slow it down or gravity to pull it down, the rocket continues on 
this ve

hysic
by setting the motion method back to ke

About Key Frames in Physics 

that the forces describe acceleration, not velocit
state. It cannot be used for a key frame.) 

the animation, change the Directional Force values to X=0 to create a key frame. 

When you play the animation, the obje
moving in X until it encounters a physical object (and rebounds) or some other force acts on it. 

This works a lot like a rocket in space because Carrara doesn't take into account friction or gravity, 
because there is no air friction or default gravity in Carrara. 

ctor at this velocity indefinitely. 

 
Next, the rocket rotates 90° and does another engine burn (this is the same as adding a new 
perpendicular Directional Force). The new trajectory is the combined effect of the initial acceleration and 
the secondary, perpendicular acceleration. The new velocity is the product of the old velocity and the new 
force (acceleration). 
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If you want to exert more control over transitions, you
in key frames just prior to a change of acceleration. 

 can use a Discrete tweener or use Damping Force 

For more information, refer to "Key Frame Animation." 

Applying Physics to an Object 
e. However, 

ffect.  
Carrara includes a number of different forces that you can use to affect objects in your scen
forces cannot affect an object unless you assign physics motion to the object or objects you want to a

To apply physics to an object: 

1. Rewind your animation to frame 1. 

2. Select the object to which you want to apply physics. 

3. In the Properties tray: Motion tab: Motion panel, choose Physics from the animation list.  
 

 
4. Carrara notifies you that existing keyframes will be converted. After you select convers

options, click OK to continue. 

5. The physics controls for the selected object become available in the Properties tray: Motion 
panel. These

ion quality 

 controls are described in the following section. 

6. Set additional options in the Properties tray: Effects tab: Physical Properties panel as outlined in 
Physics Effects, immediately following the next section.  

Physics Controls 

When you select physics as your motion method, a control panel appears in the Properties tray: Motion 
tab: Motion panel when the affected object is selected. This panel allows you to enter information on 
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how physics behave in your animation. You can experiment with modifying values to achieve the effect 
you want. 

 
• Initial Velocity: Set Initial Velocity options for one or more axes to determine the direction of the 

object's movement. You can enter positive or negative values. This setting applies directional 
motion to an object in frame 1. If no other force in
velocity indefinitely.  

fluences the object, it will maintain its initial 

 

 
• Initial Angular Velocity: Set Initial Velocity options in each dimension to determine the angle of 

the object's movement. You can enter positive or negative values. This setting applies angular 
motion to an object in frame 1. If no other force influences the object, it will maintain its initial 
velocity indefinitely. 

Physics Effects 

With the object selected, click the Properties tray: Effects tab, to view the Physical Properties panel 
and its controls. 
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Physical Properties appear in the Effects tab. 

• Collide with Other Objects: Specifies whether the specified object will collide or not. An object 

r 
ne. Note that this will increase system resource requirements. 

• Material: Allows you to specify common materials, which have preset values. These materials 
can be used as is, or you can modify their values as needed. 

• Density: Sets the object's density. 

• Bounce: Determines how far the object will bounce back after colliding with another object. A 
value of 0 sets no bounce, while a value of 100 specifies that no energy is lost in the bounce. 
Values over 100 are unrealistic although they can be used to create special effects. 

• Friction: Determines how slippery the surface of the object is. When other objects slide on an 
object with a high Friction setting, they will lose kinetic energy and come to rest faster. 

Adding Forces to the Scene 

s, each of which will be described in more detail in the sections that 
follow: 

• Directional Force: Propels an object in one or more directions. 

• Point Force: Draws an object or objects toward its center. 

• Damping Force: Dampens or counters the effect of another force. 

• Torque Force: Rotates an object or objects (like the blades of a fan) 

• Flow Force: Randomizes direction of one or more objects. 

To add forces to a scene: 

1. Use one of the following methods:  

with this option turned off can still have forces applied to it, but it will ignore geometry and move 
through other objects. 

• Collide with Hairs: Check this option if you want physics to interact with the dynamic hair in you
sce

After you apply physics to an object and set the physics controls and effects, you need to add one or 
more forces to the scene in order to animate the object with physics. 

There are five different types of force

2. Choose Insert > and select one of the Force options. 
 

 
3. Drag one of the physics tools into the scene. To apply a force to a single object or group, drag th

force on top o
e 

f the object in the hierarchy. 
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4. Each force type has its own force helper object that appears in the scene. This is a non-

lper object to change the direction of gravity. 

 follow. 

 

reviewing purposes, click the Simulate Physics tool. 

rendering wireframe representation of the selected force. You can select this object to orient the 
forces and set the effect properties. 
 
Reorient the physics he

5. Enter the effects settings for the force you've selected. The effects you add are specific to the 
type of force you are adding, and are described in the sections that

6. Repeat steps 1-3 to add additional forces if desired. You can apply any number of forces in any
order. 

7. To simulate the physics motion for p
 

 
8. Preview the animation to see how the forces influence object motion. You might want to extend 

the render range to see more action.  

'll 

 of Measurement for Forces 

electing File > Preferences> 

• Angle: degrees 

• Angular velocity: degrees/s 

• Volumetric mass: g/dm3 

9. After previewing, remember to rewind to frame 1. If you make changes without rewinding, you
be setting a key frame at this later moment of the animation. 

Units

The default values for the units of forces can be set or modified by s
General Scene Settings. 

Carrara uses the following consistent set of units of force: 

• Length: inches 

• Time: s (seconds) 

• Mass: g (grams) 

• Acceleration: m/s2 

 © 2008 DAZ 3D, Inc. 702 



Carrara 7 11 December 2008 

• Force: g*in/s2 

• Velocity: in/s. 

Directional Force and Effects 

Directional force applies a force to an object. It does not set velocity. Directional force accelerates an 
object in one direction to produce the effect of gravity:such as falling objects. 

Without direction force, the ball would continue along its original trajectory indefinitely. 

 
This trajectory is accomplished by adding a directional force. 

 
To set Directional Force Effects: 

1. After adding physics to your object and setting physics controls and settings, do one of the 
following: 

2. Select Inser D r ctional Force.  

. The following options appear:  

 a child 

t > i e

3. Drag the Directional Force tool onto an object or objects in the hierarchy. 

4. Open the Properties tray: Effects tab

• Strength: Sets the intensity of the force. 

• Rocket: This property is used to apply the force as a rocket, by making the force
of the object. 
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Point Force and Effects 

n object towards the force center. You can use point force to simulate the 
stial body. 

Point Force accelerates a
gravitational pull of a cele

 
It can also be used to simulate electromagnetism or gravity in space. You can also invert the force to 
repulse objects. 

 
To set Point Force Effects: 

1. After adding physics to your object and setting physics controls and settings, do one of the 
following:  

o Select Insert > Point Force.  

o Drag the Point Force tool onto an object or objects in the hierarchy. 
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2. Open the Properties tray: Effects tab. The following options appear:  

o Strength: Controls the intensity of the force. 

o Field Decay Rate: Controls the rate at which the force diminishes with the distance. 
 

 

Damping Force and Effects 

 

Damping force works like fluid friction in that opposes motion the same way a liquid surrounding an object 
would. 

Damping Force counters any other forces or movement working on the object. It will slow an object's
velocity. Regardless of what inertia an object has or what force is applied, damping counters it. 

 
The effect of damping is not immediate. It's like applying the brakes in a car. Even at maximum braking, 
the car takes a few feet to slow down and stop. 

 
To set Damping Force Effects: 

1. After adding physics to your object and setting physics controls and settings, do one of the 

• Drag the Damping Force tool onto an object or objects in the hierarchy. 

2. Open the Properties tray: Effects tab. The following options appear:  

following:  

• Select Insert > Damping Force.  
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• Strength: Controls the intensity of the force. 
 

 

Torque Force and Effects 

Torque Force applies a force that tends to rotate objec Use it to simulate a motor. 

To set Torque Force Effects: 

setting physics controls and settings, do one of the 
following:  

Open the Properties tray: Effects tab. The following options appear:  

• Strength: Controls the intensity of the force. 
 

ts. 

1. After adding physics to your object and 

• Select Insert > Torque Force.  

• Drag the Torque Force tool onto an object or objects in the hierarchy. 

2. 

 

Flow Force and Effects 

Flow Force creates randomized dir ctional motions. You can use Flow Force to give motion to autumn e
leaves swept up by the wind. 
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Physics Settings 
Additional physics properties can be applied to the entire scene. Select the Scene from the instance tab 
and click the Physics tab to display the following options: 

• Simulation Accuracy: High is better than Medium only when objects interact at an exceedingly 
rapid rate. 

edium levels, surface geometry is simplified to speed up 
t seem to move correctly, revert to the High setting 

e. Enter the amount 

Animating an Object's Shape 
e object, change its 

sha  create a key frame for both the original and 
the new ween" the original into the modified shape, 
thus creatin

The type of object determines which modeler you'll use, and therefore, what modifications you can make. 
For example, with the Spline modeler, you can edit the cross-sections, sweep path, and scaling envelope. 
With the volumetric primitives, like Fire and Cloud, you use sliders to change the character of the object. 

• Geometric Fidelity: At Low or M
calculations. If an object doesn'

• Gravity: Check the Use Default Gravity checkbox to add gravity to your scen
e in the value boxes provided. of gravity force to apply to the scen

Animating in Other Rooms 

You can animate an object by changing its shape over time. To do this, create th
pe using a feature such as the modeler or a modifier, then

shape. Carrara creates the transitions necessary to "t
g motion. 

 

Animating Spline Objects (Standard, Pro) 
You can change the shape of a spline object during animation using the Spline modeler. For complete 
information on the Spline modeler, refer to "Spline Modeling Overview." 

There are some limitations to the kinds of changes you can make in your models, but generally you can 
edit all cross-sections and points on an extrusion pat g envelope.  h or scalin

NOTE! You cannot add or delete cross-sections or points, or change the basic structure of the 
object. 

To animate the shape of a spline object, first create an object in the Spline modeler using cross-sections 
and a sweep path. 
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...then adjust the shapes in a different frame. 

 
To create spline models whose shapes you want to animate: 

1. Create all of the control points for the extrusion path. 

3. In the Spline modeler, adjust the points and curves of any cross-section, extrusion path, or 

You may not add or delete points or add a cross-section shape. 

a key frame marker to the spline object's Time Line. 

2. Create all of the cross-sections, with all of the control points. 
 
Start with the most complex shape your object will have during the entire animation. 

To animate the spline shape: 

1. Set the current time bar to the point where you want the key frame to occur. 

2. Select an object. 

envelope. 
 

 
Carrara adds 
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When you run the animation, Carrara fills in 
change of shape or movement. 
 

the action between the two shapes to show the 

 
You can change the tweener between the two event markers and set the transition method. 

Animating Vertex Objects 
In Carrara Standard and Pro, You now have two ways to animate vertex objects. You can change the 
shape of a vertex object during animation using Morph Targets in the Vertex modeler. For complete 
information on the Vertex modeler, refer to "Vertex Modeling Overview," "Vertex Modeling Basics," and 
"Vertex Modeling Techniques." 

Additionally you can create a skeleton  a vertex object and use the skeleton to animate the and attach it to
object. See "Character Animation" to learn about character animation using a skeleton.  

object during animation using Morph In Carrara 3D Express, you can change the shape of a vertex 
Targets in the Vertex modeler.  

NOTE! With the Vertex mo
operations such as loft, extrud

deler, you can only animate movement. You cannot perform any 
e, or sweep on an object that will add or remove vertices. 

ball Objects (Standard, Pro) 

n the Metaball modeler, refer to "Metaball Modeling

Animating Meta
You can change the shape of a Metaball object during animation using the Metaball modeler. For 
complete information o ." 

elete metaballs during the 

To create metaball models to animate: 

1. Create all of the metaballs for the object. Since you cannot add or d
animation, you must create all you'll need at the outset. 
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2. Shape the object into the desired form using any of the modeler's features. Since you can adjust 
the position of metaballs during the animation, the object you create at the onset doesn't have to 
be the final form. You can move metaballs to deform the object over time. 

To animate the metaball shape: 

1. Set the current time bar to the point where you want the key frame to occur. 

2. Select the object to be animated. 
 

 
3. In the Metaball modeler, change the position of the object's metaballs. 

 
You may not add or delete metaball . s
 

 
 
Carrara adds a key frame marker to the metaball object's Time Line. 
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You can now change the tweener b
method. 

Animating Environmental Primitives 
ironmental primitives are Fire, 

deler, the technique for anima

s of the environmental primitiv
er to see the results. 

4. etween the two event markers and set the tweener's transition 

The env Clouds, Fountain, and Fog. Although each of these primitives has 
its own mo ting them is the same. 

Animation es will not be visible when previewing. You'll need to do a test 
rend

want it to have at the start of the animation. 

 where you want the key frame to occur. 

3. Use the primitive's modeler or the features in the Properties tray to change the primitive's 
properties. 

4. Click the time bar at the point where you want the next frame of the volumetric primitive animation. 

5. Continue to adjust the properties to create new key frames. Set the completion slider. 
 
Some of these primitives have completion sliders which you can animate from 0 to 100%. 
 
For example, you might want the Fire to change the quantity of flames or its upward speed. 

• Fountain primitive with completion at 0%. 
 

To animate an environmental primitive's shape: 

1. Create the primitive and set the attributes you 

2. Click the Current Time bar at the point
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• Fountain primitive with completion at 50%. 
 

 
• Fountain primitive with completion at 100%. 

 

 
6. You can now change the tweener between these event markers to set the transition metho

example, to 
d. For 

get flickering flames, use the Oscillate tweener. 

Animating Object Motion 
You can use rotation, duplication, and cloaking to enhance some motion effects. 

Refer to "Animating with Rotation" to learn about rotation or "Duplicating Relative Motion with Groups" to 
learn a

For instru ns on working with hot points, refer to "Moving the Hot Point

bout duplication. 

ctio ."  

NOTE! You can rotate an object around its hot point or around its center. To use the hot point, be 
sure it is set in the Properties tray: Motion tab: Transform panel: Rotate around control. 

Cloaking an Object 

When you want an object to enter or exit (appear or disappear) during the course of your animation, you 
use a technique called cloaking. 

Cloaked objects are visible and can be manipulated in the 3D view; they simply are not included in the 
rendering of your animation. 

You can take advantage of cloaking to switch one version of an object for another version of the same 
object. This is advantageous when the two versions have contradictory properties, which you need at 
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dif ok the same, occupy the same space, and 
cloak and unc he exchange from the one to the other will be seamless. 

To cloak or uncloak an object at a specific point in time: 

1. Select the object. 

2. Click on the key frame marker for that object on the Time Line. 

3. Enable or disable the Visible checkbox. 

Animating Shaders 
Animating shaders opens a wide range of possibilities. You can animate virtually any type of change to a 
shader that you can imagine, from a simple color change to a shifting geometric pattern. (You can even 
make a  marble to metal.) For complete information 
on s

ferent times of the animation. As long as the two objects lo
loak in the same frame, t

n object appear to change from bricks to glass or from
haders, refer to "Creating and Editing Shader Trees." 

 in a ch

The only limitation is that you cannot replace one shader component with another during the course of an 
animation. You cannot, for example, replace a Wood function with a Spots function at a particular point 
along the Time Line. Thanks to the flexible, modular nature of the Shader Tree Editor, this turns out to be 
only a minor limitation. 

To animate simple changes to shaders, use the Shader Tree Editor to adjust the parameters of individual 
shader components at specific points along the Time Line. Examples of parameters you can adjust 
include: 

• Colors 

• Values for attributes like transparency and shininess 

• Procedural function parameters, like the number of squares ecker pattern, or the 
undulation of the veins in a wood pattern. 
 

 

Animating Shaders with the Multi-Channel Mixer 
The Multi-Channel Mixer component allows you to animate more drastic changes to an object's shader. In 
the following example, a Multi-Channel Mixer is used to create a shader which animates gradually from 
wood to glass. 
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Rotoscoping in Non-Color Shader Channels 
The most common use of rotoscoping is in a shader's Color channel, where it allows a movie to be played 

r, rotoscoping can also be used in other shader channels to create on the surface of an object. Howeve
stunning visual effects. See "Rotoscoping." 

 in an object's TranThe example that follows illustrates the use of a movie sparency channel. 

The three animation frames in the right column show a doorway materializing from the floor up. This effect 
ovie in the doorway's Transparency channel. was achieved by playing a grayscale m

 
The three corresponding frames from that movie are shown in the left column. The white region in each 
frame represents the portion of the doorway that is transparent. The black region represents the portion 
that is opaque. 

Animating with Modifiers 
Modifiers allow you to dynamically alter the shape of an object depending on the type of modifier. 

Modifiers let you give objects sets of instructions that give them an activity during the animation or that 
dynamically alter the shape of an object. Modifiers al o number of key frames you need to 
create and let you create actions that are not otherwi ssible. 

 shape of entire 

s  reduce the 
se po

Modifiers are especially useful in animation because they can be used to animate the
groups, which cannot be edited directly in a modeler. 
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Types of Modifiers 
• Modifiers like Stretch, Bend and Twist, Explode, Dissolve, and Shatter produce interesting 

animated effects that cannot be achieved by other means. These do not need any special 
instructions. 

• Some modifiers, such as Bounce and Spin, automatically assign complex actions to an object. 
greatly reducing the number of key frames you need to create. These and the other modifiers are 
explained in detail in "Modifiers." 

• Other modifiers, such as Point At and Track, define or modify the motion of one object based on 
the location or motion of another object. 

• The physics modifiers allow objects to move and interact as though they obeyed the laws of 
physics. The physics modifiers have special characteristics. which are described in "Physics." 
(Standard, Pro) 

Character Animation (Standard, Pro) 
In "Animating," you learned about key frame anima
Carrara. In "

tion and were introduced to the animation features in 
Animation Techniques," you learned about additional animation techniques. 

This chapter discusses the character animation for vertex objects. 

en 

A bone is a helper object made of Wireframe that is visible when you manipulate a scene but does not 
show up in the final rendering. 

A bone's articulation (or joint) is represented by an octahedron around the bone's center of rotation. This 
is also the hot point for the bone. This joint cannot be moved independently from the bone. 

A skeleton is a hierarchy of bones. You make a skeleton by inserting bones in the scene and dragging in 
the Hierarchy section of the Sequencer to create associations (see "Working with Objects

In Carrara 6, bending an arm is as simple as defining an articulation for the elbow and rotating the 
articulation; the vertices of the arm will automatically adjust their positions to make the bend appear 
natural. To animate a character, you simply need to create a skeleton, attach it to the character, and th
animate the skeleton. 

Working with Bones 

") or by using 
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the Bone tool. When a bone is a child of another bone, two lines pointing to its parent bone are added to 
its wire frame display. 

• The root of the skeleton is the top-most bone of the skeleton's hierarchy: 
 

 
• Two bones: 

 

 
• A complete skeleton: 
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The Bone Tool 
You can easily insert a bone into a scene. 

You can insert a bone using one of the following methods: 

• Use the Insert > Bone command. 

• Drag the Bone tool's icon to the scene. 
 

 
• Select the Bone tool, and then click inside the scene. 

• When you select the Bone tool you can do the following: 

o Click and drag in the scene to have the newly inserted bone follow the mouse. 

o If another bone is selected, the new bone is created as a child of the selected bone. This 
allows you to swiftly create skeletons.  

o If you click on a bone to move it around, use the Ctrl/Cmd key to constrain the movement 
to the Z axis instead of the X/Y axis. This makes it easier to move bones into position. 

ou click to place the next bone, hold the Shift key while you drag to change its 
tead of moving it. 

o When y
size ins

TIP! Creating a skeleton with the Bone tool is easier when using the four view mode. See 
"Displaying Multiple Camera Views." 

Selecting a Bone 
A bone can be selected with the Selection, Scale, and Rotate tools, or with the Bone tool. When you are 
working with the Bone tool, clicking a bone selects the existing bone rather than creating a new bone. 
This allows you to quickly create a new limb on a skeleton without changing tools. 

nt colors. All these colors can be changed in the Preferences dialog, 
unde w Colors: 

• By default, the Wireframe of a bone is drawn with the Primary Wireframe color.  

• When a bone is selected, it is drawn with the Selected Object color (yellow, by default).  

• The children of a selected bone are drawn with the Secondary Wireframe color (cyan by default).  

Changing the Size of a Bone 
One way to change the size of bones while you are creating them is to press the Shift key while dragging 
to position your bones. This scales the current bone to the desired size. You can also change the size of 
the selected bone or joint in the Properties tray: Motion tab: Transform panel. Enter a new value in the 
Overall field. Check the Propagate Scaling option to apply the new value to all child bones beneath the 
currently selected bone. The Propagate Scaling option also works when you set a new scale and then 
add additional child bones. 

Bones are represented by differe
r 3D Vie
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It is possi
then ch

To adju

1. ny children. 

2. Open the Properties tray: Effects tab and under Bone, enter a new Display Size value. 

ble to rescale a bone with the Scale tool. But once a bone has children, the distance between 
anges and the skeleton doesn't match the object it is going to control. 

st the display size of a bone without affecting the rest of the skeleton: 

Select a bone that does not have a

 

 

Working with Joints 
Once you have created your skeleton, you usually have to move the joints to put them in the right position. 

f a skeleton for you automatically.  

In doing that, if you do not rotate the local space of those joints and you may have difficulties setting up 
constraints, for instance. 

Orienting Joints Automatically 
A tool can orient the joints o
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Choose the Animation > Orient Joint command, and check or uncheck the following options: 

 
• Orient Children Joints: Check this option to orient joints automatically. 

• Auto-resize Joints Display: When enabled, bones are automatically resized according to the 
starting and ending points of the mouse position. When disabled, bones are created at a default 
size and you can resize later. 

 the Lock Children mode. 
e, without moving the children. See "Arranging

Orienting a Joint Manually 
If you need to manually adjust the orientation of one or more joint, you can use
This mode lets you rotate a joint and adjust its local spac  
Objects Without Modifying its Children." 

How to manually orient one joint: 

1. Select the joint that you want to align. 

2. Click the Lock Child Objects icon in the main toolbar area. 
 

 
3. Select the Rotation tool. This tool shows a small local space (three different colored lines meeting 

at a center point) in the center of the rotation sphere. 

4. Rotate this local space to align it the way you want. 
 

 

Working with Skeletons 
s of the bones change the geometry of 

d to as a skinned object. 

ing: 

• You cannot directly modify the position, scaling, or orientation of the object. Instead, you need to 
change the position, scaling, or orientation of the root of the skeleton. 

You can attach a skeleton to a vertex object so that the movement
the object. A vertex object attached to a skeleton is referre

When an object is attached to a skeleton, you’ll notice the follow
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• The position, scaling, and orientation of each bone defines the reference position of the bone. A 
bone can be sent back to its reference position at anytime, even after the skeleton has been 
detached from the object. 

• The position of any single vertex of the object depends upon the position of several bones of the 
skeleton. The bones affecting the position of that vertex influence it by a percentage. The sum of 
the influences of the bones of the skeleton over a single vertex is always 100%. See "Editing the 
Bones Influences." 

Attaching a Skeleton 
The Animation > Attach Skeleton command attaches a skeleton to one or more vertex objects. You 
cannot use this command on a skeleton that is alread ct. y attached to an obje

As the geometry and position of the attached objects depends only on the position of their skeleton, the 
Attach command sets the animation method of those objects to still. 

NOTE! Since bones can only deform ve
vertex objects by the attachment process. 

rtex objects, other objects are automatically converted to 

To attach a skeleton: 

iew, or in the hierarchy, to select one or more vertex objects or a 
jects. If you select a different type of object, it will be converted to a 

tach the bones. 

. The Attach Skeleton dialog appears. 

 

o  checked, only the selected vertex objects will attach to the skeleton. Descendants 

1. Create a skeleton and move it inside the object (or objects). Select one bone of the skeleton. 

2. Shift+click the objects in the 3D v
group containing vertex ob
vertex object when you at

3. Choose Animation > Attach Skeleton

4. If desired, check the Only attach selected objects option. 

 When
of the selected object will not attach.  

o When not checked, the skeleton will affect all of the vertex objects that are descendants 
of the selected objects or groups. 
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Detaching a Skeleton 
aIf you w nt to modify the geometry of your vertex object, you need to detach its skeleton. 

The Animation > Detach Skeleton command releases an object from the influence of its skeleton. It also 
restores its geometry the state it was in before you applied the Attach Skeleton command.  

To detach a skeleton: 

1. Select one or more skinned o
in the 3D view or in the hierar

bjects or a group containing skinned objects (Shift+ click the objects 
chy). 

You can set the position and orientation of one or more bones to the values they had when the bones 
were a

le Room, select the object to which the skeleton is attached. 

bjects. Inverse Kinematics provides 
create realistic animations. 

No
to a parent o ent can also propagate up the hierarchy:from the 
chi
propagate fro verse Kinematics. Refer to "Linking Objects

2. Choose Animation > Detach Skeleton, and click the checkbox if desired. You can choose to 
detach only the selected objects. 

Restoring Bones to Their Original Positions 

ttached. 

To restore bones to their original position: 

1. In the Assemb

2. Choose Animation > Send Bones to Reference Position. The bones return to their original 
values and the object moves accordingly. 

Inverse Kinematics 
Inverse Kinematics is a specialized modifier that is applied to linked o
the versatility of child-to-parent control. It reduces the time it takes to 

rmally, movement is transmitted downward from parent to child in the hierarchy. When you link a child 
bject and apply inverse kinematics, movem

ld to the parent. This means that when you move a child object, the parent follows. Motion cannot 
m a linked child to its parent without In " for 

informatio n rties and constraints. 

The movement is affected by the type of link property and constraint you apply, for example, a Lock, 
Slider, or 2D link can constrain the movement of the child object in relation to the parent. 

If you use an arm as an example, linking the objects that make up the arm in a hierarchical structure and 
placing the hot points at the joints, you can rotate the arm at the shoulder or elbow, and everything below 
that joint (toward the hand) moves accordingly. 

To take a simple example, assume that an arm is made of three parts: shoulder, elbow, and lower arm. 
With Inverse Kinematics, you can move the lower arm, which in turn forces the elbow and shoulder to 
rotate and move to accommodate. 

n o  link prope
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Before applying the Inverse Kinematics modifier to an articulated object, you must link the objects that 
make up the model and define properties and constraints for the movement of each child in relation to i
parent. These co

ts 
nstraints should describe the desired range of motion for each part. 

Refer to "Linking Objects" for information on linking one object to another. Refer to "Applying Constraint 
Properties" for information on setting constraints. 

 

NOTE! You must apply Inverse Kinematics to the last child object in the link chain. You can also 
apply it to other children higher up the link chain. Then if you start a movement farther up the chain, 
objects higher up the chain move as well. 
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Tracking an Object 
When animating a character with inverse kinematics, the object with the IK behavior can track another 
object (called the target). For example, you can make a foot track a foot step object. This way, as you 
move the character, the inverse kinematics will keep the foot at the position desired for the foot step 
(generally by bending or extending the knee). If the target is not reachable, the IK chain (the leg) extends 
itself to the maximum possible and points toward the target. See "IK Chains." 

IK Terminators 
When you use the Inverse kinematics behavior, the propagation of the movement stops by default on the 
last parent that has a constraint. Using the IK terminator makes it possible to stop that propagation earlier. 
For example, if you have a skeleton with constraints on every bone and an Inverse kinematics behavior 
on the hand, moving the hand will also move the spine. But if you apply the IK terminator to the shoulder 

t is to make the arm reach for an object. 

Since articulations in the human body only allow rotations, positioning the arm using forward kinematics 
involves first rotating the shoulder, then the elbow, and finally the hand (and generally starting over 
because the hand is not really where it was supposed to be). 

On the other hand, using inverse kinematics (IK) automatically calculates the position of the elbow and 
the shoulder so that the hand is as close as possible to where it is supposed to be. The hand and the 
joints it affects when using IK constitute what is called an IK chain. 

Characters typically use inverse kinematics to position intermediate joints when you select and move or 
rotate a body part. An inverse kinematic chain allows you to position all parts of a leg from the hip down 
when you move a foot. 

Creating an Inverse Kinematics chain with its target is very easy with the IK Chain tool, located in the left 
toolbar area. 

bone, moving the hand will only move the arm. 

IK Chains 
When animating a character, a common movemen

 
For example, you would use the following steps to create an IK chain for the left leg of a character: 

1. Use the Selection tool and click on your character’s left hip bone. 

2. Click the IK Chain tool, and then and click on the left foot bone. Carrara automatically creates an 
IK chain for the left leg, and inserts in the scene an IK target object that the left foot will follow. 
 
The IK tool automatically adds: 

• A ball joint constraint on each bone of the chain that didn't have a constraint. Ball joint 
constraints allow you to rotate joints, but not move them (see "Arranging Objects with 
Constraints" and "Type of Constraintss "). 

• An IK terminator behavior (see "IK Terminators") on the bone at the beginning of the 

hape. 

chain (the left hip in the example). 

• An IK target object. This is an object similar to the target helper, but with a different s
See "Tracking an Object." 

 © 2008 DAZ 3D, Inc. 723 



Carrara 7 11 December 2008 

atics behavior (see "Inverse Kinematics• An Inverse Kinem ") on the bone at the end of the 
) set up to follow the IK target object that was created. chain (the left foot

Representation of IK Chains 

In the 3D view, IK chains are represented by a line between the first and the last bone of the chain. 

 
Like the other modifier wireframes, the display line can be hidden, displayed only when the object is 

rse selected, or always displayed. To toggle between those states, select the bone with the Inve
Kinematics behavior, select the Modifiers tab in the Properties tray, and then click on the direct 
manipulation icon of the IK behavior. 

 

Limitations of IK Chains 

Two IK chains can share one bone, but o
have one IK chain consisting of the hip, knee, an

nly when they follow each other. For example it is possible to 
kle, and another chain between the ankle, foot, and toes 

as shown in the following image. 
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Any other case of sharing a bone between two IK chains will result in the unwanted motion of one chain 
when moving the other. For example, the IK chains f should not join at the pelvis. One should 

When a character is walking, the feet are supposed to stay on the ground. But moving the character up 
and down will move the feet above or below the ground. If the character has an IK chain on each leg, 
adding a target position for each foot will ensure that moving the character down bends the knees and 
keeps the feet on the ground. Any object can be used as target, but in most case one that is not rendered 
(like the target helper) is more suitable. 

To specify the IK target: 

1. Select the object with the IK behavior (such as the foot). 

2. Click on the Properties tray: Modifiers tab. 

3. Click on the Select button in the IK settings to choose the target. The target can be any object in 
the scene, but generally the IK target object works best. 

4. To turn tracking on or off, click on Enable tracking. This property can be animated so the IK 
chain doesn't have to track the target during the entire animation.  

or the legs 
end on the left hip, while the other ends on the right hip. 

IK Target 
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Editing the Bones Influences 
When you attach a 
the skeleton affec
adjust the calcula

skeleton to a vertex object, Carrara automatically computes how the different bones of 
t the position of the different vertices of the object. Additionally, Carrara allows you to 
ted influences to fine-tune the results. 

n. 

uences: 

ainting tool to quickly assign or remove influence for some of the points. 

l of the vertices. 

2. Set the Edit Mode in the Model Room to Animation Mode. 

3. Select the Weight Painting tool.  
 

After you attach a skeleton and a vertex object, you can switch to the Vertex modeler. The skinned object 
is displayed in the Vertex modeler with the deformations produced by the current position of its skeleto
The tools and commands that allow you to modify an un-skinned mesh are disabled, and you can only 
change the influences of the bones on the vertices. 

You have two ways to edit the bones infl

• Use the Weight P

• Use the slider to control precisely the influence at the leve

Using the Weight Painting Tool 
To use the Weight Painting tool: 

1. With your boned object selected, switch to the Model Room. 

 
4. Select a bone, using one of the following methods:  

• Choose a bone from the Bone menu in the Properties tray ( in the Weight Painting 
section). 

• Press the Control key while you select it directly in the view.  

5. Choose the following settings as needed for the Weight Painting tool:  

• Mode: Choose Add to increase the influence in areas, or Subtract to decrease the 
influence. 
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• Brush Size: Sets the radius of the brush. Increase or decrease the slider as needed. 

• Strength: Decrease the setting for more subtle changes, or increase it for stronger 
changes. 

• Smoothness: Controls the amount of falloff in the brush.  

• 3D Sphere Brush: Check this option to make the brush aware of the depth. With this 
option, you can paint locally on the mesh without modifying influences somewhere behind 
this area. 

6. The influence for the selected bone is represented by a color range: yellow for strong, orange for 
medium and grey for no influence. Use the brush directly on your model to modify the influences 
like a paint tool. You will see the influence and the position of the model being updated in real 
time.  
 

 

Weight Painting on DAZ Studio and Poser Figures 

You can also use the Weight Painting tool to edit bone influences on DAZ Studio/Poser figures. For 
hen you can edit weights for the selected body example, vertices can be selected by morph area and t

part with the weight painting tool.  

 
To use the weight painting tool on a DAZ Studio/Poser figure: 

1. Load the desired figure into a Carrara scene. 

2. Select the figure in the Assemble room, and switch to the Model room. 

3. Switch to Animation mode. 
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4. Choose Select > Select By > Morph Area. The Choose a Morph Area dialog lists all morph 
areas in the selected figure. Each of these morph areas corresponds with one of the bones in the 
DAZ or Poser figure. 

5. Select the morph area/body part that you want to influence and choose OK. The vertice
associated with that part are selected and highlighted. 

s 

6. Select the Weight Painting tool.  
 

 
 
The Weight Painting options appear in the Properties tray. 
 

 
7. Select the bone that you want to paint from the Bone menu. 

8. Choose the following settings as needed for the Weight Painting tool:  

• Mode: Choose Add to increase the influence in areas, or Subtract to decrease the 
influence. 

• Brush Size: Sets the radius of the brush. Increase or decrease the slider as needed. 

• Strength: Decrease the setting for more subtle changes, or increase it for stronger 
changes. 

• Smoothness: Controls the amount of falloff in the brush.  

• 3D Sphere Brush: Check this option to make the brush aware of the depth. With this 
option, you can paint locally on the mesh without modifying influences somewhere behind 
this area 

9. In the Figure Options section, select the channel that you want to influence. The availability of 
these options depen  on the bone you select:  

re applied when the selected bone is 

hen the selected bone is 

• Negative Bulge: TBD 

ds

• Rotation: Allows you to paint influences that a
rotated. 

• Smooth Scale: Allows you to paint influences that are applied w
scaled. 
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• Positive Bulge: TBD 

• In the Axis section, select the axis of Rotation, Negative Bulge, or Positive Bulge. 

10. Paint on the model with the weight painting tool to modify the existing influence as desired. 

s 

You can save a modified weight map so that you can later reuse it in another scene. 

To save a modified weight map: 

the Model room. 

2. In the Weight Map section, click the Save button. The Save Weight Map As dialog appears. 

3. Locate the folder that will store your modified weight map. 

4. Assign a name to your file and click Save. Weight maps are saved with a .cwm extension. 

Loading Modified Weight Maps 

You can save a modified weight map so that you can later reuse it in another scene. 

To save a modified weight map: 

1. Select the figure that you want to modify. 

2. Switch to the Model room, and select the Bones tab. 

3. From the Weight Map panel, click the Load button. The Load Weight Map dialog appears. 

4. Use the Look in menu to select the folder that contains the weight map you want to load. 

5. Highlight the file and click Open ps are added to the figure. 

Whe
informatio nce of each bone that affects one or more selected vertices. Each bone's 
influen

Saving Modified Weight Map

1. After your weight map is modified, choose the Bones tab in 

. The new weight ma

Editing the Influences Over One or Many Vertices 
n you are in Animation Mode in the modeler, the Bones tab of the Properties tray displays 

n about the influe
ce is represented by a slider with the name of the bone. 
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Aft  the Model room, switch to the Bones tab in Animation Mode, and 
use the 

A 

fluence, select the bone from the Remove Bone pop-up 
 remove the last influence. 

e other bones will 
p the sum of the influences on each vertex to 100%. 

d by a cylinder. The shoulder bone is 

fter they were attached (horizontal skeleton). In the 
s to bend the arm and each image shows how changing 

 the third, fourth, 
fluence values on each vertex. 

er you select one or more vertices in
controls as follows: 

• Add Bone: To add a new bone's influence, select a bone from the Add Bone pop-up menu. 
new slider will be added to the list. 

• Remove Bone: To remove a bone's in
menu. Note that you will not be able to

• Bone sliders: To change the influence of a bone, select its slider and change its value. The 
anges as you modify the value. Also, the sliders of thposition of the vertices ch

be automatically adjusted to kee

Examples of Influence 

The following screen shots show the skinning of an arm represente
on the left of the images, the elbow in the middle and the wrist on the right. 

The first image shows the arm and its skeleton just a
other images, the elbow is rotated by 90 degree
the influences affect the skinning.  

The second image shows the skinning with the default influences on each vertex while
and fifth images show extreme in

 
The next image shows the shoulder's influence set at 100% for each vertex. Note that the arm stays 
horizontal. When the elbow's influence is set at 100% for each vertex, notice that the arm follows the 
elbow and becomes vertical. 
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When the shoulder and elbow influences are set at 50% for each vertex, the arm takes an average 
position.  

 

NOTE! After you attach a skeleton to an object, some commands become unavailable such as 
copy, paste, duplicate, flip, and group. When the current selection contains an item on which a command 
cannot be performed, that command becom  unavailable. If you must perform the command on the item, es
you must first detach the object from its skeleton. 
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Tips and Tricks 

• You can convert any object to a vertex object by double-clicking it in the Assemble room and 
using the Edit > Convert to Other Modeler command. 

• The geometry of the object you want to skin must have enough vertices. To increase the number 
of vertices, use the Subdivide command of the Vertex modeler. 

• You can put a skeleton in the Browser by dragging its root from the Hierarchy section of the 
Sequencer to the object's tab in the Browser. 

• Creating a skeleton is easier when using the four-views mode and inserting new bones in the top, 
left, and front views. 

• To speed up the interaction with a complex skinned model, open the Interactive Renderer 
settings, and set the silhouettes to Boxes Only. 

• To resize a skinned object, resize the root of its skeleton. 

• To change the geometry of a skinned object, select the object, detach it, edit it, select a bone of 
its former skeleton, and send all the bones to their reference position, then select the object and 
choose the Animation> Attach Skeleton command. 

• To change the hierarchy of the bones, use the Hierarchy tray the way you would with any other 
object or group. 

Dynamic Hair and Fur (Standard, Pro) 
One of the most exciting new features o s the addition of dynamic hair and fur: hair that moves 

For Carrara 3D Express users, dynamic hair and fur can be loaded into Carrara 3D Express and rendered, 
but cannot be modified. 

About Dynamic Hair 
Dynamic hair is different than geometry-based hair in that it is strand-based. There are two types of hair 
strands: guide hairs and generated hairs. Guide hairs help you style and shape the hair. Generated hairs 
are the hairs that actually render in your scene. When you move a guide hair, the generated hairs move 
in the same direction. 

Another key difference between dynamic hair and geometry-based hair is that you won’t see a true 
representation of dynamic hair until after it is rendered. During render time, Carrara examines all of the 
properties that you assign to the hair: thickness, length, color, hair scale, and much more. All of the 
properties are calculated out for the final render. As a result, you may need to perform an occasional 
render while you are styling the hair to ensure that the final result appears the way you intend it to appear. 

Adding Hair to an Object 

f Carrara 6 i
realistically when you animate a feature, and that responds to forces and collisions with other objects in 
your scene. 

The Hair tool, located in the main toolbar, allows you to add hair to an object. Simply drag the Hair tool 
and drop it on to an object in your scene. 
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There are two ways that you can add hair to objects, depending on whether or not the geometry has UV 

 challenges in regards to hair placement. 

have 
the surfaces of a UV-mapped object you may also 

bject into the Carrara scene. 

the icon onto the object to which you 

maps assigned. 

• Geometry-based objects without UV maps present some
If you change the geometry of an object that does not have UV maps, whether by adding or 
removing polygons or turning subdivision surfaces on or off, the hair will move to unpredictable 
places on the object. 

• When objects are UV mapped, there is less impact when you make changes to hair that you 
already placed. For example, if you subdivide 
need to modify the UV maps. However, the hair still appears pretty much where you expect it to 
appear. 

To add hair to an object: 

1. Use the Content Browser to load your figure or o

2. From the main toolbar, select the Hair tool. Drag and drop 
want to add hair. The Hair First Setup dialog appears. 
 

 
3. In the Hair Placement section, select one of the following options: 

t 
 

• Choose Geometry Based if your object does not have any UV mapping assigned to it. 
ry primitives. 

ing options: 

sociated with the hair guides. This is the most common option. 
This option offers more customizable control than the Texture Map option. 

• Choose Texture Map if your object has UV maps assigned. You will be able to use the 
UVs and material assignments to control density maps. 

• Choose UV Based if your model is UV-mapped. Most objects that are compatible with 
DAZ Studio or Poser have UV Mapping assigned to the geometry, making this the mos
likely choice when importing DAZ content. If your object comes with texture maps, it is
probably UV mapped. 

Typical cases for this might be geomet

4. In the Density section, choose one of the follow

• Choose Guide Based if you want to control the density of the hair by increasing or 
decreasing the settings as
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• If you choose the Texture Map option, click the Manage Density Maps button to create 
and choose the size of the density map that you want to use. Instructions on how to use 
this dialog are described in "Managing Density Maps." 

5. Check or uncheck the Start with empty grow region option as desired: 

• When unchecked, hair will grow from all polygons in the object. 

• When checked, all polygons are left unassigned so that you can select specific polygons 
that will generate hair. 

6. Choose OK to complete the hair setup process. 
 
You are immediat
Tool, General, an

ely transferred to the Model Room, where you can set hair properties in the 
d Dynamics tabs. The Tool tab is automatically selected for you in the right side 

r. of the interface. You’ll also notice a special Hair Toolbar beneath the menu ba

 
cIf your object 

• ir they are colored grey when in the hair room. When polygons 

• strands are colored and others are 
ide hairs, which allow you later to 

ontains hair, when you look closer at the hair you’ll notice the following: 

When polygons cannot grow ha
can grow hair they are highlighted a different color. 

When you zoom into the hair on the object, notice that some 
white with a dot on the end. The white/circled hairs are the gu
style and comb the hairs more realistically. 
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Managing Density Maps 
When you initially set up your hair object as described in "Adding Hair to an Object," you are asked if you 

k the Manage Density 
Maps ure. 

Den
can us

esh, which can cause overlapping UVs. 

• Use the Geometry-based option in lieu of the UV map option. 

• Edit the UV mapping in the UV editor so that you no longer have overlapping UVs. Then apply the 
hair to the mesh. 

The density of the hair determines the number of hairs that will be generated for each guide hair. When 
you initially create a hair object, the density is set to the maximum level (or 100%). 

want to manage the density of the hair with guides or with density maps. If you clic
 button you see the Manage Density Maps dialog shown in the following fig

sity is based on the type of UV mapping that is set up on your objects. It is important to note that you 
e a single global map only if the UV coordinates on your object do not overlap. Polygons share 

UVs when the texture is mapped in two different places in your m
In cases such as this, there are a few ways to address it: 

• Create more than one density map for your object, assigning different density maps to the 
shading domains in your object. This will only work as long as the UV coordinates do not overlap 
in a single shading domain. 

 
To manage density maps: 

1. The Maps section listed in the upper-left corner of the dialog initially lists two maps: a global map
and a new map. 

• Use the global map if you want to ad

 

d hair to the entire object. By default, global maps 
use an image map size of 256 by 256 pixels. Use the Size drop-down menu to select any 
size (in a power of 2) from 64 by 64 pixels to 2048 by 2048 pixels. Larger maps provide 
finer densities. 
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• You can also create additional m
shading domains in your object.

aps with different resolutions, and apply them to other 
 This allows you to vary the density of the hair from one 

part of your object to another. To define a new map, click the New Map button in the 

ough the Shading 
 

Maps panel. A new button named “New Map” appears in the list. Assign a name to the 
map in the Name field, and select a map size from the drop-down menu. 

2. To assign your custom map to other shading domains in your object, scroll thr
Domain list until you find the material that you want to change. Click the button to view a list of the
available density maps, and select the one you want to apply. 
 

 
3. When you are done with your choices, click OK to exit the Manage Density Maps dialog. You 

return to the Hair First Setup dialog described in "Adding Hair to an Object." 

Creating Hair Groups and Grow Regions 
Objects need at least one hair group to grow hair. Carrara creates one hair group on an object or group 
when you initially add hair to an object. 

You can create more than one hair group in a single object. In fact, multiple hair groups can prove very 
useful you need to create different types of hair on the same figure or object. For example, you can create 
separate hair groups for the skull, eyebrows, eyelashes, and facial hair of a male character. After you 
create the groups and assign polygons to them, you can assign different properties to them. The hair on 
the skull can be short and thick. The eyebrow hair can be coarser than the hair on the head. The eyelash 
hairs are shorter and much less dense. The facial hair could become a full-grown beard, or the stubble of 
someone that is in need of a shave. 

You can also create a hair style that uses multiple hair groups. For example, you can create a man’s hair 
style that has a hair group that creates short hair at the neck and the back of the head. A second hair 
group can create longer hair that is styled to wave or curl the hair.  

Multiple hair groups can also prove useful when styling hair in layers. For example, you can create a hair 
group that includes a small number of polygon rows near the nape of the neck, and style them properly. 
Then create a new group that adds a few more rows of polygons immediately above the first group, and 
style them. Continue in this manner until all of the polygons in the hair are assigned and styled. 

You create new hair groups in the Model Room. Initially, your object may only consist of one hair group 
and all of the polygons in that group may be assigned to that single group. 

 
The following steps show you how to remove all polygons from an existing hair group and create 
addition

To create hai

1. at you want to change. Polygons that are assigned to hair groups will 
display in color. Unassigned polygons will be gray. 

al hair groups: 

r groups: 

Select the Hair object th
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2. If the area that you want to include in the new hair group is already assigned to an existing hair 
group, you’ll need to remove the assigned polygons:  

• Select the Grow Region tool from the Hair Toolbar.  

• Click the Clear button in the Tool tab to remove all polygons from the current hair group, 

roups are displayed in the drop-
own list. 

4. To create a new hair group, select New Hair Group. The Create New Group dialog appears. 

5. Enter a name for the new hair group and press OK. 

6. Use the Grow Region tool to select the polygons that you want to assign to the new group. 

7. Repeat Steps 3 through 6 for each new group y As you continue to create new 
 

gons remain gray. 

or press the Ctrl/Cmd key while you paint with the Grow Region tool to remove selected 
polygons. 

3. Click the Hair Group button above the Tool tab. Existing hair g
d

ou want to create. 
groups, the polygons that are already assigned will display in one color, and the polygons that
you are assigning to the new group display in another color. Unassigned poly

NOTE! Additional hair group options appear in the General tab in the Model Room. These options 
allow you to rename the hair and toggle its visibility. 

ted Shading Domains 

 

n tool (the first tool in the Hair toolbar) to accomplish this. 

Adding Hair to Selec
Most DAZ figures (as well as other Poser-compatible figures) use multiple textures and multiple material 
zones. Most likely, you’ll want to confine hair growth to the head of a human figure, rather than applying it
to the entire body. 

If your object includes more than one shading domain, you can select specific shading domains on which 
to grow hair. You use the Grow Regio

NOTE! The shading domains that you select vary, depending on the material zones that are 
 present in your figure. DAZ’s Victoria 3, for example, includes a material zone named Skin Scalp, which is

ideally suited for this purpose. DAZ’s Victoria 4 includes two material zones: SkinHead (which includes 
the ears and the back of the head), and SkinFace (which includes the front half of the head). Selecting 
one or both of these material zones will require clearing some of polygons from the shading domains, 
using the Grow Region tool. 

 
To select a shading domain on which to grow hair: 

1. Choose the Grow Region tool from the Hair toolbar. Its properties appear in the Properties tray: 
Tool tab. 

2. If your character is displayed entirely in color, it means that the entire figure is set to grow hair. 

 button in the Tool tab. The Select Shading Domain dialog appears. 

ia 

Gray areas indicate where no hair growth occurs. To remove the hair growth areas from the 
entire figure. click the Clear button in the Properties tray: Tool tab. 

3. Click the Select By

4. Locate the shading domain you want to select (such as 2_SkinHead, as used on DAZ’s Victor
4.x figure). The selected shading domain is highlighted by a yellow bar. 
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5. Click OK to assign the shading domain. 

6. Repeat Steps 3 through 5 for each additional shading domain that will grow hair. 

The Grow Region tool allows you select or deselect the polygons that will grow hair on your object. The 
Global p

Painting and Selecting Grow Regions 
If you do not want all polygons in the hair group to grow hair, you can use the Grow Region tool in the hair 
toolbar to add or remove specific polygons. 

ane of this tab displays the Enable Symmetry option, which is discussed in more detail in 
"Symmetrical Hair Styling." 

 

 © 2008 DAZ 3D, Inc. 738 



Carrara 7 11 December 2008 

The options for the Grow Region tool appear in the Properties tray: Tool tab when the Grow Region tool 
is selected.  

 
The Tool tab settings for the Grow Region tool provide the following functions: 

• Mode: Use controls in this area to choose the mode in which poly

o Paint: When selected, you can use the mouse to paint the

gons will be selected.  

 polygons that grow hair.  

o Lasso: When selected, you can draw a selection area around the polygons to select 
them. Press the Cmd/Ctrl key while selecting to remove polygons. 
 

TIP! Press the Shift key while painting to remove polygons. 

• No Overlapping Regions: Check this option to ensure that when two grow regions meet that the 
polygons in those regions do not overlap. If you decide to add polygons to a new growth group, 
they will be removed from other groups that the polygons are already assigned to. This ensures 
that polygons are only assigned to one grow region. 

• Clear: Click this button to remove hair from all polygons in the object. If you are adding hair to a 
human figure, you’ll probably want to click this button immediately after you add a hair object, and 
then proceed to select polygons on which to grow hair. 

• Select All: Selects all of the polygons in the current object to add hair to them. 

• Invert: Reverses the current polygon selection so that all polygons that were formerly selected 
are deselected, and all polygons that were formerly deselected are selected. 

• Select By: Click this button to open the Select Shading Domain dialog. When in Select mode, 
hair will be added to the groups (or shading domains) that you select. 

• Deselect By: Click this button to open the Select Shading Domain dialog. When in Deselect 
mode, hair will be removed from the groups (or shading domains) that you select. 

• Invert: Inverts the current polygon selection to add the polygons that were formerly not assigned, 
and to remove the polygons that were fo ssigned. rmerly a
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• Radius: Adjusts the width of the Grow Region tool to select less or more polygons as you move 
the tool over the object.  

• Flatness: Controls the shape of the brush. At 0% the brush has a spherical shape, while at 100% 
the brush is flattened into a circle. 
 

TIP! You can also Cmd/Ctrl click and drag the tool to resize it. 

To use the Grow Region tool: 

1. Click the Grow Region tool in the Hair toolbar. 

2. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Reference: In Reference mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symmetrical 
pose. 

3. To make symmetrical changes to the grow region, check the Enable Symmetry option. For 
further information on enabling this option, see "Symmetrical Hair Styling".  

4. Choose one of the painting modes:  

• Choose Paint mode to assign polygons by painting with a brush. 

• Choose  if you want to select polygons with a selection marquee. 

paint to the 

7. do any of the 
following:  

• If your object has multiple shading domains (such as different material zones on a figure), 
ant to include. 

. 

n and select the 

ons you want to 

Lasso

5. Check the No Overlapping Regions option, if desired, to add polygons that you 
current growth region and remove them from previously assigned regions. 

6. Set the size and shape of the brush. You can press the Ctrl/Cmd key while using the tool to 
resize the brush. 

Polygons that grow hair are colored green. To add polygons to the grow region, 

click the Select By button and select the shading domain that you w
Repeat for each additional shading domain that you want to add. 

• To paint your selection, increase or decrease the Radius of the brush to the desired size
Adjust the Flatness setting, if desired, to achieve the desired shape. Then paint on the 
object to select the polygons. 

• To select all polygons in the object, click the Select All button. 

8. Unassigned polygons are colored gray. To remove polygons from the grow region, do any of the 
following:  

• If your object has multiple shading domains, click the Deselect By butto
shading domain that you want to remove. Repeat for each additional selection. 

• To deselect by painting, press the Shift key while you paint over polyg
remove. 

Assigning General Hair Properties 
After you create your hair groups, the next step in the process is to assign some general properties to the 
hair, so that you can obtain the best results with the styling tools.  
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The Model Room contains three tabs that pertain to hair: the Tool tab (which provides options for each of 
the tools in the Hair Toolbar as they are selected), the General tab, and the Dynamics tab. We’ll start with 

ols that affect all hair groups. You can control various aspects 
of the hair, including length, thickness, hair width (or scaling), rendering quality, and more. You can also 
increase or decrease the number of segments in the hair to make it less “stiff.” These, and more 
properties, are described below. 

h, Thickness, and Rendering Quality 
scaling, and rendering quality of 
 General section to hide them 

compl

The option

the General tab first, since it is the next logical place to visit. 

The General tab provides options and contr

Setting Hair Lengt
Options in the General section allow you to adjust the length, thickness, 
the hair. When working with generated hairs, you can use controls in the

etely, or set a percentage of generated hairs that are visible. 

s are displayed in the following figure and described below. 

 
• Length: Adjust the Length slider to lengthen or shorten the hair. The default hair length is one 

foot.  

• Thickness: Controls the thickness of each strand of hair. Choose Thin, Medium, Large, or Very 
Large from the selection menu. You see the results of this setting at render time. Medium an
Large settings are most appropriate for commonly-used figures. Thin is mo

d 
st appropriate for small 

• ickness of each strand of hair. Larger values create 

 

esources to render. 

ime after 

•  Hairs: Check this option to display an approximation of the generated hairs 

, you can dial in the 

objects viewed at closeup range. Very Large thickness is suitable for grass and other grass-like 
plants. 

Scaling: Provides finer control of the th
coarser, thicker hairs. You see the results of this setting at render time. 

• Rendering Quality: Controls the appearance of hair after it is rendered. Lower values create hair
that is rough and has aliased edges. Higher values create smoother anti-aliased hair, but may 
take more r

• Placement Type: Determines whether hair placement is determined by UVs (UV Based) or by 
geometry (Geometry Based). You can use this option to switch between modes at any t
you create your hair object. 

Show Generated
before you render. Uncheck this option to view only guide hairs. 

• Display Percentage: With Show Generated Hairs (above) checked
percentage of hairs that are visible, from 0% to 100%. 

At a minimum, you’ll find it helpful to make the following adjustments to the hair before you begin to style 
it. 
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To set hair length and thickness: 

1. To set hair length, use one of the following methods:  

• Choose Hair > Set Length, and enter the length in the Set Hair Length dialog. Click OK 
to apply the new setting. 

• In the Properties tray: General tab: General pane, adjust the Length value to t
desired length.  

he 

dium or 
the 

Controls in the Hair Group section allow you to rename the current hair group or toggle its visibility. The 
properties in the hair group section are as follows: 

2. Choose the Thickness that is most appropriate for the type of hair you are creating. Me
Large is recommended for DAZ or similar figures. Use the Spot Render tool to preview 
changes you make. 

3. Adjust the Scaling setting, if necessary, to fine tune the width of the hair strands. 

4. Set remaining options discussed earlier in this section as required. 

Naming, Hiding, and Showing Hair Groups 

 
• Name: Enter a name for the current hair group in this field. 

• Visible: Determines whether or not the hair group is visible in the scene viewport. 

• Show in 3D View: When checked, displays the generated hairs for the current hair group in the 

ir 
oose to create short hairs or long hairs, and enable or disable automatic grouping. 

e 
ear thicker or thinner. For 

3D view. When unchecked, hides the generated hairs but keeps the guide hairs visible. 

Controlling Hair Segments and Hair Count 
The options in the Hair (Per Hair Group) section are also important to configure before you start styling 
the hair. These settings control the number of segments in each hair, and the number of hairs in each ha
group. You can also ch

Each hair group has a number of generated hairs associated with it. You can increase or decrease th
number of generated hairs associated with each hair group to make the hair app
example, if you are creating hair on a human figure, you may need more generated hairs on the head 
than on the eyelashes. 
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To make the hair easier to style: 

1. Adjust the Segments Per Hair value as necessary for the length or amount of curl you want to 

ce. A lower number of segments per hair makes the hair 
e, 

rformance. 

 to choose the type of hair that is being used on your object.  

other similar 

r similar to a horse mane 

Guide hairs are colored white, and have an adjustable point at their end. These guide hairs determine the 
direction, length, flow, and style of the hairs that are associated with it. You can also brush the guide hairs 
to control the direction that the generated hairs fall. Simple hair styles will need fewer guide hairs than 
more complex styles. Even simple styles will require more than one guide hair to style the hair more 
naturally. 

r the shape of the hair, since the 

nd 1,000, and 

depending on the complexity of the style. 

the number of segments in 

achieve in your hair style. Shorter hair won’t need as many segments as longer hair unless you 
want to make it very curly. For longer hair, increase the number of segments for easier styling 
and more fluid dynamic performan
straight and stiff, while a higher number makes the hair flow, relax, or curl more naturally. Not
however, that a higher number of segments per hair can affect overall system pe

2. Set the Hair Count to control the number of hairs that are generated for each hair group on the 
head. Increase the hair count to make the hair fuller. 

3. Use the Mode setting

• Short Hairs/Fur: Choose this option for short human hair, animal fur, and 
objects. 

• Long Hairs: Choose this option for longer human or animal hai
or tail). 

Guide Hairs Options 

When you add more guide hairs, you have more precise control ove
system won’t have to do as much interpretation. When you make a style, you might find it easier if you 
turn off the generated hairs. Then use the set the guide hairs to somewhere between 200 a
use at least 16 hair segments. This will help you create a shape for your hair style. 

After your style is complete, reduce the number of guides to somewhere between 100 and 400, 

Settings in the Guide Hairs (Per Hair Group) section allow you to control 
each hair, and the number of guide hairs that appear in each hair group. 

 
• Override Segment Count: By default, Carrara hair is created with four segments in each guide. 

Check this option to set a different value. 

• Segments Per Guide: Increase or decrease the number of segments that each guide hair uses. 
A lower number of segments produces hair that is straighter. A higher value allows you to create 
hair that is more wavy. In addition, short straight hair needs fewer segments than longer hair. 
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NOTE! Many of the Hair tool settings will not appear to produce different results when you
have a very low number of segments. When you increase the guide hair segments to 6 or more, 
many of the effects of the Hair tool settings will be more obvious. 

• Guide Count: Increase or decrease the setting to create more guide hairs in your hair groups. 
This setting applies the number of guide hairs based on the Guide Sampling setting (below). 

 

If 

ygons 

• Uniform: Places the guide hairs randomly on the surface, using uniform repetition. 

eck this option if you want the hair to be symmetrical from one side to 

g and Grouping Hair 

sed to fix particular 

hair is generated from the guides. By default, the hairs are 

you need to vary the number of guide hairs, you can use the Add Guide Hairs tool in the Hair 
Toolbar. 

• Guide Sampling: Determines the placement of the guide hairs in relation to the pol
beneath them. 

• Custom: Choose this option when you add guides with the Add Guide Hair tool. 

• Polygon Center: Places the http://www.nero.com/enu/downloads-nero8-trial.phphairs at the 
center of the polygon that generates the hair. 

• Symmetrical Sampling: Ch
another.  

• Plane: Choose the plane of symmetry (YZ, XZ, or XY) from the Plane popup menu. 

• Symmetry: TBD 

Partin
Many hair styles contain parts along one side or at their center. The Interpolation controls aid in creating 
parts in the hair and allow you to assign different properties to selected hair groups. They are most useful 
if you want a group of guide hairs to be interpolated together. They should only be u
issues when the automatic mode fails to interpolate the guides correctly.  

The Interpolation settings control how the 
interpolated between all of the guides.  

 
• Auto Grouping Section: Controls how hairs move when you style them.  

auto-grouping, you can control how the hair interpolates 

he 
guide can affect the shape of the hair. 

o Enable: When enabled, allows you to control which guides will be used for interpolation 
of the guide shape. If you turn on 
between the groups. 

o Distance: Restricts auto-grouping to the guides that are close enough to the distance 
setting. The Distance value sets the maximum distance from a hair to a guide, where t
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o Angle: Restricts auto-grouping to guides that are within the angle setting. The Angle 

ed 
y.  

gn a name to the new Interpolation group. 

s. Other 

value sets the maximum angle from a hair to a guide. Guide hairs that have very different 
angles are not interpolated together. 

o Distance Along: Sets the distance along the length of the hair that the groups are 
interpolated.  

• Groups Section: The Groups section allows you to create new interpolation groups that allow 
you to fine-tune the interpolation and correct problems with the auto grouping. We recommend 
that you use this feature only at the end of the process to correct problems that cannot be solv
any other wa

o New Group: Click this button to open the Create Interpolation Group dialog, which allows 
you to assi

The Hair Toolbar and Tool Tab 
Controls in the Hair Toolbar allow you to visually modify the hair density, length, and curlines
tools allow you to perform global changes on the hair, to add and remove guides, and to reset the shape 
of the hair. 
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Th  
set option

The Hai ar (by default) when you have a hair object 
sele t side 
of the docum cons in the toolbar, from left to right, are described in the sections that 

e tools in the Hair Toolbar allow you to visually style the hair. Use the Tool tab in the Model Room to
s for the selected tool. 

r Toolbar appears beneath the Model Room’s menu b
cted. You can undock the toolbar to leave it free-floating, or place it in the toolbar area at the lef

ent window. The i
follow. 

From left to right, the icons are as follows: 

• Grow Region tool, discussed earlier in "Adding Hair to Selected Shading Domains" 

• Density Add tool discussed in "Density Add Tool and Density Remove Tool" 

• Density Remove tool discussed in " oolDensity Add Tool and Density Remove T " 

• Density Paint tool discussed in "Density Paint Tool" 

• Hair Length tool discussed in "Hair Length Tool" 

• Brush tool discussed in "Brush Tool" 

• Straighten tool discussed in "Straighten Tool" 

• Hair Cut tool discussed in "Hair Cut Tool" 

• Push tool, discussed in "Push Tool" 

• Smooth tool, discussed in "Smooth Tool" 

• Curl tool, discussed in "Curl Tool"  

• Clump tool, discussed in "Clump Tool" 

• Reset Shape tool discussed in "Reset Shape" 

• Even Hair Segments tool discussed in "Even Hair Segments" 

• Drape tool discussed in "Drape" 

• Symmetrize tool, discussed in "Symmetrize" 

• Paint Selection tool discussed in "Paint Selection Tool" 

• Add Guide Hair tool discussed in "Add Guide Hair Tool" 

• Remove Guide Hair tool discussed in "Remove Guide Hair Tool" 

Symmetrical Hair Styling 
The tools in the Hair modeler allow you to perform symmetrical operations while you create your hair style. 
When applicable, you’ll find an Enable Symmetry option in the Properties tray: Tool tab: Global pane. 
Enable this option to model and style your hair symmetrically. 

Note: It is important to note that symmetrical hair styling will not work on an object that is not symmetrical. 
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The Source Object Mode options also assist in applying symmetrical changes. These modes are only 
used for skinned objects, and function as follows: 

figure that is not posed symmetrically. 

in the Model 
ou to 

: 

 that you are using, and is represented by the 
 is used. Reduce the setting to use a smaller brush, and 
sh. You can also adjust the radius of the brush by pressing 

mouse button to resize dynamically. 

rea of the brush that has the most strength. The inner 
ff begins. For example, if the falloff setting is 

the area designated by the inner circle. The effect will 
ches the outer circle. You can also adjust the falloff 

g the Shift and Ctrl/Cmd keys while pressing the left 
y. 

nt of effect that the brush has on the operation. With 
 the strength setting to produce smaller changes 

effect you want. 

 Density Remove Tool 
 you paint over. This increases the 

• Normal: In normal mode, you edit hair on the object in its skinned position.  

• Reference: In Reference mode, you edit the hair on the object in its original reference position 
(without applying the skinning). This mode is very useful when you want to use symmetry on a 

Common Tool Settings 
When you choose a hair styling tool from the Hair Toolbar, its options and settings appear 
Room’s Tool tab. There are a number of settings that are common to several tools that allow y
“paint” settings onto your object. These settings are as follows

• Radius: This setting controls the size of the brush
size of the outer circle when the brush
increase the setting to use a larger bru
the Shift or Ctrl/Cmd key while pressing the left 

• Falloff: The falloff setting determines the a
circle in the brush determines the area where fallo
50%, the brush will have full effect in 
gradually fade to no effect by the time it rea
setting of the brush by simultaneously pressin
mouse button to resize it dynamicall

• Strength: This setting controls the amou
100% strength, the brush has full effect. Reduce
with each stroke of the mouse until you get the 

Density Add Tool and
Use the Density Add tool to make hair more dense in areas that
number of generated hairs that are created for each hair group. 

 
Use the Density Remove tool to make hair less dense in areas that you paint over. This decreases the 

ch hair group. number of generated hairs that are created for ea

 
Use the Density Add and Density Remove tools to paint in grayscale while increasing or decreasing the 
density of the hair. Black areas are equal to 0% density and white areas are equal to 100% density. 

falloff, and strength of the brush. 
When either of these tools are selected, the Tool tab displays options that allow you to set the radius, 
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To increase or decrease density: 

1. Choose one of the following tools:  

• To increase density in painted areas, choose the Density Add tool. 

• To decrease density in painted areas, choose the Density Remove tool. 

2. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Reference: In Reference mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symmetrical 
pose. 

3. If you want to apply symmetrical changes to the density, check the Enable Symmetry option in 
the Global panel. 

4. Set the following properties:  

• Set the Falloff to determine how quickly the brush will fall of from maximum effect (at the 

 density setting at its maximum value 
over the polygons that you paint. Lower settings require repeated strokes to achieve the 
same result. 

 
e black. 

Density Paint Tool 

• Set the Radius of the brush to achieve the correct brush size. 

center) and no effect (at the outside boundary of the brush). 

• Set the Strength of the brush. 100% applies the

5. Paint over the object to add or remove density in the areas that you desire: When the hair is at its
maximum density the polygons will be white. When density is at 0% the polygons will b

Use this tool to increase or decrease density in the areas that you paint. Unlike the Add Density or 
Remove Density brushes, the Density Paint Tool allows you to set a specific value for density, and it 
increases or decreases appropriately where it paints. 

 
The Density setting controls the number of hairs that exist in relation to a hair group. A hair density setting 
of 100% generates the full number of hairs that are associated with a guide hair. A 50% hair density 
setting generates half the number of generated hairs. 
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When using one of the Density tools, the display of the scene changes to display your model in grayscale: 

n you initially create 

e between no density (black) and 

In 
followin

• lider determines the maximum amount of density that will be added to the 
 

eas that you want to set to that value. 

 

oose Hair > Set Density.  

To cha

• de, you edit the hair on the object in its skinned position. 

nce mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symmetrical 

 in 

5. Set the following properties:  

 the 
undary of the brush). 

• Set the Density setting to the amount of density that you want to apply to the polygons 
over which you paint. 

• White areas on the model indicate the maximum amount of hair density. Whe
hair, density is set to the maximum value. 

• Black areas indicate where hair will not grow or where the density is set to zero. 

• Shades of gray in a hair area indicate values that are somewher
maximum density (white). 

addition to the common Radius, Falloff, and Strength settings, the Density Paint tool provides the 
g options in the Tool tab: 

Density: This s
polygons that you paint with the brush. In other words, you can set the Density slider to 50%, and
then paint in the ar

To set hair density to a specific value:

1. To set density to a specific value over all polygons in the hair group, ch

2. Enter the desired value in the Set Hair Density dialog. 

nge hair density in selected areas: 

1. If you want to affect only certain guide hairs, use the Paint Selection tool to select the guide hairs 
you want to affect. With no selection made, all guide hairs will be affected. 

2. To increase or decrease density on all or selected guides, click the Density Paint tool. 

3. In the Global section, choose the desired source object mode:  

 Normal: In Normal mo

• Reference: In Refere

pose. 

4. If you want to apply symmetrical changes to the density, check the Enable Symmetry option
the Global panel. 

• Set the Radius of the brush to achieve the correct brush size. 

• Set the Falloff to determine how quickly the brush will fall of from maximum effect (at
center) and no effect (at the outside bo
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• Set the Strength of the brush. 100% applies the density setting at its maximum value 
over the polygons that you paint. Lower settings require repeated strokes to achieve the 
same result. 

6. Paint over the object to add or remove density in the areas that you desire. 

Hair Length Tool 
Use the Hair Length tool to lengthen the hair on the guide hairs that you paint. 

 
In addition to the common Radius, Fallof  and Strength settings, the Hair Length tool provides the 

een 

s higher than the current length, the hair will grow. If the Length setting 

ute option checked, the Length setting that you enter is applied to all of 

f,
following options in the Tool tab: 

• Flatness: Controls the shape of the brush. At 0% the brush has a spherical shape, while at 100% 
the brush is flattened into a circle. 

• Restrict to Selection: Confines actions of the Hair Length tool to the guide hairs that have b
selected with the Paint Selection tool, discussed previously. 

• Length: The Length setting determines whether hair will be lengthened or shortened when you 
paint. If the Length setting i
is smaller than the current length, and if Absolute is checked, the hair will get shorter. 

• Absolute: With the Absol
the hairs that you paint. When unchecked, the length of all underlying hair is increased or 
decreased based on the Length setting. 
 

 
To change the length of the hair: 

1. If desired, use the Hair Selection tool to select the guide hairs that you
selection made, all guide hairs will be affected. 

 want to change. With no 

2. Choose the Hair Length tool. 
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3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Reference: In Reference mode, you edit the hair on the object in its
This is useful when you want to use symmetry on a figure that is in a non-symme

 reference position. 
trical 

etrical changes to the density, check the Enable Symmetry option in 
the Global panel. 

• Set the Radius of the brush to achieve the correct brush size. 

 determine how quickly the brush will fall of from maximum effect (at the 

uide hairs, check the Restrict to Selection option. To affect 

hair to grow. 

Brush Tool 
The Brush tool adds curl, waves, and styling to the guide hairs. In addition to the common Radius, Falloff, 
and Strength settings, the Brush tool provides two modes of operation: Screen and Surface. 

pose. 

4. If you want to apply symm

5. Set the following properties:  

• Use the Flatness slider to change the shape of the brush if desired. 

• Set the Falloff to
center) and no effect (at the outside boundary of the brush). 

6. If you want to affect only selected g
all areas, uncheck this option. 

7. Enter a hair length in the Length field.  

8. Check the Absolute option if you do not want the hair to exceed the set length. 

9. Uncheck the Absolute option to allow hair to grow by the amount designated in the Length field 
each time you paint over the hairs. 

10. Adjust the Strength setting for more subtle or more pronounced changes while you paint. 

11. Paint over the areas where you want the 

 

Screen Mode Options 
In Screen mode, the following options apply in addition to the standard Radius, Falloff, and Strength 
settings: 
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Screen mode options for the Brush tool 

• Point: The Point slider adjusts the position of the guide’s point. You can use the + or – buttons to 

 style 
middle, and then brush the hair to pull the 

ection: Confines actions of the Remove Guide tool to the guidehairs that have 
ssed previously. 

• Stiffness: With a high stiffness setting, pulling on one point will attract the points of other guide 
hairs that are near it. For example, if the point is placed in the middle of the hair, you will see the 
brush influence more hairs around the brush when the Stiffness setting is increased. 

 to maintain the hair segment lengths while you brush the hair. 
nematics in bones. You can pull the last point of the hair and all 

• Collision Distance: Allows you to specify a value at which the hair will be considered to be 
colliding with the surfaces it comes into contact with. Hair will not be allowed to get any closer 
than this value. 

To brush hair in Screen mode: 

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With no 
selection made, all guide hairs will be affected. 

2. Choose the Brush tool. 

3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

move the point closer to or farther away from the base of the head. This point determines the 
point at which the hair moves when you style the hair. For example, if you want to affect the
at the middle of the hair guide, position the point in the 
middle of the hair in that direction. 

• Restrict to Sel
been selected with the Paint Selection tool, discu

• Apply Only to Visible Guide Hairs: Check this option to affect only the hairs that are facing 
toward you. Backward-facing geometry will not be affected. 

• Use Hair IK: Check this option
This works similar to inverse ki
points before it will move accordingly to match the new position if it can be reached. When IK is 
off, you can change the length of the hair and add additional segments to the hair. 
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• Reference: In Reference mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symmetrical 
pose. 

4. Check the Enable Symmetry option if you want to brush the hair symmetrically. 

5. In the Mode section, choose the Screen option. 

6. Adjust the Point slider to determine the point from which the brush will move the hair. 

7. Check the Restrict to Selection option if you want to restrict brushing to the selected guide hairs. 

8. Check the Apply only to visible guide hairs option to prevent accidental brushing of the guide 
hairs on the opposite side of the head. 

9. Adjust the Strength and Stiffness sliders to obtain the desired amount of response from the 
Brush tool. 

10. Check the Use Hair IK option if you want to keep the hair at the set length while you brush it. 

11. Set the Collision Distance value to closest value that hair will move toward adjacent geometry. 

12. Drag the Brush tool across the guide hairs to style the hair as desired. 

Surface Mode Options 
In Surface mode, the following options apply: 

 
• Flatness: Controls the shape of the brush. At 0% the brush has a spherical shape, while at 100% 

rush tool to the guide hairs that have been 
lection tool, discussed previously. 

air as it is being brushed. 

To bru

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With no 
selection made, all guide hairs will be affected. 

the brush is flattened into a circle. 

• Restrict to Selection: Confines actions of the B
selected with the Paint Se

• Curve: Controls the amount of curve that is added to the guide h

sh hair in Surface mode: 
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2. Choose the Brush tool. 

In the Global section, choose the desired source object mode:  3. 

sition. 

 the hair on the object in its reference position. 
etry on a figure that is in a non-symmetrical 

 brush. 

irs. 

s the guide hairs. The options for the Straighten tool are 
ut provide three different modes of operation: Screen, 

Surface, and Selection. 

• Normal: In Normal mode, you edit the hair on the object in its skinned po

• Reference: In Reference mode, you edit
This is useful when you want to use symm
pose. 

4. Check the Enable Symmetry option if you want to brush the hair symmetrically. 

5. In the Mode section, choose the Surface option. 

6. Set the Radius, Flatness, and Falloff settings for the

7. Check the Restrict to Selection option if you want to restrict brushing to the selected guide ha

8. Adjust the Strength and Curve settings to control the amount of styling and curl that will be 
applied to the hair. 

9. Drag the Brush tool across the guide hairs to style the hair as desired. 

Straighten Tool 
The Straighten tool removes curl or straighten
very similar to those listed for the Brush tool, b

 

Screen Mode Options 
In Screen mode, the following options apply in addition to the standard Radius, Falloff, and Strength 
settings: 
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• Point: The Point slider adjusts the position of the guide’s point. You can use the + or – buttons to 
ad:  

th of the 

 

 from the 

aighten tool to the guidehairs that have been 

ant to change. With no 
selection made, all guide hairs will be affected. 

 tool. 

3. In the Global section, choose the desired source object mode:  

ce: In Reference mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symmetrical 
pose. 

4. Check the Enable Symmetry option if you want to brush the hair symmetrically. 

e Screen option. 

6. Adjust the Radius and Falloff for the brush to achieve the desired size and area for the 

djust the Point slider to determine the point from which the brush will move the hair. 

8. Check the Restrict to Selection option if you want to restrict brushing to the selected guide hairs. 

9. Check the Apply only to visible guide hairs option to prevent accidental brushing of the guide 
hairs on the opposite side of the head. 

10. Adjust the Strength and Stiffness sliders to obtain the desired amount of response from the 
Brush tool. 

11. Drag the Brush tool across the guide hairs to style the hair as desired. 

move the point closer to or farther away from the base of the he

o When the point is placed near the head, changes take effect over the entire leng
hair. 

o When the point is placed at the tip of the guide hair, the styling controls affect only the tip
of the hair. 

o When the point is placed in the middle of the guide hair, styling is applied
position of the point to the tip of the hair. 

• Restrict to Selection: Confines actions oft he Str
selected with the Paint Selection tool, discussed previously. 

• Apply Only to Visible Guide Hairs: Check this option to affect only the hairs that are facing 
toward you. Backward-facing geometry will not be affected. 

To straighten hair in Screen mode: 

1. If desired, use the Hair Selection tool to select the guide hairs that you w

2. Choose the Straighten

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Referen

5. In the Mode section, choose th

Straighten tool. 

7. A
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Surface Mode Options 
In Surface m ollowing options apply: ode, the f

 
F• rols the shape of the brush. At 0% the brush has a spherical shape, while at 100% 

raighten tool to the guide hairs that have been 

ace mode: 

 With no 

d source object mode:  

erence: In Reference mode, you edit the hair on the object in its reference position. 
s in a non-symmetrical 

pose. 

4. Check the Enable Symmetry option if you want to brush the hair symmetrically. 

5. In the Mode section, choose the Surface option. 

6. Set the Radius, Flatness, and Falloff settings for the brush. 

7. Check the Restrict to Selection option if you want to restrict brushing to the selected guide hairs. 

8. Adjust the Strength and Curve settings to control the amount of styling and curl that will be 
applied to the hair. 

9. Drag the Straighten tool across the guide hairs to straighten the hair as desired. 

latness: Cont
the brush is flattened into a circle. 

• Restrict to Selection: Confines actions of the St
selected with the Paint Selection tool, discussed previously. 

To straighten hair in Surf

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change.
selection made, all guide hairs will be affected. 

2. Choose the Straighten tool. 

3. In the Global section, choose the desire

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Ref
This is useful when you want to use symmetry on a figure that i
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Selection Mode Options 
rquee around the guide hairs that you want to straighten. 

 the selection, or press the Ctrl/Cmd key while creating 
another selection marquee area around the guides you want to deselect. 

In Selection mode, you can draw a selection ma
To deselect the guide hairs, either click outside

 

Hair Cut Tool 
The Hair Cut tool allows you to shorten the length of all or selected guide hairs. 

 
In addition to the common Radius setting, the Hair Cut tool provides the following options in the Tool tab: 

 
R• ection: Confines actions of the Remove Guide tool to the guide hairs that have 

ption to affect only the hairs that are facing 

no 

3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

estrict to Sel
been selected with the Paint Selection tool, discussed previously. 

• Apply Only to Visible Guide Hairs: Check this o
toward you. Backward-facing geometry will not be affected. 

To cut hair: 

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With 
selection made, all guide hairs will be affected. 

2. Choose the Hair Cut tool. 
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• Reference: In Reference mode, you ed
This is useful when you wa

it the hair on the object in its reference position. 
nt to use symmetry on a figure that is in a non-symmetrical 

5. Check the Restrict to Selection option if you want to restrict brushing to the selected guide hairs. 

6. Check the Apply only to visible guide hairs option to prevent accidental brushing of the guide 
hairs on the opposite side of the head. 

7. Drag the Hair Cut tool across the points at the bottom of the guide hairs to shorten the hair to the 
desired length. 

Push Tool 
Use the Push tool to pull all or selected hairs away from the surface of an object. This tool is particularly 
useful to use after guide hairs have been moved too close to or inside the head after draping or styling. 

pose. 

• Check the Enable Symmetry option if you want to brush the hair symmetrically. 

4. Set the Radius of the brush to the desired size. 

 
The Push tool provides the following options: 

 
• Distance: Set the desired distance that you want to push the hairs. 

• Restrict to Selection: Confines actions of the Remove Guide tool to the guide hairs that have 
been selected with the Paint Selection tool, discussed previously. 

o 

ose the Push tool. 

air on the object in its skinned position. 

rence mode, you edit the hair on the object in its reference position. 
re that is in a non-symmetrical 

• Apply: Click the Apply button to push the selected hairs by the desired distance. 

To push hair: 

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With n
selection made, all guide hairs will be affected. 

2. Cho

3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the h

• Reference: In Refe
This is useful when you want to use symmetry on a figu
pose. 
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4. Check the Enable Symmetry option if you want to brush the hair symmetrically. 

Adjust the Distance setting to the amount of push that you want to obtain. 5. 

 this 

sired amount. 

e kinkiness and move it more toward a completely straight line. When smoothed 
to the maximum amount, the hair will be just a straight line from root to tip. Moving the mouse farther 

oint applies smoothing with greater strength. 

6. Check the Restrict to Selection option to use the tool on the selected guide hairs. Leave
option unchecked to apply the tool to all guide hairs. 

7. Click the Apply button to push the hair by the de

Smooth Tool 
The Smooth tool smoothes the variation along the hairs. For example, if hair is very kinky you can use the 
Smooth tool to reduce th

away from the click p

 
The Smooth tool has no additional options. 

 
To smooth hair: 

1. Choose the Smooth tool. 

2. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Reference: In Referenc  mode, you edit the hair on the object in its reference position. 
at is in a non-symmetrical 

ymmetrically. 

ou want to 

he mouse to deselect a rectangular area. 

, move the mouse over the selection to achieve the amount of 
 see both sides getting smoother 

e
This is useful when you want to use symmetry on a figure th
pose. 

3. Check the Enable Symmetry option if you want to brush the hair s

4. Use the Smooth tool to make a rectangular selection around the guide hairs that y
smooth.  

• If Symmetry is enabled, you can select guide hairs on one side of the head.  

• Press the Ctrl/Cmd key while dragging t

5. After the selection is made
smoothness that you desire. If Symmetry is enabled, you should
as you move the mouse. 

 © 2008 DAZ 3D, Inc. 759 



Carrara 7 11 December 2008 

Curl Tool 
The Curl tool applies curl to selected guide hairs. Moving the mouse farther from the click point applies 
curl with greater strength. 

 
The Curl tool provides the following options: 

 
• Frequency X: Controls the number of curls along the X axis. 

• Frequency Y: Controls the number of curls along the Y axis. 

• Anisotropy: Controls the size of the curl. 

To curl hair: 

1. In the General tab: Hairs (Per Hair Group) panel, increase the Segments Per Hair setting to a 
t will be suitable for creating smooth curls. If the value is set too low the hair will look zig-

 can initially set the value to 100 segments, and reduce it after you curl 

trical 

, , and  settings to achieve the amount of curl 

url.  

7. After the selection is made, move the mouse over the selection to achieve the amount of curl that 
you desire. If Symmetry is enabled, you should se both sides getting curlier as you move the 
mouse. 
 

value tha
zagged. For example, you
the hair. 

2. Choose the Curl tool. 

3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Reference: In Reference mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symme
pose. 

4. Check the Enable Symmetry option if you want to brush the hair symmetrically. 

5. Adjust the Frequency X Frequency Y Anisotropy
that you want to add to the hair. 

6. Use the Curl tool to make a rectangular selection around the guide hairs that you want to c

• If Symmetry is enabled, you can select guide hairs on one side of the head.  

• Press the Ctrl/Cmd key while dragging the mouse to deselect a rectangular area. 
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NOTE! The length of the guide hairs will increase so that the curled hair remains at 

 resources, return to the General tab: Hairs (Per Hair Group) panel and 
decrease the Segments Per Hair setting a little bit at a time, while keeping the curl at an 
acceptable level. 

Clump Tool 
The Clump tool deforms selected hairs toward a reference hair. When you move the mouse farther from 
the reference point, the clump is applied at a greater strength. 

approximately the same length as the uncurled hair. 

8. To use less system

 
The Clump tool provides the following options: 

 
The Clump tool has only one property to set: 

• Rate: Increase the Rate setting to increase the number of hairs that are pulled  

To clump hair: 

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With no 

nce: In Reference mode, you edit the hair on the object in its reference position. 
symmetrical 

tion if you want to clump the hair symmetrically. 

 
on point, 

 clump.  

rl/Cmd key while dragging the mouse to deselect a rectangular area. 

selection made, all guide hairs will be affected. 

2. Choose the Clump tool. 

3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Refere
This is useful when you want to use symmetry on a figure that is in a non-
pose. 

4. Check the Enable Symmetry op

5. Adjust the Rate setting to control the size of the hair clumps (the number of hairs that will clump
together when you use the tool). A high setting moves all selected hairs toward a comm
whereas a lower setting moves a smaller group of hairs toward a common point. 

6. Use the Clump tool to make a rectangular selection around the guide hairs that you want to

• If Symmetry is enabled, you can select guide hairs on one side of the head.  

• Press the Ct
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7. After the selection is made, move the mouse over the selection to achieve the amount of clump 

r as if 
 

 

tward. 

that you desire.  

• If Symmetry is enabled, you should se both sides clumping symmetrically. With a high 
Rate setting, hairs will clump together as if being pulled together to make pigtails. 

• If you use a high Rate setting with Symmetry turned off, all hairs will clump togethe
to make a bun or ponytail.

Reset Shape
Use the Reset Shape tool to remove styling from all of the hair. This resets the guide hairs to straight 
lines that are perpendicular to the polygon surface, and point ou

 
To reset the shape of the hair: 

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With no 
selection made, all guide hairs will be affected. 

2. Choose the Reset Shape tool. The selected hairs are reset to grow straight out and perpendicular 
to the growing surface. 

Even Hair Segments 
After you brush the hair, especially with e IK off, you can end up with hair segments that are uneven. 

s all segments even. 
 th

This tool resamples the hair shape and make

 
To even hair segments: 

gments tool. 

D
The Drap  
have applie airs and generated hairs. 

1. If desired, use the Hair Selection tool to select the guide hairs that you want to change. With no 
selection made, all guide hairs will be affected. 

2. Choose the Even Hair Se

rape 
e tool causes all guide hairs to relax and appear more natural, based on the other settings you

d to the guide h

 
To drape hair:  

1. Click the Drape tool. The hairs will relax to fall naturally over the growing surface. 

2. To convert the guide hairs to the relaxed shape, open the Dynamics tab: Simulation panel. 
Click the Convert button in the Draping section. 
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Symmetrize 
Mo to 
work, you ne etry. 

st of the Hair tools allow you to edit the hair symmetrically, relative to a plane. In order for symmetry 
ed to enable symmetrical modeling and choose the plane that will determine the symm

 
To enable symmetrical mo

1. Open the Propert

deling and to choose the plane: 

ies tray: General tab: Guide Hairs (Per Hair Group) pane. 

p menu. 

To symmetrize hair: 

• Click the Symmetrize tool. 

 hairs you want to edit. You can also control the portion of the hair that 
you want to affect by adjusting the position of the point. 

2. Check the Symmetrical Sampling option to enable the symmetry plane. 

3. Choose the desired plane (YZ, XZ, or XY) from the Plane popu

 

Paint Selection Tool 
Several tools allow you to restrict styling and shaping to selected hair guides. You can use the Paint 
Selection tool to select the guide

 
In addition to the Radius setting, the following settings are provided for the Paint Selection tool: 

 
• Point: The Point slider adjusts the position of the guide’s point. You can use the + or – buttons to 

move the point closer to or farther away from the base of the head:  

o When the point is placed near the head, changes take effect over the entire length of the 
hair. 

ect only the tip 

 the guide hair, styling is applied from the 
position of the point to the tip of the hair. 

• Apply Only to Visible Guide Hairs: Check this option to affect only the hairs that are facing 
toward you. Backward-facing geometry will not be affected. 

o When the point is placed at the tip of the guide hair, the styling controls aff
of the hair. 

o When the point is placed in the middle of
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To select or deselect hai

1. Choose the Pain

r guides: 

t Selection tool. 

• Reference: In Reference mode, you edit the hair on the object in its reference position. 
This is useful when you want to use symmetry on a figure that is in a non-symmetrical 

agging the Paint 

t slider or +/- buttons to adjust the position of the point on the guide hairs. The 
he portion of the hairs that will be affected by the tools you apply 

 Guide Hairs option to prevent accidental selection of back-

7. Paint in the document window to select or deselect hairs as follows:  

• To deselect hairs, press the Shift key while painting over the guide hairs that you want to 
deselect. 

When you create hair on an object that does not have UV maps applied, you may find that there are 
enough guide hairs to style the hair. However, when adding hair to the head of a figure, you may need to 
increase the number of guide hairs to provide better control over styling the hair. 

2. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

pose. 

3. Check the Enable Symmetry option if you want to select hairs symmetrically. 

4. Set the Radius of the brush. You can also press the Ctrl/Cmd key while dr
Selection tool in the document window to resize the brush. 

5. Use the Poin
position of the point determines t
to the hair selection. 

6. Check the Apply only to Visible
facing guide hairs. 

• To select hairs, paint over the hair guides that you want to select. Selected guide hairs 
turn orange. 

Add Guide Hair Tool 

 
The General tab (discussed later) includes a setting that allows you to globally increase or decrease the 
number of guide hairs. However, in cases where you want to add more guide hairs in specific areas, use 
the Add Guide Hair tool to paint more guide hairs where you need them. 

In addition to the common Radius, Falloff, and Strength settings, the Add Guide Hair tool provides the 
following options in the Tool tab: 
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• Flatness: Controls the shape of the brush. At 0% the brush has a spherical shape, while at 10

the brush is flattened into a circle. 
0% 

pe that is similar 
ndicular to the surface, 

To add gui

2. In the Global section, choose the desired source object mode:  

, you edit the hair on the object in its skinned position. 

• Reference: In Reference mode, you edit the hair on the object in its reference position. 
l 

ally. 

4. Adjust the Radius, Flatness, and Falloff of the brush. 

hape of the guide hairs that you 

reas that will receive the additional guide hairs. 

Remove Guide Hair Tool 
The Remove Guide Hair tool deletes guide hairs from the polygons that you paint. 

• No Deformation: When unchecked, the guide hairs that you add will have a sha
to those that are nearby. When checked, guide hairs are added perpe
regardless of the shape of nearby hairs. 

de hairs: 

1. Choose the Add Guide Hair tool. 

• Normal: In Normal mode

This is useful when you want to use symmetry on a figure that is in a non-symmetrica
pose. 

3. Check the Enable Symmetry option if you want to add guides symmetric

5. Increase or decrease the Strength of the brush to control the number of guide hairs that are 
added while you paint. 

6. Check or uncheck the No Deformation option to determine the s
add. 

7. Paint on the head in the a

 
In addition to the common Radius, Falloff, and Strength settings, the Remove Guide Hair tool provides 
the following options in the Tool tab: 
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• Flatness: Controls the shape of the brush. At 0% the brush has a spherical shape, while at 100% 

the brush is flattened into a circle. 

• Restrict to Selection: Confines actions of the Remove Guide tool to the guide hairs that have 
been selected with the Paint Selection tool, discussed previously. 

To remove guide hairs: 

select the guide hairs that you want to affect. With no 
e affected. 

nce: In Reference mode, you edit the hair on the object in its reference position. 
on-symmetrical 

ve guides symmetrically. 

uide hairs that are 

 remove the guide hairs. 

The Dynamics tab controls how the hair behaves when it is in motion during a simulation. If your hair is 
too “bouncy” you can increase the stiffness so that it stays in place. The Dynamics tab also allows you to 

ics tab: Dynamics Properties (Per Hair Group), Simulation, and 
Forces. Each of these tabs is described in the sections that follow. 

1. If desired, use the Hair Selection tool to 
selection made, all guide hairs will b

2. Choose the Remove Guide Hair tool. 

3. In the Global section, choose the desired source object mode:  

• Normal: In Normal mode, you edit the hair on the object in its skinned position. 

• Refere
This is useful when you want to use symmetry on a figure that is in a n
pose. 

4. Check the Enable Symmetry option if you want to remo

5. Adjust the Radius, Flatness, and Falloff of the brush. 

6. Check the Restrict to Selection option if you want to only remove hair guides from a selected 
area. 

7. Increase or decrease the Strength of the brush to control the number of g
removed while you paint. 

8. Paint in the areas from which you want to

Dynamics Tab 

choose the forces in your scene that will affect the movement of the hair. 

There are three sections in the Dynam
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Dynamics Properties 

 
• Stiffness Section: Hair that has a higher stiffness setting will be less likely to change shape 

during simulation. 

• Root: Controls the amount of bending from the hair’s reference position. 
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• Hair: Controls how much the hair is allowed to bend. 

• Shape: Controls how much the hair will try to keep its reference shape and position. 

• Damping Section: 

• Air: This setting controls how much the hair will interact or lose energy with the air. 

• Density: This setting controls the number of hairs that are generated with each hair group. The 
number of hairs defined in the Hair Count section are multiplied by this value to determine the 
density. 

Simulation 

 
Control the starting and ending times, quality of hair, and collision detection in the Simulation section. You 

 demand, and convert draped or styled hair to a new reference 

• Time Range Section: This section determines the time range in the animation in which 
simulation will take place. You can enter your own values if you are working on a particular part of 
your animation.  

o Use Scene Time Range: Check this option to perform dynamic hair simulations 
throughout the entire range of the scene. Uncheck this option to enter a specific time 
range. 

o Start Time: Enter the start time of the simulation in MM:SS:FF format. 

o End Time: Enter the end time of the simulation in MM:SS:FF format. 

• Quality Section: This section determines the quality of the simulation. Higher settings will 
produce better results but make ations slower.  

he simulation. 

can also simulate or drape the hair on
shape. 

 simul

o Simulation: Adjust this setting to raise or lower simulation quality. 

o Hair: Controls the percentage of hair segments to control during t
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• Collision Section: This section determines whether the hair will be affected when it collides with 

ck this option to enable collision detection. When disabled, hair will poke 
cts that it collides with. 

ts before a 

ns.  

ulate: Press this button to begin simulation. 

r: Press this button to remove the current simulation data. When you play an 
animation after clearing a simulation the hair will not move. 

• Draping Section: Controls in the Draping section allow you to initiate draping of hair, and to 
convert draped hair to a new shape.  

o Drape All: Press this button to drape the hair a little bit at a time. The hair will react to 
forces a little bit at a time. This setting is different from simulation in that it does not 
become animation data. You can press the Escape key at any point during the animation 
to use the current draped shape. 

o Convert: Click this button to keep the hairs in the draped shape. 

o Iterations: This setting determines the maximum number of times that forces are applied 
to the hair before it stops draping. 

Forces 
The Forces section allows you to choose the forces in your scene that will be allowed to interact with the 
hair. Forces that are present in your scene will be listed in this area. 

other objects in the scene.  

o Enable: Che
through obje

o Distance: This setting controls how close the hairs should get to other objec
collision is detected. 

• Simulation Section: Controls in the Simulate section allow you to manually initiate simulation 
calculatio

o Sim

o Clea

 
• All Except: Check this option if you want to remove one or more forces that cu

the hair. 
rrently interact with 

s that appear in your 
 remove, click OK to 

• Only: Check this option if you want to add forces to interact with the hair. 

• Change: Click the Change button to open the Choose Forces dialog. Force
scene will be listed here. After you select the forces that you want to add or
return to the scene. 
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Assemble Room Hair Properties 
Yo
portion of the sists of two sections: General and Hair. 

u have a limited number of properties when you work with hair in the Assemble Room. The upper 
General tab in the Assemble Room con

 

General Properties 
Use the General section to assign the following properties to the hair object: 

 
• Name: By default, a new hair object is named Hair. You can rename the hair in this field. 

• Master: TBD 
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• Visible: Check or uncheck this option to make the hair visible in

• Animated: Check or uncheck this option to allow or disallow an

 your scene. 

imation on the hair object. 

e. 

m other 
objects in your scene. 

• Shader Section: This section allows you to assign or edit the shader that the hair uses.  

o Selection Menu: Click the arrow to the right of the current shader name to select another 
shader that is already used in your scene. 

o Edit: Click the Edit button to open the Hair Shader window, which allows you to 
customize the current hair shader. 

• Preset: Click the Preset button to choose a shader preset for the current hair object. 

Hair Properties 
You’ll find three sub-tabs in the Hair section, each of which is described in the following sections. 

General Tab 

The options you can set in the General tab are as follows: 

• Casts Shadows: Check or uncheck this option to allow the hair to cast shadows in your scen

• Receive Shadows: Check or uncheck this option to allow the hair to receive shadows fro

 
• Length: Enter a new value or use the arrows to increase or decrease the length of the hair. 

• Thickness: Use the drop-down menu to select Thin, Medium, Large, or Very Large thickness 
setting. 

• Scaling: Use the arrows or enter a new value to increase or decrease the scaling of the hair, 

ality: Use the arrows or enter a new value to raise or lower rendering quality of the 

which also makes the hair thicker. 

• Rendering Qu
hairs. 
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• Show Generated Hairs: Check this option to see the generated hairs while you work on the hair. 

ar as yellow lines in the Assemble room. 

Simulati

The option

Uncheck this option to hide the hairs. 

• Display Percentage: Adjust this slider to raise or lower the percentage of generated hairs that 
you see. 

• Show Guide Hairs: Check this option to display guide hairs (the hairs that are used to style the 
hair). Guide hairs appe

on Tab 

s you can set in the Simulation tab are as follows: 

 
Simulation properties can also be accessed in the Assemble Room through the Simulation section. 

• Time Range Section: This section determines the time range in the animation in which 
simulation will take place. You can enter your own values if you are working on a particular part of 
your animation.  

o Use Scene Time Range: Check this option to perform dynamic hair simulations 
throughout the entire range of the scene. Uncheck this option to enter a specific time 
range. 

o Time Range: Enter the start time and end time of the simulation in MM:SS:FF format. 

• Quality Section: This section determines the quality of the simulation. Higher settings will 
produce better results but make simulations slower.  

 Section: This section determines whether the hair will be affected when it collides with 

collision detection. When disabled, hair will poke 

o Simulation: Adjust this setting to raise or lower simulation quality. 

o Hair: Controls the percentage of hair segments to control during the simulation. 

• Collision
other objects in the scene.  

o Enable: Check this option to enable 
through objects that it collides with. 
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o Distance: This setting controls how close the hairs should get to other objects before a 
collision is detected. 

• Simulation Section: Controls in the Simulate section allow you to manually initiate simulation 
calculations.  

o Simulate: Press this button to begin simulation. 

o Clear: Press this button to remove the current simulation data. When you play an 
er clearing a simulation the hair will not move. 

n: Controls in the Draping section allow you to initiate draping of hair, and to 
convert draped hair to a new shape.  

o The hair will react to 
forces a little bit at a time. This setting is different from simulation in that it does not 
become animation data. You can press the Escape key at any point during the animation 
to use the current draped shape. 

o Iterations: This setting determines the maximum number of times that forces are applied 
to the hair before it stops draping. 

Hair Group Tab 

The options you can set in the Hair Group tab are as follows: 

animation aft

• Draping Sectio

 Drape All: Press this button to drape the hair a little bit at a time. 

 
• Hair Group: Click this button to select a hair group to work with. 

• Hair Count: Set the number of hairs that you want to generate for the hair group. 

ape 

will try to keep its reference shape and position. 

• Stiffness Section: Hair that has a higher stiffness setting will be less likely to change sh
during simulation.  

o Root: Controls the amount of bending from the hair’s reference position. 

o Hair: Controls how much the hair is allowed to bend. 

o Shape: Controls how much the hair 
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• Damping Section:  

o Air: This setting controls how much the hair will interact or lose energy with the air. 

 
ed in the Hair Count section are multiplied by this value to determine the 

Usi
emble Room. With the hair selected, click the Shading tab, 

and then 

• Density: This setting controls the number of hairs that are generated with each hair group. The
number of hairs defin
density. 

ng Hair Shaders and Presets 
To create or edit a hair shader, go into the Ass

click the Edit button to open the hair shader. 

 
Hair shaders have different properties than those of other materials. There are properties that control the 
colors, shininess, and highlights of the hair. You can also control thickness, length, density, frizz, kink, 
wave, and clump in the shader properties. 

The left portion of the shader window shows the various types of shaders that you can combine to control 
the appearance of your hair. 
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As you make changes to the hair shader, the preview window displays your changes. Check the Auto 
Upda to 
see a p

everal settings that control the 
e overall shade of the hair. The 

te button to update your changes manually, or uncheck the option and click the Render button 
review as needed. 

Controlling Hair Color with Shaders 
When you expand the Color portion of the hair shader tree, you’ll see s
appearance of the hair. These properties combine together to define th
properties include root color, tip color, shininess, and highlight. 

 
• Root Color: Defines the color that is at the root of the hair (closest to the polygons that generate 

a 

p color. If your object is UV-mapped and texture-mapped, you can 
also use a Texture Map node to vary the colors on the head. For more realism, select a tip color 
that is slightly lighter than the root color.  

• Shininess: Controls the amount of shine in the hair. Set the amount of shininess with Value 
sliders (0-100% or 1-10000%). 

• Highlight: Defines the color of highlights that are generated by lights shining on the hair. Set the 
amount of shininess with Value sliders (0-100% or 1-10000%). 

Styling Hair with Shaders 
Hair shaders also include various properties that allow you to control the thickness, length, density, frizz, 
kink, wave, and clumpiness of the hair. These properties appear in the lower portion of the hair shader 
tree. 

the hair). Root color is generally darker than the tip color. Click the Color button to select an 
option that defines the root colors of the hair. If your object is UV-mapped and texture-mapped, 
you can also use a Texture Map node to vary the colors on the head. For more realism, select 
root color that is slightly darker than the tip color.  

• Tip Color: Defines the color at the loose end, or tip, of the hair. Click the Color button to select 
an option that defines the ti
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Hair Thickness 

The Hair Thickness shader controls the thickness of each individual generated hair. For example, the 
 you do not want to control 
ual properties for root and tip 

hairs on a bristle hair brush are thicker than human hair. Set to None if
thickness with a shader. Choose Hair Thickness Shader to set individ
thickness. 

 

TIP! When using the Hair object to simulate grass, you can use this property to make the tips of 
the grass narrower than the roots. 

To add or remove a hair thickness shader: 

 

der. Set to None if you do not 
ength Shader to create a shader that determines the 

variation. 

1. Expand the Hair Shader tree to reveal the Thickness shader tree. 

2. Click the shader selection menu and do one of the following:  

• Choose None to remove a hair thickness shader. 

• Choose Hair Thickness Shader to add the shader to the property.  

3. Set the following properties:  

• Root Thickness: Adjust the slider to increase or decrease the thickness of the hair root. 

• Tip Thickness: Adjust the slider to increase or decrease the thickness of the hair tip.

Hair Length 

The Hair Length shader allows you to vary the length of the hair with a sha
want to control length with a shader. Choose Hair L
overall length of the hair, and the amount of length 

 
To add or remove a hair length shader: 

1. Expand the Hair Shader tree to reveal the Length shader tree. 

2. Click the shader selection menu and do one of the following:  

• Choose None to remove a hair length shader. 

• Choose Hair Length Shader to add the shader to the property.  
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3. Set the following properties:  

• Length: Adjust the slider to increase or decrease the length of the hairs. 

Hair Density 

The Hair Density shader allows you to control the thickness of the hair. This setting is multiplied by the 
number of hairs per hair group to determine the number of hairs that appear in a given area. When using 
a grayscale texture map, black is equal to a density setting of zero and white is equal to full density. Click 
the button to select an option for your density shader, or choose None if you do not want to control 
density with a shader. 

To add or remove a hair density shader: 

1. Expand the Hair Shader tree to reveal the Density shader tree. 

• Length Variation: Adjust the slider to vary the length of the hair by smaller or larger 
amounts. 

2. Adjust the Value slider to decrease or increase hair density. 
 

 

Hair Frizz 

The Hai
Cho  
freque

r Frizz shader controls the frizziness of the hair. Choose None if you do not want frizzy hair. 
ose Hair Frizz Shader to control the amount of frizz at the root and tip of the hair and to control the

ncy at which the frizziness occurs. 

 
To add or remove a hair frizz shader: 

er tree. 

roperty.  

• Root: Adjust the slider to increase or decrease the frizziness of the hair root. 

1. Expand the Hair Shader tree to reveal the Frizz shad

2. Click the shader selection menu and do one of the following:  

• Choose None to remove a hair thickness shader. 

• Choose Hair Frizz Shader to add the shader to the p

3. Set the following properties:  
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• Tip: Adjust the slider to increase or decrease the frizziness of the hair tip. 

ncy means that 

y Scaling: Controls the scaling of the frizz. 

• Frequency: Controls how the shader varies on the surface. A high freque
the frizz will change faster on the surface. 

• Frequenc

Hair Kink 

The Hair Kink shader controls the amount of kink in the hair. Choose None if you do not want to control 
the amount of kink in the hair. Choose Hair Kink Shader to control the amount of kink at the root and tip 
of the hair and to control the frequency at which the kink occurs. 

 
To add or remove a hair kink shader: 

 the Hair Shader tree to reveal the Kink shader tree. 

r to add the shader to the property.  

3. Set the following properties:  

• Root: Adjust the slider to increase or decrease the kink amount of the hair root. 

• Tip: Adjust the slider to increase or decrease the kink amount of the hair tip. 

• Frequency: Controls how the shader varies on the surface. A high frequency means that 
the kink will change faster on the surface. 

• Frequency Scaling: Controls the scaling of the kink. 

Hair Wave 

ount of wave in the hair. Choose None if you do not want to control 
plitude of the wave at the root and 

uency, amplitude, and phase are 

1. Expand

2. Click the shader selection menu and do one of the following:  

• Choose None to remove a hair thickness shader. 

• Choose Hair Kink Shade

The Hair Wave shader controls the am
the waviness of the hair. Choose Hair Wave Shader to control the am
tip of the hair and to control the frequency at which the kink occurs. Freq
controlled along the X and Y axes. 
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To add or remove a hair wave shader: 

1. Expand the Hair Shader tree to reveal the Thickness shader tree. 

2. Click the shader selection menu and do one of the following:  

• Choose None to remove a hair thickness shader. 

• Choose Hair Wave Shader to add the shader to the property.  

e root of the hair. 

ip of the hair. 

air. 

ls the number of waves along the Y axis. 

xis, offsetting the wave along the 
Y axis. 

te of clumping, and radius of clumpiness. 

3. Set the following properties:  

• Root Amplitude: Controls the size of the waves at th

• Tip Amplitude: Controls the size of the waves at the t

• Frequency: Controls the number of waves in the h

• Frequency X: Controls the number of waves along the X axis. 

• Frequency Y: Contro

• Amplitude X: Controls the size of the waves along the X axis. 

• Amplitude Y: Controls the size of the waves along the Y axis. 

• Phase X: Controls where the wave starts along the X axis, offsetting the wave along the 
X axis. 

• Phase Y: Controls where the wave starts along the Y a

Hair Clump 

The Hair Clump shader controls how much the hair “clumps “or sticks together during simulation. Choose 
None if you do not want to control the clumpiness with a shader. Choose Hair Clump Shader to define 
the hair count, clump percentage, ra
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To add or remove a hair clump shader: 

1. Expand the Hair Shader tree to reveal the Thickness shader tree. 

2. Click the shader selection menu and do one of the following:  

• Choose None to remove a hair thickness shader. 

ader to add the shader to the property.  

reated. 

together. 

 shader. 

ape of the clumps (how quickly they clump together). 

 the count. 

C
The followi ave dragged the Hair icon 
on

• Choose Hair Clump Sh

3. Set the following properties:  

• Count: Controls the number of hair clumps that area c

• Clump: Controls how much of the hair is clumped 

• Variation (Clump): Adds variation to the clumps created by the

• Rate: Controls the sh

• Radius: Controls the minimum radius of each clump, which also affects

• Variation (Radius): Adds variation to the radius of the hair clumps. 

reating Hair on a Human Figure 
ng example assumes that you have loaded a human character and h

to it as outlined in "Adding Hair to an Object." 

To create hair on a figure: 

1. To remove hair from all parts of a figure, first click the Grow Region tool in the Hair Toolbar. 
 

TIP! You may find that it is easiest to start in Lasso selection mode to select a large area 
of polygons, and then use the Paint method to refine the selection. 
 

NOTE! When using the Lasso selection method, your selection may also include polygons 
that are facing away from the camera. Always view your object from multiple camera angles or 
rotate the camera as needed to verify your selections. 

2. After you select the desired polygons, you can set hair properties in the General tab. 

3. Set length, thickness, and hair scale in the General section. 

4. Add additional guide hairs in the Guide Hairs section, or use the Add Guide Hair tool to paint 
additional guide hairs where you need them. 
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5. After you have the desired length and a sufficient number of guide hairs, you can drape the hair 
to get a more relaxed shape to start with. Use the Drape tool in the Hair Toolbar, or the Drape All 
button in the Simulation section of the Dynamics tab. 

6. Use the hair styling tools in the Hair Toolbar to add curl, cut, straighten, and change density as 
needed to complete your style. 

7. When you get a style that you want to keep as the basic hair style, go back to the Simulation 
section of the Dynamics tab and click the Convert button. This “sets” the shape of the hair for the 
simulation. 

Ren e. 
An image h  or page-layout program. 

e photo-realistic images because it considers all of the objects in a 
scene nteraction of lights and 
surfa

Since you r of renderings of 
it:f n a 2D drawing 
prog you simply 
move the ca

A rende rings 
in m op, and others. You 
can open you

ecial information in data 
e manipulated in an image 

editing program to create special effects.  

nt scene or several scenes sequentially using the batch list. 

Befor

rrange the objects in the scene. Refer to "Arranging Objects

Rendering 
About Rendering 

dering is the process of capturing a view of a three-dimensional scene and saving it as a 2D imag
as to be rendered before you can print it or open it in an image editing

Carrara's rendering process can creat
simultaneously and calculates not just forms, color, and texture, but the i

ces within the scene. 

r Carrara scene exists in three dimensional space you can take any numbe
rom different angles and even with different lighting conditions. If you create an object i

ram and want to look at it from another side, you have to redraw the object. In Carrara, 
mera to another view and re-render the scene. 

ring is a separate file and is stored on disk in a different format. Carrara lets you save rende
any popular image formats: PICT, Windows Bitmap (BMP), TIFF, Adobe Photosh

r renderings in an image-editing program, or place them into virtually any application.  

The G-Buffer is a special feature of Carrara that allows you to include sp
channels that are saved with the rendered image. These channels can b

You can shorten rendering time by using multiple computers connected by a network.  

You can render either a curre

Steps Before You Render 
e you produce a rendered image, complete the following steps: 

To prepare an image for rendering: 

1. A " and "Working with Objects" for 
additional information. 

2. If desired, apply shaders to give the objects interesting surfaces. Refer to "Shading" for more on 
shading. 

3. Adjust the position and settings of the camera to frame the view of the scene you want re
Refer to "

ndered. 
Positioning and Aiming Cameras." 

4. Adjust Ambient Light, Background, and Atmospheric settings. Refer to Ambient Light for more 
information about setting ambient lights. 

 © 2008 DAZ 3D, Inc. 781 



Carrara 7 11 December 2008 

5. Apply any desired filters. 

6. Verify that the scene is as you wish. You are ready to render the scene. 

Using the Render Room 

room button at the top of the Carrara window, or by pressing Command/Ctrl+5 from 
another room. 

 Render room contains trays for Properties and the Browser. In addition, the 
e replaced by a Render tray you use to select a file to render or to 
nder in a session. Refer to "The Properties Tray

All of your rendering takes place in the Render room. You can either access the Render room explicitly 
through the Render 

Like other Carrara rooms, the
contents of the Sequencer ar
accumulate several files to re ." 

er room. You can open image files directly from the Render room 

s by rendering one or more scenes when you 

The Render tray is unique to the Rend
or open and modify batch lists. 

The Render Tray 
The contents of the Sequencer are replaced in the Render room by the Render tray. Use this tray to 
assemble files to be rendered and to manage the way they are opened, rendered, and saved. 

The Render tray has two modes: Current Scenes and Batch Queue. When you click the Current Scenes 
tab in the Render tray, you'll see a list of the currently open files. 

When you click the Batch Queue tab, you can set up a list of files for batch rendering. 

Batch rendering also allows you to manage system resource
are away from your computer. 

 
To render a scene, do one of the following: 

• Press Cmd/Ctrl+R to start rendering using the de

• Click the Render room button or press Cmd/Ctrl+5 to enter the Ren

fault render settings. 

der room and make additional 
resolution. 

f the scene files you want to render. It can contain a single file or multiple 

rendering decisions such as adding additional effects or setting 

Batch List 
The batch list contains the list o
files. 
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Current Scene Selections 

When you select the Current Scene button, you have the two options: Render and Abort. Press Render to 
int. 

Batch Queue Selections 

agement controls display to the right (top) of the batch list. The selections are: 

 Clear clears all entries from the batch list. 

aved batch. 

tch. 

ed from their last incomplete frame. Images are resumed from their last 
incomplete rectangle. 

If you use Pause while rendering a file using lossy compression such as JPEG or GIF, double 
compression artifacts will appear. 

To assemble images to render: 

1. From the Render tray, select Add and Remove as needed to add files to be rendered to the 
Render list. 

dy to render again. 

 to pause the rendering, Resume to continue. 

dicator shows the progress of your renderings. 

start the rending process and Abort to stop it at any po

When you select the Batch Queue button, you switch the Render tray to Batch Queue mode and a 
selection of batch man

• Add adds another file or batch list to the current batch. 

• Remove removes the selected file from the current batch. 

• Reset sets all of the files ready to be rendered again. 

•

• Load loads a previously s

• Save saves the current ba

• Launch starts the batch rendering process. 

• Pause allows you to quit Carrara and resume rendering at a later time. 

• Resume allows you to continue after selecting Pause. 

• Abort stops the batch rendering process. 

• Pause allows you to quit Carrara, turn off your computer, and resume rendering at some later 
time. Movies are resum

2. Select Reset to set all of the files rea

3. Select Clear to remove a selected image. 

4. Use Load to load a previously saved batch file or Save to save the current batch as a batch list. 

5. Select Launch to launch the batch rendering process or Abort to stop it. 

6. Select Pause

7. The Status in
 

 

The Image Window 

When you render a scene, the image is displayed in a window when rendering is done. If you want to 
keep this rendering, save the file using the File > Save command. The images are automatically saved as 
files when using the Batch Queue mode. 
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When you open a rendered image, it's displayed in the window shown below. 

 
You can double-click a file name in the Batch Queue list to open that image. 

ering features available in Carrara. 

The Properties Tray 
The Properties tray contains most of the special rend
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The top of the Properties tray contains tabs for Renderer Settings, Output Settings, and 
Progress/Statistics. 

Depending on your selection, different options appear in the main body of the Properties tray. 

For example, for Renderer Settings, you can select a type of renderer. Once selected, you can then 
continue to choose options appropriate for that rendering engine. 

Rendering the Current Scene 
To render just the current (saved) scene from any room, you can go to the Render room and either render 
it with the current rendering settings, or customize the render settings in the Properties tray. 

 
To render the current scene: 

1. Create or open a scene. 
2. Go to the Render room by selecting the Render icon or pressing Cmd/Ctrl+5. 
3. Click the Current Scenes tab in the Render tray 
4. Click the scene file name in the Render tray.  
5. Apply any desired rendering settings in the Properties tray.  
6. Select the file size, name, and format for the output. Refer to "Selecting Output Settings." 
7. Click the Render button, or press Cmd/Ctrl+R. You can also press Cmd/Ctrl+R while in any room 

to render the current scene using the current settings. 
 

 

8. Check on the status of your rendering in the Stats window. Refer to "Rendering Statistics." 
9. Observe the rendered image in the Image window. Refer to "Batch List." 

Rendering from a Batch List 
You can render a batch of files or select a file from a pre-defined batch list. 

To render from a batch list: 

1. Go to the Render room by selecting the Render icon or pressing Cmd/Ctrl+5. 

2. Click the Batch Queue tab 

 © 2008 DAZ 3D, Inc. 785 



Carrara 7 11 December 2008 

3. Do one of the following:  

• Click the Load button to load an existing batch that has been previously saved to your 

ons. 

ply any desired settings in the 

ame file more than once and set up different 
settings for each instance. This allows you to render several variations of the same file in a single batch. 

5. Select the file size, name, and format for the output of the selected file. Refer to "Selecting Output 
Settings". 

6. When you have finished setting up all of the files in the batch that you wish to modify, click 
Launch. Refer to "Current Scene Selections". 

7. Check on the status of files you are rendering in the Stats window. Refer to "Rendering Statistics". 

8. Observe the each image as it is rendered in the Image window. Refer to "Batch List". 

9. Double-click a file name in the batch list to open the image file. 

Rendering Preferences 
The options available in the Render Room Preferences dialog are as follows: 

o File Name Prefix: Enter a prefix to be added to all files that you render. 

dit the ports 
cation.  

hard drive.  

• If desired, you can add or remove files from the batch with the Add and Remove butt

4. If you wish to change the render settings on any file, click it, then ap
Properties tray. Refer to "The Properties Tray". 

You can specify different settings for each file, or add the s

The settings you specify in the batch list are separate from the current settings which are used when you 
press Cmd/Ctrl+R. 

• Batch Rendering:  

o : File Name Suffix  Enter a suffix to be added to all files that you render. 

anel for the render room, you can eo Network Rendering: In the preference p
 communithat are used for the network rendering

 

 
o Manual or Automatic: If the automatic configuration does not work, you can manually 

tween 5000 and 65535. Port 1 must match the 
port number that you set in the preferences of the rendering node you plan to use. 

machine 
rk. The ID and subnet mask can be obtained on Windows by typing 

 Output Without Permission: Check this option to prevent 
t same name. 

set up the subnet ID and mask. 

o Ports: The ports should have a value be

o ID  Mask
on the netwo

 and : The ID and the subnet mask are given by the IP address of your 

"ipconfig" in Command Prompt window. 

• Don’t Overwrite Rendering
overwriting files of the exac
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• Always Render in a New Window: Check this option to start all renders in a new window. 

N
ely fast, Carrara allows you to use other 

rnet hub or router. Make sure that all the computers are located on the same IP 
se 

Rendering on a Network 
achines are started, you are ready to launch network 

rendering. 

t to render to the batch list (see "Batch List

• Check Before Overriding Rendering: TBD 

etwork Rendering (Pro) 
Even though the rendering engines of Carrara are extrem
networked computers to speed up rendering. 

Setting up a Network 
To perform network rendering, you need access to computers on the same network. This can be done 
using a simple Ethe
subnet (this is usually the case as long as you have only one hub or router on your network), becau
Carrara will look for rendering nodes only on this subnet. 

Once your network is in place, you need to install a rendering node on each machine that is going to take 
part in the network rendering (except the machine on which you are using Carrara). Then you need to 
start the rendering nodes so that they are waiting for the rendering to start. 

After the rendering nodes on your networked m

To launch a network rendering: 

1. Add the file you wan "). 

2. Select the rendering settings and output options. 

3. In the Properties tray, check Enable Network Rendering . 
 

 
4. Click on the Launch button. 

he rendering nodes that are available (up to the 
 
The rendering is automatically launched on all t
number authorized by the license you purchase). For each computer actually rendering on the 
network, you should see a tile with an 'N' (for Network). 
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Troubleshooting Network Rendering 
might not work: 

ueue and that enable network rendering is 
checked. 

node is using the same port (Port 1) as the main application (see 

There are a number of reasons why network rendering 

• Make sure that you are rendering in the batch q

• First make sure that your computers can see each other on the network (check the "Computer 
near me" or Network Neighborhood). 

• Make sure that the rendering 
"Rendering Preferences"). 

• Use the log feature to see if the rendering nodes are properly registered by the main computer. If 
they are, they should show up in the network log file. 

• Make sure that the ports used for the network rendering are not blocked by a firewall or already in 
use by some other application. You can try to change to ports to see if it changes something. 

cts 
 with fog or turbulent smoke. 

Using Post Render Filters 
Rendering with an Aura 
Aura lets you render true glowing objects with an outside aura. The light emitted from the glowing obje
can interact

 
Aura automatically detects which object
laser beams, neon signs, or LEDs. 

Aura uses the shader Glow channel to know which object are glowing and which are not. Only objects 
that have some degree of luminance in the Glow channel receive

s have a glow shader, letting you create impressive effects like 

 an aura. 

To set up the glow channel for an object: 

1. Select the object you want have an aura. 

2. Click the Texture button to go to the Shader room. 

3. In the Shader Tree Editor window, make sure the top shader is a Multi-Channel shader. 
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4. Click in the Glow channel. 

5. Adjust the Glow settings as desired.  

NOTE! For details on using the Glow channel, refer to "Glow". (Standard, Pro) 

To apply an aura to a scene: 

. 

 size, in inches, of the wreath of smoke. 

l in the wreath of smoke. 

m to move (change over time). This option slows 
en doing animations. 

 color and the aura color. Higher luminance values result in a 
brighter glow and, therefore, a stronger aura. 

10. Drag the Intensity slider to change the strength of the aura effect. 

Rendering with Glare 

1. Click the working box to deselect any objects in the scene. 

2. In the Properties tray, click the Filters tab

3. Click the plus (+) sign, and choose 3D Aura from the pop-up menu. The 3D Aura editor window 
appears. 

4. Drag the Radius slider to set the radius of the aura. Radius describes the number of inches 
before the aura fades out. 

5. In the Turbulence section, check the Enable box if you want swirls in the aura medium (smoke 
wreaths). 

6. Drag the Turbulence Scale slider to set the mean

7. Drag the Lumpiness slider to set the contrast leve

8. Enable the Animate option if you want the mediu
down the rendering. Use it only wh

9. To change the color of the aura, click on the color chip under the preview window. Carrara opens 
the system color picker so you can choose a color. The color of the final aura effect results from 
the interaction of the object's glow

 
To set glare options: 

• Height and Width controls the size of the effect. 

• Intensity controls how much glare is added. 

• Shape defines the shape of the glare pattern. 

•  Algorithm specifies which algorithm is used to calculate the glare. 
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• Color controls the color of the halo when the Algorithm is White. 

 the glare bleeds over to the background. 

Mot
e and someone moves at just the wrong moment, that person's image is 

 be blurred. This effect is called 

• Background Accept Glare controls if

ion Blur (Standard, Pro) 
When you take a family pictur
blurry. In films, fast moving objects like the wheels of a car will often
Motion Blur.  

The Motion Blur post render filter combines successive frames of an animation to achieve that real-life 
blurred effect on moving objects. 

 
When rendering fast moving objects, 24 or even 60 frames per second are often not enough frames to 
capture the full complexity of the motion. For example, a spinning propeller can complete a full rotation 

are. However it is an important 
st motions look unrealistic. Carrara allows you to 

a frames and combining them together to create a similar effect to 

To add the Motion Blur filter to your scene: 

1. In the Assemble room, select the Instances tab of the Properties tray. 

2. Click on the first line of the hierarchy to display the scene properties. 

3. Select the Filters tab then use the Plus (+) button to add the Motion Blur filter. 

To set Motion Blur options: 

• Intensity: controls how many frames will be used to compute the effect 

• Blur: enables the blur of the frames used for the effect. 

• Blur Radius: controls the strength of the blur 

• Render First Frames: Renders the first frames of the animation when checked. When 
unchecked, the first frame  are replaced by a black image until enough data has been gathered. 

ur 

 in the rendering rooms under the Rendering tab: 

between 2 consecutive frames. 

In a real video camera, the camera shutter remains open for a short period of time and a moving object 
creates a blurry imprint on the film along its trajectory. This blur along the motion of an object is called 
Motion Blur. 

One could think that Motion Blur is an undesirable artifact of camera hardw
part of what makes a movie look real. Without it, fa
simulate motion blur by rendering extr
what a real camera generates. 

s

Using Motion Bl

The Motion Blur panel is located in the Properties tray
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To add motion blur to your rendering: 

1. Check the Enable Motion Blur check box. 

2. Select the number of extra frames you want to render. 

3. Adjust the motion blur settings. 

4. Render your scene. 

Vector and 3D Motion Blur. You can use either one alone or both 

tic 

frames to create a smooth looking output. You can 
results simply by adding more frames. 

stic renderer. 

Vector and 3D Motion Blur (Pro only) 

Carrara offers two types of motion blur: 
types can be combined together. 

3D Motion Blur uses a number of extra frames to simulate the motion blur. It provides extremely realis
results because it takes into account every single effect that is affected by time (such as a moving 
shadow, a reflection, or a deforming object). However it often takes a great number of frames to get a 
good result. When the number of frames is too low, you get a very unpleasant effect. 

Vector Motion Blur allows you to render fewer frames and still get a correct motion blur effect. It works 
by interpolating the motion of objects between two 
combine it with 3D Motion Blur to get better 

Vector motion blur has a number of limitations: 

• It only deals with moving objects and not with shadows, reflections,... 

• It does not handle deforming objects properly. 

• It can only be used with the photoreali
 

 
To set Vector Motion Blur options: 

2. Select Backward and Forward blur option to blur the motion in both directions around the 
position of the object at the exact time of the frame. (This is what a real movie camera does). 

1. Check the Vector Blur checkbox. 
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Select Backward Only or Forward Only to create a blurry trail only after or before the object 
(This is especially useful to give the impression of movement in a still image). 

3. Adjust the Extra Frames slider to control how many extra frames will be rendered to simulate the 
blur. 

4. Adjust the Blur Intensity to control how much motion blur will be applied. 

Motion Blur at time 0 

You can also use motion blur on still images. However you have to be careful that the motion of the object 
exists before and after the frame you are rendering. For that reason you should render a frame at a time 
different than time 0 to get the full motion blur effect. 

tart rendering an animation at time 0. The proper way to render an 
at a later time. You can do that by moving the start 

 Carrara that changes your rendered output into a cartoon drawing. Here 

for the purposes of tracing the outline 

er. While Line Effect 
es obscure the original render. 

anges the size of the 

Edges traces the edges of objects, and 
e before drawing a line. 

• Distance puts a line where there is a change in distance from the camera. 

• Distance Threshold controls the difference in distance from the camera that pixels must be 
before drawing a distance line. 

• Shadow Edge traces the edges of shadows. While Highlight Edge outlines specular highlights. 

• Algorithm reduces the jaggies in Toon!'s lines. Selections are None, Toon 1, Toon 2, and 
Custom.  

al Toon! algorithm. It's slower, but doesn't fatten lines.  

d smoothes better, but fattens the lines. Custom with the 

For the same reason, you should not s
animation with motion blur is to start your animation 
time of the rendering in the Sequencer tray. 

Cartoon Rendering 
Toon! is a post-render filter for
are some of the features of Toon!: 

• Fully supports shaders 

• Plays well with other filters 

• Can group multiple objects together 

• Mixes traditional rendering and Toon!ing in the same render 

To set Toon! options: 

• Line sets the color of the lines. Shadow sets the depth of the shadows. 

• Base adjusts the base color. Highlight adjusts the highlight color. 

• Toon Effect controls the mix of how much Toon! obscures the original rend
controls the mix of how much Toon!'s lin

• Shadow Size controls the size of the shadow. While Highlight Size ch
highlight. 

• Object Edge traces the edges of your models, Sharp 
Edge in degrees controls how sharp the edge must b

o Toon 1 is the origin

o Toon 2 is newer, faster, an
default filter smoothes better than Toon 2, but doesn't stay as dark. 
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o When Custom is selected, you can adjust how it smoothes using the nine values belo
the Algorithm popup. The values control how much line, shadow, or hig

w 
hlight effect from 

s controls how many passes of smoothing are applied when Algorithm is set to Toon 2 or 

on!  

the purposes of tracing an outline. It's not always convenient to build 
 But if you want Toon to treat it as one mesh, you can use Toon Group. 

surrounding pixels is mixed with the middle pixel's effect. 

• Passe
Custom. 

Getting started with To

To add a post-render filter to your scene: 

1. Select the scene on the Properties palette. 

2. Select the Filters view. 

3. Use the Plus button to add the Toon filter. 

To Group things together: 

Toon can group items together for 
your models from one giant mesh.

 
1. Select the items you want together. 

o group the selected items. 

up checkbox. 

llows you to control the Toon 

2. Use the Edit>Group menu t

3. Select the new group in the Object Hierarchy or in the 3D View. 

4. On the Properties palette, select the Effects view. 

5. Check the Toon Gro

To mix Raytracing and Toon: 

Toon! can mix Raytracing and the Toon effect. The Toon Override Effect a
and Line Effects on an object by object basis. 

 
To make Toon! go faster: 

Every effort has been made to make Toon! as fast as possible, but there are some options you can set 
when you really need the speed. 

• Turn off the Smooth Lines option. On animations with compression, Smooth Lines may not be 
necessary. 

• If you do use line smoothing, Toon 2 is much faster than Toon 1. 

r times 

• 

• Lower your Line Widths - each time you double the line widths, Toon! must examine fou
as many pixels. 

On your render settings, turn off Adaptive Oversampling. 
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R

ed solely for the rendering and that do not change the original scene file are applied 
in the Render room and become part of the output file settings. 

dows or bump, you select them through the Properties tray in 
anent part of the original file as render settings. If you wish 

ly them in the Assemble room, then switch to the Render room 

endering Effects 
Rendering effects that become a permanent part of the scene file are applied in the Assemble room. 

Effects that are appli

For example, if you would like to apply sha
the Render room. The settings become a perm
to apply fog or backgrounds, you must app
to render the image. 

  

The Rendering Procedure 
After you've built a scene, set lights, and chosen a viewpoint, you are ready for rendering. 

cene several times at different resolutions as you test your scene and 

solution proofs, so you can check your work. 

At each proof stage, you can change your Rendering Settings, depending on the image aspects you want 
to check. For example, if you want to look at just the objects, you might use the Draft Renderer. Or if you 
are concerned only with shading and shadows, you might turn off the other ray-tracing options, like 
reflections and transparency, which add to rendering time. 

After making all the adjustments you need in order to create the desired image, you can generate the final 
high-resolution rendering. 

e Rendering 
 and settings to control and enhance rendering. To get the rendering 

y want to: 

ails on cameras, refer to 

You will probably render your s
make adjustments. 

The first few renderings will probably be low re

Enhancing th
Carrara offers a number of options
results you want, you must make several choices and adjustments. 

For example, you ma

• Change the camera or render from several camera views. For det
"Setting Cameras." 

• Set compression or render to several file types. 

• Change the renderer, including quality and features. 

• Include the scene in a batch to render with other scenes. 
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Your choices will be based on your e
objects, rendering final artwork, or re

xpectations:whether you are creating a draft rendering to check the 
ndering an animation. 

d. 

• If a Spline object is distant from the camera, open it in the Spline modeler and lower its surface 
fidelity to the minimum. This results in the minimum amount of RAM being used for its geometry. 
(Standard, Pro) 

• When an object leaves the frame, and isn't reflected in any surface that you can see in the 
rendering, activate its Cloak property. This won't save memory, but it does save rendering time. 
Objects that pass behind solid objects can be cloaked to save time, too. Be careful that you do 
not lose a cast shadow where one is needed. 

You can speed up rendering by applying these techniques: 

• Use the Draft Renderer to preview your object positions and movement. 

• Work with smaller image (frame) sizes. The standard for CD-ROM-based QuickTime movies is 
half-screen size, or 320 by 240 pixels although satisfying results can be achieved t 240 by 180. 
(You can then scale up to full-screen size for VHS output, although pixilation may be apparent 

, which is adequate for QuickTime movies. (Video 

ber of lights. 

 options. 

ct 

f reflective and transparent objects. 

 objects that won't be seen on-screen. 

animation. 

 Optimization 
cted by available RAM and disk space. You can never have a fast enough 

onitor, or a fast enough computer. With that in 
rformance out of your system. 

ses its own virtual memory system to 
disk. The greater the disparity between 

All of these choices are available in the Properties tray of the Render room. 

Speeding up Rendering 
There are several techniques you can use to reduce your rendering time. These techniques are 
especially useful when rendering animations that may have hundreds, or even thousands, of individual 
images to be rendere

,  a

when you scale up.) 

• Limit the number of frames per second to 15
uses 30 fps and film 24 fps.) 

• Simplify objects and reduce the number of objects in the animation. 

• Limit the num

• For the Photorealistic Renderer, disable the Reflection, Transparency and Refraction

• Use low detail accuracy (2-4 pixels) to speed up rendering. 

• Keep objects near the background simple. (A complex bitmapped background does not affe
rendering speed.) 

• Limit the size of texture maps. 

• Limit the number o

• Divide animations into smaller files and eliminate

• Turn off anti-aliasing when previewing rendered 

• Close any opened Modeling windows to free up memory. 

Computer System
Carrara's performance is affe
computer, enough RAM or disk space, a large enough m
mind, here are some things you can do to get the best pe

If you have a scene that uses more RAM than you have, Carrara u
keep things running, spooling data back and forth to the hard 
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RAM needs and what is available, the more speed it costs you. If the scene ends up dipping into the 
operating system's virtual memory as well, performance can be very poor. In this case, adding RAM can 

y faster. 

The fastest rendering takes place on a fast processor with plenty of RAM. Systems used in professional 

, you need a large hard disk with plenty of free 
space. 

g on the file icon, or by double-clicking the name in the Batch Queue list. Or, you 

e, and any G Buffers before you render. 

 for each inch of image area: pixels (or dots) per inch (PPI or dpi). 

 
e inch square on the screen of that monitor. VGA monitors have 

me image setters can 

n creates a slight problem:pixels are different sizes on different 

less than 1/4 in. when printed on a 

pect ratio of your image appears in the fields in Image Size 

 and 

improve speed, although this makes the computer run more efficiently, not an

animation often need 128 MB RAM or more. 

Because all rendering involves some spooling to disk

To keep your hard disk running efficiently, use disk utilities to scan for disk errors, and defragment your 
hard disk prior to starting a project or even a long rendering session. 

Don't run other programs in the background. Some screen savers use as much CPU time as Carrara. 

Renderings generated from the Batch Queue are automatically saved to disk. You can open these files in 
Carrara by double-clickin
can open and view them in another graphics application. 

Selecting Output Settings 
You must select the image size, camera, file format, file nam

Image Size 
The resolution of a device, such as a monitor, printer, scanner, or image setter, is described as the 
number of pixels it can create

(For example, the screen of an Apple color monitor has 72 dots per inch (dpi). Each dot is a pixel, so an
image that is 72 x 72 pixels would be on
slightly higher resolutions. Many color printers are capable of 300 dpi, and so
produce more than 2,500 dpi. 

This discrepancy in device resolutio
devices, so an image displays or prints at a different size on devices of different resolution. For example, 
the 72 x 72 image that appears 1 in. square on the screen would be 
300 dpi printer. (72 pixels drawn at 300 dots per inch: 72/300 = 0.24 in.) 

The solution is to set the rendering parameters according to the size of the image you want from a 
particular output device. 

The original size, resolution and pixel as
selection of the Properties tray. 

You can accept the default size of the image, or enter new information to change the image size
other size-related properties. 
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To set the image siz

1. Choose the 

e and resolution: 

Properties tray: Output Settings button . 

ure. Set 

e at 600 dpi may occupy as much as 100 MB on disk. (The size varies 

idth of the pixel divided by its height. A ratio of 1.5 specifies large but not tall 

xamining the automatically generated information displayed under 

Rendering Camera 
You can render from any of the cameras in the scene. By default you will render from the current camera. 
Refer to "Setting Cameras

2. Select the Image Size panel. 

3. In the Width and Height entry boxes enter the dimensions and units you want for the pict
the size according to your final output. 

4. In the Resolution entry box, enter the resolution (dots per inch) of the expected output device. 
 
A six-inch square imag
depending on file format and image content.) 

5. Enable the Keep Proportions option if you want to keep the same aspect ratio (ratio of width-to-
height) when you change either the width or height. 

6. Select a Pixel Aspect ratio if you are working on a system that does not use square pixels. 
 
The ratio is the w
pixels. A ratio of 0.75 specifies slim, tall pixels. 

7. Verify the properties by e
Properties in the Image Size panel. 

" for more information about creating and using cameras. 

To change the camera, you use the Camera option in the Properties tray. 
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To select a camera view: 

1. Choose the Properties tray: Output Settings button . 

2. Select the Rendering Camera panel. 

3. Select the Camera button. 

The list displays all cameras in your scene. 

NOTE! If you want to render one scene several times from different cameras, use the Batch Queue. 

 to 

 saved to disk and set options for it. These controls 

File Format 
Before you can render, you must select a file format for the output, as well as other information needed
save in the selected format. You can render either the current frame or a movie. 

The File Format controls let you choose the type of file
also let you specify the frame range and rate for rendering animations. 

 
To select a file format for a still scene: 

1. Select Properties tray: Output Settings button. 

2. Select the File Format panel. 
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3. Select Current Frame. 

4. Select a file type from the list. 

5. Click Options. Carrara displays a dialog that lets you set features for this file format. 

The Alpha Channel 
The alpha channel (also referred to as a mask in other 2D and 3D software) is an extra channel that can 
be saved in your image file. It is a "shadow" image of your scene. It describes where objects are versus 
where they are not. 

The alpha channel is used as a selection of your image when you paste onto a background in an image-
editing program. Pasting a foreground image onto a background is called compositing.  

s flares or light cones will also appear in the alpha channel allowing you to 
ffects when compositing with another image. 

ctions on selections, masks and 

 in channel #4, the Alpha channel, which is where masks are usually 
obe Photoshop. 

1. Select a File Format that supports alpha channels (The checkbox for the alpha channel will be 

movies, for example). 

r Alpha Channel to enable alpha channel rendering. 

3. Select Use Pre-multiplied Alpha if you need the alpha channel to be pre-multiplied into your 

 and not pre-multiplied 

Name File  
Use either the default file name or select a file name. If you use the default, you automatically write over 
the existing file. If you select In Named File, you must choose the file name and storage location. 

Certain effects such as len
create nice transparency e

Refer to your image-editing application's documentation for instru
compositing. 

Carrara puts the alpha channel data
kept in applications like Painter and Ad

To render the alpha channel: 

enabled when you select such a file format. You can use Tiff for still images or QuickTime for 

2. Select Rende

image. 

Most image-editing applications (including Adobe Photoshop) use standard alpha
alpha. Refer to the documentation of your image-editing or movie-editing application to know if you need 
to use pre-multiplied alpha. 
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To name your rendered file: 

1. Select the Properties tray: Output Settings button . 

over the existing file or In Named File to create a new file. 
tomatically writes a file when you are rendering using a batch queue. 

4. If you selected In Named File, select a path and enter a file name. 

ground color.  

e 
ours and hours. The edits to layers can be changed in minutes.  

tab . 

Photoshop format to have the layers rendered to a 
 

m. 

2. Select the File Name panel. 

3. Select either Default File Name to write 
Default File Name only au

Multi-Pass Rendering (Pro) 
Carrara 7 Pro adds multi-pass rendering capabilities which enables you to render multiple passes and 
save these off to separate image files. These render passes or layers (multi-pass render layers) can be 
edited in another application like Photoshop to increase contrast in the rendered image, change a 
reflection color, make an edit to a shadow map, or even swap out a back

This tool makes it faster to make changes to a rendering which if you needed to re-render to see th
changes it could take h

To use multi-pass rendering: 

y: Output Settings 1. Choose the Properties tra

2. Set your image size, file format, etc. Select 
single Photoshop file with rendered layer as a Photoshop layer. Selecting another image format
will render the layers out as individual images which can then be combined in any paint progra

3. Select the Multi-Pass panel (all the way at the bottom). 
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4. Select Elements - 

a. Click on the Add button. The Add Multi-Pass Layers dialog will come up. 
 

 
b. Select which layers to add to the Multi-Pass Render. Use Ctrl+click to select multiple 

layers.  
 
Select individual layers or the group layer, i.e., select Material to add the ambient, diffuse, 
and specular layers all at the same time. 
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The layers will be added to the Elements listing. 
 

 
To delete layers, select the layer and cl

To not render a layer but keep it in the listing,
useful when you only need to re-render a
layers available for later rendering. 

Element Options -  

c. ick on the Delete button. 

d.  click in the check box to deselect it. This is 
 specific layer but need to keep the remaining 

5. Select 

le 
ake sure the selected file format will support layers, such as Photoshop. 

ustom: When selected, will save the renders as a separate image file for each multi-
pass element using the selected file format. With Custom, each layer can be saved as a 
different file type. 

6. To not use anti-aliasing on a layer, click in the check box next to Anti-Aliased to deselect it. Note 
that this option is not always deselectable depending on the layer type. This option is available to 
assist with mask creation since the edges are not anti-aliased and if the items on as specific layer 
should not be anti-aliased. 

7. To use the Correct Layer Blend Mode option, click in the check box next to it to select it. This 
option may produce better blending results in some paint applications. By default, this option is 
not selected but if you have layer blending issues in your paint program, select this option for the 
layer having the blending issue. 

8. Click on the Render button. 

Example of the rendered layers as separate images: 

• Embedded: When selected, will save the renders into a single image file using multip
layers. M

• External: When selected, will save the renders as a separate image file for each multi-
pass element using the same file format used for the main image. 

• C

 © 2008 DAZ 3D, Inc. 802 



Carrara 7 11 December 2008 

 

G-B
Carrara  information in 
ad

uffers 
 can calculate and save several separate channels of geometric and lighting

dition to your full color rendered image. These are called G-Buffers. 

 
The data in each of these channels describes the point in your 3D scene that each pixel in the image 
represents. For example, if the scene shows a drinking glass on a wooden table, each pixel in the 
rendered image corresponds to a point:on the glass or on the table:in your 3D scene. 

There are two types of G-Buffers: 

• Image G-Buffers: These additional channels appear as grayscale images, where the gray values 
represent information. 

• Actual G-Buffers: This buffers store values in a format that represent the actual value of the 
channel. (For instance, for the distance it would store a floating point value for each pixel.) 
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Not all file formats are capable of storing all of the channels possible. 

To save Actual GBuffers, you should save to the RPF format. 

To save image G-buffers you need to save to Adobe Photoshop or TIFF formats. 

G-Buffer Options 
The G Buffer options are: 

• Fragment color: This is the color of object that is the closest to the camera. 

• Fragment Distance: This is the distance of the object that is the closest to the camera. Lighter 
pixels are closest to the camera, while dark colors represent areas of the rendering that are 
farthest from the camera. 

• Fragment Coverage: This is the percentage of the pixel that is covered by the object closest to 
the camera. 

• Object index The object index relates each pixel in the image to the object its corresponding 
point belongs to. With an object index loaded in Adobe Photoshop, you can easily select 
individual objects with the Magic Wand, regardless of color. This works as long as the objects do 
not overlap. 

• Normal vector The normal vector creates three channels describing the direction that each 
surface of the object faces. This information can be used after rendering to simulate additional 

or example, it's possible to add directional lighting or glows in Photoshop by 
channel to select all the surfaces that face in a given direction, complete with 

those facings fall off. 

on 
d one for z. An example of how 

you could use this information is to position low hanging clouds, making use of the Z, or height, 
channel. 

• Surface Coordinates The surface coordinate is the location of the point on the object in relation 
to the object's surface coordinate system. This is two-dimensional information which allows 
adding, replacing, or repositioning texture maps on 3D objects in an image editing program. 

To select G-Buffer channels: 

1. Select the Properties tray: Output Settings button . 

2. Select the G-Buffers panel. 

3. Enable the checkbox or each feature you want. 

Do not enable channels that you don't need. Each channel adds to file size considerably. 

Choosing Movie Compression Settings 
al 

s and render in the 

ulations in the background. Carrara's renderers are designed so that you 

light sources. F
loading the normal 
information about how 

• 3D Position The 3D position describes the coordinate of each point in the image. 3D positi
uses three channels, one for the x value, one for the y value, an

Rendering is computationally intensive, and depending on the render settings, jobs may take sever
hours to complete. If you have enough memory, you can continue working on other job
background. 

When using applications such as word processors or 2D drawing programs, the CPU is not using 
maximum capability and spends a lot of time idling. Carrara takes advantage of this by taking control of 
the CPU and performing its calc
can use other applications while rendering. 
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Rendering animation requires a significant amount of hard disk space. If you have disk space limitations, 
e plenty of disk space, you may want to 

ng time only to find out that you used too 
 compression. 

compression algorithms (called codecs) that you can select in the 
e provided with QuickTime (Macintosh or Windows (if the player is 
odecs compress data when you render an animation and decompress the 

vie. Compression makes the file smaller, but degrades image quality. When 
 option, you are always choosing between image quality and file size. 

ompressed movie. 

a 

you will want to compress the movie that you render. If you hav
render without compression. This way you won't invest renderi
much compression. You can then re-open the movie file in Carrara and save it with

The software compression and de
Compression Settings dialog ar
installed)) or AVI (Windows). C
data when you play the mo
you choose a compression

Any Macintosh or Windows system with QuickTime or AVI software can play back a c

If you are using hardware for MPEG compression, see the instructions that accompanied your board for 
description of available compression options. 

To select a movie compression option: 

1. Display the Properties tray. 

2. Click the Output Settings button. 

3. Make sure Movie is selected and choose a Movie file type such as QuickTime or AVI. 

4. In the File Format controls, click the Options button. The Compression Settings dialog appears. 

5. If the movie type you selected doesn't support compression, other options will display. 

6. Select one of the compressor options from the Compressor list. 

NOTE! Your actual compression may vary, depending on the version of QuickTime or Video for 
 Windows you have installed. For additional information, refer to your Apple or Microsoft documentation.

Macintosh Compression Options 

 
• None. This is a loss less form of compression with a 2 to 1 (or less) compression ratio. This 

ality by 

 when the highest image quality is important. 

codec converts an image's pixel depth from 32-bit to 24-bit image format with no loss in qu
combining the alpha channel byte. None is a good option for raw animation if you have plenty of 
hard disk space. You may want to use this as an intermediate step if you plan to edit your 
animation in Adobe Premiere because Premiere re-compresses the movie (avoid compressing 
twice). None is better for reachieving
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• Animation . This codec works best for 8-bit animation and computer-generated screen images 
(as opposed to videotape images). 

• It's often used for 3D animation. The image quality (especially at higher quality settings) is 
acceptable for informal movies. With this codec, you can create movies up to full-screen at any 

e 
ler files. 

f 2 to 1, Component Video requires lots of disk space. Use 
 more import than compression ratio or real-time playback. 

ed for 8-bit still images. Useful for compressing pre-dithered 
on performance is not as important as the compression ratio. 

es such 

color depth. The Animation codec saves the first image and then saves only changes from on
frame to the next. It also cuts out the alpha channel, resulting in increased speed and smal

• Cinepak. This is a cross-platform codec for QuickTime and AVI movies that is best suited for 
video and CD-ROM playback. Movies take a long time to compress, but they decompress quickly 
at playback. Cinepak is best for 16- and 24-bit animations. Cinepak has better compression ratio, 
image quality, and faster playback than Apple's Video codec. 

• Component Video. This is best suited for the archival or interim storage of digitized video 
compression. At a compression ratio o
this codec when image quality is

• Graphic. This is recommend
animations in which decompressi

• Photo-JPEG. This is recommended for compression of still images with continuous ton
as photographs. It works too slowly for animation, and discards some data (it's a lossy 
compression method). Photo-JPEG is recommended for archiving 16- and 24-bit source clips. 

h This codec saves the image in JPEG format, which results in high-quality images with a hig
amount of compression. 
 

NOTE!

• Video. This is Apple's QuickTime video compressor. It is best for high-quality video clips that pla

 You may have other JPEG options available. 

y 
in real time on faster Macintosh machines. Its only option is color. Video is appropriate for 

ations, but the image quality is not as high as 

AVI Compression Options 

rotoscoping. This codec can play back regular anim
when the Animator compressor is used. 

 
• Microsoft Video 1 . This codec compresses each frame of a clip (and is used for analog video (8 

and 16-bit). Some data is discarded (the codec is lossy). 

o 

 

• Full Frames (Uncompressed). This option is best for capturing full frames of analog video. N
compression is applied, so use of this codec requires lots of disk space. 

• Cinepak Codec (Radius?). This is a cross-platform codec for QuickTime and AVI. Movies take a
long time to compress, but decompress quickly at playback. Cinepak is optimized for 16- and 24-
bit animations. Cinepak has a better compression ratio, image quality, and playback than the 
Microsoft Video 1 codec. 
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• Intel Indeo Video R3.2. This codec uses higher compression ratios, and results in better image 
quality and faster playback than Microsoft Video 1. 

t • Microsoft RLE . Use this option for compressing animation and computer-synthesized 8-bi
images. 

• Intel Indeo Video Raw . Use this compression method for capturing uncompressed video. You 
will obtain superior image quality because no compression is applied. 

TIP! For optimal compression, use the right frame size: 160 x 120 for Apple Video compressor and 
240 x 180 for Cinepak. When using Cinepak, frame dimensions should be multiples of four for best 

c. 

ral compression methods. Each key frame is stored in its 
entirety. The next set of frames:up to the next key:are saved only as changes. 

e Limit Data Rate option. 

ttings button . 

3. Select Movie. 

4. Choose the movie file format you want from the list. 
 

performance. 

To set compressor options for the QuickTime format: 

e1. Choose a color depth from the Color list. The depths available depend on the selected cod

2. Use the Quality slider to set the level of compression. 
 
The compression ratio is inversely proportional to image quality. The Quality slider allows you to 
set an optimum balance between the amount of compression and image quality. 

• For a codec that uses key framing, enter a Key frame rate. 
 
The key frame is used in tempo

• For a codec that supports the feature, you can use th

• This allows you to set a maximum size for any frame. QuickTime automatically adapts 
the compression quality to maintain this rate. This feature is available for only a few 
codecs. When you are finished setting options, close the options dialog. 

To select a file format for a movie: 

1. Select the Properties tray: Output Se

2. Select the File Format panel. 

 
• Movie formats include QuickTime Movie (Macintosh or Windows (if the player is 

installed)), AVI Movie (Windows), and a variety of sequenced image formats. 
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• The "Movie" formats (QuickTime, AVI, and animated GIF) generate a single file that 
includes all of the frames. 

• The "sequenced" formats generate a single file for each frame. The files are numbere
0

d 
00, 001, 002, and so forth, to keep them in sequence. Sequenced files are often used 

6. Select the frame rate from the list (in set increments from 1 to 60 fps). 

7. 

ing Statistics 
 

Sc bjects, and master shaders in 
your scen

To view scen

3. 

d estimated end times for the rendering, as well as the elapsed 

ss: 

 . 

2. Open the Rendering Progress panel. 

3. Look at the progress of the rendering of your scene. 

Animation Progress 
Animation progress shows the frame number currently being animated, the time rendering takes for the 
average frame, and the number of frames left to be rendered. 

To view scene information: 

1. Select the Properties tray: Progress/Statistics button . 

2. Open the Animation Prog e panel. 

for transferring the animation to other programs, such as Adobe Premiere. 

5. Set the start and end points of the render range. 

Click Options. Carrara displays a dialog that lets you set features for this file format. 

Render
You may want to keep track of the rendering process for the current scene being rendered. You do this
through the Statistics button in the Properties tray. 

Scene Info 
ene Info gives basic information on the number of objects lights, master o

e. 

e information: 

1. Select the Properties tray: Progress/Statistics button . 

2. Open the Scene Info panel. 

Look at the list of items in the scene being rendered. 

Rendering Progress 
Rendering Progress reflects the start an
time, time left and disk space. 

To view rendering progre

1. Select the Properties tray: Progress/Statistics button

r ss 

3. Look at the progress of your animation. 
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R
Ren
statistics a
statistics a our scene 

2. Open the Renderer Statistics panel. 

 

 main rendering engines to choose from: Draft, Photorealistic and Non-Photorealistic 

enderer Statistics 
derer Statistics tells you the number of rays launched. Rays are used to compute the image. These 

re renderer-specific; for example, Draft Renderer doesn't provide any statistics. Rendering 
re used to estimate the complexity of your scene. More rays are launched when y

contains more reflection and or transparency. 

To view renderer statistics: 

1. Select the Properties tray: Progress/Statistics button . 

3. Look at the number of rays launched.

Rendering Engines 
Carrara offers three
Renderer (NPR). 

 
Each engine has an advantage when
engine from the Properties tray. Refer to "

 you are looking for a particular result. You select your rendering 
The Properties Tray." 

• The Draft renderer is an excellent choice for fast proofing. For more details see "Draft 
Renderer." 

• The Photorealistic Renderer calculates the effects of light rays from your light sources as they 
st of the "real world" lighting effects, 

 supports Global Illumination 
enderer

encounter the objects in your scene. Ray tracing shows mo
on, and bump maps. It alsoincluding transparency, shadow, reflecti

and Caustics. Refer to "Photorealistic R ." 

ages that imitates drawing and painting 
effects. For more details see "Non-Photorealistic Renderer

• The Non-Photorealistic Renderer (NPR) creates im
." 

 render across networks (Pro version only). See "Network RenderingTo speed up rendering you can also ". 

es tray. 

enderer list. 

ces for this object. 

To set a rendering engine and rendering properties: 

1. Select a scene from the Render tray. 

2. Display the Properti

3. Select Renderer Settings.  

4. Choose a Rendering Engine from the R

5. Select or deselect the rendering preferen
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Draft Renderer 
Follow the instructions below for setting Draft Renderer options. The Draft Renderer provides fast 
rendering and should be used for animation previewing. 

To set the Draft renderer options: 

1. Select Properties tray: Renderer Settings button: Renderer panel. 

lt rendering mode. WireFrame is particularly useful for 
cts precisely. 

es the colors at the corners of a polygon to determine the 
on. It then blends the color across the polygon from the 

corners. 

 your objects, but takes longer to calculate and draw. (Standard, Pro) 

• Sketch: This method shows a flat shaded image with pencil-sketched hard edges. 

4. Select a lighting mode: 

• Fast Lighting : This mode uses a pre-existing lighting set and pre-calculated textures. It 
renders quickly but doesn't depict how the final scene will be rendered. 

• Actual Lighting : This mode uses the lighting information contained in the scene. This 
option matches the lighting you will see in the final rendered scene. 

 

2. Select Draft as the renderer. 

3. Select a Rendering mode:  

• WireFrame : This is the defau
scene composition since it allows you to align obje

• Gouraud : This method us
shading for the entire polyg

• Textured: (Phong) This method shows all of the details of the shape, color, and texture 
of

Photorealistic Renderer 
The Photorealistic Renderer should be used for realistic rendering. It is based on the Raytracing
technology and supports global illumination and caustic rendering. 

To select the Photorealistic Renderer: 

• Choose Properties tray: Renderer Settings tab then choose Photorealistic from the list. 

The Photorealistic Renderer settings are divided in three different categories: Ray Tracing, Global 
Illumination and Caustics settings: 

Ray Tracing Settings 
You can set the following options for raytracing: 
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• Full Raytracing: Checking the option will ensure the best rendering quality but will usually sl

down the rendering. (This corresponds to the difference between the old Ray Tracer and the
ow 
 

 previous versions). 

• 

• Enable Depth of Field to render scenes that use depth of field settings. 

n objects. 

• Enable Transparency to render transparent objects. 

Hybrid Ray Tracer of the

• Enable Shadows to render shadows. 

Enable Reflections to render reflections on reflective surfaces. 

• Enable Refractions to render refraction effects through transparent objects. 

• Enable Bump to render bump effects o

 

NOTE! Reflectiveness, transparency, refraction, and bump are Shader characteristics. 
Refer to "Shader Channels Reference." 

• Enable Light Through Transparency to render lighting effects through transparent objects. 

• Select Gamma Correction to turn on the gamma correction. 

et the value of the gamma. A value between 2.2 and 2.6 is usually 
er monitor. Check your monitor's documentation for the actual 

gamma value. Note that some video cards actually perform gamma correction so you might not 
a gamma correction of 1.4 so you might want to use a 

gamma of 1.8 to get the correct result on your monitor. 

• Select None, Fast, Good, or Best for Antialiasing . (These options allow you to smooth object or 
shadow edges.) 

• Select a Object Accuracy setting if the accuracy of some details are missing. This setting 
indicates the size of the smallest object or shadow in your scene. 

• Shadow accuracy: Shadows usually require a lower accuracy than objects. A low accuracy (2-4 
pixels will speed up the rendering) while a high accuracy (0.5 pixel) will assure that no detail is 
missed. The renderer automatically tries to pick up small details. 

• Adjust the Gamma slider to s
correct for a standard comput

need to do anything. The Macintosh has 
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• Adjust the Filter Sharpness to control the sharpness of your image. Very sharp images will tend 
to show aliasing problems (stair case effect) whereas a low value will tend to create blurry images. 

• Adjust the Maximum Ray Depth slider to set a limit on the number of interactions allowed for 
rays that reflect or refract. 

Gamma Correction 

The luminance of a typical monitor does not vary in a linear fashion. It follows a function that is 
characterized by a parameter called gamma. For most monitors the gamma value varies between 2.2 and 
2.6. 

Carrara allows you to "gamma correct" your image so that it matches the luminance of your monitor. This 
allows you to view much more realistic images. With Global Illumination the gamma correction performs 
more than to correct the image. It also assures that the textures are correctly taken into account in the 
lighting calculations. 

Note that an image that is gamma corrected will tend to be much brighter than one that is not. 

sity 

utdoor scenes to 
ackground and the 

 a logo rendered with only the diffuse lighting 

Global Illumination 
Global Illumination is the simulation of advanced lighting effects such as indirect diffuse lighting (radio
effects), extended light sources and sky illumination. 

Sky Light 

You can use the light of the sky to illuminate your scene. This is especially useful 
simulate the effect of a cloudy sky for instance. The sky light is controlled by the B

for o

Atmosphere applied to the scene. The image below shows
of the sky. 

 
To light a scene with the sky light you must: 

1. Set up a Background or an Atmosphere in the scene Properties. 

2. Check the Sky Light checkbox in the Global Illumination panel. 

3. Select the Intensity of the Sky Light using the intensity slider. 

4. Adjust these settings to control the quality of the rendering of the sky light: Lighting Quality and 
Interpolation. 
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Indirect Lighting 

In real life, much of the lighting you see is caused by indirect illumination. For example, the sun coming
through a window only directly light

 
s at a small part of a room. If there were no indirect illumination, the 

rest of the room would remain black. That's what you see in images created with typical raytracing. 
bounces off of the ground, walls and ceiling, flooding the room with light. 

ows you to simulate the diffuse part of indirect lighting. The 
h surface 

erly simulating indoor scenes. 

However, in real life, the light 

The Indirect Lighting option of Carrara all
diffuse part corresponds to that part of the light that is reflected uniformly in all directions by eac
as opposed to the specular part of the lighting that is reflected by shiny surfaces (mirror effects) or by 
transparent objects. This is the main component of indirect lighting in most cases and is very useful in 
prop

  
Notice how the 
calculation is en

light bounces off the ground to light up the entire room when the Indirect Lighting 
abled. 

vides a faster method to approximate the result of global illumination: ambient occlusion. 

Ambient occlusion calculates the amount of light that is visible from a point. It uses a hemisphere 
centered on the point and calculates the percentage of light that would be visible from that point if the 
hemisphere was emitting light. This gives a much more realistic lighting for your scene even though it is 
only a rough approximation. 

The radius of this hemisphere is very important. If you are rendering a room and you pick a radius bigger 
than the room itself everything will be black because the hemisphere will contain the walls. If you pick a 
radius that is too small, ambient occlusion will have only a small effect in corners. 

To use Ambient Occlusion: 

1. Select Indirect Lighting in the rendering properties. 

2. Select Ambient Occlusion as the calculation method. 

he ambient light settings are 

Ambient Occlusion 

Carrara pro

3. Select the radius used for the Ambient Occlusion calculation. 

4. Make sure the ambient light of the scene is set to a proper value (t
accessible in the scene properties). 

5. Render your scene. 

NOTE! Contrary to the Full Indirect Lighting where you should probably set the ambient light to 0, 
you have to set the ambient light to a high value for ambient occlusion otherwise it will have no effect. 

 © 2008 DAZ 3D, Inc. 813 



Carrara 7 11 December 2008 

Area Light Sources 

 
ot 

In typical raytracing programs, most light sources are punctual light sources. This means that they come
from a single point. Although direct sunlight can be approximated by such a mechanism, this is clearly n
the case for a tube like a neon. 

 
The renderer uses the glow channel of the shader to simulate extended light sources. Without Global 
Illumination, the glow will only make the object brighter, but if you enable the Indirect Lighting option, a 
glowing object will act as a light source. This allows you to create light sources of any shape and size. 

TIP! You can use the Scale shader (instead of the Value shader) to make very bright objects. If 
 a you want to make an object emit a very bright light of a given color (for instance, red), you can use

multiply operator between a Color and a Scale shader. 

 

Irradiance Maps 

Irradiance maps store the full solution of the global illumination. You can use them to speed up your 
animation renderings. 

If you are rendering a static scene (where nothing is moving except the camera), you do not need to 
ation for each frame. Just select the option called "one for all frames" and the 
 that the scene is static and render animations much faster. 

n reuse the map over and 

resting effects. For instance, you could render the 
out texture so that the Global Illumination solution is faster and less noisy 

and then use that irradiance map to render your scene with the texture applied. 

recalculate the global illumin
rendering engine will assume

Load/Save Irradiance Maps 

When working on a static scene, you can also save an irradiance map and the
over to render it from different point of view. 

You can also use this feature for some more inte
irradiance map for a scene with
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Settings 

 
You can enable or disable the following options to add Global Illumination to your scenes: 

• Sky Light activates the illumination by the sky dome. Note that it can be used with or without th
Indirect Light option to speed up the rendering. 

e 

o Intensity controls the intensity of the sky light. 

•  

irect lighting, and corresponds 100% to a 
physically accurate effect. 

• Interpolation speeds up rendering through the use of a caching mechanism to avoid 
recomputing the light for every pixel. 

o Precision controls the precision of the interpolation. A value of 0% can be used to get a 
quick preview of the lighting. 

 triggers more accurate calculations of edges and corners. It removes most of 
hts that can appear in corners. 

t 
 on the lighting within a scene. This approximation is also used when the final 

r values only 
when necessary since this can significantly slow rendering performance. You need high 

 scene contains many small illumination details or thin walls. 

• Lighting Quality controls the quality of the final calculation. The rendering time increases quickly 

fully until the desired quality is obtained. 

u do 

endering time increases 
quickly as accuracy goes up. Even if you set a low accuracy, the renderer will, in most cases, still 
pick up small details. Use a high accuracy setting only when the details of the indirect lighting are 
incorrect. 

Indirect Light activates the calculation for indirect lighting. Note that the renderer will also take
into account the light coming from glowing primitives. 

o Intensity controls the intensity of the ind

• Improved Edges
the shadow and highlig

• Show Photon Map displays a quick approximation of the indirect lighting. This is useful to ge
quick feedback
calculation is done. Use this setting to select the proper photon map precision. 

o Photon Count controls the number of photons emitted to sample the indirect lighting. 
When rendering, the memory used is proportional to this value. Use highe

precision when your

when you increase the quality. Since rendering can be very slow in order to obtain a high-quality 
result, increase the quality value care

• Accuracy controls the accuracy of the rendering. Setting it to a small value ensures that yo
not miss small details of illumination. Since the indirect lighting usually varies slowly, it is 
recommended to use a low accuracy for indirect lighting (8 - 16 pixels). R
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Troubleshooting Global Illumination 

You can correct the following types of problems. 

• Light filtering through corners : If you use a low resolution photon map and very thin walls, the 
light tends to go through the walls at corners. To avoid this problem, make sure that your objects 
have a thickness. If this problem still occurs with a thin wall, you can either increase the photon 
count or increase the size of the wall. 

• White Objects : When using reflection and transparency you might get very white objects. 
Usually the shading properties of your objects are not realistic (that is, your objects are creating 
lighting energy). To avoid this problem, make sure that the sum of the reflection, transparency, 
and color channels remains below 100%. 

Speeding up Global Illumination 

Here are some tips to improve renderi g speed when using Global Illumination: 

of 8 to 16 pixels is usually enough to get good 
details of indirect lighting that are missing. 

 

r 
ne increases the rendering time. 

the correct 

Cau

 . One typical 
ex

Settings 

n

• Use Ambient Occlusion. 

• Use low accuracy settings: Indirect lighting tends to vary very slowly so you do not need a lot of 
accuracy to get the correct image. An accuracy 
results. Use high accuracy only if there are some small 

• Use spot lights: When you are lighting your scene, you can help the renderer by using a spot 
light that only lights the most important area of the scene. All types of lights work, but they might
give you longer rendering times and lowered image quality. 

• Avoid huge scenes: If you are creating an image of the interior of a house, limit the exterio
world. Each object you add to a sce

• If your scene is static, you can avoid recalculating the lighting at every frame by using 
irradiance map options. 

stics (Standard, Pro) 

Overview 

When light is transmitted through transparent objects such as a glass or a bottle, or when the light is 
reflected by a mirror, it tends to create very specific illumination patterns called caustics

ample of caustics is the light effects you can see in a swimming pool. 

 
The caustic settings 

• Enable activates calculation of the caustics.  

 © 2008 DAZ 3D, Inc. 816 



Carrara 7 11 December 2008 

• (Caustics) Intensity controls the intensity of 
accurate effect.) 

the caustics. (100% corresponds to a physically 

otons that are emitted to sample the caustics. Higher • Photon Count controls the number of ph
values mean more precise caustics but also longer rendering times. 

• Filter size : This slider allows you to control how blurry the edges of the caustics will be. Higher 
values tend to make the edges very smooth and blurry.  

NOTE! Global Illumination and Caustics are only available with the Photorealistic Renderer. 

The images below show the same scene rendered without caustics (left) and with caustics (right). Notice
how the light concentrates through the sphere. 

 

 

Misc Settings (Standard, Pro) 
• Enable Multi-Threading: This option allows Carrara to use an extra thread for rendering. If you 

have a multi-processor computer, a thread will be created for each processor in order to take 
advantage of all of them for rendering. 

 option if you are rendering an animation for video and you • Select the Enable Field Rendering
want to render the interlaced fields separately. 

NOTE! If you use field rendering, choose 60 fps (NTSC) for the rendering frame rate. 

Non-Photorealistic Renderer 

Overview 
For many years the goal of computer graphics has been to create synthetic images as realistic as 
possible. This search for realism has led to images that are more and more realistic. However, very often 
what an artist really wants is to create a representation of reality. In this context realism is not the goal 
anymore and the artist is therefore given free expression which allows him to express himself in many 
different ways. It is this freedom of expression that the Non-Photorealistic Renderer (NPR) of Carrara is 
meant to give back to the artist. 

ows you to create images that imitate various painting and drawing styles. Yet it is 
ate your own styles. 

The NPR renderer all
not meant as much to imitate as to give you the freedom to cre
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Basic Concepts 
There are a few basics concepts that need to be understood before you can start using the NPR renderer: 

• Paper: The paper is the background of your image. Everything that is going to be rendered will 
be drawn on top of that. 

• Layers: Your image will be composed of different layers: the background layer, the diffuse layer, 
the highlight layer and the outline layer. These layers are drawn on top of each other (the 
background layer is drawn first on top of the paper and the outline layer is drawn last) 

t of the NPR renderer is the concept of brush strokes. 
Everything it renders is composed of a number of brush strokes. You can control the brushes at 

s). 

NPR Parameters 

Global Parameters 

• Brush Strokes: The most important concep

two different levels: 

• At the renderer level: by changing the parameters of the renderer. 

• At the geometry level: The brush size and shape depends on the triangle shapes so by editing 
your mesh you can influence your rendering. (Smaller brushes are used to paint smaller triangle
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Global Settings for NPR Rendering: 

• AntiAliasing: This parameter controls the amount of antialiasing that is performed on the image. 
Increasing the antialiasing will create smoother images by smoothing edges and removing noise. 
Be careful as a high level of antialiasing will slow down the rendering. 

• Filter Sharpness: This parameter controls how sharp your final image will be. It complements the 
antialiasing parameter. A low value will create a blurry picture and a high value will tend to show 
aliasing. 

• Paper Color: Controls the color of the paper. 

• Min Brush Size: Controls the minimum size of a brush stroke as a percentage of the image size. 
Increasing this value will create a less accurate painting effect. 

• Max Brush Size: Controls the maximum size of a brush stroke as a percentage of the image size. 

• Diffuse Layer: Activates the diffuse layer. This will paint everywhere on the objects except in the 
shadow and highlight areas if they are activated. 

s the highlight layer. 

•

, you will be able to see the paper through it. The background layer will 

• Highlights: Activate

 Shadows: Activates the shadow layer. This will turn on shadow calculation. 

• BackGround: Activates the background layer. It is important to understand how the background 
layer differs from the paper. The background layer is actually painted on top of the paper. If the 
brush strokes are sparse
use the backdrop of the scene. 

• Outline: Activates the outline layer which will draw the outline of objects. 

The image below shows a render using the Outline and Shadow layer. 

 

Layer Parameters 

The NPR also contains layer tabs (Diffuse, Highlights, Shadows, and Background, for example). You can 
edit each layer separately. Each of the following parameters apply to one single layer at a time: 

• Object Clipping: If checked, all brushes of the current layer will be clipped by the edges of the 
object. This allows you to create very clean outlines for painted objects. 

• Brush: By click on the brush image, a dialog opens that offers a selection of brushes that can be 
used to paint in the current layer. 

• Brush Color controls the color of the brush that is used for this layer. (For example you can 
select a dark grey color for shadows). Note that it will have no effect if "Use Object Color" is 
selected. 

• Use Object Color: If checked, the color of the brush will be the color of the object at the brush 
location (including lighting), se the color selected in the Brush Color field will be used.  otherwi
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liders control the thickness/length of the brush strokes. 

animations. 

: This panels controls the orientation of the brush strokes on each triangle. Selecting 
ontal and vertical are selected, for example, you 

s on the surface of the object. 

ing to the longest side of the triangle. 

 

 randomization used for the brush. 

• Thickness/Length: These s

• Intensity: Controls the intensity of the random variations of the brush color. A value of zero will 
lead to a uniform color whereas a value of 100% will create a very random intensity distribution. 
Note that high values of this parameter might cause flashing effects in 

• Transparency: controls the transparency of the brush strokes relative to each other. This is a 
very important parameter since it really controls the final appearance of the rendering. 

• Orientation
several orientations will combine them (If horiz
will get a diagonal orientation). Here is a description of the available orientations: 

• Horizontal: TBD 

• Vertical: TBD 

• U: the brush strokes follow the U texture coordinates on the surface of the object. 

• V: the brush strokes follow the V texture coordinate

• Triangle: The brush strokes are orientated accord

• Normal: The brush strokes are orientated according to the normals of the object. 

• Hue: The brush strokes are orientated according to the angle which corresponds to the hue of the
color. (very useful for backgrounds). 

• Random controls the amount of
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te position: The X, Y, Z coordinates of an obj

elative): Setting two or more objects

ot point in the Global Universe.  

aningful spatial relationship, such as 
centering them or distributing them evenly a line.  

ignment (text): Text alignment affects text obje re than one line. The lines of text may be 
aligne ight edge.  

pha Channel: The top byte of a 32-bit pixel that
hold mask or transparency data.  

or data other than color. The channel may 

ht: That light responsible for the overall, diffuse lighting of a 3D scene, similar to daylight in 

Anti-aliasing: Intermediate colors (or shades of g  pixels between contrasting colored regions. 
Anti-aliasing improves the appearance of objects 
edges.  

renderings by removing jagged, stair-step 

Aspect Ratio: The ratio of the width of an image to its height (x:y). For example, the aspect ratio of an 
image 640 x 480 pixels is 4:3.  

mospheric Effects: Atmospheric conditions or phe na that affect the clarity or mood of a scene. 
Fog and smoke are examples of atmosphe s.  

titude: See Orientation.  

is: A hypothetical linear path. The X, Y, and Z a
directions of the 3D universe. The axis along 

h, height, and depth, respectively) define the 
an object is rotated is the axis of rotation. An 

object’s axes are parallel to its bounding b

ckdrop: A picture that is automatically compos d a 3D scene. The matte paintings used in 
traditional movie making are an example o drops.  

ckground: 2D images that show up on reflectiv
increase the realism of such surfaces. Ref

s (metal, glass, etc.). Reflected backgrounds 
ckgrounds are also knows as environment 

maps.  

zier Curve: A path defined by the position of fo rol points (at the ends of the tangents of the 
vertices). The length and angle of the tang
curve follows between vertices.  

escribe the deviation

Bit Depth: The number of bits used to define the s olor of each pixel in an image. A 1-bit image 
is black and white. An 8-bit grayscale imag s 256 shades of gray (2 to the 8th power is 
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256). An 8-bit color image provides 256 colors. A 24-b 6 million colors: 8 
for green.  

map: A pixel-based image.  

s using
er, merge

 an object
ct (or gro

ndi
w, and it 

C 
t) in th

k is used to ena

 printing.
ack pigm

c ted— dep
 the perc
ubtract (by absorption) the bandwidths of white light 
r.  

Colinear: ne.  

Color Depth: See Bit Depth.  

Complex Object: An object constructed of several simple objects that are linked or grouped. For 
example, a telephone— comprised of the grouped, simple objects: cord, handset, and cradle—
would be considered a complex object.  

Component (shader): An elementary building block of a shader tree.  

Concentric: Having the same center.  

Constrain: To restrict object movement to a particular plane, axis, or angle. The working box is the 
primary tool for constraining an object.  

Control Points: The knobs at the ends of Bézier tangents used to adjust a Bézier curve.  

Coordinate System: Groups and individual objects have their own local coordinate systems. The origin 
of a group or object’s coordinate system is the center of its bounding box. The axes are parallel to 
the sides of the bounding box.  

Coplanar: Occurring in the same plane.  

Cross-Section: One of the planes on which 2D shapes are drawn in the Spline modeler to create a 3D 
object. Objects have two or more cross-sections.  

D 
Deformers: See Modifiers.  

Dithering: The process of approximating pixel colors when reducing the color depth of an image or 
mapping to a different palette. Dithering can improve transitions between colors when reducing a 
24-bit image to 8-bit format.  

it image provides over 1
bits are used for red, 8 are for blue, and 8 

Bit

Boolean: An object created by combining two object
objects may be subtracted one from anoth

 mathematical operators (Booleans). The two 
d, or intersected to form the Boolean object.  

Bounding Box: A hypothetical box drawn around  or group of objects. A bounding box is the 
smallest rectangular box in which the obje up of objects) fits completely. The bounding 
box is parallel to the axes of the object. The bou
selected objects and groups) in the 3D vie

ng box is shown (around the preview of 
is the bounding box—not the object itself—

that casts projections onto the working box grid.  

Child: An object linked to another object (its paren e hierarchy. When the parent is moved, the child 
and all grandchildren go with it. The parent-child lin
objects.  

ble articulation of complex 

CMYK Color: The subtractive color model, used in  Colors are created by assembling different 
densities of cyan, magenta, yellow, and bl ents on a surface. When white light strikes the 
surfa e, only specific bandwidths are reflec
pigments. The reflected bandwidths create

ending on the density of the specific 
eived color. The CMYK model is called the 

subtractive model because the pigments s
that do not contribute to the specified colo

re objects that are in the same li Two or mo
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Dolly: The computer equ
moves around in 
as its center.  

ivalents of the real world camera movement commands. With Dolly, the camera 
3D space as if gliding on the surface of a sphere that has the object of interest 

DXF: A standard 3D file format originally developed k, makers of AutoCAD, for the purpose of 
exchanging CAD data between various 3D software applications. Widely used as a poor man’s 

E 
Extrusion: The method of creating a 3D object by m ng a 2D cross-section along a path (the sweep 

ay 

G-Buffe ormation carried on optional channels of a rendered image. 

Global 
 the universe. The Global Universe is fixed and is not affected by changes made to the 

Glow C holds data describing an object’s luminescence or glow.  

l 

ch the pixels are defined with 8 bits, which provides 256 levels of gray.  

H 
Hierarchy: The tree structure in the Sequencer tray that lists the objects in the scene and shows their 

logical relationships (links and groups). The rarchy also includes listings for the animatable 

Highlights  the viewpoint. Highlights appear as 

Hot Po ot 
used as the reference for rotation and for some positioning and alignment operations.  

 

 by Autodes

exchange file format, DXF only offers support for basic geometric information (no textures).  

ovi
path). The Spline modeler uses this method.  

F 
Face: The back (first cross-section shape) or front (last shape) of an extruded object.  

Formula: A mathematical expression that, with input, returns a meaningful set of values. Formulas m
be used to create objects, define a tweener curve, or create a color pattern in a shader, gel, 
background, or backdrop.  

G 
r (Geometry Buffer): A type of inf
The G-Buffer carries an aspect of three dimensionality with the 2D rendering. This can assist 2D 
filters and paint tools during retouching.  

Global Mixer: A shader component that mixes all channels of its component shaders.  

Universe: A Cartesian coordinate system with the origin of the X, Y, and Z axes (0, 0, 0) at the 
center of
working box.  

hannel: A shading channel that 

Gouraud: An object preview mode in the Assemble room which shows objects with shading at a low leve
of detail.  

Grayscale: An image in whi

Group: A set of collected objects. Grouping enables a set of objects to behave as one.  

 Hie
properties of each object.  

: Regions on an object where light reflects directly into
bright spots on smooth! shiny objects and are almost nonexistent on rough!dull objects.  

int: A special, active, movable point located by default at the center of an object or group. The h
point is 

I 
Icon: A pictorial representation of a tool, object, file, or other program item. An item is selected by clicking

once, or sometimes double-clicking, on its icon.  

 © 2008 DAZ 3D, Inc. 849 



Carrara 7 11 December 2008 

J 
Jaggies: The appearance of sta

anti-aliasing.  
ir-step, jagged edges in a pixmap image. Jaggies can be reduced with 

Key Fra d 

L 
Leading: A text property that determines the vertica ce between lines of text. The default leading 

value is 120% of the font’s point size. Decre g the percentage makes vertical spacing more 

Letter S  
, or text block. A lower value decreases spacing, while a higher value increases it.  

 
 of a rendering, which describes where objects 

are not. In a 2D image editing program, the mask is used to generate a 
.  

Master  
imilarly.  

e only one Master Shader. 
ay be composed of multiple sub-shaders.  

Modifie  object (or group of objects) to modify its geometry. 
available in 

N 
Non-Ph  imitates drawing and painting effects.  

Normal Vector: A ray perpendicular to an object’s surface at a given point.  

O 
en 

Operat ombines other shaders to form a sub-shader.  

K 
me: A moment in the animation where an object’s characteristics change. Key events are marke
on the time track for each animatable property.  

l spa
asin

compact, while increasing the percentage expands it.  

pacing: A text property that determines the horizontal spacing between characters in an entire
word, line

Links: (Also known as Constraints.) A variety of child/parent relationships and constraints on relative 
motion to simulate traditional, real world mechanical links. Shafts, axis, and ball joints are 
examples of constraints.  

M
Mask: The mask is a grayscale image, stored in channel 4

are versus where they 
selection, which helps you composite your rendered scene with other background imagery

 Objects: The mold from which object instances are created. If a master object is modified, all of
the objects derived from it are modified s

Master Shader: The shader assigned to an object. Each object can hav
However, that Master Shader m

Metaball modeler: A modeler that uses blob primitives to create 3D objects.  

rs: Properties that can be applied to any
Asymmetric scaling, bend, twist, and shatter operations are examples of modifiers 
Carrara.  

Motion Path: A curve, visible in the scene window, that shows where an object will move during the 
course of an animation.  

otorealistic Renderer: (NPR) creates images that

Object: Any 3D volume or other item that appears in the universe, including cameras and lights. Wh
objects are grouped, their group is also described as an object.  

or: A shader component that c
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Orientation: The direction an object faces as defined by the compound effect of the object’s rotation 
around the X, Y and Z axis. Usually, the most important aspect of an object’s orientation is its 
relation to other objects. An object’s relation to the viewpoint can be changed by moving the 

Oversa

n in space to track an object or view a scene, 
much like a movie camera can rotate on a tripod to follow a moving object.  

Penumbra: The region of partial shadow at the edg  the full shadow. In Carrara, you can achieve nice 
penumbras with the Soft DRT Shadows option for lights.  

ng at a low level of 

Pipeline

Pitch: The aspect of an object’s attitude that describes its angular deviation along its vertical (top-to-
bottom) axis.  

Pixel (picture element): One dot in a 2D image. C ter images are created as an array of such dots, 

Plane: 
s infinitely in two dimensions. In Carrara, planes are 

s the angle at 

Point: A sure, a point is 1/72 of an inch. Point also refers to Bézier vertex and control 

 and switch the POV between them. When you render an image, you choose the POV 

f a shader in the 
Browser or Sequencer. Also refers to a rendering with a low resolution setting.  

Primitive: An object created by definition, rather th odeling. A primitive object cannot be dismantled 
into components. The Sphere, Cube, Cylinder, Cone, and Icosahedron are the basic primitives in 

Produc e 
bing the area of the 3D scene that will be rendered into an image.  

he 

Proper
selected object appear in the Properties tray.  

current camera.  

mpling: Rendering at a higher resolution, then bringing the resolution back down to minimize 
artifacts like aliasing.  

P 
Pan: The computer equivalents of the real world camera movement commands. With Pan, the camera 

acts as the center and rotates at a fixed positio

e of

Phong: An object preview mode in the Assemble room which shows objects with shadi
detail.  

: An extrusion in which the cross-section is always perpendicular to the sweep path.  

ompu
each having a specific color. See also Resolution and Bit Depth.  

A hypothetical, 2D construct that may exist at any attitude in space. A plane can be envisioned as 
a flat sheet of invisible paper that stretche
used to constrain the direction of translation of an object. The working box show
which the constraint planes are set. By default, the planes of the working box are set parallel to 
the axes of the current local universe.  

s a unit of mea
points.  

Point of View (also viewpoint): The position and angle from which you view a scene. The point of view 
(POV) is always through a camera. You may add several cameras, positioned and angled 
differently,
from which the image should be taken.  

Preview: The display of an object in the 3D View or Modeling window or the color chip o

an m

Carrara. The environmental primitives include Fountain, Fog, Cloud, and Fire.  

tion Frame: The computer equivalent of the viewfinder in a regular camera. The production fram
can be thought of as descri

Projection: The silhouette of an object’s bounding box on one of the three visible planes of the grid. T
hot point of the selected object or group also casts a projection. Projections are used for 
translation and rotation.  

ties: The collection of characteristics applied to (or available for) an object. Properties for the 

R 
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Ray Tracing: A procedure for generating a renderin he ray tracer sends hypothetical rays of light from 
the sources in the scene and calculates the visual effects, for each pixel in the rendering, as the 

Referen nt or plane used as the starting point for some operation. The hot point, the center 
of the bounding box, and the corners of the bounding box are common reference points.  

reflected: 2D images that show up on reflective su s (metal, glass, etc.). Reflected backgrounds 

Reflection: The phenomenon of light bouncing off objects.  

Refraction: The phenomenon of light deflecting as i sses through a translucent object, like glass or 
fluid.  

Resolu

RGB C rying 
 blue light. For information on the varying degrees, refer to Bit Depth.  

Root: The highest level of the Sequencer Hierarchy. When you look at a group, the group box is the 
highest level of the Hierarchy, and therefore, the local root.  

Scaling

Scaling thout affecting their height. A value below 
n 

lygon. Shapes are used in 
ing.  

Skinnin  

D 

Sub-shader: Any shader used as a component within a shader tree.  

Sweep Path: The curve or line along which shapes extruded when modeling. Called the sweep or 
k plane 
  

Texture Map: A 2D image used as a shader.  

MYK format.  

g. T

rays encounter and reflect from the objects in the scene.  

ce: A fixed poi

rface
increase the realism of such surfaces. Reflected backgrounds are also knows as environment 
maps.  

t pa

Relative position: The placement of an object in relation to another object. For example, a book might 
be on top of a table.  

Render: The process of capturing a 2D image from a 3D scene.  

tion: For an image, the number of pixels in each dimension. For devices, like a printer or the 
monitor screen, resolution is given in dots per inch (dpi) or dots per centimeter.  

olor: The additive color model, used in computer monitors. Colors are created by adding va
degrees of red, green, and

S 
 (object): The percentage an object is resized. Each object instance may be scaled from the 
dimension of its master, which has a scaling of 1.  

 (text): Scaling changes the width of characters wi
100% results in characters that are narrower than usual, while a value above 100% results i
characters wider than usual.  

Shape: A 2D path that may be open (a line) or closed, such as an oval or a po
cross-sections when modeling. In shading, paint shapes are used to specify regions for shad

g: The process of applying a vertex object to a skeleton for the purpose of animating the vertex
object.  

Spline modeler: A modeler that uses cross-sections, sweep paths, and scaling envelopes to create 3
objects.  

 are 
extrusion path, the path is defined by one line on the bottom plane and one line on the bac
in the modeling window. The compound curvature of these two lines defines the path itself.

T 

TIFF (Tagged Image File Format): An image file format often used for transfer between applications or 
platforms. Carrara opens TIFF images in RGB format, but not in C

Tiling: The technique of repeating a small image across a larger surface to cover it.  
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Transla
ains at one angle, regardless of the curvature of the sweep path.  

Tweener: A formula used to control the transition between two key events.  

Univers e or 

UV: A 3  parametric mapping to align points on 

Word S

Workin e scene window. Called the working box because you’ll 

Workin stem: The working box’s own coordinate system. The attitude of its axes and the 

Y 

Track: The computer equivalents of the real world camera movement commands. Track moves the 
camera in a plane perpendicular to the direction in which the camera is pointing.  

tion: Any manipulation of the position or attitude of an object. Also, an extrusion in which the 
cross-section rem

Translucence: The characteristic of an object that allows light to pass through it.  

U 
e: The 3D root of the Hierarchy. The Universe’s coordinate system is absolute (does not mov
rotate).  

URL: Uniform Resource Locator, the address of an item on the internet.  

D coordinate mapping system. UV coordinates are used in
the shader with points on the object.  

V 
Vertex: A control point on a path. Paths begin, change angle, and end at vertices.  

Viewpoint: See Point of View.  

W 
pacing: A text property that determines the horizontal spacing between words. A lower value 
decreases spacing, while a higher value increases it.  

g Box: The three visible grid planes in th
move it as you work to constrain operations to certain planes.  

g Box Sy
position of its origin (at the center of the working box) change as you move and reorient the 
working box.  

Yaw: The aspect of an object’s attitude that describes its angular deviation along its linear (front-to-back) 
axis.  

Z 
Z-Buffer: A rendering technique that uses z (depth) information in sorting object facets. 
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