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Daz Studio Training — Intermediate Session 2: Tweaking the Geometry

Session 2: Tweaking the Geometry

This training session is about manipulating the geometry.

You will find information on how to make selections of polygons and how
to manipulate them to tweak an existing scene to your requirements.
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2.a - Hiding Parts of the Scene

I» Complete Video: 2a Hiding Geometry Selections

If some part of the scene is in the way you can check the Scene Tab to see if it is a separate item
that could be switched off. Quite often the item will be part of the scene so it can’t be hidden or
moved individually. I» 01:05

In this case you can use the Geometry Editor to hide a selection of polygons: I» 02:45

1) Activate the Geometry Editor Tool.
2) Make sure the tool is set to Polygon Selection.
3) Pick a Selection Mode (Marquee/Lasso/Drag) from the context menu (right mouse button).

4) Select the polygons you want to hide.
To modify the selection: Hold down the Ctrl key to add polygons, hold down the polygons.
For more selection options: Right-click in the scene > Geometry Selection I» 03:42

5) Right-click in the scene > Geometry Visibility > Hide Selected Polygons.  I» 03:50

To make the hidden object visible again:
Right click > Geometry Visibility > Show All Polygons > 04:44

Setup for toggling visibility: I» 05:26
1) Go through steps 1-4 as described above.
2) Go to the Tool Settings Tab.
3) Right-click the “Selection Sets” entry > Create Selection Set From Selected > enter a name.
4) Use the eye icon next to the new selection set to toggle visibility.

Note: Sometimes Daz Studio will not remember the visibility settings after you close and reload
a scene. You may need to toggle the eye icon again after reloading the scene. I» 06:50

Side Note:
Putting several items into a group is a handy way to hide/show parts of your scene when you don’t
need to select individual polygons. 1> 02:03
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2.b - D-Former Basics

I» Complete Video: 2b DFormer Basics

| recommend getting familiar with D-Formers first in a simple scene before using them in a complex
setup.

Make sure the object is selected, then add a D-Former.  I» 00:40

Each D-Former has 3 components: Field, Base and D-Former. I» 01:36

Manipulate the D-Former to create deformation. [I» 02:01

Manipulate the Field to control where the deformation is applied. I» 02:19
You can change the falloff of the Influence Field in the DForm Tab. I» 04:20
The position of the Base sets the center for deformations. I» 07:20

By adjusting the position/rotation of the Base, you can set up a custom axis for the D-Former.

I» 09:58
Instead of the Influence Field, you can use Weight Maps for better control. I> 11:48
Use the regular Weight Mapping Tools to edit the influence weights. I» 12:56
® Adding and removing weight I» 13:40
® Smoothing weights  I» 13:53
® Brush settings I» 14:12
® Selecting geometry P 15:25
® Smoothing selections 1> 17:14
® Filling selections I» 17:57
D-Formers and morphs work together if you dial in the morph after the D-Former. I» 18:47

Use the D-Former sliders on the main object for further control over the deformation. I» 19:05

D-Formers are created at the center of the active geometry. If you have a morph active that
changes the geometry, and you add a D-Former to that, you can run into problems. I» 20:.07

To save a deformation as a permanent morph, go to the DForm Tab and use the “Spawn Morph”
command. Afterwards you can delete all components of the D-Formers. 1> 22:21

You may want to set limits for the new morph sliders. I» 23:54
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2.c - Fixing Intersecting Geometry

I» Complete Video: 2c Moving Geometry With a D-Former

If you notice some weird rendering issues, like patchy textures, check if it might be a problem with
intersecting geometry. Daz Studio does not like it if two (or more) polygons share exactly the same
location. I» 00:37

If that is the problem, use a D-Former to move the problematic polygons.

1) Select the item.

2) Load a D-Former. I» 02:08

3) Check the D-Former’s position/orientation. 1» 02:30

4) Select one of the three D-Former components (Base, D-Former or Field). 1> 04:32
5) Activate the Node Weight Brush Tool. 1> 04:48

6) Go to the Tool Settings Tab and add an Influence Weights map. 1> 04:50

7) Switch to the Geometry Selection mode of the Node Weight Brush Tool.

8) Right click > Geometry Selection > Select all I» 05:10

9) Right-click again > Weight Editing > Fill selected > fill with 0% weight. I» 05:16
10) Pick a Selection Mode (Marquee/Lasso/Drag) from the context menu (right mouse button).
11) Select the polygons you want to move. I» 05:37

Hint: You can also switch to the Geometry Editor Tool which will give you more options
for selecting surfaces, groups etc. I» 06:04

12) Activate the Node Weight Brush Tool again.

13) Right-click in the workspace for the context menu > Weight Editing > Fill selected >
fill with 100% weight. I» 06:43

14) Select the D-Former (not the Base or the Field) and move it a tiny bit. I» 07:19
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2.d - Applying One D-Former to Several Items

I» Complete Video: 2d - Applying One D-Former to Several Items
You can move parts of several items with one single D-Former:

1) Repeat steps 1-12 from chapter 2b to set up a D-Former for the first item.

2) Select the second item.

3) Go to the DForm Tab (Window > Panes (Tabs) > DForm). I» 05:18

4) Click the Add Node(s)... button.

5) Choose the D-Former from the list.

6) Select one of the D-Former components and go to the Tool Settings Tab. I» 05:52
7) Activate the Node Weight Brush Tool again.

8) Select the Influence Weights for the second item. I» 05:57

Note: If it doesn’t list the second Influence Weight entry, select any other item in the Scene
Tab, then select the D-Former component again. This will update the display.

9) Repeat the steps for selecting polygons and adding influence weights.
10) Repeat all steps 2-9 for any further items. 1> 07:31
11) Select the D-Former (not the Base or the Field) and move it as required. 1> 08:17

Alternate method for setting up the weights: > 06:18

1) Use the Geometry Selection mode to select polygons for the second item.

2) Right-click in the workspace for the context menu > Weight Editing > Fill selected > fill with
100% weight.

3) Right-click > Geometry Selection > Invert Selection.
4) Right-click > Weight Editing > Fill selected > fill with 0% weight.
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2.e - Saving Out Polygon Selections As Individual Items

I» Complete Video: 2e - Saving Out Selections As Items

To save out an individual item from a big environment, for example a single plant:

1) Hide or delete all objects you don’t want.
If your items are part of a group you can unparent them I» 01:02

2) Go through steps 1-5 from chapter 1a to hide all polygons except the part(s) you want to

save out.
3) Optional but recommended: Parent the items I» 02:19 and move them to the
world center. 1> 02:44, I» 03:05
4) Go to File > Export (remember the scale settings!) > save it out as an .obj file. I» 03:21
5) Optional: Save a material preset of the original item. I» 04:40

6) Import the .obj file back in, using matching scale settings. I» 05:32

7) Optional but recommended: Activate the Joint Editor Tool and move the Center Point to the
center of the item I» 06:16, then go to the Tool Settings Tab and memorize the set-
tings I» 07:.07

8) Transfer the surface settings, using the material preset you saved out previously, or by
copying and pasting the surface settings. 1> 07:43

9) Save theitem to the library. 1> 08:18
10) Now you can load the item from your library into any scene you like.
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2.f - Fixing Doors That Don’t Open

I» Complete Video: 2f - Opening Doors

Sometimes you have a room with doors that don’t open. How to solve this problem depends on
the way the item is modeled.

First you need to analyze the setup of the geometry: I» 01:00

1) Activate the Geometry Editor Tool.
2) Select at least one polygon in the door.
3) Right-click for the context menu > Geometry Selection > Select Connected.
If only the door is selected now, it has separate geometry. Proceed using Method 1.

If the selection also includes the doorframe and/or the wall, the door is welded with the rest of the
room. In this case use Method 2.

Method 1 - If the door has separate geometry: > 02:11
1) Load a D-Former and position the D-Former Base at the side of the door, where the hinges
would be. I» 03:08

2) Set up Influence Weights for the door (see also Session 2.b). I» 04:16
Make sure to include everything that’s part of the door, like doorknob, decorations etc.

3) Select the D-Former (not the Base or the Field) and rotate it on the Y axis to open the door.
I» 05:39

4) Add a floor plane if required. I» 06:09

Note: The door will probably lack thickness. You can hide this by turning the edge away from the
camera. I» 07:26

You can also add cubes from the Primitives menu and include those in the D-Former influence (for
Method 1) or in the export (for Method 2). I» 08:12

Method 2 - If the door is welded with the rest of the geometry: I» 13:45

1) Export the polygons that make up the door, using steps 1-5 from Session 2.d but skip step 2
(do NOT center the door). Make sure to export everything that’s part of the door, like door-
knob, decorations etc. I» 14:23

2) Make the rest of the room visible again and hide only the original door. 1> 20:47
3) Select the imported door and transfer the surface materials. I» 21:16

4) Re-position the center point: I» 22:45
Activate the Joint Editor Tool.
Move the little green center point to the side of the door, where the hinges would be.

5) Now you can rotate the door on the Y axis to open it.
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Side Notes:

Different methods for selecting the polygons of the door: Use the Geometry Editor to select
surfaces, use the Marquee selection mode to add/remove polygons from the selection.

I» 14:35
Also check to see if the groups or surfaces could help you to make a quick selection I» 15:20
Additional info: Using the Drag selection mode, you can click on one edge between two polygons
and it will select a loop of polygons (depending on the geometry).

2.g - Making Dents In Soft Surfaces

I» Complete Video: 2g - Making Dents

To make something sink into a soft surface, for example a matress or a sofa you can use the Push
Modifier.

1) Select the item you want to make a dent in.

2) Go to the Scene Tab > Options Menu > Edit > Geometry > Add Push Modifier I» 00:44
3) Adjust the Push Modfier using the slider in the Parameters Tab I» 01:12

4) Go to Create > New Push Modifier Weight Node  I» 02:00

5) Activate the Node Weight Brush Tool.

6) Go to the Tool Settings Tab and add the Push Modifier weight map.

7) Use the Geometry Selection mode of the Node Weight Brush Tool to select everything.
I» 02:34

8) Right-click in the scene window > Weight Editing > Fill Selected > fill with 0%

9) Now use the Paint Brush mode to apply the effect where you want it, use the Smooth Brush
mode to soften the edges.

Tip: If you also add weight directly under the figure/object, not only along the edges, the smooth-
ing brush will give you better results. I» 06:21

You can also use the Push Modifier, set to a positive value, to make things thicker, for example to
fix poke-through in clothing.
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Bonus Side Info: Setting Up Custom Keyboard Shortcuts

I» Complete Video: Custom Shortcuts

Using keyboard shortcuts can save a lot of time when working with Daz Studio. Setting up your
own shortcuts allows you to use key combinations that are perfectly tailored to your workflow.

Use the Customize dialog to set up custom keyboard shortc uts. I» 00:28
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